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Quick Start Tutorial
Introduction
Welcome to Cadsoft Envisioneer, a quick and
easy modeling tool that helps you create
home plans smoothly and efficiently, with
the added flexibility of 3D viewing,
rendering and estimating.
You can use this all-in-one design system for:
• Floor plans
• Interior design
• Exterior design
• Landscaping
• Elevations and Sections
• 3D Navigation
• Working Drawings
• Animations
• 3D RealView™ Rendering
• Estimates and Quotes
Since most of the features in Envisioneer are
automated, it is very easy to learn and use.
You can complete most tasks with a few
clicks of the mouse. And with the built-in
power of Cadsoft’s advanced design
technology, you can count on fast, accurate,
professional-level drawings.

Introduction | 1

About this Guide
CONTENTS
This guide can be used with both Building
Essentials and Construction Suite.
It is designed to get you up and running as
quickly as possible. You’ll start off with a
brief tour of the interface. Next, the step-bystep tutorial shows you how to create a 3D
model as well as landscaping, 3D viewing,
rendering, quantity reports, construction
documents, and more. For more information
on each of the tools used, see the Program
Help on the Help menu.

TUTORIAL AIDS
To clarify point and element selections, the
tutorial includes diagrams and screen
captures throughout. In diagrams containing
multiple selection points, the points have
been enhanced to aid in selection. For
example,
Indicates the first point to be
P1
selected.
Indicates the second point to be
x
P2
selected.

2 | Envisioneer Quick Start Tutorial

System Requirements
Your user account should be set to Computer
Administrator (not Limited) to install the
program. Prior to installing, make sure your
system meets the requirements listed below.

FOR MICROSOFT WINDOWS
• Microsoft® Windows® 10, 8, 7, or Vista
• 64-bit operating system (32-bit also
available)
• 2.0 GHz or faster processor
• 6 GB RAM (4 GB mininum)*
• 10 GB minimum free hard disk space
• DVD-ROM drive or Internet connection
for install
• 1024 x 768 display
• 2 GB dedicated video card
(1 GB minimum)*
• Windows-compatible mouse
• An Internet browser to view the online
help
• Internet connection for online features**

VR SYSTEM REQUIREMENTS
HTC Vive
• Graphics Card: GeForce GTX 970 or
AMD Radeon R9 290 or better
• CPU: Intel Core i5 4590 or AMD FX 8350
or greater
• RAM: 4GB or more
• Video port: HDMI 1.4, DisplayPort 1.2,
or better
• USB port: 1 USB 2.0 or faster port
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• Windows 7 SP1 or newer
For current recommendations and
performance testing tools, go to http://
www.htcvive.com/us/product-optimized/.
Oculus Rift
• Graphics Card: GeForce GTX 970 or
AMD Radeon R9 290 or better
• CPU: Intel Core i5 4590 or greater
• RAM: 8GB or more
• Video port: HDMI 1.3
• USB port: 2 USB 3.0 ports
• Windows 7 SP1 or newer
For current system requirements and a
compatibility testing tool, go to https://
support.oculus.com/1633938460220125/.
*Additional system and video memory will
improve speed and 3D RealView™
rendering capabilities.
**User is responsible for all Internet access
fees and phone charges.
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FOR APPLE MACINTOSH
Boot Camp Option (recommended)
• Boot Camp
• Mac Book Pro or Mac Pro running
Leopard OS X or newer with Microsoft®
Windows® 10, 8, 7, or Vista (SP2)
running on Boot Camp
• Same system requirements as Windows
Virtual Machine Option
• VMware Fusion or Parallels (separate
purchase of either required)
• Minimum system requirements for
Fusion or Parallels
• Minimum requirements for the virtual
machine (i.e. Windows) will be exactly
the same as the Boot Camp Option
requirements above
Note: Of the Virtual Machine options, Fusion

is recommended by Cadsoft as it provides
better rendering performance, however both
options will experience a performance
decrease compared to Boot Camp.

Installing the Program
Make sure you exit all other programs,
applications and screensavers before
installing.
To install from a downloaded file:
1

Double-click the installation file (*.exe)
that you downloaded.

2

Follow the on-screen instructions to
complete the installation.
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To install from a DVD:
1

Begin at the Windows® desktop.

2

Insert the installation DVD into your
DVD-ROM drive. The InstallShield
Wizard screen appears and loads the
setup. If it doesn’t appear automatically,
see the instructions after step 3.

3

Follow the on-screen instructions to
complete the installation.

To run the DVD installation if it does not begin
automatically:
1

Make sure the installation DVD is in your
DVD-ROM drive.

2

At the Windows® desktop, click the Start
button, then select Run.

3

Type D:\setup.exe in the Open edit box.
The letter D represents your DVD-ROM
drive. If you are installing from a different
drive, substitute the correct letter for the
letter D.
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Technical Support
ONLINE SUPPORT 24/7
Before contacting Technical Support, check
out the Cadsoft web site, where you can find
a variety of FAQs, white sheets, and videos.
To view reference materials, go to
http://www.cadsoft.com/clients/reference.php.
You can also post questions on the Cadsoft
Forum 24 hours a day, 7 days a week. Go to
http://www.cadsoft.com/forum/.
All support options are available in the Client
Center at http://www.cadsoft.com/clients/.
To access the Client Center directly from
Envisioneer, select Help > Customer Care or
click

on the Help toolbar.

TECHNICAL SUPPORT
If you cannot find the answer you need from
the resources above, please contact Cadsoft’s
technical support team.
When you contact technical support, be
prepared to provide information about your
computer name and model, and the brand
name of the video card you are using. If
possible, sit at your computer with the
program running when you call.

CADSOFT CUSTOMER SUPPORT
Hours: Monday to Friday, 8:30 AM - 5:00 PM,
EST
Phone: 1-888-CADSOFT (223-7638)
Fax: (519) 823-8821
E-mail: support@cadsoft.com
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Starting the Program
Once you have installed the program, you
can start using it.
1

On your Windows desktop, click the Start
button.

2

Select All Programs > Cadsoft >
Envisioneer. Or, click on the program’s
shortcut on your desktop.

Activating the Program
When you start the program for the first time,
an Activation dialog appears.

This is a good time to activate the program. If
you would prefer to run a trial version at this
time, click
at the bottom of the
dialog.
During the 30-day trial period, you have full
access to all features of the program except
Print and Export. Once the trial period has
ended, you need to activate the program to
be able to run it.
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To activate the software:
1

In the Activation dialog, click

.

2

In the Software Activation dialogue, enter
your product Serial Number and then click
.

Starting a New Project
By default, a Startup screen appears every
time you start the program. This screen lets
you start new projects, and provides instant
access to saved projects that you’ve been
working on. It also contains links to various
resources to help you get started, and
displays the latest news from Cadsoft.
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1

On the Startup screen, select New to start
a new project.

2

In the New dialog, select the 1- New home
standard construction (ft & in) template,
then click Create.

A new, blank project is started for you.
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Getting to Know Envisioneer
Take a moment to familiarize yourself with
the Envisioneer interface.
Tabbed Toolbars

Catalog Panel

Navigator
Drawing Area

View Tabs

Zoom & Navigate
Toolbar

View Control
Toolbar

Status Bar

Commander

Drawing Aids

TOOLBAR TABS
In Model View, six tabs are located just
beneath the menu bar: Building, Interiors,
Landscape, Terrain, Analyze and Help. These
are actually toolbars displayed in tabbed
format. They provide you with instant access
to the tools you need, when you need them.
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BUILDING TOOLBAR
The Building toolbar contains the tools you
need to build a home or any architectural
structure. It includes tools such as Walls,
Doors, Windows, and Roofs.

INTERIORS TOOLBAR
The Interiors toolbar contains the tools you
need to furnish, decorate and equip the
interior of your home. It contains tools such
as Cabinets, Countertops, Appliances,
Furniture, Lighting and Plumbing Fixtures.

LANDSCAPE TOOLBAR
The Landscape toolbar contains all the tools
you need to create a complete landscape plan
for the exterior of your home. Tools include
Plants, Fences/Gates, Decks, and Irrigation.

TERRAIN TOOLBAR
The Terrain toolbar contains tools that you
can use to recreate the topography of your
building site, which is especially important in
3D views. Use the Import Site Data tool to
import spot level points from a site recorder
file and create an accurate triangulated mesh,
or shape the existing terrain using tools such
as Hills/Valleys, Slopes and Plateaus. Add
hardscaping elements such as Paths, Pads
and Retaining Walls. Show the extents of the
property with the Site Boundary tool.

ANALYZE TOOLBAR
The Analyze toolbar provides instant access
to a variety of tools that help you estimate or
calculate information. You can view a project
estimate, schedules (door, window and
member), as well as area and perimeter
calculations for different levels, areas or
rooms in your model. You can also generate
a customizable quote, and output your
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model to Autodesk® Green Building
Studio® and perform an energy analysis.

HELP TOOLBAR
The Help toolbar contains instant links to the
Program Help, Glossary of Terms, the
Cadsoft web site, and our Customer Care
site. You can also control the display of the
Tutor, which pops up when you use program
tools, and the Startup screen that you see
when the program is started.

VIEW CONTROL TOOLBAR
The View Control toolbar contains several
essential view-related tools.

The toolbar’s building location drop box
displays the current building location, which
is important when inserting elements in your
drawing. The toolbar also lets you quickly
switch between 2D view and 3D view, and
view and create elevations and sections.
A display mode button lets you choose the
current display type for the view (wireframe,
hidden line, patterned, etc.). The toolbar also
provides instant access to the View Manager,
where you can create new view windows if
you want.

ZOOM AND NAVIGATE TOOLBAR
Zoom tools on the Zoom and Navigate
toolbar include Zoom In, Zoom Out, Zoom
Realtime, Zoom Window, Zoom Previous,
and Pan. The navigation features on the
toolbar (Walk Around, Fly Around, Look
Around, Reset Camera) are only active when
you are in a 3D view. These tools let you
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change the view in real time using your
mouse.

NAVIGATOR
The most common viewing and navigation
tools can also be found on the onscreen
Navigator, which is kind of like a video game
controller. It lets you switch between 2D and
3D, zoom and pan, and navigate in 3D, all
from a simple control panel displayed on the
screen. Motion is controlled by clicking and
dragging the central trackball.

COMMANDER
The Commander lets you enter precise
values when inserting or editing elements.
Initially the Commander will look grayed out
because it is inactive. It will become active
when you insert or edit elements.

VIEW TABS
By default, each project has a number of view
tabs displayed below the drawing area. Tabs
vary depending on the product you have.
The Model view window is where you build
and edit your 3D model. If you are using
Construction Suite, there are some numbered
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view tabs beside the Model view tab, such as
1 Floor Plan and 2 Elevations. These are
Worksheet View windows, where you can
create your construction documents.
View tabs help you easily switch between
view windows. If you create new view
windows, the tab display updates
automatically. You can edit the name of view
tabs and other properties.

Note: If you are using Building Essentials, your

project has only one view window by default
(Model).

MODEL VIEW VS. WORKSHEET VIEW
When you open a new project, the Model
view window is displayed. This is where you
build, edit and view your 3D model. If you
are using Construction Suite, you have access
to a 2D drafting mode called Worksheet
View. This mode contains a number of
different drafting tools that help you create
professional-looking working drawings.
Worksheet View is accessed by selecting the
view tabs beside the Model view tab, or by
opening Worksheet View windows from the
View Manager.
Note: Worksheet View is not available in
Building Essentials.

GRID AND GRID SNAP
By default a grid is displayed in the drawing
area. This set of vertical and horizontal lines
is simply an on-screen visual aid that helps
you orient objects to one another. The
distance between grid lines is 4 feet. The grid
can be turned off if desired, and you can
control the grid spacing and appearance in
your program settings.
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By default the Grid Snap is also turned on.
This feature snaps your pointer to an
invisible grid when inserting elements. The
default Grid Snap spacing is 1 inch. You can
control the spacing of the snap grid as well as
turn the Grid Snap off if you want to. You can
also match the snap grid to the visible
drawing grid by editing your program
settings.

AUTO SCROLL
If you are drawing an element such as a wall
and need to scroll the drawing area to be able
to finish drawing the element, simply press
and hold the CTRL key when your cursor is
near the edge of the drawing area. This
activates the Auto Scroll feature and scrolls
the drawing area in the direction in which
you move your mouse, allowing
uninterrupted drawing.

16 | Envisioneer Quick Start Tutorial

CATALOG PANEL
The catalog panel displays the elements
contained in the program’s Master Catalog,
or whatever catalog is currently open. This is
where you select elements to insert into your
drawing.

Getting to Know Envisioneer | 17

STATUS BAR
The Status bar is located at the bottom of the
screen. It displays helpful prompts while you
are working on your design project. For
example, if you are inserting a wall, it may
display “Pick first insertion point”. The
Status bar also includes a selection of
drawing aid buttons such as ORTHO and
OBJSNAP.
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Setting Up a Project
Once you’ve familiarized yourself with the
Envisioneer environment, you’re ready to
start your first project. Before you begin,
make sure you have a new, blank project
open (File > New).

BUILDING LOCATIONS
When you insert an element in your drawing,
it is inserted on the current building location.
It is important to define your building
locations before inserting elements.
1

Select Settings > Building Locations.

2

Note the settings in the Building Locations
dialog. You can edit the settings for the
existing locations, as well as create new
locations. When you define building
locations, you are basically doing two
things:
• setting the wall height for each floor
(level) in your model
• specifying where each floor is
positioned relative to grade or another
building location

3

Click OK to accept the default settings.
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UNIT OF MEASURE
Before you start drawing you need to make
sure you’re using the correct unit of measure
for your project, and select a level of
precision for your measurements.
1

Select Settings > Program Settings.

2

In the Program Settings dialog, select
Units of Measure in the left pane.

3

Make sure the Imperial radio button is
selected, and that Feet-Inches is selected
in the Units drop box.

4

Click the Precision drop box below the
Units drop box, and select the full feet and
inches option (#’-#”). This is a good setting
for this tutorial.

GRID SNAP
Let’s define a new grid snap spacing.
1

In the Program Settings dialog, select
Drawing Aids in the left pane.

2

Make sure that the Grid Snap (F4) check
box is enabled, as well as the Custom
Spacing radio button below that.

3

Highlight the value in the X edit box and
then type 12. Do the same in the Y edit
box. This defines a grid snap spacing of
12” (1’-0”).

4

Click OK. You are ready to draw!
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Drawing Walls
EXTERIOR WALLS
Now you’re ready to start drawing. We’re
going to create a simple exterior wall layout
that looks like this:

1

Look at the View Control toolbar and
make sure the current location is the
Ground Floor.

Location

2

Make sure the Ortho is enabled on the
status bar below the drawing area. This
will constrain your walls to 90-degree
angles.

3

Select Insert > Walls > Walls, or click
the Walls button on the Building
toolbar.
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If the Tutor window pops up, enable the
Don’t show the Tutor again check box at
the bottom of the window, then close the
window. This will keep the Tutor off
while you are completing the tutorial
(recommended). The Tutor is a
context-sensitive help aid that pops up
when you select most tools. You can turn
it back on again later by selecting Help >
Tutor.

Note

4

In the catalog panel on the right side of the
screen, select the 2 x 6 Brick Wall in the
Masonry Veneer folder.
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5

Move your pointer into the drawing area,
then click a point near the lower left
quadrant of the drawing area.

Start Point

6

Without dragging, move your pointer to
the right, and watch the on-screen
dimensions as you stretch the wall. When
the dimension reads 25’, click to select the
wall’s end point.

7

Move your pointer upward. When the
dimension reads 10’, click to select the
wall’s end point.
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8

Start moving your pointer to the right.
This time, type 20’ and press Enter,
making sure that you include the feet
symbol (‘) after the 20. To type the feet
symbol, hit the quotation mark key on
your keyboard.

If you do not include the feet symbol
when typing a value, the value will be
taken as inches.

This illustrates another method of
drawing walls where you can type
precise values. As you type the value, it
appears in the Distance edit box of the
Commander, and the angle appears in
the Direction edit box.
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9

Start moving your pointer upward. Type
20’ and press Enter.

10 Move your pointer to the left. Type 45’

and press Enter.
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11 Hover your cursor over the original start

point.

When you see the intersection snap
icon at this point, click to finish the
wall layout.

12 Right-click and select Finish.

Note

Because we created a closed wall layout
using a wall type with composite
properties, the walls automatically
become composite walls. A composite wall
is a structural wall and veneer wall put
together, with an air space in between.

13 Select File > Save.
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14 In the Save dialog, type Quick Start
Tutorial in the File name edit box, then click
Save.

Tip

If you make a mistake or change your mind
about something, simply select Edit > Undo,
or press CTRL + Z. You can undo until the
last time you saved. To cancel out of a task or
dialog, just press the ESC key on your
keyboard.

EDITING WALL DIMENSIONS
1

Click on the bottom wall. Notice that the
exterior dimension on this wall is not 25’,
which is the value we used when drawing
the wall. That is because walls are drawn
on center when you use the Walls tool.

2

Click on the bottom exterior dimension
value.

3

In the Edit Dimension dialog, type 25’,
then make sure that the lefthand arrow is
selected so that the left end of the wall
adjusts instead of the right end. Press
ENTER or click OK.
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The wall layout adjusts automatically so
that the bottom wall measures exactly 25’
on the exterior face.

4

Press ESC on your keyboard to hide the
dimensions. Now let’s look at another
way of editing the dimensions of your
wall layout.

5

Click on the top exterior wall. Notice that
the dimension on the right side of the
model is not 20’.

6

Position your pointer over the top wall’s
center blue grip, then click and drag the
wall downward.

7

When the dimension on the right side of
the model is closer to 20’, release your
mouse button. The wall layout is adjusted
again.
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QUICK TIP: DRAWING WALLS ON A
BASELINE
(For reference only)

When you draw walls with the Walls tool, the
walls are drawn on center. You can use the
Walls by Baseline tool to draw walls along a
different baseline. For example, you could
offset them from the outer veneer line.
Use this tool when you know precisely what
you want your finished dimensions to be.
To draw walls on a baseline:
1

Select Insert > Walls > Walls by Baseline,
or click the down arrow next to the Walls
button on the Building toolbar and select
Walls by Baseline.

2

Draw the outline of your exterior wall
layout, then right-click and select Finish.
This is the baseline you will offset the wall
thickness from.

3

Once you’ve drawn the outline the Walls
by Baseline dialog pops up, and you can
define your offset.
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INTERIOR WALLS
1

Before we continue, let’s maximize the
view. Select View > Zoom and Navigate >
Zoom Window.

2

Referring to the following figure, click
and hold down your mouse button above
the top left corner of the model (P1), then
drag diagonally to the bottom right corner
of the model (P2) to form a selection
window around the model. Release your
mouse button to perform the zoom.
(Click and hold)

Dr

3

ag

Turn the Grid Snap off by clicking the
GRIDSNAP button on the status bar.
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4

Now let’s continue with the interior walls.
We’re going to draw four of them.

5

In the catalog, double-click the Interior
Framed Partitions folder, then in that
folder double-click the Wood Framed

folder. In the Wood Framed folder select
the 2 x 4 Interior Wall.

6

Referring to the diagram below, hover
your cursor over the corner marked A1.
When you see a small black square pop
up, which is a snap point, click to select
that point. Then, click inside the top wall
at point A2 to create Wall A.

X
A2

A1
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7

To insert Wall B, we’re going to enter a
precise offset. Right-click in the drawing
area and select Enter insertion offset.

8

Type 14’, then press ENTER or click OK.

9

Referring to the diagram, position your
cursor slightly below point B1. A 14'-0”
dimension appears.

B1
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10 Click to select the wall’s start point, then

start moving your pointer to the right.

11 Type 14’ and press Enter to create a

14-foot wall.

12 Right-click and select Repeat. This lets

you start a new wall elsewhere instead of
continuing from the current one.

13 Referring the diagram, select a point
roughly where point C1 is located.

C1
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14 Start moving your pointer to the right,
then type 10’ and press Enter to create
Wall C.
15 Continuing from the end of Wall C, click in
the lower exterior wall to create Wall D.
16 Right-click and select Finish.
17 Click on the vertical wall above Wall C,

then click on its dimension.

18 In the Edit Dimension dialog, change the
dimension to 8’ and make sure that the

down arrow is selected. We want to make
sure that the lower endpoint adjusts and
not the top endpoint.

19 Click OK. The length of the wall is now

8’-0” exactly.

20 Press ESC to deselect everything. Your

walls are complete.

21 Save the drawing.
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Quick Tip: Adding a Level
(For reference only)

There are three ways to add another level to
your model.
Method 1: Floor/Foundation Wizard
If you already have one level drawn, you can
use the Floor & Foundation Builder Wizard
to automatically create a foundation level or
new story. Select Insert > Design Wizards >
Floor & Foundation Builder, then simply follow
the screens to build your new level.
Method 2: Duplicate to Locations

Another quick way of creating a new level is
to duplicate walls from an existing level. To
do this, simply select the walls that you want
to copy, and then right-click and select
Duplicate to Locations.
In the Duplicate to Locations dialog, select the
Second Floor location, or whatever location
you are copying to. The walls are then copied
to the selected location. To continue working
on the new level, select the appropriate
building location from the location drop box
on the View Control toolbar.
Method 3: Draw Walls

Alternatively you can select a new building
location from the location drop box, then
select the Walls tool and start drawing.

Conveniently, the walls on the ground floor
are visible (but dimmed) so that you can trace
over them or use them as a visual reference
when drawing your second floor walls.
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Inserting Doors
You can insert a variety of doors with
point-and-click simplicity. Because doors are
intelligent elements, they fit themselves into
walls and become part of them
automatically. However, you can edit doors
separately from the walls that contain them.
We will insert 3 doors in our design.
1

Select Insert > Doors, or select the
Building toolbar tab and click the
Doors button.

2

In the catalog, open the Entry 2x6 Wall
folder, then open the w/Single Sidelite
sub-folder. Select the 32" Solid Wood Door
w/ Sidelite.

3

Right-click and select Center on wall.

4

Position the door in the wall where shown
in the figure below. While you are
positioning the door, you may need to
pull to the left slightly to get the door to
swing to the inside of the model. Notice
that the door is automatically centered in
the wall for you.

5

Click to insert the door.
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Note that door marks have been hidden
in the figures to improve clarity. You can
turn off element marks using your View
Filter.
6

In the catalog, open the French Doors
folder and then the Double Door
sub-folder. Select the 60” Double French
Door.

7

Referring to the figure below, position the
door in the top exterior wall where
shown. Dimensions appear on either side
of the door. When the right-hand
dimension reads approximately 2’-0”,
click to insert the door.

8

In the catalog, open the Hinged folder and
select the 30” Hinged Door - 6 panel.

9

In the drawing area, right-click and select
Enter insertion offset.

10 In the Enter insertion offset dialog, type 4
and then press Enter or click OK.
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11 Position the door in the wall where shown

in the figure below. It snaps into place
exactly 4” from the end of the wall. Click
to insert the door.

12 Right-click and select Finish.

FLIPPING DOOR SWINGS
The Flip Swing command lets you instantly
flip a door’s hinge side. Let’s do this now.

Tip

1

Click on the front door.

2

Right-click in the drawing area and select
Flip Swing. The swing is flipped.

If you need to flip a door around so that its
swing is on the other side of the wall, use the
Flip Opening tool on the right-click menu.
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MOVING A DOOR
To move a door you can simply click and
drag it within the wall, or edit the on-screen
dimensions around it. Let’s move the front
door.
1

Click on the front entry door to select it.
Dimensions appear around the door.

2

Click on the top right dimension
indicated in the figure below.

3

In the Edit Dimension dialog, type 2’10 and
press Enter or click OK. The door is
moved.

4

Press ESC or click in blank space to
de-select the door, then save the drawing.
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Inserting Windows
We’re going to insert six windows in our
model.

W1

1

Select Insert > Windows, or click the
Windows button on the Building
toolbar.

2

In the catalog, open the Double Casement
folder, then select the
4'-9" X 4' Double Casement Window.

3

In the drawing area, right-click and select
Center on Wall.

4

Position the first window (W1) where
indicated above. For this exercise, pull
slightly towards the inside of the model
when positioning each window so that
the window is inside the stud wall.
Stud

Veneer

Correct
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Incorrect

If necessary you can use the Flip Opening
tool on a window’s right-click menu to
flip the window around after you have
inserted it.

Tip
5

With the Center on Wall option still active,
insert the remaining windows.
W6

W4

W2

W5

W3

6

Right-click and select Finish.

7

Save the drawing.

Inserting Openings
An opening is simply a cutout in a wall, or a
pass-through. You insert openings in the
same way that you insert doors and
windows.
Let’s insert an opening now.
1

Select Insert > Openings, or click the
Openings button on the Building
toolbar.

2

In the catalog, open the Arched
(Doorways) folder, then select the
3’ Arched top Doorway.
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3

Position the opening where indicated
below, then click to insert it.

4

Right-click and select Finish.

5

Save the drawing.

Viewing in 3D
Let’s take a look at what we’ve done so far in
3D. There are various tools available for
viewing in 3D, including 3D QuickView and
3D Camera.

3D QUICKVIEW
The 3D QuickView tool lets you choose a
preset viewing angle for quick 3D viewing.
1

Select View > 3D QuickView, or click
the 3D QuickView button on the
View Control toolbar.
The 3D QuickView button is also
available on the Navigator controller.
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2

In the 3D Quick View dialog or on the
Navigator’s control pad, click the lower
right arrow.

OR

Click Here

Click Here

The model is displayed in 3D from a
Southeast viewpoint.
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3D CAMERA
The 3D Camera tool displays a 3D
perspective view of your model which you
can adjust by controlling the view’s camera.
Interactive camera settings are displayed in
the panel on the right side of the screen while
the camera view is active.
1

Select View > 3D Cameras > 3D
Perspective, or click the 3D
Cameras button on the View
Control toolbar and select 3D
Perspective.
The 3D Camera button is also available
on the Navigator.

In a 3D Perspective view, the scale of an
element decreases according to its distance
from the viewer, creating a more realistic
view.
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Navigating in 3D
Not only can you view in 3D, but you can
also move around in 3D using a variety of
realtime navigation tools.
Navigation tools are available on the View
menu and Zoom & Navigate toolbar, but you
may prefer to the use the onscreen Navigator
instead. The choice is yours.

WALKING AROUND
The Walk Around tool lets you walk
forward, backward, left or right while in a 3D
camera view. You can even walk inside the
model! Let’s walk around and take a look at
the model now.
1

Make sure you are still in the 3D
Perspective camera view.

2

Select View > Zoom and Navigate >
Walk Around, or click the Walk
Around button on the Zoom and
Navigate toolbar.
If you prefer to control your navigation
with the Navigator, click the Walk button
on the Navigator.

3

Click and hold down your mouse button,
then drag to walk around. If you used the
menu or toolbar to activate the Walk tool,
click and drag in the drawing area. If you
activated the Walk tool on the Navigator,
click and drag the Navigator‘s central
trackball.
• To walk forward, drag upward.
• To walk backward, drag downward.
• To walk left or right, drag left or right.
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FLYING AROUND
The Fly Around tool revolves the camera
around the target, which by default is at the
center of the model. This creates a spinning
effect.
1

Select View > Zoom and Navigate >
Fly Around, or click the Fly Around
button on the Zoom and Navigate
toolbar, or on the Navigator.

2

Click and hold down your mouse button,
then drag to fly around.

LOOKING AROUND
In a 3D camera view, the Look Around tool
revolves the target around the camera.
1

Select View > Zoom and Navigate >
Look Around, or click the Look
Around button on the Zoom and
Navigate toolbar, or on the Navigator.

2

Click and hold down your mouse button,
then drag to look around.

RESETTING THE CAMERA
If you have moved the camera or lost your
orientation in your 3D view, you can use the
Reset Camera tool to move the camera back
to the position it was in before you started
navigating around.
1

To reset the camera, select View >

Zoom and Navigate > Reset Camera,
or click the Reset Camera button on
the Zoom and Navigate toolbar.
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Switching Back to 2D Plan View
When you are in a 3D view or elevation view,
you can switch back to 2D plan view at any
time using the 2D Plan tool. Let’s do this now
using one of four available methods.
• Click the 2D Plan button on the
View Control toolbar. Or,
• Click the 2D Plan button on the
Navigator. Or,
• Select View > 2D Plan. Or,
• Right-click in the drawing area and
select 2D Plan.

Customizing Floors
By default, a floor is inserted automatically
when you create a closed wall layout.
Initially the floor spans the entire model and
then splits into individual floors as you create
rooms inside the model.
By default, the floor type inserted is a
wood-framed floor with hardwood flooring
applied. You can customize floors in your
model in many ways.
We are going to change the floor in the
bathroom to a tiled floor.

2D DESIGNER’S VIEW
Floors are not visible or selectable in 2D
wireframe view because the floor edge lines
can interfere with the display of the wall
lines. You can use the 2D Designer's Plan tool
to quickly display a rendered version of the
2D plan. In this view you can see and select
floors.
1

Select View > 2D Designer's Plan, or
click the 2D Designer's Plan button
on the View Control toolbar.
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USING THE MATERIALS PAINTBRUSH
Now let’s change the hardwood flooring in
the bathroom to tiled flooring. We can do this
quickly with the Materials Paintbrush.
1

With the 2D Designer’s View still
active, select Edit > Materials
Paintbrush, or click the Materials
Paintbrush button on any tabbed toolbar.
The panel on the right side of the screen
displays the materials library.

2

In the materials library, scroll down in the
Groups pane and select the Tile - Generic
group.

3

In the Materials pane, select a tile that
you’d like to use in the bathroom.

4

Click inside the smallest room. The tile is
applied to the floor.

5

Right-click and select Finish.

Inserting a Structural Floor
A structural floor is needed to support the
flooring surface.
1

Return to standard 2D plan view.
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2

3

Select Insert > Structural Floor >
Structural Floor by Perimeter, or click
the Structural Floor button on the
Building toolbar and select Structural
Floor by Perimeter.
In the catalog, select the 2x10 Floor System

w/ 3/4” OSB.

4

Click inside the model. A framed floor
with OSB sheathing is inserted
throughout the model. Notice that the
joists on the left side of the model span a
significant distance, and need to be
broken into shorter lengths.

5

To make the structural floor easy to
select, we’re going to hide the walls
temporarily. Select View > View
Filters > View Filter or click the View Filter
button on the View Control toolbar.

6

In the View Filter dialog, click the eye icon
next to the Walls item. This closes the eye,
indicating that walls will be hidden. You
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may also want to turn off Tags/Marks.
Click OK.

Click the eye
7

Hover your cursor over the outer edge of
the floor and use the tooltip to confirm
that you are selecting the structural floor
and not the hardwood floor. Click on the
floor edge to select the floor, then rightclick and select Structural Floor > Insert
Bearing Line.

8

Select two points (P1 and P2) to create a
bearing line across the left half of the
model.

P1
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P2

The joists are broken and overlapped
along the bearing line.
9

Select View > View Filters > View Filter,
then click the eye icon next to the Walls
item to turn the walls back on. Also
expand the Floors item and hide the
Structural Floor components. Click OK.

Inserting Ceilings
Let's insert a ceiling in each room of our
model using the Ceiling by Room tool.
1

Select Insert > Ceilings > Ceiling by
Room, or click the Ceilings button
on the Building toolbar and select
Ceiling by Room.

2

In the catalog, open the Unframed folder
and select the 1/2” Drywall Ceiling.

3

Click inside the left room. A ceiling is
inserted.

4

Insert a ceiling in each of the other two
rooms, then right-click and select Finish.

Inserting a Roof
Inserting a roof couldn’t be easier. All it takes
is one mouse click.
1

Select Insert > Roofs > Roof by
Perimeter, or click the Roofs button
on the Building toolbar.

2

In the catalog, select the 8/12 Slope Hip
Roof - Shingles.
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3

Click anywhere inside the model. The
roof is automatically inserted. Roof
surface edges are represented by a dashed
line.

Customizing a Roof
Once you have inserted a roof you can edit
the properties of each roof segment
individually to create a complex roof with
varying pitches, styles and plate heights.
For example, you can convert a hip end to a
gable end, edit the support height, edit the
overhang distance, edit the slope, and control
the appearance of fascias, soffits and gables.

CREATING GABLES
We are going to convert two of the roof’s hip
ends to gable ends by editing the properties
of selected roof edges.
1

Select View > 3D QuickView, or click
the 3D QuickView button on the
View Control toolbar.

2

In the 3D QuickView dialog, click the lower
left arrow.
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3

Click on the very front roof edge. A green
arrow projects from the plate line of this
roof edge. Red arrows project from all
other plate lines.

4

Click on the red arrow projecting from the
plate line on the right side of the model. It
will turn green. A green arrow indicates
that a particular roof edge is selected and
will receive changes you subsequently
make. Edges marked with a red arrow
will not be changed.

5

Right-click and select Properties.
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6

In the Roofs dialog, click on the button in
the Roof Shape area, which is currently set
to Hip.

7

In the Roof Shape dialog, click on the
Gable option.

8

Back in the Roofs dialog, select the
Support and Details tab.

9

In the Gable area, select Squared from the
Type drop box, then type 12 in the
Horizontal edit box.

10 Click OK. The selected roof edges are now

gables.
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11 Save the drawing.
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Viewing Elevations
You can view front, back and side elevations
of your model with a couple of mouse clicks.
There are four default elevations available.
You can modify the properties of these
elevations, or create new ones on the fly.
As you edit your model in other views,
elevation views update automatically.
Let’s view a front elevation of our model
now.
1

Select View > Elevations > Front
Elevation, or click the down arrow
next to the Elevations button on the
View Control toolbar and select Front
Elevation.

2

By default, elevations are displayed
in Hidden Line display mode. Select
View > Display Mode, or click the
down arrow next to the Display Mode
button on the View Control toolbar, then
select Patterned. This displays material
patterns such as shingles and brick.
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Filtering the View
In the next exercise we’re going to work on
the interior of the model, so let’s hide the roof
from view to make that easier.
1

Select View > 2D Plan or click the 2D
Plan button on the View Control
toolbar or the Navigator.

2

Select View > View Filters > View
Filter, or click the View Filter button
on the View Control toolbar.

3

In the View Filter dialog, click the eye icon
next to the Roofs item.

4

Click OK. The roof is hidden from view.

Creating a Kitchen
Using the Kitchen Builder Wizard you can
quickly and easily create a kitchen layout that
includes upper and lower cabinets, a sink,
refrigerator and stove. There are a number of
layouts and styles to choose from. Once the
kitchen has been created you can move, edit
and delete elements as well as add more
elements if you want.
Let's create a kitchen now.
1

Select View > Zoom and Navigate > Zoom
Window, then click and drag a selection
window around the kitchen to zoom in
on the kitchen. The kitchen is the rear, left
room with the French door.

2

Select Insert > Design Wizards > Kitchen
Builder.

3

On the first Kitchen Builder Wizard
screen, click Next.
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4

On the General Kitchen Style screen, click
on the U-Shape style, then click Next.

5

On the General Kitchen Layout screen,
select the top right kitchen layout, then
click Next. Remember that you can move
and edit things later.

6

On the General Kitchen Theme screen,
select a theme for the kitchen, then click
Next. The selection you make determines
the materials used for the cupboards and
countertops.
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7

On the Kitchen Rotation screen, select the
top right rotation option, then click Next.

8

Click Finish. The kitchen configuration is
attached to your cursor.

9

Position the kitchen layout in the lower
left corner of the kitchen area. It will
automatically snap to the walls when you
get close to them. Click to anchor the
kitchen elements.
Dynamic dimensions are displayed to
show you the size of the layout.

10 Move your cursor toward the upper right

corner of the kitchen to stretch the layout.
Stretch it until the kitchen touches the rear
exterior wall and the lower run of cabinets
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meets up with the end of the horizontal
interior wall.

11 Once the dimensions are correct, click to

finish the insertion. The following dialog
appears:

12 Click Yes to finish the task. If you click No

you can reposition or resize the kitchen.

13 Save the drawing.
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Creating a New 3D Camera View
You can create a new 3D view by placing a
new camera in your 2D plan view. Once
you’ve inserted the camera, you specify the
camera angle and viewing field angle by
rotating and clicking your mouse. Let’s insert
a camera in the kitchen area so that we can
see what the kitchen looks like in 3D.
1

Select View > 3D Cameras > Place
New Camera, or click the 3D
Cameras button on the View
Control toolbar and select Place New
Camera.

2

Referring to the diagram below, click
where Point 1 is shown to insert the
camera, and then click where Point 2 is
shown to indicate the target of the view.
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3

The 3D view is created instantly. It should
look something like this:

Inserting Lighting
Light fixtures are one of the many different
elements that you can use to enhance your
design. You can insert a variety of light
fixtures and see lighting effects in real time as
you insert them.
Light fixtures add lighting to a 3D scene,
which is important if you plan to generate 3D
RealView renderings of your home's interior.
Since we’re in the kitchen, let’s insert a light
fixture there.
1

Select Insert > Interiors > Interior
Lighting, or select the Interiors
toolbar tab and click the Interior
Lighting button.

2

In the catalog panel, open the Ceiling
Lights > Ceiling Fixture folder and then
select Ceiling Fixture 1.

3

Position the light on the kitchen ceiling.
Notice how the room lights up as you
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bring the fixture into the room. Click to
insert the fixture on the ceiling.

4

Right-click and select Finish. The model is
now complete.

5

Save the drawing.

3D RealView™ Rendering
Rendering involves generating a
photo-realistic 3D view complete with
textures, light, reflection and shadows. You
can render any interior or exterior 3D camera
view with a simple mouse click.
Rendering consists of two steps: Radiosity
and Raytracing. Raytracing begins right after
the radiosity solution has been calculated,
making the whole process seamless.
When a rendering is complete, you can save
the image to a BMP, JPG or TGA file that can
be opened in most graphic editing
applications.
Let’s render the view of the kitchen.
1

With the 3D kitchen view displayed,
select View > Render 3D RealView.

2

In the 3D RealView dialog, click the Size
drop box and select 640 x 480.

3

Click the Start Render button.
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The radiosity solution is calculated, then
raytracing begins right after that. The
progress of the rendering is displayed in
the preview window in real time.

Tip

4

When the rendering is complete, click the
Save button in the Image area, then specify
a name and save location for the rendered
image in the Save As dialog.

5

Once the rendering is saved, click Close in
the 3D RealView dialog.

6

Save the project.

If you want to add more light to the scene,
add light fixtures to the room, then render
again.

Creating a Section
Section views are cross-sections through
your model. You create one by defining a cut
line and viewing distance. Let’s create one
now.
1

Return to 2D Plan view by selecting
View > 2D Plan or clicking the 2D
Plan button on the View Control
toolbar or the Navigator.

2

Select View > Zoom and Navigate >
Zoom Realtime, or click the Zoom
Realtime button on the Zoom and
Navigate toolbar.

3

Position your cursor in the drawing area.
Click and hold your left mouse button,
then start dragging downward to start
zooming out. When the entire model is
visible, release your mouse button.

4

Select View > View Filters > View
Filter, or click the View Filter button
on the View Control toolbar.
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5

In the View Filter dialog, click the eye icon
next to the Roofs item to turn the roof
back on.
Note that the eye will be only half open.
This is because the Roofs item has
framing associated with it, but the
framing is locked in a hidden state. The
half eye indicates that some of an
element’s components are visible, and
others are hidden. Click OK.

6

Select View > Sections > Create New
Section, or click the Sections button
on the View Control toolbar and
select Create New Section.

7

Referring to the following figure, select a
point outside the front of the model (P1).

.P2

P3

.

.P1
8

Select a point outside the rear of the
model (P2). The cut line is defined.

9

Select a point outside of the left exterior
wall (P3). This defines the viewing
direction and distance.
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The section is generated automatically.

We will work with the section in a later
exercise.

Landscaping
Envisioneer offers a wide variety of
landscaping tools to help you create a
complete landscape plan and design all of
your outdoor living areas. These include
decks, fences, garden beds, edging, plants,
furniture and lighting.

INSERTING TREES
Let’s insert a tree in the front yard.
1

Return to 2D Plan view.

2

Select Insert > Landscape > Plants, or
select the Landscape toolbar tab and
click the Plants button.

3

In the catalog, open the Deciduous Trees
folder and select Maple.

66 | Envisioneer Quick Start Tutorial

4

Insert the tree where shown in the figure
below.

5

Right-click and select Finish.

Adding Dimensions
Now we’re ready to start annotating the
drawing. Although you’ll probably want to
add things like text and dimensions when
creating your construction documents in
Worksheet View, there are a few powerful
dimension tools that are available only in
Model View.
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FILTERING THE VIEW
In the next exercise we’re going to add
dimensions to our plan. To optimize the view
for that exercise, let’s hide the roof, terrain
and tree from view.
1

Select View > View Filters > View
Filter, or click the View Filter button
on the View Control toolbar.

2

In the View Filter dialog, click the eye icon
next to the Roofs item to turn the roof off.

3

Now select the Elements on Terrain tab.

4

In the Display area, click None.

5

Click OK.

AUTO EXTERIOR DIMENSIONS
Let’s add automatic exterior dimensions to
the model now.
1

Select Tools > Dimensions > Auto Exterior
Dimensions. Dimensions automatically
appear around the exterior of the model.
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ROOM DIMENSIONS
Room dimensions are commonplace on floor
plans, and Envisioneer calculates and inserts
them automatically. All you need to do is
pick three points to define a room’s length,
width and rotation.
1

Use the Zoom Window tool to zoom in on
the bathroom.

2

Select Tools > Dimensions > Room
Dimensions.

3

Referring to the following figure, select
the inside bottom left corner (P1) of the
bathroom.

P3

P1

P2

4

Select the room’s inside bottom right
corner (P2). This defines the width of the
room.

5

Select the room’s inside top right corner
(P3). This defines the length of the room.
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The resulting dimensions are displayed in
the Room Dimensions dialog.

6

Click OK. The room dimensions are
automatically inserted in the center of the
room.

7

Insert room dimensions in the two rooms
on the left side of the model. When you
are finished, right-click and select Finish.
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Adding Text
Next we’ll use the Text tool to label the rooms
in the design.
1

Select Tools > Text > Text.

2

In the Text dialog, click

3

In the Text Styles dialog select the Labels
text style and then click OK.

4

Back in the Text dialog, type Family Room
in the text editing window.

5

Enable the Multiple text insert check box at
the bottom of the dialog. This will return
you to the Text dialog after you have
inserted the text.

6

Click OK. The text is attached to your
cursor.

7

Insert the Family Room text in the room
below the kitchen.

8

In the Text dialog, make sure the Family
Room text is highlighted.

9

Double-click the Kitchen label in the list of
pre-defined labels. The Family Room text
is replaced with the Kitchen text in the
text editing window.

.
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You can save time by dragging a
pre-defined label from the list into the
text editing window, or by selecting the
label and clicking
below the list.

Tip

10 Click OK.
11 Insert the Kitchen text in the kitchen.
12 Insert the remaining labels as shown
below, then click Cancel in the Text dialog.

Editing Text
You can edit the style or content of text after
it has been inserted.
1

Click on the Family Room text to select it,
then right-click and select Properties. Or
simply double-click the text.

2

In the Text dialog, change the text to
Living Room, then click OK. The text
updates in the drawing automatically.

3

Save the drawing.
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Calculating Square Footage
You can use the Area/Perimeter tool to
instantly view the square footage and
perimeter measurements of your design.
1

Select Tools > Analyze > Area/
Perimeter, or select the Analyze
toolbar tab and click the Area/
Perimeter button.

The dialog has two tabs: one for area
measurements, and one for perimeter
measurements. You can print the
calculations by clicking Print at the
bottom of the dialog.
2

Click OK.
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Viewing a Project Estimate
You’ve done all your modeling and design
work. Now let’s see how much the project
will cost.
1

Select Tools > Analyze > Generate
Project Estimate, or click the
Generate Project Estimate button on
the Analyze toolbar.
Your project estimate is displayed.

The project estimate, or bill of materials,
lists all of the materials used to create
your model. It lists information like the
quantity, unit price and total cost of each
material, as well as the total cost of the
project. You can control what
information is reported, how it is
reported, and specify custom material
pricing.
You can select a different report template
from the report drop box to generate a
different report file type. Some templates
generate files that can be opened in an
external estimating program.
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2

When you are finished viewing the
estimate you can click Exit to close the
dialog without saving the estimate, or
click Save and Close to save the estimate
and return to your drawing.

3

Save the project.
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Note

The following section applies to Construction Suite
only. If you are using Building Essentials, go to page
89.

Creating Construction Documents
Once you have created your model in Model
View you can switch to Worksheet View to
complete your working drawings.
Worksheet View is a quick and simple 2D
drafting environment where you can set up
drawing sheets, insert views of your model,
annotate your drawings with text,
dimensions and basic line objects, and add
construction details. A wide variety of CAD
editing tools are available to help you achieve
the exact result you want.
In this section of the tutorial we are going to
create documents containing the following:
• Floor plan
• Elevations
• Section
We’ll also learn how to edit, annotate and
customize documents.
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Worksheet View
When you are ready to start creating your
construction documents, you need to switch
to Worksheet View. Before switching it is a
good idea to make sure that your model is as
complete as possible and that any elements
that you want displayed in your construction
documents are turned on in Model View.
1

Select View > View Filters > View
Filter or click the View Filter button
on the View Control toolbar.

2

In the View Filter dialog, turn the roof back
on and click OK.

3

Just below the drawing area there are
several view tabs. We are currently on the
Model view tab. Select the 1 Floor Plan tab.
Select this tab
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You are now in Worksheet View.
Insert Toolbar

Object Properties

Crosshairs

Properties Toolbar

View Toolbar
Generic
Title Block

INSERT TOOLBAR
The Insert toolbar contains the tools needed
for setting up the main components of your
worksheet. Use the Define SmartView tool to
bring in a view of your model, such as a 2D
plan or elevation. Use the Import tools to
bring in outside CAD files in DWG or DXF
format, PDFs or image files such as JPGs and
BMPs. To save time you can use the Define
Block tool to capture a group of objects in a
block that can be saved and then inserted on
other worksheets.
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DRAW TOOLBAR
The Draw toolbar contains a number of
drafting tools: Line, Polyline, Circle, Ellipse,
Arc, Polygon, Rectangle, Polygon Hatch,
Revision Cloud, Boundary Hatch, Rigid
Insulation, Batt Insulation, Wood Section,
Masonry Section, Cut Line, and Roof Symbol.

MODIFY TOOLBAR
The Modify toolbar contains a wide variety
of tools for editing objects in your drawing:
Delete, Move, Rotate, Duplicate, Array,
Offset, Stretch, Scale, Mirror, Break, Extend,
Trim, Fillet, Join Polyline, and Explode.

TOOLS TOOLBAR
Use the Tools toolbar to insert Text, Leaders,
Dimensions, and Wall Panels. Use the
Measure tool to quickly determine the
distance between any two points.

PROPERTIES TOOLBAR
The Properties toolbar indicates the current
layer, and the color, line type and line weight
assigned to that layer. You can override layer
settings by making selections from the layer
setting drop boxes. The toolbar also provides
access to the Layer Properties dialog.

VIEW TOOLBAR
The View toolbar contains a complete set of
zoom and pan tools: Zoom In, Zoom Out,
Zoom Realtime, Zoom Window, Zoom
Previous, Zoom to Fit, and Pan.

DRAWING AREA
The drawing area contains a generic drawing
sheet border and title block that you can
delete or edit to suit your needs. You can
insert any pre-defined or custom title block,
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as well as various views of your model. From
there you can edit, detail and annotate your
drawing to create a detailed, accurate
construction document.

CROSSHAIRS, PICKBOX AND CURSOR
In Worksheet View you see crosshairs, which
are lines that represent the two coordinate
axes. At the center of the crosshairs is a
pickbox, a square used for selecting objects.
When you move your pointer outside the
drawing area you see a cursor, an arrow for
accessing menus and toolbars. The cursor can
also become a double-headed arrow when
resizing windows.

OBJECT PROPERTIES PANEL
The Object Properties panel displays the
properties of the currently selected object,
such as the layer it is assigned to. You can
edit properties by simply making different
selections in the panel.

Inserting a 2D Plan
Let’s create a floor plan drawing first. To do
that, we need to insert a 2D view of the model
onto our worksheet. We’ll just use the generic
drawing sheet border and title block for this
exercise.
1

With the Floor Plan view tab
current, select Insert > SmartViews >
Define SmartView, or click the Define
SmartView button on the Insert toolbar.
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2

On the 2D tab of the Insert View dialog,
make sure that the Location is set to
Ground Floor.

3

From the Scale drop box, select the
1/4” = 1’-0” scale. The scale is the ratio of
units on paper to real-world units. In this
case, that would mean that every foot of
the physical model is represented by 1/4
of an inch on paper.

4

In the Insertion area, select the Drawing
radio button. This option inserts a vector
image. Vector data provides useful
information about the geometry in a
drawing, such as endpoints, curves and
polygons. The Image option inserts a
raster image (bitmap) which can be
resized.
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5

Click the Zoom Out button at the
bottom of the dialog if necessary to
zoom out until the entire floor plan
(including exterior dimensions) is visible
inside the window. Anything that is not
visible in the preview window will not be
visible when the plan is inserted on the
worksheet.

View Filter

Zoom Out

6

For this particular view we want the
roof turned off, so click the View
Filter button at the bottom of the
dialog and then turn off the roof in the
View Filter dialog. Click OK to return to the
Insert View dialog. The roof is now turned
off in the preview window.

7

In the Insert View dialog, click Insert. The
ground floor plan view is attached to your
cursor.
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8

Position the plan in the center of the
drawing sheet, then click to insert it.

Inserting Elevations
There are four pre-defined worksheet views
available, and you can create more if you
want. Let’s switch to a different worksheet
and then insert our elevation views on that
sheet.
1

Below the drawing area, select the
2 Elevations view tab.
Select this tab

2

Select Insert > SmartViews > Define
SmartView. Or, click the Define
SmartView button on the Insert
toolbar.
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3

In the Insert View dialog, select the
Elevations tab.
Elevations tab

4

In the Datum Lines pane, set the Datum
Line Placement to Yes for Floor Level and
Wall Height. This will place datum lines

and measurements at the floor level and
top of wall.
5

Make sure that the entire elevation is
visible in the preview window.

6

Click Insert.

7

Insert the front elevation in the top left
corner of the drawing sheet.
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8

Use the Define SmartView tool
(Insert > SmartViews > Define SmartView)
to insert the remaining three elevations as
shown below.

Hatching an Elevation
You can use the Boundary Hatch tool to
apply patterns to areas of a drawing. Let’s
work with the front elevation and apply a
shingle pattern to the roof, and a brick
pattern to the walls.
1

Select View > Zoom Window, or click
the Zoom Window button on the
View Toolbar.

2

Click and drag a selection window
around the front elevation, then release
your mouse button. This zooms in on the
front elevation.

3

Select Draw > Boundary Hatch, or
select the Draw toolbar tab and click
the Boundary Hatch button.

4

In the Boundary Hatch dialog, select Roof
shingles from the Style drop box.
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5

Click the Select Boundaries button. This
takes you back out to your drawing.
Select Boundaries

6

Click anywhere inside the roof surface.
The roof boundary highlights green to
indicate that it has been selected.

7

Right-click and select Enter.

8

Back in the Boundary Hatch dialog, click
Preview to see what the hatching will look
like.

9

Press ESC or right-click and select Cancel
to return to the Boundary Hatch dialog.

10 Click OK to apply the hatching to the roof.

11 Select the Boundary Hatch tool again and

this time select Brick pattern.
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12 Click the Select Boundaries button, and

then click inside the wall in the elevation.

13 Right-click and select Enter.
14 In the Boundary Hatch dialog, click OK.

Tip

You can insert elevations that are
already hatched by setting the display
mode to Patterned in the Insert View
dialog when inserting the elevations onto
your worksheet. The patterns applied
depend on the material settings in each
element’s properties.

Inserting a Section
Now let’s switch to another worksheet and
insert the section we created earlier.
1

Below the drawing area, select the
3 Details view tab.

2

Select Insert > SmartViews > Define
SmartView.
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3

In the Insert View dialog, select the
Sections tab.
Sections tab

4

From the Scale drop box, select the
1/2” = 1’-0” scale, which is a common scale
for building sections.

5

Make sure that the entire section is visible
inside the preview window, then click
Insert.

6

Insert the section in the center of the sheet.

7

Save the project.
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Congratulations!

You have successfully completed the Quick
Start Tutorial. By completing the tutorial you
have learned the basics of:
• Model building
• Zooming and view control
• 3D viewing and navigation
• Elevations and sections
• Estimating
• Annotation
• Landscaping
• Creating construction documents
• 3D RealView™ rendering
With your new basic skill set you can start
creating your own designs in Envisioneer.

Resources
See and learn more about Envisioneer by
viewing our comprehensive library of
documents and videos.
To access resources:

• In Envisioneer, select Help > Customer
Care, and then click on Tutorials. Or,
• Open your Internet browser and go to
http://www.cadsoft.com/clients/
reference.php.
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