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Contents   About this GuideThe Envisioneer User’s Guide covers basic concepts and procedures for the following product-
s:ExpressPersonal ArchitectPro ArchitectBuilding EssentialsConstruction SuiteThe User's Guide provides a general overview
of all the features in Envisioneer. It does not cover every possible topic. However, you can find detailed information on just
about anything in the online help (press F1, or select Help > Program Help).Since the guide is designed for use with more
than one product, some topics may not apply to your particular product. In the case where a topic applies to a specific
product only, it will be clearly noted within the topic.Take a few minutes now to familiarize yourself with the guide’s con-
tent and layout so that you can find the information you need when you are working on your project.Uninstalling a Pre-
vious VersionIf you currently have an older version of Envisioneer installed on your system, it is recommended that you
uninstall your current version before installing the new version.Note that the uninstallation will not remove your Projects
folder. If, however, you have saved projects within the main Envisioneer program folder, make sure you move them out of
the program folder before uninstalling.To uninstall a previous version: At your Windows® desktop, select Start > Control
Panel. In the Control Panel window, under Programs, select Uninstall a program.In the Uninstall or change a program win-
dow, select the program to be deleted. Click the Uninstall button. When prompted, click Yes to remove the selected applic-
ation and all its features.To remove the entire program folder including all files related to catalogs, libraries and materials,
click Yes when prompted. Otherwise, if you want to keep existing catalogs and libraries on your system, click No. If you
have created custom catalogs, libraries or materials, it is recommended that you leave them on your system. The unin-
stallation begins. Follow any remaining instructions.Note: The Projects folder remains on your system even if you chose to
remove the entire program folder. By default, the Projects folder can be found in the following location:In Windows 10, 8,
7: C:\Users\*username*\Documents\Envisioneer\ProjectsInstalling the ProgramMake sure you exit all other programs,
applications and screensavers before installing. To install the program from a download file or install file provided on a
USB: To install from a downloaded file, double click the installation file that you downloaded. The setup begins loading. Fol-
low the on-screen instructions to complete the installation. Starting the ProgramYou can start your program by selecting
Start > All Programs > Cadsoft > Envisioneer, or by double-clicking the Envisioneer icon on your desktop.Activating the Pro-
gramThe Activation window appears when you start Envisioneer for the first time, and will keep appearing at startup until
you have activated the program. If you do not want to activate the program right away you can click the Run Trial button
to run a trial version of the software. During the 30-day trial period you have full access to all features of the program
except Print and Export. Once the trial period has ended, you need to activate the program to be able to run it. You can
activate the program at any time during the trial period.To activate the program:Click Activate at the bottom of the Activ-
ation dialog. If the Activation dialog is currently not open, select Help > Software Activation.In the Software Activation dia-
log, enter the software's Serial Number, then click Activate.If the activation is successful, the following dialog appears:Click
OK.Starting a New ProjectPersonal Architect | Pro Architect | Building Essentials | Construction SuiteEvery time you start
the program, the Startup screen appears. You can start a new project directly from this screen by clicking New in the Pro-
jects pane. When the program is running, you can also start a new project using the New tool on the File menu.By default,
the New dialog box is displayed when you select the New tool, allowing you to select a drawing template on which to base
your new project. Templates contain settings such as Building Location definitions, view window configurations, and pro-
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gram preferences such as units of measure and precision. The program ships with a variety of pre-defined templates for
your convenience. You can edit these templates to suit your needs, or create new ones.To start a new project from the Star-
tup screen:On the Startup screen, click New in the Projects pane.In the New dialog, select the template on which you want
to base your new project, then click Create. A new project is opened.To start a new project if the program is already run-
ning:Select File > New or click on the Standard toolbar. In the New dialog, select the template on which you want to base
your new project, then click Create. A new project is opened.If the Launch Wizard when Starting New Project option is
enabled in your program settings, the Wizard that is selected in your program settings (e.g. House Builder Wizard) launches
automatically when you start a new project. Tip: You can change your startup settings so that the New tool launches new
projects based on a specific template every time, or no template at all. Selecting either of these options prevents the New dia-
log box from appearing and starts new projects right away.Tip: You can create your own template by simply setting up a
drawing with the desired settings and saving it in your Templates folder. Starting New Projects from a Specific Tem-
platePersonal Architect | Pro Architect | Building Essentials | Construction SuiteBy default, every time you select the New
tool, the New dialog box appears, allowing you to select the template that you want to use for your new project. If you tend
to use the same template all the time, you can change your startup settings so that new projects are automatically based on
that specific template. This prevents the New dialog box from appearing and starts your new project right away when you
select the New tool.To start new projects from a specific template every time:Select Settings > Program Settings or click on
the Settings toolbar.On the General page, click the top drop box in the Startup area and select Use Specific Template.Click
next to the edit box that is below the Use Specific Template option. In the Open dialog, locate and select the template that
you want to use when starting new projects, then click Open. The template name is displayed in the edit box.Click OK.Tip:
You can create your own template by simply setting up a drawing with the desired settings and saving it in your Templates
folder. Starting New Projects Without Using TemplatesPersonal Architect | Pro Architect | Building Essentials | Con-
struction SuiteBy default, every time you select the New tool, the New dialog box appears, allowing you to select the tem-
plate that you want to use for your new project. If you do not want to use a template when starting new projects, you can
change your startup settings so that new projects have no pre-defined settings. This prevents the New dialog box from
appearing and starts your new project right away when you select the New tool. To start new projects without using tem-
plates:Select Settings > Program Settings or click on the Settings toolbar.On the General page, click the top drop box in the
Startup area and select Use No Template.Click OK.Enabling Template Selection at Project StartupPersonal Architect | Pro
Architect | Building Essentials | Construction SuiteIf you want to be able to select any template you want when starting a
new project, you must enable the Prompt for Template option in your startup settings. When you enable this option, the
New dialog box appears every time that you select the New tool, allowing you to select a template to use for your new pro-
ject.To enable template selection at project startup:Select Settings > Program Settings or click on the Settings toolbar.On the
General page, click the top drop box in the Startup area and select Prompt for Template.Click OK.Tip: If you use the same
template all the time, you can start new projects that are automatically based on that template. See Starting New Projects
from a Specific Template on page 1.Opening a Project from an Older VersionYou can open projects from any previous ver-
sion of Envisioneer in the new version. When you open an older project, you have the option of converting it to a current-
version project, or you can make a copy to work with, leaving the original intact. To open a project from an older version:If
the Startup screen is currently displayed, click Open Existing. If the Startup screen is not currently displayed, select File >
Open, or click on the Standard toolbar. In the Open dialog, select the project to open, then click Open.To make a copy of the
project and work with the copy instead of the original (recommended), enable the Convert a Copy radio button, and then
click Continue. In the Save As dialog, type a name for the copy that is different from the original, then click Save. The copy
is opened.To convert the project to the current version, select Convert the Original, and then click Continue. The project is
converted and opened. Note that when you convert a project, the original is overwritten and cannot be opened in older ver-
sions of the program.To cancel the task without converting or opening anything, select the Cancel option and then click
Continue.Viewing Sample ProjectsTo give you an idea of the things you can do with Envisioneer, you may want to view
some sample projects. These projects are located in the program’s Samples directory.To view sample projects:Select File >
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logs, enable the Suppress display of metric units check box. For example, 1200 mm would appear as simply 1200.To change
the level of precision for angle measurements, which are displayed in decimal degrees, make a selection from the Precision
drop box in the Angles area. The selection you make determines the number of decimal places used.Once you’ve set your
units of measure, click OK.Note: The units of measure selected in your Program Settings are used for drawing and creating
dimensions. They are not the units used for calculating and reporting material quantities in the project estimate. Each ele-
ment has a unit of measure setting on its Quantity property page that determines how the element is quantified and repor-
ted in the estimate. Suppressing Trailing Zeros in MeasurementsPersonal Architect | Pro Architect | Building Essentials |
Construction SuiteYou can specify that you want to suppress trailing zeros in measurements by editing your program set-
tings. For example, 12'-0" would be displayed as simply 12' in both onscreen and inserted dimensions. This setting applies to
both Metric and Imperial units of measure.To suppress trailing zeros in the current project:Select Settings > Document Set-
tings or click on the Settings toolbar.In the Document Settings dialog, click Units of Measure in the left column.Enable the
Suppress trailing zeros check box.Click OK.Suppressing Metric Units in DialogsPersonal Architect | Pro Architect | Building
Essentials | Construction SuiteIf you have chosen to work in Metric units, you can choose to suppress units for length/dis-
tance, volume, and area measurements shown in dialogs. For example, 1200 mm would appear as simply 1200.To suppress
units in the current project:Select Settings > Document Settings or click on the Settings toolbar.In the Document Settings dia-
log, click Units of Measure in the left column.With Metric Units selected, enable the Suppress display of metric units check
box.Click OK.Adjusting Your Display SettingsTo ensure proper performance you should set your screen resolution to at
least 1024 x 768 pixels. Consult the documentation for your Windows operating system for information on changing your
screen resolution.Videos and TutorialsGo to https://www.cadsoft.com/learning-center/support-learning to view an extensive
list of informative videos and tutorials that will help you familiarize yourself with the Envisioneer workspace and learn
about its features. To access the videos and tutorials from Envisioneer:Select Help > Customer Care or click on the Help
menu. On the Learning Center page, click Support. Tip: There are a number of "getting started" and support resources avail-
able on the Startup screen that appears when you start the program.Quick Start GuideThe Quick Start Guide is a short, step-
by-step tutorial that teaches you the basics of the program through hands-on exercises. It is a great way to get up and run-
ning with the software as quickly as possible.The Quick Start Guide can be found in the box or inside the DVD case if you
have purchased a boxed version. The Quick Start Guide is also available in PDF format, which can be read in Adobe® Read-
er®. Two versions are available: Imperial and Metric. The guide is also available in video format. To view a PDF of the
Quick Start Guide:Select Help > Quick Start Guide > Quick Start Guide (Imperial - PDF) or Quick Start Guide (Metric -
PDF).Click the down arrow next to on the Help toolbar and select either Quick Start Guide (Imperial - PDF) or Quick Start
Guide (Metric - PDF).Click the View the Quick Start Guide link on the Startup screen, then select the version that you would
like to view (Imperial or Metric).Online HelpThe comprehensive online help system includes information about every fea-
ture in Envisioneer. The system includes Index and Keyword Search features so that you can quickly find what you're look-
ing for. To access the online help file: Select Help > Program Help, or Press F1, or Click on the Standard toolbar or Help
toolbarContext-sensitive HelpContext-sensitive help is help for a specific dialog or element in your drawing. To get help for
a specific part of your drawing:Select the element you want help with.Right-click and select the Tool Help option for that ele-
ment (e.g. Walls Help). A list of topics related to the element is displayed — just click the topic you want to learn more
about. You can also access the Tool Help from the Edit > Modify Elements menu. To get help in a dialog:Click in the dialog.
A window is displayed that describes the content of the dialog.TutorThe Tutor is a context-sensitive help feature that dis-
plays "how-to" information about a tool when you select it. For example, if you select the Walls tool, the Tutor window dis-
plays a video and information on how to draw walls, handy tips and tricks, and links to other topics that may be of interest.
You can turn the Tutor on and off as needed. If the Tutor is currently displayed you can turn it off by enabling the Don't
show the Tutor again check box at the bottom of the Tutor window.To turn the Tutor on or off:Select Help > Tutor or click
on the Help toolbar.Glossary of TermsYou can instantly access a glossary of technical and construction terms from the Help
menu. To view the Glossary of Terms: Select Help > Glossary of Terms, or click on the Help toolbar.Technical Sup-
portOnline Support 24/7Before contacting Technical Support, check out the Cadsoft web site, where you can find a variety
of FAQs, white sheets, and videos. To access the Learning Center, visit https://www.cadsoft.com/learning-center/knowledge-
network/. You can also access the site directly by selecting Help > Customer Care in Envisioneer or clicking on the Help tool-
bar.You can also post questions on the Cadsoft Forum 24 hours a day, 7 days a week. Go to https://www.cad-
soft.com/community-posts/.Technical SupportIf you cannot find the answers you need in the Online Help or on the Cadsoft
Support site, please contact Cadsoft's technical support team. Please remember that technical support cannot answer specific
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About this Guide
The Envisioneer User’s Guide covers basic concepts and procedures for the following products:
l Express
l Personal Architect
l Pro Architect
l Building Essentials
l Construction Suite

The User's Guide provides a general overview of all the features in Envisioneer. It does not cover every possible
topic. However, you can find detailed information on just about anything in the online help (press F1, or select Help
> Program Help).
Since the guide is designed for use with more than one product, some topics may not apply to your particular
product. In the case where a topic applies to a specific product only, it will be clearly noted within the topic.

Take a few minutes now to familiarize yourself with the guide’s content and layout so that you can find the
information you need when you are working on your project.

Uninstalling a Previous Version
If you currently have an older version of Envisioneer installed on your system, it is recommended that you uninstall
your current version before installing the new version.

Note that the uninstallation will not remove your Projects folder. If, however, you have saved projects within the
main Envisioneer program folder, make sure you move them out of the program folder before uninstalling.
To uninstall a previous version:
1. At your Windows® desktop, select Start > Control Panel.
2. In the Control Panel window, under Programs, select Uninstall a program.
3. In the Uninstall or change a program window, select the program to be deleted.

4. Click the Uninstall button.
5. When prompted, click Yes to remove the selected application and all its features.
6. To remove the entire program folder including all files related to catalogs, libraries and materials, click Yes

when prompted. Otherwise, if you want to keep existing catalogs and libraries on your system, click No. If
you have created custom catalogs, libraries or materials, it is recommended that you leave them on your sys-
tem.

7. The uninstallation begins. Follow any remaining instructions.

Note: The Projects folder remains on your system even if you chose to remove the entire program folder. By default,
the Projects folder can be found in the following location:

xxx



Contents

In Windows 10, 8, 7: 

C:\Users\*username*\Documents\Envisioneer\Projects

Installing the Program
Make sure you exit all other programs, applications and screensavers before installing.
To install the program from a download file or install file provided on a USB:
1. To install from a downloaded file, double click the installation file that you downloaded. The setup begins

loading.

2. Follow the on-screen instructions to complete the installation.

Starting the Program
You can start your program by selecting Start > All Programs > Cadsoft > Envisioneer, or by double-clicking the
Envisioneer icon on your desktop.

Activating the Program
The Activation window appears when you start Envisioneer for the first time, and will keep appearing at startup
until you have activated the program.

If you do not want to activate the program right away you can click the Run Trial button to run a trial version of the
software. During the 30-day trial period you have full access to all features of the program except Print and Export. Once
the trial period has ended, you need to activate the program to be able to run it. You can activate the program at any time
during the trial period.
To activate the program:
1. Click Activate at the bottom of the Activation dialog. If the Activation dialog is currently not open, select

Help > Software Activation.
2. In the Software Activation dialog, enter the software's Serial Number, then click Activate.

If the activation is successful, the following dialog appears:
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3. Click OK.

Starting a New Project
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Every time you start the program, the Startup screen appears. You can start a new project directly from this screen
by clicking New in the Projects pane. When the program is running, you can also start a new project using the New
tool on the File menu.
By default, the New dialog box is displayed when you select the New tool, allowing you to select a drawing
template on which to base your new project. Templates contain settings such as Building Location definitions, view
window configurations, and program preferences such as units of measure and precision. The program ships with a
variety of pre-defined templates for your convenience. You can edit these templates to suit your needs, or create
new ones.
To start a new project from the Startup screen:
1. On the Startup screen, click New in the Projects pane.
2. In the New dialog, select the template on which you want to base your new project, then click Create. A

new project is opened.

To start a new project if the program is already running:

1. Select File > New or click on the Standard toolbar.

2. In the New dialog, select the template on which you want to base your new project, then click Create. A
new project is opened.

If the Launch Wizard when Starting New Project option is enabled in your program settings, the Wizard that is
selected in your program settings (e.g. House Builder Wizard) launches automatically when you start a new project.

Tip: You can change your startup settings so that the New tool launches new projects based on a specific template
every time, or no template at all. Selecting either of these options prevents the New dialog box from appearing
and starts new projects right away.

Tip: You can create your own template by simply setting up a drawing with the desired settings and saving it in
your Templates folder.

Starting New Projects from a Specific Template
Personal Architect | Pro Architect | Building Essentials | Construction Suite

By default, every time you select the New tool, the New dialog box appears, allowing you to select the template that
you want to use for your new project. If you tend to use the same template all the time, you can change your startup
settings so that new projects are automatically based on that specific template. This prevents the New dialog box
from appearing and starts your new project right away when you select the New tool.
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To start new projects from a specific template every time:

1. Select Settings > Program Settings or click on the Settings toolbar.

2. On the General page, click the top drop box in the Startup area and select Use Specific Template.

3. Click next to the edit box that is below the Use Specific Template option. In the Open dialog, locate and
select the template that you want to use when starting new projects, then click Open. The template name is
displayed in the edit box.

4. Click OK.

Tip: You can create your own template by simply setting up a drawing with the desired settings and saving it in
your Templates folder.

Starting New Projects Without Using Templates
Personal Architect | Pro Architect | Building Essentials | Construction Suite

By default, every time you select the New tool, the New dialog box appears, allowing you to select the template that
you want to use for your new project. If you do not want to use a template when starting new projects, you can
change your startup settings so that new projects have no pre-defined settings. This prevents the New dialog box
from appearing and starts your new project right away when you select the New tool.
To start new projects without using templates:

1. Select Settings > Program Settings or click on the Settings toolbar.

2. On the General page, click the top drop box in the Startup area and select Use No Template.
3. Click OK.

Enabling Template Selection at Project Startup
Personal Architect | Pro Architect | Building Essentials | Construction Suite

If you want to be able to select any template you want when starting a new project, you must enable the Prompt for
Template option in your startup settings. When you enable this option, the New dialog box appears every time that
you select the New tool, allowing you to select a template to use for your new project.
To enable template selection at project startup:

1. Select Settings > Program Settings or click on the Settings toolbar.

2. On the General page, click the top drop box in the Startup area and select Prompt for Template.
3. Click OK.

Tip: If you use the same template all the time, you can start new projects that are automatically based on that
template. See Starting New Projects from a Specific Template on page xxxii.

Opening a Project from an Older Version
You can open projects from any previous version of Envisioneer in the new version. When you open an older
project, you have the option of converting it to a current-version project, or you can make a copy to work with,
leaving the original intact.
To open a project from an older version:
1. If the Startup screen is currently displayed, click Open Existing. If the Startup screen is not currently dis-

played, select File > Open, or click on the Standard toolbar.

2. In the Open dialog, select the project to open, then click Open.
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3. To make a copy of the project and work with the copy instead of the original (recommended), enable the
Convert a Copy radio button, and then click Continue. In the Save As dialog, type a name for the copy
that is different from the original, then click Save. The copy is opened.

4. To convert the project to the current version, select Convert the Original, and then click Continue. The pro-
ject is converted and opened. Note that when you convert a project, the original is overwritten and cannot
be opened in older versions of the program.

5. To cancel the task without converting or opening anything, select the Cancel option and then click
Continue.

Viewing Sample Projects
To give you an idea of the things you can do with Envisioneer, you may want to view some sample projects. These
projects are located in the program’s Samples directory.
To view sample projects:

1. Select File > Open Samples, or click on the Standard toolbar.

2. In the Open dialog, select the project you would like to view, then click Open.

Selecting a Unit of Measure
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Units of measure determine how length, area and volume measurements are specified when you are creating your
project, and how dimensions are displayed on the screen. You can select the units of measure that you want to use
in your Program Settings, and select the level of precision that you want to use for each one.
To set the units of measure for the current project:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, click Units of Measure in the left column.
3. Select either Imperial or Metric units.
4. To select a unit for distance measurement, make a selection from the Units drop box. Choices for Imperial

units are Feet-Inches, Inches, Feet, and Feet-Inches-Sixteenths. Choices for Metric units are Millimeters,
Centimeters and Meters. Note that this setting does not apply to site boundary measurements.

If using Imperial measurement, it is important to understand the difference between the available options
and how to enter measurements correctly.

Feet-Inches. Displays measurements in feet and inches. When entering a measurement, you must include
the feet symbol (') after a value that you want to be in feet. Otherwise, it will be taken as inches. For inch
values, you do not need to enter the inches symbol (") because inches are already assumed. For example, to
enter a value of 6 feet 6 inches, you would type 6'6. When entering values in inches, you can use decimals
or fractions to specify the value if you want. For example, 6 feet 6 inches could be entered as 6.5' or 6' 1/2.
Regardless of the method you use, the displayed result will be the same: 6'-6".
Inches. Displays measurements in inches. When entering measurements you do not need to include the
inches symbol (") because inches are already assumed. You can still enter values in feet and inches when
specifying measurements (e.g. 6' instead of 72"), but the displayed result will always be in inches. You can
use decimals and fractions when specifying values. For example, to enter 4 and a half inches you would
type either 4.5 or 4 1/2.
Feet. Displays measurements in feet. When entering measurements you do not need to include the feet
symbol (') because feet are already assumed. For example, typing 6 would mean 6 feet. You can use
decimals and fractions when entering measurements. For example, to enter the value 6 feet 6 inches, you
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would type 6.5 or 6 1/2. The decimal or fraction applies to 'feet value', and will appear in the displayed
result if the level of precision permits it.

Feet-Inches-Sixteenths. Displays measurements in feet, inches, and sixteenths of an inch (e.g. 20-06-04).
The two rightmost digits represent sixteenths of an inch. The two digits to the left of that represent whole
inches. All digits to the left of the first four represent feet. So, for example, entering 201108 or 20-11-08
would specify a measurement of twenty feet eleven and one half inches.

5. To select a unit for area measurements, make a selection from the Area drop box. Area measurements
appear in the Area/Perimeter Calculator as well as room region calculations. Imperial choices are Square Feet
and Square Yards. In Metric, area is measured in Square Meters.

6. To select a unit for volume measurements, make a selection from the Volume drop box. Volume meas-
urements appear in room region calculations. Imperial choices are Cubic Feet and Cubic Yards. In Metric,
volume is measured in Cubic Meters.

7. Select a level of precision for each unit of measure by making a selection from the appropriate Precision
drop box. For example, selecting a unit precision of #’-# #/16” sets the level of precision to 1/16th of an inch
when measuring distances in feet and inches.

8. To remove zeros from measurements that end in zero, enable the Suppress trailing zeros check box. For
example, a measurement of 12'-0" would be displayed as simply 12'.

9. If you are working in Metric units and would like to hide the units for length/distance, volume, and area
measurements shown in dimensions and dialogs, enable the Suppress display of metric units check box.
For example, 1200 mm would appear as simply 1200.

10. To change the level of precision for angle measurements, which are displayed in decimal degrees, make a
selection from the Precision drop box in the Angles area. The selection you make determines the number of
decimal places used.

11. Once you’ve set your units of measure, click OK.

Note: The units of measure selected in your Program Settings are used for drawing and creating dimensions.
They are not the units used for calculating and reporting material quantities in the project estimate. Each element
has a unit of measure setting on its Quantity property page that determines how the element is quantified and
reported in the estimate.

Suppressing Trailing Zeros in Measurements
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can specify that you want to suppress trailing zeros in measurements by editing your program settings. For
example, 12'-0" would be displayed as simply 12' in both onscreen and inserted dimensions. This setting applies to
both Metric and Imperial units of measure.
To suppress trailing zeros in the current project:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, click Units of Measure in the left column.
3. Enable the Suppress trailing zeros check box.
4. Click OK.

Suppressing Metric Units in Dialogs
Personal Architect | Pro Architect | Building Essentials | Construction Suite
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If you have chosen to work in Metric units, you can choose to suppress units for length/distance, volume, and area
measurements shown in dialogs. For example, 1200 mm would appear as simply 1200.
To suppress units in the current project:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, click Units of Measure in the left column.
3. With Metric Units selected, enable the Suppress display of metric units check box.
4. Click OK.

Adjusting Your Display Settings
To ensure proper performance you should set your screen resolution to at least 1024 x 768 pixels. Consult the
documentation for your Windows operating system for information on changing your screen resolution.

Videos and Tutorials
Go to https://www.cadsoft.com/learning-center/support-learning to view an extensive list of informative videos and
tutorials that will help you familiarize yourself with the Envisioneer workspace and learn about its features.
To access the videos and tutorials from Envisioneer:

1. Select Help > Customer Care or click on the Help menu.

2. On the Learning Center page, click Support.

Tip: There are a number of "getting started" and support resources available on the Startup screen that appears
when you start the program.

Quick Start Guide
The Quick Start Guide is a short, step-by-step tutorial that teaches you the basics of the program through hands-on
exercises. It is a great way to get up and running with the software as quickly as possible.

The Quick Start Guide can be found in the box or inside the DVD case if you have purchased a boxed version.

The Quick Start Guide is also available in PDF format, which can be read in Adobe® Reader®. Two versions are
available: Imperial and Metric. The guide is also available in video format.

To view a PDF of the Quick Start Guide:
l Select Help > Quick Start Guide > Quick Start Guide (Imperial - PDF) or Quick Start Guide (Metric - PDF).
l Click the down arrow next to on the Help toolbar and select either Quick Start Guide (Imperial - PDF)
or Quick Start Guide (Metric - PDF).

l Click the View the Quick Start Guide link on the Startup screen, then select the version that you would like
to view (Imperial or Metric).

Online Help
The comprehensive online help system includes information about every feature in Envisioneer. The system includes
Index and Keyword Search features so that you can quickly find what you're looking for.
To access the online help file:
l Select Help > Program Help, or
l Press F1, or
l Click on the Standard toolbar or Help toolbar
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Context-sensitive Help
Context-sensitive help is help for a specific dialog or element in your drawing.
To get help for a specific part of your drawing:
1. Select the element you want help with.

2. Right-click and select the Tool Help option for that element (e.g. Walls Help). A list of topics related to the
element is displayed — just click the topic you want to learn more about. You can also access the Tool Help
from the Edit > Modify Elements menu.

To get help in a dialog:
1. Click in the dialog. A window is displayed that describes the content of the dialog.

Tutor
The Tutor is a context-sensitive help feature that displays "how-to" information about a tool when you select it. For
example, if you select the Walls tool, the Tutor window displays a video and information on how to draw walls,
handy tips and tricks, and links to other topics that may be of interest.

You can turn the Tutor on and off as needed. If the Tutor is currently displayed you can turn it off by enabling the
Don't show the Tutor again check box at the bottom of the Tutor window.
To turn the Tutor on or off:

1. Select Help > Tutor or click on the Help toolbar.

Glossary of Terms
You can instantly access a glossary of technical and construction terms from the Help menu.
To view the Glossary of Terms:

1. Select Help > Glossary of Terms, or click on the Help toolbar.

Technical Support

Online Support 24/7
Before contacting Technical Support, check out the Cadsoft web site, where you can find a variety of FAQs, white
sheets, and videos.
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To access the Learning Center, visit https://www.cadsoft.com/learning-center/knowledge-network/. You can also

access the site directly by selecting Help > Customer Care in Envisioneer or clicking on the Help toolbar.

You can also post questions on the Cadsoft Forum 24 hours a day, 7 days a week. Go to
https://www.cadsoft.com/community-posts/.

Technical Support
If you cannot find the answers you need in the Online Help or on the Cadsoft Support site, please contact Cadsoft's
technical support team. Please remember that technical support cannot answer specific questions about your
business project, only questions related to the features of your Envisioneer software.

When you contact technical support, be prepared to provide information about your computer name and model,
and the brand name of the video card you are using. If possible, sit at your computer with the program running
when you call. Be prepared to provide a detailed description of what happens when you try to run the program.
Cadsoft Customer Support

Hours: Monday to Friday, 8:30 AM - 5:00 PM, EST

Toll-Free in North America: 1-888-CADSOFT (223-7638)
Corporate Phone: (519) 836-3990
Fax: (519) 823-8821
E-mail: support@cadsoft.com
Customer Support Australia

Phone: (07) 3202-6366
Fax: (07) 3202-6311
E-mail: support@cadsoft.com.au

Auto Scroll
When an insertion tool is active in in Model View, the Auto Scroll feature will automatically scroll the drawing
when you hover your cursor near the edge of the drawing area. When the Auto Scroll feature is active, your cursor
changes to a multi-directional arrow at drawing area edges. The drawing will scroll in the direction in which you
move your cursor.

Auto Scroll is particularly useful when you are drawing an element such as a wall and discover that you need to
scroll the drawing area to be able to continue drawing it. Auto Scroll permits uninterrupted drawing and is an
excellent alternative to using scroll bars.

Auto Scroll settings are defined in your program settings. You can choose to have it active all the time, or active only
when you press the CTRL key on your keyboard. You can also adjust the scrolling speed so that it is slower or
faster. You can also disable Auto Scroll completely if you want.

Note: By default, the Active with CTRL key option is enabled in your program settings. This means that you
must press and hold the CTRL key on your keyboard to activate and use Auto Scroll while inserting elements. If
you disable this option in your program settings and simply have the Enable option selected, it will be active all
the time and you do not have to press any other keys to activate it.

To adjust Auto Scroll settings:

1. Select Settings > Program Settings or click on the Settings toolbar.

2. In the Program Settings dialog, click Drawing Aids in the left column.
3. To turn Auto Scroll on or off, check or uncheck the Enable check box in the Auto Scroll area.
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4. If you would like Auto Scroll to be active only when you choose to use it (instead of all the time), enable the
Active with CTRL key check box. If this option is enabled, Auto Scroll will only be active if you press and
hold the CTRL key while inserting an element. This gives you precise control over its use and prevents
unwanted scrolling.

5. To adjust scrolling speed, click and drag the Speed slider in the Auto Scroll area. To decrease the speed,
slide left. To increase the speed, slide right.

6. Click OK.
To use Auto Scroll when inserting an element:
l To scroll up, hover your cursor near the top edge of the drawing area.
l To scroll down, hover your cursor near the bottom edge of the drawing area.
l To scroll left, hover your cursor near the left edge of the drawing area.
l To scroll right, hover your cursor near the right edge of the drawing area.
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Chapter 4: Drawing & Editing
Basics

There are three types of elements that you can insert — single-click elements, line-drawn elements, and area-drawn
elements. Before starting a design, it may be helpful to familiarize yourself with the methods of inserting each of
these element types.

By default, when you insert a single-click element, such as a door, you remain in Insertion mode until you right-click
and select Finish. You then go into Selection mode, which means you can select elements for editing. If you prefer
you can select the Single Insertion Only option in your program settings so that you automatically go into Selection
mode after inserting an element, eliminating the need to right-click and Finish.
By default, when you insert line-drawn elements such as walls, you simply pick points to define the element's end
points. If you are more familiar with "clicking and dragging", you can select the Pick and drag option in your
program settings.

If you want to edit an element that you have inserted, you need to select the element. When an element is selected it
is highlighted. For many elements, editing grips are also displayed that let you move, rotate or stretch the element.
Right-clicking your mouse when an element is selected displays a menu that contains editing commands specific to
that element. You can also view this menu by selecting Edit > Modify Elements when an element is selected.

Inserting Elements
When you select a tool from the Insert menu or one of the insertion toolbars, you are in Insertion mode. To insert an
element, you select it in the catalog panel, then click in your drawing area.

Many elements can be inserted with a single mouse click. Single-click elements include doors, windows and stairs, and
objects such as cabinets and furniture. Line-drawn elements such as walls and railings require that you select two
points to define the element’s start point and end point. The points you pick determine the element’s length and
angle. Area-drawn elements, such as manually inserted floors and ceilings, and fills and plateaus, are drawn by
picking a series of points to define their outline.

In many cases, on-screen dimensions are displayed as you draw, making it easy to create line-drawn and area-
drawn elements at the correct length or size, and insert elements like doors and windows precisely where you want
them in a wall.

Once you insert an element in your drawing area, you can:
l Continue inserting the same element
l Select a different element in the catalog to insert
l Right-click and select Finish to end the command and return to Selection mode

Tip: When an Insert tool is active, double-clicking inserts the element and finishes the command at the same time.
Note, however, that double-clicking after you’ve already inserted an element will, in most cases, insert another
element.

- 41 -



- 42 -

Tip: If you are in Selection mode, you can insert
any element currently accessible in the catalog by
simply selecting the element in the catalog, then
moving your pointer into the drawing area.

Specifying an Insertion Offset
When you are inserting single-click elements such as
doors, columns, cabinets, toilets, and furniture, you
can use the Insertion Offset tool to offset the element
a specific distance from other elements in the
drawing. This helps you position elements precisely
where you want them.

Once you have selected the element in the catalog,
prior to inserting it, right-click in the drawing area
and select Insertion Offset.
l If the element is a door, window or opening,
enter the distance that you want to offset the
element from the end of the wall:

When you click OK and position the element in
the receiving wall, the element will snap inside
the wall at the correct position.

l For elements that can be freely placed inside
the model, such as toilets and furniture, you
can specify an offset distance for each side of
the element. For example, if you specify a
right-hand insertion offset of 12" for a toilet,
and then position the toilet near a right-hand
wall, the right side of the toilet will snap 12"
away from the wall, or any other elements that

appear to the right of the toilet.

Selecting an Insertion Method
for Line-Drawn Elements
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Line-drawn elements, such as walls, are elements that
are drawn by picking two or more points. By default,
line-drawn elements use the Pick Points insertion
method. With this method you do not have to keep
your mouse button depressed to draw the element
(i.e. you do not have to click and drag the mouse).
Once you’ve selected the first point, you can simply
move your mouse in the direction you want the
element to run, then click to select the next point.

If you are more comfortable with the “click-and-drag”
method, you can select the Pick and drag insertion
method. With this method, you keep the mouse
button depressed after clicking the first point, drag
the mouse to draw the element, then release your
mouse button to select the next point.
To select an insertion method for line-drawn
elements:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Draw-
ing Aids in the left column.

3. In the Model View Insertion Method area, select
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Pick Points or Pick and drag.
4. Click OK.

Selecting an Insertion Method
for Single-Click Elements
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Single-click elements are things like doors, windows
and staircases. By default, Insertion mode remains
active after inserting a single-click element. This
means you can keep inserting elements without
having to re-select an Insert tool or element in the
catalog. You can disable this behavior if you want to.
If you do choose the Single Insertion Only option, you
do not need to select Finish after inserting a single-
click element. You will go directly into Selection
mode.
To select an insertion method for single-click
elements:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Draw-
ing Aids in the left column.

3. In the Model View Insertion Method area, select
either Single Insertion Only or Repeat Inser-
tion.

4. Click OK.

Repeating the Insertion of a
Line-Drawn Element
When drawing elements such as walls, new segments
are continually added as you pick more points. You
can use the Repeat tool to finish drawing the current
line-drawn element and start a new one if you want,
without having to restart the tool.
To repeat the insertion of a line-drawn element:
1. When you are ready to finish the current ele-

ment and start a new one, right-click and
select Repeat, or select Edit > Modify Ele-
ments > Repeat. The current element is fin-
ished.

2. Pick a start point for the new element and
continue drawing.

Note: The Repeat tool is available for line-drawn
elements only.

Using Space as Enter
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can specify that you want the spacebar on your
keyboard to act like the Enter key. This can speed up
the way you work.
To specify that you want to use the spacebar as
Enter:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Draw-
ing Aids in the left column.

3. In the Model View Insertion Method area,
enable the Use Space as Enter check box.

4. Click OK.

Going into Selection Mode for
Editing
When you have finished using an insertion tool, either
by double-clicking or selecting Finish from the right-
click menu, you automatically go into Selection mode.
When in Selection mode, you can select elements in
your drawing area and edit them.

You can also go into Selection mode by clicking
on any insertion toolbar, or by selecting Select/Edit
from the Edit menu.

Selecting Elements for Editing
When in Selection mode, you can select elements for
editing. You can select individual elements, a group
of elements, or all elements.

When an element is selected, it is highlighted in a
different color (usually light green). One or more
grips are also displayed on the element.

When you are in 3D view, all elements on all
locations are selectable. When you are in 2D plan
view, only elements on the current building location
are selectable. However, you can change this if you
want.

If multiple elements share the same edge, such as
floors and ceilings, you can cycle through the
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different elements that share that edge so that you can
accurately pick the one that you want to edit. To do
this, select one of the element edges, and then hold
down the Shift key while using the scroll wheel on
your mouse.

If you are having trouble selecting the element you
want, you may want to use the View Filter to make
other elements non-selectable. This makes selection of
the element much easier.

Note: Automatic floors cannot be selected in 2D
Plan view unless the display mode is set to
Rendered or Rendered Outline. They can be
selected in 2D Designer's View, or in 3D view.

To select a single element:
1. Click on the element.

To select multiple elements by clicking:
1. Click the first element you want to select.

2. Hold down the Shift key and click on the rest
of the elements you want to select. The most
recent selection is green and prior selections
are blue.

To select a group of elements by creating a
selection window:
1. Going from either left to right, or right to left,

drag a selection window around the elements
you want to select. Any elements touching
the selection window will be selected (they
do not need to be totally enclosed).

To select all instances of a specific element:
1. Select one instance of the element in your pro-

ject.

2. Right-click and select Select All Similar. All
elements in the project that have the same
definition as the chosen element become selec-
ted.

To select all elements on the current location:
1. Select Edit > Select All.

To re-select the elements you last selected:
1. Select Edit > Select Previous.

Deselecting Elements
When you select elements, you can remove individual
elements from your selection set. You can also
deselect everything that is currently selected.
To deselect individual elements:

1. Hold down your Shift key.

2. Click the element you want to deselect.
To deselect everything in your selection set:
1. Select Edit > Deselect All, or right-click in

the drawing area and select Deselect All, or
simply click in a blank spot somewhere else
in the drawing area.

Making Elements on All Loca-
tions Selectable in 2D
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, only elements on the current building
location can be selected in 2D plan view, even if
elements on other locations are visible. If you want to
make elements on all locations selectable, you need to
change one of your program settings.
To make elements on all locations selectable in 2D
plan view:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Build-
ing Aids in the left column.

3. In the Drawing Assistance area, uncheck the
Select elements on current location only
while in plan view check box.

4. Click OK.

Enabling/Disabling Screen Tips
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, screen tips are displayed when you hover
over elements in Model View telling you what the
elements are. In 3D view, the element's building
location is also displayed. This can help you when
selecting elements, as it lets you know what you are
about to select. On some systems, disabling screen
tips can help improve program speed.
To enable or disable screen tips:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.
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3. In the Visual Aids area, check or uncheck the
Enable Screen Tips in Model Views check
box.

4. Click OK.

Accessing Edit Tools
Most elements in Model View can be moved once
they are selected by simply clicking and dragging
them. Some can also be stretched or rotated. You can
access a full menu of edit tools in Model View by
right-clicking in the drawing area, or by selecting Edit
> Modify Elements.
Menus vary depending on the element selected.
Typical tools are Properties, Move, Rotate, Duplicate,
and Delete. If two types of elements are selected (such
as a floor and a wall), only tools that are common to
both element types are available.





Chapter 5: Building Locations

When you insert an element in your drawing, it is inserted on the current building location. It is important to define
your building locations before inserting elements, since building locations are the key to organizing elements and
inserting them at the correct height in your model.

If you are drawing from scratch, the program’s default drawing templates have a few pre-defined building locations.
You can change the settings for existing building locations as well as add and delete locations.

If you use the House Builder Wizard to start your project, your main building locations are set up for you when you
run the House Builder Wizard.

This chapter describes how to define your building locations, and identify the current building location when
adding elements to your design.

Defining Building Locations
Personal Architect | Pro Architect | Building Essentials | Construction Suite

When you insert an element in your drawing, it is inserted on the current building location. It is important to define
your building locations before inserting elements, since building locations are the key to organizing elements and
inserting them at the correct height in your model.

The program’s default drawing templates have a few pre-defined building locations. You can change the settings for
existing building locations as well as add and delete locations.

When you define building locations, you are basically doing two things:
l setting the wall height for each floor (level) in your model
l specifying where each floor is positioned relative to grade or another location

To define building locations:

1. Select Settings > Building Locations, or click on the View Control toolbar.

Below is a brief description of each building location property.
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Number. A reference number for the location.
Name. The location’s name (e.g. Ground Floor).
Floor Level. The level of the new location's floor
relative to grade, and the level at which the wall
bottoms will sit.

Head Height. Height of tops of windows and wall
openings relative to the floor level.

Ceiling Height. Height of underside of ceiling
surface relative to the floor level.

Wall Height. Physical height of the walls on the
location.

Framing Options. Determines how the walls on the
location are framed.

Floor levels are relative to the ground. As an example,
if the Foundation location has a Floor Level of -8’ (or
-2440 mm), the base of the foundation is positioned 8’
(2440 mm) below ground level. (In other words, it is a
full basement.) In this case, if the Wall Height of the
Foundation location is 8’ (2440 mm), the top of the
foundation wall will be situated at ground level.
To change the properties of a building location:
1. In the Building Locations dialog, click on

the property you want to change. You can
change location names or any of the numer-
ical settings.

2. Type the value you want.

3. Press Enter.
To add a new building location:
1. In the Building Locations dialog, click the

Add Location button, then follow the steps
in Adding a Building Location on page 48.

To delete a building location:
1. In the Building Locations dialog, click on

one of the location’s fields to make it the cur-
rent location.

2. Click Delete Location.
Note: You cannot delete a location if it contains any
elements. Also, you cannot delete a location if it is the
only one in the list.

Adding a Building Location
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can set up all building locations before starting a
drawing, or you can add locations as needed.
To add a building location:
1. Select Settings > Building Locations, or

click on the on the View Control toolbar.

2. In the Building Locations dialog, click the
Add Location button.

3. In the New Location dialog, specify where
you want to calculate the new location from
by selecting either Calculate from existing
location or Calculate from grade. Typically,
the foundation and ground- or first-level loc-
ations are calculated from grade, while upper
floors are calculated from existing locations.

4. If you selected Calculate from existing loc-
ation, specify the following settings in the
Location Calculator (From Existing) dialog:
Location Name. The name of the location as
it will appear in the Building Locations
dialog and drop box.

Top of Wall from Grade. This value is
calculated automatically based on the values
you specify for the walls and floor, and the
levels defined for the existing building
location. It indicates the level at which the
new location's wall tops will sit relative to
grade.

Wall Height. How tall you want the walls to
be on the new location.

Ceiling Height. Height of the underside of
the ceiling surface relative to the floor.

Head Height. Height of tops of windows
and wall openings relative to the floor.

Sheathing. The thickness of the floor
sheathing.

Structural. The height of the floor's structural
material (e.g. joists).

Sill Plate. The thickness of the sill plate.
Floor Level. The level of the new location's
floor relative to grade. The new location's
wall bottoms will sit at this level. This value
is calculated automatically by adding the
total thickness of the new location's floor
structure (sill plate + joists + sheathing) to the
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existing location's Top of Wall from Grade
height value.

Top of Wall from Grade. The level at which
the existing location's wall tops currently sit
relative to grade.

Calculate from Location. The existing
building location from which the new one
will be calculated. Typically this is the
location on which the new location will sit.

5. If you selected Calculate from grade, specify
the Wall Height, Ceiling Height and Head
Height in the Location Calculator (From
Grade) dialog as described in the previous
step. Additionally, specify the location's
Floor Level from Grade to determine where
the top of the floor (and base of the walls)
will sit relative to grade.

The Top of Wall from Grade will be
automatically calculated based on the specified
wall height and floor level.

6. Click OK to add the location to the list. To
determine how walls on the location are
framed, see Defining Wall Framing Options for
Building Locations on page 147.

Note: When you add a location to your list, it
does not become the current location unless you
select it in the list or edit its properties.

Making a Building Location Cur-
rent
Before inserting an element in your drawing you
should make sure that the building location you want
to insert the element on is the current building
location.
To make a building location current:
l Click on the building locations drop box on the
View Control toolbar and select the desired loc-
ation.

OR
l In the Building Locations dialog, click in the
far left field of the location you want to make

current. A check mark indicates the location is
now current.

Allowing a Different Current
Location Per View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the location you select in one view
window will be the one displayed when you switch to
other view windows. By changing your program
settings you can allow a different location to be
current in each view window.
To allow a different current location per view
window:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Model View Behavior area, disable the
Maintain Current Location Per View check
box.

4. Click OK.

Location Dimming
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When a particular location is current, elements on all
other visible locations are dimmed. This makes it
easier to insert and edit elements on the current
location because it is more obvious which elements
are part of the current location.

By default, elements on other locations are dimmed
by 90%. You can adjust the dimming so that it is
lighter or darker according to your preference.
To change the dimming percentage:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.
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3. Type the desired dimming percentage in the
Dimming Percentage edit box, or use the
arrows to scroll up or down through a list of
values.

4. Click OK.
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The first question many people ask when they sit down with a new piece of software is, “Where do I start”? The
House Builder Wizard is the perfect way to start a project, because it builds a house for you instantly! All you need
to do is specify how many stories you want to create, select a general house shape, define the building dimensions,
then select the general style for the walls, roof, floors and foundation. In a few mouse clicks, you’ll have a basic
structure that you can edit and add to.

Once your basic model is built you can add things like interior walls, doors, windows and stairs. If you would
prefer to start your project from scratch, you may want to start by drawing walls. (See Drawing Walls on page 55.)

Using the House Builder Wizard
Personal Architect | Pro Architect | Building Essentials | Construction Suite

The House Builder Wizard is the perfect way to start a project, because it builds a house for you instantly! All you
need to do is specify how many stories you want to create, select a general house shape, define the building
dimensions, then select the general style for the walls, roof, floors and foundation. The resulting house includes
exterior walls, footings and foundation walls (or concrete slab), a roof, and a floor. In a few mouse clicks, you’ll have
a basic structure that you can edit in every way to suit your needs.
To use the House Builder Wizard:

1. Select Insert > Design Wizards > House Builder, or click on the Building toolbar.

Note: Running the House Builder Wizard will delete all existing building elements in the current project. It will
not, however, remove the terrain or any landscaping elements you have inserted.

2. Click Yes in the warning dialog to proceed.

3. On the House Builder screen, click Next.
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4. From the Number of Floors drop box, select
the number of floors you would like the
house to have (not including the basement
level).

5. In the Floor to Ceiling Height edit box, type
the desired wall height for each floor level.

6. In the Foundation Type area, select the type of
foundation you want to create. Choose from
Concrete Slab, Full Basement, or Foundation
Walls w/ Crawl Space.

7. If you selected the Full Basement or Found-
ation Walls w/Crawl Space, specify the elev-
ation of the ground floor relative to the
ground in the Ground Floor Height above
Terrain edit box.

8. Click Next.

9. Select the general house shape by clicking
one of the graphics in the House Shape pane.

10. Once you’ve selected a house shape, make a
selection in the Garage Position pane to specify
where you want to put the garage. If you
don’t want a garage, select the first option.

11. Click Next.

12. In the Building Size area, specify the desired
dimensions for the house by entering values
in the edit boxes. The edit box labels cor-
respond to the labels on the image in the left
pane.

13. In the Garage area, select either Single, Double
or Triple from the Type drop box. Then,
using the dimensioned graphic as an aid, spe-
cify the desired offset of the garage from the
exterior wall corner.

14. Click Next.
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15. From the Building Configuration drop box,
select the general style for your home (con-
temporary, country or traditional). The pre-
set material selections for the elements in
your house are displayed in the lower pane.
You can select different materials if you want
— just click the button of the element you
want to change and make a selection from the
catalog. NOTE: For Building Essentials and
Construction Suite products, the Floors
option will allow for a Structural Floor or a
Floor Surface.

16. Click Next.

17. Click Finish to build the house.

Launching the House Builder
Wizard Automatically at Startup
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you want you can choose to launch the House
Builder Wizard automatically every time you start a
new project, instead of opening a blank drawing.
To launch the House Builder Wizard automatically
at startup:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Gen-
eral in the left column.

3. In the Startup area, check the Launch wizard
when starting new project check box.

4. Select House Builder from the drop box.

5. Click OK.

Creating a Custom House
Builder Wizard Configuration
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A House Builder Wizard configuration determines
what elements are used for exterior walls, roofs,
floors, ceilings, foundation walls and footings. You
are asked to select a configuration for your house
when you run the House Builder Wizard.

You can edit any of the existing configurations that
are available in the House Builder Wizard, or create
your own. Customized configurations are saved
automatically and will be available when you run the
House Builder Wizard in the current project, or any
other project.
To access the building configuration library:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager dialog, select Librar-
ies > Building Configuration.

To add a new configuration to the list:
1. Select Edit > Add Configuration, or right-

click in the Building Configurations window

Structural_Floors.htm
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and select Add Configuration. An entry
named ‘New Configuration’ is added to the
list.

2. Select the new configuration in the list. If you
want to rename it, select Edit > Rename Con-
figuration, or right-click and select Rename
Configuration. Then, type the new name and
press ENTER.

To edit a building configuration:
1. Select the configuration in the list. The ele-

ment selections for the configuration are lis-
ted in the center pane.

2. In the center pane, select an element type you
want to specify a style for (e.g. Main Wall).

3. Click the Select button.
4. In the Catalog Access dialog, select the spe-

cific style you want to apply to the selected
element type, then click OK.

5. Continue selecting styles for the remaining
element types.

To delete a configuration from the list:
1. Select the configuration in the list.

2. Select Edit > Delete Configuration, or right-
click and select Delete Configuration, or
simply press the Delete key on your key-
board.
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In most cases you will probably want to start your design by drawing the exterior walls, and then adding interior
walls. Drawing walls is easy — just point and click!

Drawing walls is easy — just point and click. Envisioneer automatically displays dimensions as you draw, and
connects corners for you. If the Object Snap is turned on, interior walls snap to other existing walls and create clean
intersections with them.

Once inserted, any wall can be moved, rotated, lengthened, shortened, elevated, lowered, curved, deleted, and more.
This lets you create the exact wall layout that you want.

There are two different tools available for drawing walls: the Walls tool, and the Walls by Baseline tool. The Walls
tool draws walls on center. The Walls by Baseline tool lets you draw walls on any baseline, such as the exterior or
interior wall line.

The catalog contains exterior, interior and foundation wall types. Once your walls are drawn, you can add paint,
wallpaper, baseboards and other types of trim for a truly customized look. Walls also have a framing configuration
in their properties which you can customize if you want.

Drawing Walls
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can draw walls by simply pointing and clicking with your mouse.

By default, every exterior wall in the catalog is defined as a composite wall. A composite wall is a structural wall
(e.g. stud wall) and veneer wall (e.g. brick or stone wall) put together, with an air space in between.

Perimeter walls drawn with the Walls tool are drawn on center. If you want to draw walls with a different offset
(such as on the outer face of the veneer), use the Walls by Baseline tool instead.

If automatic floors are turned on in your program settings, a floor is automatically inserted when you create a closed
wall layout. You can change the floor properties after it has been inserted if you want.

Once you’ve created your exterior walls, you can start drawing interior walls. Walls snap to other walls
automatically, creating clean corners and intersections.
To draw walls:
1. Make sure the current location is the location that you want to insert walls on.

2. Select Insert > Walls > Walls, or click the down arrow next to the Walls button on the Building toolbar
and select Walls.

3. In the catalog, select the wall type that you want to insert.

4. Select a start point for the first wall.

Note: When selecting a start point for an interior wall, the on-screen dimensions measure from the inside
face of the exterior walls to the adjacent face of the interior wall you are drawing.
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5. Without dragging, move your cursor in the
direction you want your wall to run. Its
length is shown as you draw the wall.

Note: By default, drawing is constrained to
15º angles. To release this constraint, turn
off Angle Snap.

6. When the wall is the length you want, click to
set its endpoint.

7. To add another wall to the one you have just
drawn, move the mouse in the direction you
want the new wall to run. When it is the right
length, click to set its endpoint.

8. When you are finished drawing walls, right-
click and select Finish.
If drawing exterior walls with a composite wall
definition, you will see both the structural wall
and veneer. Note: If drawing composite walls, the veneer

appears only if the walls connect to form a closed
layout. Otherwise, only the structural wall is
displayed.

Drawing Walls from an Offset
Baseline
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you use the Walls tool to draw perimeter walls, the
walls are drawn on center, which means they are
drawn on a center baseline. You may prefer to draw
your walls on a different baseline. For example, you
may want your baseline to represent the inner or
outer edge of the wall core. You can then offset the
walls from that baseline in either direction by a
specified distance, or have no offset at all.
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You can draw walls from an offset baseline using the
Walls by Baseline tool. Once you’ve drawn the
perimeter baseline you can specify how you want to
offset the walls from that baseline.
To draw walls from an offset baseline:
1. Select Insert > Walls > Walls by Baseline, or

click the down arrow next to the Walls button
on the Building toolbar and select Walls

by Baseline.
2. In the catalog, select the wall type you want

to insert.

3. Pick points to draw the outline of your
exterior wall layout, then right-click and
select Finish. When considering your
measurements, keep in mind that the walls
will be offset from this outline.

If you make a mistake while drawing the
outline you can undo the last segment drawn
by right-clicking and selecting Step Back.

4. In the Walls by Baseline dialog, select the
wall face that you would like to serve as the
offset baseline. You can choose either Outer
Face of Veneer, Outer Face of Wall Core or
Stud, or Inner Face of Wall Core or Stud.

5. In the Offset area, specify an offset distance in
the Distance edit box, if desired.

6. If you have specified an offset distance, select
the direction in which you want to offset the
walls from the baseline, either Towards out-
side or Towards inside.

7. Click OK. The walls are created.

Note: When drawing the layout, do not select the
start point again to create the last segment. The last
point picked is continually connected to the start
point.

Adding a Story
Once you have created one level, such as the Ground
Floor level, adding more levels to your design is easy.
You can create a new story in one of the following
ways:
l Use the Floor and Foundation Builder Wizard
to automatically create perimeter walls on
another location (see page 57)

l Use the Duplicate to Locations tool to copy the
walls from an existing location to a new loc-
ation (see page 225)

l Use the Walls tool to draw walls on a new
building location using the walls on the pre-
vious location as a tracing footprint (see page
55)

Using the Floor and Foundation
Builder Wizard
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Once you have created a perimeter wall layout for
one level in your design, you can use the Floor and
Foundation Builder Wizard to automatically create a
foundation level or additional stories. When stepping
through the Wizard you define the element
configuration and materials you want to use, and the
relative position of elements. The Wizard then builds
the new level for you automatically using the existing
layout on another location as a tracing footprint.
To create a new level with the Floor and
Foundation Builder:
1. Make sure you have drawn a perimeter wall

layout for one building location in your
model. The Wizard will use these walls as a
tracing footprint for the new level.

2. Select Insert > Design Wizards > Floor and
Foundation Builder, or click the down arrow
next to the Design Wizards button on the
Building toolbar and select Floor and
Foundation Builder.



- 58 -

3. On the Welcome screen, click Next.

4. Select the type of level you want to create. To
create a new story (comprising walls and a
floor), enable the Floor Level radio button,
then select a building location for the new
level from the location drop box (e.g. Second
Floor). To create a foundation level (which
can include footings, or can be just a slab),
enable the Foundation Level radio button,
then select a building location for the found-
ation elements (e.g. Foundation). The build-
ing location you select determines the height
of the new level's walls as well as the floor
level.

5. Click Next.

6. In the Type area, select the type of element
configuration you want to create. For a floor
level, this determines how the floor intersects
with the walls. For a foundation level, this
dictates what type of foundation will be
created and what it will include.

Floor Level Options

Foundation Level Options

7. If you selected a configuration that includes
walls, click the Walls button, then select the
type of wall you want created on the new
level in the Catalog Access dialog.

8. If the configuration you selected includes a
floor, click the Floors button. NOTE: For
Building Essentials and Construction Suite
products, the Floors option will allow for a
Structural Floor or a Floor Surface. Select
either then select the type of floor you want
the new level to have.

9. If you are creating a Slab on Grade or Mono-
lithic foundation level but already have a
floor slab in the drawing, you will probably
want to enable the I already have a floor

Structural_Floors.htm
Floors.htm


Chapter 7: Walls

- 59 -

slab, do not include another check box. This
prevents the creation of an additional floor
slab.

10. If you are creating a foundation level, click
the Footings button, then select the type of
footing you want to use.

11. Click Next.

12. The Adjust Position of Elements screen lets
you move the walls, floor or footing toward
the inside or toward the outside of the layout.
If you want to adjust any of these elements,
select the element to adjust from the Adjust
Element drop box, then enter the distance
you want to move the element in the
Distance edit box. Then, specify the direction
in which you want to move the element by
enabling either the Towards Inside or
Towards Outside radio button.
The point from which the move distance is
measured depends on the type of element
you are adjusting and the floor style or
foundation type you have selected. For more
detailed information on adjusting elements,
click the help button on the Adjust Position
of Elements screen.

13. Once you adjusted your elements, click Next.

14. Click Finish. The new level is created auto-
matically.

Note: The Floor and Foundation Builder will not
launch if there is not a closed wall layout present in
the drawing.

Solid Filling Walls and Other Ele-
ments
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can instantly apply solid fill to the walls or other
elements in your 2D plan by enabling solid fill in your
Program Settings. Any element that has solid fill
enabled on its Appearance property page will be solid
filled. These include walls, floors, surfaces, members,
cabinets, paths, pads, and fills.
To enable solid filling:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, select
Building Aids in the left column.

3. In the Drawing Assistance area, enable the
Enable Solid Filling check box.

4. Click OK.

Note: Solid filling will only appear on elements
that have solid fill colors assigned to them and
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have solid fill turned on in their Line Work
properties.

Editing Solid Fill Colors
Certain elements have a solid fill color assigned to
them in their Line Work properties. These include
walls, floors, surfaces, members, cabinets, paths, pads,
and fills. You can edit the color assignment for these
elements in your catalog or in your drawing.
To edit solid fill colors:
1. Select the element whose solid fill color you

want to change, either in the catalog, or in
your drawing. Note that editing solid fill in
the catalog will affect only future insertions
of that element type.

2. Access the element’s properties.

3. In the properties dialog, select the Line Work
tab.

4. In the Components list, select the component
you want to change. For example, if the ele-
ment is a wall you may want to select 2D
Core or Airspace. Other elements may have
a 2D component as well.

5. In the Solid Fill area, make sure the Enable
check box is checked.

6. Click the color swatch.

7. In the Color dialog, select the desired solid
fill color, then click OK.

8. Click OK in the properties dialog.

Disabling Solid Fill for Individual
Elements
If you have enabled solid filling in your program
settings, you can turn solid fill off for individual
elements in your drawing by editing the element’s
Line Work properties.
To disable solid fill for an individual element:
1. Select the element whose solid fill you want

to turn off.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the properties dialog, select the Line Work
tab.

4. In the Components list, select the component
whose solid fill you want to disable. For
example, if the element is a wall, you may
want to select 2D Core.

5. In the Solid Fill area, uncheck the Enable
check box.

6. Click OK.

Note: To turn off all solid filling in your drawing
you need to disable solid filling in your program
settings.

Editing Dynamic Dimension Set-
tings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Dynamic dimensions are the dimensions that appear
on the screen when you select a wall, door, window
or wall opening. Editing these dimensions lets you
resize a wall layout, or move doors, windows and
openings within a wall.

In the case of a composite wall, dynamic dimensions
measure to the outer surface of the wall by default
(e.g. the veneer). You can choose to have them
measure to the edge of the core wall instead (e.g. stud
wall).
To edit dynamic dimension settings:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left pane.

3. Select the desired option in the Dynamic
Dimensions area.

To outer surface. Causes dynamic
dimensions to measure to a composite wall's
outer surface (e.g. veneer).

To edge of core. Causes dynamic
dimensions to measure to the edge of the core
wall (e.g. stud wall) in a composite wall.

4. Click OK.

Resizing a Wall Layout
You can resize an exterior wall layout by moving a
wall, or by editing its dynamic dimensions. All
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adjoining walls automatically stretch along with the
wall you are moving or editing.
To resize a wall layout by moving a wall:
1. Select the exterior wall you want to move. All

attached walls will stretch along with it when
you move it.

2. Hover your pointer over the center grip to
display the Move cursor.

3. Click and drag the wall to resize the wall lay-
out, then release your mouse button.

To resize a wall layout by editing its dimensions:
1. Select one of the walls. If you want to stretch

the layout left or right, select a vertical wall.
If you want to stretch the layout up or down,
select a horizontal wall. Dynamic dimensions
are displayed on the wall layout.

2. Click the dimension you want to edit. The
Edit Dimension dialog appears.

3. Enter the new value in the Enter Distance
edit box.

4. Specify the direction in which you want to
move the walls by clicking one of the arrows
to the right of the Enter Distance edit box.

5. Press Enter or click OK. The walls update
automatically.

Note: If you select an interior wall and edit its
dynamic length dimension, this will also resize the
wall layout.

Defining a Wall's Surfaces
Every wall in the catalog has a set of properties that
determine if the wall has interior and/or exterior
surfaces applied to it. An exterior surface would be a
veneer such as brick, stone or siding. An interior

surface would be a material applied to the core wall
(e.g. stud wall) on the interior of the model, such as
drywall or plaster.

Defining a width for an exterior or interior surface
results in the application of that surface to the core
wall (e.g. stud wall). You can also control the air
space between a surface and the core wall.
To define a wall's surfaces:
1. Select the wall whose properties you want to

change. You can select multiple walls using
Shift+click if you want. You can also define
properties for walls in the catalog.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Basic tab.
4. To apply an exterior surface (i.e. veneer) to

the core wall, type the width of the surface in
the Width edit box in the Exterior Surface area.

5. To define the space between the exterior sur-
face and the core wall, enter a value in the Air
Space edit box.

6. To drop the exterior surface below floor level,
enter the desired extension value in the Drop
Exterior Face edit box. This is typically done
to cover an exposed floor system.

7. To apply an interior surface to the core wall,
enter a width for the surface in the Width edit
box in the Left Interior Surface or Right
Interior Surface area.
The left or right side of a wall depends on the
direction in which the wall is drawn. If you
click on a wall in your drawing, you will see
one end marked with a green marker, and the
other end marked with a red marker. The
green marker indicates the start point of the
wall, or the point you started drawing from.
The red marker indicates the end point. To
determine the left or right side of the wall,
picture yourself standing at the wall's start
point (green marker) and looking toward the
end point (red marker). For example, if a wall
was drawn from left to right, the left interior
side would be the side closest to the top of
the screen.
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8. To define the space between an interior sur-
face and the core wall, enter the desired value
in the appropriate Air Space edit box.

9. Click OK.

Lengthening and Shortening
Walls
You can lengthen or shorten a wall by clicking and
dragging one of the wall’s ends, or by editing the
dynamic dimension that appears along its length. If
you choose to lengthen or shorten a wall by clicking
and dragging, and that wall is attached to other walls,
the attached walls will not move or change. However,
if you choose to lengthen or shorten a wall by editing
dynamic dimensions, and that wall is attached to
other walls, the attached walls will move along with
it.
To lengthen or shorten a wall by clicking and
dragging:
1. Select the wall. A grip is displayed at each

wall end.

2. Hover your pointer over the wall end you
want to stretch. The Lengthen cursor is dis-
played .

3. Click and drag the wall end until it has
reached the desired length.

4. Release your mouse button.
To lengthen or shorten a wall by editing dynamic
dimensions:
1. Select the wall.

2. Click on the dimension that appears along
the wall's length.

3. In the Edit Dimension dialog, specify the
desired length for the wall, then specify
which end of the wall you want to stretch or
retract by clicking one of the arrow buttons
next to the length edit box.

4. Click OK.

Editing the Width of a Wall
You can edit the width or thickness of a wall by
making changes on the wall’s Basic property page.
To edit the width of a wall:
1. Select the wall. You can select multiple walls

using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Basic tab.
4. Enter the desired thickness in the Width edit

box in the Core area. Note that the "core" is
the framed structural wall (e.g. stud wall).
The width you enter in the Core area should
not include any interior or exterior surfaces.
There are separate fields for defining the
width of surfaces. See Defining a Wall's Sur-
faces on page 61.

5. Click OK.

Editing the Height of a Wall
You can edit a wall’s height on the wall’s Top and
Bottom property page.
To edit the height of a wall:
1. Select the wall. You can select multiple walls

using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Top and Bot-
tom tab.

4. In the Wall Top area, select the Level option.
5. In the Wall Height edit box, type the desired

wall height.

6. Click OK.
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Lowering or Raising the Exterior
Face of a Wall
You can extend the bottom and/or top of an exterior
wall face in the wall's properties. For example, you
may want to lower the bottom of the exterior face of a
perimeter wall to cover the exposed floor structure
below the wall.
To raise or lower the exterior face of a wall:
1. Select the wall whose properties you want to

change. You can select multiple walls using
Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Basic tab.
4. To raise the top of the exterior wall face, enter

an extension distance in the Raise Exterior
Face Top edit box. To lower the bottom of
the exterior wall face, enter an extension dis-
tance in the Lower Exterior Face Bottom.

5. Click OK.

Forcing Wall Sides to be Exter-
ior
You can force the left and/or right side of a wall to be
an exterior surface by editing the wall's properties.
This can be particularly useful when creating 3D
RealView renderings. Sometimes when a single wall
is drawn (to fill in a gable end, for example), it
appears black when rendered because it is seen as an
interior wall instead of an exterior wall. Forcing sides
of the wall to be exterior ensures that the wall is
rendered using proper materials.
To force wall sides to be exterior:
1. Select the wall.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, enable the Force Left
Side To Be Exterior and/or Force Right
Side To Be Exterior check box. The left/right
sides of a wall are determined by the dir-
ection in which the wall was drawn. If you
click on a wall in your drawing, you will see
one end marked with a green marker, and the
other end marked with a red marker. The

green marker indicates the start point of the
wall, or the point you started drawing from.
The red marker indicates the end point. To
determine the left or right side of the wall,
picture yourself standing at the wall's start
point (green marker) and looking toward the
end point (red marker). Turning your head
left or right while in this position determines
which side is left, and which side is right. For
example, if a wall was drawn from left to
right, the left interior side would be the side
closest to the top of the screen.

4. Click OK.

Making a Wall Invisible in 2D
You may find that you want to hide certain walls in
2D view, such as dormer walls and gable end walls,
to improve the clarity of the view.
To make a wall invisible in 2D:
1. Select the wall. You can select multiple walls

using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Basic tab.
4. Enable the Invisible in 2D check box.
5. Click OK.

Raising or Lowering a Wall
You can raise or lower a wall using the Elevate tool
on the wall’s right-click menu.
To edit the elevation of a wall:
1. Select the wall whose elevation you want to

edit.

2. Right-click and select Elevate, or select Edit >
Modify Elements > Elevate. The value
shown in the Elevate dialog is the current
elevation of the wall.

3. In the Elevate dialog, specify the desired elev-
ation of the bottom of the wall above the
floor.

4. If you are in a 3D or elevation view and
would like to see what the wall looks like at
the new elevation, click Apply. The Elevate
tool remains active while the change is
applied to the wall in your model.
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5. To apply the change and close the dialog,
click OK.

Sloping a Wall
You can slope a wall by setting different heights for
each end of the wall.
To slope a wall:
1. Select the wall.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Top and Bot-
tom tab.

4. To slope the top of the wall, select the Slope
option in the Wall Top area. To slope the bot-
tom of the wall, select the Slope option in the
Wall Bottom area.

5. In the Start Point edit box, type the distance
from the floor to the start point of the slope.
Note that the green wall end marker on the
diagram corresponds to the green wall end
marker on the wall in your drawing. This
way you know which end is which.

6. In the Stop Point edit box, type the distance
from the floor to the end point of the slope.
Note that you do not need to enter a negative
value to slope a wall bottom below floor
level.

7. Click OK.

Stepping a Wall
You can step the top or bottom of a wall by simply
editing the wall’s properties. For example, you may
want to create a stepped foundation to accommodate
a sloped building lot.
To step a wall:
1. Select the wall.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Top and Bot-
tom tab.

4. To step the top of the wall, select the Step
option in the Wall Top area. To step the bot-
tom of the wall, select the Step option in the
Wall Bottom area.

5. In the Start Point edit box, type the distance
from the floor to the start point of the step.
Note that the green wall end marker on the
diagram corresponds to the green wall end
marker on the wall in your drawing. This
way you know which end is which.

6. In the Stop Point edit box, type the distance
from the floor to the end point of the slope.
Note that you do not need to enter a negative
value to step a wall bottom below floor level.

7. Click OK.

Note: If you apply strip footings to stepped wall
bottoms, the footings will automatically step also.

Extending Walls to the Roof
By default, the tops of most walls in the catalog are
set to be level (regardless of the roof type), and their
height is determined by the Wall Height setting of the
building location on which they reside. You can
specify that you want a wall to automatically extend
to the roof, regardless of the Wall Height setting in
your building locations. This is particularly useful for
filling in the pitched areas at gable ends.
To extend walls to the roof:
1. Select the wall that you want to auto-extend

to the roof. You can select additional walls
using Shift+click.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Top and Bot-
tom tab.

4. In the Wall Top area, enable the Auto Extend
option.

5. To rake the external side of the wall, check
the Exterior Wall Tops to Roof check box. If
you want to offset the wall a specific distance
from the roof surface, enter a value in the Off-
set below roof surface edit box.

6. To rake the internal side of the wall, check
the Interior Wall Tops to Roof check box. If
you want to offset the wall a specific distance
from the roof surface, enter a value in the Off-
set below roof surface edit box.

7. Click OK. The walls are adjusted.



Chapter 7: Walls

- 65 -

Tip: If you want to use a different wall material
within the pitched area of a gable end, set the wall
shape to 'Level' in its properties and change the
roof edge properties instead. In a roof's properties
you can choose to display a separate wall in the
pitched area by enabling the Display Gable option
on the roof's Basic property page and selecting the
desired gable Wall Type. This wall can then be
selected independently of the main wall so that you
can control its properties and framing separately.

Making Walls Level
By default, most walls in the catalog are set to have
level tops and bottoms, regardless of the construction
above or below them. If a wall in your drawing has
been stepped, sloped or extended to the roof, you can
specify that you want it to be level instead. As an
example, you would do this if the wall were at a
gable end and you wanted to display a separate
material or wall within the pitched area of the gable
end.
To make a wall level:
1. Select the wall that you want to edit, either in

the catalog or in your drawing.

2. Right-click and select Properties.
3. In the Walls dialog, select the Top and Bot-

tom tab.

4. Enable the Level radio button in either the
Wall Top or Wall Bottom area depending on
which part you want to level.

5. If you are leveling the top of the wall you can
specify the desired height for the wall in the
Wall Height edit box.

6. Click OK.

Moving Walls
You can move one or more walls by clicking and
dragging them, or by editing the dynamic dimensions
that appear on and near walls when you select a wall
in your plan. When you move a wall, any walls
attached to that wall move with it for a stretching
effect.
To move walls by clicking and dragging:

1. Click on the wall that you want to move. To
move multiple walls, use Shift+click to select
the remaining walls.

2. Hover your pointer over the center grip on
the currently selected wall to display the
Move cursor.

3. Click and drag the wall to move it.

4. Release your mouse button.
To move walls by editing dynamic dimensions:
1. Click on the wall that you want to move.

Dimensions appear on any walls that are
attached to the selected wall, indicating the
wall's distance from adjacent walls.

2. Click on the dimension that you want to
change.

3. In the Edit Dimension dialog, type the
desired value for the dimension, then click
OK. The dimension updates, and the wall is
moved.

Rotating a Wall
You can use the Rotate tool to rotate a wall about a
selected point.
To rotate a wall:
1. Select the wall.

2. Right-click and select Rotate, or select Edit >
Modify Elements > Rotate.

3. Position your pointer over the point you
want to rotate the wall around.

4. Click and drag to rotate the wall, then release
your mouse button.



- 66 -

Curving a Wall
You can curve a wall using the Curve tool. Once the
tool is active, you can click and drag the wall to curve
it, or select a point to curve to.
To curve a wall by clicking and dragging:
1. Click the wall to select it.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Click and drag the wall to the desired curve.

4. Release your mouse button.
To curve a wall to a selected point:
1. Click the wall to select it.

2. Right-click in and select Curve, or select Edit
> Modify Elements > Curve.

3. Select the point you want to curve to. The
wall automatically curves to the point.

4. Click to finish.

Breaking a Wall
You can break a wall into two or more segments
using the Break tool. The segments can then be edited
individually.
To break a wall:
1. Click the wall to select it.

2. Right-click in the drawing area and select
Break, or select Edit > Modify Elements >
Break.

3. Click the point where you want to break the
wall. This divides the wall into two segments
that can be moved, stretched or manipulated
individually.

Note: If the wall is a composite wall (framed wall +
veneer), only the framed wall is broken.

Tip: To break a wall into specific lengths, use the
Auto Break tool.

Tip: You can move a wall break by editing the
wall's onscreen dimensions.

Breaking a Wall into Specific
Lengths
You can use the Auto Break tool on a wall's editing
menu to break the wall into lengths of your choice.
This is particularly useful if you are using panelized
construction because it provides precise control over
the length of your panels. By breaking down long
walls you can also avoid exceeding your maximum
panel length.
To break a wall into specific lengths:
1. Select the wall that you want to break, then

right-click and select Auto Break.
2. In the Enter Break Distance dialog, type the

length that you want your wall sections to be,
then press Enter or click OK.

The wall is broken into sections. The end at
which breaking starts depends on the type of
wall you are breaking. If you are breaking a
framed wall, breaking begins according to the
Framing Rule applied to that wall. In other
words, the break direction coincides with the
framing direction. If you are breaking a non-
framed wall, breaking begins at the wall's
start point. (When you select a wall in plan
view, the end with the green grip is the start
point.)

If the wall cannot be broken equally into the
lengths you specified (due to its overall
length), the last wall section will be shorter.

Note: If the wall is a composite wall (framed wall +
veneer), only the framed wall is broken.

Tip: To break a wall anywhere by picking a break
point, use the Break tool instead.

Tip: You can move a wall break by editing the
wall's onscreen dimensions. This changes the
length of the wall panels on either side of the
break.
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Moving Wall Breaks
If you have broken a wall using the Break or Auto
Break tool, you can move a wall break by editing the
wall's onscreen dimensions. Moving a break changes
the length of wall panels on either side of the break.
To move a wall break:
1. Click on the wall segment whose length you

want to edit. A dimension appears along the
length of the wall segment.

2. Click on the onscreen dimension.

3. In the Edit Dimension dialog, type the length
that you want to the wall segment to have,
then click one of the arrows next to the edit
box to specify which end you want to move.
In the example below, if we wanted to make
the selected panel 6 feet long, we would type
6' in the edit box, and then click the left arrow
button to move the left wall break to the left.
The panel would then be resized to 6'.

4. Click OK. The wall break is moved according
to the settings you defined.

Deleting a Wall
You can delete a wall in a couple of easy steps.
To delete a wall:
1. Select the wall to delete. You can select mul-

tiple walls using Shift+click.

2. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.

Note: If your model contains an automatic floor,
the floor will be deleted if the wall you are deleting
opens up the wall layout.

Applying Different Materials to
Walls
You can apply different finishes to your walls using
the handy Materials Paintbrush. The materials catalog
contains an excellent selection of brick, concrete,
wood and stone finishes.
To apply a material to a wall:
1. Display your model in 3D, and make sure the

wall face you want to apply the material to is
visible in the view.

2. Select Edit > Materials Paintbrush, or click
on any tabbed toolbar.

3. In the catalog panel, select the material you
want to apply.

4. Click on the wall face that you want to apply
the material to. The material is immediately
applied.

5. Right-click and select Finish.

Adding Paint and Wallpaper
You can use the Materials Paintbrush to quickly apply
custom paint, wallpaper or wood paneling to a wall.
To apply paint or wallpaper to walls:
1. Display your model in 3D, and make sure the

wall face you want to apply the paint or wall-
paper to is visible in the view.

2. Select Edit > Materials Paintbrush, or click
on any tabbed toolbar.

3. In the catalog panel, select the material you
want to apply. You can filter the material list
to display only wall finishes by selecting
Paint or Wall Material - Interior from the Filter
drop box.

4. Click on the wall face that you want to apply
the paint or wallpaper to. The material is
immediately applied. You can continue apply-
ing the material to other walls if you want.

5. Right-click and select Finish.

Adding Trim to Walls
Trim types include baseboards, crown molding, chair
rails, door/window trim, sills, cove molding,
wainscoting and decorative wallpaper borders. You
can add as many types of trim to a wall as you want,
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and even add different materials to either side of the
wall.

Trim selections are made on a wall’s Trim property
page.
To add trim to walls:
1. Select the wall you want to add trim to.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Walls dialog, select the Trim tab.

4. From the Application drop box, select the
wall side you want to add trim to. Choices
are Exterior Side, Left Interior Side, and Right
Interior Side.

The Exterior Side is the exterior side of an
exterior wall.

The Left Interior Side or Right Interior Side of
a wall depends on the direction in which the
wall is drawn. If you click on a wall in your
drawing, you will see one end marked with a
green marker, and the other end marked with
a red marker. The green marker indicates the
start point of the wall, or the point you
started drawing from. The red marker
indicates the end point. To determine the left
or right side of the wall, picture yourself
standing at the wall's start point (green
marker) and looking toward the end point
(red marker). Turning your head left or right
while in this position determines which side
is left, and which side is right. For example, if
a wall was drawn from left to right, the left
interior side would be the side closest to the
top of the screen.

5. In the list of trim types, select the trim you
would like to select a member for (Crown,
Chair Rail, Baseboard, etc.).

6. Click Select.
7. In the Catalog Access dialog, select the trim

you want to use, then click OK. The trim list
displays the member you selected.

8. To delete the member from the trim list,
select it, then click Delete.

9. In the Apply to area, specify how you would
like the trim applied to the wall. Different
variables are available depending on the trim

type.

Gap. For crown moldings, baseboards and
chair rails, this is the offset of the trim from
the wall face.  

Offset. For crown moldings, this is the offset
of the molding from the top of the wall. For
baseboards and chair rails, this is the offset of
the member from the bottom of the wall. For
trim around windows and doors this is the
offset of the member from the opening.

Extension. For windows and doors that
include head and sill members, this is the
distance by which the member extends past
the edges of the opening.

Offset from wall. If creating custom trim, this
determines where the member is offset from
when an offset is specified. Choose from Wall
Bottom, Wall Top, Ceiling or Floor.

Trim basepoint. If creating custom trim, this
determines which edge of the trim is used to
measure the offset. Choose either Top of Trim
or Bottom of Trim.

10. Once you’ve selected your trim, click OK. The
walls are updated automatically.

Note: You cannot add sills to hexagon or octagon
windows.

Applying a Profile to Trim
By default, trim members in the catalog have a flat
profile. To add interesting detail to your design, you
can apply profiles to trim members by editing trim
properties. You can select a pre-defined profile from
the profiles library, or create your own.
To apply a profile to trim:
1. Select the wall containing the trim that you

want to edit, then right-click and select
Properties.
If the trim does not exist yet in your drawing,
select File > Catalogs > Element Manager,
then select the trim that you want to edit. Go
to step 5.

2. In the Walls dialog, select the Trim tab.
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3. In the Trim list, select the trim type (Crown,
Chair Rail, etc.) that you would like to apply
a profile to, then click Select.

4. In the Catalog Access dialog, select the spe-
cific member that you would like to use, then
right-click and select Edit Element.

5. On the trim's Basic property page, click on
the Custom option in the Type area.

6. Click the Select Profile button.
7. In the Profiles dialog, select the profile that

you would like to use. You can also create a
custom profile if you want.

8. Click OK in the Profiles dialog.
9. Click OK in any remaining dialogs. The

wall’s trim is updated to display the selected
profile.

Adding Corner Details to Walls
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

For architectural detail you can use the Corner Details
tool to add quoins or boards to exterior wall corners.
Just click on a wall to apply.
To add corner details to walls:
1. Select Insert > Detailing > Corner Details, or

click on the Building toolbar.

2. In the catalog panel, select the corner detail
you would like to add. For quoins you can
choose a staggered, mirrored or uniform pat-
tern.

3. Click on the exterior wall corner you would
like to apply the detail to.

4. Right-click and select Finish.

Editing Corner Details
For quoins and corner boards, you can control
properties such as base height, total height, offset, and
number of courses to achieve the exact result you
want.
To edit corner detail properties:
1. Click on the corner detail to select it. This

may be easier to do in 3D view. For quoins,
clicking on one quoin selects the whole set.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties as desired. Each type has
different settings.
Corner Boards

Width. The width of one board.
Thickness. The thickness of the board
material.

Overall Height. The overall height of the
board.

Base Height. The offset of the board from the
bottom of the wall.
Staggered/Mirrored Quoins

Length. The length of the long quoin in the
pattern.

Width. The length of the short quoin in the
pattern.

Offset. The thickness of the quoin material.
Height. The height of one quoin.
Gap. The distance between quoins.
Base Height. The offset of the quoining from
the bottom of the wall.

Number of Courses. The number of quoins
running up each wall.

Overall Height. The overall height of the
quoining according to your settings. This
value cannot be edited.

Reverse Starter Course. Reverses how the
quoining starts at the bottom of the wall. For
example, if the starter course is a staggered
long/short combination, it will be flipped to a
short/long combination.
Uniform Quoins

Length. The length of a quoin.
Offset. The thickness of the quoin material.
Height. The height of one quoin.
Gap. The distance between quoins.
Base Height. The offset of the quoining from
the bottom of the wall.

Number of Courses. The number of quoins
running up each wall.
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Overall Height. The overall height of the
quoining according to your settings. This
value cannot be edited.
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A structure’s support system is an extremely important consideration during all phases of a design project. Support
elements carry the load of walls, floors and other bearing elements in your model, and can also be a factor in the
interior design of your home.

Envisioneer provides the tools to accurately place footings, and columns, and members such as beams in your
design.

You can automatically attach strip footings to selected walls, or draw them manually if you prefer. You can also
automatically insert mono footings beneath columns, or insert them manually anywhere in your design with a click
of your mouse.

Columns and members come in a variety of shapes and sizes, and are inserted with point-and-click simplicity. You
can customize them on the fly to achieve the precise result you want.

This chapter covers the insertion and editing of strip footings, mono footings, and columns and members.

Attaching Strip Footings to Walls
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Since foundation walls bear the weight of exterior walls above them, you need to insert footings beneath the
foundation walls to transfer support for the vertical load.

Strip footings are easy to insert — just click on a wall and a footing is automatically inserted underneath the wall.
Footings automatically shape themselves to the bottom of walls, so if your wall bottoms are curved or stepped, your
footings will be curved or stepped also.
To insert strip footings under walls:
1. Select Insert > Footings > Strip Footings Attached to Walls, or click the down arrow next to the Footings

button on the Building toolbar and select Strip Footings Attached to Walls.

2. In the catalog panel, select the footing you want to insert. Typically you would choose one that is wider
than the wall you are attaching it to.

3. Click on the wall you want to attach the footing to. The footing is inserted automatically. In plan view, strip
footings are usually shown using a dashed line.

4. Continue inserting footings underneath each exterior foundation wall.

5. Right-click and select Finish.

Inserting Strip Footings by Picking Points
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can insert strip footings manually by picking points in your drawing. Using this method you have precise
control over the layout of your strip footings.
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To insert strip footings by picking points:
1. Select Insert > Footings > Strip Footings by

Picking Points, or click the down arrow next
to the Footings button on the Building
toolbar and select Strip Footings by Picking
Points.

2. In the catalog panel, select the footing you
want to insert.

3. Select the start point for the footing, noting
that strip footings are drawn on center.

4. Select an end point for the footing. You can
continue adding sections to the footing if you
want.

5. Right-click and select Finish.

Editing the Shape of a Strip Foot-
ing
Strip footing shapes include rectangular, tapered and
filleted. You can also apply a custom profile to a
footing.
To edit the footing shape:
1. Select the footing whose properties you want

to change. You can select multiple footings
using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Select the Basic tab, then click on the appro-
priate graphic in the Type area. There are sev-
eral profiles to choose from. Each profile has
a unique set of variables in the Properties pane
that you can customize. If you would like to
select or create a custom profile, scroll over
and select Custom, then click the Select Pro-
file button.

4. Click OK.

Editing the Size of Strip Foot-
ings
You can edit the dimensions of a footing on the
footing’s Size property page.
To change the footing size:
1. Select the footing.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Strip Footing dialog, select the Basic
tab.

4. Edit the dimensions of the footing.

5. Click OK.

Moving/Stretching Strip Foot-
ings
When you move a strip footing, all footings attached
to it move with it for a stretching effect. You can
move strip footings by just clicking and dragging.
To move/stretch strip footings:
1. Select the footing to move. You may need to

make walls non-selectable to be able to select
the footing.

2. Position your pointer over the center grip to
display the Move cursor.

3. Click and drag the footing to move it.

4. Release your mouse button.

Note: When you move a strip footing, it becomes
detached from the wall. Therefore, if you move or
stretch the wall, the footing will not go with it. If
you want to re-attach a footing to a wall, you will
need to delete the footing, then insert a new one.

Lengthening and Shortening
Strip Footings
You can lengthen or shorten an individual footing by
clicking and dragging one of the footing’s ends.
To lengthen or shorten a footing:
1. Select the footing. A grip is displayed at each

end.

2. Hover your pointer over the end you want to
stretch. The Lengthen cursor is displayed .

3. Click and drag the footing end until it has
reached the desired length.

4. Release your mouse button.

Breaking Strip Footings
You can break a footing into two or more segments
using the Break tool. The segments can then be edited
individually.

Member_and_Column_Profiles.htm
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To break a footing:
1. Click the footing to select it.

2. Right-click in the drawing area and select
Break, or select Edit > Modify Elements >
Break.

3. Double-click the point where you want to
break the footing.

Attaching Mono Footings to
Columns
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Since support columns in your basement bear loads at
a concentrated point, the load should be transferred to
a proper footing.

Using the Mono Footings Attached to Columns tool
you can insert a single mono footing beneath a
selected column. All you have to do is select the
column.

If you have multiple columns that require the same
footing, you can automatically attach footings to all
columns of the same type in one easy step.
To insert footings under columns:
1. Select Insert > Footings > Mono Footings

Attached to Columns, or click the down
arrow next to the Footings button on the
Building toolbar and select Mono Footings
Attached to Columns.

2. In the catalog panel, select the footing you
want to insert. Typically you would choose
one that is wider than the column you are
attaching it to.

3. If you want to simultaneously insert the foot-
ing under multiple columns of the same type,
right-click and select Attach to all similar.

4. Click on a column to which you want to
attach a footing. The footing is inserted auto-
matically. If you selected Attach to all sim-
ilar in the previous step, a footing will be
automatically inserted under each similar
column found on the current location.

5. Right-click and select Finish.

Inserting Mono Footings by Pick-
ing Points
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a variety of mono footings in your
drawing with point-and-click simplicity.
To insert mono footings by picking points:
1. Select Insert > Footings > Mono Footings

by Picking Points, or click the down arrow
next to the Footings button on the Build-
ing toolbar and select Mono Footings by
Picking Points.

2. In the catalog panel, select the footing you
want to insert.

3. Position the footing where you want it, then
click to insert it.

4. Right-click and select Finish.

Editing the Mono Footing Type
Mono footing types include rectangular, tapered,
cylinder and cylinder tapered. The footing type
determines the footing’s general appearance.
To edit the footing type:
1. Select the footing whose properties you want

to change. You can select multiple footings
using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Select the Basic tab, then click on the appro-
priate graphic in the Type area.

4. Click OK.

Editing the Size of Mono Foot-
ings
You can edit the dimensions of a footing on the
footing’s Size property page.
To change the footing size:
1. Select the footing.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Mono Footing dialog, select the Basic
tab.
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4. Edit the dimensions of the footing.

5. Click OK.

Inserting Columns
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Columns tool to insert a variety of
wood, concrete, steel, brick and gypsum columns in
various shapes and sizes. You may, for example, want
to insert steel posts in the basement to support an I-
beam, or add decorative columns to a room to create
a sense of elegance.
To insert a column:

1. Select Insert > Columns, or click on the
Building toolbar.

2. In the catalog panel, select the column you
want to insert.

3. Position the column where you want it, then
click to insert it.

4. Right-click and select Finish.

Tip: You can apply different profiles to columns in
their properties, and even create and apply your
own custom profiles.

Editing the Shape of a Column
You can choose from a wide variety of column
profiles, such as circular, rectangular, W-shape and C-
shape, or create your own.
To edit the column type:
1. Select the column whose properties you want

to change. You can select multiple columns
using Shift+click if you want.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Select the Basic tab, then click on the appro-
priate graphic in the Type area. There are sev-
eral profiles to choose from. Each profile has
a unique set of variables in the Properties pane
that you can customize. If you would like to
select or create a custom profile, scroll over
and select Custom, then click the Select Pro-
file button.

4. Click OK.

Editing the Dimensions of a
Column
You can edit the dimensions of a column (e.g. height,
width and depth) to suit your needs.
To edit the size of a column:
1. Click on the column to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties as desired. Different
column shapes will have different dimension
variables. Examples are dy1, dx1 and Height.

4. Click OK.

Editing the Elevation of a
Column
You can edit the elevation of a column by editing the
Base Offset setting in its properties.
To edit the elevation of a column:
1. Click on the column to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the value in the Base Offset edit box.
This is the offset of the base of the column
from the floor.

4. Click OK.

Inserting Members
Building Essentials | Construction Suite
You can insert both timber and steel members in your
model to provide structural support where necessary.
For example, you may want to insert an I-beam in the
basement.

You can use the Members tool to insert a horizontal
or sloping member.

You can also insert members using custom settings
that you specify in advance. When you select the
Advanced Members tool, you can specify settings
such as slope, number of members, rotation, usage,
and phase prior to inserting the member. You can
insert a sloping member or a member that matches
the slope of an existing surface using the Advanced
Members tool.

You insert a member by picking a start point and end
point on your screen. This gives you complete control
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over the length, position and direction of the member.
You can choose to break members at walls, columns
and other members if you want.

Tip: You can insert multiple members
simultaneously by specifying a value in your
member insertion settings prior to insertion. When
you insert a single member you can use the Offset
tool on the right-click menu to create multiple
copies of a member in a set pattern. For example,
you could array a floor joist to create a framed sub-
floor.

Inserting Members with Custom
Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Advanced Members tool you can define a
number of custom member settings prior to inserting
the member. For example, you can predefine its slope,
justification, rotation or offset, and attach a specific
phase and usage if desired.

1. Select Insert > Members > Advanced Mem-
bers, or click the arrow next to on the
Building toolbar and select Advanced Mem-
bers.

2. In the Advanced Members dialog, specify
the settings for the member:

Slope Type: If sloping the member, choose
the method for specifying the slope value.
Choices are ? in 12, 1 in ?, Degrees, Percent,
and Select Plane. For the Select Plane option,
click the browse button in the Select Plane
field that is created and then click on the
surface whose plane you want to match. The
name of the surface element will be reported
in the Slope Plane field.
Slope Value. Enter the slope value according
to the selected Slope Type. If the Select Plane
option was selected, this field is labeled
Select Plane instead.
Offset. To offset the member from the
insertion line, enter an offset value here. By
default, members are inserted on center.

Associate With. Associates the member with
a specific type of element. The member will
then be included when filtering that element
in the View Filter dialog. Choose either
None, Roof, Floor, Ceiling, Deck, or
Structural Floor. If None is selected, the
member will be filtered along with standard
Members in the View Filter dialog.
Member. Click the browse button in this field
to select a member from the catalog.

No. of Members. To insert multiple side-by-
side members simultaneously, enter the
number of members that you wish to insert.

Reference Point. By default, members insert
with their topmost face at the insertion point.
This face also serves as a baseline when
rotating a member’s profile. You can edit a
member’s insertion point so that it is at the
center or bottom of the member.

Justification. The alignment of the member
relative to the insertion line.

Rotation. Rotates the member about its
insertion baseline. This ensures that the
member is structurally correct and displayed
properly in 2D and 3D.

Shift. Offsets the member from the picked
start and end points. A positive or negative
value can be entered depending on the
desired shift direction.

Use usage from. To use the usage that is
applied to the member in its properties, select
Member Properties. To select a different usage
from the Usages library, select Library.

Usage. If Member Properties was selected in
the previous field, the member's current
usage is reported in this field. If Library was
selected, click the browse button in this field
to select a usage from the Usages library.

Use phase from. To use the phase that is
applied to the member in its properties, select
Member Properties. To select a different phase
from the Phases library, select Library.

Phase. If Member Properties was selected in
the previous field, the member's current
phase is reported in this field. If Library was



- 76 -

selected, click the browse button in this field
to select a phase from the Phases library.

3. Click Insert.
4. Proceed with inserting the member.

Tip: If you have already launched the standard
Members tool and have selected a member in the
catalog, you can activate the Advanced Members
dialog from the right-click menu prior to inserting
the member.

Inserting a Horizontal Member
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a horizontal member in your drawing
using the Members by Picking Points tool.
To create a horizontal member:
1. Select Insert > Members > Members, or click

on the Building toolbar.

2. In the catalog, select the member you want to
insert.

3. Select a start point for the member, then
move your mouse in the direction you want
the member to run.

4. Once the member is the desired length, click
to select its end point. You can continue
adding sections to the member if you want.

5. Right-click and select Finish.

Inserting a Sloping Member
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Advanced Members tool provides an easy way of
inserting a sloping member in your drawing. When
using the Advanced Members tool, you can predefine
the slope value along with other settings before
inserting the member.

Alternatively you can insert a sloping member with
the Members tool. With this method you define the
slope of the member by entering the heights of each
end in the Commander.
To create a sloping member with the Advanced
Members tool:

1. Select Insert > Members > Advanced Mem-
bers, or click the arrow next to on the
Building toolbar and select Advanced Mem-
bers.

2. In the Advanced Members dialog, select the
desired method for specifying the slope value
from the Slope Type drop box, then specify
the desired slope value in the Slope Value
field. By default, the start point of the mem-
ber will be inserted at floor level. To offset
the start point so that it is higher or lower,
specify a value in the Offset field.

3. Click Insert.
4. Select the member's start point and end point,

then right-click and select Finish.

To create a sloping member with the Members
tool:
1. Select Insert > Members > Members, or click

the arrow next to on the Building toolbar
and select Members.

2. In the catalog, select the member you want to
insert.

3. The Base Height edit box is displayed in the
Commander. Type the desired height for the
first end (start point) of the member, then
press ENTER.

4. Select a start point for the member.

5. Move your mouse to stretch the member to
the desired length, or enter a value in the
Commander’s Distance edit box.

6. Press the Tab key twice to move to the Com-
mander’s Z edit box.

7. Type the desired height for the other end of
the member, then press ENTER.

8. You can continue adding segments to the
member if you want.

9. When the member is complete, right-click
and select Finish.

Note: If you want to insert a member that matches
the slope of an existing surface, choose Select
Plane from the Slope Type drop box when
specifying the member's insertion settings. See
Inserting a Member by Matching a Plane.
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Inserting a Member by Matching
a Plane
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Advanced Members tool to insert a
member that matches the plane of an existing roof,
floor or ceiling surface.
To insert a member by matching a plane:
1. Select Insert > Members > Advanced Mem-

bers, or click the down arrow next to the
Members button on the Building toolbar
and select Advanced Members .

2. In the Advanced Members dialog, click the
Slope Type drop box and choose Select
Plane.

3. Click in the newly created Select Plane field,
then click the browse button that appears in
the field. This takes you out to your drawing.

4. Click on the edge of the surface whose plane
you want to match the member to. (Selecting
the surface defines the plane.) The name of
the surface is displayed in the Select Plane
field in the Advanced Members dialog.

5. Select a member type and specify any other
settings that you want the member to have.

6. Click Insert.
7. Select a start point for the member, then

move your mouse in the direction you want
the member to run. Note that the member
does not need to be drawn on the surface. It
can be anywhere in space.

8. Once the member is the desired length, click
to select its end point. You can continue
adding sections to the member if you want.

9. Right-click and select Finish.

Note: You can use the Adjust to Plane tool on the
right-click menu to match any existing member to
the slope of an existing surface.

Inserting Multiple Members Sim-
ultaneously
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Prior to inserting a member you can specify that you
want to insert multiple copies of the member at the
same time. For example, you may want to do this in
areas where a member needs to be doubled or tripled
for extra stability.
To insert multiple members simultaneously:
1. Select Insert > Members > Advanced Mem-

bers, or click the arrow next to on the
Building toolbar and select Advanced Mem-
bers.

2. In the Member Insertion Options dialog, spe-
cify the desired number of members to insert
in the No. of Members edit box. Members
will be inserted side by side. Specify any
other desired settings, such as the member
type.

3. Click Insert.
4. Proceed with inserting the members. As you

draw, the specified number of members are
created.

Inserting Trusses and Portal
Frames
Building Essentials | Construction Suite

You can use a Timber Frames tool to add trusses or
portal frames to your model.

Truss types include the scissor truss, tray truss, and
attic truss.

A portal frame is a simple structure comprising
rafters connected to a pair of columns. Portal frame
construction is typically found in single-story or low-
rise structures with large open spaces, such as barns
and warehouses.

When inserting timber frames, you can insert a single
frame, or a series of frames that span a specified
distance. The catalog contains a variety of trusses and
portal frames that you can customize to suit your
needs.
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Note: You can use the Truss Run tool to insert truss
profiles under an existing roof surface.

To insert a series of trusses or portal frames:
1. Select Insert > Members > Timber Frames >

Insert Timber Frames, or click the down
arrow next to the Members button on the
Building toolbar and select Insert Timber
Frames.

2. In the catalog panel, select the truss or portal
frame that you would like to insert. If you
would like to specify the spacing between
frames, double-click the element in the cata-
log, then specify the spacing properties in the
Timber Framing (Catalog) dialog. You can
specify the select Maximum Spacing
between frames, and whether or not they
need to be evenly spaced. You can also spe-
cify the Support Height of the frames, and
various sizing and design settings.

3. Select an insertion point for the first frame,
then select a second point to define the length
of the span. Frames will be inserted along this
span at the spacing specified in the element's
properties.

4. Initially, the frames will be centered on the
insertion line. To keep them centered on the
insertion line, press Enter, or right-click and
select Center. To offset the frames to either
side of the insertion line, move your cursor in
the desired direction until the frames have
flipped to that side of the insertion line, then

click to anchor them in place. Or, right-click
and select either Left ort Right.

To insert a single truss or portal frame:
1. Select Insert > Members > Timber Frames >

Insert Single Timber Frame, or click the
down arrow next to the Members button
on the Building toolbar and select Insert
Single Timber Frame.

2. In the catalog panel, select the truss or portal
frame that you would like to insert.

3. Select two points to define the length of the
frame.

Editing Truss and Portal Frame
Properties
Building Essentials | Construction Suite
Truss and portal frame elements are inserted using
Timber Frames tools. You can customize the
properties of trusses and portal frames in the catalog,
or ones that you have already inserted. For example,
you may want to edit the support height of the
element, the spacing between frames, or the length of
members that compose the truss or frame.

To edit the properties of truss or portal frame
properties in the catalog, double-click the element in
the catalog, or right-click and select Edit Element.
To edit the properties of an inserted timber frame
element, select the element, then right-click and select
Properties.
Properties are defined on two tabs in the Timber
Framing dialog:
General tab:

Type. Choose either Cathedral Truss, Attic Truss, Half
Truss, Portal Frame, Fink Truss, or Flat Trussto define
the general shape and layout of the element.
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Support Height. The height at which the bottom
chord sits. For a portal frame, this also determines
how long the lower vertical supports will be.

Maximum Spacing. The maximum distance that can
exist between frames when inserted as a series (using
Insert Timber Frames).

Space Evenly. If enabled, frames inserted in a series
will be evenly spaced across the span, meaning that
the distance between frames may be less than the
Maximum Spacing value. If disabled, the tool will
insert frames at the maximum spacing until it runs
out of space within the specified span. This could
result in a gap at the end of the span, but will
maintain the maximum spacing value between
inserted frames.

Bottom Chord Position. I.
a. The length of the top chord.
a1 - Slope value. The pitch of the top chord
measured using the Slope Type method selected
below.

Slope Type. The method used to measure the pitch of
the top chord. Choose from Degrees, ? in 12, 1 in ?, or
Percent.

b. The length of the bottom chord.

Depending on the type chosen, additional properties
(such as c and d) may be available. Use the diagram
as a guide when specifying these properties.

Specify Framing. Click to select the desired member
type for the truss/frame members.
Detail tab:
Member Groups
For each member type that makes up the truss or
portal frame (e.g. Top Chord, Bottom Chord, Bracing),
you can specify the following parameters:

Use member from. To use the Framing Member
assigned to the element on the General property page,
select Properties. To use a specific member from the
member library, select Member Library, then make a
selection from the Catalog Access dialog. The latter
option overrides the Framing Member selection on
the General property page.

Name. If Properties is selected in the 'Use member
from' field, the Name field displays a generic
description, 'Timber Frame Member', indicating that
the member to be used is the one selected on the

element's General property page. If Member Library is
selected in the 'Use member from' field, the Member
field displays the member type to be used (as selected
from the Member library). To select a different
member, click in this field and then click to
display the Catalog Access dialog.
Rotation. The rotation of the member about its center
line (core). Click the down arrow in this field to select
the angle of rotation (0°, 90°, 180° or 270°).

Number of Members. Specify the number of
members of this type to include: 1 or 2.

Usage. What the member will be used for. Usages
can be used as sort keys in estimates and reports. To
select a usage, click in this field and then click to
display the Usages library.
Phase. The building stage or process in which this
member will be used. Phases can be used as sort keys
in estimates and quantity reports. To select a phase,
click in this field and then click to display the
Phases library.
Top Extension. The distance the inner webbing
members (if present) project into the top chord.

Bottom Extension. The distance the inner webbing
members (if present) project into the bottom chord.

Bottom Cut. Specify how the member ends are cut by
selecting either Square, Flush, or Plumb.
Individual Members
For individual members within each member group,
you can specify the following parameters:

Name. The name of the member as it appears in the
left pane.

Offset from centerline. The offset of the member
from the centerline of the frame. A positive value
brings it forward, while a negative value pushes it
toward the back.

Editing a Member's Insertion
Reference Point
By default, members insert with their topmost face at
the insertion point. This face also serves as a baseline
when rotating a member’s profile. You can edit a
member’s insertion point so that it is at the center or
bottom of the member. You can do this before or after
inserting a member.
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To edit a member’s insertion reference point:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, select the Details tab.
4. In the Insertion Reference area, select either the

top, center or bottom Reference Point.
5. Click OK.

Rotating a Member's Profile
Editing a member’s Profile Rotation setting rotates the
member about its insertion baseline. This ensures that
your members are structurally correct and displayed
properly in 2D and 3D.
To rotate a member’s profile:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, select the Details tab.
4. In the Insertion Reference area, edit the rotation

in the Profile Rotation edit box.

5. Click OK.

Lengthening or Shortening a
Member
Building Essentials | Construction Suite
You can lengthen or shorten a member by clicking
and dragging one of its end points. Note that if your
member has multiple segments, you can
lengthen/shorten the individual segments.
To lengthen or shorten a member:
1. Select the member. A grip is displayed at

each end of the member.

2. Hover your pointer over the end you want to
stretch. The Lengthen cursor is displayed .

3. Click and drag to stretch the member to the
desired length, then release your mouse but-
ton.

Extending/Trimming Members
to a Cutting Edge
You can use the Lengthen to Fence tool to lengthen or
shorten multiple members to a cutting edge that you
define.
To extend/trim members to a cutting edge:
1. Select the members that you want to

extend/trim. The quickest way to select a
group of members is to click and drag a selec-
tion window through them.

2. With the members selected, right-click and
select Lengthen to Fence, or select Edit >
Modify Elements > Lengthen to Fence.

3. Select a start point for the cutting edge, then
select the end point. The cutting edge is
simply a line to which the ends of members
will be extended or trimmed.

Note: The member end that is closest to the cutting
edge will be the end that is extended/trimmed.

Breaking a Member
You can use the Break tool to divide a member into
independent segments. These segments can then be
edited individually if desired.
To break a member:
1. Select the member.

2. Right-click and select Break, or select Edit >
Modify Elements > Break.

3. Click the point on the selected member where
you want to break it. The member is auto-
matically broken into two segments.
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Breaking Members at Other Ele-
ments
Building Essentials | Construction Suite
You can force a member to break at the center line of
walls, columns, and other members.
To break members at other elements:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, select the Details tab.
4. Enable the appropriate check boxes — Break

at Walls, Break at Columns or Break at
Members. When a check box is enabled, the
member will be broken when it encounters
that element.

5. Click OK in the Members dialog.
6. Adjust the member slightly by stretching or

moving it. This forces the break into place,
and updates the grip display.

Offsetting a Member
Building Essentials | Construction Suite
You can use the Offset tool to offset a member a set
number of times in a set direction.
To offset a member:
1. Select the member.

2. Right-click and select Offset, or select Edit >
Modify Elements > Offset.

3. In the Offset dialog, type the distance you
want to offset the member in the Offset
Distance edit box.

4. In the Number of Copies edit box, type the
number of copies you want to create, or use
the arrow keys to increase or decrease the
number.

5. Click OK.
6. Click on the side you want to offset to. The

member is offset.

Adjusting a Member to a Plane
You can use the Adjust to Plane tool to match any
member to the slope an existing roof, floor or ceiling
surface.
To adjust a member to a plane:

1. Select the member.

2. Right-click and select Adjust to Plane, or
select Edit > Modify Elements > Adjust to
Plane.

3. In the Adjust to Plane dialog, click in the
Select Plane field, then click the browse but-
ton that appears in the field. This takes you
out to your drawing.

4. Click on the edge of the surface whose plane
you want to match the member to. (Selecting
the surface defines the plane.) The name of
the surface is displayed in the Select Plane
field.

5. To offset the member vertically from its cur-
rent position, enter a value in the Offset field.

6. Click OK. The member takes on the slope of
the selected plane.

Extending a Member to a Plane
Building Essentials | Construction Suite
You can use the Extend to Plane tool to automatically
extend a member to the plane of a selected surface.
The end of the member will be mitered accordingly.
To extend a member to a plane:
1. Click on the member, then right-click and

select Extend to Plane.
2. Click on the surface whose plane you want to

extend the member to.

3. Click on the member end that you want to
extend. The member is automatically exten-
ded to the selected plane.

Editing the Shape of a Member
Building Essentials | Construction Suite
You can choose from a wide variety of member
shapes, or create your own profile.
To edit a member’s shape:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, click on the appro-
priate graphic in the Type area. There are sev-
eral profiles to choose from. Each profile has
a unique set of variables in the Properties pane
that you can customize. If you would like to
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select or create a custom profile, scroll over
and select Custom, then click the Select Pro-
file button.

4. Click OK.

Editing the Dimensions of a
Member
You can edit the dimensions of a member (e.g. width
and depth) to suit your needs.
To edit the dimensions of a member:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the dimensions in the Properties window.
The variables in this window vary depending
on the shape chosen. Clicking on a dimension
variable in the dimensioned graphic auto-
matically highlights the corresponding dimen-
sion in the Properties window, and vice versa.

4. Click OK.

Defining the Ends of a Member
Building Essentials | Construction Suite
You can specify whether you want the ends of a
member to be plumb or square. Each end can be
different.
To define the ends of a member:
1. Select the member.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, select the Details tab.
4. In the End Conditions area, select either

Plumb or Square for each end of the mem-
ber.

5. Click OK.

Mitering Members
You can specify whether or not you want each end of
a member to miter when it is connected to another
member. By default most members in the catalog
(except gutters) are not set to miter.
To miter members:

1. Select the member(s) that you want to miter.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Members dialog, select the Details tab.

4. In the End Conditions area, enable the Miter if
Possible check box for each end that you
want to miter.

5. Click OK.

Note: Members that you want to miter must be on
the same plane, and must be connected (i.e. share a
node).

Note: In order for two members to miter, both
must have the Miter if Possible option enabled.
Currently you can only miter two members. In a
situation where there are three members or more,
you need to disable the Miter if Possible option for
the third member if you want the other two to be
mitered.
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Once you’ve drawn walls, you can insert a variety of doors, windows and openings in them to create the exact
design you want. Like all elements in Envisioneer, doors, windows and openings are intelligent. They know that
they can only be inserted in walls. As soon as your pointer gets close to a wall, they snap into place. All you have to
do is position it where you want it along the wall, then click to insert it.

Dimensions are displayed as you are positioning the element so you can get the precise placement you want. Even
though doors, windows and openings automatically become associated with the walls they are inserted in, you can
edit them independently if you want.

Inserting Doors
Personal Architect | Pro Architect | Building Essentials | Construction Suite

The catalog contains a wide variety of doors for you to insert, including hinged, bi-fold, pocket, sliding glass and
garage doors. You can point and click to insert a door anywhere inside a wall, automatically center the door in the
wall, or offset the door a specific distance from the end of the wall.

Doors are inserted at floor level. You can raise or lower a door after you have inserted it if you need to.
To insert a door:
1. Make sure the location you want to insert doors on is the current location in the building locations drop

box.

2. Select Insert > Doors, or click on the Building toolbar.

3. In the catalog, select the door you want to insert.

4. If you want the door to be automatically centered on the wall, right-click and select Center on wall. Go to
step 6.

5. If you want to offset the door a specific distance from the end of the wall, right-click and select Enter inser-
tion offset. Enter the offset distance in the Enter insertion offset dialog, then click OK.

6. Position the door in the receiving wall. If you are using an insertion offset, position the door close to the end
you want to offset it from. The door will snap inside the wall. Dimensions are displayed that show you the
distance on either side of the door.

7. With your door positioned where you want it, click to insert it.

8. Right-click and select Finish.

Moving a Door
You can move a door by clicking and dragging it inside the wall, or by editing the dynamic dimensions on either
side of the door. You can move a door in both 2D and 3D.
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To move a door by clicking and dragging:
1. Click on the door to select it.

2. Click and drag the door to move it, then
release your mouse button. If you are moving
a door in 3D, make sure that you select the
center grip.

To move a door by editing dimensions:
1. Click on the door. Dynamic dimensions

appear on either side of the door.

2. Click on the dimension you want to edit.

3. In the Edit Dimension dialog, enter the new
value, then press Enter or click OK. The door
position updates automatically.

Flipping a Door
You can use the Flip Opening tool to flip an entire
door around. If the door originally opened out, it now
opens in; if it was hinged on the left, it is now hinged
on the right (and vice versa).
To flip a door:
1. Click the door to select it.

2. Right-click in the drawing area and select
Flip Opening, or select Edit > Modify Ele-
ments > Flip Opening.

Flipping a Door Swing
Use the Flip Swing tool to flip only the swing of a
door. The door will be hinged on the opposite side,
but it will still open in the same direction, either in or
out.
To flip a door swing:
1. Click the door to select it.

2. Right-click in the drawing area and select
Flip Swing, or select Edit > Modify Elements
> Flip Swing.

Editing Door Swing Properties
You can specify the direction of a door swing as well
as the extent of the swing in 2D and 3D.
To edit door swing properties:
1. Select the door whose swing properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, edit the settings in the
Swing area of the Basic page.

Swing Type. Choose from Left, Right or
Double. A door with a left door swing will
have its hinges on the right. 

Operable Side. Choose from Left, Right or
Double. This is for double doors only. The
door that is inoperable will be closed in all
views.

3D % Open. How much the door is shown
swung open in 3D view. By default, doors are
shown closed in 3D view.

2D % Open. How much the door is swung
open in 2D plan view.

4. Click OK.

Tip: You can quickly flip a door swing using the
Flip Swing tool on the right-click menu.

Tip: To specify how door swing direction is
represented in your region, see Specifying the
Definition of a Right-hand vs Left-hand Door on page
84.

Specifying the Definition of a
Right-hand vs Left-hand Door
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The concept of a right-hand vs left-hand door differs
around the world.
To specify how the door swing direction is defined
in your region:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Build-
ing Aids in the left column.

3. In the Door Swing Direction area, select the
option that represents the way you typically
reference right-hand and left-hand doors:
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4. Click OK.

Editing Door Types
Door types include hinged, bi-fold, pocket, face slider,
track slider, fold-up, tilt, roller, and pivot. You can
edit a door’s type on the door’s Basic property page.
To edit a door type:
1. Select the door whose properties you want to

change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Basic tab.
4. In the Type area, click on the desired door

type to select it.

5. Click OK.

Editing the Size of a Door
You can edit the height or width of a door.
To edit the size of a door:
1. Select the door whose size you want to

change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, enter the desired values
in the Height and Width edit boxes on the
Basic page.

4. Click OK.
Tip: You can also stretch a door opening dynamically
by clicking and dragging its side grips if displayed.
See Stretching Doors, Windows and Openings for
more information.

Editing the Shape of a Door
A door can be rectangular, arched or apexed. Note
that you can only change the shape of a hinged door
type.
To edit the shape of a door:

1. Select the door whose shape you want to
change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select either Rectangular,
Arched or Apexed from the Shape drop box.

4. Edit the door’s size properties if needed.

5. Click OK.

Displaying a Highlite or Sidelites
on a Door
A sidelite is a glass panel set on one or both sides of a
door (usually an entry door). A highlite is a glass
panel above a door. You can choose which lites which
you want to display.
To display lites on a door:
1. Select the door.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Basic tab.
4. To display a highlite over the door, enable

the Display Highlite check box.
5. To display a sidelite on the left side of the

door, enable the Display Left Sidelite check
box.

6. To display a sidelite on the right side of the
door, enable the Display Right Sidelite check
box.

7. Click OK.

Editing a Door's Sidelites and
Highlites
A sidelite is a glass panel set on one or both sides of a
door (usually an entry door). A highlite is a glass
panel above a door. You can create a custom
configuration of sidelites and/or highlights for a door.
To edit sidelites and highlites:
1. Select the door whose properties you want to

change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Lites tab.
4. In the Type window, select the lite you want

to specify settings for. Note that the lite must
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be enabled on the Basic page before you can
edit it.

5. To select a specific window type for the cur-
rently selected lite, click on the appropriate
graphic in the Type area.

6. Edit the dimensions of the lite in the Prop-
erties area if desired. Clicking a dimension
marked with an alphabetical character (a, b, c,
etc.) highlights the corresponding dimension
in the sidelite/highlite graphic, and vice versa.
Shape. Choose from Rectangle, Arched or
Trapezoid.

(highlite) Adjust Width. Selecting Opening
adjusts the width of the highlite to match the
width of the opening (including any
sidelites). Selecting Door adjusts the width of
the highlite to match the width of the door
(excluding any sidelites). Selecting User
Defined lets you specify a precise width for
the highlite in the Width edit box.
Width. The total width of the lite.
(sidelites) Adjust Height to Door.
Automatically adjusts the height of a sidelite
to match the height of the door.

Height. The overall height of the lite.
# of Horizontal Panels. The number of
panels across the lite. If you specify more
than one panel, vertical dividers are added
inside the lite’s frame.

# of Vertical Panels. The number of panels
running vertically along the lite. If you
specify more than one panel, horizontal
dividers are added inside the lite’s frame.

# of Horizontal Panes. The number of panes
of glass across each panel.

# of Vertical Panes. The number of panes of
glass running vertically along each panel.

Editing a Door's Energy Prop-
erties
The rate of heat loss through a door is indicated in
terms of the U-factor. You can specify a door's U-
factor, and whether or not you want to include it in
energy calculations.
To edit a door's energy properties:

1. Select the door.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Basic tab.
4. To include the U-factor in calculations when

exporting the model to building energy soft-
ware, enable the Include in Calculations
check box in the Energy area.

5. To specify the U-factor, edit the value in the
U-Factor edit box.

To display the U-factor in door schedules, you need
to add a U-Factor field to the door schedule layout.
See Defining the Field Layout of a Schedule on page 374.

Editing a Door's Leaf
You can choose from a variety of door leaf types and
change the thickness of the leaf.
To edit a door’s leaf:
1. Select the door whose properties you want to

change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Leaf tab.
4. In the Type area, click on the leaf type you

want. If you would like to use a custom door
leaf that has been imported into the Door
Leafs library, select the Custom type, then
select the desired leaf from the library.

5. If you want to change the thickness of the
leaf, enter the thickness in the Leaf Depth
edit box.

6. Each door leaf type has its own set of dimen-
sions that you can define. These dimensions
vary according to how many panels the leaf
has. Clicking a dimension marked with an
alphabetical character (a, b, c, etc.) highlights
the corresponding dimension in the door leaf
graphic, and vice versa.

7. Click OK.

Editing Door Details
You can specify precise dimensions and offsets for the
door frame, sash, mullions and transoms.
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To edit door details:
1. Select the door whose properties you want to

change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Doors dialog, select the Details tab.
4. Edit the dimensions as desired.

Frame

Depth. The depth of the frame members as
seen from an overhead view.

Width. The width of the frame members as
seen from an overhead view.

Offset. The offset of the door frame from the
wall face.
Sash

Depth. The depth of sash members
(sidelite/highlite frame) as seen from an
overhead view.

Width. The width of sash members as seen
from an overhead view.

Offset. The offset of the sash from the front
of the door frame, i.e. how far back it sits in
the door frame.
Mullion

Vertical Separation. If a lite has two or more
panels running across it, this adds vertical
dividers between the panels.

Horizontal Separation. If a lite has two or
more stacked panels, this adds horizontal
dividers between them.

Depth. The front-to-back thickness of the
mullion as seen from an overhead view.

Width. The width (left-to-right distance) of
the mullion as seen from an overhead view.
Transom

Depth. The front-to-back thickness of the
transom member as seen from an overhead
view. The transom is the member between
the door and the sidelite or highlite frame.

Width. The width of the transom as seen
from an overhead view.

5. Click OK.

Displaying/Hiding Trim Around
a Door Opening
By default, door openings include trim around them if
a trim member is specified for openings in the wall’s
Trim properties. You can turn opening trim on or off
for individual door openings.
To control the display of trim around a door:
1. Select the door, then right-click and select

Properties.
2. In the Doors dialog, enable or disable the

Include Opening Trim check box. For a gar-
age door you can display or hide a door sill
using the Include Sill option.

3. Click OK.

Inserting Windows
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a wide variety of windows for
you to insert, including fixed, casement, double
casement, hopper, awning, sliding, double-hung,
single-hung, bay, bow and louvered windows.

You can point and click to insert a window anywhere
in a wall, automatically center the window on the
wall, or offset the window a specific distance from the
end of the wall.

Windows are inserted at the Head Height defined for
the building location you insert the window on. You
can raise or lower a window after you have inserted it
if you need to.
To insert a window:
1. Make sure the location you want to insert

windows on is the current location in the
building locations drop box.

2. Select Insert > Windows, or click on the
Building toolbar.

3. In the catalog, select the window you want to
insert.

4. If you want the window to be automatically
centered on the wall, right-click and select
Center on wall. Go to step 6.

5. If you want to offset the window a specific
distance from the end of the wall, right-click
and select Enter insertion offset. Enter the
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offset distance in the Enter insertion offset
dialog, then click OK.

6. Position the window in the receiving wall. If
you are using an insertion offset, position the
window close to the end you want to offset it
from. The window will snap inside the wall.
Dimensions are displayed that show you the
distance on either side of the window.

7. With your window positioned where you
want it, click to insert it.

8. Right-click and select Finish.

Moving a Window
You can move a window by clicking and dragging it
inside the wall, or by editing the dynamic dimensions
on either side of the window. You can move a
window in both 2D and 3D.
To move a window by clicking and dragging:
1. Click on the window to select it.

2. Click and drag the window to move it, then
release your mouse button. If you are moving
a window in 3D, make sure that you select
the center grip.

To move a window by editing dimensions:
1. Click on the window. Dynamic dimensions

appear on either side of the window.

2. Click on the dimension you want to edit.

3. In the Edit Dimension dialog, enter the new
value, then press Enter or click OK. The win-
dow position updates automatically.

Flipping a Window
You can use the Flip Opening tool to instantly flip a
window around in the wall. If the window has a
swing, the swing is also flipped.
To flip a window:
1. Select the window.

2. Right-click in the drawing area and select
Flip Opening, or select Edit > Modify Ele-
ments > Flip Opening.

Editing Window Types
Window types include fixed, casement, hung, sliding,
awning, hopper, vent, bay, bow and louver. You can

edit a window’s type on the window’s Basic property
page.
To edit a window type:
1. Select the window whose properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Basic tab.
4. In the Type area, click on the desired window

type to select it.

5. Click OK.

Editing a Window's Size Prop-
erties
You can edit the height and width of a window. You
can also control the number of horizontal and vertical
panes in the window. Some window types have
additional properties that define their geometry.
To edit the size of a window:
1. Select the window whose properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Basic tab.
4. Edit the dimensions as desired. Clicking a

dimension marked with an alphabetical
character (a, b, c, etc.) highlights the
corresponding dimension in the window
graphic, and vice versa.

Most windows have the common dimensions
listed below. Some have additional settings to
define their geometry. 

Window Width. The width of the window,
not including the frame.

Window Height. The height of the window.
# of Horizontal Panels. The number of
window panels running horizontally across
the window frame. If you specify more than
one panel, vertical dividers are added inside
the window frame.

# of Vertical Panels. The number of window
panels running vertically along the window
frame. If you specify more than one panel,
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horizontal dividers are added inside the
window frame.

# of Horizontal Panes. The number of panes
of glass across each window panel.

# of Vertical Panes. The number of panes of
glass running vertically along each window
panel.

5. Click OK

Tip: You can also stretch a window opening
dynamically by clicking and dragging its side grips
if displayed. See Stretching Doors, Windows and
Openings for more information.

Displaying a Highlite, Lowlite or
Sidelites on a Window
A sidelite is a glass panel set on one or both sides of a
window. A highlite is a glass panel above a window.
A lowlite is a glass panel below a window. You can
choose which lites which you want to display.
To display lites on a window:
1. Select the window.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Basic tab.
4. To display a highlite over the window, enable

the Display Highlite check box.
5. To display a lowlite under the window,

enable the Display Lowlite check box.
6. To display a sidelite on the left side of the

window, enable the Display Left Sidelite
check box.

7. To display a sidelite on the right side of the
window, enable the Display Right Sidelite
check box.

8. Click OK.

Editing a Window's Sidelites,
Highlites and Lowlites
A sidelite is a glass panel set on one or both sides of a
window. A highlite is a glass panel above a window.
A lowlite is a glass panel below a window. You can
create a custom configuration of sidelites, highlites
and lowlites for a window.
To edit a window’s lites:

1. Select the window whose properties you
want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Lites tab.
4. In the Type area select the lite you want to

specify settings for. Note that the lite must be
enabled on the Basic page before you can edit
it.

5. To select a specific window type for the cur-
rently selected lite, click on the appropriate
graphic in the Type area.

6. Edit the dimensions of the lite in the
Properties area if desired. Clicking a
dimension marked with an alphabetical
character (a, b, c, etc.) highlights the
corresponding dimension in the
sidelite/highlite graphic, and vice versa.

Shape. Choose from Rectangle, Arched or
Trapezoid. 

(highlite/lowlite) Adjust Width. Selecting
Opening adjusts the width of the highlite to
match the width of the opening (including
any sidelites). Selecting Window adjusts the
width of the highlite to match the width of
the window (excluding any sidelites).
Selecting User Defined lets you specify a
precise width for the highlite in the Width
edit box.

Width. The total width of the lite.
(sidelites) Adjust Height to Window.
Automatically adjusts the height of a sidelite
to match the height of the window.

Height. The overall height of the lite.
# of Horizontal Panels. The number of
panels across the lite. If you specify more
than one panel, vertical dividers are added
inside the lite’s frame.

# of Vertical Panels. The number of panels
running vertically along the lite. If you
specify more than one panel, horizontal
dividers are added inside the lite’s frame.

# of Horizontal Panes. The number of panes
of glass across each panel.
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# of Vertical Panes. The number of panes of
glass running vertically along each panel.

7. Click OK.

Editing a Window's Energy Prop-
erties
You can specify a window's frame type, glaze type, U-
factor, and SHGC.
To edit a window's energy properties:
1. Select the window.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Basic tab.
4. In the Energy area, specify the following

properties:

Include in Calculations. Check to include
the energy property values in calculations
when exporting the model to building energy
software.

Frame Type. Select Metal, Metal w Thermal,
Wood, or Vinyl.
Glaze Type. Select Single Pane, Double
Pane, Double Pane Low E, Triple Pane, or
Triple Pane Low E.
U-Factor. The rate of heat loss through the
window.

SHGC. Solar Heat Gain Coefficient. The
amount of solar radiation that passes through
the window. Expressed as a number between
0 and 1.

To display the U-factor in window schedules, you
need to add a U-Factor field to the schedule layout.
See Defining the Field Layout of a Schedule on page 374.

Editing Window Details
You can specify precise dimensions and offsets for the
window frame, sash, mullions and transoms.
To edit window details:
1. Select the window whose properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Windows dialog, select the Details tab.
4. Edit the dimensions as desired.

Frame

Depth. The depth of the frame members as
seen from an overhead view.

Width. The width of the frame members as
seen from an overhead view.

Offset. The offset of the window frame from
the wall face.
Sash

Depth. The depth of sash members
(sidelite/highlite/lowlite frame) as seen from
an overhead view.

Width. The width of sash members as seen
from an overhead view.

Offset. The offset of the sash from the front
of the window frame, i.e. how far back it sits
in the window frame.
Post (for Bays and Bows)

Depth: The thickness of posts in bay and bow
windows.

Width: The width of posts in bay and bow
windows.
Mullion

Vertical Separation. If a lite has two or more
panels running across it, this adds vertical
dividers between the panels.

Horizontal Separation. If a lite has two or
more stacked panels, this adds horizontal
dividers between them.

Depth. The front-to-back thickness of the
mullion as seen from an overhead view.

Width. The width (left-to-right distance) of
the mullion as seen from an overhead view.
Transom (for Lites)

Depth. The front-to-back thickness of the
transom member as seen from an overhead
view. The transom is the member between
the window and the sidelite, highlite or
lowlite frame.
Width. The width of the transom as seen
from an overhead view.

5. Click OK.
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Displaying/Hiding Trim Around
a Window Opening
By default, window openings include trim around
them if a trim member is specified for openings in the
wall’s Trim properties. You can turn opening trim on
or off for individual window openings.
To control the display of trim around a window
opening:
1. Select the window, then right-click and select

Properties.
2. In the Windows dialog, disable the Include

Opening Trim check box.

3. Click OK.

Controlling the Display of Win-
dow Opening Symbols
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, swing-type windows display symbols that
indicate the swing direction. These symbols are visible
in 3D and elevation views. You can choose between
two methods of displaying the symbols depending on
your region, or disable the symbols altogether.
To control the display of window opening
symbols:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left column.

3. In the Window Opening Symbols area, select
either Type 1 or Type 2. If you want to dis-
able window opening symbols, select None.

4. Click OK.

Inserting Wall Openings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

An opening is a cutout in a wall of a specific shape,
width and height. Openings can be rectangular,
round, arched, octagonal or trapezoidal.

You can point and click to insert an opening
anywhere in a wall, automatically center the opening
on the wall, or offset the opening a specific distance
from the end of the wall.

To insert an opening:
1. Make sure the location you want to insert

openings on is the current location in the
building locations drop box.

2. Select Insert > Openings, or click on the
Building toolbar.

3. In the catalog, select the opening you want to
insert.

4. If you want the opening to be automatically
centered on the wall, right-click and select
Center on wall. Go to step 6.

5. If you want to offset the opening a specific
distance from the end of the wall, right-click
and select Enter insertion offset. Enter the
offset distance in the Enter insertion offset
dialog, then click OK.

6. Position the opening in the receiving wall. If
you are using an insertion offset, position the
opening close to the end you want to offset it
from. The opening will snap inside the wall.
Dimensions are displayed that show you the
distance on either side of the opening.

7. With your opening positioned where you
want it, click to insert it.

8. Right-click and select Finish.
Openings are inserted at the Head Height defined for
the building location you insert the opening on. You
can resize, raise or lower an opening after you have
inserted it if you need to. 

Creating a Niche
A niche is a recess in a wall. There are a number of
rectangular, circular and arched niches in the catalog
that you can insert easily using the Openings tool.
You can create a custom niche by inserting an
opening in a wall, and then specifying a niche depth
in the opening’s properties.
To create a custom niche:
1. Insert an opening in the wall using the Open-

ings tool.

2. Click on the opening to select it, and then
right-click and select Properties.

3. In the Openings dialog, click on the drop box
next to the Specify Niche Depth item.
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4. Select either Distance or Percentage as your
method of specifying the niche depth. The
Distance option lets you enter a specific value
for the depth, while the Percentage option lets
you specify the depth as a percentage of the
wall depth.

5. If you selected the Depth option, type the
desired depth for the niche in the Depth edit
box. If you selected Percentage, type the
desired depth percentage in the Depth edit
box. Note that you can specify a distance or
percentage that is greater than the wall depth
if needed. The niche would then protrude
through the wall.

6. If you do not want any trim around the niche
opening, disable the Include Opening Trim
check box.

7. Click OK.

Tip: To flip a niche to the other side of the wall, use
the Flip Opening tool on the right-click menu.

Flipping a Niche
If you have created a niche in a wall and it appears to
be on the wrong side of the wall, you can flip it
instantly using the Flip Opening tool.
To flip a niche to the other side of the wall:
1. Select the opening.

2. Right-click and select Flip Opening.

Editing the Appearance of a
Niche
You can edit the appearance of a niche in 3D by
applying different materials to the recessed face.
To edit the appearance of a niche:
1. Select the opening, then right-click and select

Properties.
2. In the Openings dialog, select the Appear-

ance tab.

3. Select the component whose appearance you
would like to change.

Inside Niche Back. The interior face of the
niche back.

Niche Back Side. The exterior face of the
niche back. This would only be visible in 3D

if the niche depth is greater than the wall
depth, causing the niche to protrude from the
wall.

4. Click the Select button in the Material area,
then select a material to apply to the com-
ponent from the Materials library.

5. Click OK.

Moving a Wall Opening
You can move a wall opening by clicking and
dragging it inside the wall, or by editing the dynamic
dimensions on either side of the opening. You can
move an opening in both 2D and 3D.
To move an opening by clicking and dragging:
1. Click on the opening to select it.

2. Click and drag the opening to move it. If you
are moving an opening in 3D, make sure that
you select the center grip.

3. Release your mouse button.
To move an opening by editing dimensions:
1. Click on the opening. Dynamic dimensions

appear on either side of the opening.

2. Click on the dimension you want to edit.

3. In the Edit Dimension dialog, enter the new
value, then press Enter or click OK. The open-
ing position updates automatically.

Editing the Size of a Wall Open-
ing
You can edit the dimensions of a wall opening by
changing the properties on the opening’s Size
property page.
To edit the size of a wall opening:
1. Select the opening whose properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Properties area, edit the dimensions of
the opening. Dimensions vary according to
the shape of the opening.

4. Click OK.

Tip: If you want the bottom of your opening to be
level with the floor, change the height of opening
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to match the Head Height of the building location
it is inserted on. Alternatively you can lower the
opening using the Elevate tool.

Tip: You can also stretch an opening dynamically
by clicking and dragging its side grips if displayed.
See Stretching Doors, Windows and Openings for
more information.

Stretching Doors, Windows and
Openings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If the Stretch Openings option is enabled in your
Program Settings, grips will appear at the edges of
doors, windows and openings when you select them.
In 2D you can then dynamically stretch an opening to
make it narrower or wider. In 3D view you can
stretch it both vertically and horizontally. An
additional setting lets you specify that you want the
opening to be automatically renamed when its size
changes.
To enable the stretching of openings:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left column.

3. Check the Enable box in the Stretch Open-
ings area.

4. If you want openings to be automatically
renamed according to their new size, enable
the Auto-rename Openings check box. Note
that this will also override any custom names
that you have defined.

5. Click OK.

Editing the Shape of a Wall
Opening
Openings can be rectangular, round, arched,
octagonal or trapezoidal.
To change the shape a wall opening:
1. Select the opening whose properties you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Type area, click on the shape you want.

4. Click OK.

Displaying/Hiding Trim Around
a Wall Opening
By default, wall openings include trim around them if
a trim member is specified for openings in the wall’s
Trim properties. You can turn opening trim on or off
for individual openings.
To control the display of trim around a wall
opening:
1. Select the opening, then right-click and select

Properties.
2. In the Openings dialog, disable the Include

Opening Trim check box.

3. Click OK.

Editing the Appearance of a
Wall Opening in 2D Plan View
You can change the appearance of an opening in 2D
plan view by editing its line style properties. This
allows you to apply different colors, patterns or
weights to different openings if you wish.
To edit the appearance of an opening in 2D plan
view:
1. Select the opening, then right-click and select

Properties.
2. In the Openings dialog, select the Appear-

ance tab.

3. In the Components list, select Header.
4. Click the Select button in the Linestyle area.
5. Select the desired line style from the Line

Styles dialog, then click OK.
6. Click OK in the Openings dialog.

Inserting Doors, Windows and
Openings to Center
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the on-screen dimensions that appear
when inserting doors, windows and openings
measure from the edges of the opening object. The
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same applies when you insert openings using an
offset. If you prefer you can measure to center when
inserting openings.
To insert doors, windows and openings to center:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left column.

3. In the Opening Placement area, select Dimen-
sion to Center.

4. Click OK.

Inserting Doors, Windows and
Openings to Edge
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have changed your program settings so that
door, window and wall openings insert to center, you
can switch it back to the default method where
openings are measured from the edges of the
opening.
To insert doors, windows and openings to the
edge of the opening:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left column.

3. In the Opening Placement area, select Dimen-
sion to Edge.

4. Click OK.

Inserting Shutters
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Shutters tool you can instantly apply
shutters to the wall on one or both sides of a window
or opening. Choose a flat, paneled, or board-and-
batten style, or create your own style. Shutters can be
inserted on the exterior side or interior side of the
wall, or both sides.
To insert shutters:
1. Select Insert > Detailing > Shutters, or click

the down arrow next to the Detailing button
on the Building toolbar and select

Shutters.
2. In the catalog, select the type of shutter you

would like to insert.

3. In the Attach Shutters dialog, select the side
of the wall on which you want to insert the
shutters by enabling or disabling the Exterior
Side and/or Interior Side check box. Under
each option you can then specify whether
you would like to apply a shutter to the left
side, right side or both sides of the window
or opening.

4. Click OK.
5. Click on the window or opening that you

want to apply shutters to. The shutters are
inserted.

Editing Shutters
You can edit the style and dimensions of shutters by
editing their properties.
To edit shutters:
1. Click on a shutter to select it. If you are edit-

ing a pair of shutters, clicking on one shutter
selects them both.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties as desired. Each shutter
type has different settings. Below is a brief
description of each setting.

Adjust Size. If By Opening is selected, the
height of the shutter automatically adjusts to
the height of the window or opening it is
applied to. If Specify is selected, you can
define a specific shutter height in the Height
edit box. 

Width. The overall width of the shutter.
Height. The overall height of the shutter. This
value is not adjustable if By Opening is
selected in the Adjust Size drop box. It can
only be edited if Specify is selected in the
Adjust Size drop box.

Thickness. The depth of the shutter.
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Additional Settings for Panel Style

Panel Width. The width of the panel(s).
Top Rail Height. The height of the top rail.
Bottom Rail Height. The height of the
bottom rail.

Number of Panels. The number of panels in
the shutter.

Panel Type. Choose either Flat, Bevel or
Louver. If there are two or more panels, you
can select different types for individual
panels.

Panel Height. The height of a panel. If there
are two or more panels, you can set different
heights for individual panels.

Mid Rail Height. The height of the dividing
rail. If there are more than two panels, you
can set different rail heights between panels.
Additional Settings for Board-and-Batten
Style

Board Spacing. The distance between
boards.

Batten Thickness. The height of a batten.
Batten Edge Offset. The distance from the
bottom of a board to the edge of the batten.

Number of Boards. The number of boards
across the shutter.

Number of Battens. The total number of
battens on the shutter.
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If you have automatic floors enabled in your Program Settings, a floor will be automatically inserted when you
connect three or more walls to create a closed wall layout. When you insert interior walls, the floor is split as new
rooms are created. You can also manually split automatic floors using the Room Division tool.

There are three tools available on the Insert menu for inserting floors manually: Floor by Room, Floor by Perimeter,
and Floor by Picking Points.

If you want different flooring types in different rooms, you can use the Materials Paintbrush to quickly apply
different types of carpet, tiles, wood flooring, vinyl flooring, linoleum, or concrete to individual floors.

You can point and click to insert ceilings using one of the handy Ceiling tools: Ceiling by Room, Ceiling by
Perimeter, or Ceiling by Picking Points. Any ceiling surface can easily be made into a tray or cathedral ceiling by
simply editing the ceiling’s properties.

You can create openings in floors and ceilings if you need to.

Inserting a Structural Floor Throughout a Building Location
Building Essentials | Construction Suite

The Structural Floor by Perimeter tool detects the perimeter walls on the current building location and inserts a
structural floor of your choice throughout the entire location. This option is ideal if you have deleted your automatic
floor and would like to create a floor that spans your model. Once inserted, you have the option of cutting joists
along a bearing line if needed.
To insert a structural floor throughout a building location:
1. Make sure the building location that you want to insert the floor on is the current location.

2. Select Insert > Structural Floor > Structural Floor by Perimeter, or click the down arrow next to the Struc-

tural Floor button on the Building toolbar and select Structural Floor by Perimeter.

3. In the catalog, select the structural floor system that you want to insert.

4. Click anywhere inside the model. The floor is automatically inserted.

Note: The Structural Floor by Perimeter tool does not take interior walls into account. Only one large floor system
is created.

Inserting a Structural Floor in a Room
Building Essentials | Construction Suite

Using the Structural Floor by Room tool you can just click inside a room to automatically insert a structural floor of
your choice in that room.
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To insert a structural floor in a room:
1. Select Insert > Structural Floor > Structural

Floor by Room, or click the down arrow next

to the Structural Floor button on the
Building toolbar and select Structural Floor
by Room.

2. In the catalog, select the structural floor type
you want to insert.

3. Mouse over the room to which you want to
add a floor (it will highlight), then click
inside the room. The floor is automatically
inserted.

Inserting a Structural Floor by
Picking Points
Building Essentials | Construction Suite

The Structural Floor by Picking Points tool provides
the freedom to create a floor system of any size or
shape anywhere in your drawing. Just pick points to
form a closed shape and the floor is instantly created.
To insert a structural floor by picking points:
1. Select Insert > Structural Floor > Structural

Floor by Picking Points, or click the down
arrow next to the Structural Floor button

on the Building toolbar and select
Structural Floor by Picking Points.

2. In the catalog, select the structural floor type
you want to insert.

3. Select a start point for the floor, then continue
selecting points to define the size and shape
of the floor. Note that you do not have to
select the start point again to finish the floor
— the last point picked is always connected
to the start point.

4. Right-click and select Finish.

Inserting a Bearing Line in a
Structural Floor
If you have inserted a structural floor, you can insert
a bearing line to specify where you want joists to be
cut within the floor system.
To insert a bearing line:

1. Select the edge of the structural floor. You
may need to hide the wall edges to be able to
do this. You can tell that a structural floor is
selected if red arrows are displayed at the
floor's grip points.

2. Right-click and select Structural Floor >
Insert Bearing Line.

3. Select two points to draw a line through the
floor joists. The joists are automatically cut
along the bearing line. The joists ends on the
bearing line will be either overlapped or held
back depending on what is specified in the
floor's properties.

In the following example, a bearing line was
drawn down the middle of the floor system,
and the joists were cut an overlapped along
the bearing line:

Stretching or Moving a Bearing
Line in a Structural Floor
When you insert a bearing line in a structural floor,
grip points are displayed at each end of the bearing
line when the floor structure is selected. You can click
and drag these grip points to move them.

If you need to move a grip point a specific distance,
select the floor structure and then right-click and
select Stretch Bearing Line. This activates the
Commander, where you can specify exact values for
the move.

When you stretch or move a bearing line, the joists
that bear on the line adjust with it.

Removing a Bearing Line
If you want to remove a bearing line that you have
inserted in a structural floor, follow the steps below.
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1. Select the structural floor. You may need to
hide walls to be able to select the edge of it.

2. Right-click and select Remove Bearing Line.
3. Click on the bearing line. This removes the

bearing line and returns the joists to their ori-
ginal, uncut state.

Moving the Framing Base Point
in a Structural Floor
Building Essentials | Construction Suite
By default, framing in a structural floor starts from
the top corner. You may want to shift the base point
to start the joists a specific distance from the corner
instead. This may, for example, facilitate the
application of sheathing.

To move the framing base point:

1. Click on the edge of the structural floor to
select it.

2. Right-click and select Structural Floor >
Move Framing Base Point. The current fram-
ing base point is marked with a light blue tri-
angle.

3. Either drag the light blue triangle to a new
location, or click on any point in your draw-
ing and enter a precise move distance in the
Commander and press Enter. The base point
is moved, and the framing adjusts accord-
ingly.

Adding Members to a Structural
Floor
Building Essentials | Construction Suite
You can customize the framing of a structural floor by
adding members to it. When you use the Add to
Structural Floor System tool, manually inserted
members become associated with the floor, and
behave as though they are part it. For example, if you
move the floor, the members will move along with it.
Or, if the floor is deleted, the members will also be
deleted. Any View Filter changes applied to the floor
will be applied to the added members as well.
To add members to a structural floor:
1. Insert the members using the Members tool

or Advanced Members tool.

2. Select the inserted members, then right-click
and select Add to Structural Floor System.
A dialog box confirms the number of mem-
bers added.

If needed you can disassociate a member from the
floor using Remove from Structural Floor System.

Removing a Member from a
Structural Floor
Building Essentials | Construction Suite
To delete a member from a structural floor, simply
select it and press Delete on your keyboard.
To disassociate a member that you have manually
added to the floor using the Add to Structural Floor
System option, select the member, then right-click
and select Remove from Structural Floor System.
The member will remain in the drawing, but will no
longer be part of the floor system.

Cutting an Opening in a Struc-
tural Floor
If you have used the Structural Floor by Perimeter,
Structural Floor by Room or Structural Floor by
Picking Points tool to create a structural floor system,
you can use the Cut Opening tool on the floor’s right-
click menu to create an opening in it of any shape or
size.
To create an opening in a structural floor:
1. Click on the edge of the floor to select it.

2. Right-click and select Cut Opening.
3. Select a start point for the opening, then con-

tinue selecting points to define the size and
shape of the opening. Note that you do not
have to select the start point again to finish
the outline — the last point picked is always
connected to the start point.

4. Right-click and select Finish.

Editing Structural Floor Prop-
erties
Building Essentials | Construction Suite
Structural floor properties include settings for the
joists, sheathing, sill plate, and rim joists.
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To edit the general properties of an inserted floor,
select the edge of the floor, then right-click and select
Properties. In the Structural Floor System dialog,
you can specify General Properties such as joist
spacing, and define settings for the Joists and
Sheathing.

Perimeter members can be edited on a per-edge basis,
and can therefore be different on each edge. To edit
the members along a particular edge, select the floor,
then click on the red property marker on the desired
edge. Edit the member settings for the selected edge
in the Member Properties dialog box.
Structural floor properties are described below.

Regenerate components when updated. When
checked, this erases and rebuilds the auto-generated
framing components if the floor edge is modified (for
example, stretched). When unchecked, the members
remain intact when the floor edge is modified. Note
that enabling this setting does not rebuild members
that have been manually added to the floor system.
General Properties

Joist Direction. The angle at which the joists run.
Joist Spacing. The spacing between joists.
Style. The behavior of joists that rest on a bearing
line. The Stagger option overlaps the joist ends. The
Hold Back option pushes the joist ends away from
the bearing line.

Distance. The overlap distance when joist ends are
staggered, or the distance between joist ends when
they are held back along the bearing line.
Sheathing

Include. Select Yes to include sheathing, or No if you
do want to include sheathing.

Sheathing. Click on the field and then click the
browse button to select a sheathing material from the
catalog.

Phase. Click in the field and then click the browse
button to assign a phase to the sheathing. The phase
can be used as a sort key in quantity reports.

Usage. Click in the field and then click the browse
button to assign a usage to the sheathing. The usage
can be used as a sort key in quantity reports.
Joists/Sill Plate/Band Joist(s)/Rim Joist(s)/Opening
Header(s)

These framing components are arranged into
individual folders. Click New to add a member to a
selected folder, or click Copy to copy an existing
member. Click Delete to remove a selected member
from the configuration.

Parameters include:

Name. A unique identifier for the member.
Member. Click in the field and then click the browse
button to select a member from the catalog.

Rotation. The orientation of the member's profile.
Phase. Click in the field and then click the browse
button to assign a phase to the member.

Usage. Click in the field and then click the browse
button to assign a usage to the member.

Alignment. The point on a member that you want to
use as a reference point when editing it. Choices are
Top, Center and Bottom.
Opening(s)

Edge Offset. The offset of the opening's edge
members from the line that you draw when cutting an
opening. You can enter a positive or negative value to
offset the members to either side of the line.

Joist Projection. The distance that the joists project
into the opening edge.

Automatic Floors
If you have automatic floor insertion enabled in your
Program Settings, a floor is automatically inserted
throughout your model when you connect three or
more walls to create a closed exterior wall layout. You
can disable or enable automatic floor insertion at any
time.

By default, hardwood flooring is applied when an
automatic floor is created. If you use the House
Builder Wizard, the floor type depends on the house
style selected when using the Wizard. If you want
you can apply a different material to the floor using
the Materials Paintbrush.

When you draw interior walls, the floor is split into
individual floors as new rooms are created provided
the room’s walls are all connected. You can also
manually split automatic floors using the Room
Division tool.

Automatic floors cannot be selected in 2D plan view.
They can only be selected in 3D view. The only
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exception are floor edges that have been defined
using the Room Division tool. Such edges are marked
with a dashed line in 2D view, and can be stretched if
necessary.

Automatic floors are directly associated with the walls
that contain them. If you stretch your wall layout, the
floor stretches with it. If you open up your wall
layout by deleting a wall, the floor will be deleted.

Tip: For projects in which you plan to use the
House Builder Wizard, you can change the default
floor type by editing the House Builder Wizard
element configuration before running the Wizard.
You can also select the floor type you want while
running the Wizard.

Moving Defined Floor Edges
If you have used the Room Division tool to define a
custom floor area in your model, you can move the
defined floor edge in 2D view to increase or decrease
the size of the defined floor area.
To move a defined floor edge:
1. Click on the dashed floor edge in 2D plan

view. Blue grips are displayed along the line.

2. Hover your pointer over the center grip, then
click and drag to move the line.

3. Release your mouse button.

Disabling or Enabling Automatic
Floor Insertion
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

An option in your Program Settings determines
whether or not a floor is automatically inserted
throughout your model when you form a closed wall
layout. You can disable or enable this option at any
time.
To disable or enable automatic floor insertion:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, select
Building Aids in the left column.

3. In the Building Aids area, disable or enable the
Automatically Insert Floors check box.

4. Click OK.

Inserting a Floor Throughout a
Building Location
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Floor by Perimeter tool detects the perimeter
walls on the current building location and inserts a
floor of your choice throughout the entire location.
This option is ideal if you have deleted your
automatic floor and would like to create floors as
quickly as possible throughout your model. It is also
the perfect choice if you do not need different floors
in each room.
To insert a floor throughout a building location:
1. Make sure the building location that you

want to insert the floor on is the current loc-
ation.

2. Select Insert > Floors > Floor by Perimeter,
or click the down arrow next to the Floors

button on the Building toolbar and select
Floor by Perimeter.

3. In the catalog, select the floor type you want
to insert.

4. Click anywhere inside the model. The floor is
automatically inserted.

Note: The Floor by Perimeter tool does not take
interior walls into account. Only one large floor
surface is created. If you would prefer individual
floors in each room, use the Floor by Room tool.

Inserting a Floor in a Room
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Floor by Room tool you can just click inside
a room to automatically insert a floor of your choice
in that room.
To insert a floor in a room:
1. Select Insert > Floors > Floor by Room, or

click on the Building toolbar.

2. In the catalog, select the floor type you want
to insert.

3. Mouse over the room to which you want to
add a floor (it will highlight), then click
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inside the room. The floor is automatically
inserted.

Note: By default, floors inserted with the Floor by
Room tool extend to the inside edge of the wall
core (e.g. stud wall). If you prefer that they extend
to the interior wall surface, you can define this in
your program settings prior to inserting them. See
Defining the Extents of Floors to be Inserted in Rooms
on page 102.

Defining the Extents of Floors to
be Inserted in Rooms
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a floor inserted with the Floor by Room
tool extends to the inside edge of the wall core (e.g.
stud wall). If you prefer you can set the floor to
extend to the interior edge of the interior wall surface
(e.g. drywall) instead. This is an insertion setting that
is defined in your program settings. Changing this
setting has no effect on floors that have already been
inserted. It only affects floors that you are going to
insert with the Floor by Room tool. If you want to
change the extents of an existing floor you can click
and drag its editing grips.
To define the extents of floors to be inserted with
the Floor by Room tool:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Build-
ing Aids in the left column.

3. In the Insertion by Room area, click the drop
box next to the Floors item.

4. If you want floors in rooms to extend to the
wall core, select Wall Core. If you want them
to extend to the interior wall surface, select
Wall Surface.

5. Click OK.

Inserting a Floor by Picking
Points
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Floor by Picking Points tool provides the freedom
to create a floor of any size or shape anywhere in
your drawing. Just pick points to form a closed shape
and the floor is instantly created.
To insert a floor by picking points:
1. Select Insert > Floors > Floor by Picking

Points, or click the down arrow next to the
Floors button on the Building toolbar and
select Floor by Picking Points.

2. In the catalog, select the floor type you want
to insert.

3. Select a start point for the surface, then con-
tinue selecting points to define the size and
shape of the floor. Note that you do not have
to select the start point again to finish the
floor — the last point picked is always con-
nected to the start point.

4. Right-click and select Finish.

Resizing or Reshaping a Floor
You can resize or reshape a floor by clicking and
dragging its edges and corners.

Note: You cannot stretch a floor that was created
automatically with your wall layout. You can only
stretch floors that were created with a Floor tool.

To resize or reshape a floor:
1. Select the floor by clicking on one of its

edges. If you want to resize the floor, click on
the edge that you want to adjust. A solid blue
grip appears on the edge you selected, and
hollow blue grips appear at each corner of
the floor surface.

2. To resize the floor, hover your pointer over
the solid blue grip, then click and drag the
floor edge to adjust the floor size. Altern-
atively you can select the Move Edge tool on
the right-click menu.

3. To reshape the floor, hover your pointer over
one of the corner grips, then click and drag
the corner to adjust the floor shape. Altern-
atively you can select the Stretch tool on the
right-click menu.

If you would like to stretch only a portion of a floor
edge, you can accomplish this by adding a node to
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the floor edge. See Adding a Node to a Floor on page
103.

Adding a Node to a Floor
You can add nodes to a floor edge to create more
grips along the edge. You can then click and drag a
grip on a specific segment to reshape that portion of
the floor.
To add a node to a floor:
1. Select the floor.

2. Right-click and select Add Node, or select
Edit > Modify Elements > Add Node.

3. Click on the point on the floor edge where
you want to add a node. The edge is split into
separate edges, each with its own grips for
moving and stretching.

Dividing a Room
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If a room contains an automatic floor, you can use the
Room Division tool to split the room into two
separate areas. This enables you to have two different
floor types/finishes in the same room. You can also
use the Room Division tool to define an opening in a
floor.

Note: You cannot divide a room that contains a
floor that was created with a Floor tool.

To divide a room:
1. Select Insert > Floors > Room Division, or

click the down arrow next to the Floors but-

ton on the Building toolbar and select
Room Division.

2. Select points to define the division line. If you
are dividing a room into two segments, the
end points of the line must be on the floor
edge, although intermediate points are
permitted anywhere on the floor surface.

If you are creating a floor within a floor, the
split line must form a closed shape.

3. Right-click and select Finish.
To move a division line:
1. Click on the dashed division line in 2D plan

view. Blue grips are displayed along the line.

2. Hover your pointer over the center grip, then
click and drag to move the line.

3. Release your mouse button.

Note: When you divide a floor, the division lines
are also created on the ceiling above.

Editing the Thickness of a Floor
You can edit the thickness of a floor on its Basic
property page.
To edit the thickness of a floor:
1. Select the floor. If the floor was created auto-

matically with your wall layout, you need to
select the floor in 3D.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the value in the Thickness edit box on
the Basic page.

4. Click OK.

Converting a Floor to a Struc-
tural Floor
Building Essentials | Construction Suite
When you use the Floor by Room, Floor by Perimeter,
or Floor by Picking Points tool, a finish floor such as
hardwood is inserted. You can use the Convert to
Structural Floor tool to automatically convert the
finish floor to a structural floor comprising framing
members.
To convert a floor to a structural floor:
1. Select the floor to convert. An easy way to do

this is to go into 2D Designer's Plan mode,
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then click on the floor surface.

2. Right-click and select Convert to Structural
Floor.

3. In the Catalog Access dialog, select the struc-
tural floor type to which you want to convert
the selected floor.

4. Click OK to convert the floor.

Note: The Convert to Structural Floor tool is not
available for auto-inserted floors.

Cutting an Opening in an Auto-
matic Floor
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert an opening of any shape and size in an
automatic floor by defining the area to be cut out,
then deleting it. You may need to do this to
accommodate a staircase.

Note: If you want to insert an opening in a floor
that was created with a Floor tool, see Cutting an
Opening in a Manually Inserted Floor on page 104.

To insert an opening in an automatic floor:
1. Select Insert > Floors > Room Division, or

click the down arrow next to the Floors but-

ton on the Building toolbar and select
Room Division.

2. Select points to define the outline of the open-
ing, ensuring the outline forms a closed
shape.

3. Right-click and select Finish. An outline is
created on the floor surface. You can stretch,
move and curve the outline if necessary to get
the exact size and shape you want.

4. Go into 3D view and make sure the floor is
visible and accessible.

5. Click in the center of the outline you drew to
select the outline.

6. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.

Cutting an Opening in a Manu-
ally Inserted Floor
If you have used the Floor by Room, Floor by
Perimeter or Floor by Picking Points tool to create a
floor, you can use the Cut Opening tool on the floor’s
right-click menu to create an opening in it of any
shape or size.
To create an opening in a manually inserted floor:
1. Select the floor surface.

2. Right-click and select Cut Opening.
3. Select a start point for the opening, then con-

tinue selecting points to define the size and
shape of the opening. Note that you do not
have to select the start point again to finish
the outline — the last point picked is always
connected to the start point.

4. Right-click and select Finish.

Resizing or Reshaping a Floor
Opening
If you have created an opening in a floor, you can
resize or reshape the opening by clicking and
dragging its edges or corners.
To resize or reshape a floor opening:
1. Click on the edge of the opening.

2. To resize the opening, hover your pointer
over the center blue grip of the edge that you
want to move, then click and drag the edge to
adjust the opening size.

3. If the opening is located in a manually inser-
ted floor, you can reshape the opening by
clicking and dragging a corner grip.

Removing an Opening from an
Automatically Inserted Floor
If you have inserted an opening in an automatic floor,
you can remove it by deleting all of the opening
edges.
To remove an opening from an automatic floor:
1. In 2D plan view, click on one of the opening’s

edges, then Shift+click to select the remaining
edges.
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2. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.

Removing an Opening from a
Manually Inserted Floor
You can remove an opening from a manually inserted
floor using the Remove Opening tool. A manually
inserted floor is one that was inserted with either the
Floor by Room, Floor by Perimeter or Floor by
Picking Points tool.

Note: You cannot remove an opening from a
manually inserted floor using Delete.

To remove an opening from a manually inserted
floor:
1. Click on the edge of the floor or opening to

select the floor.

2. Right-click and select Remove Opening, or
select Edit > Modify Elements > Remove
Opening.

3. Click on the edge of the opening. The open-
ing is removed.

How Ceilings are Created
You can insert ceilings using any of the handy Ceiling
tools — Ceiling by Room, Ceiling by Perimeter, or
Ceiling by Picking Points.

You can edit the thickness and appearance of any
ceiling as well as lower it to create a suspended
ceiling, regardless of how you created it. You can also
use the Materials Paintbrush to apply different colors
or materials to individual ceilings. As well, any
ceiling can be converted into a tray or cathedral
ceiling by simply editing the ceiling’s properties.

Tip: The underside of an upper-story floor can also
serve as a ceiling. Similarly, the top side of a lower-
story ceiling can serve as a floor.

Inserting a Ceiling Throughout a
Building Location
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Ceiling by Perimeter tool detects the perimeter
walls on the current building location and inserts a
ceiling of your choice throughout the entire location.
This option is ideal if you would like to create ceilings
as quickly as possible throughout your model and do
not have a need for different ceilings in each room.
To instantly add a ceiling to the entire perimeter of
a location:
1. Make sure the location you want to insert the

ceiling on is the current location in the build-
ing locations drop box.

2. Select Insert > Ceilings > Ceiling by Peri-
meter, or click the down arrow next to the
Ceilings button on the Building toolbar
and select Ceiling by Perimeter.

3. In the catalog, select the ceiling type you
want to insert.

4. Click anywhere inside the perimeter of the
model. The ceiling is added automatically.

5. Right-click and select Finish.

Note: The Ceiling by Perimeter tool does not take
interior walls into account. Only one large ceiling
surface is created. If you would prefer individual
ceilings in each room, use the Ceiling by Room
tool.

Inserting a Ceiling in a Room
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Ceiling by Room option inserts a ceiling inside
the perimeter of a room provided all the walls are
connected. Adding ceilings by room allows you to
have different ceiling types in different rooms.
To insert a ceiling inside a room:
1. Make sure the location you want to insert the

ceiling on is the current location in the build-
ing locations drop box.

2. Select Insert > Ceilings > Ceiling by Room,
or click on the Building toolbar.

3. In the catalog, select the ceiling type you
want to insert.

4. Mouse over the room to which you want to
add a ceiling (it will highlight), then click
inside the room. The ceiling is added
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automatically. (If you want, you can continue
adding ceilings to other rooms.)

5. Right-click and select Finish from the short-
cut menu.

Note: By default, ceilings inserted with the Ceiling
by Room tool extend to the inside edge of the wall
core (e.g. stud wall). If you prefer that they extend
to the interior wall surface, you can define this in
your program settings prior to inserting them. See
Defining the Extents of Ceilings to be Inserted in Rooms
on page 107.

Inserting a Ceiling By Picking
Points
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Ceiling by Picking Points tool you can
insert a ceiling by picking points to define the
ceiling’s outline. This lets you create a ceiling of any
shape and size, anywhere in the drawing area.
To create a ceiling by picking points:
1. Make sure the location you want to insert the

ceiling on is the current location in the build-
ing locations drop box.

2. Select Insert > Ceilings > Ceiling by Picking
Points, or click the down arrow next to the
Ceilings button on the Building toolbar
and select Ceiling by Picking Points.

3. In the catalog, select the ceiling type you
want to insert.

4. Select a start point for the ceiling outline.

5. Continue selecting points until the outline is
defined. (You do not have to select the start
point again because the last point you pick is
always closed back to the start point.)

6. Right-click and select Finish.

Creating a Tray Ceiling
A tray ceiling slopes upward with one or more steps
prior to reaching a flat portion. This decorative ceiling
treatment is often used to add volume or height to a
room.

You can create a tray ceiling by changing a ceiling’s
type to Tray in its properties, then defining the tray
height, skirt width and slope angle.
To create a tray ceiling:
1. Create a regular flat ceiling in the room that

you want to have a tray ceiling.

2. Select the ceiling.

3. Right-click and select Properties.
4. In the Ceilings dialog, click the Tray option

in the Type area.

5. In the Properties area, click the Tray Height
option, then type the desired distance from
the base of the ceiling to the raised flat por-
tion. This defines the height of the tray.

6. Click the Skirt Width option, then specify the
desired distance from the outer edge of the
ceiling to the edge of the tray.

7. Click the Edge Shape option, then select
either Straight, Gable or Arched.

Straight. Creates straight tray edges that can
be angled.

Gable. Creates straight tray edges and leaves
one side open on the tray so that the tray can
fit up against a wall.

Arched. Creates curved tray edges.
8. If you selected the Straight edge shape, spe-

cify the desired angle for the tray’s edges in
the Slope Value edit box. To specify the
method that you would like to use to specify
the slope value, choose either Degrees, ? in 12,
1 in ?, or Percent from the Slope Type drop
box.

9. If you selected the Arched edge shape, specify
the following values:

Start Angle. The angle of the start of the
curve, measured from the base of the ceiling
to the center of the starting curve. Choose a
value from 1º to 90º. 

End Angle. The angle of the upper portion of
the curve, measured from the center of the
ending curve to the top of the tray.

Radius. The distance from the base of the
ceiling to the center of the curved edge.

10. Click OK.
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Creating a Cathedral Ceiling
A cathedral ceiling is a high, vaulted, open ceiling
that can be arched or slant upward to a point.

You can create a cathedral ceiling by changing a
ceiling’s type to Cathedral in its properties, then
defining the ceiling’s edge conditions.
To create a cathedral ceiling:
1. Create a regular flat ceiling in the room that

you want to have a cathedral ceiling.

2. Select the ceiling.

3. Right-click and select Properties.
4. In the Ceilings dialog, click the Cathedral

option in the Type area.

5. Click the Skirt Width option, then specify the
distance from the edge of the ceiling at which
you want the ceiling to start sloping upward.
If you want the ceiling to start sloping dir-
ectly from the outer edges, specify a value of
0.

6. Click the Edge Shape option, then select
either Straight, Gable or Arched to define
the shape of the ceiling’s sloping edges.

Straight. Creates straight edges that can be
angled. 

Gable. Creates straight edges and leaves one
side open so that the ceiling can fit up against
a wall. 

Arched. Creates curved edges.
7. If you selected the Straight edge shape, spe-

cify the desired angle for the sloping edges in
the Slope Value edit box. To specify the
method that you would like to use to specify
the slope value, choose either Degrees, ? in 12,
1 in ?, or Percent from the Slope Type drop
box.

8. If you selected the Arched edge shape,
specify the following values:

Start Angle. The angle of the start of the
curve, measured from the base of the ceiling
to the center of the starting curve. Choose a
value from 1º to 90º. 

End Angle. The angle of the upper portion of
the curve, measured from the center of the
ending curve to the top of the ceiling's peak.

Radius. The distance from the base of the
ceiling to the center of the curved edge.

Vert. Distance. The distance from the base of
the ceiling to the peak.

9. Click OK.

Note: If you are creating a cathedral ceiling, you
need to make sure your roof is steep enough to
accommodate the ceiling. Otherwise, the ceiling
will go through the roof.

Defining the Extents of Ceilings
to be Inserted in Rooms
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a ceiling inserted with the Ceiling by
Room tool extends to the inside edge of the wall core
(e.g. stud wall). If you prefer you can set the ceiling to
extend to the interior edge of the interior wall surface
(e.g. drywall) instead. This is an insertion setting that
is defined in your program settings. Changing this
setting has no effect on ceilings that have already
been inserted. It only affects ceilings that you are
going to insert with the Ceiling by Room tool. If you
want to change the extents of an existing ceiling you
can click and drag its editing grips.
To define the extents of ceilings to be inserted with
the Ceiling by Room tool:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Build-
ing Aids in the left column.

3. In the Insertion by Room area, click the drop
box next to the Ceilings item.

4. If you want ceilings in rooms to extend to the
wall core, select Wall Core. If you want them
to extend to the interior wall surface, select
Wall Surface.

5. Click OK.

Resizing or Reshaping a Ceiling
You can resize or reshape a ceiling by clicking and
dragging its edges and corners.
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To resize or reshape a ceiling:
1. Select the ceiling by clicking on one of its

edges. If you want to resize the ceiling, click
on the edge that you want to adjust. A solid
blue grip appears on the edge you selected,
and hollow blue grips appear at each corner
of the ceiling surface.

2. To resize the ceiling, hover your pointer over
the solid blue grip, then click and drag the
ceiling edge to adjust the ceiling size. Altern-
atively you can select the Move Edge tool on
the right-click menu.

3. To reshape the ceiling, hover your pointer
over one of the corner grips, then click and
drag the corner to adjust the ceiling shape.
Alternatively you can select the Stretch tool
on the right-click menu.

If you would like to stretch only a portion of a ceiling
edge, you can accomplish this by adding a node to
the ceiling edge. For example, you may want to
stretch a portion of a ceiling into the foyer or closet.
See Adding a Node to a Ceiling on page 108.

Adding a Node to a Ceiling
You can add nodes to a ceiling edge to create more
grips along the edge. You can then click and drag a
grip on a specific segment to reshape that portion of
the ceiling.
To add a node to a ceiling:
1. Select the ceiling.

2. Right-click and select Add Node, or select
Edit > Modify Elements > Add Node.

3. Click on the point on the ceiling edge where
you want to add a node. The edge is split into
separate edges, each with its own grips for
moving and stretching.

Cutting Openings in Ceilings
You can create an opening in a ceiling using the Cut
Opening tool. You create the opening by picking
points to define its size and shape.
To cut an opening in a ceiling:
1. Select the ceiling by clicking on one of its

edges.

2. Right-click and select Cut Opening, or select
Edit > Modify Elements > Cut Opening.

3. Select a start point for the opening.

4. Continue selecting points to define the open-
ing. As you select points, the opening is cre-
ated. The last point picked is always
connected back to the start point to form a
closed shape, so you don’t have to select the
start point again.

5. Right-click and select Finish.

Resizing or Reshaping Ceiling
Openings
If you have created an opening in a ceiling, you can
resize or reshape the opening by clicking and
dragging its edges or corners.
To resize or reshape a ceiling opening:
1. In 2D plan view, click on the opening edge

you want to move.

2. To resize the opening, hover your pointer
over the center blue grip of the edge that you
want to move, then click and drag the edge to
adjust the opening size.

3. To reshape the opening, click and drag a
corner grip.

Removing an Opening from a
Ceiling
You can remove an opening from a manually inserted
ceiling using the Remove Opening tool. A manually
inserted ceiling is one that was inserted with either
the Ceiling by Room, Ceiling by Perimeter or Ceiling
by Picking Points tool.

Note: You cannot remove an opening from a
manually inserted ceiling using Delete.

To remove an opening from a manually inserted
ceiling:
1. Click on the edge of the ceiling or opening to

select the ceiling.

2. Right-click and select Remove Opening, or
select Edit > Modify Elements > Remove
Opening.

3. Click on the edge of the opening. The open-
ing is removed.
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If your design has more than one floor, you’ll want to insert a staircase. The catalog contains a variety of stair and
ramp styles, including straight, spiral, fold-back, L-shaped and L-winder. There are even stairs specifically for decks
and porches.

You can edit the composition and dimensions of each component in your staircase to create the exact look you want.
Stairs and ramps are inserted as solid objects with point-and-click simplicity. Just select the staircase or ramp you
want to insert in the catalog, then click to insert it in your model.

The catalog also contains an excellent selection of railing types. A railing can be just a handrail, or a balustrade with
posts, top/bottom rails and newels. You can insert railings on a staircase automatically. You can choose to put it on
both sides, the left side, the right side, or the center. You can also draw a horizontal railing by picking points.

Inserting Stairs and Ramps
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can insert a staircase or ramp with a single mouse click. If you place the staircase near a wall, the staircase will
automatically snap to the wall. Once you have inserted a staircase, you can edit its size, style and geometry.
To insert a staircase or ramp:
1. In the building locations drop box, select the location where you want to insert the base of the staircase.

2. Select Insert > Stairs/Ramps, or click on the Building toolbar.

3. In the catalog, select the staircase or ramp you want to insert.

4. Position the staircase and click to insert it.

5. Right-click and select Finish.

Parts of a Staircase
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Editing Stair Size Properties
You can edit the general dimensions of a staircase,
such as height, width, and number of steps.
To edit stair size properties:
1. Select the staircase whose stair properties you

want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Stairs/Ramps dialog, edit the
dimensions in the Properties window.

Overall Height. The vertical distance from
the base of the staircase to the top of the
staircase. Generally this is the distance from
one floor to the next. 

Total Steps. The total number of steps in the
staircase including all treads and landings.
This value is controlled by the Overall Height
and Riser Maximum, so you can only go so
high or so low when specifying the total
number of steps.

Riser Height. The distance from the top of
one tread to the top of the next tread. The
riser height adjusts if you edit the Overall
Height or Total Steps, making this a read-
only value.

Tread Run. The width of a step from the nose
of the step to the riser of the next step.

Riser Maximum. The maximum height
allowed for risers. The riser height adjusts
when you change the Overall Height or Total
Steps variables.

Show Riser. Inserts vertical boards under the
treads. If turned off, the stairs are open under
the treads.

4. Click OK.

Editing a Staircase Layout
You can choose from a multitude of preset staircase
layouts and edit the dimensions of individual
segments to suit your needs.
To edit a staircase layout:
1. Select the staircase whose stair properties you

want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Stairs/Ramps dialog, select the Layout
tab.

4. To change the layout of the staircase, make a
selection from the Preset Layouts drop box, or
click the graphic to display the available lay-
outs and select the one you want.

5. To edit the dimensions of a particular
segment, select the segment in the Layout
Segments window. For example, an L-shaped
staircase will have three segments: Stair 1,
Landing 2 and Stair 3. The Stair 1 segment is
the lower flight of stairs, Landing 2 is the
central landing between the two flights, and
Stair 3 is the upper flight of stairs.

Different layouts will have different
parameters. Clicking a dimension marked
with an alphabetical character (a, b, c, etc.)
highlights the corresponding dimension in
the stair graphic, and vice versa.
Stair Segments

Number of Steps. The number of steps in the
flight.

Position Offset. Shifts the base of the
staircase left or right from the center line. A
positive value shifts it right, a negative value
shifts it left. If the Upper Offset is set to 0, the
entire staircase is moved.

Lower Width. The width of the bottom step.

Upper Width. The width of the top step.
Upper Offset. Shifts the top of the stair
segment left or right to create an angled
flight. A positive value shifts it right, a
negative value shifts it left.

Landing Connection. Choose from Front,
Bottom or Under to determine how the stairs
attach to the landing.

Adjust Width. If the staircase has multiple
segments, this adjusts the width of attached
landings and stair flights to match the width
settings of the current segment.

Adjust Height. When editing the number of
risers or height of a segment in a multi-
segmented staircase, this determines which
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other segments (or all others) are to be
adjusted to make up the overall height of all
segments.
Landing Segments (vary per style)

Position Offset. Shifts the landing left or
right. A positive value moves the landing
right. A negative value moves it left.

Width. The width of the landing along the
lower flight of stairs. By default this matches
the Upper Width setting of the lower stair
flight.

Depth 1. The width of the landing along the
upper flight of stairs. By default this matches
the Lower Width setting of the upper stair
flight.

Depth 2. The width of the exposed side of the
landing.

Adjust Width. Adjusts the width of attached
stair flights to match the width of the
landing.

6. To add a flight or landing to your staircase,
click Add in the Layout Segments area. Select
the segment you want to add in the Add/Edit
Segment dialog.

7. The segment is added to your list of segments
in the Layout Segments window. Proceed with
defining the parameters for the new segment
in the Parameters window.

8. To change an existing segment to another
type, select the segment in the Layout Seg-
ments window, then click Edit. Select the new
segment type in the Add/Edit Segment dia-
log.

9. To delete a segment from the staircase, select
the segment in the Layout Segments window,
then click Delete.

10. Once you are satisfied with your layout set-
tings, click OK.

Editing Stair Details
Editing stair details lets you precisely control the size
and position of treads, risers, stringers and landing
platforms.
To edit stair details:

1. Select the staircase whose stair properties you
want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To change the stringer style or create a solid
stair, click the appropriate graphic in the Type
area.

4. To edit tread, riser, stringer and landing
details, select the Details tab. Clicking a
dimension marked with an alphabetical char-
acter (a, b, c, etc.) highlights the cor-
responding dimension in the stair graphic,
and vice versa.

5. Edit the properties in the Properties area.

Tread Thickness. The thickness of each step. 
Nosing Depth. The distance the step extends
past the riser.

Riser Angle. The tilt of the riser board. A
value of 0 means the board is perpendicular
to the step (straight up and down). A value
above 0 tilts the riser down toward the back
of the staircase. The maximum angle allowed
is 20º.

Stringer Side Offset. The distance the side
stringers are offset from the ends of the
treads.

Stringer Width. The distance from the
bottom of the stringer to the underside of the
tread/riser intersection. Setting the stringer
width to match the height of your staircase
creates a stringer that runs from the staircase
right to the floor.

Stringer Thickness. The thickness of the
stringer member.

Max Stringer Spacing. The maximum
distance allowed between stringers. If you
increase the width of the staircase, additional
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stringers will be inserted if this spacing is
exceeded.

Landing Thickness. The thickness of the
landing platform.

6. Click OK.

Editing the Appearance of a
Stair Cut Line
When viewing a staircase in 2D plan view you can see
a cut line through the staircase. The cut line is a
standard drafting symbol for stairs.

You can change the cut line’s position, size, angle and
style. You can also hide it from view if you want.
To edit the appearance of the cut line:
1. Select the staircase.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Stairs/Ramps dialog, select the Details
tab.

4. Edit the settings in the Cut Line area.

Show Cut Lines. Shows or hides the cut lines
in 2D plan view. 

Extension. The distance the cut line extends
past the edge of the staircase in 2D plan view.

Angle. The angle of the cut line in 2D plan
view.

Spacing. If using the Double or Double Arch
style, this is the distance between the lines.

Elevation. How high up the staircase the cut
line sits.

Style. Choose from Single, Single Architectural,
Double and Double Architectural. The default is
Double Architectural.

5. Once you’ve defined your cut line, click OK.

Editing General Ramp Prop-
erties
If editing a ramp, you can select a uniform or full
style, and edit the ramp thickness and landing
thickness. If you want to change the layout (shape) of
the ramp or edit properties such as the height or
slope, see Editing the Layout of a Ramp on page 112.
To edit ramp properties:

1. Select the ramp.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Stairs/Ramps dialog, select the Basic
tab.

4. If you want to change the ramp type, click on
the type you want in the Type area. The first
type is a ramp with uniform thickness, while
the second is a full, wedge-style ramp.

5. If you selected the uniform ramp style, you
can change its thickness by entering the
desired thickness in the Ramp Thickness
edit box.

6. To change the thickness of the landing, enter
a value in the Landing Thickness edit box.

7. Click OK.

Editing the Layout of a Ramp
You can choose from a multitude of preset ramp
layouts as well as edit various layout properties such
as length and slope.
To edit the layout of a ramp:
1. Select the ramp.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Stairs/Ramps dialog, select the Layout
tab.

4. To change the layout of the ramp, make a
selection from the Preset Layouts drop box, or
click the graphic to display the available lay-
outs and select the one you want.

5. To edit the dimensions of a particular seg-
ment, select the segment in the Layout Seg-
ments window. A straight ramp will have one
segment, named Ramp 1. Other ramp styles
will have more segments. For example, an L-
shaped ramp will have three segments: Ramp
1, Landing 2 and Ramp 3. The Ramp 1 seg-
ment is the lower section of the ramp, Land-
ing 2 is the central landing between the two
sections, and Ramp 3 is the upper section of
the ramp. Clicking a dimension marked with
an alphabetical character (a, b, c, etc.) high-
lights the corresponding dimension in the
ramp graphic, and vice versa.
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6. Edit the variables in the Parameters window.
Ramp Segments

Slope. The angle of the ramp’s incline.
Length. The length of the ramp’s surface.
Position Offset. Shifts the base of the ramp
left or right from the center line. A positive
value shifts it right, a negative value shifts it
left. If the Upper Offset is set to 0, the entire
ramp is moved.

Lower Width. The width of the bottom of the
ramp.

Upper Width. The width of the top of the
ramp.

Upper Offset. Shifts the top of the ramp
segment left or right to create an angled
ramp. A positive value shifts it right, a
negative value shifts it left.

Adjust Width. For ramps with multiple
segments, this adjusts the width of attached
landings and ramp flights to match the width
settings of the current segment.

Adjust Height. When editing the height of a
segment in a multi-segmented ramp, this
determines which other segments (or all
others) are to be adjusted to make up the
overall height of all segments.
Landing Segments (vary per style)

Position Offset. Shifts the landing left or
right from the center line. A positive value
moves it right, a negative value moves it left.

Width. The width of the landing along the
lower ramp section. By default this matches
the Upper Width setting of the lower ramp
section.

Depth 1. The width of the landing along the
upper ramp section. By default this matches
the Lower Width setting of the upper ramp
section.

Depth 2. The width of the exposed side of the
landing.

Adjust Width. Adjusts the width of attached
ramp segments to match the width of the
landing.

7. To add a segment or landing to your ramp,
click Add in the Layout Segments area. Select
the segment you want to add in the Add/Edit
Segment dialog.

8. The segment is added to your list of segments
in the Layout Segments window. Proceed with
defining the parameters for the new segment
in the Parameters window.

9. To change an existing segment to another
type, select the segment in the Layout Seg-
ments window, then click Edit. Select the new
segment type in the Add/Edit Segment dia-
log.

10. To delete a segment from the ramp, select the
segment in the Layout Segments window, then
click Delete.

11. Once you are satisfied with your layout set-
tings, click OK.

Inserting Railings on Both Sides
of a Staircase or Ramp
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert railings on both sides of a staircase
automatically. A railing can be just a handrail, or a
balustrade with posts, top/bottom rails and newels.
To insert railings on both sides of a staircase
automatically:
1. Select Insert > Railings > Railings on Stairs

Automatically, or click the down arrow next
to the Railings button on the Building
toolbar and select Railings on Stairs Auto-
matically.

2. In the catalog, select the railing type you
want to insert.

3. Click on the staircase. The railings are inser-
ted automatically on both sides.

4. Right-click and select Finish.

Inserting a Railing on the Left
Side of a Staircase or Ramp
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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A railing can be just a handrail, or a balustrade with
posts, top/bottom rails and newels. Using the Railing
on Stair Left tool you can insert a railing on the left
side of a staircase easily by just clicking two points on
the stair.
To insert a railing on the left side of a staircase:
1. Select Insert > Railings > Railing on Stair

Left, or click the down arrow next to the Rail-
ings button on the Building toolbar and
select Railing on Stair Left.

2. In the catalog, select the railing type you
want to insert.

3. Select a point anywhere along the bottom of
the staircase (or along the tread where you
want the bottom of the railing to sit) to define
the level of the railing’s bottom post. Your
cursor will snap to the left side of the stair-
case as you start to draw the railing.

4. Select a point anywhere along the top of the
staircase (or along the tread where you want
the top of the railing to sit) to define the level
of the railing’s top post.

5. Right-click and select Finish.

Inserting a Railing on the Right
Side of a Staircase or Ramp
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A railing can be just a handrail, or a balustrade with
posts, top/bottom rails and newels. Using the Railing
on Stair Right tool you can insert a railing on the right
side of a staircase easily by just clicking two points on
the stair.

1. Select Insert > Railings > Railing on Stair
Right, or click the down arrow next to the
Railings button on the Building toolbar
and select Railing on Stair Right.

2. In the catalog, select the railing type you
want to insert.

3. Select a point anywhere along the bottom of
the staircase (or along the tread where you
want the bottom of the railing to sit) to define
the level of the railing’s bottom post. Your
cursor will snap to the right side of the stair-
case as you start to draw the railing.

4. Select a point anywhere along the top of the
staircase (or along the tread where you want
the top of the railing to sit) to define the level
of the railing’s top post.

5. Right-click and select Finish.

Inserting a Railing Along the
Center of a Staircase or Ramp
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A railing can be just a handrail, or a balustrade with
posts, top/bottom rails and newels. Using the Railing
on Stair Center tool you can insert a railing along the
center of a staircase easily by just clicking two points
on the stair.
To insert a railing along the center of a staircase:
1. Select Insert > Railings > Railing on Stair

Center, or click the down arrow next to the
Railings button on the Building toolbar
and select Railing on Stair Center.

2. In the catalog, select the railing type you
want to insert.

3. Select a point anywhere along the bottom of
the staircase (or along the tread where you
want the bottom of the railing to sit) to define
the level of the railing’s bottom post. Your
cursor will snap to the center of the staircase
as you start to draw the railing.

4. Select a point anywhere along the top of the
staircase (or along the tread where you want
the top of the railing to sit) to define the level
of the railing’s top post.

5. Right-click and select Finish.

Inserting a Horizontal Railing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Railing by Picking Points tool to
create a horizontal railing anywhere in your model.
You may, for example, want to create a railing around
a stairwell, or insert a railing to separate two rooms in
your house. You create the railing by picking the start
point and end point of the railing. Each point you
pick serves as a main post point.
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To insert a railing along a floor:
1. Make sure the building location that you

want to insert the railing on is current.

2. Select Insert > Railings > Railings by Pick-
ing Points, or click on the Building tool-
bar.

3. In the catalog, select the railing type you
want to insert.

4. Select the start point for the railing.

5. Select an end point for the railing. You can
continue adding sections to the railing if you
want.

6. Right-click and select Finish.

Parts of a Railing

Editing Railing Properties
When editing a railing, you can choose a different
railing type as well as control the dimensions and
settings of posts, rails and newels.
To edit railing properties:
1. Select the railing. If the railing has multiple

segments, use Shift+click to select the remain-
ing segments.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Railings dialog, select the Basic tab.
4. To change the railing type, click on the type

you want in the Type area.

5. To edit the settings of individual railing
components, make your changes in
parameters window. The available
parameters vary depending on the railing
type. Clicking a dimension marked with an

alphabetical character (a, b, c, etc.) highlights
the corresponding dimension in the railing
graphic, and vice versa.
Posts

Include Posts. Inserts a post at the railing’s
start point and endpoint, and at points in
between defined by the Post Spacing.

Include First Post. If disabled, eliminates the
post at the start point of the railing.

Include Last Post. If disabled, eliminates the
post at the end point of the railing.

Post Spacing. The distance between
intermediate posts in your railing.

Post Position. Choosing From Start measures
the intermediate posts from the start point of
the railing. Choosing Centered inserts an
intermediate post at the center of the railing
and measures other intermediate posts from
there.

Post Height. This value is determined by the
handrail and bottom rail heights.

Post Style. Choose either Rectangle or Round
for the post shape.

Post Width. The width of the post.
Post Depth. The depth of the post.
Post Rotation. Determines the rotation of the
connecting post where two railings connect.
Choosing Half Way rotates the connecting
post half way between the angle. Choosing
None leaves the connecting post aligned to
the first railing.
Handrail

Handrail Height. The height of the handrail
above the insertion surface.

Make Continuous. Makes the handrail cut
through all posts, creating a continuous, solid
member.

Handrail Style. Choose either a Rectangle or
Round shape.

Handrail Width. The width of the handrail
(as seen in 2D plan view).

Handrail Depth. The depth (thickness) of the
handrail.
Bottom Rail
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Bottom Rail Height. The height of the
bottom rail from the insertion surface.

Bottom Rail Style. Choose either a Rectangle
or Round shape for the rail.

Bottom Rail Width. The width of the bottom
(as seen in 2D plan view).

Bottom Rail Depth. The depth (thickness) of
the bottom rail.
Balusters

Baluster Spacing. The horizontal distance
between balusters.

Baluster Style. Choose either Rectangle or
Round for the baluster shape.

Baluster Width. The width of the baluster.
Baluster Depth. The depth (thickness) of the
baluster.
Stair Insertion

Post Offset. The horizontal offset of the first
post from the bottom of the staircase. Only a
positive value can be specified, which moves
the post further back along the stairs.

Side Offset. Offset of railing from the sides
of the treads.

Connection. Determines how railings are
connected to the staircase. Connection 2
maintains the distance from the nosing to the
railing at all times. Connection 1 breaks this
rule to create a nicer-looking railing.

6. Click OK.

Changing the Length of a Rail-
ing
You can lengthen or shorten a railing by clicking and
dragging one of its end points.
To stretch a railing:
1. Select the railing. A grip is displayed at each

railing end.

2. Hover your pointer over the railing end you
want to stretch. The Lengthen cursor is dis-
played.

3. Click and drag to lengthen or shorten the rail-
ing, then release your mouse button.

Stretching a Railing
You can use the Stretch tool to lengthen or shorten a
railing and re-position it at the same time.
To stretch a railing:
1. Select the railing.

2. Right-click and select Stretch.
3. Click and drag the railing end you want to

adjust, then release the mouse button.
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To complete your structural model, you want to insert a roof over it. The design of your roof can be a major factor in
the overall look and feel of your home. Inserting a roof in Envisioneer is incredibly simple. Just click inside your
model and the roof is inserted.

Roofs are inserted by location. Therefore, if you have a two-story house, each story may require its own roof if the
levels are split. The great thing about roofs in Envisioneer is that you can edit each roof edge individually to achieve
the precise geometry, dimensions and appearance you want. This means that virtually any roof configuration is
possible, including multiple pitch, multiple plate height roofs. And with a wide selection of roof styles to choose
from, including hip, gable, mansard and arched, you can be as creative as you want.

To give your roof design that extra edge, you can add things like dormers, skylights and roof accessories such as
solar panels and roof vents, all of which are completely customizable to suit your needs.

Inserting an Automatic Roof Over Perimeter Walls
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can use the Roof by Perimeter tool to automatically insert a roof over the perimeter wall layout of a selected
building location. If you have a two-story home where the ground floor wall layout is different than the upper story
wall layout, and you want each story to have its own roof, you will need to insert a roof on each location.

By default, the roof is inserted directly on top of the walls of the current building location. You can edit the support
height as well as change the roof’s style and dimensions.
To insert a roof over an entire wall layout:
1. Make sure the current location is the location containing the walls you want to insert the roof over.

2. Select Insert > Roofs > Roof by Perimeter, or click on the Building toolbar.

3. In the catalog, select the roof type you want to insert. Note that the catalog does not contain gable roofs. If
you want to create a gable roof, insert a hip roof first, then convert it to a gable.

4. Click inside the wall perimeter. The roof is inserted automatically.

Note: If a roof already exists on the current location, it will be deleted.

Inserting a Roof By Picking Points
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can use the Roof by Picking Points tool to create a roof of a custom size and shape by drawing the basic outline
of the roof. This option is ideal when you want the roof to cover only a specific area, such as a porch.
To create a roof by picking points:
1. Make sure the current location is the location containing the walls that you want to insert the roof over.

2. Select Insert > Roofs > Roof by Picking Points, or click the down arrow next to the Roofs button on
the Building toolbar and select Roof by Picking Points.

- 117 -
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3. In the catalog, select the roof type you want
to insert. Note that the catalog does not con-
tain gable roofs. If you want to create a gable
roof, insert a hip roof first, then convert it to a
gable.

4. Select a start point for the roof outline. Typ-
ically you would select an exterior wall
corner. Continue selecting points until the
boundary is defined. If you make a mistake
while drawing the outline you can undo the
last segment drawn by right-clicking and
selecting Step Back. You do not have to
select the start point again because the last
point you pick is always closed back to the
start point.)

5. Right-click and select Finish.

Note: If the roof you are inserting runs up against
any upper-story walls, the roof will cut around the
walls. You can adjust the roof to avoid saddle
situations, or to ignore the walls. See Changing the
Way a Lower-Story Roof is Created on page 118.

Tip: You can create any custom, complex roof by
drawing the individual surfaces of the roof.

Selecting a Roof for Editing
You can select a roof by clicking on one of its edges.
When you select a roof, the entire roof is selected, and
a number of different grips and markers appear on
the roof.

General editing tools like Move and Rotate will affect
the roof as a whole. By clicking and dragging the
solid blue grips at the center of each edge you can
move an edge to effectively stretch the roof. By
clicking and dragging the hollow blue grips at the
corners, you can stretch the corners of the roof to
reshape it.

The red and green arrows are surface markers. The
green arrow indicates the currently selected surface
(roof segment). Changes to most properties, such as
the roof type, slope, and overhang distance, affect
only the currently selected surface (which is marked
by the green arrow). You can make additional
surfaces current by simply clicking on the red arrows
to change them to green. This lets you apply changes
to multiple surfaces simultaneously.

Changing the Way a Lower-
Story Roof is Created
By default, a lower-story roof cuts around upper-story
walls where it runs up against upper-story walls. You
can adjust the roof to avoid saddle situations if you
want. A saddle situation is one where rain or snow
runs down the roof slope and collects in areas where
the roof meets a wall. You can also have the roof
ignore the upper-story walls completely.
To change the way a lower-story roof is created:
1. Select the roof, then right-click and select

Properties.
2. In the Roofs dialog, click the Solution Type

button.

3. In the Solution Type dialog, click on the solu-
tion you want.

4. Click OK in the Roofs dialog.

Converting a Hip Roof to a
Gable Roof
To convert a hip roof to a gable roof, you need to
select two hip ends, then select the gable roof type in
the roof properties.
To convert a hip roof to a gable roof:
1. Click on the roof edge of one of the ends you

want to convert. The roof is selected, and
arrows appear on each roof surface edge. The
arrow on the roof edge you selected should
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be green to indicate that it is the currently
selected roof surface.

2. Click on the arrow on the opposite roof edge.
That arrow turns green also. Both hip ends
are now selected.

3. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

4. In the Roofs dialog, click the Hip button in
the Roof Shape area of the Basic page.

5. In the Roof Shape dialog, click the Gable
graphic.

6. Click OK in the Roofs dialog. The roof is con-
verted.

Note: By default, gable ends on a roof do not
display a wall or material within the pitched area
of the roof. To extend the wall beneath a gable end
to the pitched edges of the roof, see Extending Walls
to the Roof on page 64. To display a separate wall in
the pitched area, see Displaying Walls Beneath Gable
Ends on page 119. To display a material in the
pitched area rather than an actual wall, see Defining
the Material at Gable Ends on page 119.

Defining the Material at Gable
Ends
If you have converted hip roof ends to gable roof
ends, you can choose to display a material such as
siding within the gabled areas by enabling the
Display Gable option in the roof's properties and
selecting a material for the roof's Gable End
component. You can also choose to display no
material at all at gable ends, or choose to display an
actual wall. Note that the Gable End material setting
does not apply if you have chosen to display an
actual wall beneath gable ends in the roof's

properties. Also, should you choose to display a
material instead of a wall, the material will have no
framing associated with it.
To change the appearance of raked surfaces under
gable ends:
1. Click on a roof edge to select the roof.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. If you want to display a material within the
pitched areas of the roof's gable ends, enable
the Display Gable check box on the Basic
property page. If you do not want to display
a material at all, disable this check box. (If
you would like to display an actual wall
instead of just a material, click in the Wall
Type field below the Display Gable check
box and select a wall from the catalog. See
Displaying Walls Beneath Gable Ends on page
119.)

4. If you are displaying a material (rather than a
wall) at gable ends, select the Appearance
tab.

5. In the Components list, select Gable End.
6. In the Material area, click the Select button.
7. In the Materials dialog, select the material

you would like to use, then click OK.
8. Click OK in the Roofs dialog.

Note: If the Display Gable option is enabled and
you do not select a wall type to display, the
material specified for the Gable End component on
the Appearance page will automatically be
displayed at the selected gable end. If you want to
display an actual wall instead of just a material at
gabled ends, see Displaying Walls Beneath Gable Ends
on page 119.

Displaying Walls Beneath Gable
Ends
If you have converted hip roof ends to gable roof
ends, you can choose to display a wall within the
gabled areas of the roof (above the main wall). This
can be any wall type in your catalog and can be
different from the main wall type below it. When you
choose to display a wall at a gable end, the wall can
be selected and edited independently of the main wall
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that supports it. If you choose a framed wall, you can
view and edit its framing properties just like any
other wall in your model. Note that you can specify
different wall display settings for each individual
gable end in your roof, as making this change applies
to selected roof edges only.
To display walls beneath gable ends:
1. Click on the roof edge where the gable end is

located. The roof is selected, and the arrow
on the selected roof edge is displayed in
green. If you want to apply the same change
to other gabled ends, click on their arrows to
turn them green as well. Make sure all other
arrows are red.

2. Right-click and select Properties.
3. In the Roofs dialog, enable the Display

Gable check box on the Basic property page.
4. Click in the Wall Type field below the Dis-

play Gable option, then click to display
the Catalog Access dialog.

5. Select the wall type that you would like to dis-
play in the gabled area, then click OK. The
selected wall type is displayed in the Wall
Type field.

6. Click OK in the Roofs dialog.
7. Look at the gabled ends in 3D. If the wrong

material appears to be displayed on the exter-
ior side, you will need to flip the wall. See For-
cing Wall Sides to be Exterior on page 63.

Note: Make sure that the tops of the main walls
beneath the gabled ends of the roof are set to
'Level' instead of 'Auto Extend', 'Slope' or 'Step' in
their properties. Otherwise, the main wall will
extend up and over the gable end wall, resulting in
extraneous wall surfaces in the gabled area.

Note: If you would prefer to display a simple
material in the gabled areas instead of an actual
wall, do not select a wall type in the Wall Type
field. Instead, go to the Appearance property page
and select the desired material for the Gable End
component. See Defining the Material at Gable Ends
on page 119.

Stretching a Roof
You can stretch a roof by clicking and dragging its
grips or by using the Stretch or Move Edge tools on
the roof's right-click menu. Each method has different
options and results.

When grip editing, clicking and dragging the center
grip on a roof edge moves the edge uniformly in the
direction you drag. Clicking and dragging a corner
grip stretches only that corner, allowing you to
reshape the roof surface if desired. Using the click-
and-drag method maintains the support height of the
roof surface.

The Stretch tool allows you to stretch the corners of a
roof edge, allowing for reshaping if desired. When
using the Stretch tool, the Commander becomes active
allowing you to specify a precise stretch distance and
direction. Also, the support height of the roof surface
is maintained.

The Move Edge tool moves the edge of a roof surface
in the direction you specify. There are two options
when stretching a roof edge using the Move Edge
tool. You can either maintain the support height of
the stretched portion or allow the support height to
adjust. When using the Move Edge tool the
Commander is active so that you can specify a precise
move distance and direction if desired.
To stretch a roof by clicking and dragging:
1. Click on a roof edge to select the roof.

2. To uniformly stretch the edge of a roof sur-
face, hover your pointer over the solid blue
grip at the center of the roof edge you want
to move. The Move cursor is displayed.

3. To stretch the corner of a roof surface, hover
your pointer over the hollow blue grip at the
corner you want to stretch. The Stretch cursor
is displayed.

4. Click and drag to stretch the roof, then
release your mouse button.

To stretch or reshape a roof with the Stretch tool:
1. Click on a roof edge to select the roof.

2. Right-click and select Stretch. Your pointer
becomes the Stretch cursor.

3. Click and drag the corner of the roof surface
that you want to move, then release your
mouse button. Or, select a start point for the
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move, then enter the desired move distance
and direction in the Commander.

To move a roof edge and maintain its support
height:
1. Click on a roof edge to select the roof.

2. Hover your pointer over the solid blue grip at
the center of the roof edge you want to move.
The Move cursor is displayed. . Or, right-
click and select Move Edge > Maintain Sup-
port Height. Selecting the Move Edge tool
activates the Commander so that you can see
or specify the precise stretch distance.

3. Click and drag to stretch the roof, then
release your mouse button. If you selected the
Move Edge tool you can also pick a start
point for the move, then type a stretch dis-
tance in the Commander and press Enter to
complete the stretch.

To move a roof edge and allow its support height
to adjust:
1. Click on a roof edge to select the roof.

2. Right-click and select Move Edge > Adjust
Support Height.

3. Click and drag to stretch the roof, then
release your mouse button. Or, pick a start
point for the move, then type a stretch dis-
tance in the Commander and press Enter.

Note: When using the Move Edge - Adjust
Support Height tool, you cannot stretch a roof so
that it extends below the floor level of the building
location on which the roof resides.

Note: If your roof was inserted automatically and
you stretch your exterior wall layout, the roof
stretches with it, eliminating the need to stretch the
roof separately.

Matching Roof Planes
Use the Match Planes tool to instantly change the
plane of one roof surface to match the plane of
another. In the following example, surface A is
selected as the plane to match, and then surface B is
selected as the plane to change. Surface B then has the
same plane as surface A. Notice that the support

height of the surface B lowers to allow for the
adjustment to the plane.

Surface A is the primary surface

Surface B is matched to surface A

To match roof planes:
1. Click on the roof to select it, then right-click

and select Match Planes. Or, select Edit >
Modify Elements > Match Planes.

2. Click on the roof surface whose plane you
want to apply to another surface (i.e. the
plane you want to match to). In 2D plan view
click on the edge of the surface to select it. In
3D click anywhere on the surface to select it.

3. Click on the roof surface whose plane you
want to match with the plane of the first sur-
face selected. The plane adjusts.

4. Right-click and select Finish.

Note: The Match Planes tool is only available for
roofs created with a Roofs tool. It is not available if
the roof has been created with the Surfaces tool, or
converted to surfaces.

Note: Both surfaces must be running in the exact
same direction.

Reshaping a Roof
You can stretch the corners of a roof to change the
shape of its perimeter.
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To reshape a roof:
1. Click on a roof edge to select the roof.

2. Click and drag the hollow blue grips at the
corners of the roof, then release your mouse
button. Alternatively you can use the Stretch
tool on the right-click menu.

Breaking a Roof Surface
You can use the Break tool to insert a break on a roof
surface edge. This splits the surface into two surfaces
that can be edited individually.
To break a roof surface:
1. Select the roof.

2. Right-click and select Break, or select Edit >
Modify Elements > Break.

3. Click on the edge of the surface you want to
break at the point where you want to break it.
A new grip appears at the break point.

Creating Gables Mid-Fascia
You can create a gable on any fascia edge by inserting
two break points to create a new surface, then
changing the shape of the new surface to a gable.
To create a gable mid-fascia:
1. Select the roof.

2. Right-click and select Break, or select Edit >
Modify Elements > Break.

3. Insert a break point on the fascia to define the
start of the gable segment.

4. Select the Break tool again and insert another
break point on the fascia to define the other
end of the gable segment. A new surface is
created between the two break points.

5. Click on the new surface’s arrow to change it
to green. If any other arrows are green, click
them to change them to red.

6. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

7. Click the graphical button in the Roof Shape
area.

8. In the Roof Shape dialog, click on the Gable
option.

9. Click OK. The mid-fascia segment is con-
verted to a gable.

Editing the Basic Properties of a
Roof Surface
Basic roof properties include Shape, Slope, Overhang
Distance, Fascia Distance, etc. Changes are applied to
the currently selected roof surface. You can edit
multiple roof surfaces simultaneously if you want.
Each surface in a roof can have different settings.
To edit the basic properties of a roof surface:
1. Click on the edge of the surface whose prop-

erties you want to edit. The arrow marker on
that edge should be green. To select addi-
tional surfaces to edit, simply click their
arrows to change them from red to green. All
surfaces with green arrows will receive the
changes.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To convert the currently selected segments to
a different roof type, click the graphical but-
ton in the Roof Shape area, then select a roof
type in the Roof Shape dialog.

4. To edit the general dimensions and geometry
of the roof, edit the values on the Basic page.
Note that a gable roof will have fewer
properties.

Slope Value. The pitch of the roof measured
using the Slope Type method selected above.
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Slope Type. The method used to measure the
pitch of the roof. Choose from Degrees, ? in
12, 1 in ?, or Percent.

Thickness. The combined thickness of all
roofing materials, such as shingles and
sheathing. 

Overhang. The distance from the side wall to
the fascia.

Overhang Drop. The distance measured
vertically from the support point to the
underside of the fascia.

Fascia Distance. The distance from the
ground to the top edge of the fascia board.

Horiz. Distance. The maximum horizontal
distance allowed from the support point the
uppermost point of the underside of the
rafter. This is a calculated result from the
Slope Value and Vert. Distance variables.

Vert. Distance. The maximum vertical
distance allowed from the support point to
the uppermost point of the underside of the
rafter.

Framing Offset. The distance below the
surface thickness of the roof that the framing
sits. Eg. Roof finish and sheathing thickness.

Display Gable (gables only). If the currently
selected roof edge is a gable, you can choose
what you want to display beneath the pitched
edges of the roof (None, Surface or Wall).
The None option displays no material.
The Surface option displays a material such
as siding, but no framing. The gable end
material is defined on the Appearance tab.
The Wall option displays an actual wall from
the catalog.

Note: If using the Surface or Wall option,
make sure that the Wall Top of the main
wall that supports the roof is set to Level
and not Auto Extend, Slope or Step.

5. Click OK.

Editing the Height of a Roof Sur-
face
You can raise or lower a roof surface by editing its
Support Height variable.
To edit the height of a roof surface:
1. Click on the edge of the surface whose height

you want to adjust. The surface’s arrow
should be green. To select additional surfaces
to adjust, simply click their red arrows to
change them to green arrows. The change
applies to those surfaces marked with a green
arrow, not the whole roof.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Roofs dialog, select the Support and
Details tab.

4. Edit the value in the Support Height edit
box.

5. Click OK.

Editing a Roof's Frame Details
Building Essentials | Construction Suite
You can choose to frame with rafters or trusses. You
can also select the members you want to use and edit
the precise dimensions of your roof’s framing
configuration.
To edit a roof’s framing details:
1. Click on a roof edge to select the roof.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To select a member type for each component
in the roof frame (rafters, opening headers,
fascia board, ridge board, gable board, hip
board, valley board), click the Specify Fram-
ing button on the Basic page. Specify the
properties in the Roof Framing dialog. See
Specifying Roof Framing Options on page
156.

4. In the Roofs dialog, select the Support and
Details tab.

5. Edit the parameters as desired.

Support Type. Choose Truss or Rafter.
Raised Heel. The portion of the rafter that
rests on the wall plate.
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Birds Mouth. The notch cut in the lower end
of a rafter to fit it to the top plate of a wall.

Seat. The horizontal cut that is made when
cutting a bird's mouth in a rafter.
Fascia

Depth. The thickness of the fascia board.
Plumb. The ends of the rafters are cut
vertically resulting in a 90º fascia board.

Raked. The ends of the rafters have an
angled cut.
Soffit

Plumb. Creates a flat soffit that is parallel
with the ground. 

Raked. Creates a soffit that is angled to
match the roof slope.
Gable

Type. Choose either Plain, Squared, Full Hip or
Half Hip for the gable return.

Horizontal. The horizontal distance of the
return when looking at the gable end face on.

Depth. The depth of the return.
6. Once you have set your properties, click OK.

Converting a Roof to Surfaces
If you have created a roof using one of the Roofs
tools, you can explode the roof into individual
surfaces. This allows for more in-depth editing and
customization.
To convert a roof to surfaces:
1. Click on a roof edge to select the roof.

2. Right-click and select Convert Roof to Sur-
faces, or select Edit > Modify Elements >
Convert Roof to Surfaces.

3. In the Catalog Access dialog, select the
desired surface material for the roof.

4. Click OK. The roof is converted.
Note that the framing on adjoining surfaces will
adjust intelligently so that only one member is present
along each adjoining edge instead of two.

To ensure that roof elements are correctly represented
in 3D, and quantified correctly in the project estimate,
you can use the Roof Edge Type Editor on the
Surfaces menu to verify and specify properties for
each roof edge.

Inserting an Opening in a Roof
Once you have created a roof, you can insert a custom
opening in it of virtually any shape and size using the
Cut Opening tool. You create the opening by picking
points to define its outline.
To insert an opening in a roof:
1. Select the roof by clicking on one of its edges.

2. Right-click and select Cut Opening, or select
Edit > Modify Elements > Cut Opening.

3. Select a start point for the opening.

4. Continue selecting points to define the open-
ing. As you select points, the opening is cre-
ated. The last point picked is always
connected back to the start point to form a
closed shape, so you don’t have to select the
start point again.

5. When you have selected your final point,
right-click and select Finish.

Removing a Roof Opening
You can remove an opening that you have created in
your roof using the Remove Opening tool.
To remove a roof opening:
1. Select the roof.

2. Right-click and select Remove Opening, or
select Edit > Modify Elements > Remove
Opening.

3. Click on one of the roof opening’s corner
grips. The opening is removed.

Note: You cannot use Delete to remove a roof
opening.

Creating Dormers
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A dormer is a small structure that projects from a roof
slope. Dormers are often used to extend the usable
floor area of a second story that is under a moderate
to steeply pitched roof. They can be quite effective in
opening up cramped rooms under the roof. A typical
dormer consists of a roof and three walls. The most
common type of dormer is the gable dormer,
characterized by the front gable in the roof.
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You can also create a dormer without walls. In this
case the dormer roof sits on top of the main roof. Its
purpose is usually to add character to an otherwise
plain roof or to make your roof design more complex.
For example, you can insert a dormer roof on your
main roof and stretch it to create a porch roof or gable
extension.

Dormers are easy to insert - just point and click. You
can control the dormer’s width, roof type, wall type,
and wall height. You can also specify whether or not
you want the dormer to have walls.
To create a dormer:
1. In the building locations drop box, select the

location containing the roof you want to add
the dormer to.

2. Select Insert > Roofs > Dormer Roof, or click
the down arrow next to the Roofs button
on the Building toolbar and select Dormer
Roof.

3. In the Dormers dialog, specify the desired
width for the dormer in the Dormer Width
edit box.

4. Click the Dormer Roof button, then select the
desired roof type for the dormer. By default,
the roof will have a gable front, regardless of
the roof type. If you do not want it to have a
gable front, uncheck the Gable Front check
box.

5. If you want your dormer to have walls, check
the Include Walls check box. Then, click the
Dormer Wall button and select the desired
wall type from the catalog. If you do not
want your dormer to have walls, disable the
Include Walls check box.
Note that dormer walls extend only to the
surface of the main roof. As well, an opening
is cut in the main roof surface to open the
dormer up to the space below.

6. In the Support height above main roof edit
box, type the height of the dormer’s front

wall, not including the raked portion between
the two roof slopes. You can use this option
even if you are not inserting walls to control
the position of the bottom of the dormer roof.

7. Click OK. The dormer’s wall footprint is
attached to your cursor.

8. Position the dormer where you want it, then
click to insert it. In most cases you would
place the front dormer wall directly on top of
the exterior wall.

9. Right-click and select Finish.

Note: If you can’t seem to insert the dormer, it
means that the dormer is too large for the surface
you are inserting it on. You may want to try
decreasing the wall height before inserting it.

Inserting Skylights
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a skylight in your roof with point-and-
click simplicity. The catalog contains a long list of
skylights in a variety of sizes.
To insert a skylight:
1. Select Insert > Roofs > Skylights, or click the

down arrow next to the Roofs button on
the Building toolbar and select Skylights.

2. In the catalog, select the skylight you want to
insert.

3. Position the skylight on the roof.

4. Click to insert the skylight.

5. Right-click and select Finish.

Editing the Properties of a Sky-
light
Skylight properties include height and width, as well
as dimensions for the frame and sash.
To edit the properties of a skylight:
1. Click on the skylight to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties in the Properties window.

Height. The overall height of the skylight
window opening. 
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Width. The overall width of the skylight
window opening.

Frame Depth. The depth of the window
frame.

Frame Width. The thickness of the window
frame.

Frame Offset. The offset of the window
frame from the roof surface.

Sash Offset. The distance the sash sits back
in the window frame. The sash is the frame
that holds the glass.

Sash Depth. The thickness of the sash in plan
view.

Sash Width. The width of the sash in
elevation.

4. Once you’ve set your properties, click OK.

Inserting Roof Accessories
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add elements such as solar panels and roof
vents to your roof using the Roof Accessories tool.
When you insert a roof accessory on a roof, it inserts
directly on the roof surface at the same angle as the
roof surface.
To insert a roof accessory:
1. Select Insert > Roofs > Roof Accessories, or

click the down arrow next to the Roofs button
on the Building toolbar and select Roof

Accessories.

2. In the catalog, select the roof accessory that
you would like to insert.

3. Click on the roof surface on which you want
to insert the accessory. If you are in 2D plan
view, click on the edge of the roof surface. If
you are in 3D view you can click anywhere
on the surface. The element is attached to
your cursor.

4. Position the element where you want it, then
click to insert it.

5. Right-click and select Finish.
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You can use the Surfaces tool to create a floor, roof or ceiling surface of virtually any size and shape. You can control
the slope of a surface, as well as the elevation of the upper and lower points of the surface. The Surfaces tool can
help you handle special or complex construction situations.

A full menu of editing tools are available for editing surfaces, including Move, Rotate, Duplicate, Curve and Cut
Opening. You can also join two or more surfaces together to meet your specific construction needs.

Creating a Surface
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can use the Surfaces tool to create a custom floor, roof or ceiling surface. First you draw the surface by picking
points, then define its slope. This lets you create a surface of any size, shape or slope, which can be useful in special
or complex construction situations.
To create a surface:

1. Select Insert > Surfaces > Surfaces, or click on the Building toolbar.

2. In the catalog, select the material you would like to use to create your surface.

3. Select two points to define the first edge of the surface. If the surface will be sloped, start by drawing what
will be the lower edge of the surface. The surface will incline from this edge.

4. Continue selecting points to define the shape of the surface. As you select points, an arrow is displayed that
indicates the direction of the slope. Note that since the surface is always closed, you do not need to pick the
start point again to close it.

5. When you have defined the shape, right-click and select Finish. The Define Surface dialog appears.

If you want the lower edge of the surface to sit at a specific height, enter the height in the Lower Point edit
box, then click the lock icon to lock that value in. Otherwise, this value will be variable depending on the
Upper Point height or Slope Value.

If you want the upper edge of the surface to sit at a specific height, enter the height in the Upper Point edit
box, then click the lock icon to lock the value in. Either the Lower Point or Slope Value fields must be
unlocked in order to be able to enter an upper point value.

If you want the surface to have a specific slope, enter the slope in the Slope Value edit box. By default, the
slope is measured using the 1 in ? method. If you use a different method for slope measurement, select it
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from the Slope Type drop box. Other choices
are ? in 12, Degrees, and Percent. If you choose
to lock the slope value, the Lower Point and
Upper Point values become variable.

6. In the Define Surface dialog, enter values to
define the slope of the surface. There are a
few different ways to do this:

If you want the lower edge of the surface to
sit at a specific height, enter the height in the
Lower Point edit box, then click the lock icon
to lock that value in. Otherwise, this value
will be variable depending on the Upper
Point height or Slope Value. 

If you want the upper edge of the surface to
sit at a specific height, enter the height in the
Upper Point edit box, then click the lock icon
to lock the value in. Either the Lower Point or
Slope Value fields must be unlocked in order
to be able to enter an upper point value.

If you want the surface to have a specific
slope, enter the slope in the Slope Value edit
box. By default, the slope is measured using
the 1 in ? method. If you use a different
method for slope measurement, select it from
the Slope Type drop box. Other choices are ?
in 12, Degrees, and Percent. If you choose to
lock the slope value, the Lower Point and
Upper Point values become variable.

7. Click OK.

Resizing or Reshaping a Sur-
face
You can resize or reshape a surface by clicking and
dragging its edges and corners.
To resize or reshape a surface:
1. Select the surface by clicking on one of its

edges.

2. To resize the surface, click and drag the solid
blue grips located at the center of each edge.
Alternatively you can use the Move Edge
tool on the right-click menu to move an edge.

3. To reshape the surface, click and drag the hol-
low blue grips located at the corners. Altern-
atively you can use the Stretch tool on the
right-click menu. You can add nodes to the
surface edges to create more grips for stretch-
ing.

Adding a Node to a Surface
You can add nodes to surface edges to create more
grips. You can then click and drag the grips to
reshape the surface.
To add a node to a surface:
1. Select the surface.

2. Right-click and select Surface Commands >
Add Surface Node, or select Edit > Modify
Elements > Add Surface Node.

3. Click on the point on the surface edge where
you want to add a node. The edge is split into
separate edges, each with its own grips for
moving and stretching.

Editing the Slope of a Surface
You can edit the slope of a surface after you have
inserted it. You can also edit the lower point and
upper point heights.
To edit the slope of a surface:
1. Select the surface.

2. Right-click and select Surface Commands >
Define Surface, or select Edit > Modify Ele-
ments > Define Surface.
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3. Edit the values in the Define Surface dialog,
then click OK.
If you want the lower edge of the surface to
sit at a specific height, enter the height in the
Lower Point edit box, then click the lock icon
to lock that value in. Otherwise, this value
will be variable depending on the Upper
Point height or Slope Value. 

If you want the upper edge of the surface to
sit at a specific height, enter the height in the
Upper Point edit box, then click the lock icon
to lock the value in. Either the Lower Point or
Slope Value fields must be unlocked in order
to be able to enter an upper point value.

If you want the surface to have a specific
slope, enter the slope in the Slope Value edit
box. By default, the slope is measured using
the 1 in ? method. If you use a different
method for slope measurement, select it from
the Slope Type drop box. Other choices are ?
in 12, Degrees, and Percent. If you choose to
lock the slope value, the Lower Point and
Upper Point values become variable.

Editing the Location of a Sur-
face's Lower or Upper Point
The ends of the arrow on a surface represent the
Lower Point and Upper Point of the surface when you
are defining the surface. By default, the Lower Point
and Upper Point are located on the edges of the
surface. You can edit the location of the Lower Point
or Upper Point on the surface by adjusting the length
of the up-slope arrow.

For example, if you were creating a roof surface, and
wanted it to have an overhang of 16”, you could
move the bottom end of the arrow 16” away from the
lower surface edge. You would then enter the roof
support height in the Lower Point edit box when
defining the surface.
To edit the length of the arrow:
1. Select the surface.

2. Right-click and select Surface Commands >
Lengthen Arrow, or select Edit > Modify Ele-
ments > Lengthen Arrow.

3. Click and drag the ends of the arrow to
adjust its length.

Editing the Up-Slope Direction
of a Surface
You can change the up-slope direction of a surface by
editing the rotation of the surface arrow.
To edit the up-slope direction of a surface:
1. Select the surface.

2. Right-click and select Surface Commands >
Define Surface, or select Edit > Modify Ele-
ments > Define Surface.

3. In the Define Surface dialog, edit the value
in the Rotation edit box.

4. Click OK.

Joining Surfaces Together
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Intersect Planes tool to join two
surfaces together. To join two surfaces, you select the
edge on each surface that you want to extend. The
Intersect Planes tool calculates the plane where the
two surfaces would intersect in space and extends the
surface edges to this plane. This tool is particularly
useful when creating a complex roof configuration
where different surfaces have different slopes.
To join two surfaces together:
1. In 2D plan view, select Insert > Surfaces >

Intersect Planes, or click the down arrow
next to the Surfaces button on the Build-
ing toolbar and select Intersect Planes.

2. On the first surface, click on the edge that
you want to extend.

3. On the second surface, click on the edge that
you want to extend. The surface edges are
extended to the intersecting plane.
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Defining Roof Surface Edge
Properties
Pro Architect | Building Essentials | Construction Suite

When you convert a roof to surfaces, or create a roof
using the Surfaces tool, each edge of a roof has a
definition applied to it that determines its appearance
in 3D. For example, an edge defined as a Gable may
have a gable end return. The roof edge definition also
determines the properties of a roof edge, and these
properties are calculated in quantity reports - for
example, as hip length, ridge length, valley length,
and so on.

Below are sample roof surface edge definitions for a
standard hip roof:

Edges can be defined as a Fascia, Gable, Hip, Valley
or Ridge, or have no definition.
To define a roof surface edge:
1. Select Insert > Surfaces > Roof Edge Type

Editor. All roof surface edges in your
drawing are marked with colored arrows,
and the Roof Edge Type Editor appears on
the right side of the screen:

The color of each arrow indicates the type of
each roof edge, as referenced in the editor.

2. To edit a roof edge's type, select the desired
option in the Roof Edge Type Editor.

3. If Fascia is selected as the roof edge type,
you can specify the following settings:

[Fascia] Depth. The thickness of the fascia
board.

Plumb. The ends of the rafters are cut
vertically resulting in a 90º fascia board.

Raked. The ends of the rafters have an
angled cut.

Include Soffit. Includes a soffit along the
edge.

[Soffit] Width. The width of the soffit.
Plumb. Creates a flat soffit that is parallel
with the ground. 
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Raked. Creates a soffit that is angled to
match the roof slope.

4. If Gable is selected as the roof edge type, you
can specify the following settings:

Type. Choose either Plain, Squared, Full Hip or
Half Hip for the gable return.

Horizontal. The horizontal distance of the
return when looking at the gable end face on.

Depth. The depth of the return.
Gable Soffit Width. The width of the soffit
along the gable edge.

5. To display arrows that indicate slope dir-
ections on your roof, enable the Display
Slope Arrows check box.

6. Click on the arrow to which you want to
apply the change.

7. When you have finished, click Close.

Editing Roof Surface Edge
Details
The fascia, soffit and gable settings on a roof surface’s
Details property page determine the appearance and
construction of roof surface edges defined as Fascias
or Gables.
To edit roof surface edge details:
1. Click on a surface edge to select the surface.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Surfaces dialog, select the Details tab.
4. Edit the settings as desired. They are

described below.
Fascia 

Depth. The thickness of the fascia board.
Plumb. The ends of the rafters are cut
vertically resulting in a 90º fascia board.

Raked. The ends of the rafters have an
angled cut.
Soffit

Plumb. Creates a flat soffit that is parallel
with the ground.

Raked. Creates a soffit that is angled to
match the roof slope.
Gable

Type. Choose either Plain, Squared, Full Hip
or Half Hip for the gable return.

Horizontal. The horizontal distance of the
return when looking at the gable end face on.

Depth. The depth of the return
5. Click OK.

Curving a Surface Edge
You can curve a surface edge using the Curve tool.
Once the tool is active, you can click and drag the
edge to curve it, or select a point to curve to.
To curve a surface edge by clicking and dragging:
1. Click on the edge you want to curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Click and drag the surface edge to the desired
curve.

4. Release your mouse button.
To curve a surface edge to a selected point:
1. Click on the surface edge you want to curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Select the point you want to curve to. The sur-
face edge automatically curves to the point.

4. Click to finish.

Editing the Thickness of a Sur-
face
You can edit the thickness of a surface on its Basic
property page.
To edit the thickness of a surface:
1. Select the surface by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the value in the Thickness edit box on
the Basic page.

4. Click OK.

Cutting an Opening in a Surface
You can use the Cut Opening tool to quickly create an
opening of any shape or size.
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To create an opening in a surface:
1. Select the surface.

2. Right-click and select Cut Opening.
3. Select a start point for the opening, then con-

tinue selecting points to define the size and
shape of the opening. Note that you do not
have to select the start point again to finish
the outline — the last point picked is always
connected to the start point.

4. Right-click and select Finish.

Editing Surface Openings
You can resize, reshape and curve openings in a
surface in the same way that you would edit the
surface itself.

See the following topics:

Resizing or Reshaping a Surface on page 128

Curving a Surface Edge on page 131

Removing an Opening from a
Surface
You can remove an opening from a surface using the
Remove Opening tool.
To remove an opening from a surface:
1. Select the surface.

2. Right-click and select Remove Opening, or
select Edit > Modify Elements > Remove
Opening.

3. Click on the edge of the opening that you
want to remove.

Note: You cannot remove an opening from a
surface using Delete.
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The Interiors menu contains just about everything you would ever need to furnish and equip the interior of your
home.

You may want to start with the handy Kitchen Builder Wizard to automatically create a kitchen design comprising
cabinets and appliances. Just choose the shape, layout and materials you want, and then click to position and size
the configuration to your exact specifications. If you prefer you can insert cabinets and appliances individually.

The Bathroom Builder Wizard works in much the same way — just step through the screens to select the layout and
components you want, then watch as your bathroom is instantly created.

There are also a number of tools available for laying out utilities and equipment. These include Plumbing, Electrical,
Equipment and HVAC.

Creating a Kitchen with the Kitchen Builder Wizard
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Using the Kitchen Builder Wizard you can quickly create a kitchen layout that includes upper and lower cabinets, a
sink, refrigerator and stove. There are a number of layouts and styles to choose from.
To create a kitchen with the Kitchen Builder Wizard:
1. Select Insert > Design Wizards > Kitchen Builder, or click the down arrow next to the Design Wizards

button on the Building toolbar and select Kitchen Builder.

2. Click Next.
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3. Click on the general style of kitchen you want
— L-Shape, Galley or U-Shape.

4. Click Next.

5. Select the layout that most closely resembles
the layout you want. Remember that you can
move and edit things later.

6. Click Next.

7. Select a general style for your kitchen. The
selection you make mainly determines the
materials and colors used for the cupboards
and countertops.

8. Click Next.

9. Select the desired rotation for the kitchen lay-
out by clicking the appropriate graphic.

10. Click Next.
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11. Click Finish. The kitchen configuration is
attached to your cursor.

12. Position the kitchen layout in your kitchen
area. It will automatically snap to the walls
when you get close to them. Click to anchor
the kitchen elements. Dynamic dimensions
are displayed to show you the size of the lay-
out.

13. If you want you can stretch the layout by
simply moving your pointer in the direction
you want to stretch.

14. Once the dimensions are correct, click to
finish the insertion.

15. Click Yes to finish the task. If you click No
you can reposition or resize the kitchen.

Creating a Custom Kitchen Wiz-
ard Configuration
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A Kitchen Builder Wizard configuration determines
what types of cabinets and appliances are used in
your kitchen. You are asked to select a configuration
for your kitchen when you run the Kitchen Builder
Wizard.

You can edit any of the existing configurations that
are available in the Kitchen Builder Wizard, or create
your own. Customized configurations are saved
automatically and will be available when you run the
Kitchen Builder Wizard in the current project, or any
other project.
To access the kitchen configuration library:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager dialog, select Librar-
ies > Kitchen Configuration.

To add a new configuration to the list:
1. Select Edit > Add Configuration, or right-

click in the Kitchen Configurations window
and select Add Configuration. An entry
named ‘New Configuration’ is added to the
list.

2. Select the new configuration in the list. If you
want to rename it, select Edit > Rename Con-
figuration, or right-click and select Rename
Configuration. Then, type the new name and
press ENTER.

To edit a kitchen configuration:
1. Select the configuration in the list. The ele-

ment selections for the configuration are lis-
ted in the center pane.

2. In the center pane, select an element type you
want to specify a style for (e.g. Refrigerator).

3. Click the Select button.
4. In the Catalog Access dialog, select the spe-

cific style you want to apply to the selected
element type, then click OK.

5. Continue selecting styles for the remaining
element types.

To delete a configuration from the list:
1. Select the configuration in the list.

2. Select Edit > Delete Configuration, or right-
click and select Delete Configuration, or
simply press the Delete key on your key-
board.
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Creating a Bathroom with the
Bathroom Builder Wizard
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Bathroom Builder Wizard you can quickly
and easily create a bathroom layout that includes a
cabinet, sink, toilet, tub and shower. There are a
number of layouts and styles to choose from.
To create a bathroom with the Bathroom Builder
Wizard:
1. Select Insert > Design Wizards > Bathroom

Builder, or click the down arrow next to the
Design Wizards button on the Building
toolbar and select Bathroom Builder.

2. Click Next.

3. Select the image that contains the elements
you want to include in your bathroom.

4. Click Next.

5. Click on the layout you want the bathroom
elements to have.

6. Click Next.

7. Select a style for your bathroom elements.
Each style dictates which cabinet, countertop,
sink, toilet, tub and shower will be used.
Remember that you can edit the properties of
individual elements later.

8. Click Next.
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9. Click on the desired rotation for your bath-
room configuration. This is how the con-
figuration will be oriented when you are
inserting it in your plan.

10. Click Next.

11. Click Finish.
12. Position the bathroom layout in your bath-

room area. It will automatically snap to the
walls when you get close to them. Click to
anchor the bathroom elements. Dynamic
dimensions are displayed to show you the
size of the layout.

13. Move your cursor to stretch the layout to the
desired size, then click again to finish.

14. If you are satisfied with the bathroom place-
ment, click Yes to finish the task. If you click
No you can reposition or resize the layout.

Creating a Custom Bathroom
Wizard Configuration
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A Bathroom Builder Wizard configuration determines
what types of cabinets and plumbing fixtures are used
in your bathroom. You are asked to select a
configuration for your bathroom when you run the
Bathroom Builder Wizard.

You can edit any of the existing configurations that
are available in the Bathroom Builder Wizard, or

create your own. Customized configurations are
saved automatically and will be available when you
run the Bathroom Builder Wizard in the current
project, or any other project.
To access the bathroom configuration library:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager dialog, select Librar-
ies > Bathroom Configuration.

To add a new configuration to the list:
1. Select Edit > Add Configuration, or right-

click in the Bathroom Configurations window
and select Add Configuration. An entry
named ‘New Configuration’ is added to the
list.

2. Select the new configuration in the list. If you
want to rename it, select Edit > Rename Con-
figuration, or right-click and select Rename
Configuration. Then, type the new name and
press ENTER.

To edit a bathroom configuration:
1. Select the configuration in the list. The ele-

ment selections for the configuration are lis-
ted in the center pane.

2. In the center pane, select an element type you
want to specify a style for (e.g. Vanity).

3. Click the Select button.
4. In the Catalog Access dialog, select the spe-

cific style you want to apply to the selected
element type, then click OK.

5. Continue selecting styles for the remaining
element types.

To delete a configuration from the list:
1. Select the configuration in the list.

2. Select Edit > Delete Configuration, or right-
click and select Delete Configuration, or
simply press the Delete key on your key-
board.

Inserting Cabinets
Personal Architect | Pro Architect | Building Essentials |
Construction Suite



- 138 -

Cabinets are essential for storage and can also
contribute to the overall look and feel of a room. The
catalog contains a huge selection of cabinet types,
styles and sizes, all customizable to suit your taste
and needs.

Cabinet types include base cabinets, corner cabinets,
upper cabinets, islands, pantry cabinets and bathroom
vanities.

You can insert cabinets in your design by simply
pointing and clicking with your mouse. Cabinets
automatically snap to walls and other elements when
you get close to them provided Collision Control is
turned on.

Note that most cabinets in the catalog have a
countertop displayed. If you plan to insert a custom
countertop over inserted cabinets with the Countertop
tool, you may first want to turn off the Show
Counter property for those cabinets. See Editing
Cabinet Properties on page 138.
To insert a cabinet:
1. Select Insert > Interiors > Cabinets, or click

on the Interiors toolbar.

2. In the catalog, select the cabinet you want to
insert.

3. Position the cabinet where you want it, then
click to insert it.

4. Right-click and select Finish.

Editing Cabinet Properties
Cabinet properties include cabinet type, size, and leaf
style, as well as settings for the counter, shelves, toe
space and hardware.
To edit cabinet properties:
1. Select the cabinet whose properties you want

to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To change the cabinet type, dimensions or 2D
representation, select the Basic tab.
To specify the cabinet type, click the Type
drop box and select either Base, Upper and
Pantry. You can then select a style for the
cabinet. Cabinet styles and size properties
will vary depending on the cabinet type

selected. Note that there is a Spacer style for
filler cabinets.

Use the graphics as guides when determining
the cabinet’s properties. Clicking a dimension
marked with an alphabetical character (a, b, c,
etc.) highlights the corresponding dimension
in the cabinet graphic, and vice versa. Note
that if you change the dimensions of a cabinet
that has a patterned door leaf, the leaf
material will remap itself automatically to
match the new cabinet size.

In the 2D Representation area you can
specify whether or not the left and right
edges of the cabinet are displayed in 2D.

4. To change the cabinet’s leaf style, select the
Leaf tab.

5. To select a leaf style for the door, select Door
from the Apply to drop box, then make your
selections. To select a leaf style for the draw-
ers, if applicable, select Drawer from the
Apply to drop box. Leaf properties vary
depending on the leaf style selected. Use the
graphics as guides when setting these prop-
erties. If you would like to use a custom door
leaf that has been imported into the Door
Leafs library, select the Custom type, then
select the desired leaf from the library.

6. To edit the counter, shelving, toe space or
hardware details, select the Details tab.
Counter

Show Counter. Displays a counter on the
cabinet.

Thickness. The thickness of the counter
material.

Show Backsplash. Displays a backsplash on
the cabinet. The backsplash is a vertical
surface designed to protect the wall behind a
countertop.

Thickness. The thickness of the backsplash
material.

Height. The distance from the countertop to
the top of the backsplash.

Show Nosing. Displays nosing (moulded
projection) on the front edge of the counter.

Thickness. The depth of the nosing.
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Height. The height of the nosing.
Radius. The radius of the curve.
Shelves

Show Shelves. Displays shelves inside the
cabinet. The shelves would be visible if the
cabinet door is glass.

Number of Shelves. The number of shelves
you would like to display inside the cabinet.
Toe Space

Style. Select Indent for a recess of a specified
depth, Floating for completely open space
beneath the entire cabinet, or None for no toe
space.

Depth. For an indented toe space, this is the
depth of the recess.

Height. The height of the recess.
Hardware

Show Handle. Displays handles on the
cabinet door and drawers, if present.

Handle Style. Choose from Box, Circle or
Cylinder. A box style creates a rectangular
handle. A circle style creates a round knob.
The cylinder style creates a cylindrical
handle.

Distance a. For pantry cabinets, this is the
distance from the bottom of the upper cabinet
portion to the top of the door handle.

Distance b. The distance from the bottom of
the cabinet to the top of the door handle.

7. When you’re finished editing properties, click
OK.

Inserting a Countertop
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a countertop anywhere in your
drawing by picking points.

The width, thickness and appearance of a countertop
is determined by the countertop’s properties in the
catalog. You control the length and direction of the
countertop as you draw it.

Note that most cabinets in the catalog have a
countertop displayed. If you plan to insert a
countertop using the Countertop tool, you may first

need to disable the Show Counter option in the
properties of those cabinets, so that you do not have
two countertops. See Editing Cabinet Properties on page
138.
To insert a countertop:
1. Select Insert > Interiors > Countertop, or

click on the Interiors toolbar.

2. In the catalog, select the countertop that you
want to insert.

3. Select a start point. Note that your insertion
point is on the center line of the countertop.

4. Move your cursor in the direction you want
the countertop to run, then select an endpoint
for the countertop. You can continue selecting
points in any direction to add more segments
to the countertop if you want.

5. Double-click to finish, or right-click and select
Finish.

Editing the Properties of a Coun-
tertop
You can customize a countertop in the catalog, or one
that you have inserted with the Countertop tool. For
example, you can change its insertion height, width,
backsplash, and nosing.
To edit the properties of a countertop:
1. Select the countertop.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Basic tab you can specify the
following properties:

- Type

- Insertion Height

- Insertion Direction (Left or Right.
Determines which edge the nosing is on.)

- Thickness

- Width

- Backsplash Type (None, Nosing, Backsplash)

- Backsplash Thickness

- Backsplash Height

- Nose Type (None, Nosing)

- Nosing Thickness

- Nosing Height
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4. On the Appearance tab you can specify the
Layer, Material and Pattern for each com-
ponent of the countertop (2D Component,
Surface, Splash).

5. On the Quantity tab you can specify whether
or not you want the countertop to be include
in quantity reports, and specify quantity prop-
erties such as Price, Phase and Category.

6. Click OK.
If the countertop was not inserted with the
Countertop tool, and is instead associated with a
cabinet, you must edit the countertop through the
cabinet properties. On the Details tab of the cabinet
properties dialog you can specify the thickness of the
counter, and whether or not it is displayed. On the
Appearance tab you can specify the layer, material
and pattern for the cabinet's Counter component.

Inserting Appliances
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a wide variety of kitchen and laundry
appliances in your design by simply pointing and
clicking with your mouse. Appliances automatically
snap to walls and other elements when you get close
to them provided Collision Control is turned on.
To insert an appliance:
1. Select Insert > Interiors > Appliances, or

click on the Interiors toolbar.

2. In the catalog, select the appliance you want
to insert.

3. Position the appliance where you want it,
then click to insert it.

4. Right-click and select Finish.

Note: If you are inserting a built-in oven, just
position it where you want it in the wall and it will
snap into place correctly with only the oven door
and controls protruding from the wall.

Inserting Interior Furniture
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a variety of furnishings for every
room in your home — everything from beds to CD
stands. Furnishings automatically snap to walls and
other elements when you get close to them provided
Collision Control is turned on.
To insert furniture:
1. Select Insert > Interiors > Interior Furniture,

or click on the Interiors toolbar.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting Electronics
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Electronics include televisions, computers, clocks and
telephones.
To insert electronics:
1. Select Insert > Interiors > Electronics, or

click on the Interiors toolbar.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting Interior Accessories
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Accessories are those small, personal touches that
really pull a room together. They are things like
curtains, blinds, towel racks, shower curtains,
medicine cabinets, plates, bowls, cups, mirrors and
pictures.
To insert accessories:
1. Select Insert > Interiors > Interior Accessor-

ies, or click on the Interiors toolbar.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.
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Inserting Equipment
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a wide range of functional
equipment, including exercise equipment, central vac
units, utility boxes and meters, satellite dishes, and
garbage disposal units.
To insert equipment:
1. Select Insert > Interiors > Equipment, or

click on the Interiors toolbar.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting Interior Lighting
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog offers an excellent selection of lighting
fixtures for the interior of your home. Interior light
fixtures include ceiling lights, wall lights, track
lighting, recessed lights, and lamps.

Each lighting fixture has a light source in its property
definition, such as an incandescent light bulb. Lights
are particularly important if you plan to create a 3D
RealView™ of your model, since the program uses
light to calculate and create the rendered view.

With the exception of lamps, light fixtures are set to
snap to either ceilings or walls depending on what
kind of fixture they are.
To insert a light fixture:
1. Select Insert > Interiors > Interior Lighting,

or click on the Interiors toolbar.

2. In the catalog, select the light fixture you
want to insert.

3. Position the light where you want it, then
click to insert it.

4. Right-click and select Finish.

Tip: If you switch to Rendered or Rendered Outline
display mode, you can see instant lighting effects
as you position and insert light fixtures.

Note: If you want to insert exterior light fixtures,
use the Exterior Lighting tool.

Changing the Way a Light
Snaps Upon Insertion
By default, ceiling lights are set to snap to ceilings,
and wall lights are set to snap to walls. Lamps have
no snap setting so that you can place them anywhere
in a room. You can change a light fixture’s snap
setting on the fixture’s Behavior property page. Note
that this applies to interior light fixtures only.
To change the way a light snaps on insertion:
1. In the catalog, select the light fixture whose

snap setting you want to change.

2. Right-click and select Edit Element.
3. In properties dialog, select the Behavior tab.

4. From the Align Light to drop box, select
either Ceiling, Wall or None.

6. Click OK in the Lights dialog.

Editing a Light Fixture's Light
Source
A light source is usually a type of light bulb. You can
edit a light fixture’s light source to achieve a different
lighting effect.
To edit a light fixture’s light source:
1. Select the light fixture whose properties you

want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Select the Lights tab.

4. To replace the currently selected light source
with another type, click Edit, then select a
light source from the Light Sources dialog.

5. To add a light source to the fixture, click Add,
then select a light source from the Light
Sources dialog.

6. To delete a light source from the light fixture,
click Delete.

7. To edit the position of the light source in rela-
tion to the light fixture, specify the X, Y and Z
coordinates in the Light Position area.

Displaying_a_Rendered_View.htm
Displaying_a_Rendered_Outline_View.htm
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Coordinates are measured from the bottom
center of the fixture. The small red box in the
preview window indicates the current
position of the light source. Changing the X
value moves the light source left or right.
Selecting Middle positions the light in the
center of the fixture, and selecting Minimum
or Maximum positions it on the left or right
side. If you select Custom you can enter a
specific value in the adjacent edit box which
is relative to the center position. For example,
entering -3 moves the light source 3” left
from the center. Changing the Y value moves
the light source forward or backward.
Selecting Minimum brings the light source all
the way forward, and selecting Maximum
moves it to the back of the fixture. Changing
the Z value moves the light source up or
down. Selecting Minimum positions the light
source at the bottom of the fixture, while
selecting Maximum positions it at the top of
the fixture.

8. To edit the orientation of the light source, edit
the Tilt up/down and Tilt left/right values. You
may want to do this if your light fixture is
angled a certain way. For example, if you
have adjustable track lighting, and each
fixture is angled at 45 degrees, you will
probably want to change the tilt of the light
source to 45 degrees as well, so that the light
shines at a 45-degree angle instead of straight
down.

Tilt up/down. The angle of the light beam
relative to the floor. A 0-degree tilt means
that the light shines straight down.

Tilt left/right. The rotation of the light source
left or right.

9. Once you’ve specified the properties, click
OK.

Turning a Light On or Off
By default, lights are on when you insert them. You
can virtually turn lights on and off in one of two
ways:
Turn the light on/off directly:

1. Select the light fixture in your drawing.

2. Right-click and select Light On or Light Off.
Edit the light's properties:
1. Select the light fixture.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Select the Lights tab.
4. To turn the light on or off, click the eye icon

next to the light source name.

Light is turned on 

Light is turned off

5. Click OK.

Inserting Electrical Elements
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert electrical elements such as outlets, light
switches, thermostats and smoke detectors with a
single mouse click. The backs of these elements
automatically snap to walls and are inserted at a
logical height on the wall, making accurate placement
effortless. You can move, raise and lower these
elements after you have inserted them.
To insert electrical elements:
1. Select Insert > Interiors > Electrical > Elec-

trical Elements, or click on the Interiors
toolbar.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Note: You can insert outlets throughout a room
automatically using the Auto Place Outlets tool.

Inserting Outlets Throughout a
Room Automatically
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Auto Place Outlets feature to have
automatically insert outlets throughout selected
rooms in your model. You can move, raise and lower
outlets after they have been inserted.
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To insert outlets automatically:
1. Select Insert > Interiors > Electrical > Auto

Place Outlets, or click on the Interiors
toolbar.

2. If you are using the Auto Place Outlets tool
for the fist time, you will be prompted to
specify the following settings:

Outlet Element. Click Select to choose the
outlet that you would like to be inserted.

Min. wall length. The minimum length that a
wall must be to eligible for an outlet.

Max. distance from outlet. The maximum
distance between one outlet and the next.

Max. distance from opening. The maximum
distance that an outlet can be from a wall
opening.

The values you specify will be saved as the
default values going forward. You can
change the default values at any time by
selecting Settings > Document Settings.

3. Position your cursor inside the room in which
you want to place outlets (it will highlight).

4. Click inside the room. Outlets are inserted
throughout the room according to the settings
you specified.

Note: You can insert outlets individually using the
Electrical Elements tool.

Inserting Electrical Wiring
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Once you’ve inserted electrical elements, you can use
the Wiring tool to indicate the location of electrical
wiring in your 2D plan. By default, wiring lines have
arched segments and use a dashed linestyle. You can
stretch and reshape individual segments after you’ve
inserted the line. You can also edit the linestyle.
Wiring is only visible in 2D plan view.
To add electrical wiring:
1. Select Insert > Interiors > Electrical >

Wiring, or click the down arrow next to the
Electrical button on the Interiors toolbar
and select Wiring.

2. Select a start point for the wiring line.

3. Select the next point for the wiring line. An
arched line segment is created between the
two points. Continue selecting points to add
more segments.

4. Right-click and select Finish.

Note: You can change the line style of individual
wires if you want. You can also mark your wiring
lines with text.

Stretching and Reshaping Wir-
ing
You can stretch individual segments in a wiring line
by clicking and dragging their grips. Stretching
wiring segments can change their length or shape.
To stretch a wiring segment:
1. Select the segment you want to stretch. Grips

are displayed along the segment.

2. Hover your pointer over the grip that you
want to grab and stretch.

3. Click and drag to stretch the line, then release
your mouse button.

Editing the Line Style of Wiring
By default, electrical wiring is displayed using the
Electrical Power Distribution line style, which is a
brown, dashed line. You can select a different line
style for selected wiring segments if you want. For
example, you may want to select the Telephone line
style for your telephone lines.
To edit the line style of wiring:
1. Select one of the line segments you want to

change. Use Shift+click to select the remain-
ing segments in the line.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Line Styles dialog, select the line style
you want to use.

4. Click OK. The line style is updated in your
drawing.
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Selecting a Default Line Style
for Wiring
You can select a default line style to use when
drawing electrical wiring by editing your Drafting
Settings.
To select a default line style for electrical wiring:
1. Select Settings > Drafting Settings, or click

on the Settings toolbar.

2. In the Drafting Settings dialog, select the
Electrical Wiring item.

3. Click Settings.
4. In the Line Styles dialog, select the line style

you want to use as the default when drawing
electrical wiring, then click OK.

5. Click OK in the Drafting Settings dialog.

Note: You can edit the line style of electrical wiring
after it has been drawn.

Inserting Plumbing Fixtures
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Placing plumbing fixtures in your plan is easy — just
select what you want to insert, then point and click.
With Collision Control turned on, fixtures will
automatically snap to walls when you get close to
them. Also, fixtures will insert at a logical height. For
example, a toilet will insert on the floor, while a sink
may insert 3’ off the floor. You can edit a fixture’s size
and elevation, as well as move and rotate it.
To insert plumbing fixtures:
1. Select Insert > Interiors > Plumbing

Fixtures, or click on the Interiors toolbar.

2. In the catalog, select the fixture you want to
insert.

3. Position the fixture where you want it, then
click to insert it.

4. Right-click and select Finish.

Note: Certain sinks can only be inserted into a
cabinet. If you are inserting such a sink, the cabinet
must be large enough to house the sink.

Inserting HVAC Elements
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert HVAC elements such as fireplaces,
furnaces, water heaters, central air units, floor
registers and vents with a click of your mouse.
To insert an HVAC element:
1. Select Insert > Interiors > HVAC Elements,

or click on the Interiors toolbar.

2. In the catalog, select the element that you
want to insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.
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Framing
Walls, floors, ceilings, roofs and surfaces have framing configurations assigned to them in their properties. You can
choose which framing members you would like to use and edit their spacing by editing an element's framing
properties.

Each building location in your project has a set of Framing Options assigned to it. These options determine how
walls are framed on each location. They include a wall opening span table, framing rule, intersection reference table,
and an infill configuration.

By entering into Framing Mode you can create custom configurations for individual walls and intersections in your
model. While in this mode each wall, opening and intersection has special shading applied to it, identifying it as a
unique framing component within the model. Three tools are available in this mode: Intersection Tool, Infill Tool,
and Head Sill Jamb Tool.

Framing members are included in your project estimate. If you would like to generate a member schedule you will
need to convert floor, ceiling and roof framing to actual elements using the Convert Framing to Members tool. After
using this tool you can also select and edit individual members in your floor, ceiling or roof frame.

By default, framing is not visible, but you can use the Display Framing tool to view it instantly. Even when framing
is displayed, framing cannot be selected for editing unless it is floor, ceiling or roof framing that has been converted
to members. However, wall framing can be edited by editing a wall's framing properties, or editing the Framing
Options in the Building Locations dialog. For more in-depth editing you can also switch to Framing Mode and edit
the framing for individual walls and intersections.

Displaying Framing
Building Essentials | Construction Suite
Walls, floors, ceilings and roofs have a framing configuration assigned to them in their properties. You can instantly
view just your house frame using the Display Framing tool, then return to a regular view of your model at any time.

To display framing:

1. Select View > Framing > Display Framingor click on the View Control toolbar.
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To return to a non-framed view:
1. Select View > Framing > Display All But

Framing or click the down arrow next to
on the View Control toolbar and select Dis-
play All But Framing.

Note: You can also use the View Filter to display
framing. However, the framing will not be
displayed on its own unless you turn everything
else off.

Note: Framing cannot be selected for editing in
framing display mode. It is available for viewing
purposes only. You can, however, change the
framing options for walls, floors, ceilings and roofs.

Note: When in framing display mode, any
members inserted with the Members tool are not
visible. Floor, ceiling and roof framing that has
been converted to members is not visible in this
mode.

Returning to a Non-Framed View
Building Essentials | Construction Suite
If you have used the Display Framing tool to view
your house frame, you can instantly return to a non-
framed view using the Display All But Framing tool.
To return to a non-framed view:
1. Select View > Framing > Display All But

Framing or click the down arrow next to the
Display Framing button on the View Con-
trol toolbar and select Display All But Fram-
ing.

Wall Framing
Building Essentials | Construction Suite
Every building location in your project has a number
of framing options assigned to it that determine how
walls on that location will be framed. These options
include:
l Span tables (determines how openings should
be framed)

l Infill (stud/top plate/bottom plate con-
figuration)

l Framing rule (the direction in which walls are
framed)

l Intersection lookup table (determines how
intersections are framed)

You can select the framing member that you want to
use for your walls. You can also specify whether or
not selected walls are framed as load-bearing walls,
and customize the framing settings for each building
location in your project.

You can define custom framing settings for individual
walls, openings and intersections by going into
Framing Mode. In this mode each framing component
(infill, opening and intersection) has special
highlighting applied to it for ease of identification and
selection.

The catalog ships with pre-defined libraries of
head/sill/jamb tables, wall opening span tables, and
infill configurations. You can edit or add to these
libraries to meet your specific construction needs.

Selecting a Framing Member for
Walls
Building Essentials | Construction Suite
Every wall has a setting in its properties that
determines what type of member (e.g. 2 x 4) will be
used to frame the wall. In other words, this is the
member that will be used for the studs, top plate and
bottom plate as well as the members used to frame
openings (except the header).

You can edit the member selection for individual
walls in your model, or for walls in the catalog.
To edit the framing options for an individual wall or
wall type:
1. To edit a wall in your drawing, double-click

it, or select the wall then right-click and select
Properties, or select Edit > Modify Elements
> Properties.
To edit a wall in the catalog, select the wall in
the catalog, then right-click and select Edit
Element.

2. In the Walls dialog, click the Framing
member button.

3. Select the desired member from the Catalog
Access dialog.

4. Click OK.

Framing_Libraries.htm
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Note: By default, walls are framed using the
framing options specified in your building location
settings (see page 147). These options include an
infill configuration that determines settings for the
studs, top plate, bottom plate, and very top plate.
By default, each of these components is set to use a
framing member from the Member Library rather
than the framing member selected in each wall's
properties. See Defining a Wall Infill Configuration
on page 484.

Note: You can override the framing member
selection for individual walls in your model by
customizing the infill configuration applied to the
wall in Framing Mode. See Editing the Infill
Configuration for Individual Walls on page 148.

Note: Stud spacing is determined by the infill
configuration assigned to the building location on
which a wall resides, or by the infill configuration
assigned to a wall in Framing Mode if a custom
one has been selected for it.

Specifying Whether Walls are
Load-bearing or Non-load-bear-
ing
Building Essentials | Construction Suite
You can determine whether or not a wall is framed as
a load-bearing wall by editing the wall's properties.
This ensures that the proper head/sill/jamb
configuration is applied to the wall.
To frame a wall as load-bearing or non-load-
bearing:
1. Select the wall, then right-click and select

Properties. You can select multiple walls sim-
ultaneously.

2. Specify the desired framing behavior for the
Frame As Load Bearing setting:
Auto. The default value for all walls, this
frames exterior walls as load-bearing, and
interior walls as non-load-bearing.

Yes. Frames the selected wall as load-
bearing.

No. Frames the selected wall as non-load-

bearing.

3. Click OK.

Defining Wall Framing Options
for Building Locations
Building Essentials | Construction Suite
Each location in the Building Locations dialog has a
set of framing options that determine how walls,
openings and intersections on that location will be
framed.

Location framing options include a span table
selection, an infill configuration, framing rule, and
intersection reference table.

The framing options you choose will determine what
you see when framing is displayed (with the Display
Framing tool), as well as the members reported in
your Project Estimate. For example, if a wall has an
infill configuration with studs 12" apart, the wall will
have more studs than if it were to have an infill
configuration with studs 16" apart.
To define framing options for a building location:
1. Select Settings > Building Locations, or

click on the View Control toolbar.

2. In the Building Locations dialog, click in the
location's Framing Options field.

3. Make the desired selections in the Location
Framing Options dialog. The options are
described below.

Span table. The wall span table that
determines the head/sill/jamb configuration
to be used for openings of different sizes in
walls. You can select a span table for load-
bearing walls, and one for non-load-bearing
walls.

You can create custom span tables. See
Defining a Wall Opening Span Table on page
477. You can also select a custom span table
for individual walls in Framing Mode. See
Editing the Span Table Selection for Individual
Walls on page 150.

Intersection lookup table. The reference
table containing rules for framing different
types of intersections. You can edit
intersection configurations by going into
Framing Mode and using the Intersection
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tool. See Editing Intersection Framing on page
151.

Infill configuration. The precise layout of
studs, top plate, very top plate and bottom
plate that fill the volume of the wall. You can
define custom infill configurations if you
want. See Defining a Wall Infill Configuration
on page 484. You can also apply different
infill configurations to individual walls in
Framing Mode. See Editing the Infill
Configuration for Individual Walls on page 148.

Framing rule. The direction in which walls
are framed. Options are described below.

From Bottom Left. Walls frame from the
bottom left corner of the drawing area (from
bottom to top, left to right).

From Bottom Right. Walls frame from the
bottom right corner of the drawing area (from
bottom to top, right to left).

From Top Left. Walls frame from the top left
corner of the drawing area (top to bottom, left
to right).

From Top Right. Walls frame from the top
right corner of the drawing area (top to
bottom, right to left).

From Start of Wall. Walls frame from their
"start point", which is the end marked with a
green grip when the wall is selected.

From End of Wall. Walls frame from their "end
point", which is the end marked with a red
grip when the wall is selected.

4. Click OK.

Note: You can override the building location
framing options and specify custom framing
options for individual walls, openings and
intersections in your model by switching to
Framing Mode.

Going into Framing Mode
Building Essentials | Construction Suite

When in Framing Mode, framing components (wall
infill, intersections and openings) are displayed as
"glass boxes", making it easy to identify and select

each one. You can see these glass boxes in both 2D
and 3D views.

Clicking on a wall lets you select the infill
configuration, framing rule and wall opening span
table for that wall. Clicking on an opening lets you
select the opening span table to be used for framing
that opening, or define a custom head/sill/jamb
configuration for that particular opening. Clicking on
an intersection lets you select the intersection framing
configuration that you want to use on that
intersection.
To switch to Framing Mode:
1. Select View > Framing Mode On/Off, or click

on the Framing toolbar.

To exit Framing Mode, select the Framing
Mode On/Off tool or button again.

Editing the Infill Configuration
for Individual Walls
Building Essentials | Construction Suite
Infill refers to the material that fills the volume of the
wall. An infill configuration determines what types of
members are used for the studs, top plate, bottom
plate and very top plate, the spacing between studs,
and the way in which members are aligned and
rotated.

By default, walls are framed using the infill
configuration defined in the Framing Options for each
building location. You can override this setting and
select a custom infill configuration for individual
walls in your model by going into Framing Mode.
To edit a wall's infill configuration:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the wall that you want to edit,

or select the wall and then right-click and
select Properties. When selecting a wall,
watch for the 'Wall Infill' screen tip to appear
so that you know you are selecting the infill
and not another framing component.
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3. To use the infill configuration defined for the
building location on which the wall resides,
enable the Refer to location radio button in
the Infill Configuration area. 

4. To use a custom infill configuration, enable
the Use custom infill configuration radio
button in the Infill Configuration area, then
click the Select custom configuration but-
ton and make a selection from the Wall Infill
Library.

5. To flip the framing from one side of the wall
to the other, enable the Flip framing side
check box. If, for example, you notice that an
opening's header member is positioned
toward the exterior face of the wall and you
want it positioned toward the interior face,
you would enable the Flip framing side
check box to flip the framing to the other side
of the wall.

Note: By default each infill configuration is set to
use framing members from the Member Library
rather than the framing member defined in the
wall's properties. You can change infill settings by
editing the parameters in the infill configuration.
See Defining a Wall Infill Configuration on page 484.
You can also create new infill configurations to suit
your needs.

Editing the Framing Rule for Indi-
vidual Walls
The 'framing rule' refers to the direction in which
walls are framed. You may, for example, want to start
framing walls from the bottom left corner of your
drawing area.

By default, the framing rule used to frame walls is the
one defined in the Framing Options of each building
location. You can override the framing rule for
individual walls in your model by going into Framing
Mode.
To edit a wall's framing rule in Framing Mode:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the wall that you want to edit,

or select the wall and then right-click and
select Properties. When selecting a wall,
watch for the 'Wall Infill' screen tip to appear
so that you know you are selecting the infill
and not another framing component.

3. To use the framing rule defined for the build-
ing location on which the wall resides, enable
the Refer to location radio button in the
Framing Rule area. 

4. To use a custom framing rule, enable the Use
custom framing rule radio button in the
Framing Rule area, then select a framing rule
from the drop box.
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From Bottom Left. Walls frame from the
bottom left corner of the drawing area (from
bottom to top, left to right).

From Bottom Right. Walls frame from the
bottom right corner of the drawing area (from
bottom to top, right to left).

From Top Left. Walls frame from the top left
corner of the drawing area (top to bottom, left
to right).

From Top Right. Walls frame from the top
right corner of the drawing area (top to
bottom, right to left).

From Start of Wall. Walls frame from their
"start point", which is the end marked with a
green grip when the wall is selected.

From End of Wall. Walls frame from their "end
point", which is the end marked with a red
grip when the wall is selected.

Editing the Span Table Selection
for Individual Walls
Building Essentials | Construction Suite
By default, wall openings are framed according to the
span tables selected in the Framing Options of each
building location. There is a span table selection for
load-bearing walls, and one for non-load-bearing
walls. Each span table contains a list of opening sizes
(spans) and the head/sill/jamb configuration that
should be used for each span.

You can override the span table selection in your
building locations and select a custom span table for
individual walls in your model. This can only be done
in Framing Mode.
To edit the span table selection for an individual
wall:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the wall infill that you want to

edit, or select the wall infill and then right-
click and select Properties. When selecting a
wall infill, watch for the 'Wall Infill' screen tip
to appear so that you know for sure that you
are selecting the infill and not another fram-
ing component.

3. To use the span table defined for the building
location on which the wall resides, enable the
Refer to location radio button in the Span
Table area. Then, select either the Load-Bear-
ing or Non-Load-Bearing span table.

4. To use a custom span table, enable the Use
custom span table radio button in the Span
Table area, then click the Select custom span
table button and make a selection from the
Wall Span Table Library.

Editing the Head/Sill/Jamb Con-
figuration for Individual Open-
ings
By default, wall openings are framed according to the
span table selected in the infill settings for the wall in
which the opening resides. A span table contains a list
of opening sizes (spans) and the head/sill/jamb
configuration that should be used for each span. You
can override the span table selection and select a
custom head/sill/jamb configuration for individual
openings in your model. This can only be done in
Framing Mode.
To edit the head/sill/jamb configuration for an
individual opening:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the opening that you want to

edit, or select the opening and then right-click
and select Properties. When selecting an
opening, watch for the 'Head Sill Jamb Tool'
screen tip to appear so that you know for
sure that you are selecting an opening and
not another framing component.

3. Select one of the following options:

Refer to Infill. Uses the span table selected in
the infill settings for the wall in which the
opening resides. The program will find the
opening's size in the span table and apply the
head/sill/jamb configuration assigned to that
opening size.

Use custom head/sill/jamb configuration.
Allows you to select a custom head/sill/jamb
configuration to use. Click the Select
configuration button and select the desired
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configuration from the Head Sill Jamb
Library.

4. Click OK.

Note: When two or more openings are very close to
each other, the openings are selected as a group
rather than individually. Applying a single
head/sill/jamb configuration to the group of
openings prevents framing members from
overlapping.

Note: If needed you can create custom span tables
(see page 477) and custom head/sill/jamb
configurations (see page 479).

Editing Intersection Framing
Building Essentials | Construction Suite
Each wall intersection in your model is framed using
a standard intersection framing configuration
designed specifically for that type of intersection.
Intersection framing configurations are stored in an
internal library called an intersection lookup table. The
program matches intersections in your project with
intersections in the lookup table to determine how
each intersection should be framed.

When you switch to Framing Mode, each intersection
is represented by a "glass box" for easy identification
and selection. You can click on any intersection and
apply a specific intersection framing configuration to
it. When you apply a framing configuration to a
selected intersection, you can choose to save that
particular instance to the catalog, where it is added to
an intersection lookup table that you choose. This
way any configuration applications that you specify
in the current project will be available for future use
in any project. Otherwise, the intersection
configuration that you specify resides in the current
project only.
To edit an intersection's framing configuration:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the intersection that you want to

edit, or select the intersection and then right-
click and select Properties. When selecting
an intersection, watch for the 'Intersection
tool' screen tip to appear when you hover

over the intersection. This way you know for
sure that you are selecting an intersection and
not another framing component.

3. To apply the default configuration for this
type of intersection (as defined in the inter-
section lookup table), enable the Default
radio button. To apply a custom con-
figuration, enable the Custom radio button,
and then select a framing configuration from
the list. You can add, edit and delete con-
figurations. The preview pane displays a live
preview of the selected configuration. You
can right-click in this pane to display various
viewing options. If viewing in 3D you can
click and drag in the pane to rotate the pre-
view around.

4. If you want to save all of the intersection con-
figurations in the current drawing to an inter-
section lookup table, click , then
type a name for the table in the New Lookup
Table Name dialog.

5. Click OK.

Note: Because there are so many different types of
possible intersections, it is not possible to define
intersection framing configurations externally (i.e.
independently from an actual model). They can
only be defined in Framing Mode.

Creating Custom Intersection
Framing Configurations
Building Essentials | Construction Suite
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The intersection lookup table that ships with the
program contains a variety of intersection framing
configurations that can be applied to intersections in
your model. You can edit the existing configurations
or add new ones if needed. Each configuration
consists of a number of detailed settings for the wall
core and very top plate so that you can create the
exact configuration you need.
To create a custom intersection framing
configuration:
1. Go into Framing Mode (View > Framing

Mode On/Off).
2. Double-click the intersection that you want to

edit, or select the intersection and then right-
click and select Properties. When selecting
an intersection, watch for the 'Intersection
tool' screen tip to appear when you hover
over the intersection. This way you know for
sure that you are selecting an intersection and
not another framing component.

3. If you want to edit a configuration in the Edit
Intersection dialog, select it in the list, then
click Edit.

4. If you want to add a new configuration, click
Add.

5. Define the configuration in the Wall
Intersection dialog. When defining a
configuration, the wall core (studs, top plate,
bottom plate) is defined independently of the
very top plate. This allows you to overlap the
very top plate at corners for greater strength
if desired. The settings are described below.

Configuration name. The name of the
configuration as it appears in the list of
configurations in the Edit Intersection dialog
when an intersection is selected.

Wall Component. Select the wall to define
(Wall A, Wall B, etc.). Refer to the diagram in
the dialog to see which wall you are defining.

Relative to Wall. Click in this field to display
a list of walls in the selected intersection.
Select the wall to which you want the current
wall to extend. If you do not want to extend
the current wall, select None.

Extend to. Click in this field and select the
method that you want to use to extend the
current wall. Options are described below.

Leading. Extends the wall to the leading edge
of the wall it intersects. The leading edge is
the first edge that the current wall encounters
when extended into the intersecting wall.

Trailing. Extends the wall to the trailing edge
of the wall it intersects. The trailing edge is
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the second edge that the current wall
encounters when extended into the
intersecting wall.

Miter. Extends the wall to the trailing edge of
the wall it intersects and creates a 45° miter
cut.

Continuous. Applicable only to intersecting
walls that lie at the same angle, as in a T-
intersection or X-intersection, this extends the
current wall into the same-plane intersecting
wall, forming a continuous wall.

Treatment. Applicable only when the wall is
being extended to the leading or trailing edge
of another wall, and the angle between the
walls is not 90°. The Flush option cuts the
current wall so that it is flush with the edge
of the intersecting wall. The Square option
cuts the end of the wall squarely so that the
wall end forms a 90° angle. (The angle of the
intersecting wall is irrelevant.)

Offset. The distance that you want to offset
the end of the wall from the intersecting wall.
This value can be positive (for an extension)
or negative (for a retraction).

Flip End. Flips the end studs to the other side
of the wall.

End Condition. (wall core only) The number
and orientation of studs at the wall's end
(single, double, triple, turned, etc.). To select
an end condition, click in the End Condition
field and make a selection from the drop box.
If you want to add or edit an end condition
configuration, select <Edit> in the drop box
to access the End Condition Library. You can
create custom end conditions if necessary (see
page 490).

6. The configuration will be applied to all
intersections similar to the current one. In the
Apply to Similar Intersections area, select either
Basic Match, Moderate Match or Exact
Match to determine how similar the
intersections must be to the current one in
order to receive the new configuration.

Basic Match. The intersection has the same
shape (same number of walls and nodes
within the intersection).

Moderate Match. The intersection has the
same shape, and angle between walls.

Exact Match. The intersection has the same
shape, angle between walls, and orientation.

The table below illustrates sample matches to
a selected intersection.
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7. If you would like to use this configuration for
intersections of this type when new walls are
created, enable the Make default for
matches of selected strength check box.

8. The preview pane displays a live preview of
the intersection configuration. You can right-
click in the preview pane to access a menu of
viewing options, including View as 2D and
View as 3D. If viewing in 3D you can also
click and drag inside the pane to rotate the
preview around. The options below the pre-
view pane allow you to determine which com-
ponents you want to see in the preview.

9. Click OK.

Specifying Floor Framing
Options
Building Essentials | Construction Suite
Floors have a framing configuration assigned to them
which you see when you display framing. You can
specify a custom framing configuration if you want.
There are settings for the joist, rim joist, and opening
header, and you can control the joist spacing and
direction.

Framing can be displayed using the Display Framing
tool, and is included in the project estimate. Settings
in the framing configuration let you specify whether
or not you want each component in the floor frame to
be displayed and quantified, providing the ultimate in
versatility and control. You can also assign a Phase
and Usage to each member in the configuration so
that they are sorted appropriately in the project
estimate.
To specify framing options for floors:

1. In a non-framed view, select the floor. If the
floor was created automatically, you need to
select it in 3D view. You can also specify
framing members for floors in the catalog.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Basic property page, click the Specify
Framing button. The Floor Framing dialog
appears.

4. To select a joist member, click on the Member
field in the Joist area, then click the browse
button in that field to display the mem-
ber catalog. Select the desired member in the
Catalog Access dialog, then click OK.

5. To define the joist spacing, edit the value in
the a. Spacing field.

6. To define the joist direction, edit the angle in
the Direction field.

7. To select a rim joist member, click on the
Member field in the Rim Joist area, then click
the browse button in that field to display
the member catalog. Select the desired mem-
ber in the Catalog Access dialog, then click
OK.



Chapter 15: Framing

- 155 -

8. To select an opening header member, click on
the Member field in the Opening Header area,
then click the browse button in that field
to display the member catalog. Select the
desired member in the Catalog Access dia-
log, then click OK.

9. By default, the joists, rim joists and opening
headers are set to be displayed in the framing
and quantified in the project estimate. If you
do not want one of those components to be
displayed and quantified, click in the Include
in Framing field in that component's settings
and select No.

10. You can assign a unique Usage and Phase to
the joist, rim joist and opening header
members. Usages help to identify what
materials are used for, or could be used for
on the construction site. Phase refers to the
construction phase in which a material is
used. Phase and Usage can be used as sort
keys in your report template. Sort keys
determine how materials are sorted in your
project estimate.

To assign a Usage to a member, click in the
member's Usage field and then click the
browse button in that field and make a
selection from the Usages library. To assign
a Phase to a member, click in the member's
Phase field and then click the browse button

in that field and make selection from the
Phase library.

11. Click OK.

Tip: If you want to be able to select and edit floor
framing members, or include them in member
schedules, you must first convert them to actual
elements using the Convert Framing to Members
tool.

Specifying Ceiling Framing
Options
Building Essentials | Construction Suite
Ceilings have a framing configuration assigned to
them which you see when you display framing in
Building Essentials and Construction Suite. You can
specify a custom framing configuration if you want.

There are settings for the joist, rim joist, and opening
header, and you can control the joist spacing and
direction.

Framing can be displayed using the Display Framing
tool, and is included in the project estimate. Settings
in the framing configuration let you specify whether
or not you want each component in the ceiling frame
to be displayed and quantified, providing the ultimate
in versatility and control. You can also assign a Usage
and Phase to each member in the configuration.
To specify framing options for ceilings:
1. In non-framed view, select the ceiling you

want to change. You can also specify framing
members for ceilings in the catalog.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Basic property page, click the Specify
Framing button. The Ceiling Framing dialog
appears.
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4. To select a joist member, click on the Member
field in the Joist area, then click the browse
button in that field to display the mem-
ber catalog. Select the desired member in the
Catalog Access dialog, then click OK.

5. To define the joist spacing, edit the value in
the a. Spacing field.

6. To define the joist direction, edit the angle in
the Direction field.

7. To select a rim joist member, click on the
Member field in the Rim Joist area, then click
the browse button in that field to display
the member catalog. Select the desired mem-
ber in the Catalog Access dialog, then click
OK.

8. To select an opening header member, click on
the Member field in the Opening Header area,
then click the browse button in that field
to display the member catalog. Select the
desired member in the Catalog Access dia-
log, then click OK.

9. By default, the joists, rim joists and opening
headers are set to be displayed in the framing
and quantified in the project estimate. If you
do not want one of those components to be
displayed and quantified, click in the Include
in Framing field in that component's settings
and select No.

10. You can assign a unique Usage and Phase to
the joist, rim joist and opening header
members. Usages help to identify what
materials are used for, or could be used for
on the construction site. Phase refers to the
construction phase in which a material is
used. Phase and Usage can be used as sort
keys in your report template. Sort keys
determine how materials are sorted in your
project estimate.

To assign a Usage to a member, click in the
member's Usage field and then click the

browse button in that field and make a
selection from the Usages library. To assign
a Phase to a member, click in the member's
Phase field and then click the browse button

in that field and make selection from the
Phase library.

11. Click OK.

Tip: If you want to be able to select and edit ceiling
framing members, or include them in member
schedules, you must first convert them to actual
elements using the Convert Framing to Members
tool.

Specifying Roof Framing
Options
Building Essentials | Construction Suite
Roofs have a framing configuration assigned to them
that you see when you display framing. Framing can
be displayed using the Display Framing tool, and is
included in the project estimate. Settings in the
framing configuration let you specify whether or not
you want each component in the roof frame to be
displayed and quantified. You can assign a member
type, Usage and Phase to each member in the
configuration.
To specify framing members for roofs:
1. In non-framed view, select the roof you want

to change. You can also specify framing mem-
bers for roofs in the catalog.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Basic property page, click the Specify
Framing button. The Roof Framing dialog
appears.
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4. Specify the desired options in the Rafter,
Opening Header, Hip, Valley, Gable, Gable
Ladder, Collar Ties ,Rafter Ties and
Purlinssections.

l To control whether or not each com-
ponent in the frame is displayed in
the framing and included in the pro-
ject estimate, click in the component's
Include in Framing field and select
either Yes or No.

l To select the member that you would
like to use for a framing component,
click on the Member field, then click
the browse button in that field to
display the member catalog. Select the
desired member in the Catalog
Access dialog, then click OK.

l You can assign a unique Usage and
Phase to the rafter and opening
header members. Usages help to
identify what materials are used for,
or could be used for on the
construction site. Phase refers to the
construction phase in which a
material is used. Phase and Usage can
be used as sort keys in your report
template. Sort keys determine how
materials are sorted in your project
estimate.
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To assign a Usage to a member, click
in the member's Usage field and then
click the browse button in that
field and make a selection from the
Usages library. To assign a Phase to a
member, click in the member's Phase
field and then click the browse button

in that field and make selection
from the Phase library.

l If you are including Rafters or a Gable
Ladder, you can specify the spacing
between members in the Spacing
field.

l If you are including a Gable Ladder,
the Extension property enables you
to control the distance that the ladder
framing extends. The default To Struc-
ture option automatically extends the
ladder framing to the second rafter.
Selecting the Fixed option enables
you to specify a set extension
Distance, which allows the ladder
framing to be extended further.

l If you are including Collar Ties, the
Vertical distance from ridge is from
the top of the ridge to the top of the
collar tie member. Specify the distance
between the two. The Max span is the
maximum span for the collar tie. If the
span is longer than the distance spe-
cified it will be eliminated.

l If you are including Rafter Ties, the
Vertical distance from support is
from the top of the support height to
the top of the rafter tie member. Spe-
cify the distance between the two. The
Max span is the maximum span for
the collar tie. If the span is longer than
the distance specified it will be elim-
inated.

l If you are including Purlins, the Off-
set from Ridge defines the distance
down the slope from the ridgeline to
the center of the first purlin. The
Span (Distance) defines the distance
down the slope from the center of one

purlin to the center of the next purlin.
Reset span at segment boundary
(Yes/No) defines whether purlins
restart at the top edge of each seg-
ment if a roof surface is comprised of
multiple segments. Holdback from
fascia (Distance) defines the last
valid position of a purlin relative to
the fascia edge of a roof surface. No
part of the purlin should extend past
this imaginary line. Place purlin at
segment boundaries (Yes/No) forces
a purlin to be places at the top and
bottom edge of a roof segment if a
roof surface is comprised of multiple
segments. Place purlin at holdback
(Yes/No) defines whether a purlin
should be placed at the holdback line.

5. Click OK.

Note: Additional frame details can be found on a
roof's Support and Details property page.

Tip: If you want to be able to select and edit roof
framing members, or include them in member
schedules, you must first convert them to actual
elements using the Convert Framing to Members
tool.

Inserting Truss Profiles Under a
Roof Surface
Building Essentials | Construction Suite

You can use the Truss Run tool to quickly insert a run
of truss profiles under an existing roof surface. The
tool will recognize the hips, valleys and gable ends of
the roof and insert an appropriate profile. It also
recognizes any ceiling surfaces beneath the roof, and
will alter the profile of the bottom chord to
accommodate them.

Note: Truss profiles are mainly for display, and are
not quantifiable. To insert actual truss members,
use the Timber Frames tool.
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To insert truss profiles under a roof surface:
1. Select Insert > Roofs > Truss Run.
2. In the catalog panel, select the truss profile

that you would like to insert.

3. Click on the roof edge at the start of the truss
run, then click on the roof edge at the end of
the truss run.

4. Right-click and select Finish.

Converting Framing to Members
Building Essentials | Construction Suite

When roofs, floors, ceilings and surfaces are created,
their framing cannot be selected for editing, and does
not appear in member schedules. Using the Convert
Framing to Members tool you can instantly convert a
surface’s framing into actual members that can be
selected, edited, and quantified in schedules.
To convert framing to members:
1. Select Insert > Members > Convert Framing

to Members, or click the down arrow next to
the Members button on the Building
toolbar and select Convert Framing to
Members.

2. Select the roof, floor, ceiling or surface whose
framing you want to convert. If you are in 2D
plan view, click on the edge of the element. If
you are in 3D, click anywhere on the surface
of the element. (Note: Automatic floors can
only be selected in 3D.)

The framing is automatically converted.

3. Right-click and select Finish.
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Wall Panels
Building Essentials | Construction Suite
If you have your walls pre-built in a factory rather than stick-built on site, the program's Wall Panel feature will be
of great benefit to you. You can view an instant list of all wall panels in your project, then generate diagrams for
each one.

Each diagram shows an elevation and a plan view of the wall's framing configuration. By default the diagram is
fully dimensioned, and each member in the diagram is tagged according to its type. A schedule is also included that
lists the members used in the panel and the usage and quantity of each.

Prior to drawing walls you can set up a tagging system and define the settings that you want your wall panels to
have. For example, you can decide which dimensions to include, define schedule settings, and control the amount of
information displayed in the diagram. Once walls are drawn you can preview all wall panels and customize the
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appearance of each one. You can specify settings for
all or multiple panels simultaneously, or customize
individual panels to suit your needs.

Once you have defined panel properties and settings,
you can insert wall panels onto worksheets. When
you insert a wall panel diagram onto a worksheet, a
block of that panel is created and stored in memory.
Any time that you make a change to a wall's framing
configuration, you will need to regenerate its
associated wall panel diagram in order to update its
block definition. When you regenerate a panel, any
inserted instances of it in your project are
automatically updated. Since the diagrams are
generated directly from wall panels in your model,
you can submit them to the panel assembly plant with
confidence knowing that they are accurate and
designed to your specifications.

Setting Up a Wall Panel Tagging
System
Construction Suite only

As you draw walls, each wall is marked with a wall
panel tag. Each tag is associated with a wall panel
diagram that is generated by the program. By default,
panel tags are simply numbers, and numbering
begins at 0. You can specify how you would like wall
panels to be tagged prior to drawing walls. You can
change the default start number, add a prefix or suffix
to the number, add location data to the tag, and
change the panel view side.
To specify how you want wall panels to be tagged:
1. Select Tools > Wall Panels.

2. In the Wall Panels dialog, click
and select Panel Configuration.

3. In the Panel Configuration dialog, select
Panel Tags in the left pane. The settings are
described below.
Default Start Number. The number at which
panel numbering starts by default. Note that
this setting applies to walls that will be
drawn and has no effect on walls that have
already been drawn. If you have already
drawn your walls you can customize the way
panels are numbered using the Panel
Numbering tool on the Options menu.

Prefix. A set of characters that appear before
the panel number. For example, if you specify
a prefix of 'WP', the panels would be named
'WP1', 'WP2', etc.

Add location data before prefix. Displays
either the Location Name or Location
Number before the prefix. For example, if
panel WP2 resides on the Ground Floor
location, and you select 'Location Name' to
add to the prefix, the panel would be named
'Ground Floor WP2'. If you do not want to
add location data to the prefix, ensure that
None is selected in the drop box.
Suffix. A set of characters that appear after
the panel number. For example, if you specify
a suffix of 'EXT', the panels would be named
'1EXT', '2EXT', etc.

Add location data after suffix. Displays
either the Location Name or Location
Number after the suffix. For example, if panel
2EXT resides on the Ground Floor location,
and you select 'Location Name' to add to the
suffix, the panel would be named '2EXT
Ground Floor'. If you do not want to add
location data to the suffix, ensure that None
is selected in the drop box.

Default Panel View Side. This is the side of
the wall that you are viewing, as indicated by
the arrow on the wall panel tag in your 2D
plan. The 'Left' or 'Right' side of the wall
depends on the direction in which a wall is
drawn. If you were to draw a wall from left
to right, the 'left' side would be the side
closest to the top of the screen. Imagine
yourself standing at the wall's start point and
looking to the left or the right to determine
the desired view side.

4. Click OK in the Panel Configuration dialog.
5. Click Close in the Wall Panels dialog.

Note: If you have already drawn your walls, you
can edit the wall panel names to suit your needs.
See Editing Wall Panel Names on page 170.
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Note: To select a text style for your wall panel tags,
see Editing the Text Styles Used for Wall Panels on
page 174.

Displaying/Hiding Wall Panel
Tags
Building Essentials | Construction Suite
As you draw walls, each wall is marked with a wall
panel tag. Each tag is associated with a wall panel
diagram that is generated by the program. By default,
wall panel tags are not displayed. You can turn them
on and off using your View Filter.
To display or hide wall panel tags:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. By default, wall panel tags are locked from
filtering, so you need to unlock them before
you can control their visibility. Click the lock
icon in the Tags/Marks row to unlock tags.

Tags are locked

Tags are unlocked

4. Click the eye icon in the Tags/Marks row to
turn wall panel tags on or off.

Tags are turned on 

Tags are turned off

5. Click OK.

Note: Wall panel tags are visible but not selectable
in Framing Mode. You can only select wall tags
when in normal design mode.

Defining Wall Panel Settings
Construction Suite only

As you draw walls, each wall is marked with a wall
panel tag. Each tag is linked to a wall panel diagram
that the program generates. You can define the
settings that you want your tags and wall panel
diagrams to have prior to drawing walls, or
customize them afterward. It is recommended that
you define the wall panel settings before drawing

walls to avoid having to regenerate wall panel
diagrams.

When defining panel settings you can:
l Customize wall panel tags
l Set the panel view side
l Edit the scale of inserted panels
l Choose to insert a drawing border when pan-
els are inserted

l Choose whether or not to display the elevation
view, plan view, wall tags and very top plates
in the diagram

l Choose what you want to dimension
l Choose whether or not you want to include a
schedule, and where it is placed

All of these settings are defined in a single dialog and
will be applied to panels as they are generated. If you
have already drawn your walls and edit your wall
panel settings, the settings will be applied to the
panels that are currently selected in the Wall Panel
List when you insert them. If you have already
inserted wall panels onto worksheets, you will need
to regenerate them in order to update them with your
changes.
To define wall panel settings:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. If you have already drawn your walls, select
the panels in the list that you want to edit.
'Ctrl+click' to select multiple panels one by
one, or 'Shift+click' to select a group of con-
secutive panels (or all panels). You can also
click once on the building location name to
instantly select all panels on that location.
Note that you can expand and collapse each
location by double-clicking the location name.

3. In the Wall Panels dialog, click
and select Panel Configuration. The Panel
Configuration dialog box appears. This dia-
log contains 5 pages of settings.

4. To define a naming convention for wall pan-
els, select Panel Tags in the left pane. The set-
tings are described below.
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Default Start Number. The number at which
panel numbering starts by default. Note that
this setting applies to walls that will be
drawn and has no effect on walls that have
already been drawn. If you have already
drawn your walls you can customize the way
panels are numbered using the Panel
Numbering tool on the Options menu.

Prefix. A set of characters that appear before
the panel number. For example, if you specify
a prefix of 'WP', the panels would be named
'WP1', 'WP2', etc.

Add location data before prefix. Displays
either the Location Name or Location
Number before the prefix. For example, if
panel WP2 resides on the Ground Floor
location, and you select 'Location Name' to
add to the prefix, the panel would be named
'Ground Floor WP2'. If you do not want to
add location data to the prefix, ensure that
None is selected in the drop box.
Suffix. A set of characters that appear after
the panel number. For example, if you specify
a suffix of 'EXT', the panels would be named
'1EXT', '2EXT', etc.

Add location data after suffix. Displays
either the Location Name or Location
Number after the suffix. For example, if panel
2EXT resides on the Ground Floor location,
and you select 'Location Name' to add to the
suffix, the panel would be named '2EXT
Ground Floor'. If you do not want to add
location data to the suffix, ensure that None
is selected in the drop box.

Default Panel View Side. This is the side of
the wall that you are viewing, as indicated by
the arrow on the wall panel tag in your 2D
plan. The 'Left' or 'Right' side of the wall
depends on the direction in which a wall is
drawn. If you were to draw a wall from left
to right, the 'left' side would be the side
closest to the top of the screen. Imagine
yourself standing at the wall's start point and
looking to the left or the right to determine
the desired view side. Note: This is the
default view side for all walls that will be

drawn. Once your walls are drawn you can
flip the view side of individual panels using
the Flip Panel View Side tool.

Note: If you have drawn walls already and want
to apply edited name settings to the currently
selected panels, you must use the Apply Name
Changes to Selected Panel(s) tool on the Options
menu to update the tags.

5. To define the settings used when inserting
panels onto worksheets, select Insertion Set-
tings in the left pane. The settings are
described below.
Import Scale. The scale of the panel diagram
when it is inserted onto the worksheet. By
default, the import scale is the same as the
worksheet scale. This means that the diagram
will fill most of the sheet, which is ideal if
you only want one wall panel diagram on
each sheet. If you want to insert multiple
panels on a sheet, or make panels appear
smaller on the sheet for any reason, select an
import scale that is smaller than the
worksheet scale.

192 1/16" = 1'-0"
96 1/8" = 1'-0"
64 3/16" = 1'-0"
48 1/4" = 1'-0"
32 3/8" = 1'-0"
24 1/2" = 1'-0"
16 3/4" = 1'-0"
12 1" = 1'-0"
8 1 1/2" = 1'-0"
4 3" = 1'-0"
2 6" = 1'-0"
1 12" = 1'-0"

Common Scales

Worksheet Scale. The scale of the worksheet
that will be created if you choose to insert
panels from Model View, or choose to insert
panels onto new worksheets when in
Worksheet View. By default, the scale
displayed is the same scale that is set for your
main Model view window.
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Plan View Spacing. The distance between
panels when multiple panels are inserted
onto one worksheet.

Drawing Border. Inserts a drawing border
around the panel when it is inserted onto a
worksheet. The list will contain any title
blocks that exist in the current project. If you
do not want to include a border, select None
in this drop box.

# Panels Across in Multi-Panel Insertion. If
you are inserting multiple panels onto one
worksheet, this value determines the
maximum number of panels in one row. For
example, if you are inserting 20 panels and
you set this value to 5, your worksheet will
contain 4 rows of panels with 5 panels in
each row.

6. To select the styles for text and dimensions in
your wall panel diagrams, select Text and
Dimension Styles in the left pane. Click on
the item for which you want to select a style,
then click the browse button in that field
to display the Dimension Styles or Text
Styles dialog. You can make selections for
the following styles:

Dimension Style. The style used for the
dimensions in the wall panel diagram,
including member tags.

Label Text Style. The style applied to the
panel name in the wall panel diagram. The
panel name appears at the lower left corner
of the elevation view, or the top right corner
of the plan view.

Tag Text Style. The style applied to wall
panel tags in your 2D plan.

Schedule Text Style. The style applied to
text in the member schedule.

7. To specify what you would like to include in
your wall panel diagrams, select Panel Con-
tent in the left pane. Select either Yes or No
for each of the following to determine
whether or not they will be included in the
panel diagram.
Include Elevation View. Includes the display
of the framed panel in elevation view.

Include Plan View. Includes a plan view of
the wall panel, which shows you the distance
between members in the panel.

Display Wall Tags. Includes the wall panel
tag name in the diagram. The tag appears at
the bottom left corner of the elevation view,
or top left corner of the plan view.

Include Very Top Plates. Includes the
display of the very top plate if one is present
in the frame.

8. To specify the dimensions that you would
like to include on the panel diagram, select
Dimensions in the left pane. Select either
Yes or No for each available dimension string
to specify whether or not it is included in the
diagram. For example, you can choose
whether or not you want to display
dimensions for studs, top plates, bottom
plates, cripples and openings.

There are 3 groups of dimensions in each
diagram: those running up the side of the
panel, those running across the top of the
panel, and those running across the plan
view. The dimensions running across the top
of the panel include 4 dimension strings, each
of which can be defined individually.
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9. To specify whether or not you want to
include a schedule along with the diagram or
define schedule settings, select Schedule in
the left pane. A typical schedule includes the
tag, usage, description, count and length of
each member type in the frame. Schedule
settings are described below.

Include Schedule. Select either Yes or No to
specify whether or not you want to include a
schedule in the diagram.

Placement. Choose either Below or Right to
specify where you want to place the schedule
in relation to the annotated panel.

Include Usage. Select either Yes or No to
specify whether or not you want to include a
Usage column in the schedule that reports
the usage of each member.

10. Once you have defined your panel con-
figuration, click OK.

11. If you have previously inserted any of the
panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.

To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

12. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Tip: If you have already drawn your walls and
want to break a wall into two or more smaller
panels, use the Break or Auto Break tool in your 2D
plan.

Note: If walls have been drawn already, name
changes are not automatically applied, even if you
regenerate panels. You must use the Apply Name
Changes to Selected Panel(s) tool to update wall
panel names and tags.

Note: If you want to change a panel's framing
configuration, you need to actually change the
framing in the model, either by editing the framing
options in your building locations or customizing
framing configurations in Framing Mode. See Wall
Framing on page 146.

Previewing Wall Panels
Construction Suite only

As you draw walls in your project, each one is
automatically tagged with a panel number. Each wall
panel in your model has an associated wall panel
diagram that shows you the wall's panel number,
framing configuration and framing dimensions. You
can display an instant list of wall panels in your
project and preview each one.
To preview wall panels:
1. In Model View or Worksheet View, select

Tools > Wall Panels. In Model View you can
also double-click any wall panel tag
displayed in your 2D plan, or right-click a tag
and select Edit Wall Panels. The Wall Panels
dialog appears:
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2. To preview a wall panel, select it in the list in
the left pane. The wall panel's diagram is
displayed in the top right pane. The bottom
right pane contains a 2D wall layout, and the
currently selected wall panel is highlighted in
red so that you know which one you are
looking at.

Initially, every panel in the list will have an
beside it. That is because you haven't

inserted any panels yet. When you insert a

panel onto a worksheet, a check mark
is displayed instead.

In addition to viewing panels in this dialog,
you can customize panel settings, renumber
panels, edit the properties of individual
panels, and insert panels onto worksheets.

If you change a wall in your model (for
example, if you change its length or its
framing configuration), the wall panel
preview will update automatically the next
time that you open the Wall Panels dialog.
However, if you have already inserted the
panel diagram for that wall, a Regenerate

symbol appears next to the panel name
indicating that you need to regenerate the
panel in order to update the inserted panel
diagram with the changes you have made.

Note: Wall panel tags are visible but not selectable
in Framing Mode. You can only select wall tags
when in normal design mode. To turn wall panel
tags on or off, use the View Filter.

Note: If a wall is intersected by one or more other
walls, it is broken into multiple panels at those
intersection points. You can use the Break tool on a
wall's editing menu to manually create a break in a
wall if needed. You can also use the Auto Break
tool to break a wall into specific lengths.

Viewing and Editing the Prop-
erties of Individual Wall Panels
Construction Suite only

You can override the panel name settings defined in
your panel configuration and define a custom name
for individual wall panels in your project. You can
define a prefix and/or suffix, and specify whether or
not you want to include location data in the name.
To customize the name of an individual wall panel:
1. In Model View or Worksheet View, select

Tools > Wall Panels. In Model View you can
also double-click any wall panel tag dis-
played in your 2D plan, or right-click a tag
and select Edit Wall Panels.

2. In the left pane of the Wall Panels dialog,
double-click the wall panel whose properties
you want to view or edit, or right-click on the
panel and select Panel Properties.

3. In the Panel Properties dialog, specify the
name settings if desired. These are described
below. As you define the name settings, the
result is displayed in the Panel Name field.
Add location data before prefix. Displays
either the Location Name or Location
Number before the prefix. For example, if
'Panel2' resides on the Ground Floor location,
and you select 'Location Name' to add to the
prefix, the panel would be tagged 'Ground
Floor Panel2'. If you do not want to add
location data to the prefix, ensure that None
is selected in the drop box.

Add location data after suffix. Displays
either the Location Name or Location
Number after the suffix. For example, if panel
'2EXT' resides on the Ground Floor location,
and you select 'Location Name' to add to the
suffix, the panel would be tagged '2EXT
Ground Floor'. If you do not want to add
location data to the suffix, ensure that None
is selected in the drop box.

Prefix. A set of characters that appear before
the panel number. For example, if you specify
a prefix of 'Panel', the panels would be
tagged 'Panel1', 'Panel2', etc.

Number. The number assigned to the panel
according to your panel configuration
settings. This value cannot be edited for
individual panels, but you can edit your
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panel numbering system. See Editing Wall
Panel Numbering on page 168.

Suffix. A set of characters that appear after
the panel number. For example, if you specify
a suffix of 'EXT', the panels would be tagged
'1EXT', '2EXT', etc.

Panel Name. The resulting panel name and
tag.

4. To display the diagram's tags and dimensions
in the preview window, enable the Display
Annotations check box. Disabling annota-
tions results in a larger preview of the panel,
providing a close-up look.

5. Click OK. The panel name updates in the
Wall Panels dialog and the panel tag updates
in your 2D plan.

6. If you have previously inserted the panel

onto a worksheet, a Regenerate symbol
appears next to the panel name. This
indicates that you need to regenerate the
panel in order to update it with your name
changes.

To regenerate the panel, click
at the top of the dialog.

7. Click Close in the Wall Panels dialog.

Flipping a Wall Panel's View
Side
Walls are tagged automatically as you draw them.
They are tagged on the side specified in your panel
configuration settings. Once you have drawn your
walls you can flip the panel tag of individual walls to
the other side of the wall if desired. This will also flip
the resulting wall panel diagram so that you are
viewing the wall from the other side.
To flip a wall panel's view side:
1. In 2D plan view, right-click on the panel tag

that you want to flip, then select Flip Panel
View Side. The tag flips to the other side of
the wall.

Note: If you have previously inserted the panel
onto a worksheet and want to update the inserted
diagram, you will need to regenerate it.

Editing Wall Panel Numbering
Construction Suite only

By default, wall panels are numbered in the order in
which walls are drawn, starting with the default Start
Number defined in your panel configuration settings.
When you draw a wall that intersects another wall,
the wall that you intersect is broken into smaller
panels, which can cause panel numbering to become
non-sequential in your 2D plan.

You can customize the wall panel numbering order
on each building location after your walls have been
drawn. You can choose a different start number or
specify custom numbering options for exterior walls,
interior load-bearing walls and interior non-load-
bearing walls. Instead of numbering panels in the
order in which walls are drawn, you can number
them in a specific direction. For example, you can
number exterior walls in a clockwise or
counterclockwise direction, or number vertically
drawn walls from left to right or right to left.
To edit wall panel numbering:
1. In Model View, select Tools > Wall Panels.

You can also bring up the Wall Panels dialog
by double-clicking a wall panel tag in your
2D plan, or right-clicking a tag and selecting
Edit Wall Panels.

2. In the Wall Panels dialog, click
and select Panel Numbering. The Panel
Numbering dialog appears:

3. From the Sort Location drop box, select the
location for which you want to customize
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panel numbering. If you want to apply the
same rules to every location, select All Loca-
tions.

4. To specify a different start number for your
panel numbering system, edit the value in the
Panel Start Number edit box. For each wall
panel in the sequence, panel numbers will
increment by 1 from this value. For example,
if the first panel is numbered 100, the next
will be 101, and the one after that will be 102,
and so on.

5. If you want all wall panels to be numbered in
the order in which they were drawn, enable
the Sort as Drawn radio button.

6. If you want to sort panels in a specific dir-
ection rather than the order in which they
were drawn, enable the Custom Sort radio
button.

7. To specify a sort order for exterior walls, click
the drop box next to Exterior Walls and
select either As Drawn, Counter-Clockwise
or Clockwise.

8. To specify a sort order for vertical interior
walls, click the drop boxes in the Interior Ver-
tical Wall area and select either As Drawn,
Left to Right or Right to Left. For example, if
you select Left to Right, the vertical interior
walls on the left side of the plan will be
numbered first, and numbering will increase
as you go across the plan to the right. You
can specify a different sort order for load-
bearing and non-load-bearing walls.

9. To specify a sort order for horizontal interior
walls, click the drop boxes in the Interior
Horizontal Wall area and select either As
Drawn, Top to Bottom or Bottom to Top.
You can specify a different sort order for
load-bearing and non-load-bearing walls.

10. When you are finished defining your sort

options, click . The wall pan-
els in the Wall Panels dialog are sorted
according to the rules you have set.

11. If you have previously inserted any of the re-
numbered panels onto worksheets, a

Regenerate symbol appears next to the

names of the panels that have been inserted.
This indicates that you need to regenerate the
panels in order to update their tag numbers
on the worksheets.

To regenerate inserted panels and update
them with your changes, select them in the
list and then click at the top
of the dialog.

12. To update the panel numbering in your 2D
plan, click Close in the Wall Panels dialog.

Tip: You can also manually re-order wall panels by
moving them up and down in the Wall Panels
dialog. See Re-ordering Wall Panels Manually on
page 169.

Re-ordering Wall Panels Manu-
ally
Construction Suite only

You can manually re-order wall panels by moving
them up and down in the Wall Panels dialog. When
you move a wall panel up or down, it acquires the
number of the panel that was in that spot originally.
For example, if you move panel 1 at the top of the list
down one spot, it becomes panel 2. Once you have re-
ordered your panels and close the Wall Panels dialog,
the tags in your 2D plan will update. If you have
inserted any of the panels onto worksheets, you will
need to regenerate them in order to update their tag
numbers on the worksheets.
To re-order panels in the wall panel list:
1. Select Tools > Wall Panels. You can also

bring up the Wall Panels dialog by double-
clicking a wall panel tag in your 2D plan, or
by right-clicking a tag and selecting Edit Wall
Panels.

2. In the Wall Panels dialog, click on the wall
panel that you want to move. The panel is
highlighted red in the 2D plan shown in the
dialog's lower right pane. This lets you know
which panel you are re-numbering.

3. Click at the top of the dialog to move the

panel up in the list, or click to move it
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down. As you move the panel up or down, it
acquires the number of that spot in the list.

4. If you have previously inserted any of the re-
numbered panels onto worksheets, a

Regenerate symbol appears next to the
names of the panels that have been inserted.
This indicates that you need to regenerate the
panels in order to update their tag numbers
on the worksheets.

To regenerate inserted panels and update
them with your changes, select them in the
list and then click at the top
of the dialog.

5. When you are finished re-ordering panels,
click Close in the Wall Panels dialog. The
wall panel tags in your 2D plan are updated.

Note: To sort your panels automatically according
to a custom set of sorting rules, see Editing Wall
Panel Numbering on page 168.

Editing Wall Panel Names
Construction Suite only

By default, wall panels are simply referred to by
number and do not include any other information.
You can add a prefix and/or suffix to the wall panel
number, and add location data to the prefix or suffix
for easier identification. You can edit the name
definition for single or selected panels, or for all
panels. (If you want to quickly edit the name of an
individual wall panel and its associated tag, see
Viewing and Editing the Properties of Individual Wall
Panels on page 167.)

If you have already drawn your walls and edit your
panel tag definition, the tags do not update
automatically in your drawing or in the Wall Panels
dialog. You must update them using the Apply Name
Changes to Selected Panel(s) tool.
To edit panel naming settings:
1. In Model View or Worksheet View, select

Tools > Wall Panels. In Model View you can
also double-click any wall panel tag dis-
played in your 2D plan, or right-click a tag
and select Edit Wall Panels.

2. In the left pane of the Wall Panels dialog,
select the panels whose name definition you
want to change. 'Ctrl+click' to select multiple
panels one by one, or 'Shift+click' to select a
group of consecutive panels (or all panels).
You can also click once on the building loc-
ation name to instantly select all panels on
that location. Note that you can expand and
collapse each location by double-clicking the
location name.

3. Click and select Panel
Configuration.

4. In the Panel Configuration dialog, select
Panel Tags in the left pane. The settings are
described below.

Prefix. A set of characters that appear before
the panel number. For example, if you specify
a prefix of 'WP', the panels would be named
'WP1', 'WP2', etc.

Add location data before prefix. Displays
either the Location Name or Location
Number before the prefix. For example, if
panel WP2 resides on the Ground Floor
location, and you select 'Location Name' to
add to the prefix, the panel would be named
'Ground Floor WP2'. If you do not want to
add location data to the prefix, ensure that
None is selected in the drop box.
Suffix. A set of characters that appear after
the panel number. For example, if you specify
a suffix of 'EXT', the panels would be named
'1EXT', '2EXT', etc.

Add location data after suffix. Displays
either the Location Name or Location
Number after the suffix. For example, if panel
2EXT resides on the Ground Floor location,
and you select 'Location Name' to add to the
suffix, the panel would be named '2EXT
Ground Floor'. If you do not want to add
location data to the suffix, ensure that None
is selected in the drop box.

5. Click OK.
6. To apply edited name settings to the cur-

rently selected panels, click and
select Apply Name Changes to Selected
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Panel(s). The tags in the Wall Panels dialog
and in your drawing are updated.

7. If you have previously the selected panels

onto worksheets, a Regenerate symbol
appears next to the panel name. This
indicates that you need to regenerate the
panel in order to update it with your tag
changes.To regenerate the panel, click

at the top of the dialog.

8. Click Close.

Note: If you want to change the way panels are
numbered, see Editing Wall Panel Numbering on
page 168.

Applying Name Changes to Wall
Panels
Construction Suite only

If you have already drawn your walls and have
edited the name definition in your panel
configuration settings, the tags will not update
automatically in your drawing or in the Wall Panels
dialog. You must update them using the Apply Name
Changes to Selected Panel(s) tool.
To apply tag changes to existing wall panels:
1. In Model View, select Tools > Wall Panels.

You can also double-click any wall panel tag
displayed in 2D plan view, or right-click a tag
and select Edit Wall Panels.

2. In the left pane of the Wall Panels dialog,
select the panels whose tag name you want to
update. 'Ctrl+click' to select multiple panels
one by one, or 'Shift+click' to select a group of
consecutive panels (or all panels). You can
also click once on the building location name
to instantly select all panels on that location.
Note that you can expand and collapse each
location by double-clicking the location name.

3. Click and select Apply Name
Changes to Selected Panel(s). The current
tag definition is applied to the selected panels
in the Wall Panels dialog as well as in your
drawing.

4. If you have previously inserted the selected
wall panels onto worksheets, click

at the top of the dialog to
update the inserted panels.

5. Click Close in the Wall Panels dialog.

Note: You do not need to use the Apply Name
Changes to Selected Panel(s) tool if you have not
drawn walls yet. The current tag definition will be
automatically applied as you draw walls.

Note: If you regenerate a wall panel diagram that
has been inserted onto a worksheet, the tag in the
inserted diagram updates, but the name of the
worksheet does not. You can edit the name of a
worksheet by editing its view properties. See
Renaming a View Window on page 259.

Editing Content Display in Wall
Panel Diagrams
Construction Suite only

By default, each wall panel diagram includes both an
elevation view and plan view of the wall as well as
the panel's tag number. The very top plate is also
included. You can specify whether or not you want
each of these items to be included in your wall panel
diagrams by editing your panel configuration settings.
Note that when you define panel content settings,
they apply to all wall panels.
To specify what you want displayed in your wall
panel diagrams:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. Click and select Panel Con-
figuration.

3. In the Panel Configuration dialog, select
Panel Content in the left pane.

4. Select either Yes or No for each of the
following to determine whether or not they
will be included in the panel diagram.

Include Elevation View. Includes the display
of the framed panel in elevation view.
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Include Plan View. Includes a plan view of
the wall panel, which shows you the distance
between members in the panel.

Display Wall Tags. Includes the wall panel
tag name in the diagram. The tag appears at
the bottom left corner of the elevation view,
or top left corner of the plan view.

Include Very Top Plates. Includes the
display of the very top plate if one is present
in the frame.

5. Once you have defined your panel content,
click OK.

6. If you have previously inserted any of the
panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.

To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

7. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Note: If you have already inserted wall panel
diagrams onto worksheets you can also manually
edit wall panel diagrams by editing each panel's

definition in Worksheet View. See Editing Inserted
Wall Panels Manually on page 177.

Editing Wall Panel Dimension
Settings
Construction Suite only

Wall panel diagrams have a default set of dimension
settings that determine which items are dimensioned
in the diagram, including studs, top plates, bottom
plates, cripples and openings. You can choose which
dimensions you want displayed by editing your panel
configuration settings. Note that when you define
dimension settings, they apply to all wall panel
diagrams.
To define wall panel dimension settings:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or right-click-
ing a tag and selecting Edit Wall Panels.

2. Click and select Panel
Configuration.

3. In the Panel Configuration dialog, select
Dimensions in the left pane.

4. Select either Yes or No for each available
dimension string to specify whether or not it
is included in the diagram.

There are 3 groups of dimensions in each
diagram: those running up the side of the
panel, those running across the top of the
panel, and those running across the plan
view. The dimensions running across the top
of the panel include 4 dimension strings, each
of which can be defined individually.
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5. To select a style to use for the dimensions,
select Text and Dimension Styles in the left
pane of the Panel Configuration dialog.
Click on the Dimension Style item, then click
the browse button in that field. Select the
desired style in the Dimension Styles dialog,
then click OK.

6. Click OK in the Panel Configuration dialog.
7. If you have previously inserted any of the

panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.
To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

8. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Note: If you have already inserted wall panel
diagrams onto worksheets and you want to
manually edit dimensions, you can do so by editing
the panel's definition in Worksheet View. See
Editing Inserted Wall Panels Manually on page 177.

Editing the Dimension Style
Used in Wall Panels
Construction Suite only

You can select the dimension style that you would
like to use in your wall panel diagrams. The selected
style will be applied to all numerical dimensions as
well as the member tags.
To edit the text styles used for wall panels:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. In the Wall Panels dialog, click
and select Panel Configuration.

3. In the Panel Configuration dialog, select
Text and Dimension Styles in the left pane.

4. Click on the Dimension Style item, then click
the browse button in that field.

5. In the Dimension Styles dialog, select the
desired dimension style, then click OK.

6. Click OK in the Panel Configuration dialog.
7. If you have previously inserted any of the

panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.
To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

8. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Editing Wall Panel Schedule Set-
tings
Construction Suite only

By default, a member schedule is included in each
wall panel diagram. You can control the placement of
the schedule within the diagram and choose whether
or not you want to include a usage for each member
in the schedule. If you don't want to include a
schedule in your wall panel diagrams, you can turn
them off in your panel configuration settings. Note
that schedule settings apply to all wall panel
diagrams.
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To edit wall panel schedule settings:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or right-click-
ing a tag and selecting Edit Wall Panels.

2. Click and select Panel Con-
figuration.

3.

In the Panel Configuration dialog, select
Schedule in the left pane. A typical schedule
includes the tag, usage, description, count
and length of each member type in the frame.

Schedule settings are described below.

Include Schedule. Select either Yes or No to
specify whether or not you want to include a
schedule in the diagram.

Placement. Choose either Below or Right to
specify where you want to place the schedule
in relation to the annotated panel.

Include Usage. Select either Yes or No to
specify whether or not you want to include a
Usage column in the schedule that reports
the usage of each member.
When you finished editing schedule settings,
click OK.

4. If you have previously inserted any of the
panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.

To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

5. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Note: If you have already inserted wall panel
diagrams onto worksheets and you want to
manually edit an individual schedule, you can do
so by editing the panel's definition in Worksheet
View. See Editing Inserted Wall Panels Manually
on page 177.

Note: To select a style for schedule text, see Editing
the Text Styles Used for Wall Panels on page 174.

Editing the Text Styles Used for
Wall Panels
Construction Suite only

You can select the text styles that you would like to
use for the wall panel tags in your 2D plan and for
the text that appears in your wall panel diagrams.
To edit the text styles used for wall panels:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. In the Wall Panels dialog, click
and select Panel Configuration.

3. In the Panel Configuration dialog, select
Text and Dimension Styles in the left pane.

4. Click on the item for which you want to
select a text style , then click the browse
button in that field to display the Text
Styles dialog. You can make selections for
the following styles:

Label Text Style. The style applied to the
panel name in the wall panel diagram. The
panel name appears at the lower left corner
of the elevation view, or the top right corner
of the plan view.

Tag Text Style. The style applied to wall
panel tags in your 2D plan.

Schedule Text Style. The style applied to
text in the wall panel's member schedule.

5. When you are finished selecting text styles,
click OK.

6. If you have previously inserted any of the
panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.
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To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

7. When you are finished customizing and
updating panels, click Close in the Wall
Panels dialog.

Editing Wall Panel Insertion Set-
tings
Construction Suite only

You can edit the settings used when wall panel
diagrams are inserted onto worksheets. You can
control the insertion scale of panels as well as the
scale of the worksheets that are created. You can also
choose to include a drawing border or title block
along with the panel diagram. If inserting multiple
panels on one sheet, you can define the number of
panels that you want to have in each row, and control
the spacing between panels.
To define panel insertion settings:
1. Select Tools > Wall Panels. If you have

already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. Click and select Panel Con-
figuration. 

3. In the Panel Configuration dialog, select
Insertion Settings in the left pane. The
settings are described below.

Import Scale. The scale of the panel diagram
when it is inserted onto the worksheet. By
default, the import scale is the same as the
worksheet scale. This means that the diagram
will fill most of the sheet, which is ideal if
you only want one wall panel diagram on
each sheet. If you want to insert multiple
panels on a sheet, or make panels appear
smaller on the sheet for any reason, select an
import scale that is smaller than the
worksheet scale.

192 1/16" = 1'-0"
96 1/8" = 1'-0"

Common Scales

64 3/16" = 1'-0"
48 1/4" = 1'-0"
32 3/8" = 1'-0"
24 1/2" = 1'-0"
16 3/4" = 1'-0"
12 1" = 1'-0"
8 1 1/2" = 1'-0"
4 3" = 1'-0"
2 6" = 1'-0"
1 12" = 1'-0"

Worksheet Scale. The scale of the worksheet
that will be created if you choose to insert
panels from Model View, or choose to insert
panels onto new worksheets when in
Worksheet View. By default, the scale
displayed is the same scale that is set for your
main Model view window.

Plan View Spacing. The distance between
panels when multiple panels are inserted
onto one worksheet.

Drawing Border. Inserts a drawing border
around the panel when it is inserted onto a
worksheet. If you do not want to include a
border, select None in this drop box. You can
choose any block that currently exists in your
project. For example, in the default drawing
you will see Titleblock (Arch D-Landscape)
listed because that is the title block that is
inserted on the default worksheets.

# Panels Across in Multi-Panel Insertion. If
you are inserting multiple panels onto one
worksheet, this value determines the
maximum number of panels in one row. For
example, if you are inserting 20 panels and
you set this value to 5, your worksheet will
contain 4 rows of panels with 5 panels in
each row.

4. Click OK.
5. If you have previously inserted any of the

panels onto worksheets, a Regenerate symbol

appears next to the names of the panels
that have been inserted. This indicates that
you need to regenerate the panels in order to
update them with your changes.
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To regenerate inserted panels and update
them with your changes, click

at the top of the dialog.

6. Click Close in the Wall Panels dialog.

Note: Editing the wall panel insertion settings has
no effect on wall panel diagrams that you have
already inserted onto worksheets. If you want to
use the new settings on inserted panels, you will
have to delete the inserted panels and insert them
again.

Note: If you have already inserted wall panel
diagrams onto worksheets you can manually edit
wall panel diagrams by editing each panel's
definition in Worksheet View. See Editing Inserted
Wall Panels Manually on page 177.

Specifying Default Print Settings
for Wall Panel Diagrams
Construction Suite only

Prior to printing wall panel diagrams you can specify
the print settings that you would like to use.

1. Select Tools > Wall Panels. If you have
already drawn walls, you can also bring up
the Wall Panels dialog by double-clicking a
wall panel tag in your 2D plan, or by right-
clicking a tag and selecting Edit Wall Panels.

2. Click and select Default Print
Setup. 

3. In the Print Setup dialog, specify the desired
print settings. For more information about
these settings, see Printing Drawings on page
411.

4. Click OK.

Inserting Wall Panels onto Work-
sheets
Construction Suite only

You can insert wall panel diagrams onto worksheets
directly from the Wall Panels dialog. You can insert
multiple diagrams simultaneously, saving valuable
time and effort. If you insert wall panel diagrams
from Model View, they are inserted onto new

worksheets that the program creates for you. If you
insert wall panel diagrams from Worksheet View, you
can choose to insert the diagrams onto new sheets or
existing sheets.
To insert wall panel diagrams onto worksheets:
1. You can insert panels from Model View or

Worksheet View. However, if you want to
insert panels onto an existing worksheet,
make that Worksheet View window the cur-
rent view window first.

2. Select Tools > Wall Panels. If you are in
Model View you can also bring up the Wall
Panels dialog by double-clicking a wall panel
tag in your 2D plan, or by right-clicking a tag
and selecting Edit Wall Panels.

3. In the Wall Panels dialog, select the panels in
the list that you want to insert. 'Ctrl+click' to
select multiple panels one by one, or
'Shift+click' to select a group of consecutive
panels (or all panels). You can also click once
on the building location name to instantly
select all panels on that location. Note that
you can expand and collapse each location by
double-clicking the location name.

4. If you are currently in Model View, click
. A new worksheet will be

created for each selected panel , and the panel
diagrams will be inserted onto the sheets
automatically. If your view tabs are
displayed, you will see new tabs added —
one for each new worksheet created.

If you are currently in Worksheet View, click
and then select either On

Current Worksheet or On New Worksheet
(s).
If you select On Current Worksheet, all
selected panels will be inserted on the current
worksheet. The spacing and layout of panels
is determined by the insertion settings in
your Panel Configuration. If you select On
New Worksheet(s), a new worksheet will be
created for each selected panel.

5. When you are finished inserting panels, click
Close.
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Tip: You can define various insertion settings prior
to inserting panels. For example, you can choose to
include a drawing border on the worksheet, set the
spacing between inserted panels, and specify a
scale for inserted panels. See Editing Wall Panel
Insertion Settings on page 175.

Note: New worksheets containing panel diagrams
are listed in the View Manager, so that you can
control the visibility and properties of each one.

Regenerating Wall Panels
Construction Suite only

If you have inserted wall panel diagrams onto
worksheets and you subsequently make changes to
your wall framing or your wall panel configuration,
the inserted diagrams do not update automatically. In
order to update the inserted diagrams with your
changes you need to regenerate them in the Wall
Panels dialog.

If you see a Regenerate symbol next to a panel's
name in the Wall Panels dialog, this indicates that the
panel has been inserted previously and that it
requires regeneration. The program has detected a
change in your wall framing or wall panel settings
that impacts the appearance of the wall panel
diagram.
To regenerate wall panels:
1. Select Tools > Wall Panels. If you are in

Model View you can also bring up the Wall
Panels dialog by double-clicking a wall panel
tag in your 2D plan, or right-clicking a tag
and selecting Edit Wall Panels.

2. In the Wall Panels dialog, select the panels in
the list that you want to regenerate.
'Ctrl+click' to select multiple panels one by
one, or 'Shift+click' to select a group of con-
secutive panels (or all panels). You can also
click once on the building location name to
instantly select all panels on that location.
Note that you can expand and collapse each
location by double-clicking the location name.

3. Click . When a panel has

been regenerated, the Regenerate symbol

is replaced by a check mark , indic-
ating that the panel's definition has been
updated.

4. Click Close in the Wall Panels dialog. If you
go to a worksheet that contains a regenerated
wall panel, you will see that the diagram has
been updated.

Note: Panels that have never been inserted onto
worksheets are marked with an in the Wall
Panels dialog. These panels do not require
regeneration if you make changes to your wall
framing or panel configuration because they have
not been generated yet. Their diagrams will be
generated with the current settings when you insert
them onto worksheets.

Note: You can also manually edit wall panel
diagrams that have already been inserted onto
worksheets. See Editing Inserted Wall Panels
Manually on page 177.

Editing Inserted Wall Panels
Manually
When you insert a wall panel diagram onto a
worksheet, it is inserted as a block. This means that
you can move, rotate, scale or delete the diagram as a
whole. You can also edit every line, character and
object in the diagram individually and even add
objects to it. When you edit a block's definition, all
instances of that block will update automatically with
your changes.
To edit an inserted wall panel diagram manually:
1. Go to the worksheet containing the wall

panel diagram that you want to edit.

2. Click anywhere on the diagram to select it.

3. If you want to edit the diagram as a whole,
select the desired editing tool (Move, Rotate,
Scale, Delete, etc.) from the Modify menu.

4. If you want to edit individual lines or text in
the diagram, go to the Object Properties pane
on the right side of the screen and click the
Edit button in the Definition field. This takes
you into block editing mode.
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5. Click on an object that you want to edit, then
make the desired change. Continue editing
objects as needed.

6. When you are finished editing the diagram,
press ESC on your keyboard to return to the
overall worksheet.

Note: If you change a wall's size or framing, or
change your panel configuration settings, you can
update inserted wall panel diagrams with those
changes by regenerating the panels in the Wall
Panels dialog.

Exporting Wall Panel Data to a
CSV File
Construction Suite only

You can export data from selected wall panels to a
CSV file to create an automatic bill of materials.
To export wall panel data to a CSV file:
1. Select Tools > Wall Panels. You can also

bring up the Wall Panels dialog by double-
clicking a wall panel tag in your 2D plan, or
by right-clicking a tag and selecting Edit Wall
Panels.

2. In the Wall Panels dialog, select the panels
whose data you want to export. Single-click
to select one panel, Shift-click to select a
group of consecutive wall panels, or
Ctrl+click to select multiple panels one at a
time.

3. Click and select BOM from
Selected Panel(s).

4. In the Save As dialog box, specify a name
and save location for the generated file, then
click Save. A message box confirms that the
BOM generation is complete.

A partial sample file is shown below.
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By default, a basic 160’ x 160’ grass terrain is displayed in the drawing area. You can edit the terrain's size, base
level, mesh spacing and contour display. You can also select a different material to apply to the terrain when
viewing in Rendered and Rendered Outline display mode.

To recreate the topography of your lot, you can add Hills, Valleys, Berms, Trenches, Plateaus or Slopes to the
existing terrain.

Alternatively you can use the Terrain Import Wizard to import data from a site recorder file. This instantly creates a
Triangulated Irregular Network (TIN) mesh that accurately depicts the contours of your building site.

If you do not have a site recorder file to import, you can convert the standard terrain to a TIN mesh and then create
contours by adding spot points to the mesh.

Once you've modeled the terrain, you can create sidewalks and driveways using the Paths tool, or create a patio
with the Pads tool. To help control sloped areas, you may want to insert a Retaining Wall.

If you would like your property lines and building setbacks to be represented in your plan, just use the Site
Boundary tool to define the outline of your lot.

Defining the Size of the Terrain
Personal Architect | Pro Architect | Building Essentials | Construction Suite

By default, a 160' x 160' terrain is displayed in the drawing area. You can edit the length and width of the terrain to
suit your needs.
To define the size of the terrain:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, click Terrain in the left pane.
3. To change the overall size of the terrain, enter the desired values in the Length and Width edit boxes.
4. Click OK.

Note: Length and width settings are not available if the terrain is currently a TIN mesh.

Defining the Grade Level of the Terrain
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can define the elevation at which the base of the terrain sits by editing the terrain's base level in your program
settings. This effectively raises or lowers the terrain when viewing in 3D. The base level is also the reference point
from which topographical features like hills and berms are measured. The Grade level also applies to TIN meshes.
To define the grade level of the terrain:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, click Terrain in the left pane.
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3. To change the level at which the base of the
terrain sits, type the desired value in the
Grade Level edit box. This value is measured
from 0.

4. Click OK.

Cutting the Terrain Around the
Building
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the standard terrain in every new project
is set to cut around the building instead of through it.
You can specify the building location that you want
the terrain to cut around, or force the terrain to cut
through the building if you prefer. These settings
apply to both the standard terrain and TIN meshes.
To define how the terrain cuts around the building:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. To force the terrain to cut around the build-
ing, enable the Auto-cut terrain around
building check box. If you want the terrain to
cut through the building, disable this check
box.

4. To specify the building location that you
want the terrain to cut around, click the
Select Building Location to Cut Around
drop box, then select the desired location.

5. Click OK.

Defining the Terrain Mesh Spa-
cing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When viewing the terrain in Hidden Line or
Rendered Outline display mode in 2D Plan view, or
in any display mode other than Rendered mode in 3D
view, a mesh is displayed on the surface of the terrain
to help you visualize the contours of the terrain in
these display modes. You can edit the spacing
between terrain mesh lines.
To define the terrain mesh spacing:

1. Select Settings > Document Settings or click
on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. Type the desired spacing between mesh lines
in the Mesh Spacing edit box. A smaller
mesh spacing will show a higher level of
detail than a larger mesh spacing.

4. Click OK.

Note: The Mesh Spacing setting is not available if
the current terrain is a TIN mesh.

Controlling the Display of Ter-
rain Contours
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you add features such as hills and slopes to the
terrain, or create a TIN mesh with varying spot level
points, contour lines appear on the terrain in 2D view.
You can control the interval at which contour lines
appear, specify the elevation of the first contour, or
disable contours if preferred.
To control the display of terrain contours:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. To display contours on your terrain, enable
the Show Contours check box. If you do not
want to display contours, disable this check
box.

4. In the Start edit box, enter the elevation of
the first contour.

5. In the Interval check box, enter the desired
spacing between contours.

6. Click OK.

Note: If the current terrain is TIN mesh, you can
also control the labels that appear on contour lines.

TIN_Mesh.htm
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Selecting a Material for the Ter-
rain
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a grass texture is applied to the terrain in
Rendered and Rendered Outline display mode. You
can apply a different material to the terrain if you
want. For example, you may want to display a sandy,
snowy or concrete terrain.
To select a material for the terrain:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. Click in the Material area, then
make your selection in the Materials dialog
and click OK. A preview of the selected tex-
ture is displayed on the Terrain settings page.

4. Click OK.

Specifying Line Style Settings
for the Terrain
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the terrain resides on the Terrain layer,
and adopts the color, line type and line weight
assigned to that layer. You can override the layer
settings and apply a different line style settings to the
terrain lines.
To specify line style settings for the terrain:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. In the Material area, select the desired color,
line type and line weight.

4. Click OK.

Displaying/Hiding the Terrain
Boundary Line
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, when viewing the terrain in 2D view, the
outline of the terrain is displayed. You can disable the
display of the boundary line if you want. This setting
is available for both the standard terrain and for TIN
meshes.
To display or hide the terrain boundary line:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Ter-
rain in the left pane.

3. In the Terrain Mesh area, check or uncheck the
Show Boundary check box.

4. Click OK.

Turning the Terrain On and Off
You can hide the terrain from view and display it
again whenever you want using the View Filter.
To turn the terrain on or off:
1. Select View > View Filters > View Filter or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Terrain tab.

3. Click the eye icon next to the Terrain option.
The eye closes.

4. Click OK.

Creating Hills and Valleys
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add hills to your terrain with a single mouse
click. You can control the height of a hill as well as its
peak shape. Generally, the diameter of the hill base is
the same as the hill height. You can insert multiple
hills together to create one larger hill. Also, if you
insert hills next to other terrain elements, like plateaus
or slopes, the elements will automatically blend
together.
To insert a hill or valley:
1. Select Insert > Terrain > Hills/Valleys, or

click on the Terrain toolbar.

2. In the Hills/Valleys dialog, specify the height
of the hill in the Height edit box. Entering a
negative value will create a valley.
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3. Using the Zenith slider control, select a peak
shape for the hill.

4. Click OK.
5. Click to insert the hill. You can insert mul-

tiple hills if you like.

6. Right-click and select Finish.

Note: The Hills/Valleys tool cannot be used on TIN
meshes.

Editing the Height or Shape of a
Hill
To edit the height or peak shape of a hill:
1. Click in the center of the hill to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties in the Hills/Valleys dia-
log.

4. Click OK.

Creating Berms and Trenches
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A berm is a mound or bank of soil without formal
sides. You often see large berms on the sides of
highways, which are used for noise control. On a
reduced scale, a natural berm can provide some
interesting benefits in a backyard landscape.

Climate control. Berms act as windbreaks, channeling
air flow. Berms can create a warmer microclimate or
direct cooling breezes.

Privacy. A berm can be a "friendly fence" in the back
yard or between your house and a sidewalk.

Vertical interest. You can add variety and texture to
your gardens with berms, change the view from your
outdoor sitting areas, or even hide eyesores with
them.

Noise control. A berm can cut down on traffic noise
if you live on a busy street or near a schoolyard.

Berms may be shored with stone, bricks, or timbers,
and planted with groundcovers, perennials, annuals,
trees, etc.

You can control the height of a berm as well as its
peak shape.

To create a berm/trench:
1. Select Insert > Terrain > Berms/Trenches, or

click on the Terrain toolbar.

2. In the Berms/Trenches dialog, specify the
height of the berm in the Height edit box.
Entering a negative value creates a trench.

3. Using the Zenith slider control, select a peak
shape for the berm.

4. Click OK.
5. Select two points to define the length of the

top of the berm. The berm will be created
downward and outward from this line.

6. Right-click and select Finish.

Note: The Berms/Trenches tool cannot be used on
TIN meshes.

Stretching a Berm
To stretch a berm:
1. Click in the center of the berm to select it.

Grips are displayed at either end of the
berm’s central line.

2. Click and drag an end grip to stretch the
berm, then release your mouse button. You
can move the end point to any position on
the screen.

Editing the Height or Shape of a
Berm
You can edit the height of a berm, or the depth of a
trench, as well as its peak shape.
To edit a berm's height or shape:
1. Click in the center of the berm to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.
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Creating Plateaus
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A plateau is a relatively large, flat area of land
situated above the adjacent land. Adding a plateau to
your terrain involves clicking a few points to define
the shape of the plateau. You can control the height of
the plateau as well as its peak shape. Note that if you
insert a plateau in close proximity to other terrain
elements, such as hills, the elements automatically
blend together.
To create a plateau:
1. Select Insert > Terrain > Plateaus, or click

on the Terrain toolbar.

2. In the Plateaus dialog, specify the height of
the plateau in the Height edit box. Entering a
negative value creates an excavated area.

3. Using the Zenith slider control, select a gen-
eral shape for the plateau. The pointier the
shape, the steeper the sides will be.

4. Click OK.
5. In the drawing area, select points to define

the outline of the top of the plateau. Note that
the last point picked always closes back to the
start point, so you don’t have to pick the start
point again. The plateau will be created
downward and outward from your outline.

6. Right-click and select Finish.

Note: The Plateaus tool cannot be used on TIN
meshes.

Stretching a Plateau
To stretch a plateau:

1. Click in the center of the plateau to select it.

2. Click on the edge of the central outline that
you want to stretch. A blue grip is displayed
on the selected edge.

3. Click and drag the edge to stretch the plat-
eau, then release your mouse button.

Reshaping a Plateau
To reshape a plateau:
1. Click in the center of the plateau to select it.

Corner grips are displayed on the central out-
line of the plateau.

2. Click and drag a corner grip to stretch the
shape, then release your mouse button.

Editing the Height or Peak
Shape of a Plateau
To edit the height or peak shape of a plateau:
1. Click in the center of the plateau to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the properties in the Plateaus dialog.
4. Click OK.

Creating Slopes
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A slope is an area of land with a natural incline. It is
often common practice to slope the land away from
the sides of a house so that water drains away from it
rather than towards it. When you create a slope, you
select two points: the first point is the starting point of
the slope, and the second point determines the length
and direction of the slope. If the slope comes into
contact with other terrain elements, like hills and
plateaus, the elements automatically blend together.
To create a slope in your terrain:

1. Select Insert > Terrain > Slopes, or click
on the Terrain toolbar.

2. In the Slopes dialog, enable the Height but-
ton.

3. In the Height edit box, enter the desired
height for the top of the slope. Note that
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slopes are built from the top surface of the ter-
rain up.

4. Enable the Angle button.
5. In the Angle edit box, enter an angle (in

degrees) for the slope. The higher the value,
the steeper the slope.

6. Click OK.
7. Select a start point for the slope. The slope

will incline from this point. Note that the
sides of the slope will extend to the very
edges of the terrain.

8. Move your cursor in the direction you want
the slope to run. A stretchable arrow is
displayed.

9. When the arrow is pointing in the right dir-
ection and is the desired length, click to insert
the slope. The longer the arrow, the more
gradual the slope will be. A shorter arrow
will result in a steeper slope. Note that if the
point you pick is not on the edge of the ter-
rain, the land will level off at the top of the
slope.

10. Right-click and select Finish.

Note: The Slopes tool cannot be used on TIN
meshes.

Note: If you insert another slope, and that slope
comes into contact with an existing slope, the new
slope will insert on top of the existing slope.

Stretching a Slope
To stretch a slope:
1. Click in the center of the slope. The central

arrow is displayed, and grips are displayed at
either end of it.

2. Click and drag an end grip to stretch the
arrow, then release your mouse button. Note
that you can also rotate the arrow by select-
ing a different position for it while clicking
and dragging. This changes the direction of
the slope.

Editing the Height of a Slope
To edit the height of a slope:
1. Click in the center of the slope to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Slopes dialog, enable the Height radio
button.

4. Edit the height in the Height edit box.
5. Click OK.

Editing the Angle of a Slope
To edit the angle (steepness) of a slope:
1. Click in the center of the slope to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Slopes dialog, enable the Angle radio
button.

4. Edit the height in the Angle edit box.
5. Click OK.

Importing Site Data
Construction Suite only

You can use the Terrain Import Wizard to import spot
levels from a site recorder file. When you import site
data, the program reads in the X, Y and Z coordinate
values for each point in the file.

You can import site data from the following types of
files:
l TXT (delimited text file)
l CSV (Comma Separated Value file)
l GPX (GPS eXchange Format)
l XYZ (Coordinates file)
l YXZ (Coordinates file)
l PRM (Parameter file)
l PNT (Point file)
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l AUF (Autodesk Uploadable File)
l NEZ (Northing, Easting and Elevation data)

Once you have stepped through the Wizard, a
Triangulated Irregular Network (TIN) mesh is
instantly created in the drawing area that accurately
depicts the contours of your building site.

To import site data:
1. Select Insert > Terrain > Import Site Data, or

click on the Terrain toolbar.

2. On the first screen of the Terrain Import Wiz-

ard, click .

3. In the Open dialog, click the drop box next to
the File Name edit box and select the file
type you are looking for.

4. Locate and select the site recorder file that
you want to import, then click Open. The file
is loaded into the Terrain Import Wizard.

5. Click the Format drop box, then select the
format of the data that you are importing.

6. Click the Delimiter drop box, then select the
method used to separate data in the imported
file. Choices are Comma, Tab, Space,
Semicolon, or Bar/Pipe. If you are not sure
what type of delimiter was used in the file,
select the option that creates the most optimal
result in the preview window. For example, if
you are importing an XYZ file, you want to
make sure that there is a value displayed in
each column (X, Y and Z). If the wrong
delimiter is selected, all values may appear
grouped into one column (e.g. the X column),
and the points will not be input properly.

7. If you want to start importing data from a
row other than row 1, enter the row number
in the Start Import at Row edit box.

8. Click .

9. On the next screen, click the Units drop box
and select the unit of measure used in the file
that you are importing (Millimeters,
Centimeters, Meters, Inches, Feet or
Yards).
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10. Certain points in the file may be there as a ref-
erence or comment only, and should not be
included in the import. Such points are usu-
ally accompanied by text that distinguishes
them from the measured spot levels. For
example, a point may be labeled as a bench-
mark rather than a measured spot level. If the
file contains points that you do not want to
import, enter a keyword that identifies them
in the file. If you are specifying multiple
keywords, separate them with a semicolon (;).
When the program is importing the file, any
lines containing the specified keywords will
be ignored.

11. Click . The points in the data
file are imported into the Wizard. A preview
of the resulting mesh is displayed on the next
screen. You can zoom and pan in the preview
window using the controls below the preview
window.

The overall dimensions of the mesh (Width
and Height) are displayed to the left of the
preview. The elevation of the highest point
on the mesh (the highest Z coordinate) is
displayed in the Max Z box, and the lowest
point (the lowest Z coordinate) is displayed
in the Min Z box.

If the resulting values do not look realistic,

click to select input units that
result in correct measurements. Note that the
measurements are displayed in the unit of
measure selected in your program settings,
not necessarily the unit of measure used in
the imported file.

12. To adjust the base level from which spot
levels are measured so that the mesh is inser-
ted at the Base Level defined for the terrain in
your program settings, edit the value in the
Grade Level edit box. For example, if the Min
Z value in your file is 20', and the Base Level
in your program settings is set to 0", you
might set the Grade Level value to -20' so
that the bottom of the mesh sits at the 0" Base
Level when it is inserted. If instead you were
to specify a Z Offset of 0", the mesh would
virtually be inserted 20' in the air when view-
ing in 3D.
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13. If you want to change the angle of the mesh,
enter the desired angle in the Angle edit box,

or click the Pick Angle button next to
the Angle edit box and pick two points in the
preview window to define the angle. If you
are picking points to define the angle, the
Angle by Reference dialog appears and
reports the angle that you defined. You can
edit the angle here if you want.

14. If you want to import only a portion of the

mesh, click under the Crop Box
option, then click two points diagonally in
the preview window to define a box around
the portion that you want to import. A blue
box is displayed around the selected portion.

To remove the crop box, click .

15. Specify the point on the mesh that you want
to be attached to your cursor when you are
inserting the mesh:

To select a specific insertion point on the

mesh, click under the Insertion
Point option, then select a point on the mesh
that you would like to serve as the insertion
point. A green circle is displayed at the
selected point. This is the point that will be
attached to your cursor when you insert the
mesh in your drawing area. To remove the

defined insertion point, click .

To move the insertion point to the origin
specified in the original mesh file, enable the
Move to origin check box.
If you do not select an insertion point or
move it to the origin, your cursor will be
attached to the center of the mesh when you
insert it.

16. Click . The mesh is attached to
your cursor.

17. Position the mesh in the drawing area, then
click to insert it.

Note: If you import site data to create a TIN mesh
and save the project as a version 7.2 file, the mesh
will not be saved in that file. It will revert back to
the standard, flat terrain.

Converting the Terrain to a TIN
Mesh
Construction Suite only

A Triangulated Irregular Network (TIN) mesh is a
representation of the surface of the terrain based on a
set of points. As an alternative to using Terrain tools
such as Hills/Valleys, Slopes and Plateaus, you can
convert your standard terrain to a Triangulated
Irregular Network (TIN) mesh and then add spot
level points to the mesh to create contours in the
terrain. This can help you accurately depict the
topography of your building site by illustrating
changes in elevation across the site.

You can also convert a terrain that has had features
such as hills and slopes added to it. In this case, spot
level points and contours are displayed within the
boundary of the TIN mesh.
To convert the terrain to a TIN mesh:
1. Select Insert > Terrain > Convert Terrain to

TIN.
2. In the Convert Terrain dialog, click Yes to

confirm that you want to convert the terrain
to a TIN mesh.

Note: If you convert the terrain to a TIN mesh and
save the project as a version 7.2 file, the mesh will
not be saved in that file. It will revert back to the
standard, flat terrain.

Adding Spot Level Points to a
TIN Mesh
Construction Suite only

If you have converted the terrain to a TIN mesh, or
have imported data from a site recorder file to create
a TIN mesh, you can use the Spot Points tool to add
spot level points to the mesh. Adding spot level
points with different elevations creates contours on
the mesh. This is a great alternative to using terrain
tools such as Hills/Valleys, Slopes and Plateaus. Even
adding only a few key points can result in a fairly
good representation of your building site.

As you are positioning a spot point on the mesh you
can view its current position by looking at the X and
Y coordinates displayed on the Commander, and
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specify the point's Z coordinate, or elevation. You can
also edit the point's elevation after insertion.
To add spot level points to a TIN mesh:
1. Select Insert > Terrain > Spot Point, or click

on the Terrain toolbar. A spot point is
attached to your cursor, and the Commander
displays X, Y and Z edit boxes.

2. To specify the elevation of the spot point,
type a value and press the Tab key. This
value is measured from the base of the terrain
and appears in the Z edit box as you type it.

3. With the Z value defined, position the spot
point on the mesh. As you move it around,
the values in the X and Y edit boxes update
the display the point's current position. You
can type directly in the X and Y edit boxes if
you want.

4. Click to insert the spot point. Contours are
created around the inserted point. Each
contour is marked with elevation text.

Editing the Elevation of Spot
Level Points
If you have used the Spot Points tool to add a spot
level point to a TIN mesh, you can edit the elevation
of that point after it has been inserted. When you edit
the elevation of a spot level point, the contours
update to reflect the change in the mesh.
To edit the elevation of a spot level point:
1. Click on the spot point to select it.

2. Right-click and select Properties. The current
elevation of the point is displayed in the Spot
Points dialog.

3. Edit the value in the Level edit box to adjust
the elevation of the point. The value is meas-
ured from the base of the terrain.

4. Click OK. The mesh is updated.

Adjusting the Smoothness of
Mesh Contours
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have imported site data to create a TIN mesh
or have converted the terrain to a TIN mesh and
added spot level points, you can control the
smoothness of the mesh's contour lines. Fine
smoothing creates gentle, rounded curves, while a
more coarse setting creates more angular lines.
To adjust the smoothness of mesh contours:
1. Select Settings > Program Settings.
2. In the Program Settings dialog, select Ter-

rain in the left pane.
3. In the right pane, click and drag the TIN

Smoothing slider to the desired setting. Fine
smoothing creates gentle, rounded curves,
while a more coarse setting creates more
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angular lines.

4. Click OK.

Note: The TIN Smoothing setting is not available if
the current terrain is not a TIN mesh.

Controlling the Display of Ter-
rain Contour Labels
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When you import site data to create a TIN mesh or
add spot level points to a TIN mesh, the resulting
contour lines are marked with labels that indicate the
elevation of each contour. You can turn contour labels
on or off, and select a text style to apply to the labels
if they are turned on.
To control the display of terrain contour labels:
1. Select Settings > Program Settings.
2. In the Program Settings dialog, select Ter-

rain in the left pane.
3. In the right pane, enable the Show Labels

check box if you want to display contour
labels, or disable the check box if you do not
want to display labels.

4. To select a text style for the labels, click
below the Show Labels check

box. Make a selection in the Text Styles dia-
log, then click OK.

5. Click OK to apply your changes.

Resetting the Terrain
Construction Suite only

If you have imported site data to create a TIN mesh
or converted the standard terrain to a TIN mesh, you
can use the Reset Terrain tool to remove the TIN
mesh from your drawing and re-insert a standard, flat
terrain. The size and properties of the terrain are
determined by your program settings.
To reset the terrain:
1. Select Insert > Terrain > Reset Terrain. The

TIN mesh is removed, and the terrain is reset.

Creating Paths, Sidewalks and
Driveways
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a wide variety of path types,
including boardwalks, sand paths, gravel paths, brick
paths, and driveways. The width and thickness of a
path is determined by the path’s properties in the
catalog. You control the length and direction of the
path as you draw it. Dimensions are displayed as you
draw each segment.
To create a path:

1. Select Insert > Terrain > Paths, or click
on the Terrain toolbar.

2. In the catalog, select the path type you want
to insert.

3. Select a start point for your path. Note that
your insertion point is on the center line of
the path.

4. Move your cursor in the direction you want
the path to run, then select an endpoint for
the path. You can continue selecting points in
any direction to add more sections to the path
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if you want.

Tip: To create a smooth curve in the path, click
several points with a short distance between each
point.

5. Double-click to finish, or right-click and select
Finish.

Note: By default, all paths hug the terrain they are
inserted on, but you can disable the Hug Terrain
option in the path’s properties if you want.

Stretching a Path Element
You can lengthen or shorten a sidewalk, pathway or
driveway by clicking and dragging its end grips, or
using the Stretch tool. If you use the click-and-drag
method, the path is constrained to its current
direction when you stretch it. If you use the Stretch
tool you can rotate the path while stretching. You can
also use the Commander when the Stretch tool is
active.
To stretch a path by clicking and dragging:
1. Click on the path to select it.

2. Click and hold your mouse button over one
of the path's end grips. The Lengthen cursor
is displayed .

3. Drag to stretch the path, then release your
mouse button.

To stretch a path with the Stretch tool:
1. Click on the path to select it.

2. Right-click and select Stretch. Your cursor
becomes the Stretch cursor .

3. Click and hold your mouse button over one
of the path's end grips, drag to stretch the
path in any direction, then release your
mouse button. If you want to enter a precise
stretch distance or direction, click on the end

grip, specify the desired distance and dir-
ection in the Commander, then press Enter.

Editing the Thickness or Width
of a Path Element
You can edit the thickness of your path material or
the path’s overall width.
To edit the thickness or width of a path:
1. Select the path. If the path has multiple seg-

ments, you do not have to select them all.
Property changes affect the whole path.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To edit the thickness of the path, enter a
value in the Thickness edit box.

4. To edit the width of the path, enter a value in
the Width edit box.

5. Click OK.

Creating a Pad
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Pads tool to insert a concrete or brick
pad directly on your terrain. By drawing the outline
of the pad, you control its precise size and shape. You
can use the Materials Paintbrush to apply a different
color or material to the pad after it has been inserted.
To create a pad:

1. Select Insert > Terrain > Pads, or click
on the Terrain toolbar.

2. In the catalog, select the type of pad that you
want to insert.

3. Select a start point for the pad.

4. Continue selecting points to define the out-
line of the pad. Note that the last point
picked always closes back to the start point,
so you don’t have to pick the start point
again.

5. Right-click and select Finish.

Note: By default, pads hug the terrain they are
inserted on. If the terrain is not flat where you are
inserting the pad, you may want to turn off the
pad’s Hug Terrain option to make the pad flat and
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have it positioned at the Terrain Base Level
specified in your Terrain Settings.

Disabling the Hug Terrain
Option
Disabling the Hug Terrain option ensures an element
remains flat regardless of any slopes in the terrain,
and positions the element at the Base Level specified
in your terrain settings.
To disable the Hug Terrain option:
1. Click on the edge of the element to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Basic property page, uncheck the Hug
Terrain? check box.

4. Click OK.

Resizing a Pad
You can resize a pad by stretching one of its edges.
To resize a pad by stretching it:
1. Click on the edge of the pad to select it.

2. Hover your pointer over the center blue grip
of the edge you want to move. This displays
the Move cursor. Alternatively you can
select the Move Edge tool on the right-click
menu.

3. Click and drag to stretch the pad, then release
your mouse button.

Reshaping a Pad
You can change the shape of a pad by clicking and
dragging its corners.
To reshape a pad:
1. Click on the edge of the pad to select it. A

grab handle is displayed at each corner.

2. Click and drag a corner grip to stretch the
pad.

3. Release your mouse button.

Editing the Thickness of a Pad
You can edit the thickness of a pad on the pad’s Basic
property page.
To edit the thickness of a pad:

1. Click on the edge of the pad to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Pads dialog, select the Basic tab.
4. Enter the desired thickness in the Thickness

edit box.

5. Click OK.

Drawing Retaining Walls
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Drawing retaining walls is easy — just point and
click. Envisioneer automatically displays dimensions
as you draw, and connects corners for you.
To draw a retaining wall:
1. Select Insert > Terrain > Retaining Walls, or

click on the Terrain toolbar.

2. In the catalog, select the wall type you want
to insert.

3. Select a start point for the wall.

4. Move your cursor in the direction you want
your wall to run. Its length is shown as you
draw the wall.

5. When the wall is the length you want, click to
set its endpoint.

6. Continue selecting points to add on to the
wall if you want.

7. When you are done, right-click and select Fin-
ish.

Creating a Site Boundary Using
the Reference Angle Method
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When creating a site boundary using the Reference
Angle Method, angles are measured using compass
bearings and a reference angle. Each angle is
measured within a given quadrant (NE, NW, SE or
SW). The angle is the acute (less than 90°) angle from
the North or South meridian as measured to the East
or West. For example, the bearing N 90d00’00” E can
be thought of as 90º east of North.
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By default, the angle is specified using the
degrees/minutes/seconds format, but you can choose
to use decimal degrees if you prefer.
To create a site boundary with the Reference Angle
Method:
1. Make sure the Reference Angle format is

selected on the Site Boundaries page in your
Document Settings.

2. In 2D plan view, select View > Zoom and
Navigate > Zoom to Fit, or click on the
View Control toolbar. This will bring the
entire terrain into view so you can insert the
boundary easily and precisely.

3. Select Insert > Terrain > Site Boundary, or
click on the Terrain toolbar.

4. Select a point for the first peg (stake). The
Commander becomes instantly active, dis-
playing options for defining the length and
direction of line segments.

5. Move your mouse in the general direction
you want the first site boundary line to run.
This determines the quadrant you are work-
ing in, and the compass points used in the
bearing. Note that you can also select a quad-
rant (NE, NW, SE or SW) from the drop box
in the Commander if you prefer — just
remember to Tab over to the Distance edit
box when you’re done.

6. Type a length for the boundary line. The
value appears in the Commander’s Distance
edit box.

7. To specify the direction of the line, either
move your mouse in the desired direction
(watching the resulting angle in the Com-
mander’s Direction edit box), or press the
Tab key to move to the Direction edit box,
then enter the desired angle and press
ENTER. Remember that the angle is meas-
ured from the North or South meridian, and
should be between 0 and 90 degrees.

8. Continue defining the remaining segments.
When you have defined all but the last
segment, right-click and select Finish. A
closing line segment will be created
automatically between the first and last peg,
forming a closed site boundary.

Note: Bearings coincide with the angle of the north
arrow specified in your global settings.

Creating a Site Boundary Using
the Angle Bearing Method
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When using the Angle Bearing Method to draw a site
boundary, each angle is calculated clockwise from the
positive Y axis, or North meridian. By default, each
bearing is entered as a forward bearing, but you can
choose to enter a back bearing instead.
To create a site boundary with the Angle Bearing
Method:
1. Make sure the Angle Bearing format is selec-

ted on the Site Boundaries page in your Docu-
ment Settings.
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2. In 2D plan view, select View > Zoom and
Navigate > Zoom to Fit, or click on the
View Control toolbar. This will bring the
entire terrain into view so you can insert the
boundary easily and precisely.

3. Select Insert > Terrain > Site Boundary, or
click on the Terrain toolbar.

4. Select a point for the first peg (stake). The
Commander becomes instantly active, dis-
playing options for defining the length and
direction of line segments.

5. If you want to enter a back bearing instead of
a forward bearing, select Back bearing from
the Commander’s left drop box. Just remem-
ber to Tab over to the Distance edit box
when you’re done.

6. Type a length for the first boundary line. The
value appears in the Commander’s Distance
edit box.

7. To specify the direction of the line, either
move your mouse in the desired direction
(watching the resulting angle in the
Commander’s Direction edit box), or press
the Tab key to move to the Direction edit
box, then type the desired angle and press
ENTER. Remember that each angle is
calculated clockwise from the positive Y axis,
or North meridian.

8. Continue defining the remaining segments.
When you have defined all but the last seg-
ment, right-click and select Finish. A closing
line segment will be created automatically
between the first and last peg, forming a
closed site boundary.

Stretching a Site Boundary
You can resize or reshape a site boundary by clicking
and dragging its grips.
To stretch a site boundary:
1. Click on one of your lot lines to select the site

boundary. If you want to resize the bound-
ary, click on the specific lot line that you
want to move. Clear blue grips appear at
each corner of the boundary, and a solid blue
grip appears at the center of the lot line you
selected.

2. To resize the boundary, click and drag the
solid blue grip. To reshape the boundary,
click and drag one of the clear blue corner
grips.

3. Release your mouse button.

Note: You can also edit the length and direction of
individual lot lines precisely by editing the
boundary’s properties.

Editing the Length or Direction
of Site Boundary Edges
You can edit the length or direction of a site boundary
edge by editing site boundary properties.
To edit the length or direction of a site boundary
edge:
1. Click on the lot line you want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To edit the length of the current segment,
type the desired value in the Length edit box.

4. To edit the distance of the setback line from
the lot line, type the distance in the Setback
edit box.

5. To edit the angle of the current segment,
make the appropriate changes in the Direction
area of the Site Boundary Edge dialog.
There are two methods of defining direction.
The method that is available is the one that
was used to draw the site boundary initially,
or whatever is current on the Units of
Measure page in your Program Settings.

If the Reference Angle Method is current, you
can edit the direction of the segment by
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editing the value in the Angle edit box. If the
Angle Bearing Method is current, you can edit
the direction of the segment by editing the
Forward Bearing or Back Bearing value.

6. In the When Editing area, select the appro-
priate Peg No. to adjust, as editing the length
or angle of a segment will cause a peg to
move.

7. Click OK.

Defining Setback Distances
By default, setback lines are not included in your site
boundary, as all setback distances are set to 0. You
can specify a setback distance for each individual site
boundary edge.
To define setback distances:
1. Click on the property line you want to specify

a setback distance for. Note that setback dis-
tances are defined per site boundary edge,
one at a time.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Site Boundary Edge dialog, edit the
value in the Setback edit box.

4. Click OK.

Clipping the Terrain to the Site
Boundary
If you have added a site boundary to your plan, you
can choose to clip the terrain to the site boundary so
that when you view the model in 3D, you see only
your lot. In other words, the terrain is resized to the
size of your lot in 3D.

To clip the terrain to the site boundary:
1. Click on the edge of the site boundary to

select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Site Boundary Edge dialog, enable the
Clip Terrain check box.

4. Click OK.
The terrain boundary line becomes dashed in 2D
plan view, indicating that it will be clipped. The
terrain will be clipped (resized) when you view
the model in 3D.

Curving a Site Boundary Edge
You can curve a site boundary edge using the Curve
tool, or by editing site boundary edge properties.
To curve a site boundary edge using the Curve
tool:
1. Click on the site boundary edge you want to

curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Click and drag the edge to the desired curve.

4. Release your mouse button.

To curve a site boundary edge by editing its
properties:
1. Click on the lot line you want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Enable the Arc Radius check box, then enter
the desired arc radius in the adjacent edit
box. The arc radius is the distance from the
lot line (in its uncurved state) to the top of
the proposed arc.

4. Select the desired direction of the arc from
the Arc Direction drop box. Selecting Inside
creates the arc toward the inside of the bound-
ary, while selecting Outside pushes it out-
ward.

5. Click OK.
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Editing a Site Boundary's Line,
Text and Peg Styles
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit site boundary settings before or after a
site boundary has been created. Settings include line
styles for lot lines and setback lines, text styles for
bearings, lengths and pegs, as well as peg size and
style. You can also control which textual information
you want to appear.
To edit site boundary settings:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Site
Boundaries in the left column.
If you have already drawn a site boundary,
you can also access site boundary settings by
clicking the Settings button in the Site
Boundary Edge dialog.

3. To edit the line style of the outside boundary
line, select Boundary line from the drop box
in the Lines area, then select the desired color,
line type and line weight for the line.

4. To edit the line style of the setback line, select
Setback line from the drop box in the Lines
area, then select the desired color, line type
and line weight for the line.

5. To edit the line style of the pegs, select Peg
from the drop box in the Lines area, then
select the desired color, line type and line
weight for the line.

6. To edit the peg style, select either the Round
or Square option in the Pegs area. To edit the
size of the peg symbol, enter the desired
value in the Width edit box.

7. To edit the text style of bearing text, click the
Bearing button, then select the desired text
style from the Text Styles dialog. If you do
not want to include bearing text in the site
boundary, disable the adjacent Include check
box. By default, bearing text appears on the
inside of the site boundary. If you want it to
appear on the outside, select Outside Line
from the drop box next to the Include check

box. Note that if you are including both bear-
ing text and length text, one must be set to
the outside of the boundary, and one must be
set to the inside. You cannot have both on the
same side. Otherwise, one of them will be dis-
abled.

8. To edit the text style of length text, click the
Length button, then select the desired text
style from the Text Styles dialog. If you do
not want to include length text in the site
boundary, disable the adjacent Include check
box. By default, length text appears on the
outside of the site boundary line. If you want
it to appear on the inside, select Inside Line
from the drop box next to the Include check
box.

9. To edit the text style of peg text, click the Peg
button, then select the desired text style from
the Text Styles dialog. If you do not want to
include peg text in the site boundary, disable
the adjacent Include check box.

10. To edit the distance between text and the site
boundary line, enter the desired distance in
the Distance from line edit box. This applies
to all forms of text — bearing, length and peg
text.

11. Click OK.

Selecting a Method of Meas-
urement When Drawing a Site
Boundary
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

There are two methods of angle measurement
available for creating a site boundary. With the
Reference Angle method, each angle is measured
from the North or South meridian within a given
quadrant (NE, NW, SE, SW). With the Angle Bearing
method, each angle is measured clockwise from the
positive Y axis, or North meridian.

Site units can be Imperial or Metric. You can select the
unit of measure you want to use and specify the
desired level of precision.
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When specifying the angle of each site boundary
segment, you can use Degrees/Minutes/Seconds, or
Decimal Degrees with a specified level of precision.
To select a method of angle measurement for site
boundary entry:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Site
Boundaries in the left column.

3. Select the desired entry method from the
Bearing Format drop box (Reference Angle or
Angle Bearing).

4. In the Distances area, select either Imperial or
Metric, then select a unit of measure from the
Units drop box. Imperial choices are Feet-
Inches and Inches. Metric choices are Mil-
limeters, Centimeters and Meters. From the Pre-
cision drop box, select a level of precision for
distance measurements.

5. From the Units drop box in the Angles area,
select the unit you wish to use when spe-
cifying the angle of each site boundary edge.
Choose either the Degrees/Minutes/Seconds, or
Decimal Degrees. If your choice is Decimal
Degrees, select the desired level of precision
from the adjacent Precision drop box.

6. Click OK.
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Envisioneer offers a full set of landscaping tools to help you design a complete and realistic landscape plan. You
may want to start with major structures, such as Decks, Patios, Fences, Sheds and other Exterior Structures.

Once those are in place you can bring your plan to life with Garden Beds, Edging and Plants, and even lay out an
Irrigation system!

Enhance and personalize your plan even further by adding Furniture, Accessories and Lighting.

Inserting Plants
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Inserting plants involves nothing more than a single mouse click, and once inserted, they can be dragged and
dropped anywhere you like. Before inserting plants, you may want to research different plant types in the Plant
Encyclopedia, which contains thousands of different plant species.
To insert a plant:

1. Select Insert > Landscape > Plants, or click on the Landscape toolbar.

2. In the catalog, select the plant you want to insert. If you want to view the plant’s size or requirements before
inserting it, right-click in the catalog and select Properties.

3. Position the plant where you want it, then click to insert it.

4. Right-click and select Finish.

Note: Although the Master Catalog contains a wide variety of plants for you to insert, it does not contain all the
plants listed in the Encyclopedia. You can, however, insert plants from the Encyclopedia. You can also add plants
from the Encyclopedia to the current catalog.

Editing the Appearance of a Plant in 2D View
By default, plants are represented by a circular symbol in 2D plan view. You can choose from three 2D plant styles.
You can also change the diameter of the trunk in 2D, or hide the trunk altogether.
To edit the style of a plant in 2D:
1. Select the plant whose properties you want to edit.

2. Right-click and select Properties, or select Edit > Modify Elements > Properties.
3. In the Plants dialog, select the Size tab.
4. To change the style of the circle shown in 2D plan view, click the style you want in the Type area.

5. To change the size of the trunk in 2D plan view, edit the value in the Trunk Diameter edit box. To hide the
trunk from 2D view, select No from the Show trunk in plan? drop box.

6. Click OK.
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Changing the Age of a Plant
The age of a plant determines its size at planting time.
You can increase or decrease the age of a plant by
making a change on the plant’s Plant Info property
page.
To change the age of a plant:
1. Click on the plant whose planting age you

want to change.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Plants dialog, select the Plant Info tab.
4. Move the Planting Age slider left or right

until the desired planting age is displayed.
Planting age is measured in years.

5. Click OK.

Note: This ability is not available for 3D plants.
Only billboard plants have this option.

Forcing a Custom Plant Size
The size of a plant is determined by properties in the
Plant Encyclopedia. You can specify a custom height
and width for a plant on the plant’s Size property
page. Note that if you do this, however, the plant’s
size changes in both 2D and 3D regardless of the
Planting Age setting on the Plant Info page.

Note: If you just want to see plants at a different
maturity level (i.e. change their age), you should
change their planting age instead. You can also
apply an overall age change to your landscape.

To change the size of a plant:
1. Select the plant whose properties you want to

edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Plants dialog, select the Size tab.
4. Set the Size from encyclopedia option to

No.
5. To change the width of the plant, enter a

value in the Width edit box.
6. To change the height of the plant in 3D view,

edit the value in the Height edit box.
7. Click OK.

Note: This ability is not available for 3D plants.
Only billboard plants have this option.

Seeing Plant Growth Over Time
Once you have inserted plants in your landscape
plan, you can see how they will look any specified
number of years down the road using the Plant
Growth Over Time feature.
To see plant growth over time:
1. Select Insert > Landscape > Gardening >

Plant Growth Over Time, or click the down
arrow next to the Gardening button on
the Landscape toolbar and select Plant
Growth Over Time.

2. Enter the number of years to add to your
landscape.

3. Click OK.
NOTE: This ability is not available for 3D plants. Only
billboard plants have this option. For 3D plants you
must change their actual size in the plants properties.

Applying Seasonal Changes to
Plants
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Plant Seasonal Change feature updates the
appearance of the plants in your drawing to reflect a
particular season. Generally the change applies to
flowering plants and trees that have a certain bloom
time.
To apply seasonal changes to your plants:
1. Select Insert > Landscape > Gardening >

Plant Seasonal Change, or click the down
arrow next to the Gardening button on
the Landscape toolbar and select Plant
Seasonal Change.
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2. In the Program Settings dialog, change the
date. Select a month by clicking the arrows
on the month bar at the top of the calendar.
Select a day by clicking a number on the cal-
endar.

3. Click OK. The plants in your drawing are
updated according to the time of year you
specified.

Note: Keep in mind that seasonal changes may
have different results depending on the plant’s
properties in the Encyclopedia. Things to consider
are the climate of the region the plant is in, and the
plant’s world origin.

Note: This ability is not available for 3D plants.
Only billboard plants have this option.

Using the Plant Encyclopedia
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Plant Encyclopedia contains comprehensive
information on thousands of plants. The Encyclopedia
has many uses related to the selection and care of
plants. You can:
l View information about any plant
l Select plants based on certain criteria
l Research potential diseases
l Learn how to care for your plants

To access the Plant Encyclopedia:
1. Select Insert > Landscape > Gardening >

Plant Encyclopedia, or click on the
Landscape toolbar.

You can also access the Plant Encyclopedia by
clicking the Encyclopedia button on a plant’s
Encyclopedia property page.

Encyclopedia Main Page
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia’s main page contains a
comprehensive plant list that you can scroll through
and select plants from. The page also displays a photo
and two previews of a selected plant, as well as basic

information about the plant and its appropriate
growing environment.

Selecting a Plant to View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the plant list on the Encyclopedia's main
page contains all 7500 plant species. If you have used
the Plant Filter to filter out certain plant types, the list
is smaller.

To select a plant in the plant list, use the scrollbar
beside the plant list to scroll through the list of plants,
then click on the plant you want to view. By default,
common plant names are listed in the plant list. You
can switch to Latin names by clicking the Latin
button.

If you know the name of the plant you are looking
for, you can locate it more quickly by typing the first
few letters of the plant’s name in the Search Edit field
above the plant list. The list of plants will move to the
closest match as you type.
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Viewing Plant Information
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's main page displays images and
basic information about the currently selected plant.
To view plant information:
1. Select Insert > Landscape > Gardening >

Plant Encyclopedia, or click on the
Landscape toolbar.

2. Select the plant you want to view information
about.

3. Basic information is displayed on the main
page, which is described below.

Usage. This window lists all the possible ways you
can use the plant. Click one of the usage options to
view a brief description of the usage in the Plant
Usage catalog.

Soil/Zone/Lifetime. The window below the Usage
window indicates Soil Preference (alkaline, acidic,
heavy, etc.), Zone (ranging from 1 for Sub-Arctic to 10
for Sub-Tropical), and Lifetime (the life expectancy of
the plant in years). Each of the icons/items in this
window has a tool tip. If you hover your cursor over
the icon/item, a small pop-up window appears
displaying a brief description of the item. For
example, if you hover your cursor over the soil
preference icon, the window will display the
preferred soil type that the icon indicates.

Plant Type and Needs. The window to the right of
the Usage window indicates the following:

Each of the icons in this window has a tool tip. If you
hover your cursor over the icon, a small pop-up
window appears displaying a brief description of the
icon.

Season Color Diagram. This circle gives you an idea
of what you can expect from the chosen plant
throughout the year. The outer circle shows the
months in which the plant blooms, and the color of its
flowers. Fruits are also indicated in this circle,
showing the period when they ripen, and the color of
their fruit. The inner circle indicates when the plant
has foliage (including autumn leaves), and the color
of its leaves.

Plant Views

The main page has two views: overhead and profile.
The overhead view shows you a textured view of the
plant from above.

The profile view gives you an idea of the plant’s
height and spread, and shows you what your plant
will look like in 3D.

Note: The profile view shows the plant’s total
height. If the plant is a vegetable, this includes the
underground part. If the plant is a water plant, the
underwater part is included. The width of bushes
and flowers can be affected by how they are
pruned. The plant will reach optimum size at
maturity and under favorable conditions.

Note: This ability is not available for 3D plants. Only
billboard plants have this option.
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Plant Care Calendar
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's Plant Care Calendar page shows
the required monthly care (planting, watering,
fertilizing, etc.) for the currently selected plant.

Note: This ability is not available for 3D plants.
Only billboard plants have this option.

To see detailed information about each plant care
task, click on the icon. A Care dialog appears
displaying helpful tips on how to complete a given
task. Clicking the tools icon in the top right corner of
the dialog opens a dialog showing the tools you will
need to complete the task.

World Map Page
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's World Map page displays a world
map that indicates the region of the world where the
currently selected plant originates. Right-click on a
highlighted region to see details about the climate and
growing conditions most favorable for plants
indigenous to the region.

Notebook Page
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Encyclopedia's Notebook page to
enter and view notes about the currently selected
plant. To select a plant, scroll through the list and
click on it, or use the Search Edit field above the plant
list to enter the first few letters of the plant name and
find a quick match. Click in the box on the right side
of the page and type your note. When you move to
another page in the Encyclopedia, your text is saved
automatically.

Picture Page
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's Picture page contains a collage of
thumbnail images of all the available plants in the
plant list. You can browse through the images
manually or by using the arrows at the top of the
page.
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To view a large picture of a selected plant, click the
View Large button at the top of the page.

To return to the thumbnail views, click the View
Thumbnail button .

Diseases Page
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's Diseases page lists the possible
diseases that may affect a plant. By default, the
disease list contains the diseases that can affect the
currently selected plant. If you want to view a
comprehensive list of diseases for all plants, click All
in the bottom right corner of the page.

When you select a disease in the disease list, you will
see a picture of the disease, details of its symptoms in
the Symptoms windows, and care information in the
Control window.
If you want to search in reverse to find all plants
affected by a specific disease, click the Filter button at
the bottom of the page. This opens the main
Encyclopedia page. To restore your plant list, return
to the Diseases page and click the All button.

Filtering the Plant List
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Encyclopedia's Plant Filter lets you filter out
unwanted plants from your plant list by specifying
various criteria.
To use the Plant Filter:
1. Select the Plant Filter tab on the left side of

the Encyclopedia window.

2. Each Encyclopedia page has different options.
Click on the tabs along the top of the
Encyclopedia window to select the page you
want, then select the options you want.

The main Encyclopedia page lets you select
the Plant Type, Watering Needs, Lighting
Preference, Soil Preference, Zone, Color (for
flower, leaf, autumn leaf, and fruit), Height
and Blooming Season. 

The Plant Care Calendar page lets you select
the Complexity of Care required, Speed of
Growth (for both height and spread), Life
Expectancy and Usage.

The World Map page lets you select the
region of the world where the plants
originate. For example, if you wanted to find
plants for an Asian-themed water garden,
you would click on the Asian region of the
map to exclude any plants that aren’t
indigenous to Asia.

The Notebook page lets you filter plants by
notes that you’ve entered previously on this
page. For example, you could enter the note
“Front Yard” for all plants that you want to
use in your front yard. When you are ready
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to lay out the front yard of your landscape
plan you can go back to the Plant Filter and
limit your plant list to only the plants you’ve
pre-chosen for your front yard.

The Picture page lets you limit your plant list
by the part of the plant shown in its photo
(leaf, bark, fruit, etc.).

The filter option available on the Diseases
page is different, because it affects the disease
list, not the plant list. To use this filter, click
on the image that represents the part of the
plant affected or type of infestation, then
select the Encyclopedia tab on the left side of
the window to switch to the regular
Diseases page. For example, if you are
considering planting lilies or daffodils in your
garden, and want to know what type of
diseases these bulb plants may encounter,
click the Bulb image on the Diseases page
(in Plant Filter mode), then go into
Encyclopedia mode and select the Diseases
page.

3. Select the criteria for filtering.

When you are in Plant Filter mode, each icon
and scale represents a specific plant criterion.
As soon as you click on an icon or move a
slider, filtering begins. To deselect an icon,
click on it again. 

Note: If some of the icons disappear, it is
because no such plant is selectable within
the current criteria. For example, if you
select minimal water, the climber plant
type icon will disappear because there are
no climbing plants that will accept minimal
watering.

If you select more than one icon within a
single group, then all plants with any of the
checked properties will be selected. For
example, selecting maximum light and
medium light will exclude all plants that
flourish under minimal light (shade)
conditions. If icons/sliders of more than one
type are checked/moved, then plants that
satisfy all the chosen criteria will be selected.
For example, if you click on the deciduous

tree icon in the Type box, the full sun icon in
the Lighting Preference box, and the white
square on the Color box, then only hardwood
trees that flourish in full sunlight, require
minimal watering, and produce white flowers
will be selected.

4. The total number of plants available — based
on the filters you have applied — is indicated
on the leaf in the upper right corner of the
window. If at any time you want to restore
the complete list of plants, click Reset.

NOTE: This ability is not available for 3D plants. Only
billboard plants have this option.

Inserting Plants from the Encyc-
lopedia
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Plant Encyclopedia contains more than 7500 plant
species, not all of which are included in the catalog.
You can insert a plant directly from the Encyclopedia
if you want.
To insert a plant from the Encyclopedia:
1. Select Insert > Landscape > Gardening >

Plant Encyclopedia, or click on the
Landscape toolbar.

2. In the Plant Encyclopedia, locate and select
the plant you want to insert. To select a plant
in the plant list, use the scrollbar beside the
plant list to scroll through the list of plants,
then click on the plant you want to view. By
default, common plant names are listed in the
plant list. You can switch to Latin names by
clicking the Latin button.
If you know the name of the plant you are
looking for, you can locate it more quickly by
typing the first few letters of the plant’s name
in the Search edit field above the plant list.
The list of plants will move to the closest
match as you type.
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3. Click the Select button. The Encyclopedia
closes, and the plant is attached to your
cursor.

4. Insert the plant in your plan.

5. Right-click and select Finish.

Adding Plants to the Catalog
from the Encyclopedia
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Although the catalog contains a vast array of plants
for you to insert, it does not contain all the plants
listed in the Plant Encyclopedia.

You can add any plant from the Plant Encyclopedia to
any catalog by following the steps below.
To add a plant from the encyclopedia to the
current catalog:
1. Select File > Catalogs > Element Manager.
2. In the Element Manager dialog, select or cre-

ate the group you want to add the plant to.

3. Select Edit > Add Element.
4. In the Plants dialog, select the Plant Info tab.
5. Click the Encyclopedia button to launch the

Plant Encyclopedia.

6. On the Encyclopedia’s main page, select the
desired plant in the plant list.

7. Click Select. Notice that the Plant Info page
of the Plants dialog is now full with the selec-
ted plant’s information.

8. In the Name edit box, specify a name for
your plant.

9. Specify the remaining properties (Size, Quant-
ity or Behavior) if desired, then click OK in
the Plants dialog. Note that the settings on
the Appearance page have no effect on the
plant’s appearance. The appearance of a plant
is determined by settings in the Encyclopedia.

10. Click OK in the Element Manager dialog.
The plant is added to your catalog.

Inserting Irrigation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a wide selection of pop-up
sprinklers with varying ranges of spray. You insert a
sprinkler by simply pointing and clicking with your
mouse. When you insert a sprinkler, the coverage of
the spray is outlined with a dashed line.
To insert pop-up sprinklers:
1. Select Insert > Landscape > Irrigation, or

click on the Landscape toolbar.

2. In the catalog, select the sprinkler you want
to insert.

3. Position the sprinkler where you want it, then
click to insert it. You can continue inserting
more sprinklers if you want.

4. Right-click and select Finish.

Editing a Sprinkler's Spray Prop-
erties
You can edit the distance covered by a sprinkler’s
spray, as well as the spray pattern line style.
To edit a sprinkler’s spray properties:
1. Select the sprinkler.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To edit the spray distance, edit the size values
on the Basic property page. For most sprink-
lers you would edit the Width and Depth val-
ues. The Adjustable sprinkler in the catalog
lets you specify a custom radius and included
angle for the spray.

4. To edit the line style of the spray pattern,
select the Appearance tab, then select Spray
Pattern in the left pane. Click the Select but-
ton in the Linestyle area to select a different
line style.

5. Click OK.

Creating Fills
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Fills tool to define an area filled with
soil, sand, gravel, concrete, bark or water. You define
the area by picking points to draw its outline. Filled
areas automatically hug the terrain they are inserted
on.
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To create a filled area:
1. Select Insert > Landscape > Fills, or click

on the Landscape toolbar.

2. In the catalog, select your fill material.

3. Select a start point for your filled area.

4. Continue selecting points to define the bound-
ary of the filled area. Note that the last point
picked always closes back to the start point,
so you don’t have to pick the start point
again.

5. Right-click and select Finish.

Note: You cannot insert a fill on top of another fill.

Resizing a Filled Area
You can resize a filled area by stretching one of its
edges.
To resize a filled area by stretching it:
1. Click on the filled area to select it.

2. Click on the edge you want to stretch.

3. Hover your pointer over the solid blue grip
to display the Move cursor. Alternatively
you can select the Move Edge tool on the
right-click menu.

4. Click and drag to stretch the fill.

5. Release your mouse button.

Reshaping a Filled Area
You can change the shape of a filled area by
stretching its corners. You can do this by clicking and
dragging its grips.
To reshape a filled area by stretching:
1. Click on the filled area to select it. A grab

handle is displayed at each corner.

2. Click and drag a corner grip to stretch the
filled area.

3. Release your mouse button.

Curving a Filled Area
You can curve the edge of a fill using the Curve tool.
Once the tool is active, you can click and drag the
edge to curve it, or select a point to curve to.
To curve a fill edge by clicking and dragging:
1. Click on the fill edge that you want to curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Click and drag the fill edge to the desired
curve.

4. Release your mouse button.
To curve a fill edge to a selected point:
1. Click on the fill edge you want to curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Select the point you want to curve to. The fill
edge automatically curves to the point.

4. Click to finish.

Inserting Edging
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Edging can be an attractive accent around gardens,
ponds, sidewalks, driveways, and other areas. It can
also help retain fill materials and keep weeds out of
your garden. You can choose from PVC lawn edging,
wood posts, or rails. You insert edging by simply
picking points to define the end points and direction
of the edging.
To insert edging:
1. Select Insert > Landscape > Edging, or click

on the Landscape toolbar.

2. In the catalog, select your edging material.

3. Select a start point for the edging.

4. Move your cursor in the direction you want
the edging to run, then select an endpoint for
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the edging. You can continue selecting points
in any direction to add more sections to the
edging if you want.

5. Right-click and select Finish.

Tip: You can also insert decorative borders around
a garden. See Inserting Exterior Accessories on page
220.

Cleaning Up the Corners of
Edging
If you edged around an area with posts or rails, you’ll
notice that the edging members connect on center at
the corners. You may want to lengthen the members
to form completely flush intersections.

To clean up the corners of edging:
1. Click on one of the edging members. Blue

grab handles are displayed at the ends of the
member.

2. Hover your pointer over the end grip to dis-
play the Lengthen cursor.

3. Click and drag the edging so that it meets up
with the outside of the member it is
connected to, then release your mouse button.

4. Select the other member.

5. Click and drag the end so that it meets up
with the inside edge of the connecting
member, then release your mouse button.

Changing the Length of Edging
You can lengthen or shorten edging by clicking and
dragging its end points.
To change the length of edging:
1. Select the edging you want to lengthen or

shorten. Grips are displayed at the center and
ends of the edging.

2. Hover your pointer over the end you want to
stretch. The Lengthen cursor is displayed.

3. Click and drag to lengthen or shorten the
edging, then release your mouse button.

Breaking Edging
When you create a break in edging, you can select
and edit the portions on either side of the break
independently.
To create a break in edging:
1. Select the edging you want to break.

2. Right-click and select Break, or select Edit >
Modify Elements > Break.

3. Click where you want to break the edging.

Editing the Height and Width of
Edging
You can edit the height or width (thickness) of edging
on the edging’s Basic property page.
To edit the height or width of edging:
1. Click on the edging to select it. Use

Shift+click to select multiple segments if
necessary.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To edit the height of the edging, change the
value in the Edge Height edit box.

4. To edit the width (thickness) of the edging,
change the value in the Edge Width edit box.
Note that this variable is not available for
PVC edging.

5. If the edging is post edging, you can control
the spacing between posts by editing the
value in the Approx. Edge Spacing edit box.

6. Click OK.

Inserting a Fence
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To insert a fence, you draw it just like a wall by
selecting a start point and end point. This allows you
to create a fence of any length. You can continue
selecting points in other directions to add on to the
fencing (if you want to fence around your yard, for
example).
To insert a fence:
1. Select Insert > Landscape > Fences/Gates >

Fences, or click on the Landscape
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toolbar.

2. In the catalog, select the fence type you want
to insert.

3. Select a start point for the fence.

4. Move your cursor in the direction you want
the fence to run. The fence stretches as you
move your cursor.

5. Select an end point for the fence. If you want
you can continue adding sections to the fence
in any direction by simply selecting points.

6. Right-click and select Finish.

Tip: If you have inserted a site boundary in your
plan, you can draw your fence on top of the lot
lines for ease. The fence then acts as a visual
indicator of your property extents in 3D.

Stretching a Fence Layout
You can stretch a fence layout by clicking and
dragging one of the fence segments.
To stretch a fence layout:
1. Click on the fence segment you want to

move.

2. Position your pointer over the center blue
grip to display the Move cursor.

3. Click and drag to stretch the layout, then
release your mouse button.

Changing the Length of a Fence
You can lengthen or shorten a fence by clicking and
dragging its end points.
To change the length of a fence:
1. Select the fence you want to lengthen or

shorten.

2. Position your cursor over the fence end that
you want to stretch. The Lengthen cursor is
displayed.

3. Click and drag to lengthen or shorten the
fence, then release your mouse button.

Creating a Break in a Fence
When you create a break in a fence, you can select the
fence portions on either side of the break
independently. You may want to insert one or more

breaks in a fence so that you can then remove certain
segments of it.
To create a break in a fence:
1. Select the fence you want to break.

2. Right-click and select Break, or select Edit >
Modify Elements > Break.

3. Click where you want to break the fence.

Parts of a Fence

Editing the Properties of a
Fence
You can change the height of a fence, specify whether
or not you want the fence to hug the terrain, edit the
size and position of fence posts, and edit the
dimensions of the rails and boards.
To edit the properties of a fence:
1. Click on the fence to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To change the type of fence, click on the
appropriate graphic in the Type area. Choose
from General, Privacy, Picket or Ranch. The
General style just inserts a plain, flat surface.

4. To change the height of the fence, edit the val-
ues in the Fence Height edit box.

5. If you want the bottom of the fence to hug
the terrain, check the Hug Terrain? check
box, then select either Raked or Stepped from
the Slope Type drop box.

6. To change the dimensions or position of the
fence posts, edit the post parameters in the
Posts area.
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Secondary Post Position. Choosing Centered
starts the spacing of intermediate posts from
the middle of the fence to create a balanced
look. Choosing From Start starts the spacing
of intermediate posts from the first main post. 

Max. Post Spacing. The maximum allowable
spacing between posts. If you stretch the
fence, the spacing between posts increases.
More posts are added to prevent the spacing
from exceeding the maximum.

Post Width. The width (and depth) of fence
posts.

Post Extension. The distance the fence posts
extend past the top of the fence boards.

Post Rotation. Determines the rotation of the
connecting post where two fence segments
connect. Choosing Half Way rotates the
connecting post half way between the angle.
Choosing None leaves the connecting post
aligned to the first fence.

7. To change the dimensions of the top, middle
or bottom rail, edit the rail parameters in the
Rails area.

Rail Width. The width of the rail members. 
Rail Depth. The thickness of the rail
members.

Top Rail Height. The distance from the
bottom of the fence to the top rail.

Middle Rail Height. The distance from the
top rail to the middle rail.

Bottom Rail Height. The distance from the
middle rail to the bottom rail.

8. To change the dimensions of the boards in a
privacy or picket fence, edit the board
parameters in the Boards area.

Board Style. Choose either Squared or
Pointed. You would typically see pointed
boards on a picket fence. 

Board Width. The width of one fence board.
Board Depth. The thickness of one fence
board.

Board Spacing. The distance from the center
of one board to the center of the next board.

Board Offset. The offset of the bottom of the
fence boards from the ground.

9. When you’re done editing properties, click
OK.

Inserting a Gate
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The catalog contains a variety of gate types, including
wood, picket and ranch style gates. Gates just pop
themselves right into fences. Naturally, if you are
inserting a gate in a fence, you want to choose a gate
size that corresponds to the fence size. For example, if
your fence is a 6’ wood privacy fence, you would
likely choose the 6’ wood privacy gate. Gates are
shown slightly open so you can identify them easily
in 2D and 3D views.
To insert a gate:
1. Select Insert > Landscape > Fences/Gates >

Gates, or click the down arrow next to the
Fences button on the Landscape toolbar
and select Gates.

2. In the catalog, select the gate you want to
insert.

3. Position the gate where you want it, then
click to insert it. The gate will automatically
pop itself into the fence when you position it
in the fence.

4. Right-click and select Finish.

Flipping a Gate
You can use the Flip Opening tool to flip an entire
gate around. If the gate originally opened out, it now
opens in; if it was hinged on the left, it is now hinged
on the right (and vice versa).
To flip a gate:
1. Click the gate to select it.

2. Right-click in the drawing area and select
Flip Opening, or select Edit > Modify Ele-
ments > Flip Opening.
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Flipping a Gate's Swing
Use the Flip Swing tool to flip only the swing of a
gate. The gate will be hinged on the opposite side, but
it will still open in the same direction, either in or out.
To flip a gate swing:
1. Click the gate to select it.

2. Right-click in the drawing area and select
Flip Swing, or select Edit > Modify Elements
> Flip Swing.

Editing the Properties of a Gate
You can change the height and width of a gate as well
as the dimensions of the rails and boards. You can
also control how far the gate is open in 2D and 3D
views.
To edit the properties of a gate:
1. Click on the gate to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. To change the type of gate, click on the appro-
priate graphic in the Type area. Choose from
General, Privacy, Picket or Ranch. The Gen-
eral style just inserts a plain, flat door.

4. To change the overall size of the gate, edit the
values in the Gate Width and Gate Height
edit boxes.

5. To change the swing type, select either Left or
Right from the Swing Type drop box. This
determines which side the gate is hinged on.

6. If you want to change how far the gate is
open in 3D views, edit the percentage in the
3D Percent Open edit box. To change how
far the gate is open in 2D views, change the
percentage in the 2D Percent Open edit box.

7. To change the dimensions of the top, middle
or bottom rail, edit the rail parameters in the
Rails area.

Rail Width. The width of the rail members. 
Rail Depth. The thickness of the rail
members.

Top Rail Height. The distance from the
bottom of the gate to the top rail.

Middle Rail Height. The distance from the
top rail to the middle rail.

Bottom Rail Height. The distance from the
middle rail to the bottom rail.

8. To change the dimensions of the boards in a
privacy or picket fence, edit the board
parameters in the Boards area.

Board Style. Choose either Squared or
Pointed. You would typically see pointed
boards on a picket fence. 

Board Width. The width of one fence board.
Board Depth. The thickness of one fence
board.

Board Spacing. The distance from the center
of one board to the center of the next board.

Board Offset. The offset of the bottom of the
gate boards from the ground.

9. When you’re done editing properties, click
OK.

Building a Shed with the Shed
Builder Wizard
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Shed Builder Wizard will create a custom shed
for you in a few easy steps. All you need to do is
select a shed style, enter the desired dimensions, and
specify the door and window placement. You can
even select what materials you would like to use for
the roof, walls, floor, door and window.

Once you’ve inserted the shed in your plan, you can
further edit its individual components to achieve the
exact size and appearance you want.
To build a shed:
1. Select Insert > Design Wizards > Shed

Builder, or click the down arrow next to the
Design Wizards button on the Building
toolbar and select Shed Builder.
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2. On the Welcome screen, click Next.

3. On the next screen, click on the graphic that
most closely resembles the style of shed you
would like to build.

4. Enter the desired dimensions for the shed in
the Length and Width edit boxes.

5. Click Next.

6. On the Door and Window Configuration
screen, click on the door/window com-
bination that you would like for the front of
the shed. If you would like a window on the
left side of the shed, enable the Include Win-
dow on left side check box. If you would like
a window on the right side of the shed,
enable the Include Window on right side
check box.

7. Click Next.

8. On the Shed Elements screen you can select a
custom materials to use for the shed’s roof,
walls, floor, door and window. Just click the
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desired elements button, then make a
selection from the catalog. NOTE: For
Building Essentials and Construction Suite
products, the Floors option will allow for a
Structural Floor or a Floor Surface. If you
have defined your own shed configuration in
the Library Manager, you can simply select it
from the Shed Configuration drop box.

9. On the final screen, click Finish. The shed is
attached to your cursor, ready to be inserted.

10. Position the shed where you want it, then
click to insert it.

Tip: If you would like to insert a pre-made shed
from the catalog, use the Exterior Structures tool.
You can find sheds in the Storage and Enclosures
category of the catalog.

Editing a Shed
If you have created and inserted a shed with the Shed
Builder Wizard, you can edit its roof, walls, floor,
door and window individually. Just click on the
element you want to edit, then edit it as you would if
it were part of a house. For example, you can stretch
the walls to make the shed bigger or smaller, or select
a different window size.

Creating a Custom Shed Builder
Wizard Configuration
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A Shed Builder Wizard configuration determines
what elements are used for a shed’s roof, walls, floor,
door and window. You are asked to select a
configuration for your shed when you run the Shed
Builder Wizard.

You can edit any of the existing configurations that
are available in the Shed Builder Wizard, or create
your own. Customized configurations are saved
automatically and will be available when you run the
Shed Builder Wizard in the current project, or any
other project.
To access the shed configuration library:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager dialog, select Librar-
ies > Shed Configuration.

To add a new configuration to the list:
1. Select Edit > Add Configuration, or right-

click in the Shed Configuration window and
select Add Configuration. An entry named
‘New Configuration’ is added to the list.

2. Select the new configuration in the list. If you
want to rename it, select Edit > Rename Con-
figuration, or right-click and select Rename
Configuration. Then, type the new name and
press ENTER.

To edit a shed configuration:
1. Select the configuration in the list. The ele-

ment selections for the configuration are lis-
ted in the center pane.

2. In the center pane, select an element type you
want to specify a style for (e.g. Wall).

3. Click the Select button.
4. In the Catalog Access dialog, select the spe-

cific style you want to apply to the selected
element type, then click OK.

5. Continue selecting styles for the remaining
element types.

Structural_Floors.htm
Floors.htm


- 212 -

To delete a configuration from the list:
1. Select the configuration in the list.

2. Select Edit > Delete Configuration, or right-
click and select Delete Configuration, or
simply press the Delete key on your key-
board.

Building a Deck with the Deck
Builder Wizard
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Deck Builder Wizard takes all the work out of
building a deck because it does it all for you! Just
select the decking material and deck shape, enter the
dimensions you want, then point and click to insert
the deck. By default, decks include posts, beams and
railings.

After inserting a deck you can move, stretch, rotate,
raise or lower it if needed, as well as edit its
properties, which include settings for posts, railings
and skirting.
To build a deck using the Deck Builder Wizard:
1. In the Building Locations drop box, select the

location you want to associate the deck with.
The height of a deck is determined by the
Height above current location variable in
the deck properties. You can edit this value
after the deck has been inserted if necessary.

2. Select Insert > Design Wizards > Deck
Builder, or click the down arrow next to the
Design Wizards button on the Building
toolbar and select Deck Builder.

3. In the Deck Wizard dialog, click Next.

4. Select the decking material you would like to
use.

5. Click Next.
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6. In the Shape area, click on the shape that most
closely resembles the shape you want to cre-
ate. Remember that you can edit the shape
after the deck has been inserted.

7. In the Size area, specify the desired dimen-
sions for the deck.

8. Click Next.

9. In the Deck Rotation area, select the desired
rotation for your deck. This is how the deck
will be oriented when it is attached to your
cursor.

10. In the Decking Direction area, select the dir-
ection you want the deck boards to run.

11. Click Next.

12. Click Finish. The Deck Wizard closes, and
the deck is attached to your cursor, ready to
be inserted.

13. Position the deck where you want it, then
click to insert it.

Building a Deck with the Deck
Tool
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Deck tool to build a deck of virtually
any shape and size.

Once you’ve inserted a deck you can move, stretch,
rotate, raise or lower it if needed, as well as edit its
properties, which include settings for posts, railings
and skirting.
To create a deck:
1. In the Building Locations drop box, select the

location you want to associate the deck with.
The height of a deck is determined by the
Height above current location variable in
the deck properties. You can edit this value
after the deck has been inserted if necessary.

2. Select Insert > Landscape > Decks > Decks,
or click on the Landscape toolbar.

3. In the catalog, select the decking material you
want to use.
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4. Select a start point for the deck outline.
Continue selecting points until the outline is
defined. (You do not have to select the start
point again because the last point you pick is
always closed back to the start point.)

5. Right-click and select Finish.

Changing the Direction of Deck
Boards
You can use the Set Decking Direction tool to change
the direction of your deck boards.
To change the direction of deck boards:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Set Decking Direction,
or select Edit > Modify Elements > Set Deck-
ing Direction.

3. Select two points to define a line that runs in
the direction you want the deck boards to
run. The deck boards update to match the dir-
ection of the line.

Stretching a Deck
You can stretch a deck in any direction by clicking
and dragging one of its edges.
To stretch a deck:
1. Click on the deck edge you want to stretch.

2. Hover your pointer over the center blue grip
to display the Move cursor. Alternatively
you can select the Move Edge tool on the
right-click menu.

3. Click and drag to stretch the deck, then
release your mouse button.

If you would like to stretch only a portion of a deck
edge, you can accomplish this by adding a node to
the deck edge. See Adding a Node to a Deck on page
214.

Reshaping a Deck
You can change the shape of a deck by stretching any
of its corners.
To reshape a deck:
1. Click on the deck to select it. A grip is dis-

played at each corner.

2. Click and drag a corner grip to stretch the
deck. Alternatively you can select the Stretch
tool on the right-click menu.

3. Release your mouse button.

If you would like to stretch only a portion of a deck
edge, you can accomplish this by adding a node to
the deck edge. See Adding a Node to a Deck on page
214.

Adding a Node to a Deck
You can add nodes to a deck edge to create more
grips along the edge. You can then click and drag a
grip on a specific segment to reshape that portion of
the deck.
To add a node to a deck:
1. Select the deck.

2. Right-click and select Add Node, or select
Edit > Modify Elements > Add Node.

3. Click on the point on the deck edge where
you want to add a node. The edge is split into
separate edges, each with its own grips for
moving and stretching.

Changing the Height of a Deck
By default, decks are inserted at a height that is
relative to the current building location.
To change the height of a deck:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Support property page, edit the value
in the Height above current location edit
box.

4. Click OK.
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Editing Deck Post Properties
You can edit a deck's post type, post spacing and post
depth. You can also disable posts altogether if you
want.
To edit deck post properties:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Decks dialog, select the Support tab.
4. If you want to remove posts from the deck,

uncheck the Include Posts check box in the
Supports area.

5. To select a different member to use for deck
posts, click the Select button next to the
Include Posts edit box, then make your selec-
tion from the catalog.

6. To change the spacing between posts along
beams, edit the value in the Spacing along
Beam edit box.

7. To change the depth of the posts in the
ground, edit the value in the Depth below
ground level edit box. This effectively
changes the overall height of the post, but
does not affect the portion shown above
ground.

8. Click OK.

Editing Deck Footings
You can control the display of footings under your
deck by editing deck properties. You can also choose
the footing material you want to use.
To create footings under deck posts:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. On the Support property page, check the
Include Footings check box in the Supports
area.

4. Click the Select button next to the Include
Footings edit box, then select the desired
footing type from the catalog.

5. Click OK.

Editing the Deck Frame
You have complete control over the way a deck is
constructed. You can specify the way you want the
beams constructed in relation to the posts. You can
also select specific materials to use for deck boards,
beams and joists, as well as edit the spacing and
overhang of these members.
To edit the deck frame:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Decks dialog, select the Frame tab.
4. To change the way the beams are con-

structed, click on the desired configuration in
the Construction area. Beams are the vertical
members that rest on or are attached to the
posts, and that support the deck joists.

5. To select a different material for the deck
boards, click the Select button in the Decking
area, then make your selection from the cata-
log.

6. To edit the spacing between deck boards, edit
the value in the Spacing edit box in the Deck-
ing area.

7. To change the amount the deck boards hang
over the deck frame, edit the value in the
Overhang edit box in the Decking area.

8. To adjust the angle of the deck boards in rela-
tion to the joists, edit the value in the Angle
from Joists edit box.

9. To select a different material for the deck
joists, click the Select button in the Joists
area, then make your selection from the cata-
log.

10. To edit the spacing between joists, edit the
value in the Spacing edit box in the Joists
area.

11. To change the amount the joists hang over
the beams, edit the value in the Overhang
edit box in the Joists area. The general rule of
thumb is to limit the extension to 1/3 of their
length.
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12. To select a different material for the deck
beams, click the Select button in the Beams
area, then make your selection from the cata-
log.

13. To change the amount the beams extend past
each other, edit the value in the Overhang
edit box in the Beams area.

14. Once you’ve specified the deck frame prop-
erties, click OK.

Controlling the Display of Deck
Railings
By default, ground-level and low-level decks do not
have railings turned on, while raised-level and
second-story decks do. You can control the display of
railings for each side of a deck.
To control the display of deck railings:
1. Select the deck.

2. Click on the edge properties grip (red circle)
on the deck edge you want to define.

3. To display a railing on the selected deck
edge, enable the Railing check box. If you do
not want to display a railing on the deck
edge, clear the Railing check box.

4. If you want to display railings on all deck
edges, enable the Apply to all edges check
box.

5. Click OK.

Note: If you add stairs to your deck, an opening
will be automatically created in the railing.

Changing the Style of a Deck
Railing
You can change a deck’s railing type by making a
selection on the Accessories property page.
To change a deck’s railing style:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Decks dialog, select the Accessories
tab.

4. In the Railings area, click the Select button.

5. Select the desired railing type from the cata-
log.

6. Click OK.

Controlling the Display of Deck
Skirting
Skirting is basically screening such as lattice along the
bottom of a deck that conceals the underside of the
deck frame. It can also keep out animals and debris.
Most decks do not display skirting by default. You
can control the display of skirting for each deck edge.
To control the display of skirting on your deck:
1. Select the deck by clicking on one of its

edges.

2. Click on the edge properties grip (red circle)
on the deck edge you want to define.

3. To display skirting on the selected deck edge,
enable the Skirting check box. If you do not
want to display skirting on the deck edge,
clear the Skirting check box.

4. If you want to display skirting on all deck
edges, enable the Apply to all edges check
box.

5. Click OK.

Changing the Skirting Material
on a Deck
You can change a deck’s skirting material by making
a selection on the Accessories property page.
To change a deck’s skirting material:
1. Select the deck.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Decks dialog, select the Accessories
tab.

4. In the Skirting area, click the Select button.
5. Select the desired skirting material from the

catalog.

6. Click OK.

Inserting an Opening in a Deck
Once you have created a deck, you can insert a
custom opening in it of virtually any shape and size
using the Cut Opening tool.
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You create the opening by picking points to define its
outline.
To insert an opening in a deck:
1. Select the deck by clicking on one of its

edges.

2. Right-click and select Cut Opening, or select
Edit > Modify Elements > Cut Opening.

3. Select a start point for the opening.

4. Continue selecting points to define the open-
ing. As you select points, the opening is cre-
ated. The last point picked is always
connected back to the start point to form a
closed shape, so you don’t have to pick the
start point again.

5. When you have selected your final point,
right-click and select Finish.

Resizing a Deck Opening
You can resize a deck opening by clicking and
dragging one of its edges.
To stretch a deck opening:
1. Select the deck.

2. Hover your pointer over the center blue grip
of the edge that you want to move. This dis-
plays the Move cursor. Alternatively you
can select the Move Edge tool from the right-
click menu.

3. Click and drag in the direction you want to
stretch, then release your mouse button.

Reshaping a Deck Opening
You can change the shape of a deck opening by
stretching its corners. You can do this by clicking and
dragging.
To reshape a deck opening by stretching:
1. Select the deck.

2. Click and drag the corners of the opening to
stretch it, then release your mouse button.
Alternatively you can select the Stretch tool
from the right-click menu.

Removing Deck Openings
You can delete an opening from a deck using the
Remove Opening tool.

Note: You cannot remove an opening using Delete.

To remove a deck opening:
1. Click on the edge of the deck or opening to

select the deck.

2. Right-click and select Remove Opening, or
select Edit > Modify Elements > Remove
Opening.

3. Click on the edge of the opening. The open-
ing is removed.

Adding Stairs to a Deck
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add a staircase to your deck with a single
mouse click. Stairs automatically snap to your deck
for easy insertion, and the railings on the deck are
automatically removed to allow for the stair opening.
By default, stairs extend from the deck platform down
to the terrain, so there’s absolutely nothing you need
to calculate. Also, deck stairs have a railing on both
sides by default, but you can remove one or both of
them if you want after the stairs have been inserted.

You can choose either pressure treated or cedar stairs,
and edit the stair dimensions to get the exact result
you want.
To add stairs to a deck:
1. Select Insert > Landscape > Decks > Deck

Stairs, or click the down arrow next to the
Decks button on the Landscape toolbar
and select Deck Stairs.

2. In the catalog, select the type of stairs you
would like to insert.

3. Move your pointer close to the deck edge.
Position the stairs where you want them, then
click to insert them.

4. Right-click and select Finish.

Editing the Size of Deck Stairs
You can edit the overall height and width of deck
stairs, the width of the steps, and the riser height.
To edit the size of deck stairs:
1. Click on the staircase to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.
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3. Edit the properties on the Basic tab.

Extend Stair. The option selected determines
where the base of the stairs sit. You can either
change where they extend to, or specify an
explicit height. By default, the deck stairs are
inserted at deck level and run down to the
terrain. 

Down to terrain. Extends the stairs down to
the ground.

Down to previous location. Extends the
stairs to the floor level of the building
location below the current one.

Down to deck location. Extends the stairs
down to the floor level of the building
location the deck is associated with. You
might use this if you have raised your deck
above the floor level of the current location
and want to extend the stairs down.

Explicit Height. Extends the stairs down a
specific distance that you define in the
Overall Height edit box.

Overall Height. Available only if Explicit
Height is selected in the Extend Stair drop
box, this lets you define a fixed height for the
stairs.

Max. Riser Height. The maximum distance
allowed between individual steps. Note that
if your riser height exceeds the width of the
member you are using for your riser boards,
two or more boards will be inserted for each
riser.

Tread Run. The width of each step. The
width of a step is measured from the nose of
the step to the riser of the next step. Note that
if your tread run exceeds the width of the
member you are using for your treads, two or
more boards will be inserted for each step.

Overall Width. The width of the stairs
measured from one end of a step to the other
end of the step.

4. Click OK.

Controlling the Display of Rail-
ings on Deck Stairs
By default, deck stairs have a railing on both sides.
You can choose to have a railing on the left side only
or right side only, or remove them altogether.
To control the display of railings on deck stairs:
1. Click on the staircase to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Railings area, uncheck the Include Rail-
ings check box if you don’t want any railings
on your deck stairs. If you want one or more
railings on the stairs, leave this check box
enabled.

4. If you want a railing on the left side of the
stairs, select Railing on left side from the
drop box. If you want a railing on the right
side of the stairs, select Railing on right side
from the drop box. If you want a railing on
both sides of the stairs, select Railing on both
sides.

5. Click OK.

Editing Stringers, Treads and
Risers on Deck Stairs
You can specify detailed settings for the stringers,
risers and treads on your deck stairs.
To edit stringer, riser or tread details:
1. Click on the staircase to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Deck Stairs dialog, select the Details
tab.

4. To change the stringer style, click the appro-
priate graphic in the Stringer area. Choose
from Notched, Under or Side.

5. Edit the remaining properties as desired.
Stringer
Spacing. The spacing between the outside
stringers and intermediate stringers.

Height. The distance from the bottom of the
stringer to the underside of the tread/riser
intersection. Specifying a stringer height that
is the same as the overall height of the
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staircase creates a staircase that is completely
closed on the sides. In other words, the
stringers go right to the ground.

Width. The thickness of the stringer members.
Riser

Closed Riser. Inserts riser boards under the
steps. If you leave this disabled, the staircase
will be open under the treads.

Select. Click this button to select a riser
board to use.

Spacing. When the riser comprises two or
more boards, this is the spacing between the
boards.

Angle. The tilt of the riser boards. A value of
0 means the board is perpendicular to the
step (straight up and down). A value above 0
tilts the riser down toward the back of the
staircase. The maximum angle allowed is 20º.

Tread

Select. Click this button to select the type of
wood to use for your steps.

Spacing. When each step comprises two or
more boards, this is the spacing between
those boards.

Nosing. The distance the step extends past
the riser.

Overhang. The distance the ends of the steps
extend past the outer stringers.

6. Click OK.

Inserting Exterior Structures
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert a wide variety of exterior structures to
make your outdoor living space more functional.
These include play gyms, swings, sandboxes,

trampolines, tennis and volleyball courts, detached
garages, sheds, gazebos, arbors, garden boxes,
greenhouses, pools and hot tubs.All structures are
inserted with a single mouse click and can be easily
moved, rotated and edited.
To insert an exterior structure:
1. Select Insert > Landscape > Exterior Struc-

tures, or click on the Landscape toolbar.

2. In the catalog, select the structure you want
to insert.

3. Position the structure where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting a House Template
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A house template is basically the exterior shell of a
finished home. If you are creating a landscape plan
and your project does not contain a model, you can
insert a house template to serve as the focal point of
your plan.
To insert a house template:
1. Select Insert > Landscape > Exterior Struc-

tures, or click on the Landscape toolbar.

2. In the catalog, select the House Templates
group, then select the desired house template.

3. Position the template where you want it, then
click to insert it.

4. Right-click and select Finish.
Although a house template looks like a real house, it
can’t be edited like a real model can. It is considered a
single-click element, so clicking on any part of the
template selects the entire house.

It is important to note that when you select the house
template, the invisible bounding box is always square
or rectangular, and does not necessarily follow the
shape of the house outline. This can interfere with the
selection of other elements near the house. If you have
inserted elements around the house, such as plants,
and want to select them, you may want to use the
View Filter to make the house template non-selectable
for ease of editing your landscape plan.
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Another thing to note is that the house template’s
exterior walls are not visible in 2D. You only see the
roof line. If you want to insert things like fills up
against the exterior walls of the house, you will need
to either draw them in 3D, or draw them in 2D and
then move them into place in 3D.

Inserting Exterior Furniture
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can insert patio tables, patio chairs, picnic tables,
loungers and benches with a single mouse click.
When inserting exterior furniture, you have the
option of inserting it on the terrain, or on a building
location.
To insert exterior furniture:
1. Select Insert > Landscape > Exterior

Furniture, or click the down arrow next to
the Exterior Furniture button on the
Landscape toolbar. Then, select either Exter-
ior Furniture on Terrain or Exterior
Furniture on Location, depending on where
you want to insert the element. The Exterior
Furniture on Location option lets you insert
the element on a deck, or on anything that is
associated with a building location.

2. In the catalog, select the element you want to
insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting Exterior Accessories
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Exterior accessories include everything from bird
baths to weather vanes. Inserting exterior accessories

is easy — just point and click. You can insert exterior
accessories on the terrain, or on a building location.
To insert an exterior accessory:
1. Select Insert > Landscape > Exterior

Accessories, or click the down arrow next to
the Exterior Accessories button on the
Landscape toolbar. Then, select either Exter-
ior Accessories on Terrain or Exterior
Accessories on Location. The 'on Location'
option lets you insert the element on a deck,
or on anything that is associated with a build-
ing location.

2. In the catalog, select the accessory you want
to insert.

3. Position the element where you want it, then
click to insert it.

4. Right-click and select Finish.

Inserting Exterior Lighting
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Inserting exterior light posts and ground lighting is
easy — just point and click.
To insert an exterior light fixture:
1. Select Insert > Landscape > Exterior Light-

ing, or click the down arrow next to the Exter-
ior Lighting button on the Landscape
toolbar. Then, select either Exterior Lighting
on Terrain or Exterior Lighting on Location,
depending on where you want to insert the
element. The Exterior Lighting on Location
option lets you insert the element on a deck,
or on anything that is associated with a build-
ing location.

2. In the catalog, select the light you want to
insert.

3. Position the light where you want it, then
click to insert it.

4. Right-click and select Finish.

Tip: If you switch to Rendered or Rendered Outline
display mode, you can see instant lighting effects
as you position and insert light fixtures.

Displaying_a_Rendered_View.htm
Displaying_a_Rendered_Outline_View.htm
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When you double-click after inserting an element or select Finish from the right-click menu, you automatically go
into Selection Mode, meaning you can select elements in your drawing area and edit them. Most elements can be
moved, rotated, copied, replaced and deleted. Some elements have additional editing commands available. For
example, you can lengthen, break and curve walls. All elements have a property sheet where you can change the
size or appearance of the element.

To access a menu of editing commands for a selected element, just right-click in the drawing area or select Edit >
Modify Elements. Certain functions can be performed without selecting any commands at all. For example, you can
move and rotate most elements by simply clicking and dragging your mouse.

This chapter describes how to select elements, and use general editing commands like Move, Rotate, Elevate,
Duplicate, Replace and Delete. It also describes how to access and edit element properties. For information about
editing a specific type of element, see the chapter about that element.

Undoing the Previous Action
The Undo tool cancels your most recent action. You can undo as many actions as you have taken since your last
save.
To undo an action:
l Select Edit > Undo, or
l Click on the Standard toolbar, or
l Press Ctrl+Z

Tip: You can use the Redo tool to reapply an action you have canceled using the Undo tool.

Redoing an Undo
The Redo tool reapplies a tool that you have reversed using Undo. Redo will only work directly following an Undo.
To redo a task:
l Select Edit > Redo, or
l Click on the Standard toolbar, or
l Press Ctrl+Y

Moving Elements
When you select an element in Model View, you are automatically in Drag and Drop mode. If the element is a
singular, one-click object, like a cabinet or plant, you can move the element by simply clicking and dragging it. If
you want to move an area-drawn element, such as a roof or floor, you need to select the Move tool before clicking
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and dragging. Otherwise, doing a straight drag-and-
drop will only stretch it. If you click and drag a wall,
all walls attached to it move with it.

If you have your Commander turned on and would
like to be able to enter precise values for the move,
you need to select the Move tool instead of doing a
straight drag-and-drop.

Note: Elements associated with walls, such as
doors and windows, can only be moved within the
wall they are in. You cannot move them to another
wall.

To move an element using drag-and-drop:
1. Select the element you want to move. You are

now in Drag and Drop mode.

2. Hover your pointer over the element’s center
grip to display the Move cursor.

3. Click and drag to move the element.

4. When the element is where you want it,
release the mouse button.

To move an element using the Move tool:
1. Select the element you want to move.

2. Right-click and select Move, or select Edit >
Modify Elements > Move.

3. Select a base point for the move. The move
distance and direction will be measured from
this point.

4. Without holding your mouse button down,
move your mouse to move the element. Select
the point you want to move the element to, or
enter a distance and direction in the Com-
mander.

Tip: You can nudge an element slightly using the
arrow keys on your keyboard.

Nudging Elements
You can nudge an element or object slightly using the
arrow keys on your keyboard. By default, the element
is nudged 1” (or 25mm). You can change the nudge
distance in your program settings before nudging if
you like.

For an additional level of control, a secondary nudge
distance is also available in your program settings. By
default it is set to 1'-0" (or 300mm). This distance is

used if you press and hold down the CTRL key while
using the arrow keys.
To nudge an element:
1. Select the element that you want to nudge.

2. Use the arrows on your keyboard to nudge
the element up, down, left or right. This uses
the primary nudge distance defined in your
program settings.

To nudge an element using the CTRL key:
1. Select the element that you want to nudge.

2. Press and hold down the CTRL key on your
keyboard.

3. While holding down the CTRL key, use the
arrows on your keyboard to nudge the ele-
ment up, down, left or right. This uses the sec-
ondary nudge distance defined in your
program settings.

Editing Nudge Distances
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, an element is moved 1” (25mm) when you
nudge it using your arrow keys. If you hold down the
CTRL key while using the arrow keys, a secondary
nudge distance of 1'-0" (305mm) is used. You can edit
both of these nudge distances in your program
settings.
To edit nudge distances:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Draw-
ing Aids in the left column.

3. To edit the primary nudge distance (when
using only your arrow keys to nudge), edit
the value in the Normal edit box in the Nudge
Distance area.

4. To edit the secondary nudge distance (when
using the CTRL key in conjunction with the
arrow keys), edit the value in the With CTRL
key edit box.

5. Click OK.
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Raising and Lowering Elements
Most elements can be raised or lowered using the
Elevate tool on the element’s right-click menu. Some
elements, such as roofs, do not provide access to the
Elevate tool. In the case of a roof, you can raise or
lower it by changing the Support Height variable in
its properties.

Many block elements (like furniture and plants) also
have a Distance above current location or terrain variable
in their properties that you can use to raise or lower
the element. Walls have a Drop Exterior Face variable,
and columns have a Base Offset variable in their
properties that you can edit.
To raise or lower an element using the Elevate
tool:
1. Select the element that you want to raise or

lower.

2. Right-click and select Elevate, or select Edit >
Modify Elements > Elevate. The value
shown in the Elevate dialog is the current
elevation of the element above the floor level
or terrain.

3. In the Elevate dialog, specify the desired elev-
ation of the element above the floor. If the ele-
ment is a landscaping element, the value you
specify is relative to the terrain. The distance
you enter is the distance from the floor or ter-
rain to the insertion point of the element. For
most elements, the insertion point is at the
base of the element. For windows and wall
openings, however, the insertion point is at
the top of the element. Therefore, if you are
raising or lowering a window or wall open-
ing, specify the desired distance from the
floor to the top of the window or opening.

4. If you are in a 3D or elevation view and
would like to see what the element looks like
at the new elevation, click Apply. The Elevate
tool remains active while the change is
applied to the element in your model.

5. To apply the change to the element, click OK.
To raise or lower a block element by editing its
properties:

1. Select the element you want to raise or lower.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the properties dialog, select the Behavior
tab. If there is no Behavior tab, you will need
to use the Elevate tool to raise or lower the
element.

4. Edit the value in the Distance above current
location or terrain edit box.

5. Click OK.

Rotating Elements
Singular, one-click elements like cabinets and
furniture can be rotated on the spot by simply
clicking and dragging them while in Rotation mode.
Railings can be rotated by clicking and dragging their
end points. For most other elements such as walls,
floors, ceilings or roofs, you need to use the Rotate
tool. You also need to use the Rotate tool if you want
to be able to enter a precise rotation angle in the
Commander, or you want to rotate the element about
a point other than the center point of the element.

Doing a Simple, On-the-Spot Rotation
If you see a triangular grip on an element when it is
selected, it can be rotated by simply clicking and
dragging it. Using this method, the element is rotated
about its center point. If your Angle Snap is on, the
element will rotate in increments of whatever angle is
set for the Angle Snap. If the Angle Snap is off, the
element will rotate in increments of 1º.

To rotate an element by clicking and dragging:
1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip
to display the Rotate cursor.

Tip: If the triangular grip is in close proximity
to the square grab handle, you may want to
zoom in on the element to distinguish
between the two grips. If you do not see the
triangular grip, the element can only be
rotated with the Rotate tool.
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3. Click and drag to rotate the element.

4. When the element is at the desired rotation,
release your mouse button.

Using the Rotate Tool
Using the Rotate tool you can rotate an element about
any selected base point. You should also use the
Rotate tool if you want to be able to enter a precise
rotation angle in the Commander. If your Angle Snap
is on, the element will rotate in increments of
whatever angle is set for the Angle Snap. If you are
using the Commander, you can override the Angle
Snap by entering the desired angle in the
Commander. If the Angle Snap is off, the element will
rotate in increments of 1º.
To rotate an element using the Rotate tool:
1. Select the element to rotate.

2. Right-click and select Rotate, or select Edit >
Modify Elements > Rotate.

3. Select a base point for the rotation. The base
point can be any point on the element (e.g.
center point or corner point), or any point in
the drawing area. The point you pick estab-
lishes an automatic baseline that runs
through the point at 180°. You can rotate full-
circle around this baseline.

Tip: If you want to align an element with another
element that may be lying at an odd angle, select
a base point on the other element, then line up
your rotation line with that element.

4. Without holding your mouse button down,
move your mouse to rotate the element. The
element will rotate from the defined base
point in the direction you move the mouse. If
the Commander is turned on, you can view
the angle of rotation as you rotate, or enter a
precise angle. Positive angle values are read
in a counter-clockwise direction, while neg-
ative values are read in a clockwise direction.

Curving Elements
You can curve line-drawn elements such as walls, as
well as area-drawn elements such as floors.

If an element has the Curve tool on its right-click
menu, it can be curved. Once the Curve tool is active,
you can click and drag the edge to curve it, or select a
point to curve to. 
To curve an element by clicking and dragging:
1. Click on the element edge that you want to

curve.

2. Right-click and select Curve, or select Edit >
Modify Elements > Curve.

3. Click and drag the edge to the desired curve.

4. Release your mouse button.
To curve an element to a selected point:
1. Click on the ceiling edge you want to curve.

2. Right-click in and select Curve, or select Edit
> Modify Elements > Curve.

3. Select the point you want to curve to. The ceil-
ing edge automatically curves to the point.

4. Click to finish.

Note: For more precise curving, see Curving
Elements Using the Commander on page 402.

Copying Elements on the Same
Location
The Duplicate tool creates a copy of a selected
element that you can then position where you like on
the current location.
To duplicate an element in Model View:
1. Select the element to copy.

2. Right-click and select Duplicate, or select
Edit > Modify Elements > Duplicate.



Chapter 19: Editing Elements in Model View

- 225 -

3. Select a base point for the copy movement.
Typically you would select one of the ele-
ment's grips, but you can click anywhere in
the drawing. The base point is simply a ref-
erence point used to define the move dis-
tance.

4. Select the point you are copying the element
to. You can do this by moving your mouse
and then clicking to insert the copy, or by typ-
ing a distance and direction in the Com-
mander.

Copying Objects to Other Loca-
tions
The Duplicate to Locations tool lets you copy existing
elements and objects to other locations. This is useful
if the elements you have already drawn will have the
same layout on another location. For example, you
can copy the exterior walls on the Ground Floor to the
Second Floor and instantly create another story. You
can also use this tool to copy text, dimensions and
CAD objects to another location.

When you use the Duplicate to Locations tool you
have the option of deleting the original objects. This is
a great way to move objects from one location to
another if they are not on the correct location.
To copy objects to other locations:
1. Make sure the location you want to copy

objects FROM is current.

2. Select the objects that you want to copy.

3. Right-click and select Duplicate to
Locations.

4. In the Duplicate to Locations dialog, select
the target location(s) you want to copy the
objects to.

5. Click OK. You are asked if you want to delete
the original object.

6. If you want to delete the original objects, click
Yes. You would select this if you wanted to
move the objects instead of copying them. If
you want to leave the original objects on their
current location, click No. The objects are
copied.

Note: The location you are copying to must exist in
the Building Locations dialog.

Cutting and Pasting Elements
Use the Cut and Paste tools to remove an inserted
element and place it elsewhere in your drawing. Note
that you can cut an element from one location and
paste it on a different location.
To cut and paste an element in Model View:
1. Select the element to cut.

2. Right-click and select Cut, or select Edit >
Modify Elements > Cut. The element is tem-
porarily removed from the drawing.

3. Right-click and select Paste, or select Edit >
Modify Elements > Paste. The element is
attached to your cursor.

4. Position the element where you want it, then
click to insert it.

Arraying Elements
When you array elements, you create multiple copies
of an element at the same time. You can create an
array in a single row or column, or multiple rows and
columns. You can also control the spacing between
elements in the array, and the array's rotation angle.

Sample array of posts with 2 rows and 5 columns

To array an element in Model View:
1. Select the element you want to array.

2. Right-click and select Array, or select Edit >
Modify Elements > Array.

3. In the Number of Rows box, type the num-
ber of horizontal rows you want or use the
arrows to select a value.

4. In the Number of Columns box, type the
number of vertical columns you want.

5. In the Distance Between Rows box, type the
spacing you want between rows. This determ-
ines the distance between elements appearing
in columns (vertical spacing).
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6. In the Distance Between Columns box, type
the spacing you want between columns. This
determines the distance between elements
appearing in rows (horizontal spacing).

7. In the Array Rotation Angle box, type the
degree of rotation for the array.

8. Click OK. The array is created.

Note: The Array tool is only available for certain
elements.

Mirroring Elements
You can create a mirror image of selected elements
using the Mirror tool. You mirror the elements by
specifying a mirror line — an imaginary line about
which the elements are flipped. Once the element has
been mirrored, you can choose whether or not you
want to delete the original element.

Tip: You can use the Mirror tool to reverse an
entire floor plan.

To mirror elements in Model View:
1. Select the elements you want to mirror.

2. Right-click and select Mirror, or select Edit >
Modify Elements > Mirror.

3. Click two points to define a mirror line.

4. When prompted to choose whether or not
you want to delete the original object, click
Yes to delete the original object, or click No
to leave the original intact.

Replacing Elements
You can use the Replace tool to replace an element in
your drawing with a different item from the catalog.
To replace an element:

1. Select the element that you want to replace.

2. Right-click and select Replace, or select Edit
> Modify Elements > Replace.

3. In the Replace dialog, select the replacement
item.

You can use the Search feature to quickly
narrow down the element list according to a
specified keyword or part number. Click the
drop box in the Search area and select either
Description to search by keyword, or Part
No. to search by part number. An edit box
appears next to the drop box.

In the edit box, enter the keyword(s) or part
number to search for, then press Enter or

click . For keyword searches, the
search will display any match that contains
the specified text string, even if the string is
part of a word. Note that only elements of the
type that you are replacing are displayed.

Once search results are obtained they are
displayed in the catalog portion of the dialog.

To return the catalog to its default state,
where all elements are displayed, select
Show All from the Search drop box. Search
terms that you have used are saved in the
Search window for future use.

4. Once you have selected the replacement item,
click OK. The element is automatically
replaced.

Note: You can only replace an element with
another of the same type. For example, you can
replace a window with another window, but you
cannot replace a window with a door.

Applying Colors and Materials
with the Materials Paintbrush
The Materials Paintbrush is best used in 3D view and
the 2D Designer's Plan view. It lets you select a
material or color in the catalog, then apply it to
elements. When you use the Materials Paintbrush on
an element, the settings on the element’s Appearance
property page update to match the selections you
made with the Materials Paintbrush.
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To use the Materials Paintbrush:
1. Select Edit > Materials Paintbrush, or click

on any tabbed toolbar.

2. In the catalog panel, select the material you
want to apply. There is an incredible selection
to choose from, including Wood, Brick,
Marble, Concrete, Steel, Carpet, Tile, Roofing,
Paint, Fabric, and much more. You can filter
the material list according to specific
applications by making a selection from the
Filter drop box.

3. If you want to apply the material to all
instances of the element you select, enable the
Apply to All Similar check box. For example,
let's say your model's exterior walls are 2x6
Framed Masonry walls, and you want them
all to have horizontal siding instead. If you
enable the Apply to All Similar option, all
you have to do is click on one of the walls,
and all of the walls of the same type will
change simultaneously.

4. In 3D view, click on the element that you
want to apply the material to. The material is
immediately applied.

5. Right-click and select Finish.

Note: To undo the last application, right-click in
the drawing area and select Step Back.

Undoing a Material Application
If you have just used the Materials Paintbrush to
apply a material to an element, you can undo the
application using the Step Back tool.
To undo a material application:
1. With the Materials Paintbrush still active,

right-click in the drawing area and select
Step Back, or select Edit > Modify Elements
> Step Back.

You can continue stepping back to the point when the
Materials Paintbrush was first launched.

Note: You cannot undo a material application if
you have left the Materials Paintbrush mode.

Sampling Materials with the
Eyedropper
While the Materials Paintbrush is active you can use
the Eyedropper tool to identify a material applied to
an element in your drawing. Once you’ve clicked on
the element, the catalog panel updates to display the
material applied to the element. This eliminates
guesswork and allows you to identify a material that
you want to use again without having to search the
catalog.
To sample a material with the Eyedropper:
1. Activate the Materials Paintbrush tool.

2. In the catalog panel, click . Your cursor
becomes an eyedropper.

3. Click on the element whose material you
want to sample. The catalog updates to dis-
play the material applied to the element.

Note: The material will not be added to the
materials history list unless you apply it to an
element.

Viewing Recently Used Mater-
ials
When you use the Materials Paintbrush, a record is
kept of the materials you have used. You can view a
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list of the most recently used materials by selecting
the History tab in the catalog panel while the
Materials Paintbrush is active. If you want to use one
of the recently used materials, just select it in the
history list and proceed with applying in your
drawing.

Setting the Maximum Size for
the Material History List
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, when the Materials Paintbrush tool is
active, the History tab in the catalog panel displays a
maximum of 15 materials. You can change this setting
if you wish.
To change the maximum setting for the material
history list:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, enter the
desired maximum number of materials in the
Material history list edit box, or use the
arrows to scroll up or down through a list of
values.

3. Click OK.

Matching the Appearance of Ele-
ments
Use the Match Appearance tool to match the
appearance of selected elements with that of another
similar element. For example, if you have inserted a
cabinet in your drawing whose appearance you really
like, you can instantly change the appearance of all

other cabinets in the room (or model) to match the
appearance of that cabinet.
To match the appearance of elements:
1. Window around or cross through the ele-

ments that you want to edit. It does not mat-
ter if other element types are included in the
selection — only elements that are of the
same type as the primary element (the one
whose appearance you want to match) will
receive the changes. You can even cross
through the entire model if you want to
change the appearance of all similar elements
throughout the model.

2. Shift+click to select the primary element. This
is the element to which you want to match
the other elements.

3. Right-click and select Match Appearance.
The appearance of all selected elements that
are the same type as the primary element will
now match the appearance of the primary
element.

A dialog box confirms the number of
elements that were changed, and the number
of elements in the selection set that were
excluded from the appearance change
(because they are not of the same element
type).

Deleting Elements
You can delete an element from your drawing in two
quick steps.
To delete an element:
1. Select the element.

2. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.
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There are a variety of options for viewing your design in 2D and 3D. When you begin working, your design is
displayed as a 2D Plan. You can also use the 2D Designer’s Plan tool to instantly view a rendered version of your 2D
plan.

When working in 2D view, you can magnify or reduce the view using the Zoom In, Zoom Out or Zoom Realtime
tools. You can also magnify a selected area using the Zoom Window tool. The Zoom to Fit tool magnifies your
design so it fills the drawing area, creating the largest view possible. The Pan tool lets you pan the view in any
direction by simply clicking and dragging.

You can instantly switch to 3D view with a couple of mouse clicks. Using the 3D QuickView tool you can instantly
view your 3D design from a number of pre-set angles. Or you can choose one of the pre-defined 3D Cameras — 3D
Perspective or 3D Overview — as well as create new views to suit your needs.

While in a 3D view you can navigate through the scene using realtime navigation tools such as Walk Around, Fly
Around, and Look Around.

You can select 2D and 3D viewing and navigation tools from the View menu or from the View Control and Zoom &
Navigate toolbars below the drawing area. Most of these tools can also be found on the handy Navigator, which is
an all-in-one onscreen controller similar to a handheld video game controller.

Elevations are automatic — just select the one that you want to view, or create a custom one. You can create a
Section by defining a cut line through your model.

Using the Dynamic Cutaway tool you can dynamically strip away a portion of your 3D model so that you can see
inside it.

For a truly amazing experience you can try the Stereo Vision tool. Just slip on a pair of 3D glasses and watch every
detail of your 3D model pop out at you.

In 2D plan view, your drawing is displayed in Wireframe mode by default. In 3D view, it is displayed in Rendered
mode. You can switch to other display modes such as Hidden Line and Patterned at any time.

Using the Navigator
The Navigator is an onscreen controller that lets you switch between 2D and 3D, zoom and pan, and navigate in 3D.
Similar to a video game controller, it brings the most frequently used viewing and navigation tools together in one
place.
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To display a 2D plan view, click on the
Navigator.

To display a 3D camera view, click .

To display a 3D QuickView, click , then select the
desired view angle on the Navigator's center pad.

To zoom in realtime, click and then click and
drag on the Navigator's center pad. Drag upward to
zoom in, drag downward to zoom out.

To pan the view, click and then click and drag on
the Navigator's center pad in the direction that you
want to pan.

To walk around in a 3D camera view, click and
then click and drag on the Navigator's center pad in
the direction that you want to walk. For example, to
walk forward, click and drag upward.

To fly around the model, click and then click and
drag on the Navigator's center pad. The Fly Around
tool revolves the camera around the target in a 3D
view. Drag upward or downward to tilt the model
down or up, drag right to rotate the model in a
clockwise direction, or drag left to rotate it
counterclockwise.

To spin the view with the Look Around tool, click
and then click and drag on the Navigator's center

pad. The Look Around tool revolves the target
around the camera in a 3D Camera view. Drag left to
spin the model clockwise, drag right to spin it
counterclockwise. Drag up to lower the height and
shorten the distance of the target. Drag down to raise
the height and lengthen the distance of the target.

Note: The Walk Around, Fly Around and Look
Around tools are only available if the current view
is a 3D view. In a 3D QuickView, the only
navigation tool available is Fly Around.

Moving the Navigator
You can move the Navigator around on the screen by
clicking and dragging its move grip.

To move the Navigator:
1. Click and hold your mouse button over the

Navigator's grip.

2. While holding your mouse button down,
drag the Navigator to the desired location on
the screen.

3. Release your mouse button.

Turning the Navigator On or Off
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can turn the onscreen Navigator on or off as
needed through your program settings.
To turn the Navigator on or off:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Nav-
igation in the left pane.

3. In the right pane, enable or disable the
Enable check box in the Navigator Control
pane.

4. Click OK.

Viewing the 2D Plan
When you start a drawing, the default view is a 2D
plan view, which is a flat, overhead view. 2D plan
view is ideal for creating a floor plan.

move_navigator.tif
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To display your model in 2D plan view:
l Select View > 2D Plan, or
l Click on the View Control toolbar or on
the onscreen Navigator, or

l Right-click in the drawing area and select 2D
Plan, or

By default, all locations are visible at the same time.
However, any locations other than the current
location are dimmed. While in 2D plan view you can
zoom in and out, and pan your drawing.

Viewing a 2D Designer's Plan
By default, your design is displayed in a wireframe
2D plan view. You can use the 2D Designer's Plan
tool to quickly display a rendered version of the 2D
plan view. In a rendered view, materials are applied
to the elements and terrain, creating a more realistic
view. For example, if you have a shingled roof on
your model, you will actually see the shingles in 2D
Designer's Plan view.
To view a 2D Designer's Plan:
1. Select View > 2D Designer's Plan, or click

on the View Control toolbar.

Note: You can use the View Filter to hide elements
like the roof or ceilings so that you can see inside
the model.

Quick 3D Viewing
Using the 3D QuickView tool you can instantly view
your design in 3D by selecting a pre-defined view
angle. You can view your design from the front left,
rear left, front right or rear right corner. You can also
create an orthogonal elevation view by selecting a
front, rear, left or right view angle.

Each 3D QuickView is a parallel view, which means
distance is eliminated from the view. 3D views are
automatically displayed in rendered mode for optimal
effect.
To create a basic 3D view:

1. Select View > 3D QuickView, or click on
the View Control toolbar or the onscreen Nav-
igator.

2. In the 3D QuickView dialog (or in the Nav-
igator), click the button representing the

angle you want to view from. The corner
arrows represent the four available isometric
views, which let you view your design from
any corner at a 30º angle. Clicking the center
button creates a 2D rendered plan view.

Note: The 3D QuickView tool is designed for quick,
basic 3D viewing. These views are preset and do
not have cameras associated with them. Most
navigation tools are not available in a 3D
QuickView, except for Fly Around. For 3D views
that you can adjust, see Displaying 3D Camera Views
on page 231.

Displaying 3D Camera Views
A camera view is a 3D perspective view. In a
perspective view, the scale of an element decreases
according to its distance from the viewer, creating a
more real-world view.

Envisioneer offers two pre-defined camera views for
your convenience: 3D Perspective and 3D Overview.
The 3D Perspective lets you view your design from a
Southwest viewpoint. The 3D Overview looks at your
design from an elevated position, creating an
overhead view. You can change a 3D view by editing
camera properties, as well as create new views.
To view a 3D camera view:
1. Select View > 3D Cameras, then select the

camera view you want to display. Or, click
on the View Control toolbar and select
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the camera view to display. You can also click
on the Navigator to display the first 3D

camera view in the list.

You can change the view interactively by
changing the settings or camera/target
positions in the Camera Properties panel on
the right side of the screen, or by clicking and
dragging on the center pad in the Navigator.

To close the Camera Properties panel and
display the Catalog panel, click the panel’s
Close Properties button.

Tip: If you have your cameras turned on in 2D, you
can switch to a 3D view by selecting a camera,
right-clicking it, then selecting Activate View.

Creating a New 3D Camera View
You can create a new 3D view by placing a new
camera in your 2D plan view. Once you’ve inserted
the camera, you specify the camera angle and viewing
field angle by rotating and clicking your mouse.
To create a new 3D camera view:
1. While in 2D plan view, select View > 3D Cam-

eras > Place New Camera, or click on
the View Control toolbar and select Place
New Camera. A camera is attached to your
cursor, ready to be inserted.

2. Click to insert the camera where you want it.

3. Move your cursor in the direction you want
to view. Moving the cursor back and forth
changes the camera angle.

4. Once you have the desired direction and
angle in place, click to select a location for the
target.

5. Once you’ve defined the position and angle
of your camera, the 3D view is instantly
displayed.

The view will appear on your 3D Cameras
menu and toolbar flyouts for easy access. (By
default, the first view you create is called
Camera1).

Note: If a camera is placed in a room that has
no light fixtures, the camera headlight feature
will illuminate the room when you are
viewing the room in 3D. This light is only

available when viewing and navigating in
real time and is not used in rendering.

Changing a 3D Camera View
You can change a 3D camera view using the Camera
Properties panel that appears when you switch to a
3D camera view, or by clicking and dragging on the
center pad of the Navigator.

The position of the camera determines the point you
are viewing your design from while in a 3D camera
view. You can change your viewpoint by moving
your camera in the Camera Properties panel. You can
also change your camera height and adjust the
viewing field angle.

If you are currently in a 3D camera view, you can use
navigation tools such as Walk Around and Fly
Around to move the camera dynamically.

You can also change what you’re focused on in a 3D
camera view by moving the target in the Camera
Properties panel. You can also change the target
height.

You can use the onscreen Navigator to quickly move
the camera and target simultaneously by clicking and
dragging on the Navigator's center pad.

Turning Cameras On and Off
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Every 3D camera view is controlled by a virtual
“camera”. The Cameras On/Off tool displays a camera
icon on the screen. This gives you an idea of where
you are viewing from. If you click on a camera, the
target and viewing field angle become highlighted.
This lets you know what the camera is focused on,
and how much of your design is included in the view.

Having cameras displayed in 2D plan view allows
you to move cameras and targets in order to adjust
the 3D views they are associated with. This is an
alternative to adjusting 3D views interactively with
the Camera Properties panel.
To turn cameras on:
l Select View > Viewing Aids > Cameras

On/Off, or
l Click on the View Control toolbar

Navigating_in_3D.htm
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In 2D plan view, all cameras for all 3D camera views
are visible. (By default there are two: one for the 3D
Perspective, and one for the 3D Overview.) You may
need to zoom out to see them.

Changing Your Viewpoint
Moving a camera changes the angle you are viewing
from in a 3D camera view. You can change the
position of a camera by clicking and dragging the
camera grip in the interactive Camera Properties
panel. You can also move a camera while in 2D plan
view if your cameras are turned on. If the Navigator
is displayed you can change your viewpoint by
clicking and dragging on the Navigator's center pad.
To change your viewpoint in a 3D camera view:
1. Display the 3D camera view, and make sure

the Camera Properties panel is displayed. If it
isn’t, right-click in the view window and
select Camera Properties.

2. In the view map window of the Camera
Properties panel, click and drag the yellow
camera grip, then release your mouse button.
The 3D view updates automatically.

To change your viewpoint from 2D plan view:
1. Make sure you are in 2D plan view.

2. Turn your cameras on.

3. By default, the camera for the 3D Perspective
view is located to the left of the model. The
camera for the 3D Overview is located
towards the right side of the model. Click on
the camera you want to move.

4. Hover your pointer over the camera’s blue
grip to display the Move cursor . Or, right-
click in the drawing area and select Move
Camera.

5. Click and drag the camera to move it where
you want it.

6. To see the resulting view, right-click and
select Activate View, or simply double-click
the camera.

Note: If you use the Navigator to change your
viewpoint, the camera and target both move
simultaneously in the direction that you drag. If
you want to move only the camera, use one of the
other techniques described above.

Note: You cannot change the viewpoint of a 3D
QuickView, since these views do not have cameras
associated with them.

Changing the Camera Height
The height of your camera determines the height you
are viewing your model from in a 3D Camera View.
A positive camera height lets you look down on your
model, while a negative camera height lets you look
up at your model.
To change the camera height:
1. Display the 3D camera view, and make sure

the Camera Properties panel is displayed. If it
isn’t, right-click in the view window and
select Camera Properties.

2. In the Camera Properties panel, type the
height you want in the Camera Height edit
box, or use the arrows to scroll up or down
through a list of values.

Changing the Target of a 3D
Camera View
The target of a 3D camera view is the area you are
focused on, or looking towards. You can change the
position of a target by clicking and dragging the
target grip in the interactive Camera Properties panel.
You can also move a target while in 2D plan view.
To change the target in a 3D camera view:
1. Display the 3D camera view, and make sure

the Camera Properties panel is displayed. If it
isn’t, right-click in the view window and
select Camera Properties.

2. In the view map window of the Camera Prop-
erties panel, click and drag the circular target
grip, then release your mouse button. The 3D
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view updates automatically.

To change a target from 2D plan view:
1. In 2D plan view, turn your cameras on.

2. By default, the camera for the 3D Perspective
view is located to the left of the model. The
camera for the 3D Overview is located
towards the right side of the model. Click on
the camera whose target you want to move.
The target is usually inside or near your
model. It is marked with a blue grip.

3. Hover your pointer over the target’s grip to
display the Move cursor . Or, right-click in
the drawing area and select Move Target.

4. Click and drag the target to move it where
you want it.

5. To see the resulting view, right-click and
select Activate View, or simply double-click
the camera.

Note: If the Navigator is displayed, you can move
the camera and target simultaneously by clicking
and dragging on the Navigator's center pad. If you
want to move only the target, however, use one of
the two techniques described above.

Changing the Target Height in a
3D Camera View
Raising or lowering your target can increase or
decrease the steepness of the angle you are viewing
from when looking through the camera.
To change the target height:
1. Display the 3D camera view, and make sure

the Camera Properties panel is displayed. If it
isn’t, right-click in the view window and
select Camera Properties.

2. In the Camera Properties panel, type the
height you want in the Target Height edit

box, or use the arrows to scroll up or down
through a list of values.

Changing the Viewing Field
Angle
In a 3D camera view, the viewing field refers to your
field of vision. It works like a camera lens: higher
values produce a wide-angle view; lower values
produce a close-up view.

Sometimes changing the viewing field angle makes it
seem like you are zooming in or out. This is because
for wide-angle views, the program needs to shrink the
image to provide enough screen space to contain the
view. Conversely, the program enlarges the image to
fill the screen at smaller view angles, creating a close-
up view.
To change the viewing field angle in a 3D camera
view:
1. Display the 3D camera view, and make sure

the Camera Properties panel is displayed. If it
isn’t, right-click in the view window and
select Camera Properties.

2. In the Camera Properties panel, type the
desired angle in the View Angle edit box, or
use the slider to increase or decrease the
angle.

60º View Angle

100º View Angle
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Viewing in Presentation/Virtual
Reality Mode
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

In Presentation Mode, you navigate using an external
controller (such as a video game controller), or the
arrow keys on your keyboard. If you have a virtual
reality headset, you can create a 360° virtual reality
viewing experience.

When navigating in Presentation Mode, you will not
walk through walls or other objects. Instead you can
walk up and down stairs, step onto decks, and walk
through open doors, just as you would in real life.

To enter into Presentation Mode, select View >
Presentation Mode, or click on the View Control
toolbar.

The Presentation Mode dialog box will appear. You
can enter Presentation mode with a Lightmap or with
None selected without a Lightmap. You have two
choices: Presentation or VR to view the model.

l Click Presentation to enter in Presentation
Mode. While in Presentation mode, selecting
the +- will incrementally increase/decrease the
exposure and selecting shit +- will
increase/decrease the gamma correction of the
view.

l To navigate in Presentation Mode, use the
arrow keys on your keyboard. To look around
hold down your left mouse button and move
your mouse left or right. Hold down your right
mouse button and move your mouse to look
up and down.

l NOTE: If it is too dark or too light as you enter
Presentation Mode, use the + or - to adjust the
level of brightness.

l Click VR to enter Virtual Reality Mode. You
must have a compatible virtual reality headset
for VR to work. This option will be greyed out
if it doesn't detect the appropriate equipment.

l To exit Presentation or Virtual Reality Mode,

click .

By default, a standard 360° view is produced during
virtual reality viewing. You can switch to a
stereoscopic view in your Program Settings
(Settings>Program Settings>Graphics). In a
stereoscopic view, depth data is added between the
foreground and background, creating a more
immersive experience. See Stereoscopic VR Viewing on
page 499.

If you want to render a panoramic view that can be
shared and viewed with the VR app, see Rendering a
Panoramic View for VR Viewing on page 381.

Stereoscopic VR Viewing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a standard 360° view is produced during
virtual reality viewing in Presentation Mode. If you
switch to a stereoscopic view, depth data is added
between the foreground and background, creating a
more immersive experience.
To enable or disable stereoscopic VR viewing:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Graph-
ics in the left column.

3. In the VR pane, check or uncheck the Ste-
reoscopic check box.

4. Click OK.

Specifying the Properties of a
3D Scene
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When a view window contains a 3D scene, there are a
number of properties that you can specify to control
the appearance of the scene, such as the background
and amount of daylight.
To specify scene properties:
1. Display the scene, then right-click and select

Scene Properties. Or, select View > View
Properties and select the Scene Properties
tab.
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2. In the Scene Properties panel, specify the
following settings:

Use physically accurate lighting. Enabling
this option causes light to be simulated in a
more natural way, resulting in optimal
rendering quality. Note, however, that these
advanced lighting calculations will increase
rendering time.

Exposure. Determines how light or dark the
image will appear. The higher the value, the
lighter the image will be.

Date and Time. Determines how much
daylight will be in the scene relative to your
global location.

Background. If Use physically accurate
lighting is enabled, a realistic sky
background is automatically generated, and
the background type is set to Physical Sky.
If Use physically accurate lighting is
disabled, you can select an image to use for
the background. From the Type drop box,
select either 2D Image or 3D Image
depending on the type of image you want to
use. 2D images are displayed directly across
from the camera, and therefore move when
you move. 3D images form a skybox, creating
the perception of a realistic 3D world. You
can then select the image to use from the
Materials library.
Sky settings. This setting helps to control the
amount of light being cast onto a scene.
Choices are Clear Sky, Partly Cloudy Sky, and
Overcast Sky. For example, if your rendered
image looks overexposed, you can select a
partly cloudy or overcast sky to reduce the
amount of light coming through.

If Use physically accurate lighting is
enabled, the following settings are also
available:

Sky Power. The sky multiplier. Set the value
to 1.0 to create a physically accurate sky
texture. Lower values can be used to simulate
the effect of clouds or environment on the sky
intensity.

Sky Saturation. The intensity of color in an
image. If saturation is set to 1.0, colors are as
computed by the model, and the image will
have overly bright colors. If the value is
lower, returned colors will look more grayish.

Sun Power. The intensity of sunlight. This
applies in Realistic display mode and photo-
realistic renderings, both of which displays
sun and shadows.

Enable reflections. Simulates light reflecting
off of objects and surfaces.

Enable sun light. If disabled, sun light is not
created, regardless of the time of day. It is
recommended that you disable sun light if
you are rendering within a room that has no
openings.

Enable sun shadow. Simulates the shadows
cast by objects when they are illuminated by
the sun.

3. Click Close.

Walking Around in a 3D Camera
View
When you are in a 3D camera view, you can use the
Walk Around tool to walk around your model, or
even go right inside it. You can walk forward,
backward, left or right.
To walk around in a 3D camera view:
1. Select View > Zoom and Navigate > Walk

Around, or right-click in the drawing area
and select Walk Around, or click on the
Zoom and Navigate toolbar or on the Nav-
igator.

2. Click and hold down your mouse button in
the drawing area or on the Navigator's center
pad.

3. Drag in the direction you want to move.
l To move forward, drag upward.
l To move backward, drag downward.
l To walk left or right, drag left or right.
l If you drag up to the left, your path of
motion will curve upward to the left, and
so forth.
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Tip: You can also walk around using only your
mouse. Click and hold the CTRL key and your left
mouse button, then drag to walk around.

Tip: You can also use your arrow keys to walk
forward and backward. Click the up arrow to walk
forward, and click the down arrow to walk
backward.

Note: The Walk Around tool is not available if the
view is a 3D QuickView.

Note: By default, motion will continue when you
stop dragging, until you release your mouse
button. If you would prefer that motion stop when
you stop dragging, you should change your motion
response setting. See Setting the Zoom and Navigation
Motion Response on page 241.

Flying Around Your 3D Model
In a 3D camera view, the Fly Around tool revolves the
camera around the target, making it seem like the
model is spinning.
To fly around your model in a 3D camera view:
1. Select View > Zoom and Navigate > Fly

Around, or right-click in the drawing area
and select Fly Around, or click on the
Zoom and Navigate toolbar or on the
onscreen Navigator.

2. Click and hold down your mouse button in
the drawing area or on the Navigator's center
pad.

3. Drag in the direction that you want to rotate
the model. For example, if you want to rotate
the model to the right, drag to the right.

Note: To have the model rotate in the opposite
direction when you drag, enable the Invert Orbit
Navigation setting in Settings > Program
Settings > Navigation.

Note: By default, motion will continue when you
stop dragging, until you release your mouse
button. If you would prefer that motion stop when
you stop dragging, you should change your motion

response setting. See Setting the Zoom and Navigation
Motion Response on page 241.

Tip: You can also fly around by clicking and
dragging your middle mouse button provided that
the Fly Around tool is assigned to the middle
mouse button in your navigation settings. (By
default, the Look Around tool is assigned to the
middle button.)

Spinning the View with the Look
Around Tool
In a 3D camera view, the Look Around tool revolves
the target around the camera.
To spin the view in a 3D camera view:
1. Select View > Zoom and Navigate > Look

Around, or right-click in the drawing area
and select Look Around, or click on the
Zoom and Navigate toolbar or on the Nav-
igator.

2. Click and hold down your mouse button in
the drawing area or on the Navigator's center
pad, then drag to look around.
l Drag right to move the target in a coun-
terclockwise direction. Your model orbits
around you in a clockwise direction.

l Drag left to move the target in a clockwise
direction. Your model orbits around you
in a counterclockwise direction.

l Drag up to lower the height and shorten
the distance of the target. Your view
becomes high-angle, and your model
moves toward the top of the screen.

l Drag down to raise the height and
lengthen the distance of the target. Your
view becomes low-angle, and your model
moves toward the bottom of the screen.

Note: Be careful when using the Look Around tool.
It is very easy to lose sight of your model since the
camera's "eye" is fixed in one direction only. It does
not move to follow the orbiting target. Therefore,
your field of vision is limited, and your model can
quickly get above, below or behind you.
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Note: The Look Around tool is not available if the
view is a 3D QuickView.

Resetting the Camera
If you have moved the camera of a 3D camera view,
either by dragging it in 2D plan view or using a
navigation tool like Walk Around or Pan, you can use
the Reset Camera tool to move the camera back into
its original position. Note that this tool is only
available when the current view is a 3D view.
To reset the camera to its original position:
1. Select View > Zoom and Navigate > Reset

Camera, or click on the Zoom and Nav-
igate toolbar.

Note: The Reset Camera tool is not available if the
view is a 3D QuickView.

Zooming In
The Zoom In tool magnifies the entire view in
increments. Zooming is possible in both 2D and 3D
view.
To zoom in:
1. Select View > Zoom and Navigate > Zoom

In, or click on the Zoom and Navigate
toolbar.

2. To zoom in more, select the Zoom In tool
repeatedly until the view is sufficiently mag-
nified.

Zooming Out
The Zoom Out tool reduces the size of the current
view in increments.
To zoom out:
1. Select View > Zoom and Navigate > Zoom

Out, or click on the Zoom and Navigate
toolbar.

2. To zoom out more, select the Zoom Out tool
repeatedly until the desired zoom level is
achieved.

Zooming in Realtime
The Zoom Realtime tool continuously magnifies or
shrinks the view as you click and drag with your

mouse. You can zoom in and out in 2D plan view or
any 3D view.
To zoom in and out:
1. Select View > Zoom and Navigate > Zoom

Realtime, or click on the Zoom and Nav-
igate toolbar or on the Navigator.

2. Click in the drawing area or on the Nav-
igator's center pad, then drag up or down to
zoom in or out. To zoom in, click and drag
upward. To zoom out, click and drag down-
ward.

3. When the view is the desired size, release
your mouse button.

Note: By default, zooming will continue when you
stop dragging, until you release your mouse
button. If you would prefer that zooming stop
when you stop dragging, you should change your
motion response setting. See Setting the Zoom and
Navigation Motion Response on page 241.

Tip: You can also zoom in and out using the scroll
wheel on your mouse, or by holding down the
CTRL key and right mouse button simultaneously.

Zooming With a Scroll Wheel
Mouse
If you have a mouse with a scroll wheel, you can
zoom in and out in real time by rolling the wheel. The
position of your mouse pointer determines the center
of zoom.
To zoom with a scroll wheel mouse:
1. Position your pointer over the center of the

area you want to zoom.

2. To zoom in, roll the wheel forward.

3. To zoom out, roll the wheel backward.

Zooming a Selected Area (Zoom
Window)
Using the Zoom Window tool you can magnify a
particular area of your design by drawing a selection
window around it.
To zoom a selected area:
1. Select View > Zoom and Navigate > Zoom

Window, or click on the Zoom and
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Navigate toolbar. Your cursor becomes a mag-
nifying glass.

2. Click and drag a selection window around
the area you want to magnify.

Note: The Zoom Window tool is not available in
3D camera views.

Zooming to Fit the Drawing Area
The Zoom to Fit tool instantly extends your drawing
to the edges of the drawing area. This ensures your
entire drawing is visible at the most maximized view
possible, and makes full use of the drawing area.
Note that the terrain is considered part of your
drawing. If you want to zoom your model to fit the
drawing area, you need to turn the terrain off before
using Zoom to Fit.
To zoom the drawing to fit the drawing area:
1. Select View > Zoom and Navigate > Zoom to

Fit, or click on the Zoom and Navigate
toolbar.

Note: The Zoom to Fit tool is not available in 3D
camera views.

Panning
Using the Pan tool you can move the current view of
your design to bring a particular part of your design
into view. This is especially useful when the area you
want to view is currently not visible because you have
zoomed in on your drawing.
To pan the current view:
1. Select View > Zoom and Navigate > Pan, or

click on the Zoom and Navigate toolbar
or on the Navigator.

2. Click and hold your mouse in the drawing
area or on the Navigator's center pad.

3. Drag the view in the direction you want to
pan.

4. Release the mouse button.

Tip: You can also pan the view using your mouse.
To pan in 2D view, click and drag the middle
button. To pan in 3D view, click and hold the
CTRL key while pressing the middle button.

Tip: In 2D views you can also pan the view using
the arrow keys on your keyboard.

Zooming Back to the Previous
View
If you have used a zoom or pan tool, you can use the
Zoom Previous tool to instantly return the view to its
previous state.
To zoom back to the previous view:
1. Select View > Zoom and Navigate > Zoom

Previous, or click on the Zoom and Nav-
igate toolbar.

Zooming and Navigating with
the Mouse
You can use the buttons on your mouse to perform
many zoom and navigation functions instead of
making selections from the menu, toolbar or
Navigator. This allows you to instantly change your
view while designing, making the design process
more quick and efficient. For example, you can zoom
in realtime by simply rolling the scroll wheel on your
mouse.

In 2D view you can use the mouse to zoom and pan.
In 3D view you can use the mouse to zoom, pan, walk
around, look around, or fly around.

You can view the mouse control settings at any time
by displaying the Navigation page in your Program
Settings.
To view mouse control settings:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click
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Navigation in the left pane.

Note: By default, the Look Around tool is assigned
to the middle mouse button. You can assign the Fly
Around tool to it if you prefer by selecting the Fly
Around option for the Middle Button setting.

Assigning a Navigation Action
to the Middle Mouse Button
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use your middle mouse button to either Look
Around or Fly Around without having to make a
selection from the menu, toolbar or Navigator. By
default, the Look Around tool is assigned to the
middle mouse button. You can choose to assign the
Fly Around tool to it if you prefer.
To assign a navigation action to the middle mouse
button:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Nav-
igation in the left pane.

3. In the Mouse Controls area, select either the
Look Around or Fly Around option next to
the Middle Button setting.

4. Click OK.

Using Arrow Keys to Pan and
Navigate
You can use the arrow keys on your keyboard to pan,
walk or look around instead of making selections
from the menu, toolbar or Navigator. This allows you
to instantly shift your view when needed. In 2D view
you can use the arrow keys to pan the view. In 3D
view you can use the arrow keys to walk and look
around. You can click an arrow key to move in
increments, or click and hold an arrow key for
continuous motion in the specified direction.

You can view the arrow key settings at any time by
displaying the Navigation page in your Program
Settings.
To view arrow key settings:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click
Navigation in the left pane.

Adjusting Zoom and Navigation
Speed
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can adjust the rate of motion for zoom and
navigation tools so that your motion is faster or
slower when dragging your mouse. This applies to
continuous motion tools, including Zoom Realtime,
Pan, Walk Around, Fly Around, and Look Around.
To adjust zoom and navigation speed:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Nav-
igation in the left pane.

3. In the Zoom and Navigation Speed area, click
and drag the slider to adjust the zoom and
navigation speed. Slide left for slower motion,
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or slide right for faster motion.

4. Click OK.

Setting the Zoom and Nav-
igation Motion Response
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, when using continuous motion tools such
as Zoom Realtime, Pan, Walk Around and Fly
Around, motion continues in the current direction
when you stop dragging your mouse, until you
release your mouse button. If you prefer that motion
stop when you stop dragging, you can disable
continuous motion in your program settings.
To select a zoom and navigation motion response:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Nav-
igation in the left pane.

3. In the Zoom and Navigation Speed area, check
or uncheck the Continuous Motion check
box.

4. Click OK.

Viewing Elevations
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Elevations are 2D images that show a particular side
of your model (front, rear, left or right) as if you were
looking at it face on. While in an elevation view you
can zoom in and out as well as change the display
type.

To view an elevation:

1. Select View > Elevations, or click on the
View Control toolbar.

2. From the flyout, select the elevation you want
to view (Front, Back, Right or Left).

When you are in elevation view, the Elevation
Properties panel is displayed on the right side of
the screen. You can use this panel to interactively
adjust the elevation and its settings.

Tip: If you have your elevation marks turned on in
your 2D plan view, you can switch to an elevation
view by selecting an elevation mark, right-clicking
it, then selecting Activate View. Or, you can simply
double-click the elevation mark.

Creating a Custom Elevation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can create a custom elevation by inserting an
elevation mark in your 2D plan view. Once you’ve
inserted the mark, which represents your viewpoint,
you can rotate it using your mouse to define the view
direction.
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To create a custom elevation:
1. Make sure you are in 2D plan view.

2. Turn your elevation marks on. This is not
necessary, but we recommend it so that you
can see where other elevation marks are loc-
ated. The default elevation marks are located
at the extents of the terrain, so you may need
to zoom out to see them.

3. Select View > Elevations > Create New Elev-
ation, or click on the View Control tool-
bar and select Create New Elevation. An
elevation mark is attached to your cursor,
ready to be inserted.

4. Click to insert the new elevation mark. This
represents your viewpoint, so naturally you
would select a point in front of the model
side you want to look at in your elevation.

5. Move your cursor to rotate the arrow on the
elevation mark and define the view direction.
Once it is pointing in the desired direction
(usually towards your model), click to finish.

Once you’ve positioned the elevation mark, the
resulting elevation is instantly displayed. It is also
added to the Elevations menu and toolbar flyout for
easy access. Note that elevations sections are named
automatically when you create them, starting with the
name A1. The number increments each time you
create a new elevation or section. You can rename
elevations and sections in their properties.

Turning Elevation Marks On and
Off
You can use the View Filter to display or hide
elevation marks in your 2D plan view. An elevation
mark contains the label given to the elevation in the
elevation’s properties, as well as a target arrow that
identifies the view direction of the elevation.

By default, four marks are displayed, one for each of
the default elevations on the Elevation View menu. If
you have created a custom elevation, a mark is
displayed for that elevation as well.
To turn elevation marks on or off:

1. Select View > View Filters > View Filter, or
click on the View Control toolbar.

2. In the View Filter dialog, select the Viewing
Aids tab.

3. In the Elevation Mark row, click the eye icon
in the Display column to toggle elevation
marks on or off.

Marks are turned on 

Marks are turned off

The marks are located at the extents of your drawing,
so you may need to zoom out to see them.

If you select and right-click an elevation mark, you
can access a menu of tools including Move, Move
Target and Activate View.

Moving Elevation Marks
By default, elevation marks are centered with your
model, which means the model is centered on the
screen when you view the resulting elevation view. If
you move an elevation mark in your 2D plan view,
the model may be moved left or right when you
display the elevation view.

You can move an elevation mark while in elevation
view using the interactive Elevation Properties panel.
Alternatively you can move it while in 2D plan view,
then display the resulting view.
To move an elevation mark while in elevation view:
1. Display the elevation view, and make sure

the Elevation Properties panel is displayed. If
it isn’t, right-click in the view window and
select Elevation Properties.

2. In the view map window of the Elevation
Properties panel, click and drag the elevation
mark grip. The elevation view updates
instantly.

For front and rear elevations, move the mark
left or right. For left or right elevations, move
the mark up or down. Note that moving a
mark closer to or farther away from the
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model has no effect on the resulting elevation
view.

To move an elevation mark while in 2D plan view:
1. Select the elevation mark in 2D plan view.

2. Hover your pointer over the mark’s blue grip
to display the Move cursor. Or, right-click
in the drawing area and select Move.

3. Click and drag the mark to move it where
you want it.

4. Right-click and select Activate View to see
the resulting elevation, or simply double-click
the elevation mark.

Changing the Target of an Elev-
ation
By default, elevation marks point straight at your
model. The result is a completely face-on view when
you display the resulting elevation view. If you rotate
an elevation mark, you change the target of the
elevation. This focuses the view on a different part of
your design when you display the elevation view.
To change the target of an elevation:
1. Go to 2D plan view, and make sure your elev-

ation marks are turned on.

2. Select the mark whose target you want to
change.

3. Right-click and select Move Target.
4. Click and drag to rotate the mark so it is

pointing in a different direction.

5. Right-click and select Activate View to see
the result, or simply double-click the elev-
ation mark.

Editing Elevation Properties
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit the name of an elevation as it appears on
the Elevation Views menu, as well as edit the mark
text and mark text style.
To edit elevation properties:
1. Display the elevation view and make sure the

Elevation Properties panel is displayed. If it
isn’t, right-click in the view window and
select Elevation Properties.

2. To edit the name of the elevation as it
appears on the Elevations menu, edit the
name in the Name edit box.

3. To edit the text that appears on the elevation
mark, edit the text in the Mark Text edit box.

4. To apply a different text style to the elevation
mark, click the Text Style button and make a
selection from the Text Styles dialog. You
can also add and edit text styles if you want.

Detailing Elevations
In Model View, text, dimension and drafting tools are
only available in 2D plan view, and not in elevation
views. To be able to detail an elevation in Model
View, you need to create a new view window, then
use the Insert View tool to import an image of the
elevation into the new view window. If your product
does not contain the Insert View tool, this procedure
is not possible.

To avoid having to create new view windows, and
have more detailing and editing power, we
recommend detailing elevations in Worksheet View
— the program’s 2D production drafting module.
To be able to detail an elevation in Model View,
follow these steps:
1. Create the desired elevation view in the

Model view window.

2. Create a new view window and name it Elev-
ation (or something similar).

3. With a 2D plan view displayed in the new
view window, use the Insert View tool to
copy the elevation view from the Model view
window to the new view window.

4. Detail the copied elevation view image as
desired.

Deleting an Elevation
You can delete an elevation from the Elevations menu
by deleting its corresponding elevation mark in 2D
plan view.
To delete an elevation:
1. Go to 2D plan view, and make sure your elev-

ation marks are turned on.

2. Select the mark to delete.

Creating_Working_Drawings_in_Worksheet_View.htm
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3. Press the Delete key on your keyboard, or
right-click and select Delete.

Creating a Section
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can cut through any portion of your model to
create a section view, or cross-section. Section views
are a great way to see the interior features of your
model that you are not able to see from the outside,
and clarify construction details.

To create a section, you draw a section line through
your model in 2D plan view, then click to define the
view direction and depth.
To create a section:
1. Make sure you are in 2D plan view.

2. Select View > Sections > Create New Sec-
tion, or click on the View Control toolbar
and select Create New Section.

3. Select two points to draw a line that cuts
through your model. This is the line you will
be viewing from.

4. Move your cursor in the direction you want
to view. The more you move away from the
section line, the deeper your view becomes.

Once the bounding box is the desired dis-
tance and direction from the section line, click
to finish.

Once you’ve defined the section mark, the resulting
section view is instantly displayed. It is also added to
the Sections menu and toolbar flyouts for easy access.
Note that elevations sections are named automatically
when you create them, starting with the name A1.
The number increments each time you create a new
elevation or section. You can rename elevations and
sections in their properties.

Viewing Sections
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have created section views, you can display
them at any time using the Sections menu or toolbar.
To view a section:

1. Select View > Sections, or click on the
View Control toolbar and select the section
name.

Tip: If you have your section marks turned on in
your 2D plan view, you can switch to a section
view by selecting a section mark, right-clicking it,
then selecting Activate View.

Turning Section Marks On and
Off
When you create a section, a section mark is
displayed in the 2D plan view. The section mark
contains markers at each end of the section line which
indicate the direction of the section view. You can
turn section marks on and off using the View Filter.
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To turn section marks on or off:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Viewing
Aids tab.

3. In the Section Mark row, click the eye icon in
the Display column to toggle section marks on
or off.

Marks are turned on 

Marks are turned off

Changing Your Viewpoint in a
Section
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can change your viewpoint in a section by
moving a section mark. You can use the Section
Properties panel to move the section mark
interactively. Alternatively you can move the section
mark in 2D plan view, then display the resulting
view.
To change your viewpoint in a section:
1. Display the section, and make sure the Sec-

tion Properties panel is displayed. If it isn’t,
right-click in the view window and select
Section Properties.

2. In the view map window of the Section Prop-
erties panel, click and drag the red square
grip at the center of the section mark line,
then release your mouse button. The section
updates instantly.

To change your viewpoint from 2D plan view:
1. In 2D plan view, make sure your section

marks are turned on.

2. Click on the section mark.

3. Hover your pointer over the blue grip on the
section line to display the Move cursor .

Or, right-click in the drawing area and select
Move.

4. Click and drag the mark to move it where
you want it.

5. Right-click and select Activate View to see
the result.

Changing the Depth of a Section
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can change the depth of a section by stretching
the section line bounding box. You can change the
depth interactively using the Section Properties panel.
Alternatively you can change the depth in 2D plan
view, then display the resulting view.
To change the depth of a section:
1. Display the section, and make sure the Sec-

tion Properties panel is displayed. If it isn’t,
right-click in the view window and select
Section Properties.

2. In the view map window of the Section
Properties panel, click and drag the circular
grip opposite the main section mark line,
then release your mouse button. The section
updates instantly.

To change the depth from 2D plan view:
1. In 2D plan view, make sure your section

marks are turned on.

2. Click on the section mark.

3. Hover your pointer over the blue grip on the
bounding box line to display the Stretch
cursor. Or, right-click in the drawing area
and select Stretch.

4. Click and drag to make the bounding box
smaller or bigger. The bigger the box, the
deeper the view.

5. Right-click and select Activate View to see
the result.
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Detailing Sections
To detail a section, you can use a variety of text,
dimension and drafting tools. Such tools are only
available in 2D plan view, and not in section views.
You can, however, create a new view window, then
use the Insert View tool to import an image of the
section into the new view window. If your product
does not contain the Insert View tool, this procedure
is not possible.

To avoid having to create new view windows, and
have more detailing and editing power, we
recommend detailing sections in Worksheet View —
the program’s 2D production drafting module.
To be able to detail a section, follow these steps:
1. Create the desired section view in the Model

view window.

2. Create a new view window and name it Sec-
tion (or something similar).

3. With a 2D plan view displayed in the new
view window, use the Insert View tool to
copy the section view from the Model view
window to the new view window.

4. Detail the copied section image as desired.

Editing Section Properties
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit the name of a section as it appears on
the Sections menu, as well as edit the section mark
text and text style.
To edit section properties:
1. Display the section and make sure the Section

Properties panel is displayed. If it isn’t, right-
click in the view window and select Section
Properties.

2. To edit the name of the section as it appears
on the Sections menu, edit the name in the
Name edit box.

3. To edit the text that appears on the section
mark, edit the text in the Mark Text edit box.

4. To apply a different text style to the section
mark, click the Text Style button and make a
selection from the Text Styles dialog. You
can also add and edit text styles.

Deleting a Section
You can delete a section from the Sections menu by
deleting its corresponding section mark in 2D plan
view.
To delete a section:
1. In 2D plan view, make sure your section

marks are turned on.

2. Select the mark to delete.

3. Press the Delete key on your keyboard, or
right-click and select Delete.

Creating Dynamic Cutaway
Views
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Dynamic Cutaway tool lets you strip away a
portion of your 3D model so that you can see inside
it. By sliding a selected clipping plane back and forth,
you essentially create a moving cross-section of your
design.

To create a dynamic cutaway view:
1. Go into 3D view.

2. Select View > Dynamic Cutaway, or click
on the View Control toolbar.

3. In the Dynamic Cutaway dialog, click on the
clipping plane you would like to use. For
example, if you want to strip away the front
of your house, click on Front.

4. Click and drag the slider in the Dynamic Cut-
away dialog to move the clipping plane back
and forth. As you move the clipping plane,
your design is stripped away.

5. To change the angle of the clipping plane,
click and drag inside the dialog’s clipping
plane graphic to rotate the clipping plane.

Creating_Working_Drawings_in_Worksheet_View.htm
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6. When you have created the desired view,
click OK. Note that the 3D view will remain a
cutaway view once you close the Dynamic
Cutaway dialog. If you want to return to the
original view, click on None in the Dynamic
Cutaway dialog before clicking OK.

What is Stereo Vision?
Stereo Vision gives you depth perception. Here's how
it works:

Both of your eyes are aimed at the same target, but
because each eye is located in a different position,
each takes in a unique view from its own perspective.
When the two separate images arrive simultaneously
in the back of the brain, they are united into one
picture. The combined picture appears three-
dimensional because it has the added depth
dimension.

Displaying a 3D Stereo View
Selecting the Stereo Vision tool while wearing a pair
of 3D glasses adds the perception of depth to a 3D
view, making it seem like every detail is popping out
at you. This is a great way to really step into your
model and get a true feel for it.
To display a 3D stereo view:
1. Display a 3D view.

2. Select View > Stereo Vision > Stereo Vision
On/Off.

3. Put on a pair of 3D glasses. You can use any
pair of anaglyphic (red/cyan) glasses.

Tip: Stereo vision works when viewing still images
as well as when you are navigating through a 3D
scene.

Adjusting Stereo Vision Settings
You can adjust your 3D stereo view by editing the
stereo vision settings. Make sure you have your 3D
glasses on while editing the settings.
To edit stereo vision settings:
1. Select View > Stereo Vision > Stereo Vision

Settings.
2. Editing the settings by clicking and dragging

the sliders. For the most part you just need to

play around with the settings until you
achieve the result you want.

Below is a description of each setting. 

Stereo Effect. Adjusts the distance between
the red image and cyan image.

Comfort Adjustment. Caters to the
differences in the human eye. Since each eye
takes in a unique view from its own
perspective, and each person’s eyes and
vision are different, the image will not appear
exactly the same to everyone.

Projection Plane Distance From Camera.
The distance of the projection plane from the
camera determines which objects in the
model appear to pop out of the screen, and
which ones are sunken into the screen.

Changing the Display Mode
By default, your design is displayed in Wireframe
mode when you are in 2D plan view. When you
switch to a 3D view, the default display mode is
Rendered mode. There are six display modes you can
choose from — Wireframe, Hidden Line, Rendered,
Rendered Outline, Patterned, and Realistic.

Note that when you change the display mode in one
view and then switch to another view and change the
display mode in that view, the display mode in the
first view will be retained when you go back to it.
To change the display mode:
1. Select View > Display Mode, or click the

down arrow next to the Display Mode button
on the View Control toolbar to view the

Display Mode menu.

2. Choose the desired display mode. These are
described below.

Wireframe
Each line in your design is visible, creating a “see-
through” view. It is available for both 2D and 3D
views.
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Hidden Line
In a hidden line view, all lines that you would
normally not see are removed from the view, creating
an opaque view.

Rendered
In Rendered display mode, textures and colors are
applied to the elements and terrain, creating a very
realistic view. Note: The Rendered display mode
should not be confused with a 3D RealView.

Rendered Outline
In the Rendered Outline display mode, textures and
colors are applied to the elements and terrain, and
surface edges are outlined in a single, dark line for
increased surface definition.

Patterned
In Patterned display mode, patterns of lines
(hatching) are applied to the surfaces of elements.
Patterns are part of a material’s definition. Therefore,
the materials applied to your elements determine
what patterns you will see.

Realistic
Shades and shadows are displayed in Realistic mode,
which change in real time as you navigate. This can
be particularly noticeable when viewing interiors with
light fixtures and other sources of light and reflection.
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The unique View Filter dialog acts as a display filter, letting you decide which elements or locations you want
displayed at any given time. For example, you may want to hide your roof and ceilings to be able to see inside the
model. It also acts as a selection filter, letting you control whether or not certain objects can be selected, which is
sometimes necessary when trying to select a particular element in your drawing, like a floor or ceiling.

Other features allow you to “pick and choose” with your mouse precisely what you would like to filter. These
include Pick Items to Hide, Hide All Except, Pick Items to Make Non-Selectable, and Make All Non-Selectable
Except.

To access the View Filter:

1. Select View > View Filters > View Filter, or click on the View Control toolbar.

Filtering the Display
The View Filter provides precise control over what elements and locations are displayed in a view at any given time.

You can display/hide:
l an entire location, or multiple locations
l building elements on a specific location or multiple locations
l wall panel tags
l the terrain
l elements on the terrain
l notation elements such as text, dimensions, schedules and drafting objects
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l viewing aids such as elevation and section
marks How to

l framing components in Framing Mode

Note: Using the View Filter does not delete
elements from your drawing. It just hides them
from view.

To filter the display:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

The View Filter dialog contains several tabs, including
Elements on Location, Elements on Terrain, and Notation.

The Elements on Location tab lists all the elements in
your model that are associated with building
locations. Many elements in the list can be expanded
to display a list of sub-components for precise view
control. You can display or hide elements on all
locations, or specific locations.

The Elements on Terrain tab lists the terrain and any
landscaping elements in your drawing that are
associated with the terrain.

The Notation tab contains items such as text,
dimensions, drafting objects, and project trace images.

The Viewing Aids tab contains items such as elevation
marks and section marks.

The Framing tab lists the framing components tools
available in Framing Mode — the Head/Sill/Jamb tool,
Intersection tool and Wall Infill tool.

The icons in the Display column indicate whether or
not that location or element is currently displayed.
Clicking an icon toggles the icon to the opposite state
(on or off).

Element is turned on

Element is turned off

On the Elements on Location tab, this icon indicates
that some of an element’s components are turned on,
and some are turned off.

Clicking Display All turns on all elements displayed
on the current tab. Clicking Display None turns off
all elements displayed on the current tab. On the
Elements on Location tab, these buttons affect elements
on the currently selected location(s).

The icons in the Lock column indicate whether or not
an item is locked. If an item is locked, it remains in its
current state regardless of any element filtering you

do. For example, if Wall Framing is locked in a visible
state, Wall Framing will remain visible even if you
turn off the Walls element, or click the Display None
button.

Item is locked

Item is unlocked

Some of the item's components are locked, and
some are not

Displaying/Hiding Elements on
Locations
You can use the View Filter to display or hide
selected element types on all or selected building
locations. This applies to building elements such as
walls and doors, as well as landscaping elements that
were inserted using the “Insert on Location” option.
To display or hide building elements:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. By default, elements on all locations are dis-
played in the element list. To control the vis-
ibility of elements on a specific location,
disable the All Locations check box, then
select the location where you want to filter
the view. You can Ctrl+click to select multiple
locations if you want.

4. To turn an element on or off, click the
element’s eye icon in the Display column to
toggle it on or off. If you want to filter
specific element components, click the
element’s plus sign (+) to display a list of
components. For example, the Walls element
can have components such as wall surfaces,
trim, wall framing, doors and windows. Each
component has its own display icon.

Element or component is turned on 

Element or component is turned off

Indicates that some of an element’s
components are turned on, and some are
turned off

5. To display or hide all building elements cur-
rently shown in the element list, click Display

Displaying_Hiding_Viewing_Aids.htm
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All or Display None.
6. To lock an element or component in its cur-

rent display state, click the lock icon in the
Lock column. When an item is locked, any fil-
tering you do in the dialog will have no effect
on the locked item. For example, if Wall Fram-
ing is locked in a visible state, Wall Framing
will remain visible even if you turn off the
Walls element, or click the Display None but-
ton.

7. Click OK.

Displaying/Hiding Building Loca-
tions
You can turn individual or all locations on or off.
When you turn a location off, all elements on that
location are hidden from view.
To display or hide locations:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. On the right side of the dialog, select the loc-
ation(s) that you want to display or hide.

l To display or hide one or more spe-
cific locations, disable the All Loca-
tions check box, then in the locations
list, select the location(s) that you
want to display or hide. You can
Ctrl+click to select multiple locations
if you want.

l To display or hide all locations, enable
the All Locations check box.

4. In the Display area, click All or None to turn
all the elements on the selected location on or
off.

5. Click OK.
To quickly display or hide all locations:
1. Select View > View Filters > All Locations

On/Off, or click the down arrow next to the
View Filters button on the View Control
toolbar and select All Locations On/Off.

Displaying/Hiding Elements on
the Terrain
You can use the View Filter to display or hide the
terrain and any elements associated with the terrain,
such as landscaping elements.
To filter elements on the terrain:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Terrain tab.

3. Click the eye icons in the Display column to
turn elements on or off. You can also click the
Display All or Display None button to
display or hide all terrain elements
simultaneously.
Element is turned on
Element is turned off

4. Click OK.

Note: The visibility of decks is controlled on the
Elements on Location tab. This also applies to
exterior lighting, exterior furniture or exterior
accessories that were inserted using the “Insert on
Location” option.

Displaying/Hiding Notation
Objects
You can use the View Filter to control the visibility of
notation objects such as text and dimensions.
To filter notation objects from view:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Notation
tab.

3. Click the eye icon in the Display column next
to the notation object you want to display or
hide. Clicking the icon toggles visibility on
and off. You can also click the Display All or
Display None button to display or hide all
notation objects simultaneously.

Object is turned on 

Object is turned off

4. Click OK.
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Displaying/Hiding Framing
Mode Components
Building Essentials | Construction Suite
When in Framing Mode, framing components (wall
infill, intersections and openings) are displayed as
"glass boxes", making it easy to identify and select
each one. You can hide selected framing components
from view if you want.
To filter components from view in Framing Mode:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Framing
tab.

3. Click the eye icon in the Display column next
to the framing component that you want to
display or hide in Framing Mode. The Head
Sill Jamb Tool option relates to the display of
openings. Other components that may be
listed are Intersections and Wall Infill.

Component is turned on  

Component is turned off

4. Click OK.

Selection Filtering
You can use the View Filter to prevent specific
elements from being selected. You can even prevent
entire building locations from being selected.
To control element selectability:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

The View Filter dialog contains various tabs,
including Elements on Location, Elements on Terrain,
and Notation.

The Elements on Location tab lists all the elements in
your model that are associated with building
locations. Many elements in the list can be expanded
to display a list of sub-components for precise
filtering. You can control the selectability of elements
on all locations, or specific locations.

The Elements on Terrain tab lists the terrain and any
landscaping elements in your drawing that are
associated with the terrain.

The Notation tab contains items such as text and
dimensions.

The Viewing Aids tab contains items such as elevation
marks and section marks.

The Framing tab lists the framing components tools
available in Framing Mode — the Head/Sill/Jamb tool,
Intersection tool and Wall Infill tool.

The icons in the Selection column indicate whether or
not an element is currently selectable. Clicking an icon
toggles the icon to the opposite state (selectable or
non-selectable).

Element is selectable

Element is not selectable

On the Elements on Location tab, this icon indicates
that some of an element’s components are selectable,
and some are not.

Clicking Select All makes all elements on the current
tab selectable. Clicking Select None turns off
selectability for all elements displayed on the current
tab. On the Elements on Location tab, these buttons
affect elements on the currently selected location(s).

The icons in the Lock column indicate whether or not
an item is locked. If an item is locked, it remains in its
current state regardless of any element filtering you
do. For example, if walls are currently non-selectable
and you click the Select All button to make all
elements selectable, walls will remain unselectable if
they are locked.

Item is locked

Item is unlocked

Some of the item's components are locked, and
some are not

Note: Wall framing cannot be selected, but you can
select intersections, openings and wall infill while
in Framing Mode. Floor, ceiling and roof framing
cannot be selected unless you convert their framing
to actual members.

Making Elements on Locations
Selectable or Non-Selectable
You can use the View Filter to control the selectability
of elements on all or selected building locations. This
applies to building elements such as walls and doors,
as well as landscaping elements that were inserted
using the “Insert on Location” option.
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To change the selectability of elements on
locations:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. By default, elements on all locations are dis-
played in the element list. To control the
selectability of elements on a specific location,
disable the All Locations check box, then
select the location that you want to filter. You
can Ctrl+click to select multiple locations if
you want.

4. To control an element’s selectability, click the
element’s filter icon in the Selection column to
toggle it on or off.

Element is selectable

Element is not selectable

If you want to control the selectability of
specific element components, click the
element’s plus sign (+) to display a list of
element components. For example, the Walls
element can have components such as wall
surfaces, trim, wall framing, doors and
windows. Each component has its own filter
icon.

5. To control the selectability of all building ele-
ments currently shown in the element list,
click Select All or Select None.

6. To lock an element or component in its cur-
rent state of selectability, click the lock icon in
the Lock column. When an item is locked, any
filtering you do in the dialog will have no
effect on the locked item. For example, if
walls are currently non-selectable and you
click the Select All button to make all ele-
ments selectable, walls will remain unse-
lectable if they are locked.

7. Click OK.

Making Building Locations
Selectable or Non-Selectable
When you make a location non-selectable, no
elements on that location can be selected in any view.
To make a location selectable or non-selectable:

1. Select View > View Filters > View Filter, or
click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. On the right side of the dialog, select the loc-
ation(s) that you want to make selectable or
non-selectable.

l To control selectability for one or
more specific locations, disable the All
Locations check box, then in the loc-
ations list, select the location(s) that
you want to filter. You can Ctrl+click
to select multiple locations if you
want.

l To control selectability for all loc-
ations, enable the All Locations check
box.

4. In the Selection area, click All or None to
make all the elements on the selected location
selectable or non-selectable.

5. Click OK.

Making Elements on the Terrain
Selectable or Non-Selectable
You can use the View Filter to control the selectability
of the terrain or any elements associated with the
terrain, such as landscaping elements.
To make elements on the terrain selectable or non-
selectable:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Terrain tab.

3. Click the filter icons in the Selection column to
toggle selectability on or off.

Element is selectable

Element is not selectable

4. If you want to make all elements on the Ele-
ments on Terrain tab selectable or non-select-
able, click the Select All or Select None
button.

5. Click OK.
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Note: The selectability of decks is controlled on the
Elements on Location tab. This also applies to
exterior lighting, exterior furniture or exterior
accessories that were inserted using the “Insert on
Location” option.

Making Notation Objects Select-
able or Non-Selectable
You can use the View Filter to control whether or not
notation objects such as text and dimensions can be
selected for editing.
To make notation objects selectable or non-
selectable: 
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Notation
tab.

3. Find the item that you want to control and
then click its filter icon in the Selection
column to toggle selectability on or off.

Object is selectable

Object is not selectable

4. Click OK.

Making Framing Mode Com-
ponents Selectable or Non-
Selectable
Building Essentials | Construction Suite
When in Framing Mode, framing components (wall
infill, intersections and openings) are displayed as
"glass boxes", making it easy to identify and select
each one. You can use the View Filter to prevent
specific framing components from being selected
while in Framing Mode.
To control the selectability of Framing Mode
components:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Framing
tab.

3. Find the item that you want to control and
then click its filter icon in the Selection
column to toggle selectability on or off. The
Head Sill Jamb Tool option relates to wall

openings. Other components that may be
listed are Intersections and Wall Infill.

Component is selectable 

Component is not selectable

4. Click OK.

Hiding Items by Picking in Your
Drawing
Using the Pick Items to Hide tool you can select items
directly in your drawing that you want to hide.
To hide an item by picking:
1. Select View > View Filters > Pick Items to

Hide, or click the down arrow next to the
View Filters button on the View Control
toolbar and select Pick Items to Hide.

2. Click on the item that you want to hide. Note
that filtering occurs per item type rather than
individual item. For example, if you pick one
column, all columns will be hidden.

3. Right-click and select Finish.

Hiding All Except What Is
Picked
Using the Hide All Items Except tool you can select
an item in your drawing and automatically hide
everything else for quick display control.
To hide all except what is picked:
1. Select View > View Filters > Hide All Items

Except, or click the down arrow next to the
View Filters button on the View Control
toolbar and select Hide All Items Except.

2. Click on the item that you want to remain dis-
played. Note that filtering occurs per item type
rather than individual item. For example, if
you pick one column, all columns will remain
displayed.

3. Right-click and select Finish.

Making Items Non-Selectable by
Picking in Your Drawing
Using the Pick Items to Make Non-Selectable tool you
can select items directly in your drawing that you
want to make non-selectable.
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To make an item non-selectable:
1. Select View > View Filters > Pick Items to

Make Non-Selectable or click the down
arrow next to the View Filters button on
the View Control toolbar and select Pick
Items to Make Non-Selectable.

2. Click on the item that you want to make non-
selectable. Note that filtering occurs per item
type rather than individual item. For example,
if you pick one column, all columns will be
made non-selectable.

3. Right-click and select Finish.

Making All Non-Selectable
Except What Is Picked
Using the Make All Non-Selectable Except tool you
can pick an item in your drawing that you want to be
selectable, and automatically make everything else
non-selectable.
To make all non-selectable except what you pick:
1. Select View > View Filters > Make All Non-

Selectable Except or click the down arrow
next to the View Filters button on the
View Control toolbar and select Make All
Non-Selectable Except.

2. Click on the item(s) that you want to be select-
able. Note that filtering occurs per item type
rather than individual item. For example, if
you pick one column, all columns will be
made selectable.

3. Right-click and select Finish.

Creating a View Filter Template
You can create filter templates in the View Filter
dialog which enable you capture a specific group of
filter settings, and instantly apply them to your
drawing. For example, if you wanted to display an
electrical diagram, you could create an 'Electrical'
template in which only walls, electrical elements and
electrical wiring are shown.
To create a view filter template:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, click .

3. In the New View Filter Template dialog, you
can select an existing template on which to
base the new template if desired.

4. Specify the desired display and selection set-
tings. For more information, refer to Filtering
the Display on page 249 and Selection Filtering
on page 252.

5. In the Template Name edit box, type a name
for the template.

6. By default, the template will displayed on the
View > View Filters menu for quick access. If
you do not want it to appear there, disable
the Include in menu check box. Note that the
template will still be displayed in the Tem-
plates drop box in the View Filter dialog.

7. Click Save.
8. To apply the template settings, click Apply in

the View Filter dialog.

Applying a View Filter Template
If you have created a view filter template, you can
apply its filter settings to the current view by selecting
it from the View > View Filters menu. This assumes
that the Include in menu option is selected in the
template's properties.

You can also apply a template in the View Filter
dialog:

1. Select View > View Filters > View Filter, or
click on the View Control toolbar.

2. In the View Filter dialog, select the desired
template from the Template drop box.

3. Click Apply.

Editing a View Filter Template
If you have created a view filter template, you can
edit its filter settings if needed.
To edit a view filter template:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the template
from the Template drop box.

3. Click .

4. In the Edit View Filter Template dialog, edit
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the filter settings.

5. Click Save.
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Windows

The View Manager contains a listing of view windows and lets you open, close, create, and edit views. Every new
project has at least one pre-defined view window. A Model View view window is where you build and edit your 3D
model. A Worksheet View window takes you into a 2D drafting mode where you can create your construction
documents. Note: Personal Architect does not have Worksheet views.
You can easily create new view windows as needed. Each window can have different view settings. For example,
you may want to display a wireframe, 2D plan view in one view window, and a 3D view in another window.

When you create new view windows, you can switch between open view windows using the Window menu or view
tabs.

You can display multiple view windows at the same time using the Tile Open Views and Cascade Open Views tools.
View windows can be moved, resized and closed to create the exact arrangement you want.

You can edit the name and scale of views listed in the View Manager, as well as specify print properties for each
view.

To access the View Manager:

1. Select View > View Manager, or click on the View Control toolbar, or right-click any view tab and select
View Manager.

Adding a Group to the View Manager
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Views are arranged in groups for ease of organization. You can add groups to the View Manager to help you
organize views.
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To create a new group in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select Arrange >
Add Group, or right-click in the left pane and
select Arrange > Add Group. A 'New Group'
is added to the list.

3. Edit the group's name in the Name edit box
in the right pane.

You can now add views to the group, or move
existing views into the group.

Renaming a Group in the View
Manager
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To rename a group in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select the group
that you want to rename. It's properties
appear in the right pane.

3. Edit the name in the Name edit box.
4. Click OK.

Deleting a Group in the View
Manager
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To delete a group in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select the group
that you want to delete.

3. Select Arrange > Remove Group, or right-
click in the left pane and select Arrange >
Remove Group. The group is deleted.

Note: If a group contains views and you delete it,
the views will be deleted also. You may first want
to move the views into another group.

Expanding and Collapsing
Groups in the View Manager
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Views are contained in groups in the View Manager.
You can expand or collapse individual groups, or all
groups simultaneously.
To expand or collapse groups:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. To expand a group that is currently col-
lapsed, click the small plus sign (+) to the left
of the group's name.

3. To expand all groups at once, select Arrange
> Expand All, or right-click in the left pane
and select Arrange > Expand All.

4. To collapse a group that is currently expan-
ded, click the small minus sign (--) to the left
of the group's name.

5. To collapse all groups at once, select Arrange
> Collapse All, or right-click in the left pane
and select Arrange > Collapse All.

Creating a New View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Every new project contains at least one pre-defined
view window.

You can use the View Manager to create new view
windows and specify different view settings for each
window. For example, you may want to create a view
window called '3D View' and display a 3D view in
that window.

If your product contains the Worksheet View mode,
you can create either a Model View window or
Worksheet View window. You build, edit and view
your model in Model View windows. When you
create a Worksheet View window, you are
automatically switched to the 2D production drafting

Creating_Working_Drawings_in_Worksheet_View.htm
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mode. Here you can create detailed and accurate
construction documents.

Views are stored in groups for easy organization and
navigation. You can add view windows to the default
group, or create your own groups if you want. You
can add views using the View Manager, or through
the view tabs below the drawing area.
To create a new view in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the left pane of the View Manager dialog,
select the group you want to add the view to.

3. Select Views >Add Model View or Add
Worksheet (depending on which type of
view you want to create), or right-click in the
left pane and select Add Model View or Add
Worksheet. A Model View window will
contain your actual 3D model. In model view
you can build and edit your model. Selecting
Worksheet View will put you directly into
drafting mode where you can create working
drawings.

Note: You cannot create Worksheet View
windows in Building Essentials.

A new view is added to the list.

4. In the Name edit box in the right pane, type a
name for the view window.

5. Select a view scale for the view.
The view scale is the ratio of units on paper
to real-world units. If the scale is set to 1:48
(1/4" = 1'- 0"), a quarter inch on paper will
represent one foot of your model. For
example, an 8-foot wall would be 2 inches on
paper. The view scale becomes particularly
important in Worksheet View, where you
create all of your printable working
drawings. (Note that you can set a print scale
for the view that is independent of the view
scale.)

6. If you want to define the view's print settings
at this time, select the Print Properties tab in
the right pane, then define the print settings.

7. Click OK. The new view becomes the current
view window.

To create a new view through the view tabs:
1. Right-click any view tab and select either

Add Model View or Add Worksheet (depend-
ing on which type of view you want to cre-
ate). A new view tab is added.

2. To edit the properties of the view window,
such as the name and view scale, right-click
the view tab and select View Manager.

Copying a View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can copy an existing view window to create a
new view window. When you copy a view, the
contents and display settings of the view are copied to
the new view window. The Copy View tool works on
both Model View and Worksheet View windows. You
can copy a view in the View Manager, or through the
view tabs.
To copy a view in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the left pane of the View Manager dialog,
select the view window that you want to
copy.

3. Select Views > Copy View, or right-click and
select Copy View.

To copy a view through the view tabs:
1. Right-click on the view tab that you want to

copy.

2. Select Copy View.

Renaming a View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit the name of a view window as it appears
in the View Manager, in the program’s title bar, and
on the view tabs. You can do this in the View
Manager, or by accessing the view window’s
properties.
To rename a view window when it is the current
view window:
1. Select View > View Properties, or right-click

in the view window and select View

Creating_Working_Drawings_in_Worksheet_View.htm
Editing_the_Print_Scale_of_a_View.htm
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Properties.
2. In the View Properties dialog, type the new

name in the Name edit box.
3. Click OK.

To rename a view window in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. On the left side of the View Manager dialog,
select the view that you want to rename. It's
properties appear in the right pane.

3. Edit the view's name in the Name edit box in
the right pane.

4. Click OK.

Opening View Windows
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have closed a view window either through the
View Manager or by clicking a view window’s Close
button, you can open it again by making it active in
the View Manager.
To open a view window:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. Click in the check box next to the view win-
dow's name to make it active. It appears on
the Window menu as well as on a view tab if
you have view tabs turned on.

To open all view windows at once:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select Views >
Set All Active, or right-click in the left pane
and select Set All Active.

Closing View Windows
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the Model view window is open when you
start a project. Others may be open as well depending
on the program version you are using. You can close

individual view windows by making them inactive in
the View Manager, by clicking the view window’s
Close button, or through the right-click menu of view
tabs.
To close a view window from within the window
itself:
1. Click the Close button in the top right corner

of the view window.

To close a view window using the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. Click in the check box next to the view's
name to make the view inactive.

To close all view windows at once:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select Views >
Set All Inactive, or right-click in the left pane
and select Set All Inactive.

To close a view window from the view tabs:
1. Right-click the view tab of the window that

you want to close.

2. Select Close View.

Deleting a View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can delete a view window by removing it from
the View Manager, or by selecting the Delete View
tool on a view tab's right-click menu.
To delete a view window from the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. Select the view to delete.
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3. In the View Manager dialog, select Views >
Delete View, or right-click in the left pane
and select Delete View.

To delete a view window from the view tabs:
1. Right-click on the view tab containing the

view that you want to delete.

2. Select Delete View.
3. Click OK to confirm that you want to per-

manently delete the view.

Re-ordering Views in the View
Manager
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can move views up or down in the View
Manager to control which group they are contained
in, or change their place in the list.
To re-order views in the View Manager:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select the view
that you want to move.

3. Select Arrange > Move Up or Arrange >
Move Down, or right-click in the left pane
and select Arrange >Move Up or Arrange >
Move Down. Repeat to move the view further
up or down if necessary.

Displaying/Hiding the View Tabs
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When view tabs are turned on, a row of tabs is
displayed below the drawing area. Each tab
represents an open view in the View Manager. View
tabs make it easy to switch from one view to another.
To turn view tabs on or off:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Tool Display area, check or uncheck the
View Tabs check box.

4. Click OK.

Making a View Window the Cur-
rent View Window
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have multiple view windows, you can use the
Set Current option in the View Manager to make a
particular view window the current one displayed.
To set the current view window:

1. Select View > View Manager, or click on
the View Control toolbar, or right-click any
view tab and select View Manager.

2. In the View Manager dialog, select the view
window you want to make current.

3. Select Views > Set Current, or right-click in
the left pane and select Set Current. The
selected view window is now the current
view window.

Switching Between View Win-
dows
All open view windows appear on the program’s
Window menu, making it easy to switch from one
window to another.

Also, if you have turned your view tabs on, view tabs
for each open view window are displayed below the
drawing area.

To make a view window the current view window,
simply select it from the Window menu, or select the
view’s corresponding view tab below the drawing
area.

Tiling View Windows
By default, only one maximized view window is
displayed at a time. Using the Tile Open Views tool
you can instantly tile all open view windows in the
drawing area. This is a great way to see different
views of your design while you are working on it.
When you make a change in one view window, the
design updates automatically in all other view
windows.
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To tile all open view windows:
1. Select Window > Tile Open Views.

Cascading View Windows
By default, only one maximized view window is
displayed at a time. Using the Cascade Open Views
tool you can instantly display all open view windows
in a stacked format, with the current view window on
top. Once the view windows are cascaded you can
move and resize each one if you want.
To cascade all open view windows:
1. Select Window > Cascade Open Views.

Returning to a Maximized View
If you have tiled or cascaded your open view
windows, you can return to a maximized view (where
only one view window is visible) by maximizing one
of the open view windows.
To maximize a view window:
1. Click the Maximize button in the view win-

dow you want to maximize.

Restoring the Previous Arrange-
ment of View Windows
If you tiled, cascaded or arranged your view
windows, then maximized one of them, you can use
the Restore Down button to return to the view
window arrangement that was displayed before you
used the Maximize button.
To restore the previous arrangement of view
windows:
1. Click the Restore Down button in the top

right corner of the current view window.
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In Model View, you can find a variety of drafting tools on the Tools menu, such as Text and Dimensions.

The Tools > Layout sub-menu contains a basic set of line and shape tools — Line, Arc, Circle, Rectangle and Polygon
Hatch, as well as a set of detailing tools — Batt Insulation, Rigid Insulation, Wood Section, Masonry Section, and
Cut Line. Objects drawn with these tools will not display in 3D view. You can use these tools to help with your
design layout. For example, you may want to draw construction lines to help you place walls and other elements.

In addition to drafting tools, the Layout menu contains the Insert View tool, which lets you insert views of your
model — 2D plans, elevations, sections or 3D views — into the current view window.

You can use the Import PDF File to import the contents of any PDF file into your Envisioneer project. You can define
the size and angle of the imported block prior to importing it. If the PDF contains a floor plan, you can scale the plan
to the correct size upon import, then trace the imported plan using building tools such as the Walls tool to create an
accurate 3D model in Envisioneer.

You can also use the Import CAD File tool to import an AutoCAD DWG or DXF file into your project, such as a title
block, detail or drafting symbol. Using these tools allows you to create quick, basic working drawings.

Many of the drafting tools that you see in Model View are also available in Worksheet View. The exceptions are
Auto Exterior Dimensions, Auto Interior Dimensions, and Room Dimensions. These tools can only be used in Model
View.

Note: We recommend completing your working drawings in Worksheet View rather than Model View.
Worksheet View provides access to the same tools you see on the Layout menu, plus many more. Dedicated
solely to 2D production drafting, Worksheet View gives you all the drawing and editing tools needed to create
fast, accurate, detailed working drawings.

Adding Text in Model View
You can add custom text or pre-defined labels to your drawing. You can select the text style you want to use, and
control the justification of the text. Text can be moved and rotated after it has been inserted, just like most other
elements.
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To add custom text to your drawing:

1. Select Tools > Text > Text, or click on
the Annotation toolbar.

2. In the Text dialog, type the text you want to
add. If you want to import a text (*.txt) file,
click Import, then select the file to import.

3. To select a style for the text, click the Text
Style button and select or create a text style
in the Text Styles dialog.

4. By default, text is left justified. For multi-line
text, this means that text lines will line up on
the left, and be ragged on the right. If you
want to change the justification Justification
refers to the way lines of text "line up" in
relation to the window that contains them. A
"left" justification lines the left side of the text
up with the left side of the window, leaving
the right side ragged. of the text, click the
appropriate justification button above the text
editing window.

Left Justify 

Center Justify

Right Justify

5. If you want to automatically return to the
Text dialog after you have inserted the cur-
rent text, enable the Multiple text insert
check box. This is ideal when you want to
insert different pieces of text without having
to select the Text tool again.

6. Click OK. The text is attached to your cursor.
7. Position the text where you want it, then click

to insert it.

To add pre-defined labels to your drawing:

1. Select Tools > Text > Text, or click on
the Annotation toolbar.

2. In the Text dialog, select the label you want
in the Pre-defined Labels list on the right side
of the dialog, then drag it into the editing win-
dow. You can also double-click the label or
click to add the label to the editing win-
dow.

3. If you want to add or edit a label, click the
Library button to access the Labels library.

4. To select a style for the text, click the Text
Style button and select or create a text style
in the Text Styles dialog.

5. If you want to automatically return to the
Text dialog after you have inserted the cur-
rent text, enable the Multiple text insert
check box. This is ideal when you want to
insert different pieces of text in your drawing
without having to select the Text tool again.

6. Click OK. The text is attached to your cursor.
7. Position the text where you want it, then click

to insert it.

Editing Text Content in Model
View
You can edit the content of a text element by
accessing its properties.
To edit text:
1. Select the text you want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Text dialog, edit the text in the text
window.

4. Click OK.

Changing the Style of Text in
Model View
You can edit the appearance of text by applying a
different text style to it.
To change the style of text:
1. Select the text whose style you want to

change.
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2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Text dialog, click Text Style.
4. In the Text Styles dialog, select a new text

style. You can also create your own text style,
or edit the current text style.

Note that if you edit an existing text style,
your changes are permanently saved in the
text styles library, and are not project-specific.

5. Click OK in the Text Styles dialog.
6. Click OK in the Text dialog. The text is

changed automatically.

Note: The Properties tool lets you change the text
style of the selected text object only. If you want to
globally change all text objects that use a particular
text style, see Updating a Text Style Globally on page
265.

Updating a Text Style Globally
You can use the Update Style tool to change the text
style of all text objects in your drawing that use the
same text style.
To update a text style globally:
1. Select a text object whose text style you want

to change.

2. Right-click and select Update Style, or select
Edit > Modify Elements > Update Style.

3. In the Text Style Properties dialog, make the
desired text style change.

4. Click OK. All text objects using the selected
text style will automatically update.

Changing the Justification of
Multi-line Text
You can change the way multiple lines of text are
aligned.
To change the justification of text:
1. Select the text you want to edit.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Text dialog, click the appropriate jus-
tification button below the editing window.

4. Click OK.

Finding and Replacing Text in
Model View
You can use the Find and Replace tool to find a
specific word or phrase in your project. You can also
replace it instantly with another word or phrase of
your choice.
To find and replace text:
1. Select Tools > Text > Find and Replace, or

click on the Annotation toolbar.

2. In the Find and Replace Text dialog, type
the word or phrase that you want to find in
the Find what edit box.

3. If you want to replace the text with some-
thing else, enter the replacement text in the
Replace with edit box.

4. Select any options you want to use to control
the search. These are described below.

Match case. Find text with the same
capitalization as the search text. For example,
if you enter the word "Bedroom" as your
search text, the word "bedroom" would not
be returned as a match because the first
character is not uppercase.

Match whole word. Find only whole words,
not parts of words. For example, if you enter
the word "day" as your search text, the words
"Monday" or "daytime" would not be
returned as matches.

Search up. Search backward from the
current search position.

5. Click Find Next.
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If the text is found, the first instance is
displayed in the lower pane of the Find and
Replace Text dialog, and the text is
highlighted in the drawing area.

6. To replace the text with the text in the
Replace with edit box, click Replace. To
instantly replace all instances of the search
text, click Replace All.

7. To search for the next instance of the text,
click Find Next again. When the search is
complete, the End of Search dialog will
appear notifying you that all text has been
searched.

8. When you are finished searching for text,
close the Find and Replace Text dialog.

Note:The Find and Replace tool searches the
current building location only.

Adding Text with a Leader in
Model View
You can insert text with an arrow attached to it that
points to a particular element or area in your
drawing. The leader has two segments and can be
oriented in any fashion.
To add a text with leader:
1. Select Tools > Text > Text with Leader, or

click on the Annotation toolbar.

2. To select a dimension style for the leader,
click the Dimension Style button and make a
selection from the Dimension Styles dialog.

3. Type the desired text in the editing window.
Or, to import a text (*.txt) file, click Import,
then select the file to import.

4. To insert a pre-defined label, select the label
you want in the Pre-defined Labels list on the
right side of the dialog, then drag it into the
editing window. You can also double-click
the label or click to add the label to the
editing window. To access the Labels library,
where you can add and edit labels, click
Library.

5. If you want to automatically return to the
Leader dialog after you have inserted the cur-
rent text, enable the Multiple text insert

check box. This lets you keep inserting text
without having to select the Text with Leader
tool again.

6. Click OK.
7. In the drawing area, select the point where

you want the arrowhead to appear.

8. Select the next point of the leader. If you only
want a two-point leader, right-click and select
Finish at this point. Otherwise, you can select
a third point for the leader if you want.

9. If you are creating a three-point leader, select
a third point for the leader. The text is inser-
ted.

Moving and Stretching a Leader
You can move or stretch a leader by clicking and
dragging its grips.
To move/stretch a leader:
1. Click on the text with leader to select it. Grips

appear on the leader.

2. Click and drag a grip to move it, then release
your mouse button.

Changing the Style of Text with
a Leader in Model View
The text style and leader arrow style of text with a
leader is determined by the current dimension style,
which by default is the Standard dimension style. You
can change the style of text with a leader by selecting
a dimension style with the desired style settings.
To select a different style for text with a leader:
1. Click on the text with leader to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Leader dialog, click the Dimension
Style button.

4. In the Dimension Styles dialog, select the
dimension style that you want to use, then
click OK. For information about editing
dimension styles, including leader settings,
see Customizing the Dimension Styles Library on
page 459.
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5. Click OK in the Leader dialog. The text with
leader is updated.

Note: The Properties tool lets you change the style
of the selected text object only. If you want to
globally change all text objects that use a particular
text style, see Updating the Style of Text with a Leader
Globally on page 267.

Updating the Style of Text with a
Leader Globally
You can use the Update Style tool to change the style
of all text with leader objects in your drawing that use
the same dimension style.
To globally update the style of text with a leader:
1. Select a text with leader object whose dimen-

sion style you want to change.

2. Right-click and select Update Style, or select
Edit > Modify Elements > Update Style.

3. In the Dimension Style Properties dialog,
make the desired dimension style change.
Leader arrow properties are specified on the
Leader tab. The text style is specified on the
Text tab.

4. Click OK.

Moving Leader Text in Model
View
If you have inserted text with a leader, you can move
the text independently of the leader.
To move leader text:
1. Click on the text with leader to select it.

2. Right-click and select Move Text, or select
Edit > Modify Elements > Move Text.

3. Click and drag the text to move it, then
release your mouse button.

Editing Leader Text in Model
View
If you have inserted text with a leader, you can
change the text to whatever you want.
To edit leader text:
1. Click on the text with leader to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Leader dialog, edit the text as desired,
then click OK.

Dimensions (Model View)
Envisioneer automatically displays on-screen
dimensions as you draw, making it easy to draw
walls at correct lengths, and insert elements like doors
and windows precisely where you want them. These
dimensions are drawing aids only that disappear once
you have inserted the element.

The Dimensions menu in Model View offers a variety
of powerful tools to help you add dimensions to your
2D plan. Dimension values are calculated
automatically so you can annotate your drawing
quickly and effortlessly.

Use the Auto Exterior Dimensions tool to
automatically apply dimensions to the perimeter of
your model, and the Auto Interior Dimensions tool to
insert auto-calculated dimensions on the model's
interior. Another powerful tool is the Room
Dimensions tool, which instantly calculates the
dimensions of a room (length x width) and inserts the
measurement in the room.

Three tools are available for inserting singular
dimensions. Use the Linear Dimensions tool to insert
a simple horizontal or vertical dimension, and the
Aligned Dimensions tool to insert a dimension that
aligns with (takes the angle of) the object being
dimensioned. Use the Angular Dimensions tool to
insert a dimension that measures an angle rather than
a distance.

Use the Continuous Dimension tool to quickly add
more segments to an existing linear or aligned
dimension. You can use the Baseline Dimension tool
to build multiple dimensions along a common
baseline, creating a series of stacked dimensions. You
can create an Overall Dimension from two or more
selected dimensions.

By default dimensions use the Current Dimension
Style. You can also change the style of an individual
dimension after it has been inserted, or perform a
global update of a dimension style.

You can move or stretch a dimension after it has been
inserted, as well as align, join and split dimensions.
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Setting the Current Dimension
Style in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When you add dimensions to your drawing, they use
the current dimension style, which by default is the
Standard dimension style. You can select a different
dimension style to be the current one if you want.
To set the current dimension style:
1. Select Settings > Current Dimension Style.
2. In the Current Dimension Style dialog, click

the Select button..
3. In the Dimension Styles dialog, select the

style you want to set as current.

4. Click OK in the Dimension Styles dialog.
5. Click OK in the Current Dimension Style dia-

log.

Creating Automatic Exterior
Dimensions
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Auto Exterior Dimensions tool automatically
dimensions the exterior walls of your home. By
default, three dimension strings are created: one for
openings, one for wall segments, and an overall
dimension for each side of the model.
To create automatic exterior dimensions:
1. Select Tools > Dimensions > Auto Exterior

Dimensions, or click on the Annotation
toolbar.

Note: You can control which dimension strings are
created, as well as how walls and wall elements are
dimensioned. You must specify these settings
before the dimensions are created.

Specifying Exterior Dimension
Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Before using the Apply Auto Exterior Dimensions tool
to create automatic exterior wall dimensions, it is a

good idea to specify the settings for the exterior
dimensions. These settings control how the walls and
wall elements (doors, windows, openings, etc.) are
dimensioned.
To specify exterior dimension settings:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click
Dimension Auto Exterior in the left column.

3. Specify the settings described below.
Include Dimension String for:

Overall. The outermost dimension string that
dimensions the overall length of each exterior
wall.

Projections. String that dimensions all
projecting points along an exterior wall. If a
wall has no projections, this string will be
identical to the overall dimension string.

Openings: String that dimensions all major
projections and all openings in the exterior
walls, including door and window openings.
Openings can be dimensioned on center, or to
the outside edges (see the Openings area of
the dialog).

Interior Walls: String that dimensions to all
major projections and each interior wall that
projects into the exterior wall. (You can
specify which edges you want to dimension
to in the Interior Walls area of the dialog).
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Angled Walls: Angled string that dimensions
angled walls.

Dimension Line Distances

Dim Line Spacing: The spacing between
successive dimension lines (when two or
more strings are used).

Dimension Offset: The distance between the
first dimension string and the walls.

Extension Lines

Extension lines extend from the dimension
line toward the walls being dimensioned. In
situations where dimension points are not
parallel with each other, you can specify
whether you want the extension lines to
extend all the way to the dimension points, or
whether you want them to line up with the
shortest dimension point.

Openings

If you are including a dimension string for
openings, you can specify whether you want
the openings to be dimensioned on center, or
to the edges of the openings.

Add Opening Height after Width. For door,
window and opening dimensions, enabling
this option displays the height of the opening
in addition to the width. For example, if an
opening is 5' wide and 6'-8" high, the
dimension would read 5'-0"/6'-8". You can
choose a different separator if you wish.

Separation. The character or format used to
separate the opening width and opening
height. Available choices are shown below
with examples.

/ (forward slash) 5'-0"/6'-8"

— (dash) 5'-0"— 6'-8"

X 5'-0" X 6'-8"

Multi-line 5'-0"
6'-8"

End Condition

You can choose which exterior wall faces you
want to dimension to.

Surface (Exterior). Dimensions to the outer
edge of the walls's exterior surface (e.g. brick,
stone or siding). If the wall does not contain
an exterior surface, the outer edge of the core
wall is used instead.

Core (Exterior). Dimensions to the outer edge
of the core wall (e.g. stud wall).

Core (Center). Dimensions to the center of the
core wall (e.g. stud wall).

Core (Interior). Dimensions to the inner edge
of the core wall (e.g. stud wall).

Surface (Interior). Dimensions to the interior
edge of the interior surface (e.g. drywall or
plaster). If the wall does not contain an
interior surface, the inner edge of the core
wall is used instead.

Interior Walls

If you are including the Interior Walls
dimension string, you can specify whether
you want the interior walls to be
dimensioned to the center or edges of the
wall core, or to the edges of the wall's interior
surfaces. You can select more than one option
if needed.

Edges (Surfaces). Dimensions to the edges of
the wall's interior surfaces (e.g. drywall or
plaster).

Edges (Core). Dimensions to the edges of the
core wall (e.g. stud wall).

Center (Core). Dimensions to the center of the
core wall (e.g. stud wall).

4. Click OK.

Creating Automatic Interior
Dimensions
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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The Auto Interior Dimensions tool automatically
dimensions interior walls in your model. To create
automatic interior wall dimensions, you draw a base
line through your model. Dimensions are created for
any walls along that line (running in the same
direction as the line).
To create automatic interior dimensions:
1. Select Tools > Dimensions > Auto Interior

Dimensions, or click on the Annotation
toolbar.

2. Select a start point for the base line that is out-
side of the model.

3. Select an end point for the base line that is
outside of the model. Dimensions are created
along that line.

4. Right-click and select Finish.

Note: Before creating automatic interior
dimensions, you may want to specify the interior
dimension setting, which determines exactly how
the walls are dimensioned.

Specifying Interior Dimension
Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you are using the Auto Interior Dimensions tool to
create automatic interior wall dimensions, you can
specify how you want the walls dimensioned before
creating the dimensions. By default, walls are
dimensioned on center. If you prefer you can
dimension to other or additional wall edges.
To specify the auto interior dimension setting:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click
Dimension Auto Interior in the left column.

3. You can specify whether you want the
interior walls to be dimensioned to the center
or edges of the wall core, or to the edges of
the wall's interior surfaces. You can select
more than one option if needed.

Leading Edge (Surface). Dimensions to the
leading edge of the interior surface (e.g.
drywall or plaster). The leading edge is the
first edge of the interior surface that the
dimension line encounters as it runs from its
start point.

Leading Edge (Core). Dimensions to the leading
edge of the core wall (e.g. stud wall). The
leading edge is the first edge of the core wall
that the dimension line encounters as it runs
from its start point.

Center (Core). Dimensions to the center of the
core wall (e.g. stud wall).

Trailing Edge (Core). Dimensions to the
trailing edge of the core wall (e.g. stud wall).
The trailing edge is the second edge of the
core wall that the dimension line encounters
as it runs from its start point.

Trailing Edge (Surface). Dimensions to the
trailing edge of the interior surface (e.g.
drywall or plaster). The trailing edge is the
second edge of the interior surface that the
dimension line encounters as it runs from its
start point.
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4. If you do not want to include the width of
intersecting walls in the dimensions, enable
the Ignore Wall Dimensions check box. The
difference is shown below:

5. Click OK. You can now proceed with creating
auto interior dimensions.

Creating Linear Dimensions in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A linear dimension is a horizontal or vertical
dimension with extension lines going vertically (for a
horizontal linear dimension) or horizontally (for a
vertical linear dimension) to the origins of the
extension lines, which define the endpoint of the
dimension.

This tool is ideal for creating interior dimensions, or
dimensions on a landscape plan.
To create linear dimensions:
1. Select Tools > Dimensions > Linear Dimen-

sions, or click on the Annotation toolbar.

2. Click a point in your drawing to begin the
dimension line.

3. Move your mouse (you do not have to hold
the mouse button down) to a second point
and click. A dimension line including offsets,

arrows and a numerical value is added to
your drawing.

4. Move your mouse away from the dimension
line to stretch your extension lines. When the
extension lines are the desired length, click to
finish the dimension.

Creating Aligned Dimensions in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

An aligned dimension is similar to a linear dimension,
except it tilts to the same angle as the element you are
dimensioning, making it the ideal choice for elements
that are not horizontal or vertical.

To create aligned dimensions in Model View:
1. Select Tools > Dimensions > Aligned Dimen-

sions, or click on the Annotation toolbar.

2. Click a point in your drawing to begin the
dimension line.

3. Move your mouse (you do not have to hold
the mouse button down) to a second point
and click. A dimension line including offsets,
arrows and a numerical value is added to
your drawing.

4. Move your mouse away from the dimension
line to stretch your extension lines. When the
extension lines are the desired length, click to
finish the dimension.

Creating Angular Dimensions in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Angular Dimensions tool to insert a
dimension that measures an angle rather than a
distance. This is particularly useful where objects are
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not rectangular, or are not perpendicular to one
another.

To create an angular dimension, you select three
points that will be used to create the dimension, then
select a location for the dimension line.
To create an angular dimension:
1. Select Tools > Dimensions > Angular Dimen-

sions, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Angular Dimensions.

2. Select the angle’s vertex point.

3. Select the first endpoint of the angle.

4. Select the second endpoint of the angle.

5. With the dimension attached to your
crosshairs, position the dimension where you
would like it, and then click to insert it.

Creating Continuous Dimen-
sions in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can easily add more segments to an existing
dimension using the Continuous Dimension tool.
Simply pick points where you want each extension
line to be, and the dimension line will automatically
extend with each point picked. This creates a series of
dimensions that are end to end. When you select the
Continuous Dimension tool, it automatically starts to
continue the last dimension created in the current
session, from that dimension's second extension line.
You can choose a different extension line from which
to continue, or select a different dimension altogether.

To create continuous dimensions:
1. Select Tools > Dimensions > Continuous

Dimension or click on the Annotation
toolbar. Your cursor will automatically snap
to the second extension line of the last linear
or aligned dimension created in the current
session.

If you would like to continue the dimension
from the other extension line, right-click and
choose Select continued dimension, then
click near the end from which you want to
continue.

If you would like to continue a different
dimension, right-click and choose Select
continued dimension, then click on the
desired dimension, clicking near the end from
which you would like to continue.

2. Move your cursor in the direction in which
you would like to continue the dimension.
The dimension line extends as you move
your cursor.

3. Click to select the next extension line point.
This creates a new dimension.

4. Continue adding more dimensions as needed.

5. When you are finished adding dimensions,
right-click and select Finish.
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Creating Baseline Dimensions
in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Baseline Dimension tool to create
multiple dimensions along the same baseline. Baseline
dimensions are built from an existing linear or aligned
dimension in your drawing. Simply pick points where
you want each extension line to be, and new
dimensions will be created with each point picked.
When you select the Baseline Dimension tool, it
automatically starts from the second extension line of
the last linear or aligned dimension created. You can
choose to continue from the other extension line
instead, or choose a different dimension to continue if
you want. Each new dimension is stacked next to the
previous one.

To create baseline dimensions:
1. Select Tools > Dimensions > Baseline

Dimension or click on the Annotation
toolbar. Your cursor will automatically snap
to the second extension line of the last linear
or aligned dimension created. This will be the
first extension line of the new dimensions.

If you want to continue from the other
extension line instead, right-click and choose
Select continued dimension, then click near

the extension line that you want to use as
your first extension line point.

If you would like to continue a different
dimension altogether, right-click and choose
Select continued dimension, then click on
the dimension that you would like to
continue.

2. Move your cursor in the direction in which
you would like to continue the dimension,
then select a point for the second extension
line. A new dimension is created.

3. Continue to select extension line points to
add more dimensions.

4. When you are finished adding dimensions,
right-click and select Finish.

Tip: To change the spacing between baseline
dimensions, edit the Baseline Offset value in your
dimension style properties. See Changing the Style of
a Dimension in Model View on page 276.

Creating Overall Dimensions in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Overall Dimension tool to create one
overall dimension from two or more existing
dimensions in your drawing. The overall dimension
extends from the first extension line of the first
dimension picked to the second extension line of the
last dimension picked.
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To create an overall dimension:
1. Select Tools > Dimensions > Overall Dimen-

sion or click on the Annotation toolbar.

2. Click where you would like the dimension
line to be placed.

3. Click on the first dimension from which you
would like to create an overall dimension.

4. Click on the second dimension from which
you would like to create an overall dimen-
sion. An overall dimension is created. You
can select more dimensions to add if you
want.

5. Right-click and select Finish.

Creating Room Dimensions
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Room Dimensions tool you can quickly
calculate the dimensions of a room (e.g. 8' x 10') and
insert the dimension on your plan.
To create room dimensions:
1. Select Tools > Dimensions > Room Dimen-

sions, or click on the Annotation toolbar.

2. Click on a corner of the room.

3. Click an adjacent corner to indicate the width
and rotation of the room. Then, click an
opposite corner to indicate the length of the
room.

4. In the Room Dimensions dialog, you can
edit the resulting dimensions if needed.

5. Select the format in which you want the
dimensions displayed — either Width x
Length, or Length x Width.

6. To select a style for the dimension, click the
Dimension Style button, then make a selec-
tion from the Dimension Styles dialog.

7. Click OK. The dimensions are automatically
inserted at the center of the room.

Moving a Dimension Line in
Model View
You can move a dimension line using the Move
Dimension Line tool. When you move a dimension
line, the extension lines stretch to accommodate the
move.
To move a dimension line using the Move
Dimension Line tool:
1. Select the dimension.

2. Right-click and select Move Dimension Line,
or select Edit > Modify Elements > Move
Dimension Line.

3. Click any point to serve as the base point for
the move.

4. Move your mouse in the direction you want
to move the dimension line.

5. Click to finish the move.

Stretching Dimensions in Model
View
You can make a dimension longer or shorter, or
stretch either of its extension lines. When you stretch
the length of a dimension, the dimension value
updates automatically to reflect the new length.
To adjust the length of a dimension:
1. Select the dimension.

2. Click on one of the lower extension grips,
then drag the dimension to stretch it. Note
that it is possible to stretch the extension line
at the same time.

3. Release your mouse button.
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To adjust the length of extension lines:
1. Select the dimension.

2. Click the grip at the end of the extension line,
then drag to stretch the extension line.

3. Release your mouse button.

Aligning Dimensions in Model
View
You can use the Align Dimension tool to align an
existing dimension with another.
To align dimensions:
1. Click on the dimension that you want to align

another dimension with.

2. Right-click and select Align Dimension, or
select Edit > Modify > Align Dimension.

3. Click on the dimension that you want to align
with the first dimension. The dimension
adjusts to align with the first dimension.

Joining Dimensions in Model
View
You can join two existing linear or aligned
dimensions using the Join Dimension tool. Joining
two dimensions turns two dimensions into one, and
the dimension value updates automatically to display
the new length.
To join dimensions:
1. Click on one of the dimensions that you want

to join with another.

2. Right-click and select Join Dimension, or
select Edit > Modify > Join Dimension.

3. Click on the dimension that you want to join
with the first. The two dimensions are joined
into one.

Note: If the two dimensions that you are joining
are not aligned with each other, the second
dimension picked will be aligned with the first
dimension picked when they are joined.

Splitting Dimensions in Model
View
You can split a dimension into two dimensions at a
selected point using the Split Dimension tool.
To split a dimension:

1. Click on the dimension that you want to split.

2. Right-click and select Split Dimension, or
select Edit > Modify > Split Dimension.

3. Click on the dimension line where you would
like to split the dimension. The dimension is
split at the selected point.

Overriding Dimension Text in
Model View
You can edit a dimension’s calculated numerical value
to suit your needs, or add information to the value.
You can even change the value to text, such as
“Varies”.
To override dimension text:
1. Select the dimension, then right-click and

select Override Text. Or, select Edit > Modify
Elements > Override Text.

2. If you want to replace the current dimension
value with something else, type the desired
text in the Override Dimension Text dialog.
You can type any numerals or characters you
want.

If you want to keep the current value but add
information before or after the value, use a
pair of angle brackets <> before or after the
additional text. For example, if you wanted to
add the words 'Final Dimension' after the
dimension value, you would type <> Final
Dimension in the edit box.
For a 12'-0" dimension, the dimension would
then look like this:

If you want to add text below the dimension
value (on the other side of the dimension
line), type the characters \X where you want
to drop down to a new line. For example, if
you wanted to add the 'Final Dimension' text
below the current dimension value instead of
beside it, you would type <> \X Final
Dimension in the edit box.
The dimension would then read:
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The line break option can be used with the
current dimension value (as shown in the
example above), or with custom text that you
type in the edit box. Note that you can only
use the line break option once when
overriding a dimension. You cannot keep
adding more lines of text.

3. Click OK to update the dimension text.

Changing the Style of a Dimen-
sion in Model View
You can change the appearance of a dimension’s line,
arrows and text by applying a different dimension
style to it.
To change the style of a dimension:
1. Select the dimension. You can select multiple

dimensions using Shift+click.

2. Right-click and select Change Style, or select
Edit > Modify Elements > Change Style.
(Note: For text with a leader, select Properties).

3. In the Dimension Styles dialog, select the
style that you want to apply to the dimen-
sion. You can also create your own dimension
style, or edit the current dimension style.
Note that if you edit an existing dimension
style, your changes are permanently saved in
the dimension styles library, and are not pro-
ject-specific.

4. Click OK.

Note: The Change Style tool lets you change the
dimension style of the selected dimension only. If
you want to globally change all dimensions that
use a particular dimension style, use the Update
Style tool instead.

Updating a Dimension Style
Globally
You can use the Update Style tool to change the style
of all dimensions in your drawing that use the same
dimension style.
To update a dimension style globally:

1. Select a dimension whose dimension style
you want to change.

2. Right-click and select Update Style, or select
Edit > Modify Elements > Update Style.

3. In the Dimension Style Properties dialog,
make the desired dimension style change.

4. Click OK. All dimensions using the selected
dimension style will update automatically.

Specifying How Elements are
Marked
Element marks show information such as an element's
dimensions or part number. By default, doors,
windows and openings insert with marks displayed,
while other elements do not. You can specify whether
or not a mark is displayed for any element in your
drawing or catalog, and even specify custom mark
text if desired.

You can specify default element mark settings such as
the format and text style of marks in your Document
Settings. See Specifying Settings for Element Marks on
page 276.
To specify how an element is marked:
1. Select the element in your drawing, then

right-click and select Properties. Or, if you
have not inserted the element yet, select it in
the catalog, then right-click and select Edit
Element.

2. In the properties dialog, select the Quantity
tab.

3. In the Quantity pane, select the desired mark
method from the Mark drop box:
Auto. Inserts a mark with the default mark
settings.

Custom. Inserts a mark with custom text that
you specify in the Mark field.
Off. Disables the creation of a mark.

4. Click OK.

Specifying Settings for Element
Marks
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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You can specify the default format and appearance of
element marks in your Document Settings. There are
settings for door, window,opening, member and
cabinet marks, as well as a set of default settings for
all other types of elements.

1. Select Settings > Document Settings or click
on the Settings toolbar.

2. In the Document Settings dialog, click Ele-
ment Marks in the left column.

3. Specify the mark settings. You can specify
unique mark settings for doors, windows,
openings, members, and cabinets. For all
other elements, the settings in the Default
Mark section will be used.
The available settings are:

Format. The format for the element's
measurements. e.g. Width x Height

Units. The units in which measurements are
displayed. e.g. Feet-inches

Precision. The precision of the element's
measurements in terms of the selected units.

Position. The position of the mark in relation
to the element (Inside, Outside or Center).

Offset. The distance of the mark from the
element when the Position is set to Inside or
Outside.

Layer. The layer on which marks will reside
in Worksheet View.

Text Style. The style of the mark text (font,
font size, color, etc.).

Displaying/Hiding Element
Marks
You can display or hide element marks using your
View Filter. Note that marks will only be shown on
elements that have Marks turned on in their
properties. By default, doors, windows and openings
have marks turned on. See Specifying How Elements
are Marked.

1. Select View > View Filters > View Filter, or
click on the View Control toolbar.

2. In the View Filter dialog, select the Elements
on Location tab.

3. Click the eye icon in the Display column to
toggle marks on or off.

Marks turned on 

Marks turned off

4. Click OK.

Drawing Lines in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can draw a line with one or more segments by
simply picking points.
To draw a line:

1. Select Tools > Layout > Line, or click on
the Layout toolbar.

2. Select a start point for the line.

3. Select the end point for the line. If you want
you can continue adding segments to the line.
If you want to close the last line back to the
first line to create a closed shape, right-click
and select Close.

4. When you are finished drawing the line,
right-click and select Finish.

Note: Lines can only be drawn in 2D plan view.

Extending a Line to Another
Object (Model View)
You can use the Extend tool to extend a line to
another drafting object in your drawing.
To extend a line to another object:
1. Select the object you want to extend to. The

object must be a line, arc, circle or rectangle.
It must also be in the path of the line you
want to extend.

2. Right-click and select Extend.
3. Select the line you want to extend, clicking

near the end that you want to extend. The
line is extended to the object you selected.

Trimming a Line to Another
Object (Model View)
If a line passes through another drafting object, you
can use the Trim tool to trim the line to the object it
intersects.
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To trim a line to another object:
1. Select the object you want to trim to. The

object must be a line, arc, circle or rectangle.
Also, the line must intersect the object. In the
following example, you would select the
circle as the object to trim to.

2. Right-click and select Trim.
3. Select the line you want to trim, clicking near

the end you want to trim.

The line is trimmed automatically to the nearest
border.

In the above example, if you clicked on the center
of the line, the portion inside the circle would be
trimmed:

Breaking a Line in Model View
You can break a line into two separate lines using the
Break tool.
To break a line:
1. Click on the line to select it.

2. Right-click and select Break.

3. Click the point on the line where you want to
break it. The line is broken at the selected
point.

Drawing Arcs in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

There are three Arc tools available in Model View:

Start, Center, End. When you specify the start and
center points, you define the arc’s radius. The end
point establishes the arc’s length.

3 Points. Select a start point for the arc, a second
point along the arc, then drag the arc into position as
you specify the end point.

Start, End, Radius. Select the start and end point of
the arc to define its length, then select a third point to
define the arc’s radius (curve).
To draw an arc with the Start, Center, End tool:
1. Select Tools > Layout > Arc > Arc - Start,

Center, End, or click the down arrow next to
the Arcs button on the Layout toolbar
and select Arc - Start, Center, End.

2. Select a start point for the arc.

3. Select the arc’s center point. The radius is
now defined.

4. Select the arc’s end point to define the arc's
length.

5. Right-click and select Finish.
To draw an arc with the 3 Points tool:
1. Select Tools > Layout > Arc > Arc - 3 Points,

or click the down arrow next to the Arcs but-

ton on the Layout toolbar and select Arc
- 3 Points.

2. Select the start point of the arc.

3. Select a second point on the arc.
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4. Drag the arc to stretch it to the desired length
and position, then select the end point of the
arc.

5. Right-click and select Finish.
To draw an arc with the Start, End, Radius tool:
1. Select Tools > Layout > Arc > Arc - Start,

End, Radius, or click the down arrow next to
the Arcs button on the Layout toolbar
and select Arc - Start, End, Radius.

2. Select the start point of the arc.

3. Select the end point of the arc to define its
length.

4. Move your pointer to curve the arc, then
select a third point to define the arc’s radius.

5. Right-click and select Finish.

Note: Arcs can only be drawn in 2D plan view.

Editing the Curve of an Arc in
Model View
You can change how much an arc curves by clicking
and dragging its center grip.
To edit the curve of an arc:
1. Click on the arc to select it.

2. Hover your pointer over the center grip, then
click and drag the handle to change the arc’s
curve.

Extending an Arc to Another
Object (Model View)
You can use the Extend tool to extend an arc to
another drafting object in your drawing.
To extend an arc to another object:
1. Select the object you want to extend to. The

object must be a line, arc, circle or rectangle.

It must also be in the path of the arc you
want to extend.

2. Right-click and select Extend.
3. Select the arc you want to extend, clicking

near the end that you want to extend. The arc
is extended to the object you selected.

Trimming an Arc to Another
Object (Model View)
If an arc passes through another drafting object, you
can use the Trim tool to trim the arc to the object it
intersects.
To trim an arc to another object:
1. Select the object you want to trim to. The

object must be a line, arc, circle or rectangle.
Also, the arc must intersect the object. In the
following example, you would select the rect-
angle as the object to trim to.

2. Right-click and select Trim.
3. Select the arc you want to trim, clicking near

the end you want to trim.

The arc is trimmed automatically to the nearest
border.

In the above example, if you clicked on the center
of the arc, the portion inside the rectangle would
be trimmed:
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Drawing Circles in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

There are two ways to draw a circle. With the Circle -
Center, Radius tool you draw the circle from the
center out, by picking two points to define its radius.
With the Circle - 2 Point tool, you draw the circle
outward from a selected point, essentially defining
the circle’s diameter.
To draw a circle by specifying its radius:
1. Select Tools > Layout > Circle > Circle -

Center, Radius, or click the down arrow next
to the Circles button on the Layout tool-
bar and select Circle - Center, Radius.

2. Click the point that is to be the center of the
circle.

3. Move your pointer away from the center
point. The circle grows as you move farther
away from the center.

4. When the circle is the desired size, click to fin-
ish.

5. Right-click and select Finish.
To draw a circle by specifying its diameter:
1. Select Tools > Layout > Circle > Circle - 2

Point, or click the down arrow next to the
Circles button on the Layout toolbar and
select Circle - 2 Point.

2. Click a point in the drawing. The circle will
grow from this point.

3. Move your pointer away from the selected
point. The farther you move away from this
point, the larger the circle becomes.

4. When the circle is the desired size, click to fin-
ish.

5. Right-click and select Finish.

Note: Circles can only be drawn in 2D plan view.

Creating Ellipses in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To draw an ellipse, select Tools > Layout > Ellipse,
then select either Ellipse - Axis or Ellipse - Center.
To use the Ellipse - Axis tool:
1. Select two points to define the major axis of

the ellipse.

2. Select a third point away from the axis to
define the minor radius.

3. Right-click and select Finish.

To use the Ellipse - Center tool:
1. Select the midpoint of the ellipse, then select

a second point to define the major radius of
the ellipse.

2. Select a third point to define the minor
radius.

3. Right-click and select Finish.
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Creating Elliptical Arcs in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To draw an elliptical arc, select Tools > Layout >
Ellipse, then select either Elliptical Arc - Axis or
Elliptical Arc - Center.
To use the Elliptical Arc - Axis tool:
1. Select two points to define the major axis of

the ellipse.

2. Select a third point away from the axis to
define the minor radius.

3. Select two points to define the end points of
the arc.

The section between the two points will form
the arc:

4. Right-click and select Finish.

To use the Elliptical Arc - Center tool:
1. Select the midpoint of the ellipse, then select

a second point to define the major radius of
the ellipse.

2. Select a third point to define the minor
radius.

3. Select two points to define the end points of
the arc.

The section between the two points will form
the arc:

4. Right-click and select Finish.

Drawing Rectangles in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can draw a rectangle easily by just picking two
points on the screen.
To draw a rectangle:
1. Select Tools > Layout > Rectangle, or click

on the Layout toolbar.

2. Click a point on the screen. This will be one
of the rectangle’s corners.

3. Move your pointer away from the current
point. The rectangle grows as you move
farther away.

4. When the rectangle is the desired size, click
to finish it.
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5. Right-click and select Finish.

Drawing Hatched Polygons in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Polygon Hatch tool to draw a
polygon of any shape with hatching of your choice
instantly applied. You can edit the shape, line style
and hatch pattern of the polygon after it has been
inserted.
To draw a hatched polygon:
1. Select Tools > Layout > Polygon Hatch, or

click on the Layout toolbar.

2. Select a start point for the polygon, then con-
tinue selecting points to define its shape.
Note that you do not have to select the start
point again, as the polygon always remains
closed as you draw it. Be careful not to cross
any lines, or the polygon will not be created.

3. Once you’ve selected the last point of the
polygon, right-click and select Finish.

Tip: If you don’t want your polygon to have
hatching, you can set its hatch properties to None.

Editing the Style of a Polygon's
Boundary Line (Model View)
When you draw a polygon, the boundary line uses
the default line style set for Drafting Objects in your
Drafting Settings. You can change the line style of a
polygon's boundary line after the polygon has been
inserted.
To edit the style of a polygon's boundary line:
1. Click on the edge of the polygon to select it.

2. Right-click and select Properties. The Poly-
gon Hatch dialog appears.

3. Click on Color, Line Type, or Line Weight to

change the individual line style properties.

4. Click OK to apply the changes.

Editing a Polygon's Hatch Pat-
tern in Model View
Once you have created a polygon, you can edit the
properties of the hatch pattern applied, or select a
different hatch pattern to apply.
To edit a polygon’s hatch pattern:
1. Click on the edge of the polygon to select it.

2. Right-click and select Properties.
3. In the Polygon Hatch dialog, click the Select

button in the Pattern area.

4. In the Patterns dialog, select the hatch pat-
tern you want to apply, then click OK. You
can add and edit patterns if you want.

5. Click OK. The polygon is automatically
updated.

Tip: If you don’t want the polygon to have
hatching, select 'None' in the pattern list.

Drawing Revision Clouds in
Model View
Revision clouds call attention to areas of change in
your drawing. You can quickly draw a revision cloud
around any portion of your drawing by simply
clicking a few points.
To draw a revision cloud:
1. Select Tools > Layout > Revision Cloud >

Revision Cloud, or click on the Layout
toolbar.

2. Pick points to form the outline of the cloud,
then hover your cursor over the start point to
close the shape. When picking points, be
careful not cross over any segments that you
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have already drawn.

Specifying Default Revision
Cloud Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can define the settings that you would like your
revision clouds to have prior to drawing them. You
can select a line style and hatch pattern, and define an
arc size.
To define revision cloud settings:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Revi-
sion Cloud in the left column.

3. By default, revision clouds are drawn on the
Drafting - Hatch layer. To select a different
layer, click the browse button next to the
Layer box, then select a layer from the Lay-
ers dialog.

4. To override the color, line type, or line
weight, click in the Color, Line Types, or
Line Weight box and make the desired selec-
tion.

5. To apply a pattern to revision clouds which is
visible in Patterned display mode, enable the
Include check box in the Pattern area. Click
Select in the Pattern area to select a pattern
from the Patterns library.

6. To define the size of the arcs in the revision
cloud, enter values in the Minimum Arc
Length and Maximum Arc Length edit
boxes..

7. Click OK.

Converting 2D Lines and
Shapes to 3D Building Elements
In Model View you can convert lines, arcs, circles,
rectangles and polygons to actual 3D building
elements such as walls, members, strip footings and
edging.
To convert lines and shapes to 3D building
elements:
1. Select the line or shape.

2. Right-click and select Convert To, or select
Edit > Modify Elements > Convert To. Then,
select the building element that you want to
convert the object to.

3. In the Catalog Access dialog, select the
material you want to use for the element,
then click OK. The object is instantly con-
verted.

Note: Circles and arcs cannot be converted to
members.

Drawing Batt Insulation in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add sections of batt insulation to a 2D view
by picking points to define the length and width of
the insulation detail.
To draw batt insulation in Model View:
1. Select Tools > Layout > Details > Batt Insu-

lation, or click the down arrow next to the
Details button on the Layout toolbar and
select Batt Insulation.

2. Click two points to define the length of the
insulation section, then move your pointer
away from the base line and click a third
point to define the width of the section.
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Drawing Rigid Insulation in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add sections of rigid insulation to a 2D view
by picking points to define the length and width of
the insulation detail.
To draw rigid insulation:
1. Select Tools > Layout > Details > Rigid Insu-

lation, or click on the Layout toolbar and
select Rigid Insulation.

2. Click two points to define the length of the
insulation section, then move your pointer
away from the base line and click a third
point to define the width of the section.

Drawing a Wood Section in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Wood sections can be used to represent blocking,
wood posts or other wood elements in a 2D view.
You can add a custom-sized wood section to a 2D
view by picking points to define its length and width.
To draw a wood section:
1. Select Tools > Layout > Details > Wood Sec-

tion, or click the down arrow next to the
Details button on the Layout toolbar and
select Wood Section.

2. Click two points to define the length of the
wood section, then move your pointer away
from the base line and click a third point to
define the width of the section.

Drawing a Masonry Section in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add a masonry section to a 2D view to
represent an area where brick, stone or concrete is
used. You create a masonry section by specifying the
dimensions of one masonry unit and joint, and then
picking points to define the length and direction of
the section.
To draw a masonry section:
1. Select Tools > Layout > Details > Masonry

Section, or click the down arrow next to the
Details button on the Layout toolbar and
select Masonry Section.

2. In the Masonry Section dialog, select either
Brick or Block to define how you want the
masonry to be represented graphically in the
section.

3. Specify the desired dimensions for each brick
and joint.

Masonry Height. The height of one masonry
unit (e.g. brick) in the section.

Masonry Width. The width of each masonry
unit in the section.

Joint Height. The distance between masonry
units.

Joint Width. The offset of the mortar from
the face of the masonry units.

4. Click OK.
5. In your drawing, click two points to define

the length of the masonry section, keeping in
mind that the line you are defining will rep-
resent the exterior face of the masonry. Then,
move your pointer away from the base line
and click a third point to define the direction
of the section relative to the base line.
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Editing Masonry Section Prop-
erties in Model View
Once you have created a masonry section, you can
edit the dimensions of the masonry units and joints
by accessing the masonry section properties.
To edit masonry section properties:
1. Click on the masonry section to select it.

2. Right-click and select Masonry Section Prop-
erties.

3. In the Masonry Section Properties dialog,
edit the values as desired.

Masonry Height. The height of one masonry unit
(e.g. brick) in the section.

Masonry Width. The width of each masonry unit
in the section.

Joint Height. The distance between masonry
units.

Joint Width. The offset of the mortar from the
face of the masonry units.

4. Click OK.

Drawing a Cut Line in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A cut line is a standard drafting symbol used to
represent a break in the drawing. It indicates that the
object continues in the same manner after or between
the break lines. You can add a cut line to a 2D view
by picking points to define the length and extent of
the cut line.
To draw a cut line:
1. Select Tools > Layout > Details > Cut Line,

or click the down arrow next to the Details

button on the Layout toolbar and select
Cut Line.

2. Click two points to define the length of the
cut line, then move your pointer away from
the base line and click a third point to define
the extent of the break symbol’s sharpness.

Inserting Views in Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Insert View tool to insert different
views of your drawing into one Model View window.
For example, you could insert four different
elevations into a view window to simulate a typical
drawing sheet.

You can insert a 2D plan view, elevation, section, 3D
camera view, or 3D QuickView. When you insert a
view, it is inserted as a 2D image (even if the view is a
3D view), and is only visible in 2D plan view. The
image can be moved once it has been inserted, but
you cannot change the appearance of its contents.
To insert a view:
1. Make sure the view window into which you

want to insert the view is the current view
window.

Note: The view in the view window must be a 2D
plan view. Otherwise, the Insert View tool is
unavailable. If you do not want the 2D plan view
displayed, use the Display None option in the View
Filter.

2. Select Tools > Layout > Insert View, or click
on the Layout toolbar.

3. In the Insert View dialog, select the tab con-
taining the type of view you want to insert
(2D, 3D, elevation, etc.).

4. Select the specific view you would like to
insert (e.g. Front Elevation).

5. For all view types except 3D camera views
you can specify a scale for the inserted view
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in the Properties area. The scale is the ratio of
units on paper to real-world units. If the scale
is set to 1:1 (12" = 1'- 0"), twelve inches on
paper will represent one foot of your model.
This would be a rather large printout. A scale
of 1:12 (1" = 1'- 0"), however, would result in
a smaller-scale view when the drawing is
printed because every foot is represented by
only one inch on paper.

6. If you are inserting an elevation or section, a
Datum Lines pane appears in the dialog:

If you want datum lines to be inserted at key
points in the elevation or section, select Yes
from the Include Datum Lines drop box.
Otherwise, select No.
If you are including datum lines:

In the Datum Line Placement section, select
the points at which you want a datum line to
be placed (Grade, Grade Level, Floor Level,
etc.) by selecting Yes next to each one that
you want to include.

NOTE: Grade Level is taken directly from
Settings>Document Settings> Terrain> Grade
Level. The height reported there will be the
height above sea level (ABS) listed in the
datum information. If you have left it at 0"
you can elect to show Grade but set Grade
Level to No so the height doesn't appear.

If the elevation or section shows more than
one location:

If the elevation or section shows more than
one location:

In the Include Locations section, select the
locations where you would like datum lines
to be displayed by selecting Yes next to each
desired location.

To define the appearance of the datum lines,
datum marks, leader lines and text, click
Settings. See Defining the Appearance of Datum
Lines in Elevations and Sections on page 303.

7. In the Insertion area, select the format in
which you want the view to be inserted. The
Image option inserts a raster image, or bit-
map, which can be resized once inserted. You
can also change the display mode of a raster
image to rendered, rendered outline, or pat-
terned. The Drawing option inserts a vector
image. Vector data provides useful inform-
ation about the geometry in a drawing, such
as endpoints, curves and polygons. Vector
images are displayed in wireframe or hidden
line display mode.

8. To filter elements from the view that you are
inserting, click below the preview win-
dow.

9. To change the display mode of the view, click
, then selected the desired display mode.

Choices are Wireframe, Hidden Line,
Rendered, Rendered Outline and Patterned.
Note that if the Drawing option is selected in
the Insertion area, the image will only appear
in wireframe or hidden line display mode
when inserted.

10. To zoom or pan the view in the preview win-
dow, use the zoom/pan tools below the pre-
view window.
To zoom in by increments:
1. Click below the view map win-

dow.
To zoom out by increments:
1. Click .

To zoom in and out in real time:
1. Click .

2. To zoom in, click and drag toward
the top of the screen.

3. To zoom out, click and drag toward
the bottom of the screen.
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4. When the view is the desired size,
release your mouse button.

Tip: You can also zoom in and out using the
scroll button on your mouse.
To zoom a selected area:
1. Click . Your cursor becomes a

magnifying glass.

2. Click and drag a selection window
around the area you want to mag-
nify.

To zoom to the extents of the view map
window:
1. Click .

To pan (shift) the view:
1. Click .

2. Click and hold your mouse button in
the view map window.

3. Drag the view in the direction you
want to pan.

4. Release the mouse button.
To zoom back to the previous view:
1. Click .

2. Click Insert. The image is attached to
your cursor.

3. Click to insert the view image where
you want it. You can move and
stretch the image later if you want.

Resizing a Model View Image (in
Model View)
If a view of the model has been imported into a
Model View window, you can resize the inserted
image by clicking and dragging its corner grab
handles. This shrinks or enlarges the view depending
on the direction in which you stretch.

Note: If the Drawing insertion option was selected
when the view was inserted, it is considered a
vector image and cannot be resized. You can only
resize views that were inserted with the Image
insertion option selected.

To resize an imported view image:
1. Click on the image to select it. Its bounding

box is highlighted, and blue grips appear at

the corners and center.

2. Hover your pointer over a corner grip to dis-
play the Stretch cursor.

3. Click and drag to stretch the view, then
release your mouse button.

Importing CAD Files in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Import CAD File tool lets you bring an AutoCAD
DWG or DXF file into your project as a 2D image.
You may, for example, want to bring in a drawing
sheet border, title block, drafting symbol, or detail.
You can define the size and angle of the imported
block prior to importing it.
To import a CAD file in Model View:
1. In Model View, select Tools > Layout >

Import CAD File, or click on the Layout
toolbar. You can also select File > Import >
Import CAD File.

2. In the Open dialog, select the type of file you
want to import from the Files of type drop
box.

3. Select the file you want to import, then click
Open.

4. In the Component Options dialog, specify
how you would like colors and linetypes to
be displayed. If By Layer is selected, the res-
ulting image will use the colors and linetypes
assigned to the layers of the CAD drawing. If
By Color is selected, it will use the colors and
linetypes of individual entities in the CAD
drawing.

5. Click OK. The image is displayed in the
Import dialog. You can zoom and pan in the
preview pane using the zoom/pan controls
below the pane. Note that changing the zoom
level inside the preview pane has no effect on
the image when it is imported.
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6. If the document has more than one page,
navigate to the page that you want to import
by clicking the buttons in the Page area of the
Import dialog.

7. Before importing the image you will need to
define the size or scale of the imported image.

Initially the size of the image is the same as
the size in the CAD file. You can set a custom
size by editing the values in the Width and
Height edit boxes. When you do so, the
Scale values adjust accordingly.
If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit boxes. For example, if the plan
was drawn at a 1/4" = 1'-0" (1:48) scale, you
would enter 48 in the Scale (X) or Scale (Y)
edit box. There are separate X and Y
(horizontal and vertical) scale settings. By
default, whatever you enter in one edit box
will automatically be displayed in the other
edit box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale

(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.

Another way of specifying the scale is to
draw a reference line along an existing object
in the CAD image and specify the length of
that object in real-world units. To do this,
click the Pick Scale button next to the
Scale (X)or Scale (Y) edit box, then pick two
points along an object in the CAD image to
define a reference line. (If the X scale and Y
scale will differ, you should pick points along
a horizontal object for the X scale, and pick
points along a vertical object for the Y scale.)
Then in the Scale by Reference dialog, enter
the length of the reference line and click OK.
For example, if you know that a particular
wall in your plan is 12' long, draw a line
along that wall and then enter 12' in the
Scale by Reference dialog.

The Scale values in the Import dialog will
then adjust to reflect the scale you defined.

8. To specify the angle of the imported image,
enter a value in the Angle edit box, or click

Pick Angle button next to the Angle
edit box and pick two points along an object
in the CAD image to define the angle. If you
are picking points to define the angle, the
Angle by Reference dialog appears and
reports the angle that you defined. You can
edit the angle here if you want.

9. If you want to import only a portion of the

image, click under the Crop Box
option, then click two points diagonally in
the preview window to define a box around
the portion that you want to import. A blue
box is displayed around the selected portion.

To remove the crop box, click ,
then click OK to confirm that you want to
clear the crop box.

10. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
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higher the percentage, the more dim the
image will be.

11. If you want the Import dialog to appear again
after you insert the image so that you can
insert another image, enable the Multiple
Insert check box.

12. To import the image into the current view
window, click Insert. The image is attached
to your cursor.

13. Position the image where you want it, then
click to insert it.

Tip: For your convenience, there are also a number
of pre-defined drafting symbols, details and title
blocks in DWG format available in the program’s
Drafting Objects directory.

Specifying a Default Drafting
Objects Directory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When you use the Import CAD File tool, you are
prompted to select a DWG or DXF file to open. By
default, the program’s Drafting Objects folder is
displayed in the Open dialog, where you can find a
number of pre-defined drafting symbols and title
blocks. This folder is in the following location:

C:\ProgramData\Cadsoft\Envisioneer\Drafting
Objects

You can specify a different default directory to
display if you want.
To specify a default drafting objects directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select the
General tab.

3. In the File Paths area, scroll down and select
the Drafting Settings Directory.

4. Click Modify.
5. In the Browse for Folder dialog, locate and

select the directory you want to use as the
default drafting objects directory, then click
OK.

6. Click OK in the Program Settings dialog.

Importing a PDF File in Model
View
Building Essentials | Construction Suite

You can use the Import PDF File to import the
contents of any PDF file into your Envisioneer project.
You can define the size and angle of the imported
block prior to importing it. If the PDF contains a floor
plan, you can scale the plan to the correct size upon
import, then trace the imported plan using building
tools such as the Walls tool to create an accurate 3D
model in Envisioneer.
To import a PDF file in Model View:
1. Select File > Import > Import PDF File, or

Tools > Layout > Import PDF File, or click
on the Layout toolbar.

2. In the Open dialog, locate and select the PDF
file that you want to import, and then click
Open. (If the Font Support Issue dialog
appears, see the note below.)

The PDF file is displayed in the Import
dialog. You can zoom and pan in the PDF
preview pane using the zoom/pan controls
below the pane. Note that changing the zoom
level inside the preview pane has no effect on
the image when it is imported.

3. If the PDF has more than one page, navigate
to the page that you want to import by
clicking the buttons in the Page area of the
Import PDF dialog.
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4. Before importing the PDF you will need to
define the size or scale of the imported image.
This is especially important if you are
importing a floor plan because you want the
walls to be the correct length when you trace
them.

Initially the size of the image is the same as
the page size in the PDF file. You can set a
custom size by editing the values in the
Width and Height edit boxes. When you do
so, the Scale values adjust accordingly.
If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit boxes. For example, if the plan
was drawn at a 1/4" = 1'-0" (1:48) scale, you
would enter 48 in the Scale (X) or Scale (Y)
edit box. There are separate X and Y
(horizontal and vertical) scale settings. By
default, whatever you enter in one edit box
will automatically be displayed in the other
edit box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale
(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.

Another way of specifying the scale is to
draw a reference line along an existing object
in the PDF image and specify the length of
that object in real-world units. To do this,
click the Pick Scale button next to the
Scale (X)or Scale (Y) edit box, then pick two
points along an object in the PDF image to
define a reference line. (If the X scale and Y
scale will differ, you should pick points along
a horizontal object for the X scale, and pick
points along a vertical object for the Y scale.)
Then in the Scale by Reference dialog, enter
the length of the reference line and click OK.
For example, if you know that a particular
wall in your plan is 12' long, draw a line
along that wall and then enter 12' in the
Scale by Reference dialog.

The Scale values in the Import dialog will
then adjust to reflect the scale you defined.

5. To specify the angle of the imported image,
enter a value in the Angle edit box, or click

the Pick Angle button next to the Angle
edit box and pick two points along an object
in the PDF image to define the angle. If you
are picking points to define the angle, the
Angle by Reference dialog appears and
reports the angle that you defined. You can
edit the angle here if you want.

6. If you want to import only a portion of the

image, click next to the Crop Box
item, then click two points diagonally in the
PDF window to define a box around the por-
tion that you want to import. A blue box is
displayed around the selected portion. To

remove the crop box, click , then
click OK to confirm that you want to clear the
crop box.

7. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
higher the percentage, the more dim the
image will be.

8. To import the file as an image with no vector
information, make sure that theConvert to
Image check box is enabled. This option is
particularly useful for large files that take a
long time to open. If this option is enabled
you can adjust the quality of the resulting
image by dragging the Quality slider to the
desired position. Note that increasing the
quality may also increase the time needed to
load the image.

Note: If the PDF is converted to an image,
you will not be able to snap to points on
the image like you can on a vector-based
PDF.
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9. If you want the Import dialog to appear again
after you insert the PDF so that you can insert
another PDF, enable the Multiple Insert check
box.

10. To import the image into the current view
window, click Insert. The image is attached
to your cursor.

11. Position the image where you want it, then
click to insert it.

Note: If the PDF file that you are importing
contains fonts that are not available on your
computer, the Font Support Issue dialog will
appear. Before importing the PDF, you need to
specify how you want to handle this issue.

You can choose to rasterize the text by selecting the
Raster Format option. This maintains the display
of the text, but you will not be able to snap to
linework once the PDF is inserted in your project. If
you choose the Vector Format option, all vector
geometry will remain intact so that you can snap to
linework once the PDF is inserted, but the text may
not display properly.

Tip: If the PDF is a vector PDF (one that was
generated from vector-based design software), you
can snap to points on the imported plan while
tracing. Note that the Ortho snap takes precedence
over the Object Snap when tracing to facilitate the
creation of straight lines.

Tip: You can hide the imported image from view
by disabling the visibility of Drafting objects in
your View Filter.

Displaying_Hiding_Drafting_Objects.htm
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Worksheet View is a powerful, 2D production drafting module. Here you can find all of the drawing and editing
tools needed to create fast, accurate, detailed working drawings.

Selecting a Worksheet View tab below the drawing area takes you directly into Worksheet View. There are a number
of pre-defined Worksheet View windows available, and you can create more if needed.

The pre-defined Worksheet View windows contain a generic border and title block. You can delete the border/title
block if you do not want to use it, or customize it to suit your needs. You can also use the Import CAD File tool to
insert one of the pre-defined title blocks in the program's Drafting Objects folder, or your own title block in DWG or
DXF format. You can also use the Import Image tool to insert a BMP, JPG or TGA image, such as a company logo.

Once your drawing border is in place, you can use the Define SmartView tool to insert a view of your model onto
the worksheet. You can insert 2D Plan Views, 3D Camera Views, 3D QuickViews, Elevations and Sections.

Once you have inserted a view you can begin annotating it. You can add text, dimensions, lines, shapes, hatching,
details (such as insulation) and symbols.

If your worksheet has content that you want to reuse in other projects, you can capture it in a block using the Define
Block tool. You can even attach user-defined attributes to blocks for maximum versatility and control.

All objects drawn in Worksheet View are drawn on layers. This provides you with control over line types, line
weights and colors, and whether or not objects can be seen, selected or plotted.

Tip: There are three powerful dimensioning tools available in Model View that you may want to use before
inserting 2D plan views in Worksheet View. These are Auto Exterior Dimensions, Auto Interior Dimensions, and
Room Dimensions.

Worksheet View
When you open a new project, a Model View window is displayed. This is where you build, edit and view your 3D
model.

When you switch to a Worksheet View window, you go directly into 2D drafting mode. The Worksheet View
interface is different than the Model View interface. It offers a number of different drafting tools that help you create
professional-looking working drawings. You can start by inserting a view of your model with the Define SmartView
tool, such as a floor plan or elevation. You can then edit and annotate the drawing to suit your documentation
needs.

Switching to Worksheet View
Express | Pro Architect | Building Essentials | Construction Suite

Once you have created your model you can begin creating your construction documents. Envisioneer offers a
complete 2D drafting mode called Worksheet View. To enter Worksheet View you need to open a Worksheet view
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window using the view tabs or the Window menu.
You can also open Worksheet View windows from
the View Manager.

A number of Worksheet view windows have been
pre-defined for you, such as Floor Plan, Elevations
and Details.
To switch to Worksheet View:
1. Select a view tab below the drawing area that

represents a Worksheet View window, or
click on the Window menu and select the
desired view.

You can also access a Worksheet View window
through the View Manager.

The Worksheet View Envir-
onment
Express | Pro Architect | Building Essentials |
Construction Suite

The layout of Worksheet View is similar to the layout
you see in Model View. There is a title bar, menu bar
and toolbar area at the top of the screen.

Below the drawing area you will see the view tabs
that let you switch between view windows, the View
toolbar, and the Commander. At the bottom of the
screen you can see the same status bar available in
Model View.

In Worksheet View, the information panel on the
right side of the screen displays Object Properties.

Insert Toolbar
The Insert toolbar provides access to a number of
powerful, automated tools that will help you get your
worksheet started. Use the SmartView tools to define
and insert a view of your 3D model, whether it be a
2D plan, elevation, section, or 3D view. If your model
changes you can instantly update the views on your
worksheets to reflect the changes. Using the Import
CAD File tool you can insert title blocks, details and
symbols that are in DWG or DXF format. Use the
Import PDF tool to bring in a PDF file, scaled and
rotated as desired. With the Import Image tool you

can bring in any image in JPG, BMP or TGA format,
such as a company logo. To save time you can use the
Define Block tool to capture a group of objects in a
block that can be saved and then inserted on other
worksheets.

Draw Toolbar
The Draw toolbar contains a number of drafting tools:
Line, Polyline, Circle, Arc, Polygon, Boundary Hatch,
Rigid Insulation, Batt Insulation, Wood Section,
Masonry Section and Cut Line.

Modify Toolbar
The Modify toolbar contains a wide variety of tools
for editing objects in your drawing: Delete, Move,
Rotate, Duplicate, Array, Offset, Stretch, Scale, Mirror,
Break, Extend, Trim, Fillet, Join Polyline, and Explode.

Tools Toolbar
Insert pre-defined labels or custom Text, as well as
Linear, Aligned and Angular Dimensions. Build on
existing dimensions using the Continuous, Baseline
and Overall Dimension tools, and edit dimensions
using the Align, Join and Split Dimension tools. Use
the Measure tool to quickly determine the distance
between any two points.

Properties Toolbar
The Properties toolbar indicates the current layer, and
the color, line type and line weight assigned to that
layer. You can override layer settings by making
selections from the layer setting drop boxes. The
toolbar also provides access to the Layer Properties
dialog.
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View Toolbar
The View toolbar contains a complete set of zoom and
pan tools: Zoom In, Zoom Out, Zoom Realtime, Zoom
Window, Zoom Previous, Zoom to Fit, and Pan.

Drawing Area
By default, the drawing area displays a virtual piece
of paper with a shadow behind it. This represents the
paper size set in the view's Print Properties. If you
change the paper size selection in the view's Print
Properties, the virtual sheet of paper will update to
reflect the new size. Having the virtual paper
displayed enables you to see how the worksheet
content will appear on the printed page. If you want
you can disable the virtual sheet of paper to create a
standard look where a solid background is displayed
throughout the entire drawing area.

By default, print margins are marked with a dotted
line if you have your virtual paper enabled. These are
the print margins set in the properties of the printer
that is currently selected for the view. You can disable
the display of the print margin lines if you want.

Each pre-defined worksheet contains a sample
drawing sheet border that you can delete or edit to
suit your needs. You can insert any pre-defined or
custom title block, as well as various views of your
model. From there you can edit, detail and annotate
your drawing to create a detailed, accurate
construction document.

Crosshairs, Pickbox and Cursor
In Worksheet View you see crosshairs, which are lines
that represent the two coordinate axes. At the center
of the crosshairs is a pickbox, a square used for
selecting objects. When you move your pointer
outside the drawing area you see a cursor, an arrow
for accessing menus and toolbars. The cursor can also
become a double-headed arrow when resizing
windows.

Object Properties Panel
The Object Properties panel displays the properties of
the currently selected object, such as the layer it is
assigned to. You can edit properties by simply
making different selections in the panel.

Controlling the Display of the
Paper Shadow in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

By default, a virtual sheet of paper with a shadow
behind it is displayed in the drawing area in
Worksheet View. This piece of paper represents the
paper size selection in the view's Print Properties.
Having the virtual paper displayed lets you see how
the worksheet content will fit and appear on the
printed page. You can disable the virtual paper
display if you want to create a standard look where a
solid background is displayed throughout the entire
drawing area.
To control the display of the paper shadow:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Worksheet View Behavior area, check or
uncheck the Enable Paper Shadow check
box.

4. Click OK.

Controlling the Display of Page
Margin Lines in Worksheet View
Pro Architect | Building Essentials | Construction Suite

By default, dashed lines are displayed on the virtual
paper in Worksheet View to show you where the
page margins are. Page margins denote the areas of
the paper (along the borders) in which the printer will
not print any content (i.e. the non-printable areas). Page
margins are set in the properties of the printer that is
selected for each view.
To control the display of page margin lines:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.
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3. In the Worksheet View Behavior area, check or
uncheck the Enable Page Margin Lines
check box.

4. Click OK.

Note: Page margin lines can only be displayed if
your paper shadow is enabled.

Layer Control
Express | Pro Architect | Building Essentials |
Construction Suite

Layers are like the overlays used in paper-based
drafting. They are used to organize the content of a
drawing and group information by function. For
example, you may have a layer dedicated to text and
dimensions, and another specifically for your title
block.

All objects in Worksheet View are drawn on layers.
As you draw, new objects are placed on the current
layer. There are several pre-defined layers available in
Worksheet View that you can use. You can edit the
properties of these layers, or create new ones.

By placing objects on layers you can determine the
following:
l Whether objects on a layer are visible
l Whether objects on a layer can be selected for
editing

l What color, line type and line weight is
assigned to objects on a layer

l Whether objects are plotted
l Whether objects on the layer will appear in
front of or behind objects on other layers

Selecting a Layer to Draw On
Express | Pro Architect | Building Essentials |
Construction Suite

Before you draw or insert an object in Worksheet
View, you should select a layer to put it on.
To quickly select a layer:
1. Click the layer drop box on the Properties

toolbar and select the layer you want.
To make a layer current in the Layer Properties
dialog:

1. Select View > Layer Properties, or click
on the Properties toolbar.

2. Select the layer that you want to make cur-
rent.

3. Click , or right-click and select
Set Current, or or click and
choose Set Current.

Creating a New Layer for the
Current Project
Express | Pro Architect | Building Essentials |
Construction Suite

You can easily create your own layers for the current
project and define their name, color, line type and line
weight. You can also control whether or not objects
on the layer are visible, selectable or plottable. Layers
created in Worksheet View are specific to the current
project, and will be available in all Worksheet Views
in the current project. If you want to create a layer
that can be used in other projects, add it to the Layers
Library instead.
To create a new layer for the current project:
1. In Worksheet View, select View > Layer Prop-

erties, or click on the Properties toolbar.

2. In the Layer Properties dialog, click ,
or right-click in the layer list and select Add.
You can also click and select
Add. A new layer called Layer 1 is added
below the currently selected layer.

3. To edit the name of the layer, click the cur-
rent name, then type the desired name and
press Enter. Or click and then
type the desired name.

4. To control the visibility of objects on the
layer, click the eye icon in the Display
column.

5. To control the selectability of objects on the
layer, click the layer’s filter icon in the
Selectable column.

6. To control whether or not objects on the layer
will be plotted, click the layer’s printer icon

in the Plot column to toggle plotting on
and off.
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7. To edit the default color assigned to the layer,
click inside the Color field, then make a selec-
tion from the list of colors. Or, select Other to
access the Colors dialog.

8. To edit the layer’s default line type assign-
ment, click inside the Line Type field, then
make a selection from the list of line types.
Or, select Other to access the Line Types dia-
log.

9. To edit the layer’s default line weight assign-
ment, click inside the Line Weight field, then
make a selection from the list of line weights.
Or, select Other to access the Line Weights
dialog.

10. Click OK.

Editing Layer Properties
Express | Pro Architect | Building Essentials |
Construction Suite

You can add, edit, rename and delete layers in the
current project. Layer properties include the layer
name, color, line type and line weight. You can also
specify whether or not a layer is visible, whether or
not it can be selected, and whether or not it plots. You
can change the display order priority of a layer, so
that objects on the layer appear in front of or behind
objects on other layers. You can edit the settings for
single layers or for multiple layers simultaneously.

Layers defined in Worksheet View are specific to the
current project, and any changes you make will apply
to all Worksheet Views in the current project. If you
want to define layers that can be used in other
projects, edit your Layers Library instead.
To edit layer properties in the current project:
1. In Worksheet View, select View > Layer

Properties, or click on the Properties
toolbar.

2. To rename a layer, select the layer in the list
and then click , or right-click and
select Rename. Type the new name, then
press Enter.

3. To add a layer, click , or right-click
and select Add. A layer named Layer 1 is
added to the list. You can edit the properties
of the layer to suit your needs.

4. To delete a layer, select the layer in the list
and then click , or right-click and
select Delete. You cannot a delete a layer that
currently has objects on it.

5. To edit a layer's properties, select the layer
that you want to edit. If you want to edit
multiple layers simultaneously, select the
layers that you want to edit using one of the
following methods:

To select a group of sequential layers, click on
the first layer in the group, then holding
down the Shift key select the last layer in the
group.

To select multiple layers one at a time, hold
down the CTRL key while selecting layers.

To select all layers, right-click in the layer list
and choose Select All, or click

and choose Select All.

To deselect all layers, right-click in the layer
list and choose Deselect All, or click

and choose Deselect All.

If you have some layers selected and want to
invert the selection so they are not selected
and all other layers are selected, right-click in
the layer list and select Invert Selection, or
click and select Invert
Selection.



- 298 -

6. Edit the settings as desired. You can simply
click inside a field to edit it, or if multiple lay-
ers are selected, use options such as Display,
Selectable, Plot, Set Color, Set Line Type
and Set Line Weight on the right-click menu
or the menu. If multiple lay-
ers are selected, the same change will apply
to all selected layers. Settings are described
below.
Display. Controls whether or not objects on
the layer are visible. Click the eye icon to
toggle visibility on or off.

Layer is visible

Layer is invisible

Selectable. Controls whether or not objects
on the layer can be selected. Click the filter
icon to toggle selectability on or off.

Objects on layer are selectable

Objects on layer are not selectable

Plot. Controls whether or not objects on the
layer will be plotted. Click the printer icon to
toggle the plot state on or off.

Objects on layer will plot

Objects on layer will not plot

Priority. The display order priority of the
layer. A layer with a higher number will
appear in front of a layer with a lower
number.

Color. The color of objects on the layer. Click
the box to display a list of colors. Select the
desired color, or select Other to access the
Color dialog.
Line Type. The style of line used to display
objects on the layer. Click the box to display a
list of line types. Select the desired line type,
or select Other to access the Line Types
dialog.

Line Weight. The weight of the line used to
display objects on the layer. Click the box to
display a list of line weights. Select the
desired line weight, or select Other to access
the Line Weights dialog.

7. Click OK.

Deleting a Layer
Express | Pro Architect | Building Essentials |
Construction Suite

You can delete unused layers from the layer list if you
like.
To delete a layer:
1. In Worksheet View, select View > Layer Prop-

erties, or click on the Properties toolbar.

2. In the Layer Properties dialog, click on the
layer that you want to delete.

3. Click , or right-click and select
Delete, or click and select
Delete. The layer is deleted.

Transferring an Object to
Another Layer
Express | Pro Architect | Building Essentials |
Construction Suite

In Worksheet View, you can transfer an object that
you have drawn to another layer by making a layer
selection on the Properties toolbar or in the Object
Properties panel.
To transfer an object to another layer:
1. Select the object.

2. In the Object Properties panel, select the layer
that you want to transfer the object to from
the Layer drop box. Or, select a layer from
the layer drop box on the Properties toolbar.

Note: Transferring an object to another layer does
not make that layer current.

Overriding Color, Line Type and
Line Weight
Express | Pro Architect | Building Essentials |
Construction Suite

By default, the color, line type and line weight
settings on the Properties toolbar are set to BYLAYER,
which means the color, line type and line weight of
new objects are determined by the settings of the
layer they are drawn on. For example, if a layer’s
color setting is red, objects drawn on that layer will be
red. If you select a specific color on the Properties
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toolbar, however, that color is used for all new
objects, overriding the default color for the current
layer. The same applies to line types and line weights.
l To override a layer setting before drawing an
object, make the desired color, line type or line
weight selection on the Properties toolbar.

l To edit an object’s color, line type or line
weight after it has been drawn, select the
object, then make the desired changes in the
Object Properties panel.

Controlling the Visibility of Lay-
ers
Express | Pro Architect | Building Essentials |
Construction Suite

You can make a layer visible or invisible by editing its
properties. Hiding layers can reduce the complexity of
a drawing by removing unnecessary objects from
view, without removing them from the drawing. You
may, for example, want to hide a layer containing
construction lines.
To control the visibility of layers:

1. Select View > Layer Properties, or click
on the Properties toolbar.

2. In the Layer Properties dialog, click the
layer’s eye icon in the Display column to
toggle visibility on and off.

Layer is visible

Layer is invisible

To toggle the visibility for multiple layers
simultaneously, select the layers and then right-
click and select Display, or click
and select Display.
To select multiple layers, hold down the
CTRL key while selecting layers. If you want to
select a group of sequential layers, select the first
layer in the group, then holding down the Shift
key, select the last layer in the group.

To select all layers, right-click in the layer list and
choose Select All, or click and
choose Select All.
To deselect all layers, right-click in the layer list
and choose Deselect All, or click

and choose Deselect All.

3. Click OK.

Note: Changes to layer visibility are per worksheet.

Controlling the Ability to Select
and Edit Objects on Layers
Express | Pro Architect | Building Essentials |
Construction Suite

You may have specific layers containing objects that
you do not want anyone to be able to edit. You can
determine whether or not objects on a layer are
selectable by editing the layer’s properties. This may
be particularly useful if the drawing is being shared
with other people.
To control the selectability of objects on a layer:
1. In Worksheet View, select View > Layer Prop-

erties, or click on the Properties toolbar.

2. In the Layer Properties dialog, click the
layer’s filter icon in the Selectable column to
toggle selectability on and off.

Objects on layer are selectable

Objects on layer are not selectable

To toggle the selectability of multiple layers
simultaneously, select the layers and then right-
click and select Selectable, or click

and select Selectable.

To select multiple layers, hold down the
CTRL key while selecting layers. If you want to
select a group of sequential layers, select the first
layer in the group, then holding down the Shift
key, select the last layer in the group.

To select all layers, right-click in the layer list and
choose Select All, or click and
choose Select All.
To deselect all layers, right-click in the layer list
and choose Deselect All, or click

and choose Deselect All.

3. Click OK.

Controlling Whether or Not a
Layer is Plotted
Express | Pro Architect | Building Essentials |
Construction Suite
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You can determine whether or not a layer is plotted
by editing the layer’s properties. If you turn off
plotting for a layer, the objects on that layer are still
displayed. However, if a layer is set to plot but is
currently turned off (invisible), the layer will not be
plotted.
To control a layer’s plot setting:
1. In Worksheet View, select View > Layer Prop-

erties, or click on the Properties toolbar.

2. In the Layer Properties dialog, click the
layer’s printer icon in the Plot column to
toggle plotting on and off.

Objects on layer will plot

Objects on layer will not plot

To toggle the plot setting for multiple layers
simultaneously, select the layers and then right-
click and select Plot, or click
and select Plot.
To select multiple layers, hold down the
CTRL key while selecting layers. If you want to
select a group of sequential layers, select the first
layer in the group, then holding down the Shift
key, select the last layer in the group.

To select all layers, right-click in the layer list and
choose Select All, or click and
choose Select All.
To deselect all layers, right-click in the layer list
and choose Deselect All, or click

and choose Deselect All.

3. Click OK.

Controlling the Display Order
Priority of Layers
Express | Pro Architect | Building Essentials |
Construction Suite

You can make objects on certain layers appear in front
of or behind objects on other layers. You can achieve
this by assigning numbers of priority to layers.
To control the display order priority of layers:
1. In Worksheet View, select View > Layer Prop-

erties, or click on the Properties toolbar.

2. In the Layer Properties dialog, click the
value in a layer’s Priority column, and then
enter the desired number of priority. A layer

with a higher number will appear in front of
a layer with a lower number.

3. Click OK.

Note: Changes to layer priority are per worksheet.

Using Object Snaps in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

Object snaps help you locate precise points on objects
when drawing and editing in Worksheet View,
without having to know their coordinates or draw
construction lines. For example, if you hover your
pickbox along a line, the pickbox will automatically
snap to the precise endpoints and midpoint of that
line as the pickbox nears those points. Envisioneer
displays a special marker whenever your pickbox
comes close to a snap point.

Worksheet View offers nine object snaps for
accurately locating precise points.

Endpoint. Snaps to the endpoint of an existing line or
arc.

Midpoint. Snaps to the midpoint of a line or arc.
Center. Snaps to the center point of an arc or circle.
Nearest. Snaps to a point on a line, circle, arc or other
object that is nearest to the center of the pickbox
(where the crosshairs intersect).

Intersection. Snaps to the point where objects cross
each other.

Insertion. Snaps to the insertion point of text, blocks,
imported model views, and imported CAD objects.

Perpendicular. Snaps to a point on a line, arc or circle
that forms a perpendicular from the current point to
the selected object.

Tangent. Snaps to a point on an object that forms a
tangent between the object and another point.

Quadrant. A quadrant is a section of an arc or circle.
This snaps to the 0-, 90-, 180- and 270-degree positions
on a circle or arc.
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Selecting the Objects Snaps
You Want to Use
Express | Pro Architect | Building Essentials |
Construction Suite

By default, all nine object snaps are active while you
are drawing and editing in Worksheet View. You can
disable selected object snaps if you want.
To select object snaps to use:
1. In Worksheet View, select Settings > Object

Snap Settings.
2. Uncheck the boxes of object snaps that you

do not want to use. Any that you want to use
should be checked.

Endpoint. Snaps to the endpoint of an
existing line or arc. 

Midpoint. Snaps to the midpoint of a line or
arc.

Center. Snaps to the center point of an arc or
circle.

Nearest. Snaps to a point on a line, circle, arc
or other object that is nearest to the center of
the pickbox (where the crosshairs intersect).

Intersection. Snaps to the point where
objects cross each other.

Insertion. Snaps to the insertion point of text,
blocks, imported model views, and imported
CAD objects.

Perpendicular. Snaps to a point on a line, arc
or circle that forms a perpendicular from the
current point to the selected object.

Tangent. Snaps to a point on an object that
forms a tangent between the object and
another point.

Quadrant. A quadrant is a section of an arc
or circle. This snaps to the 0-, 90-, 180- and
270-degree positions on a circle or arc.

3. Click OK.

Using a Specific Object Snap
(Snap Override)
Express | Pro Architect | Building Essentials |
Construction Suite

If while drawing or editing in Worksheet View you
want to use a specific object snap, you can
temporarily disable all active object snaps and select
the specific one that you want to use.
To use a specific object snap:
1. When you are ready to select a point, right-

click and select Snap Overrides, then select
the specific object snap that you want to use.

2. Select the point using the object snap.

Once you’ve used a snap override, all enabled objects
snaps become active again.

Turning Object Snaps On and
Off
If you do not want object snaps to be active while you
are drawing and editing, you can disable them.
To turn object snaps on and off:
l Press F5 on your keyboard, or
l Click the OBJSNAP button on the Status bar, or
l Select Settings > Program Settings, then on
the Drawing Aids pane, check or uncheck the
Enable (F5) check box in the Object Snap area

Inserting a SmartView of your
Model in Worksheet View
Pro Architect | Building Essentials | Construction Suite

Using the Define SmartView tool you can quickly
insert any view of the model you created in Model
View, including 2D Plan views, elevations, sections,
3D Camera views and 3D QuickViews. When you
insert a SmartView onto a worksheet the SmartView
and its settings are saved in memory so that you can
quickly insert the same view again onto other sheets
using the Insert SmartView tool. If you make changes
to your 3D model in Model View, you can choose to
instantly update your inserted SmartViews to reflect
the changes.
To insert a SmartView:
1. In Worksheet View, select Insert >

SmartViews > Define SmartView.
2. In the Insert View dialog, select the tab con-

taining the type of view you want to insert
(2D, 3D, elevation, etc.). The Name edit box
will be automatically populated with an
appropriate name (e.g. 2D Plan). If you have
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inserted this type of view before, a number
will be appended to the name to differentiate
it from previous SmartViews (e.g. 2D Plan 1).
You can edit the name if desired.

3. Select the specific view you would like to
insert (e.g. Front Elevation).

4. For all view types except 3D Camera views
you can specify a scale for the inserted view
in the Properties area. The scale is the ratio of
units on paper to real-world units. For
example, a 1/4" = 1'-0" scale means that every
foot of your actual is represented by 1/4" on
paper. When setting a scale for the
SmartView, consider the scale of the work-
sheet on which you are inserting the
SmartView.

5. If you are inserting an elevation or section, a
Datum Lines pane appears in the dialog:

If you want datum lines to be inserted at key
points in the elevation or section, select Yes
from the Include Datum Lines drop box.
Otherwise, select No.
If you are including datum lines:

In the Datum Line Placement section, select
the points at which you want a datum line to
be placed (Grade, Grade Level, Floor Level,
etc.) by selecting Yes next to each one that
you want to include.

NOTE:  Grade Level is taken directly from
Settings>Document Settings> Terrain> Grade
Level. The height reported there will be the
height above sea level (ABS) listed in the
datum information. If you have left it at 0"

you can elect to show Grade but set Grade
Level to No so the height doesn't appear.

If the elevation or section shows more than
one location:

If the elevation or section shows more than
one location:

In the Include Locations section, select the
locations where you would like datum lines
to be displayed by selecting Yes next to each
desired location.

To define the appearance of the datum lines,
datum marks, leader lines and text, click
Settings. See Defining the Appearance of
Datum Lines in Elevations and Sections on
page 303.

6. In the Insertion area, select the format in
which you want the view to be inserted. The
Image option inserts a raster image, or bit-
map, which can be resized once inserted, but
cannot be updated. The Drawing option
inserts a vector image that can be updated
with changes to your model. Vector data
provides useful information about the geo-
metry in a drawing, such as endpoints,
curves and polygons. Vector images are dis-
played in wireframe or hidden line display
mode.

7. To filter elements from the view that you are
inserting, click below the preview win-
dow.

8. To change the display mode of the view, click
, then selected the desired display mode.

Choices are Wireframe, Hidden Line,
Rendered, Rendered Outline and Patterned.
Note that the display mode tool is not avail-
able for 2D plan views. Also, if the Drawing
option is selected in the Insertion area, the
image will only appear in wireframe or hid-
den line display mode when inserted.

9. To zoom or pan the view in the preview win-
dow, use the zoom/pan tools below the pre-
view window.

Note: If you have inserted an elevation or section
and it appears as though some lines or faces are
missing, try disabling polygon consolidation in
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your program settings and then insert the
SmartView again. See Enabling/Disabling Polygon
Consolidation When Inserting a SmartView on page
303.

Inserting a Saved SmartView
Pro Architect | Building Essentials | Construction Suite

Every time you use the Define SmartView tool to
insert a SmartView of your model, the SmartView is
saved in memory so that you can quickly insert the
same view again onto other sheets using the Insert
SmartView tool.
To insert a saved SmartView:
1. In Worksheet View, select Insert >

SmartViews > Insert SmartView.
2. In the Insert SmartView dialog, select the

SmartView that you want to insert from the
top drop box.

3. Click OK.
4. Position the SmartView where you want it,

then click to insert it.

Note: If you are inserting the saved SmartView on
a worksheet that has a different scale than the
worksheet on which you originally inserted the
SmartView, the SmartView will appear to be
different in size than it did on the original
worksheet.

Enabling/Disabling Polygon Con-
solidation When Inserting a
SmartView
Pro Architect | Building Essentials | Construction Suite

Polygon consolidation combines individual polygons
and/or objects into a single object. By default, polygon
consolidation is enabled in your program settings.

If you insert a SmartView that is an elevation or
section view onto a worksheet and discover that
certain lines or faces are missing in the inserted view,
disabling polygon consolidation prior to inserting the
SmartView may resolve this issue.
To enable or disable polygon consolidation:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select Work-
space in the left pane.

3. In the Worksheet View Behavior area, check or
uncheck the Enable Polygon Consolidation
check box.

4. Click OK.

Note: Disabling polygon consolidation may cause
extraneous lines to be displayed in inserted
SmartViews. For example, you may see a line on
the exterior wall face where an interior wall
intersects it.

Defining the Appearance of
Datum Lines in Elevations and
Sections
Pro Architect | Building Essentials | Construction Suite

When inserting an elevation or section view onto a
worksheet, you have the option of including datum
lines at key points such as the Floor Level and Wall
Height of each location. Sample datum lines are
shown below.

Prior to inserting an elevation or section, you can
define the appearance of datum lines, leaders, marks
and text. You can also turn off individual components
if desired.
To define datum line properties:
1. If you are currently in the Insert View dialog,

click Settings in the Datum Lines pane on
the elevation view or section view tab. Other-
wise, select Settings > Document Settings
or click on the Settings toolbar, then select
Datum Lines in the Document Settings dia-
log.

2. You can define the following properties:
General

Layer. The drawing layer on which the
datum lines, marks and text will be placed.
The layer dictates the color, line type and line
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weight of datum and/or leader lines if By
Layer is selected for these settings in the
datum line properties.
Datum Marks

These are optional blocks that can be
displayed at the end(s) of each datum line.

Position. If including a block at the end of
datum lines, specify whether you want to
display the block at Both ends, the Left end
or Right end of the datum line.

Datum Block. To display a block at the end
of each datum line, select the desired block
from the drop box. If you do not want to
display a block, select None. The blocks in
the drop box are blocks that have been
created using the Define Block tool (see
Creating a Block on page 330).
Leader Lines

Leader lines extend from the ends of datum
lines (past the extents of the model). Leader
lines are optional and can have a different
appearance than that of the datum line. If
used, they are the lines along which the text
is placed.

Position. Specify whether you want to
display leader lines at Both ends, the Left
end or Right end of each datum line.

Length. The length of the leader line. If you
do not want to include leader lines, specify a
length of 0. Keep in mind that you can also
extend datum lines past the extents of the
model by specifying an Extension Distance
in the Datum Lines section.

Color. The color of the leader lines. If By
Layer is selected, the color is determined by
the layer selected in the Layer field.
Line Type. The style of the leader lines (solid,
dashed, etc.). If By Layer is selected, the line
type is determined by the layer selected in
the Layer field.
Line Weight. The thickness of the leader
lines. If By Layer is selected, the line weight
is determined by the layer selected in the
Layer field.
Datum Lines

Datum lines are lines that pass through the
model. Their display is optional. If used, they
can be extended past the extents of the
model.

Display. Select either On or Off to specify
whether or not you want datum lines
displayed.

Extension Distance. The distance by which
the datum lines extend past the extents of the
model.

Color. The color of the datum lines. If By
Layer is selected, the color is determined by
the layer selected in the Layer field.
Line Type. The style of the leader lines (solid,
dashed, etc.). If By Layer is selected, the line
type is determined by the layer selected in
the Layer field.
Line Weight. The thickness of the leader
lines. If By Layer is selected, the line weight
is determined by the layer selected in the
Layer field.
Text

Text can be optionally displayed at the end(s)
of datum lines. It can consist of a description
and/or elevation from grade.

Description. The location name. Specify
where you want to display the elevation text
relative to the leader line (Above-Right,
Below-Right, etc.). If you do not want to
display a description, select None.
Elevation. The height above grade. Specify
where you want to display the elevation text
relative to the leader line. If you do not want
to display elevation text, select None.
Style. The text style in which the text will be
displayed.

Alignment. The alignment of the text relative
to the leader line. Selecting Left or Right will
align the text with the left end or right end of
the leader line, while selecting Center will
center the text along the leader line.

Editing a SmartView
Express | Pro Architect | Building Essentials |
Construction Suite
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If you have inserted a SmartView on your worksheet,
you can edit the contents of the SmartView if needed.
You can edit its individual components (for example
move or delete lines or other objects), or add objects
to it. Any changes or additions you make are
automatically saved to the SmartView's definition, so
any future insertions of the SmartView will contain
your changes.
To edit a SmartView:
1. Double-click the inserted SmartView, or select

the SmartView and then click the Edit button
in the Definition field in the Object Properties
panel. Everything except the SmartView is
dimmed, indicating that you are now in
SmartView editing mode.

2. Make the desired changes or additions.

3. Press ESC to return to your worksheet.

Note: If you inserted your SmartView using the
'Image' option instead of the 'Drawing' option, in-
place editing is not available. However, you can
replace the image with another saved on your
computer. To do so, click the browse button in the
Object Properties panel.

Note: If you want your changes to apply to the
selected instance of the SmartView only and not
future insertions of the SmartView, explode the
SmartView and then make your edits. This leaves
its original definition intact. Note, however, that
the SmartView will no longer be linked to the 3D
model and can no longer be updated with changes
you make to the model.

Redefining a SmartView's Set-
tings
Pro Architect | Building Essentials | Construction Suite

If you have inserted a SmartView on a worksheet you
can change its settings using the Redefine SmartView
tool. You can change the scale of the SmartView,
change what is visible in the SmartView, or select
different content to display, such as a different
location in a 2D plan or a different view in an
elevation.
To redefine a SmartView's settings:

1. Select Insert > SmartViews > Redefine
SmartView.

2. Click on the edge of the inserted SmartView
to select it.

3. Define the desired settings for the SmartView
in the Redefine SmartView dialog.

4. Click Update to apply the new settings to the
inserted SmartView.

Updating a SmartView with
Changes to your Model
Express | Pro Architect | Building Essentials |
Construction Suite

If you make changes to your model in Model View
after you have inserted SmartViews of the model in
Worksheet View, you can use the Update SmartView
tool to instantly update a selected SmartView with the
changes. For example, if you add a window to the
model and then update a SmartView, the window
will then appear in the SmartView.
To update a SmartView:
1. In Worksheet View, select Insert >

SmartViews > Update SmartView. (In
Express, use the Tools menu.)

2. Click on the edge of the SmartView to select
it. The SmartView is instantly updated.

Note: Currently you cannot update 3D views of
your model or any view that was inserted using the
'Image' option instead of the 'Drawing' option.

Note: When you update a SmartView, you are
changing its definition. This means that all inserted
instances of the SmartView will update on all
worksheets.

Tip: If you have several different SmartViews that
you want to update with changes to your model,
use the Update SmartView (Global) tool, which lets
you update multiple SmartViews simultaneously.

Updating SmartViews Globally
Express | Pro Architect | Building Essentials |
Construction Suite
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If you make changes to your model in Model View
after you have inserted SmartViews of the model in
Worksheet View, you can use the Update SmartViews
(Global) tool to instantly and simultaneously update
multiple inserted SmartViews with the changes you
made. When using this tool and can choose which
SmartViews you want to update.
To update SmartViews globally:
1. In Worksheet View, select Insert >

SmartViews > Update SmartViews (Global).
(In Express, use the Tools menu.)

2. In the Update SmartViews dialog, check the
boxes of the SmartViews that you want to
update. Note that all inserted instances of a
selected SmartView will update on all work-
sheets.

3. Click Update.

Note: Currently you cannot update 3D views of
your model or any view that was inserted using the
'Image' option instead of the 'Drawing' option.

Deleting Unreferenced
SmartViews from Memory
Pro Architect | Building Essentials | Construction Suite

When you insert a SmartView in your drawing, a
block of that SmartView is stored in memory, and the
inserted SmartView references that stored block. If you
delete an inserted SmartView from your drawing, the
block that it references remains in memory. Having
too many unreferenced SmartViews in your project
can increase drawing file size. You can alleviate this
problem by deleting unreferenced SmartViews from
memory.
To delete unreferenced SmartViews:
1. In Worksheet View, select Insert >

SmartViews > Delete Unreferenced
SmartViews.

2. If there are any unreferenced SmartViews in
memory, they are listed in the Delete Unrefer-
enced SmartViews dialog. Check the ones
that you want to delete. You can select all
SmartViews simultaneously by clicking the
top check box beside the SmartView
Namelabel.

3. Click . A dialog warns you that
you will not be able to undo changes to your
drawing since your last save if you proceed
with deleting unreferenced items.

4. Click OK in the dialog to proceed with the
deletion.

Customizing the Default Title
Block
Express | Pro Architect | Building Essentials |
Construction Suite

When you open one of the pre-defined Worksheet
View windows, a generic drawing sheet border and
title block are displayed. You can edit the border or
title block to suit your needs.
To customize the default title block:
1. Click on the border to select the border and

title block.

2. In the Object Properties panel, click the Edit
button in the Definition field.
You can now select individual parts of the border
or title block to edit them, or add objects to the
title block. Changes are saved automatically to
the block definition.

Deleting the Default Drawing
Border and Title Block
Express | Pro Architect | Building Essentials |
Construction Suite

In Worksheet View, if you do not want to use the
default drawing sheet border and title block, you can
delete them.
To delete the default drawing border and title
block:
1. Click on the border to select it.

2. Press the Delete key on your keyboard, or
select Modify > Delete.

Importing CAD Files in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

The Import CAD File tool lets you insert any
AutoCAD DWG or DXF file into your worksheet view
window. You may, for example, want to bring in a
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drawing sheet border, title block, detail or drafting
symbol. You specify the scale of the drawing prior to
insertion.
To import a CAD file:
1. In Worksheet View, select Insert > Import

CAD File, or click on the Insert toolbar.
You can also select File > Import > Import
CAD File.

2. In the Open dialog, select the type of file you
want to import from the Files of type drop
box.

3. Select the file you want to import, then click
Open.

4. Click OK. The image is displayed in the
Import dialog. You can zoom and pan in the
preview pane using the zoom/pan controls
below the pane. Note that changing the zoom
level inside the preview pane has no effect on
the image when it is imported.

5. If the document has more than one page,
navigate to the page that you want to import
by clicking the buttons in the Page area of the
Import dialog.

6. Before importing the image you will need to
define the size or scale of the imported image.

Initially the size of the image is the same as
the size in the CAD file. You can set a custom
size by editing the values in the Width and
Height edit boxes. When you do so, the
Scale values adjust accordingly.
If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit boxes. For example, if the plan
was drawn at a 1/4" = 1'-0" (1:48) scale, you
would enter 48 in the Scale (X) or Scale (Y)
edit box. There are separate X and Y
(horizontal and vertical) scale settings. By
default, whatever you enter in one edit box
will automatically be displayed in the other
edit box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale
(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.

Another way of specifying the scale is to
draw a reference line along an existing object
in the CAD image and specify the length of
that object in real-world units. To do this,
click the Pick Scale button next to the
Scale (X)or Scale (Y) edit box, then pick two
points along an object in the CAD image to
define a reference line. (If the X scale and Y
scale will differ, you should pick points along
a horizontal object for the X scale, and pick
points along a vertical object for the Y scale.)
Then in the Scale by Reference dialog, enter
the length of the reference line and click OK.
For example, if you know that a particular
wall in your plan is 12' long, draw a line
along that wall and then enter 12' in the
Scale by Reference dialog.
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The Scale values in the Import dialog will
then adjust to reflect the scale you defined.

7. To specify the angle of the imported image,
enter a value in the Angle edit box, or click

Pick Angle button next to the Angle
edit box and pick two points along an object
in the CAD image to define the angle. If you
are picking points to define the angle, the
Angle by Reference dialog appears and
reports the angle that you defined. You can
edit the angle here if you want.

8. If you want to import only a portion of the

image, click next to the Crop Box
item, then click two points diagonally in the
preview window to define a box around the
portion that you want to import. A blue box
is displayed around the selected portion. To

remove the crop box, click , then
click OK to confirm that you want to clear the
crop box.

9. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
higher the percentage, the more dim the
image will be.

10. If you want the Import dialog to appear again
after you insert the image so that you can
insert another image, enable the Multiple
Insert check box.

11. To import the image into the current view
window, click Insert. The image is attached
to your cursor.

12. Position the image where you want it, then
click to insert it.

Tip: For your convenience, there are also a number
of pre-defined drafting symbols, details and title
blocks in DWG format available in the program’s
Drafting Objects directory.

Importing a PDF File in Work-
sheet View
Building Essentials | Construction Suite

You can use the Import PDF File to import the
contents of any PDF file into your Envisioneer project.

You can define the size and angle of the imported
block prior to importing it. You can also choose to
import a portion of the image if needed.
To import a PDF file in Worksheet View:
1. Select File > Import > Import PDF File, or

Insert > Import PDF File, or click on the
Insert toolbar.

2. In the Open dialog, locate and select the PDF
file that you want to import, and then click
Open. (If the Font Support Issue dialog
appears, see the note below.)

The PDF file is displayed in the Import PDF
dialog. You can zoom and pan in the PDF
preview pane using the zoom/pan controls
below the pane. Note that changing the zoom
level inside the preview pane has no effect on
the image when it is imported.

3. If the PDF has more than one page, navigate
to the page that you want to import by
clicking the buttons in the Page area of the
Import PDF dialog.

4. Before importing the PDF you will need to
define the size or scale of the imported image.

Initially the size of the image is the same as
the page size in the PDF file. You can set a
custom size by editing the values in the
Width and Height edit boxes. When you do
so, the Scale values adjust accordingly.
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If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit box. For example, if the plan was
drawn at a 1/4" = 1'-0" (1:48) scale, you would
enter 48 in the Scale (X) or Scale (Y) edit
box. There are separate X and Y (horizontal
and vertical) scale settings. By default,
whatever you enter in one edit box will
automatically be displayed in the other edit
box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale
(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.

Another way of specifying the scale is to
draw a reference line along an existing object
in the PDF image and specify the length of
that object in real-world units. To do this,
click the Pick Scale button next to the
Scale (X)or Scale (Y) edit box, then pick two
points along an object in the PDF image to
define a reference line. (If the X scale and Y
scale will differ, you should pick points along
a horizontal object for the X scale, and pick
points along a vertical object for the Y scale.)
Then in the Scale by Reference dialog, enter
the length of the reference line and click OK.
For example, if you know that a particular
wall in your plan is 12' long, draw a line
along that wall and then enter 12' in the
Scale by Reference dialog.

The Scale values in the Import PDF dialog
will then adjust to reflect the scale you
defined.

5. To specify the angle of the imported image,
enter a value in the Angle edit box, or click
the Pick Angle button next to the Angle edit
box and pick two points along an object in
the PDF image to define the angle. If you are
picking points to define the angle, the Angle

by Reference dialog appears and reports the
angle that you defined. You can edit the
angle here if you want.

6. If you want to import only a portion of the

image, click next to the Crop Box
item, then click two points diagonally in the
PDF window to define a box around the por-
tion that you want to import. A blue box is
displayed around the selected portion. To

remove the crop box, click , then
click OK to confirm that you want to clear the
crop box.

7. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
higher the percentage, the more dim the
image will be.

8. If you want the Import dialog to appear again
after you insert the PDF so that you can insert
another PDF, enable the Multiple Insert check
box.

9. To import the image into the current view
window, click Insert. The image is attached
to your cursor.

10. Position the image where you want it, then
click to insert it.

Note: If the PDF file that you are importing contains
fonts that are not available on your computer, the
Font Support Issue dialog will appear. Before
importing the PDF, you need to specify how you
want to handle this issue.

You can choose to rasterize the text by selecting the
Raster Format option. This maintains the display of
the text, but you will not be able to snap to linework
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once the PDF is inserted in your project. If you choose
the Vector Format option, all vector geometry will
remain intact so that you can snap to linework once
the PDF is inserted, but the text may not display
properly.

Importing an Image in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

Using the Import Image tool you can import a BMP,
JPG or TGA file onto your worksheet, such as a floor
plan or your company logo. You can scale or crop the
image prior to import.
To import an image:
1. In Worksheet View, select Insert > Import

Image, or click on the Insert toolbar. You
can also select File > Import > Import Image.

2. In the Open dialog, select the file type you
are importing from the File type drop box.
You can import BMP, JPG or TGA files.

3. Locate the file to import, then click Open.
4. The image is displayed in the Import dialog.

You can zoom and pan in the preview pane
using the zoom/pan controls below the pane.
Note that changing the zoom level inside the
preview pane has no effect on the image
when it is imported.

5. Before importing the file you will need to
define the size or scale of the imported image.

You can set a custom size by editing the
values in the Width and Height edit boxes.
When you do so, the Scale values adjust
accordingly.

If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit boxes. For example, if the plan
was drawn at a 1/4" = 1'-0" (1:48) scale, you
would enter 48 in the Scale (X) or Scale (Y)
edit box. There are separate X and Y
(horizontal and vertical) scale settings. By
default, whatever you enter in one edit box
will automatically be displayed in the other
edit box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale
(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.

Another way of specifying the scale is to
draw a reference line along an existing object
in the image and specify the length of that
object in real-world units. To do this, click the
Pick Scale button next to the Scale (X)or
Scale (Y) edit box, then pick two points in
the image to define a reference line. (If the X
scale and Y scale will differ, you should pick
points along a horizontal object for the X
scale, and pick points along a vertical object
for the Y scale.) Then in the Scale by
Reference dialog, enter the length of the
reference line and click OK. For example, if
you know that a particular wall in your plan
is 12' long, draw a line along that wall and
then enter 12' in the Scale by Reference
dialog.

The Scale values in the Import dialog will
then adjust to reflect the scale you defined.

6. To specify the angle of the imported image,
enter a value in the Angle edit box, or click

the Pick Angle button next to the Angle
edit box and pick two points along an object
in the image to define the angle. If you are
picking points to define the angle, the Angle
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by Reference dialog appears and reports the
angle that you defined. You can edit the
angle here if you want.

7. If you want to import only a portion of the

image, click next to the Crop Box
item, then click two points diagonally in the
preview window to define a box around the
portion that you want to import. A blue box
is displayed around the selected portion. To

remove the crop box, click , then
click OK to confirm that you want to clear the
crop box.

8. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
higher the percentage, the more dim the
image will be.

9. If you want the Import dialog to appear again
after you insert the image so that you can
insert another image, enable the Multiple
Insert check box.

10. To import the image onto the current work-
sheet, click Insert. The image is attached to
your cursor.

11. Position the image on the sheet, then click to
insert it.

Scaling an Inserted Image
Express | Pro Architect | Building Essentials |
Construction Suite

If you have used the Import Image tool in Worksheet
View to insert an image in your drawing, you may
need to scale it to make it the correct size.
To scale an inserted image:
1. Select the image.

2. Select Modify > Scale, or click on the
Modify toolbar.

3. Select a base point to scale from. Typically
this is a point on the image.

4. Enter the desired scale factor in the Scale
edit box. For example, to double the size of
the image, type 2. To reduce the size by half,
type 0.5.

5. Click OK.

Adding Text in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can add custom text to your worksheet using the
Text tool. You can control the style and color of the
text, and even apply different styles or colors to
individual characters.
To add text in Worksheet View:
1. In Worksheet View, click the layer drop box

and select the layer you would like to insert
the text on.

2. Select Tools > Text > Text, or click on
the Tools toolbar.

3. In the Text dialog, select the text style you
would like to apply to the text from the text
style drop box.

4. If you would like to add or edit a text style,
click to access the Text Styles library. The
selected text style and its associated font and
font size are displayed in the adjacent drop
boxes.

5. To select a color for the text, click , then
select a color from the pop-up color palette.

6. To select a background color for the text, click

, then select a color from the pop-up
color palette. Creating a background fill can
make it easier to see text when it is placed on
top of patterned and rendered images.

7. To make the text bold, click .

8. To italicize the text, click .

9. To underline the text, click .

10. To change the justification of the text, click
the appropriate justification Justification
refers to the way lines of text "line up" in
relation to the window that contains them. A
"left" justification lines the left side of the text
up with the left side of the window, leaving
the right side ragged. button.

Left Justify

Center Justify

Right Justify
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11. Type the desired text in the text preview win-
dow. Or, to import a text (*.txt) file, click

, then select the file to import.

12. To insert a pre-defined label, select the label
you want in the Pre-defined Labels list on the
right side of the dialog, then drag it into the
editing window. You can also double-click
the label or click to add the label to the
editing window. To access the Labels library,
where you can add and edit labels, click

.

13. To change the zoom level inside the editing
window, select a value from the Zoom drop
box.

14. To edit the style, color or justification of the
text in the preview window, or parts of the
text, highlight the text that you want to
change, then make your new selections above
the preview window.

15. If you want to automatically return to the
Text dialog after you have inserted the cur-
rent text, enable the Multiple text insert
check box. Otherwise, the Text command is
finished once you insert the text.

16. When you are ready to insert the text in your
drawing, click OK. The text is attached to
your crosshairs.

17. Position the text where you would like it,
then click to insert it.

Note: If you select part of the text in the editing
window and try to resize it, the selected characters
cannot be 8 times larger or 4 times smaller than any
unselected text in the editing window. If all text is
selected, however, you can resize without limits.

Editing Text in Worksheet View
You can edit the font, height, color and content of text
after it has been inserted.
To edit text in Worksheet View:
1. Select the text.

2. Make the desired changes in the Object Prop-
erties panel.

Tip: To quickly display the Text dialog where you
can edit all text properties, just double-click the
text.

Finding and Replacing Text in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can use the Find and Replace tool to find a
specific word or phrase in your project. You can also
replace it instantly with another word or phrase of
your choice.
To find and replace text:
1. Select Tools > Text > Find and Replace, or

click the down arrow next to the Text button
on the Tools toolbar and select Find and

Replace.
2. In the Find and Replace Text dialog, type

the word or phrase that you want to find in
the Find what edit box.

3. If you want to replace the text with some-
thing else, enter the replacement text in the
Replace with edit box.

4. From the Search In drop box, select the area
of your project that you want to search.
Options are Current Worksheet and Current
Selection. If nothing was selected before you
chose the Find and Replace tool, the only
option is Current Worksheet.

5. Select any options you want to use to control
the search. These are described below.
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Match case. Find text with the same
capitalization as the search text. For example,
if you enter "Bedroom" as your search text,
the text "bedroom" would not be returned as
a match because the first character is not
uppercase.

Match whole word. Find only whole words,
not parts of words. For example, if you enter
the word "day" as your search text, the words
"Monday" or "daytime" would not be
returned as matches.

Search up. Search backward from the
current search position.

6. Click Find Next.
If the text is found, the first instance is
displayed in the lower pane of the Find and
Replace Text dialog, and the text is
highlighted in the drawing area.

7. To replace the text with the text in the
Replace with edit box, click Replace. To
instantly replace all instances of the search
text, click Replace All.

8. To search for the next instance of the text,
click Find Next again. When the search is
complete, the End of Search dialog will
appear notifying you that all text has been
searched.

9. When you are finished searching for text,
close the Find and Replace Text dialog.

Controlling the Quality of Text
Through Antialiasing
Pro Architect | Building Essentials | Construction Suite

By default, antialiasing is used in the display of text in
Worksheet View. Antialiasing smooths jagged edges
by changing the color or intensity of pixels at object
edges. If you find that text in Worksheet View looks
too fuzzy, you can try disabling antialiasing.
To enable or disable antialiasing in Worksheet
View:
1. Select Settings > Program Settings or click

the Program Settings button on the Settings
toolbar.

2. In the Program Settings dialog, select Work-
space in the left pane.

3. Check or uncheck the Enable Antialiased
Text check box.

4. Click OK.

Adding Text with a Leader in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

Using the Text with Leader tool you can insert text
with a leader line attached to it. The leader has an
arrow at one end, and two segments that can be
oriented in any fashion.
To add text with a leader:
1. Select Tools > Text > Text with Leader, or

click the down arrow next to the Text button
on the Tools toolbar and select Text with

Leader.
2. In the Text dialog, select the text style you

would like to apply to the text from the text
style drop box.

3. If you would like to add or edit a text style,
click to access the Text Styles library.

4. To make the text bold, click .

5. To italicize the text, click .

6. To underline the text, click .

7. Type the desired text in the text preview win-
dow. Or, to import a text (*.txt) file, click

, then select the file to import.

8. To insert a pre-defined label, select the label
you want in the Pre-defined Labels list on the
right side of the dialog, then drag it into the
editing window. You can also double-click
the label or click to add the label to the
editing window. To access the Labels library,
where you can add and edit labels, click

.

9. To change the zoom level inside the text pre-
view window, select a value from the zoom
drop box .

10. To edit the style, color or justification of the
text in the preview window, or parts of the
text, highlight the text that you want to
change, then make your new selections above
the preview window.
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11. Click OK.
12. By default, the leader lines will be straight. If

you want to create an arched leader line,
right-click and select Spline before selecting
your first point. If you drew an arched leader
previously, the style will remain set to Spline
for subsequent leaders that you create. To
create straight leader lines, right-click and
select Straight before drawing the leader.

13. In the drawing area, select the point where
you want the arrowhead to appear. Typically
this is next to or on an object.

14. Select the next point of the leader. If you only
want a two-point leader, right-click and select
Finish at this point. Otherwise, you can select
a third point for the leader if you want.

Tip: To automatically tag a building element with
its name, use the Description with Leader tool
instead.

Editing the Style or Content of
Leader Text in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

Once you have inserted text with a leader, you can
access and edit the text properties through the Object
Properties panel.
To edit leader text:
1. Select the text.

2. In the Object Properties panel, click next
to the Contents item.

3. Make the desired changes in the Text dialog,
then click OK.

Tip: To quickly launch the Text dialog where you
can edit all text properties, just double-click the
text.

Moving Leader Text in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

If you have inserted text with a leader, you can move
the text independently of the leader.
To move leader text:
1. Select the text with leader.

2. Click and drag the grip that appears on the
text to move the text, then release your
mouse button.

Changing the Style of a Leader
in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

When you use the Text with Leader tool, the style of
the leader (i.e. arrowhead) is determined by the
current dimension style. You can change the leader
style by selecting a dimension style with the desired
style settings.
To select a different style for a leader:
1. Click on the text with leader to select it.

2. In the Object Properties panel, select the
desired dimension style from the Style drop
box.

Scaling Leader Arrows in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

If you have inserted text with a leader, you can edit
the scale of the leader arrowhead.
To scale a leader arrow:
1. Select the text with leader.

2. In the Object Properties panel, enter the
desired scale for the leader arrow in the
Scale edit box. For example, to double the
size, enter 2. To reduce the size by half, enter
0.5.

Adding_Description_Leader.htm
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Setting the Current Dimension
Style in Worksheet View
Pro Architect | Building Essentials | Construction Suite

When you add dimensions to your drawing, they use
the current dimension style, which by default is the
Standard dimension style. You can select a different
dimension style to be the current one if you want.
To set the current dimension style:
1. Select Settings > Current Dimension Style.
2. In the Current Dimension Style dialog, click

the Select button.
3. In the Dimension Styles dialog, select the

style you want to set as current.

4. Click OK in the Dimension Styles dialog.
5. Click OK in the Current Dimension Style dia-

log.

Creating Linear Dimensions in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

A linear dimension is a horizontal or vertical
dimension with extension lines going vertically (for a
horizontal linear dimension) or horizontally (for a
vertical linear dimension) to the origins of the
extension lines, which define the endpoint of the
dimension.

To create linear dimensions:
1. Select Tools > Dimensions > Linear Dimen-

sions, or click on the Tools toolbar.

2. Click a point in your drawing to begin the
dimension line.

3. Move your mouse (you do not have to hold
the mouse button down) to a second point
and click. A dimension line including offsets,
arrows and a numerical value is added to
your drawing.

4. Move your mouse away from the dimension
line to stretch your extension lines. When the
extension lines are the desired length, click to
finish the dimension.

Creating Aligned Dimensions in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

An aligned dimension is similar to a linear dimension,
except it tilts to the same angle as the object you are
dimensioning, making it the ideal choice for elements
that are not horizontal or vertical.

To create aligned dimensions in Worksheet View:
1. Select Tools > Dimensions > Aligned Dimen-

sions, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Aligned Dimensions.

2. Click a point in your drawing to begin the
dimension line.

3. Move your mouse (you do not have to hold
the mouse button down) to a second point
and click. A dimension line including offsets,
arrows and a numerical value is added to
your drawing.

4. Move your mouse away from the dimension
line to stretch your extension lines. When the
extension lines are the desired length, click to
finish the dimension.

Creating Angular Dimensions in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can use the Angular Dimensions tool to insert a
dimension that measures an angle rather than a
distance. This is particularly useful where objects are
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not rectangular, or are not perpendicular to one
another.

To create an angular dimension, you select three
points that will be used to create the dimension, then
select a location for the dimension line.
To create an angular dimension:
1. Select Tools > Dimensions > Angular Dimen-

sions, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Angular Dimensions.

2. Select the angle’s vertex point.

3. Select the first endpoint of the angle.

4. Select the second endpoint of the angle.

5. With the dimension attached to your
crosshairs, position the dimension where you
would like it, and then click to insert it.

Creating Continuous Dimen-
sions in Worksheet View
Pro Architect | Building Essentials | Construction Suite

You can easily add more segments to an existing
linear or aligned dimension using the Continuous
Dimension tool. Simply pick points where you want
each endpoint to be, and the dimension line will
automatically extend with each point picked. This
creates a series of dimensions that are end to end.

To create continuous dimensions:
1. Select Tools > Dimensions > Continuous

Dimension or click the down arrow next to
the Dimensions button on the Tools
toolbar and select Continuous Dimension.

2. If it is not currently selected, click on the lin-
ear or aligned dimension that you would like
to continue.

3. Move your cursor in the direction in which
you would like to continue the dimension.
You can continue a dimension from either
endpoint. The dimension line extends as you
move your cursor.

4. Click to select the next extension line point.
This creates a new dimension.

5. Continue adding more dimensions as needed.

6. When you are finished adding dimensions,
right-click and select Finish.

Creating Baseline Dimensions
in Worksheet View
Pro Architect | Building Essentials | Construction Suite

You can use the Baseline Dimension tool to create
multiple dimensions along the same baseline. Baseline
dimensions are built from an existing linear or aligned
dimension in your drawing. Simply pick points where
you want each extension line to be, and new
dimensions will be created with each point picked.
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To create baseline dimensions:
1. Select Tools > Dimensions > Baseline

Dimension or click the down arrow next to
the Dimensions button on the Tools
toolbar and select Baseline Dimension.

2. If not already selected, click on the dimension
that you would like to continue, clicking near
the extension line that you would like to use
as the first extension line (baseline) for each
new dimension.

3. Move your cursor in the direction in which
you would like to continue the dimension,
then select a point for the second extension
line. A new dimension is created.

4. Continue to select extension line points to
add more dimensions.

5. When you are finished adding dimensions,
right-click and select Finish.

Tip: To change the spacing between baseline
dimensions, edit the Baseline Offset value in your
dimension style properties. See Changing the Style of
a Dimension in Worksheet View on page 319.

Creating Overall Dimensions in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

You can use the Overall Dimension tool to create one
overall dimension from two or more existing

dimensions in your drawing. The overall dimension
extends from the first extension line of the first
dimension picked to the second extension line of the
last dimension picked.

To create an overall dimension:
1. Select Tools > Dimensions > Overall Dimen-

sion or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Overall Dimension.

2. Click where you would like the dimension
line to be placed.

3. Click on the first dimension from which you
would like to create an overall dimension.

4. Click on the second dimension from which
you would like to create an overall dimen-
sion. An overall dimension is created. You
can select more dimensions to add if you
want.

5. Right-click and select Finish.

Moving Dimension Text in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can move a dimension’s text without affecting
the dimension line.
To move dimension text:
1. Click on the dimension to select it.

2. Position your crosshairs over the solid blue
grip that is on the text, then click and drag to
move the text.
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Resetting the Dimension Text
Position in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

If you have moved a dimension’s text, you can use
the Reset tool to move it back to its original position if
needed.
To reset the dimension text position:
1. Click on the dimension to select it.

2. In the Object Properties panel, click the Reset
button in the Text Position field.

Moving a Dimension Line in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can move a dimension line by clicking and
dragging it. When you move a dimension line, the
extension lines stretch.
To move a dimension line:
1. Select the dimension.

2. Click and drag one of the dimension line’s
end grips, then release your mouse button.

Stretching Dimensions in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can make a dimension longer or shorter, or
stretch either of its extension lines. When you stretch
the length of a dimension, the dimension value
updates automatically to reflect the new length.
To adjust the length of a dimension:
1. Select the dimension.

2. Click on one of the lower extension grips,
then drag the dimension to stretch it. Note
that it is possible to stretch the extension line
at the same time.

3. Release your mouse button.
To adjust the length of extension lines:
1. Select the dimension.

2. Click the grip at the end of the extension line,

then drag to stretch the extension line.

3. Release your mouse button.

Aligning Dimensions in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

You can use the Align Dimension tool to align an
existing dimension with another.
To align dimensions:
1. Select Tools > Dimensions > Align Dimen-

sion, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Align Dimension.

2. Click on the dimension that you want to align
another dimension to.

3. Click on the dimension that you want to align
with the first dimension. The second dimen-
sion adjusts to align with the first dimension.

Joining Dimensions in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

You can join two existing linear or aligned
dimensions using the Join Dimension tool. Joining
two dimensions turns two dimensions into one, and
the dimension value updates automatically to display
the new length.
To join dimensions:
1. Select Tools > Dimensions > Join Dimen-

sion, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Join Dimension.

2. Click on one of the dimensions that you want
to join with another.

3. Click on the dimension that you want to join
with the first. The two dimensions are joined
into one.

Splitting Dimensions in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

You can split a dimension into two dimensions at a
selected point using the Split Dimension tool.
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To split a dimension:
1. Select Tools > Dimensions > Split Dimen-

sion, or click the down arrow next to the
Dimensions button on the Tools toolbar
and select Split Dimension.

2. Click on the dimension that you would like
to split.

3. Click on the dimension line where you would
like to split the dimension. The dimension is
split at the selected point.

Changing the Style of a Dimen-
sion in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

You can apply a different dimension style to a
dimension in Worksheet View by simply making a
style selection in the Object Properties panel.
To change the style of a dimension:
1. Select the dimension. You can select multiple

dimensions using Shift+click.

2. In the Object Properties panel, select the
desired dimension style from the Style drop
box. To access the Dimension Styles library,
where you can add and edit dimension styles,
select Other from the Style drop box.

Overriding Dimension Text in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

In Worksheet View it is possible to edit a dimension’s
calculated numerical value to suit your needs, or add
information to the value. You can even change the
value to text, such as “Varies”.
To override dimension text:
1. Select the dimension.

2. If you want to replace the current dimension
value with something else, type the desired
text in the Override edit box in the Object
Properties panel. You can type any numerals
or characters you want.

If you want to keep the current value but add
information before or after the value, use a

pair of angle brackets <> before or after the
additional text. For example, if you wanted to
add the words 'Final Dimension' after the
dimension value, you would type <> Final
Dimension in the edit box.
For a 12'-0" dimension, the dimension would
then look like this:

If you want to add text below the dimension
value (on the other side of the dimension
line), type \X where you want to drop down
to a new line. For example, if you wanted to
add the 'Final Dimension' text below the
current dimension value instead of beside it,
you would type <> \X Final Dimension in
the edit box.

The dimension would then read:

The line break option can be used with the
current dimension value (as shown in the
example above), or with custom text that you
type in the edit box. Note that you can only
use the line break option once when
overriding a dimension. You cannot keep
adding more lines of text.

3. Press Enter or click in the drawing area to
update the dimension.

Scaling a Dimension in Work-
sheet View
Express | Pro Architect | Building Essentials |
Construction Suite

Dimension scale affects the size of the dimension
geometry: text, ticks and offsets. It does not affect the
measured length shown in a dimension. You may
need to scale dimensions in Worksheet View if you
are importing a view whose scale is different than the
scale of the worksheet, or scaling a block that contains
dimensions.
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To scale a dimension:
1. Select the dimension.

2. In the Object Properties panel, edit the value
in the Scale edit box. For example, to double
the dimension sizing, enter 2. To reduce the
sizing to half, enter 0.5.

Scaling Dimension Values in
Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

In Worksheet View you can scale the measured length
shown in a dimension by editing the dimension’s
Value Scale property. You may need to scale
dimension values if you are importing a view whose
scale is different than the scale of the worksheet, or
scaling a block that contains dimensions.
To scale a dimension value:
1. Select the dimension.

2. In the Object Properties panel, edit the value
in the Value Scale edit box. For example, to
double the value, enter 2. To reduce the value
by half, enter 0.5.

Note: You cannot scale a value that has been
overridden.

Drawing Lines in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

You can draw a line with one or more segments by
simply picking points.
To draw a line in Worksheet View:

1. Select Draw > Line, or click on the Draw
toolbar.

2. Select a start point for the line.

3. Select the end point for the line. If you want
you can continue adding segments to the line.
The line will snap to common points on
objects provided those snaps are enabled in
your Object Snap settings.

4. When you are finished drawing the line,
right-click and select Finish.

Note: If a line has multiple segments, each segment
is considered a separate entity.

Drawing Polylines in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

A polyline is a continuous line composed of one or
more line segments. To create a polyline, you select
the endpoints of each line segment. When you select a
polyline, grips are displayed at each segment
endpoint. You can move these grips to effectively
stretch the polyline in different directions.

To draw a polyline:

1. Select Draw > Polyline, or click on the
Draw toolbar.

2. Select a start point for the polyline.

3. Select the end point of the first line segment.

4. Move your mouse in the direction you want
the next segment to run. When the segment is
the correct length, click to define its endpoint.

5. Continue adding segments as desired.

6. Right-click and select Finish.

Joining Objects to a Polyline
You can join an existing line, arc or other polyline to a
polyline using the Join Polyline tool provided the end
of the object is currently connected to the end of the
polyline. Together the object and the polyline form
one continuous polyline. If the object you initially
choose is not a polyline, you will be prompted to turn
it into one.
To join an object to a polyline:
1. Select Modify > Join Polyline or click the

Join Polyline button on the Modify toolbar.

2. Click on the polyline to which you want to
join objects. A dialog confirms your selection.
Click OK.
If the object is not a polyline, you will be
asked if you want to convert it to one. Click
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Yes to convert the object to a polyline, or
click No to select a different object.

3. Click on the line, arc or polyline that you
want to join to the polyline, then press Enter
or right-click and select Enter. The object is
joined to the polyline.

Curving a Polyline (Worksheet
View)
You can curve a polyline by simply making a
selection from the Curve Type drop box in the Object
Properties panel. There are three different curve types
available: Curve Fit, Quadratic, and Cubic. Each
creates a different degree of curvature.
To curve a polyline:
1. Click on the polyline to select it.

2. In the Object Properties panel, make a
selection from the Curve Type drop box.
These are described below.

Curve Fit. Creates a smooth curve with high
curvature, passing through all of the vertices.

Quadratic. Creates a smooth curve that is
pulled toward the vertices but passes through
only the first and last vertices.

Cubic. Creates a smooth curve that is pulled
toward the vertices but passes through only
the first and last vertices. Cubic curving
creates the smoothest curve with the lowest
curvature.

Tip: To remove the curve from a polyline, just
select None from the Curve Type drop box.

Decurving a Polyline
If you have fit a polyline with a curve in Worksheet
View, you can remove the curve by editing the
polyline's properties.
To decurve a polyline:
1. Click on the polyline to select it.

2. In the Object Properties panel, select None
from the Curve Type drop box.

Drawing Arcs in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

There are three tools available for drawing arcs in
Worksheet View.

Start, Center, End. When you specify the start and
center points, you define the arc’s radius. The end
point establishes the arc’s length.

3 Points. Select a start point for the arc, a second
point along the arc, then drag the arc into position as
you specify the end point.

Start, End, Radius. Select the start and end point of
the arc to define its length, then select a third point to
define the arc’s radius (curve).
To draw an arc with the Start, Center, End tool:
1. Select Draw > Arc > Arc - Start, Center, End,

or click the down arrow next to the Arc but-

ton on the Draw toolbar and select Arc -
Start, Center, End.

2. Select a start point for the arc.

3. Select the arc’s center point. The radius is
now defined.

4. Select the arc’s end point to define the arc's
length.

To draw an arc with the 3 Points tool:
1. Select Draw > Arc > Arc 3 Points, or click the

down arrow next to the Arc button on
the Draw toolbar and select Arc - 3 Points.

2. Select the start point of the arc.

3. Select a second point on the arc.

4. Drag the arc to stretch it to the desired length
and position, then select the end point of the
arc.
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To draw an arc with the Start, End, Radius tool:
1. Select Draw > Arc > Arc Start, End, Radius,

or click the down arrow next to the Arc but-

ton on the Draw toolbar and select Arc -
Start, End, Radius.

2. Select the start point of the arc.

3. Select the end point of the arc to define its
length.

4. Move your pointer to curve the arc, then
select a third point to define the arc’s radius.

Editing the Curve of an Arc in
Worksheet View
You can change how much an arc curves by clicking
and dragging its midpoint grip. Alternatively you can
edit the Radius in the Object Properties panel.
To edit the curve of an arc:
1. Click on the arc to select it.

2. Hover your pickbox over the hollow mid-
point grip, then click and drag to change the
arc’s curve.

To edit the radius of an arc:
1. Select the arc.

2. In the Object Properties panel, enter the
desired radius in the Radius edit box.

3. Click in the drawing area to update the arc.

Drawing Circles in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

There are two ways to draw a circle. With the Circle -
Center, Radius tool you draw the circle from the
center out, by picking two points to define its radius.
With the Circle - 2 Point tool, you draw the circle

outward from a selected point, essentially defining
the circle’s diameter.
To draw a circle by specifying its radius:
1. Select Draw > Circle > Circle - Center,

Radius, or click the down arrow next to the
Circle button on the Draw toolbar and
select Circle - Center, Radius.

2. Click the point that is to be the center of the
circle.

3. Move your pointer away from the center
point. The circle grows as you move farther
away from the center.

4. When the circle is the desired size, click to fin-
ish.

To draw a circle by specifying its diameter:
1. Select Draw > Circle > Circle - 2 Point, or

click the down arrow next to the Circle but-

ton on the Draw toolbar and select Circle
- 2 Point.

2. Click a point in the drawing. The circle will
grow from this point.

3. Move your pointer away from the selected
point. The farther you move away from this
point, the larger the circle becomes.

4. When the circle is the desired size, click to fin-
ish.

Drawing an Ellipse in Worksheet
View
Pro Architect | Building Essentials | Construction Suite
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To draw an ellipse in Worksheet View, select Draw >
Ellipse, or click the down arrow next to the Ellipse

button on the Draw toolbar, then select either
Ellipse - Axis or Ellipse - Center.
To use the Ellipse - Axis tool:
1. Select two points to define the major axis of

the ellipse.

2. Select a third point away from the axis to
define the minor radius.

To use the Ellipse - Center tool:
1. Select the midpoint of the ellipse, then select

a second point to define the major radius of
the ellipse.

2. Select a third point to define the minor
radius.

Drawing Elliptical Arcs in Work-
sheet View
To draw an elliptical arc in Worksheet View, select
Draw > Ellipse, or click the down arrow next to the

Ellipse button on the Draw toolbar, then select
either Elliptical Arc - Axis or Elliptical Arc - Center.
To use the Elliptical Arc - Axis tool:
1. Select two points to define the major axis of

the ellipse.

2. Select a third point away from the axis to
define the minor radius.

3. Select two points to define the end points of
the arc.

The section between the two points will form
the arc:

To use the Elliptical Arc - Center tool:
1. Select the midpoint of the ellipse, then select

a second point to define the major radius of
the ellipse.

2. Select a third point to define the minor
radius.

3. Select two points to define the end points of
the arc.
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The section between the two points will form
the arc:

Drawing Polygons in Worksheet
View
Pro Architect | Building Essentials | Construction Suite

A polygon is a closed, multi-sided object. You can use
the Polygon tool to quickly create a polygon with
three or more equal sides (such as a triangle, square
or hexagon) without having to draw each side. Just
specify the number of sides you want, select a center
point, then select a point to define the size of the
polygon. You can choose to inscribe the polygon
inside an imaginary circle, or circumscribe it about an
imaginary circle.
To draw a polygon:
1. In Worksheet View, select Draw > Polygon

or click on the Draw toolbar.

2. In the Polygon dialog, enter the number of
sides you want the polygon to have in the
Number of Sides edit box. The minimum

number of sides is 3 and the maximum is
1000.

3. From the drop box select either Inscribed in
Circle or Circumscribed about Circle. Use
the Inscribed in Circle option when you want
to specify the distance between the center of
the polygon and each vertex. That is, the
corners of the polygon will touch the
circumference of an imaginary circle. Use the
Circumscribed about Circle option when you
want to specify the distance between the
center of the polygon and the midpoint of
each side. That is, the polygon's sides will be
tangent to the circle.

4. Click OK.
5. In the drawing area, select a center point for

the polygon. The polygon will be created out-
ward from this point.

6. Move your pointer away from the center to
stretch the polygon to the desired size. Note
that the direction in which you move determ-
ines the rotation of the polygon.

7. When the polygon is the desired size, click to
finish.

Drawing Hatched Polygons in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

A polygon is a closed object consisting of three or
more line segments. You can use the Polygon Hatch
tool to draw a free-form polygon of any shape with
hatching of your choice instantly applied (or no
hatching if you prefer). You can edit the shape, line
style and hatch pattern of the polygon after it has
been inserted.
To draw a hatched polygon:

1. Select Draw > Polygon Hatch, or click on
the Draw toolbar.
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2. In the Polygon Hatch dialog, select the
appearance properties that you would like
the polygon to have. If you would like it to
have a boundary line, enable the Include
check box in the Boundary Line area. If you
would like the polygon to be hatched, enable
the Include check box in the Pattern area,
then click Select to select a hatch pattern
from the Patterns library.

3. Select a start point for the polygon, then con-
tinue selecting points to define its shape.
Note that you do not have to select the start
point again, as the polygon always remains
closed as you draw it. Be careful not to cross
any lines, or the polygon will not be created.

4. Once you’ve selected the last point of the
polygon, right-click and select Finish.

Note: The color, line type and line weight of the
boundary line is determined by the properties of
the layer that the polygon is drawn on.

Editing a Polygon's Hatch Pat-
tern Line Properties in Work-
sheet View
If you have created a polygon using the Polygon
Hatch tool, you can change the color, line type and
line weight of the polygon’s hatch pattern after it has
been inserted.
To edit a polygon's hatch pattern:
1. Click on the polygon to select it.

2. In the Object Properties panel, select the
desired settings from the Color, Line Type
and Line Weight drop boxes.

Editing a Polygon's Hatch Pat-
tern in Worksheet View
Once you have created a polygon, you can replace its
hatch pattern with a different one, or edit the
properties of the existing one.
To edit a polygon’s hatch pattern:
1. Click on the polygon to select it.

2. In the Object Properties panel, make your
desired changes.

To hide the hatch pattern’s boundary line,
disable the Boundary/Include check box.  
To hide the hatch pattern, disable the
Pattern/Include check box.
To replace the hatch pattern with a different
one, click the Style drop box and select the
pattern you want.

To edit the scale of the hatch pattern, enter
the desired scale in the Scale edit box.
To edit the angle of the hatch pattern, enter
the desired angle in the Angle edit box.
To edit the start point of the hatch pattern in
relation to the polygon, click the browse
button in the Specify Origin field, then select
the desired start point in your drawing.

Drawing Rectangles in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

You can draw a rectangle easily by just picking two
points on the screen.
To draw a rectangle:
1. Turn your Ortho off.

2. Select Draw > Rectangle, or click on the
Draw toolbar.

3. Click a point on the screen. This will be one
of the rectangle’s corners.

4. Move your pointer away from the current
point. The rectangle grows as you move
farther away.

5. When the rectangle is the desired size, click
to finish it.

Drawing Revision Clouds in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

Revision clouds call attention to areas of change in
your drawing. You can quickly draw a revision cloud
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around any portion of your drawing by simply
clicking a few points.
To draw a revision cloud:

1. Select Draw > Revision Cloud, or click
on the Draw toolbar.

2. Pick points to form the outline of the cloud,
then hover your cursor over the start point to
close the shape. When picking points, be care-
ful not cross over any segments that you have
already drawn.

Creating Hatching Using Bound-
ary Hatch
Pro Architect | Building Essentials | Construction Suite

Hatch patterns represent actual materials, such as
shingles and brick. You can apply a hatch pattern to
any closed area in a 2D view using the Boundary
Hatch tool. For example, you may want to apply a
shingle pattern to the roof in an elevation. You can
choose an angle and scale for the pattern, and specify
how you want the hatching applied. When you apply
hatching, the hatch pattern becomes an object that
you can edit to suit your needs.
To apply hatching:
1. In Worksheet View, make sure your 2D view

is displayed (plan or elevation).

2. Select Draw > Boundary Hatch, or click
on the Draw toolbar.

3. In the Boundary Hatch dialog, click the Style
drop box and select the pattern that you
would like to apply.

4. Click Select Boundaries. This takes you
back out to your drawing.

5. Position your crosshairs inside the area that
you want to hatch. The area’s boundary
becomes highlighted. Click inside the area to
select it. You can select multiple areas if you
want. When you are finished selecting areas
to hatch, right-click and select Enter.

6. By default, if a boundary contains another
closed boundary, the inner boundary will not
be hatched. If you want to hatch the inner
boundary as well, enable the Ignore radio
button in the Hatching dialog. Otherwise,
enable the Outer radio button to hatch only
the outer boundary.

7. To deselect an area that you have selected,
click Remove Boundaries, click inside
the area, then right-click and select Enter.

8. By default, patterns are applied horizontally
(0 degrees). If you want to rotate the pattern,
enter the desired angle in the Angle edit box.

9. To change the size of the pattern, enter a
value in the Scale edit box. A value of 2
doubles the size, while a value of .5 reduces
the size by half.

10. By default, the pattern is created from the 0,0
origin (the Use Default radio button is selec-
ted). If you want the pattern to be created
from a different point, enable the Specify Ori-
gin radio button, then click . Select the
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desired origin point in the drawing. For
example, if you were applying a brick pattern
to a wall and wanted full bricks along the bot-
tom of the wall, you would select one of the
wall’s bottom corners as the origin.

11. If you want the boundary to be part of the
hatch pattern (i.e. have the same color and
line weight applied), enable the Include
Boundary check box. Otherwise, the bound-
ary line will remain the way it was before
hatching, and will not be part of the hatch
object.

12. By default, if more than one boundary is
selected for hatching, only one hatch object is
created. If you want to create a separate hatch
object for each boundary, enable the Create
Separate Hatches check box. This is import-
ant if you want to edit the hatching later.

13. Once you have selected your boundary and
specified your options, click Preview to see
how the hatching will look. When you are fin-
ished previewing the hatching, press ESC, or
right-click and select Cancel.

14. To apply the hatching, click OK.

Note: If the Boundary Hatch tool is not successful
in detecting the boundary, use the Polygon Hatch
tool instead.

Note: The color and weight of the pattern’s lines
are determined by the layer that the pattern is on.

Tip: You can insert elevations that are already
hatched by setting the display mode to Patterned in
the Insert View dialog when inserting the
elevations onto your worksheet. The patterns
applied depend on the material settings in each
element’s properties.

Editing Hatch Pattern Line Prop-
erties in Worksheet View
You can change the color, line type and line weight of
a hatch pattern (created with the Boundary Hatch
tool) after it has been inserted in Worksheet View.
To edit hatch pattern properties:

1. Click on the hatching to select it.

2. In the Object Properties panel, select the
desired settings from the Color, Line Type
and Line Weight drop boxes.

Editing an Object's Hatch Pat-
tern in Worksheet View
Once you have created hatching using the Boundary
Hatch tool, you can replace the hatch pattern with a
different one, edit the properties of the existing one,
or add or remove boundaries.
To edit an object’s hatch pattern:
1. Click on the hatching to select it.

2. In the Object Properties panel, make your
desired changes.

3. To hide the hatch object’s boundary line, dis-
able the Boundary/Include check box.

4. To hide the hatch pattern, disable the Pat-
tern/Include check box.

5. To replace the hatch pattern with a different
one, click the Style drop box and select the
pattern you want.

6. To edit the scale of the hatch pattern, enter
the desired scale in the Scale edit box.

7. To edit the angle of the hatch pattern, enter
the desired angle in the Angle edit box.

8. To edit the start point of the hatch pattern in
relation to the hatch object, click the browse
button in the Specify Origin field, then select
the desired start point in your drawing.

Drawing Batt Insulation in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

Batt insulation is pre-cut, flexible insulation that fits
inside wall cavities between the studs. You can add
sections of batt insulation to your Worksheet View
drawing by picking points to define the length and
width of the insulation detail.
To draw batt insulation:
1. In Worksheet View, select Draw > Details >

Batt Insulation, or click the down arrow next
to the Details button on the Draw toolbar
and select Batt Insulation.
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2. Click two points to define the length of the
insulation section, then move your pointer
away from the base line and click a third
point to define the width of the section.

Drawing Rigid Insulation in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

Rigid insulation takes the form of non-flexible panels
and is often used on roofs and walls to provide
thermal insulation. You can add sections of rigid
insulation to a Worksheet View drawing by picking
points to define the length and width of the insulation
detail.
To draw rigid insulation:
1. In Worksheet View, select Draw > Details >

Rigid Insulation, or click on the Draw
toolbar.

2. Click two points to define the length of the
insulation section, then move your pointer
away from the base line and click a third
point to define the width of the section.

Drawing a Wood Section in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

Wood sections can be used to represent blocking,
wood posts or other wood elements in a 2D drawing.

You can add a custom-sized wood section to a
worksheet by picking points to define its length and
width.
To draw a wood section:
1. In Worksheet View, select Draw > Details >

Wood Section, or click the down arrow next
to the Details button on the Draw toolbar
and select Wood Section.

2. Click two points to define the length of the
wood section, then move your pointer away
from the base line and click a third point to
define the width of the section.

Drawing a Masonry Section in
Worksheet View
Pro Architect | Building Essentials | Construction Suite

You can add a masonry section to a 2D worksheet to
represent an area where brick, stones or concrete
blocks are used. You create a masonry section by
specifying the dimensions of one masonry unit and
joint, and then picking points to define the length and
direction of the section.
To draw a masonry section:
1. Select Draw > Details > Masonry Section, or

click the down arrow next to the Details but-

ton on the Draw toolbar and select
Masonry Section.

2. In the Masonry Section dialog, select either
Brick or Block to define how you want the
masonry to be represented graphically in the
section.

3. Specify the following:

Masonry Height. The height of one masonry
unit (e.g. brick) in the section.

Masonry Width. The width of each masonry
unit in the section.

Joint Height. The distance between masonry
units.
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Joint Width. The offset of the mortar from
the face of the masonry units.

4. Click OK.
5. In your drawing, click two points to define

the length of the masonry section, keeping in
mind that the line you are defining will rep-
resent the exterior face of the masonry. Then,
move your pointer away from the base line
and click a third point to define the direction
of the section relative to the base line.

Editing Masonry Section Prop-
erties in Worksheet View
Once you have created a masonry section, you can
edit the dimensions of the masonry units and joints
by accessing the masonry section properties.
To edit masonry section properties:
1. Click on the masonry section to select it.

2. Right-click and select Masonry Section Prop-
erties.

3. In the Masonry Section Properties dialog,
edit the values as desired.

Masonry Height. The height of one masonry
unit (e.g. brick) in the section. 

Masonry Width. The width of each masonry
unit in the section.

Joint Height. The distance between masonry
units.

Joint Width. The offset of the mortar from
the face of the masonry units.

4. Click OK.

Drawing a Cut Line in Work-
sheet View
Pro Architect | Building Essentials | Construction Suite

A cut line is a standard drafting symbol used to
represent a break in the drawing. It indicates that the
object continues in the same manner after or between
the break lines. You can add a cut line to a 2D view
by picking points to define the length and extent of
the cut line.
To draw a cut line:
1. In Worksheet View, select Draw > Details >

Cut Line, or click the down arrow next to the
Details button on the Draw toolbar and
select Cut Line.

2. Click two points to define the length of the
cut line, then move your pointer away from
the base line and click a third point to define
the extent of the break symbol’s sharpness.

Inserting a Roof Symbol
Pro Architect | Building Essentials | Construction Suite

A roof symbol indicates the slope of a roof. When
inserting a roof symbol you first define its properties,
then click to insert it on your worksheet.

To insert a roof symbol:

1. In Worksheet View, select Draw > Details >
Roof Symbol, or click the down arrow next
to the Details button on the Draw toolbar
and select Roof Symbol.

2. In the Roof Slope Symbol dialog, specify the
following properties:

Slope Type. Select the method for specifying
the slope: ? in 12 or 1 in ?.
Slope Value. Enter the value that completes
the slope measurement. For example, if you
selected ? in 12 as the method, you would
enter 8 for an 8 in 12 slope.
Text Style. Select a text style for the slope
measurement.

Length. The overall length of the angled line
in the symbol.
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Alignment. Specify the orientation of the
symbol: Left or Right. The symbol below is
left-aligned:

3. Click OK.
4. Click to insert the symbol on your worksheet.

Inserting a Member Spacing
Note
Pro Architect | Building Essentials | Construction Suite

A member spacing note is typically found on working
drawings that show framing (for example, floor joist
layouts). It is used to indicate the spacing between
members, and can include other relevant information
that you want to convey. When using the Member
Spacing Note tool you can have it automatically
detect the member type that you are annotating,
enabling you to create the note quickly and easily.
To insert a member spacing note:
1. In Worksheet View, select Draw > Details >

Member Spacing Note, or click the down
arrow next to the Details button on the
Draw toolbar and select Member Spacing
Note.

2. Pick two points to define the width and loc-
ation of the spacing symbol. For example, if
you want the symbol to be the width of the
space between two members, you would
select the edge of one member, then select the
edge of the adjacent member.

3. In the Member Spacing Note dialog, specify
the content and appearance of the note:

l To edit the dimension style applied to
the note, which controls the appear-
ance of the symbol and text, click

and select a style from the
Dimension Styles dialog.

l To automatically detect the member

type in the drawing, click and
then click on a member in your

drawing. The member type is repor-
ted in the top line of the note.

l Edit the text of each line as desired.

4. Click OK.
The note appears where you specified the
symbol insertion points:

Creating a Block
Pro Architect | Building Essentials | Construction Suite

A block is a single object that is composed of many
other objects. A block can be a symbol, detail, note or
entire drawing that you need to use more than once.
You can use the Define Block tool to capture a group
of objects in a block. To create the block you specify a
block insertion point, then select the objects that you
want to capture in the block.
To create a block:
1. In Worksheet View, select Insert > Blocks >

Define Block, or click on the Insert tool-
bar.

2. In the Block Name edit box, type a name for
the block.

3. Click (the Pick Point button) in the Define
Block dialog. You are taken out to your draw-
ing.
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4. Select a point to serve as the block’s insertion
point. This is the point that will be attached
to your crosshairs when you insert the block
later.

The Define Block dialog reappears. If an
insertion point was successfully selected, the
message “base point defined” is displayed in
the Base point area of the dialog.

5. Click (the Select Objects button) in the
Define Block dialog. You are taken out to
your drawing again.

6. Select the objects that you want to capture in
the block, then press Enter (or right-click and
select Enter).
The Define Block dialog reappears and
displays the number of objects selected in the
Objects area of the dialog.

7. To leave the original objects in the drawing in
their original state, enable the Retain radio
button.

8. To convert the objects you selected to a block,
enable the Convert to block radio button.

9. To remove the objects you selected from the
drawing, enable the Delete radio button.

10. Click OK. The block is now created and
saved.

Inserting a Block
Pro Architect | Building Essentials | Construction Suite

If you have used the Define Block tool to capture
objects in a block, you can use the Insert Block tool to
insert the block at any time, on any worksheet, in any
project.
To insert a block:
1. In Worksheet View, select Insert > Blocks >

Insert Block, or click the down arrow next to
the Blocks button on the Insert toolbar
and select Insert Block.

2. From the Block Name drop box, select the
block that you would like to insert.

3. Click OK. The block is attached to your
crosshairs.

4. Click to insert the block where you want it.

Note: If you want to insert a block created in
another project, use the Insert Block from File tool
on the Blocks menu. If you want to insert a block
created in another program (DWG or DXF file), use
the Import CAD File tool on the Insert menu.

Inserting a Block from Another
Project
Pro Architect | Building Essentials | Construction Suite

If you have created blocks in another Envisioneer
project, you can import them into the current project
using the Insert Block from File tool.
To insert a block from another project:
1. In Worksheet View, select Insert > Blocks >

Insert Block from File. Or, click the down
arrow next to the Blocks button on the
Insert toolbar and select Insert Block from
File.

2. In the Open dialog, locate and select the Envi-
sioneer project (*.bld file) containing the
block that you want to import, then click
Open.

3. In the Block Selection dialog, select the
block that you want to import, then click OK.
The block is attached to your crosshairs.

4. Click to insert the block in your drawing
area.

Note: If a block by the same name already exists in
the current project, you will have the option of
replacing it with the incoming block, or renaming
the incoming block.

Note: If you want to insert a block created in
another program (DWG or DXF file), use the
Import CAD File tool on the Insert menu.

Scaling a Block
You can use the Scale tool to increase or decrease the
size of a block to suit your drawing needs.
To scale a block:
1. Select the block.

2. Select Modify > Scale, or click on the
Modify toolbar.
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3. Select a base point to scale from. Typically
this is a point on the block.

4. Enter the desired scale factor in the Scale edit
box. For example, to double the size of the
block, type 2. To reduce the size by half, type
0.5.

5. Click OK.

Note: If the block contains a dimension, the
dimension value does not scale. If you need to scale
the dimension value, double-click the block, select
the dimension, then edit the Value Scale in the
Object Properties panel.

Editing a Block
If you have inserted a block on your worksheet,
whether it be with one of the Blocks tools or the
Import CAD File tool, you can edit the contents of the
block if needed. You can edit its individual
components or add objects to it. Any changes or
additions you make are automatically saved to the
block's definition, and any instances of the block in
your project are automatically updated.
To edit a block:
1. Double-click the block, or select the block and

then click Edit in the Definition field of the
Object Properties panel. Everything except
the block is dimmed, indicating that you are
now in block editing mode.

2. Make the desired changes to the block.

3. Press ESC on your keyboard to return to your
worksheet.

Deleting Unreferenced Blocks
When you insert a block in your drawing, a copy of
the block is stored in memory, and the inserted block
references that stored block. If you delete a block from
your drawing, the block that it references remains in
memory. Having too many unreferenced blocks in
your project can increase drawing file size. You can
alleviate this problem by deleting unreferenced blocks
from memory.
To delete unreferenced blocks:
1. Select Insert > Blocks > Delete Unrefer-

enced Blocks, or click the down arrow next

to the Blocks button on the Insert toolbar
and select Delete Unreferenced Blocks.

2. The Delete Unreferenced Blocks dialog lists
all of the blocks that are not being used by
the drawing. Enable the check boxes beside
the blocks that you want to delete. You can
select all blocks simultaneously by clicking
the top check box beside the Block
Namelabel.

3. Click . A dialog warns you that
you will not be able to undo changes to your
drawing since your last save if you proceed
with deleting unreferenced items.

4. Click OK to proceed with the deletion.

Defining Attributes
Pro Architect | Building Essentials | Construction Suite

Attributes allow you to attach textual information to
blocks. They are useful for entering text that changes
with each insertion of a particular block. For example,
you can add attributes to a title block that prompt for
the designer’s name, current date or drawing sheet
number each time someone inserts the title block into
a drawing. Once you’ve defined the attribute, you
insert it in the drawing (for example, on your title
block), then capture the object and attribute in a
block.
To create an attribute:
1. In Worksheet View, select Insert > Blocks >

Insert Attribute, or click the down arrow
next to the Blocks button on the Insert
toolbar and select Insert Attribute.

2. In the Tag edit box, type the name of the
attribute as you would like it to appear when
the attribute is inserted. For example, if the
attribute is for a person’s name, type Name.
Or, to use a project setting as the tag name,
click the arrow in the Tag edit box and select
a project setting from the drop box (e.g. #Pro-
ject_name). When you insert a block that con-
tains the attribute, the tag name will be auto-
populated with the value of that setting in the
Project Manager dialog box.

3. In the Prompt edit box, type a prompt that
asks what value you want the attribute to



Chapter 24: Drafting in Worksheet View

- 333 -

have when it is inserted. (For example, Enter
your name.) If you selected a project setting as
the tag name, this field is disabled, because
the value will be taken from the Project Man-
ager dialog box.

4. Select a style for the text from the text styles
drop box. If you would like to add or edit a
text style, click to access the Text Styles lib-
rary.

5. To make text bold, select the text that you
want to make bold in the editing window,
then click .

6. To italicize text, click .

7. To underline the text, click .

8. To change the justification of the text, click
the appropriate justification Justification
refers to the way lines of text "line up" in
relation to the window that contains them. A
"left" justification lines the left side of the text
up with the left side of the window, leaving
the right side ragged. button.

Left Justify

Center Justify

Right Justify

9. If you want the attribute to have a pre-
defined (default) value when you insert the
block that contains it, enter the desired text in
the editing window. The value will be dis-
played after you have captured in the attrib-
ute in a block, and then insert the block. At
that time you can accept or overwrite the
default value that you have assigned. If you
do not want the attribute to have a pre-
defined value, leave the editing window
blank. Note that you cannot specify a default
value if a project setting has been selected as
the tag name.

10. Click OK. The text is attached to your
crosshairs.

11. Insert the text attribute in your drawing. You
can now go ahead and create a block con-
taining the attribute.

Editing an Attribute Before it is
Captured in a Block
After you have used the Insert Attribute tool to define
and insert an attribute, you can edit the attribute
before it is captured in a block. For example, you can
move and rotate it, change the text style, or change
the tag name. Simply click on the attribute, and then
edit it just as you would any other type of text.

If you want to edit attribute properties, double-click
the attribute to access the Edit Attribute dialog. If the
attribute is already selected, clicking the browse
button in the Contents field of the Object Properties
panel displays the Edit Attribute dialog.

Creating a Block with Attributes
Pro Architect | Building Essentials | Construction Suite

Once you have defined and inserted an attribute
using the Insert Attribute tool, you can capture it in a
block.
To create a block with attributes:
1. In Worksheet View, select Insert > Blocks >

Define Block, or click on the Insert tool-
bar.

2. Define the block just as would any other
block, making sure that you select the attrib-
utes as well any other objects that you want
to include in the block. For example, if you
added attributes to a title block, select the
entire title block including the attributes, then
press Enter.

3. Click OK in the Define Block dialog.

Inserting a Block with Attributes
Pro Architect | Building Essentials | Construction Suite

Once you have created a block containing attributes
you can use the Insert Block tool to insert the block
and define the attribute values.
To insert a block with attributes:
1. In Worksheet View, select Insert > Blocks >

Insert Block, click the down arrow next to
the Blocks button on the Insert toolbar
and select Insert Block.



- 334 -

2. In the Insert Block dialog, select the block to
insert, then click OK.

3. To define a value for an attribute, click on the
attribute name in the Value column, type the
desired value, then press Enter.

4. Click OK. The block is attached to your
crosshairs.

5. Insert the block in your drawing.

Editing Block Attribute Values
If a block with attributes is present in your drawing,
you can use the Edit Block Attributes tool to edit the
attribute values that have been specified.
To edit attribute values:
1. In Worksheet View, select Insert > Blocks >

Edit Block Attributes, or click the down
arrow next to the Blocks button on the
Insert toolbar and select Edit Block Attrib-
utes. (In Express, use the Tools menu.)

2. Click on the block containing the attributes,
then press Enter.

3. Edit the values in the Edit Block Attributes
dialog, then click OK.

Editing Objects in Worksheet
View
Worksheet View offers a full suite of editing tools,
located on the Modify menu: Delete, Move, Rotate,
Duplicate, Array, Offset, Stretch, Scale, Mirror, Break,
Extend, Trim, Chamfer, Fillet, and Explode. Many of
these tools are available in Model View, and generally
work in the same way.

A unique feature of Worksheet View is that you can
select an editing tool before selecting the object to edit,
or vice versa. (In Model View, you always select the
object first.) If you select the tool first, you need to
select the object by clicking, windowing or crossing it,
then press Enter (or right-click and select Enter) to
complete the selection. You can then proceed with the
editing function. For example, if you want to break a
line, select Modify > Break, select the line and press
Enter, then select the break point.

If you select the object first, you can either select a
tool from the Modify menu or right-click menu.

Note: Throughout the online help, the procedures
for editing objects in Worksheet View describe the
method where the object is picked first.

Selecting Objects in Worksheet
View
There are three ways to select objects in Worksheet
View: by clicking, by windowing, and by crossing.

The simplest way to select an object is to just click on
it. If you want to select a number of objects, click on
the first one, then Shift+click the rest of the objects
that you want to select. Objects that are defined
through dialogs, such as text and attributes, can be
double-clicked to display their property dialogs.

If you are trying to select multiple objects, you may
find it easier to window or cross the objects.
To select objects by windowing:
1. Starting to the left of the objects, click and

drag a selection window around the objects.
All objects that you want to select must be
totally enclosed by the selection window.

To select objects by crossing:
1. Starting to the right of the objects, click and

drag a selection window through the objects
that you want to select. The objects do not
need to be totally enclosed in the window. As
long as they are inside or touching the selec-
tion window, they will be selected.

To select all objects on the current worksheet:
1. Select Edit > Select All.

To re-select the objects you last selected:
1. Select Edit > Select Previous.
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To deselect individual objects:
1. Hold down your Shift key.

2. Click the object that you want to deselect.
To deselect everything in your selection set:
1. Select Edit > Deselect All, or simply click in a

blank spot somewhere else in the drawing
area.

Moving Objects in Worksheet
View
With the exception of polygons and dimensions,
objects in Worksheet View can be moved by simply
clicking and dragging. If you have your Commander
turned on and would like to be able to enter precise
values for the move, you need to select the Move tool
instead of doing a straight drag-and-drop.
To move an object using drag-and-drop:
1. Select the object.

2. Hover your pickbox over the object’s square
blue grip at the center of the object.

3. Click and drag to move the object.

4. When the object is where you want it, release
the mouse button.

To move an object using the Move tool:
1. Select the object.

2. Select Modify > Move, or right-click and
select Move, or click on the Modify tool-
bar.

3. Select a base point for the move. The move
distance and direction will be measured from
this point.

4. Without holding your mouse button down,
move your mouse to move the element. Select
the point you want to move the object to, or
enter a distance and direction in the Com-
mander.

Rotating Objects in Worksheet
View
Objects that were inserted with a single click can be
rotated by clicking and dragging their rotation grip,
which is triangular in shape. Such objects include text,
blocks, inserted views, inserted images, and inserted
CAD files.

For most other objects, you need to use the Rotate
tool. You also need to use the Rotate tool if you want
to be able to enter a precise rotation angle in the
Commander, or you want to rotate the object about a
point other than the center point of the object.

If your Angle Snap is on, the object will rotate in
increments of whatever angle is set for the Angle
Snap. If you are using the Commander, you can
override the Angle Snap by entering the desired angle
in the Commander. If the Angle Snap is off, the object
will rotate in increments of 1º provided Ortho is
turned off.
To rotate an object by clicking and dragging:
1. Select the single-click object that you want to

rotate.

2. Hover your pickbox over the object’s tri-
angular grip.

3. Click and drag to rotate the object.

4. When the object is at the desired rotation,
release your mouse button.

To rotate an object using the Rotate tool:
1. Select the object.

2. Select Modify > Rotate, or right-click and
select Rotate, or click on the Modify tool-
bar.

3. Select a base point for the rotation. The base
point can be any point on the object (e.g. cen-
ter point or corner point), or any point in the
drawing area. The point you pick establishes
an automatic baseline that runs through the
point at 180°. You can rotate full-circle
around this baseline.

4. Without holding your mouse button down,
move your mouse to rotate the object. The
object will rotate from the defined base point
in the direction you move the mouse. If the
Commander is turned on, you can view the
angle of rotation as you rotate, or enter a pre-
cise angle. Positive angle values are read in a
counter-clockwise direction, while negative
values are read in a clockwise direction.
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Duplicating Objects in Work-
sheet View
The Duplicate tool creates a copy of a selected object
that you can then position where you like on the same
sheet.
To duplicate an object:
1. Select the object to copy.

2. Select Modify > Duplicate, or right-click and
select Duplicate, or click on the Modify
toolbar.

3. Select a base point for the copy movement.
Typically you would select one of the object's
grips, but you can click anywhere in the
drawing. The base point is simply a reference
point used to define the move distance.

4. Select the point you are copying the object to.
You can do this by moving your mouse and
then clicking to insert the copy, or by typing
a distance and direction in the Commander.

Note: If you want to copy an object to another
worksheet, use the Copy and Paste tools on the
Edit menu instead.

Arraying Objects in Worksheet
View
You can create copies of objects in a rectangular or
polar (circular) pattern called an array.

When you create a rectangular array, objects are
arranged in a pattern of rows and columns. You can
control the number of rows and columns, the spacing
between the rows and columns, and the array's
rotation angle.

When you create a polar array, objects are arranged in
a circular pattern about a selected center point. You
can specify criteria such as the total number of objects

you want to include in the array, the angle to fill, or
the angle between objects.

To create a rectangular array:

1. Select the object that you want to array.

2. Select Modify > Array, or right-click and
select Array, or click on the Modify tool-
bar.

3. In the Array dialog, enable the Rectangular
radio button.

4. In the Number of Rows box, type the num-
ber of horizontal rows you want or use the
arrows to select a value.

5. In the Number of Columns box, type the
number of vertical columns you want.

6. In the Distance Between Rows box, type the
spacing you want between rows. This determ-
ines the distance between objects appearing
in columns (vertical spacing).

7. In the Distance Between Columns box, type
the spacing you want between columns. This
determines the distance between objects
appearing in rows (horizontal spacing).

8. In the Array Rotation Angle box, type the
degree of rotation for the array.

9. Click OK. The array is created.
To create a polar array:

1. Select the object that you want to array.

2. Select Modify > Array, or right-click and
select Array, or click on the Modify tool-
bar.

3. In the Array dialog, enable the Polar radio
button.

4. Click , and then select the point in your
drawing area that will serve as the center of
the array.

5. To rotate the items as they are arrayed,
enable the Rotate Items check box. If you

Cutting_Copying_Pasting_Worksheet.htm
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disable this check box, each item in the array
will have the same orientation as the selected
object.

6. From the Method drop box, select the criteria
that you want to use to create the array.

Total Number of Items & Angle to Fill

Total Number of Items & Angle Between Items

Angle to Fill & Angle Between Items

7. Enter values for the two parameters that
support the method you selected.

Total number of items. The total number of
items in the array, including the selected
object.

Angle to fill. The distance to fill around the
circumference of the array.

Angle between items. The distance between
each item.

Arrays are generated counterclockwise from
the selected object. To produce a clockwise
array, enter a negative value in the Angle to
fill edit box.

8. To preview the array, click Preview. The
array is displayed in your drawing area. If
you are satisfied with the array, click Yes in
the dialog to create it. Otherwise, click No to
return to the Array dialog.
If you do not want to preview the array, just
click OK in the Array dialog to create the
array.

Offsetting Objects in Worksheet
View
Offsetting creates a new object whose shape is the
same as the shape of a selected object. Offsetting a
circle, for example, creates a larger or smaller circle,
depending on which side you specify for the offset.

You can offset lines, polylines, circles, arcs and
polygons.
To offset an object:
1. Select the object to offset.

2. Select Modify > Offset, or right-click and
select Offset, or click on the Modify tool-
bar.

3. In the Offset dialog, enter the distance that
you would like to offset the object, then click
OK.

4. In the drawing, click on the side that you
would like to offset to.

Stretching Objects in Worksheet
View
Any object that can be stretched manually (by editing
grips) can also be stretched using the Stretch tool.
With this method you can specify a stretch distance
and direction with the Commander.
To stretch an object:
1. Select Modify > Stretch, or right-click and

select Stretch, or click on the Modify
toolbar.

2. Click and drag a crossing selection window
(from right to left) around the line end or
corner that you want to stretch.

3. Press Enter, or right-click and select Enter.
4. Select a base point to stretch from. This can

be any point in the drawing.

5. Move your crosshairs in the direction that
you want to stretch, then either click when
the object is the desired length, or enter a
stretch distance in the Commander.

Scaling Objects in Worksheet
View
You can use the Scale tool to increase or reduce the
size of an object.
To scale an object:
1. Select the object.

2. Select Modify > Scale, or right-click and
select Scale, or click on the Modify tool-
bar.
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3. Select a base point to scale from. Typically
this is a point on the object.

4. Enter the desired scale factor in the Scale
edit box. For example, to double the size of
the object, type 2. To reduce the size by half,
type 0.5.

5. Click OK.

Note: If you are scaling a block, and the block
contains a dimension, the dimension value does not
scale. If you need to scale the dimension value,
double-click the block, select the dimension, then
edit the Value Scale in the Object Properties panel.

Mirroring Objects in Worksheet
View
You can create a mirror image of a selected object
using the Mirror tool. You mirror the object by
specifying a mirror line — an imaginary line about
which the object is flipped. Once the object has been
mirrored, you can choose whether or not you want to
delete the original object.
To mirror an object:
1. Select the object that you want to mirror.

2. Select Modify > Mirror, or right-click and
select Mirror, or click on the Modify tool-
bar.

3. Click two points to define a mirror line. The
element is mirrored.

4. When prompted to choose whether or not
you want to delete the original object, click
Yes to delete the original object, or click No
to leave the original intact.

Breaking Objects in Worksheet
View
You can use the Break tool to create a break in a line,
polyline, arc, or polygon. This divides the object into

segments which can be edited individually, and adds
a grip at the break point.
To break a line, polyline, arc or polygon:
1. Select the object.

2. Select Modify > Break, or right-click and
select Break, or click on the Modify tool-
bar.

3. Select the point where you want to break the
object.

Extending Objects in Worksheet
View
You can use the Extend tool to extend one object to
another.
To extend an object to another:
1. Select Modify > Extend, or right-click and

select Extend, or click on the Modify tool-
bar.

2. Select the object you want to extend to, then
press Enter (or right-click and select Enter).
The object must be in the path of the object
that you want to extend.

3. Select the object that you want to extend. The
object is extended to the first object you selec-
ted.

Trimming Objects to Other
Objects (Worksheet View)
When two drafting objects cross each other, you can
use the Trim tool to trim one object to the other.
To trim an object to another object:
1. In Worksheet View, select Modify > Trim, or

right-click and select Trim, or click on the
Modify toolbar.

2. Select the object that you want to trim to,
then press Enter (or right-click and select
Enter). In the following example, you would
select the circle as the object to trim to.
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2. Select the object that you want to trim, click-
ing near the end you want to trim.

The line is trimmed automatically to the nearest
border.

In the above example, if you clicked on the center
of the line, the portion inside the circle would be
trimmed:

Chamfering Objects in Work-
sheet View
Use the Chamfer tool to create a beveled connection
between two lines or polylines.
To chamfer objects:

1. Select Modify > Chamfer, or click on the
Modify toolbar.

2. In the Chamfer Distances dialog, specify the
first and second chamfer distance (the dis-
tance each object will be cut back). The dis-
tances that you specify will be applied in the
order that you select the objects.

3. Select the first object, then select the second
object. The chamfer is created.

In the following example, line 1 will be cut back
(horizontally) by the First Distance specified, and
line 2 will be cut down (vertically) by the Second
Distance specified. A line will then be drawn
between the two endpoints to create the angled
connection.

Filleting Objects in Worksheet
View
Filleting connects two lines together at a point where
they would naturally meet if both were extended. If
the objects already intersect, one object is trimmed to
the other. The Fillet tool can be used on lines,
polylines, arcs, and circles.

There are two fillet options available. The Fillet - Join
tool performs a straight connection, causing the lines
to meet at a single point, while the Fillet - Radius tool
connects two lines with a curve.
To join objects at a single point:
1. Select Modify > Fillet > Fillet - Join, or click

the arrow next to on the Modify toolbar
and select Fillet - Join.

2. Select the first object that you want to join. If
the object is a line or arc, click near the spe-
cific end that you want to extend.

3. Select the second object that you want to join.
The objects are connected.

To join objects with a curve:
1. Select Modify > Fillet > Fillet - Radius, or

click the arrow next to on the Modify
toolbar and select Fillet - Radius.

2. In the Radius dialog box, specify the desired
radius for the curve, then press Enter or click
OK.

3. Select the first object that you want to fillet.

4. Select the second object that you want to fil-
let. The objects are connected with a curve.
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Exploding Objects in Worksheet
View
You can use the Explode tool to “blow up” an object
into its component parts. You could use this on
objects such as blocks, inserted model views and
inserted CAD files (such as a detail or title block).
Once an object has been exploded you are free to edit
its individual components.
To explode an object:
1. Select the object.

2. Select Modify > Explode, or right-click and
select Explode, or click on the Modify
toolbar.

Deleting Objects in Worksheet
View
You can delete an object from your drawing in two
quick steps.
To delete an object:
1. Select the object.

2. Press the Delete key on your keyboard, select
Modify > Delete, or right-click and select
Delete, or click on the Modify toolbar.

Editing the Line Style of Lines,
Shapes and Details in Work-
sheet View
By default, lines, shapes and details are drawn using
the color, line type and line weight assigned to the
layer that the line is drawn on. You can easily change
the line style of an object after you have inserted it.
To change the line style of a line object:
1. Click on the line, shape or detail to select it.

2. In the Object Properties panel, select the
desired settings from the Color, Line Pattern
and Line Weight drop boxes.

Measuring Distance and Angle
in Worksheet View
Express | Pro Architect | Building Essentials |
Construction Suite

Using the handy Measure tool you can measure the
distance and angle between any two points in your
drawing.
To measure in Worksheet View:

1. Select Tools > Measure, or click on the
Tools toolbar.

2. Click the first point that you want to measure
from. As you move your crosshairs away
from this point, distance and angle
information is reported on the status bar:

3. Click the second point that you want to meas-
ure to. All calculations, including the distance
along the X axis and Y axis, are reported in
the Measure dialog.

Drafting Settings
In your Drafting Settings you can select a default line
style to be used for drafting objects (lines, circles, arcs,
rectangles) when they are drawn. You can also set a
default line style for revision clouds, hatched
polygons, and details.

You can also assign a layer to objects created in Model
View that are not building elements. These include
lines and shapes, revision clouds, hatched polygons,
details, room division lines, CAD blocks, text,
dimensions, schedules, room regions, site boundaries,
terrain lines, and wall panel components.

When these objects are imported into Worksheet
View, they will reside on the layer assigned to them if
you explode the block that they are part of.

Specifying Default Revision
Cloud Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can define the settings that you would like your
revision clouds to have prior to drawing them. You
can select a line style and hatch pattern, and define an
arc size.
To define revision cloud settings:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Revi-
sion Cloud in the left column.
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3. By default, revision clouds are drawn on the
Drafting - Hatch layer. To select a different
layer, click the browse button next to the
Layer box, then select a layer from the Lay-
ers dialog.

4. To override the color, line type, or line
weight, click in the Color, Line Types, or
Line Weight box and make the desired selec-
tion.

5. To apply a pattern to revision clouds which is
visible in Patterned display mode, enable the
Include check box in the Pattern area. Click
Select in the Pattern area to select a pattern
from the Patterns library.

6. To define the size of the arcs in the revision
cloud, enter values in the Minimum Arc
Length and Maximum Arc Length edit
boxes..

7. Click OK.

Specifying Default Polygon
Hatch Settings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can define the settings that you would like
hatched polygons to have prior to drawing them,
such as the line style and hatch pattern.
To define polygon hatch settings:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Poly-
gon Hatch in the left column.

3. By default, polygons are drawn on the Draft-
ing - Hatch layer. To select a different layer,
click the browse button next to the Layer box,
then select a layer from the Layers dialog.

4. To override the color, line type, or line weight
assigned to the selected layer, click in the
Color, Line Types, or Line Weight box and
make the desired selection.

5. To apply a pattern to polygons, which is vis-
ible in Patterned display mode, enable the
Include check box in the Pattern area. Click
Select in the Pattern area to select a pattern

from the Patterns library.
6. Click OK.

Selecting a Default Line Style
for Drafting Objects
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can select a default line style for lines, arcs,
circles and rectangles in Model View.
To select a default layer for drafting objects:
1. Select Settings > Drafting Settings, or click

on the Settings toolbar.

2. In the Drafting Settings dialog, select the
Drafting Objects item.

3. Click Settings, and then select the desired
layer in the Line Style dialog. The layer
determines the color, line type, and line
weight of the object.

4. You can override the color, line type or line
weight by clicking on the desired property
and making a different selection from the
drop box.

5. Click OK in the Drafting Settings dialog.

Note: You can edit the line style of a drafting object
after it has been drawn.

Selecting a Default Line Style
for Revision Clouds
You can select a default line style to use when
drawing revision clouds in Model View.
To select a default line style for revision clouds:
1. Select Settings > Drafting Settings, or click

on the Settings toolbar.

2. In the Drafting Settings dialog, select the
Revision Cloud item.

3. Click Settings, and then select the desired
line style in the Line Styles dialog.

4. Click OK in the Drafting Settings dialog.

Note: You can edit the line style of a revision cloud
after it has been drawn.
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Specifying a Default Line Style
and Pattern for Hatched Poly-
gons
You can select a default line style, pattern and color to
use when drawing hatched polygons in Model View.
To specify default settings for hatched polygons:
1. Select Settings > Drafting Settings, or click

on the Settings toolbar.

2. In the Drafting Settings dialog, select the
Polygon Hatch item.

3. Click Settings.
4. By default, polygons are drawn on the Draft-

ing - Hatch layer. To select a different layer,
click the browse button next to the Layer box,
then select a layer from the Layers dialog.

5. To override the color, line type, or line
weight, click on the property and make a
selection from the drop box.

6. Click OK in the Drafting Settings dialog.

Note: You can edit the properties of a hatched
polygon after it has been drawn.

Selecting a Default Layer for
Details
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can select a default line style to use when
drawing batt insulation, rigid insulation, wood
sections, masonry sections and cut lines in Model
View.
To specify default settings for details:
1. Select Settings > Drafting Settings, or click

on the Settings toolbar.

2. In the Drafting Settings dialog, select the
Details item.

3. Click Settings.
4. By default, details are drawn on the CAD

layer. To select a different layer, click the
browse button next to the Layer box, then
select a layer from the Layers dialog.

5. To override the color, line type, or line
weight, click on the property and make a
selection from the drop box.

6. Click OK in the Drafting Settings dialog.

Note: You can edit the properties of a detail after it
has been drawn.

Assigning Layers to Objects in
Model View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can assign a layer to objects created in Model
View that are not building elements. These include
lines and shapes, revision clouds, hatched polygons,
details, room division lines, CAD blocks, text,
dimensions, schedules, room regions, site boundaries,
terrain lines, and wall panel components.

When these objects are imported into Worksheet
View, they will reside on the layer assigned to them if
you explode the block that they are part of.

A layer definition includes settings for an object's line
style, line weight and color.
To assign layers to objects in Model View:
1. Select Settings > Drafting Settings.
2. In the Drafting Settings dialog, select the

object to which you want to assign a layer.

3. Click the drop box in the Layer column, and
then select the desired layer from the drop
list.

4. Click OK.

Note: Building elements have a layer assignment
on their Appearance property page.
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There are several powerful tools available to help you analyze your project and generate various types of reports
and information.

Area/Perimeter. You can use the Area/Perimeter Calculator to display the area (e.g. square footage) and perimeter
length of each location in your model, as well as the total area and total perimeter (of all locations).

Room Measurements. You can use a Room Region tool to instantly calculate the area, perimeter and volume of a
room or selected area in your model and insert the information in your drawing. 

When you use a Room Region tool, a boundary is created around the room or area. This boundary defines a room
region in your model that can be used in the Area/Perimeter Calculator and for creating a room region schedule.

Project Estimate. Any elements that you insert in your drawing are tracked internally, making it possible to
generate a project estimate automatically. You can also generate a partial estimate for selected elements when
needed.

When you generate an estimate for your project, the estimate comprises a quantity report as well as a cut list. The
quantity report, or bill of materials, lists all of the materials used to build your house, as well as the quantity, unit
price and total cost of each material. The cut list reports all the timber and steel members in your drawing calculates
the number of members you need to purchase using realistic cut lengths of your choice.

Quote. A quote is a list of products with quantities, pricing and other important information. Quotes are used by
building material supply retailers, wholesalers, distributors and contractors to facilitate the design, sale and
installation of construction projects. You can use the Generate Quote tool to instantly generate a quote that opens in
Quote Generator software (included). You can then edit the quote to suit your needs.

Schedules. You can display, print and insert complete door, window, member or room region schedules for each
location in your project. By default, doors, windows or members are tagged with schedule marks that link them to
the associated schedule. 

Upload to ERP. If your organization uses an Enterprise Resource Planning (ERP) system, you can connect to it
directly from Envisioneer and upload an order to it using the Upload to ERP tool.

You can edit a schedule's layout, text styles and line styles, and control the content and style of schedule marks.

REScheck Export. You can use the REScheck Export tool export data from your Envisioneer model to a REScheck
file to determine if it meets IECC or certain state code requirements.

Calculating Area and Perimeter
Personal Architect | Pro Architect | Building Essentials | Construction Suite

The Area/Perimeter Calculator displays the area (e.g. square footage) and perimeter length of the building footprint
on each location in your model. It also displays the total area and total perimeter (of all locations). You can use the
calculator at any given point in time. The values in the calculator update automatically as your model increases or
decreases in size.
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Note that the calculations are taken from the exterior
side of the building’s perimeter walls.
To measure area:
1. Select Tools > Analyze > Area/Perimeter, or

click on the Analyze toolbar. Area
measurements are displayed on the Area tab
of the Area/Perimeter Calculator dialog.
Perimeter measurements are shown on the
Perimeter tab.

If you have created room regions in your
model, they are listed under their associated
location names. For example, if you have
calculated the area of your garage using the
Room Region by Room tool, you will see the
garage listed under the Ground Floor
location, or whatever location it was built on.
By default, the sub-total of each location is
the total area or perimeter of that location,
including all regions on that location. You can
omit selected locations or room regions from
the total if you want. If a calculation is
included in the total, it is highlighted green.

2. To omit a location or region from the cal-
culation, select Omit from the drop box in the
Include column. By default, room regions are
already omitted because they are part of the
overall calculation for the location.

3. To subtract the area or perimeter of a region
from a location’s sub-total, select Subtract
from the drop box in the Include column. For
example, if you want to remove the garage
from the calculation, select Subtract next to
the Garage room region. The garage’s meas-
urement then highlights red, indicating that it
has been subtracted.

4. To add a location that you have omitted back
into the calculation, select Add from the drop
box in the Include column.

5. To turn the grid lines off, uncheck the Show
Grid check box.

6. To print the calculations, click Print.
7. When you are done viewing the area cal-

culations, click OK.

Note: The units of measure used for the area and
perimeter can be changed on the Units of Measure
page in your program settings.

Calculating the Space in Rooms
and Areas
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Room Region by Room tool or the Room
Region by Picking Points tool you can instantly
calculate the area, perimeter and volume of a room or
selected area in your model and insert the information
in your drawing.

When you use a Room Region tool, a boundary is
created around the room or area. This boundary
defines a room region in your model that can be used
in the Area/Perimeter Calculator and for creating a
room region schedule. You can control the line style
of the region boundary and apply a hatch pattern to
the region if you want.
To calculate the space in a room or area:
1. If you want to calculate the space in a room,

select Tools > Analyze > Schedules > Room
Region by Room, or click on the Ana-
lyze toolbar. Note that this tool requires that
the room have a closed wall layout.

2. If you want to calculate the space in a par-
ticular area in your design, select Tools >
Analyze > Schedules > Room Region by
Picking Points, or click on the Analyze
toolbar. This does not necessarily have to be a
room — it could be any space, such as a court-
yard.

3. To display text in the title of the calculation
note, enable the Display Name radio button,
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then type the desired text in the adjacent edit
box (e.g. Garage).

4. To display a mark as the title of the note,
enable the Display Mark radio button, then
type the desired mark text in the adjacent edit
box.

5. Select the desired justification for the title by
clicking the appropriate justification button.

Left Justify

Center Justify

Right Justify

6. In the Calculation Display area, check off
which pieces of information you would like
to display in the note. Choices are Display
Area, Display Perimeter and Display
Volume. Note that the units of measure used
for the area, perimeter and volume can be
changed on the Units of Measure page in
your program settings.

7. If you enabled Display Volume, enter the
height of the room in the Height edit box. By
default, the location’s wall height is used, but
you can overwrite this if necessary.

8. If you plan to create a room region schedule
later, you can enter information in the Addi-
tional Schedule Fields area. These fields, which
include Ref Note, Floor Finish, Ceiling Finish,
Wall Finish and Base Finish, are fields that can
appear in a room region schedule.

9. To define the appearance of the note and
room region object, select the Settings tab.

l To select a text style for the title text,
click the Text Style button in the Title
Appearance area, then make a selection
from the Text Styles dialog.

l To select a line style for the mark if
you are using a mark instead of text,
click the Line Style button in the Title
Appearance area, then make a selection
from the Line Styles dialog.

l To select a style for the mark if you
are using a mark instead of text, make
a selection from the Mark Style drop
box. Choices include Square, Circle,
Hexagon, Octagon, and Text Only.

l To select a text style for the body of
the note, click the Text Style button in
the Calculation Appearance area, then
make a selection from the Text Styles
dialog.

l To select a line style for the region
boundary, click the Line Style button
in the Region Appearance area, then
make a selection from the Line Styles
dialog.

l To display a hatch pattern throughout
the region, click the Pattern button
and make a selection from the Pat-
terns dialog.

l To edit the color of the hatch pattern,
click the Color swatch and make a
selection from the Color dialog.

10. Once you’ve defined your settings, click OK.
11. If you selected the Room Region by Room

tool, mouse over the room whose space you
are calculating (it will highlight), then click
inside the room. The room region is created,
and the note is inserted.

12. If you selected the Room Region by Picking
Points tool, pick points to define the bound-
ary of the area whose space you want to cal-
culate, then right-click and select Finish. The
room region is created, and the note is inser-
ted.

13. You can now calculate the space of another
room, or click Cancel to close the Room
Region dialog.

Note: Room regions are linked to their associated
walls and update automatically if walls are
stretched.

Note: By default, room regions inserted by room
extend to the wall core (e.g. stud wall). If you
prefer that they extend to the interior wall surface,
you can define this in your program settings prior
to inserting the room regions. See Defining the
Extents of Room Regions to be Inserted in Rooms on
page 346.
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Note: Region hatch patterns are only visible when
the display mode is set to Patterned.

Note: Room regions are listed in the View Filter, so
you can control their visibility and selectability.

Defining the Extents of Room
Regions to be Inserted in
Rooms
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a room region inserted with the Room
Region by Room tool extends to the inside edge of the
wall core (e.g. stud wall). If you prefer you can set the
room region to extend to the interior edge of the
interior wall surface (e.g. drywall) instead. This is an
insertion setting that is defined in your program
settings. Changing this setting has no effect on room
regions that have already been inserted. It only affects
room regions that you are going to insert with the
Room Region by Room tool. If you want to change
the extents of an existing room region you can click
and drag its editing grips.
To define the extents of room regions to be
inserted with the Room Region by Room tool:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, click Build-
ing Aids in the left column.

3. In the Insertion by Room area, click the drop
box next to the Room Regions item.

4. If you want room regions in rooms to extend
to the wall core, select Wall Core. If you want
them to extend to the interior wall surface,
select Wall Surface.

5. Click OK.

Editing Room Region Properties
Once you have inserted a room region note in your
drawing, you can edit the settings pertaining to the
content and style of the note, and the style of the
room region boundary and pattern.
To edit room region properties:

1. Click inside the room region to select it.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the settings in the Room Region dialog.

4. Click OK.

Resizing or Reshaping a Room
Region
You can resize or reshape a room region boundary by
clicking and dragging its edges and corners. The
calculations in the room region note update
automatically.
To resize or reshape a room region:
1. Click inside the room region to select it.

2. To resize the region, click and drag the solid
blue grips located at the center of each edge.
Alternatively you can use the Move Edge
tool on the right-click menu to move an edge.

3. To reshape the region, click and drag the hol-
low blue grips located at the corners. Altern-
atively you can use the Stretch tool on the
right-click menu.

Note: Room regions are linked to their associated
walls and update automatically if walls are
stretched.

Moving Room Region Text
By default, the space calculation note appears at the
center of a room region. You can move the title or
body of a room region note using the Move Text tool.
To move room region text:
1. Click inside the room region to select it.

2. Right-click and select Move Text, or select
Edit > Modify Elements > Move Text.

3. Hover your pointer over the solid blue grip
displayed over the text, then click and drag to
move the text where you want it. Note that
the title and body of the note are moved sep-
arately.

4. Release your mouse button.

Project Estimate
The Project Estimate tool automatically generates a
quantity report and cut list at any time during the

Room_Region_Dialog.htm
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design process. If you make changes to your model,
the estimate will update automatically.

The quantity report, or bill of materials, lists all of the
materials used to build your house, as well as the
quantity, unit price and total cost of each material.
The quantity report also lists assemblies, which are
part of an element’s properties. For example, a wall
may have assemblies such as studs, drywall,
insulation, vapor barrier, and drywall screws.

The cut list reports all the timber and steel members
in your drawing calculates the number of members
you need to buy from your supplier using realistic
lengths of your choice.

When you view your project estimate, you can choose
a report template to apply to the estimate. The
template determines what information is reported,
how it is reported, and the file type created when you
save the estimate. Some templates generate files that
are compatible with popular estimating programs.
You can edit report templates to suit your needs, or
even create new ones.

Editing the Quantitative Prop-
erties of Elements
Building Essentials | Construction Suite
Included among the property pages of every element
is a Quantity property page. This page contains a
number of variables that are commonly used in
inventory control, quoting and estimating — fields
such as Manufacturer, Part Number, Price and Unit of
Measure. The information on this page is used when a
project estimate is generated.

Some of the fields on the Quantity page are used to
define the sort order of information in quantity
reports, as defined by the report template used. These
fields include Division, Alt Code, Phase, Usage and
Category.

You can edit the quantitative properties of elements in
the catalog, or in your drawing. Alternatively you can
generate and save a project estimate, then edit the
fields in the estimate’s associated editor, such as Excel
or Notepad (depending on the report template used).
To edit the quantitative properties of elements in
your drawing:
1. Select the element in your drawing.

2. Right-click and select Properties.
3. In the properties dialog, select the Quantity

tab.
To edit the quantitative properties of elements in
your catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
inside the catalog panel and select Element
Manager.

2. Select the element(s) that you want to edit.

3. In the properties pane, select the Quantity
tab.
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Note: Editing elements in a catalog has no effect on
elements already inserted in your drawing. It only
affects future insertions of the element.

Below is a description of each available property.

Manuf: The Manufacturer of the product. Click the
browse button to access the Manufacturers library
where you can add, edit and select manufacturers.

Supplier: The company or store who will be
supplying the product.

Price: The unit price of the product. This value
correlates with the selection in the Units field. For
example, if Linear Feet is specified in the Units field,
you would enter the price per linear foot here.

Phase: Materials are often shipped to the building
site in phases, such as the Site Work, Foundation or
Framing phase. The selection here indicates the phase
this particular element is associated with. Phases can
be used as sort keys in estimates and quotes. Click the
browse button to select a phase from the Phase
library.

Category: Elements can be grouped into categories
according to their type, such as sheathing or pre-cut
lumber. Categories can be used as sort keys in
estimates and quotes. Click the browse button to
select a category from the Category library.

Division: A construction division identification. In
North America, CSI divisions are used.

Part No.: Part Number. A series of numbers that
identifies the product. This could be a vendor part
number, manufacturer part number, etc.

Alt Code: An alternate code for identifying the item.
You might use this to link to an inventory control
database or estimating system. Vendors may use Alt
Codes as alternate lookup keys or product IDs, often
to facilitate product substitutions. The Alt Code can
be used as a sort key in estimates and quotes.

An Alt Code can be any series of numbers or
characters, and you can also incorporate element
variables into the code by creating a custom Alt Code
formula. The Alt Code is a great way to combine two
or more variables into one for simpler sorting. For
example, instead of grouping materials by Location
first and then by Phase in your report template,
resulting in materials from the same Phase being
spread out into multiple location groups, you could

group them by Location AND Phase at the same time
by specifying an Alt Code formula that includes both
of these variables. By using the Alt Code as the
primary sort key, this would put all items sharing the
same Location and Phase into onto one group, which
would make it easier to create delivery and
distribution lists. For example, if you specified an Alt
Code formula of Location_Phase, you might see
headings and groups such as 'Ground Floor_Wall
Systems', 'Second Floor_Wall Systems', etc. in your
project estimate.

To create a custom formula, click the browse button
next to the Alt Code field, then define a formula in
the Define Formula dialog. See Specifying Formulas
on page 368.

Usage. An element's usage can help make it more
clear what the element is to be used for. For example,
a 2" x 4" member could be used for Blocking, or for a
Stud. Usages can be used as sort keys in estimates
and quotes. Click the browse button to select a usage
in the Usages library.

Unit of Measure. The unit of measure used to
quantify the element. You can quantify an element in
terms of a Count, Length, Area or Volume. For example,
if you purchase vapor barrier in rolls, you might
select Roll as the unit of measure. In this case you
would be quantifying a Count. If you would rather
measure your vapor barrier in linear feet, you would
select LNFT instead, which is a Length measurement.
You might want to quantify drywall in terms of Area,
in which case your unit of measure might be SQFT or
SQMM.
Units of measure are stored in a library for your
convenience. You can add and edit units of measure
in the Units of Measure library. Each unit of measure
has a set of properties that determine what the unit
quantifies (Count, Length, Area or Volume), the unit
format (Decimal, Inches, etc.), the unit precision, and
the unit text displayed after the numerical value. Most
importantly, each unit of measure contains a
conversion factor. The program measures all
quantities in millimeters initially. The conversion
factor is the number you need to multiply by to
convert from millimeters to the unit you want.
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Click the browse button next to the Units field to
select a unit of measure from the Units of Measure
library.

Note: The Unit of Measure selected on element's
Quantity property page is not necessarily the unit
that will be used in the project estimate. This is
determined by the report template used to display
your estimate, specifically the Record defined for
that element in the report template. If the Unit in a
Record is set to the Quantity variable, or to a
formula that uses the Quantity variable, the
program will use the measurement calculated from
the Quantity page settings.

Mark. Displays a text mark on the element in 2D.
Selecting Auto displays an auto-generated mark
whose properties are determined by the default
Element Mark Settings in your Program Settings.
Selecting Custom enables you to type a custom text in
the Mark field. If you do not want to display a mark,
select Off.
Include in Quantities. Specifies whether or not the
element will be included in quantity reports.

Replace with Assemblies. If disabled, and an
element has assemblies defined on the Quantity tab,
both the element and its assemblies will appear in
quantity reports. If enabled, only the element's
assemblies will be reported.

Include cut lengths?. (Members and columns only) If
enabled, tally lines containing cut lengths will be
added to the quantity report, preceding the total
linear length calculation of a member or column.

Quantify each Member. (Timber Frames only) If
enabled, each member that makes up a timber frame
will be quantified separately in the quantity report.

Editing Material Pricing
Most elements have a default unit price set for them
in their properties. These prices are used in the project
estimate.

You can specify prices for elements in the catalog, or
elements in your drawing. If you have already created
your design, you can edit the prices of inserted
elements by selecting them in the drawing, then
editing their properties. Alternatively you can
generate and save a project estimate, then edit the

pricing in the estimate’s associated editor, such as
Excel or Notepad (depending on the report template
used).

Note: You can specify pricing for material finishes
(brick, paint, wallpaper, etc.) that are applied to
elements by adding an assembly to the material. See
Editing Material Properties.
To edit the price of an inserted element:
1. Select the element in your drawing. You can

select multiple elements of the same type
using Shift+click.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the properties dialog, select the Quantity
tab.

4. Edit the value in the Price edit box. Note that
prices are unit prices. For a carpet, for
example, you would enter the price per
square foot, not the price of the entire carpet.

5. Click OK in the properties dialog.
If you edit the price of any element in the catalog, the
price change will affect all new insertions of the
element.
To edit material pricing in the catalog:
1. Select File > Catalogs > Element Manager,

or right-click an element in the catalog and
select Element Manager.

2. Select the element that you want to edit.

3. In the properties pane, select the Quantity
tab.

4. Edit the value in the Price edit box. Note that
prices are unit prices. For a carpet, for
example, you would enter the price per
square foot, not the price of the entire carpet.

5. Click OK.

Exporting the Quantitative Prop-
erties of all Catalog Elements to
a Text File
You can use the Export TXT File tool in the Element
Manager to export the description and key
quantitative properties of all catalog elements to a tab-
separated text file. Each entry in the file includes the
element Name, Part Number, Category, Phase, Usage,
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and Unit of Measure. Sample entries are shown
below.

To export the quantitative properties of elements
to a text file:
1. Make sure that the catalog that you want to

export is the current catalog.

2. Select File > Catalogs > Element Manager,
or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

3. In the Element Manager dialog, select File >
Export TXT File.

4. In the Save As dialog box, type a name for
the file in the File name edit box (without
extension).

5. Select the desired save location, then click
Save.

Attaching Assemblies to Ele-
ments
Pro Architect | Building Essentials | Construction Suite

Assemblies are parts that are linked to an element,
but do not exist in the drawing. For example, a door
may have a Lock Set assembly attached to it which
includes a door lock and a set of hinges. A wall may
have a Drywall assembly that includes drywall sheets,
drywall screws, and paint. If an element in your
project has an assembly assigned to it in its
properties, the materials in that assembly will be
included in the quantity report. You can attach one or
more assemblies to an element.
To attach assemblies to an element: 
1. To attach assemblies to an inserted element,

select the element, and then right-click and
select Properties, or select Edit > Modify
Elements > Properties. You can select

multiple elements of the same type using
Shift+click, or the Select All Similar tool.
To attach assemblies to an element in the
catalog, select File > Catalogs > Element
Manager. In the Element Manager, select the
element in the left pane.

2. In the property dialog, select the Quantity
tab.

3. Click in the Assemblies area.

4. In the Assembly dialog, select the assembly
that you want to attach to the element, then
click OK. The contents of the assembly are
displayed in the Assemblies pane on the
Quantity page.

To edit an assembly that is attached to the element,

select the assembly and click . You can
then define the assembly in the Assembly library.

Tip: You can customize the Assembly library by
adding or editing assemblies if needed.

Removing an Assembly from an
Element
Pro Architect | Building Essentials | Construction Suite

You can remove assemblies from an element using the
Remove tool on the element's Quantity property page.
To remove an assembly from an element:
1. Access the element’s Quantity property page.

2. In the Assemblies area, select the assembly that
you want to remove.

3. Click .

4. Click OK.
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Replacing an Element with its
Assemblies in Quantity Reports
Pro Architect | Building Essentials | Construction Suite

By default, if an element has assemblies defined on its
Quantity property page, both the element and its
assemblies will appear in quantity reports. You can
choose to report only an element’s assemblies if you
want.
To replace an element with its assemblies in the
quantity report:
1. Access the element’s Quantity property page.

2. In the Quantity panel, enable the Replace ele-
ment with assemblies check box. If this
check box is disabled, the element will appear
in the quantity report along with all of its
assembly items.

3. Click OK.

Viewing a Quantity Report
Pro Architect | Building Essentials | Construction Suite

The quantity report, or bill of materials, lists all of the
materials used to build your house, as well as the
quantity, unit price and total cost of each material.
The quantity report also lists assemblies, which are
part of an element’s properties. For example, a wall
may have assemblies such as studs, drywall,
insulation, vapor barrier, and drywall screws.

The quantity report is displayed on the Quantity
Report page of the Generate Project Estimate dialog.

To view a quantity report:
1. To view a quantity report for the full project,

select Tools > Analyze > Generate Project
Estimate, or click on the Analyze
toolbar.

To view a quantity report for specific
elements only, select the elements in your
drawing, then right-click and select Generate
Estimate.

2. Make sure the Quantity Report tab is

selected.

Selecting a Report Template
Pro Architect | Building Essentials | Construction Suite

By default, the quantity report uses the Standard
Report Form template, which generates a TXT file. You
can select a different report template to use if you
want. Below is a list of the available templates.
l Standard Report Form
l Microsoft® Excel XLS
l BuilderTREND Link
l CG Visions BIM Pipeline
l Constellation Buildsoft
l Constellation FAST
l Constellation HomeDev
l Constellation NEWSTAR
l Estimator (CSV)
l PrioSoft File Format (CSV)
l ProEst Quantity Template (TXT)
l Quote Generator
l CSG TakeOff Plus (TXT)
l UDA Construction Office™ (XLS)

If you created a custom template in an older version
of the program, or would like to use a template that
you have copied to your system but don't see in the
list, you can open it using the Open Template tool.
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To select a report template:
1. In the Generate Project Estimate dialog,

select the template you want to use from the
template drop box.

To open a report template that is not in the list:
1. In the Generate Project Estimate dialog, click

the Open Template button .

2. In the Open dialog, locate the template that
you want to open. If the template was created
in the current version of the program, it will
have an *.RXML extension. If the template
was created in an older version of the pro-
gram, click the drop box next to the File
Name edit box and select Report Template
(pre-version 8.0), then locate the template. It
will have an *.RPT extension.

3. Click Open.
4. In the Report Template dialog, click Save.

The template is added to the list, and your
estimate is displayed using that template.

Filtering Locations from an
Estimate
Pro Architect | Building Essentials | Construction Suite

In a project estimate, materials are grouped by
location, and there is a terrain category for
landscaping materials. You can omit a location from
your quantity report and/or cut list if you want.
To filter locations from the estimate:
1. In the Generate Project Estimate dialog, make

sure the correct tab is selected (Quantity
Report or Cut List). The location filter applies
to the current tab only.

2. Click beside the report form drop box.

3. To omit a location and its elements from the
report, click the location’s filter icon. You can
omit landscaping elements from the report by
filtering the terrain out.

4. Click OK. The estimate is updated.

Ignoring Assemblies Attached
to Materials
Pro Architect | Building Essentials | Construction Suite

If an element has a material applied to it on its
Appearance property page, that material may have an
assembly attached to it. By default, the information
contained in those assemblies is included in the
quantity report so that material pricing is included in
the overall project cost.

To ignore the information in assemblies that are

attached to materials, click in the Generate
Project Estimate dialog box. The estimate will
regenerate itself.

If you have chosen to ignore material assemblies, you

can choose to include them again by clicking .

Printing a Quantity Report
Pro Architect | Building Essentials | Construction Suite

You can print the quantity report directly from the
Generate Project Estimate dialog. Alternatively you
can open the quantity report in its associated editor
and print it there.
To print the quantity report:
1. If you are in the Generate Project Estimate

dialog, select the Quantity Report tab.

2. Select File > Print, or click to the left of
the report form drop box.

3. In the Print dialog, select the printer you
want to use, then click Print.

Tip: You can also print a saved report by opening it
in its associated editor, and printing it from there.

Saving a Quantity Report
Pro Architect | Building Essentials | Construction Suite
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The Generate Project Estimate dialog acts like a
viewer for your quantity report. If you want to save
the quantity report to a file, you need to use the Save
and Close tool. By default, quantity reports are saved
in the same directory where the project is saved. The
file extension depends on the currently selected report
template.
To save the current quantity report:
1. In the Generate Project Estimate dialog, select

File > Save and Close, or click the Save and
Close button at the bottom of the dialog.

2. In the Save As dialog, select the folder where
you want to save the file, then type a name
for the report in the File Name edit box.

3. Click Save.

Opening a Quantity Report in its
Associated Editor
Pro Architect | Building Essentials | Construction Suite

You can choose to open your quantity report in its
associated editor. For example, if the report is using
the Standard Report Form template, which generates
a TXT file, the report will open in Notepad. You can do
this directly from the Generate Project Estimate
dialog, or by using the View Project Estimate tool.
To open a quantity report from the Generate
Project Estimate dialog:
1. In the Generate Project Estimate dialog, select

File > Open with Associated Editor.
To view a saved quantity report:
1. Select Tools > Analyze > View Project Estim-

ate, or click on the Analyze toolbar.

2. In the View Project Estimate dialog, click
, then locate the file to open.

3. Click Open. The report opens in its asso-
ciated editor.

Tip: If you have already saved your quantity
report, an alternative way of opening the quantity
report is to double-click the file in Windows
Explorer, or to open the associated editor and use
that program’s Open function.

Closing the Generate Project
Estimate Dialog
Pro Architect | Building Essentials | Construction Suite

When you are finished viewing the current project
estimate, you can close the Generate Project
Estimate dialog without saving the estimate.
To close the Generate Project Estimate dialog:
1. Select File > Exit, or click in the top right

corner of the dialog.

Note: This does not save the estimate. If you want
to save before closing, click the Save and Close
button in the dialog.

Excluding Elements from a
Quantity Report
Pro Architect | Building Essentials | Construction Suite

You can prevent an element from appearing in the
quantity report by changing a setting on the element’s
Quantity property page.
To prevent an element from appearing in a quantity
report:
1. Select the element in your drawing.

2. Right-click and select Properties.
3. In the properties dialog, select the Quantity

tab.

4. Disable the Include Element in Quantities
check box.

5. Click OK.

Note: You can also apply this change to elements in
the catalog. The change will affect all new
insertions of the element.

Note: As an alternative, you can filter selected
elements from your quantity report by editing the
report template.

Viewing a Cut List
Building Essentials | Construction Suite

The cut list is displayed on the Cut List page of the
Generate Project Estimate dialog. The cut list
reports all the timber and steel members in your

Generating_a_Project_Estimate.htm
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drawing. It calculates the number of members you
need to buy from your supplier using the purchased
lengths specified in each member's properties.

To view a cut list:
1. To view a cut list for the full project, select

Tools > Analyze > Generate Project
Estimate, or click on the Analyze
toolbar.

To view a cut list for specific elements only,
select the elements in your drawing, then
right-click and select Generate Estimate.

2. In the Generate Project Estimate dialog,
select the Cut List tab.

3. By default, purchased items are grouped by
building location and usage. You can set
different grouping options in your
Optimization Settings. For example, you can
group by Usage if you want. The cut list is
color-coded to make it easy to read and
understand. Purchased items are the main
entries and are highlighted in blue. You can
expand each purchased member entry to see
exactly how the number of members was
calculated (i.e. how the members in your 3D
model were cut down into purchased
lengths). To expand an entry, click the plus
sign to the left of the entry. The
breakdown list is highlighted in an

alternating gray and white pattern.

Note: Currently the cut list does not report deck
boards — only beams and joists. Deck boards are,
however, included in the quantity report.

Note: To optimize the cut list and define settings that
determine how the content is sorted and displayed,
you need to edit the report template that you are
using to display the estimate. See Optimizing a Cut List
on page 354.

Optimizing a Cut List
Building Essentials | Construction Suite

You can optimize your cut list in a variety of ways to
calculate the best combination from the stock lengths
available and therefore minimize waste. You can set a
number of different rules that determine how
members are cut, as well as options such as the saw
cut allowance and maximum scrap length. You can
also define how you want the items in your cut list to
be sorted and displayed. Optimization settings are
defined in the report template.
To optimize a cut list:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to use from the
template drop box.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, select the Cut
List Optimization tab.
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5. To set rules that determine how members
should be cut or reported, enable or disable
the appropriate check boxes in the Rules
pane. Below is a description of each available
rule.

Calculate total linear length only. Reports
members in the quantity report in terms of
total linear length. If disabled, purchased
lengths are reported in the quantity report.

Cut down long members. For members with
specific usages whose length exceeds the
maximum purchased length defined on the
member's Purchased Items property page, this
lets you cut down the member into shorter
pieces. For example, if a member is 20' long
in the drawing but the longest purchased
length defined in that member's properties is
16', the member may be broken down into a
12' piece and 8' piece if Cut down long
members is turned on.
To select the usages to which you want this
rule to apply, enable and select the rule in the
list, then click next to the usage
pane to access the Usages library. When you
select a usage in the library and click OK, it is
added to the usage pane below the list of
rules.

To remove a usage from the usage pane,

select the usage, then click .

Note: If Cut down long members is turned
off and a member is detected that is longer
than the maximum purchased length defined
in the member's properties, the member will
become a skipped item, which is an item that
cannot be cut according to the defined
purchased lengths and cutting rules. You can
display skipped items in the cut list by
enabling the Show Skipped Items check box.
Cut one piece from each purchased length.
Cuts only one piece from each purchased
length provided that the leftover piece is
short enough to be scrapped. You can define
the Maximum Scrap Length in the dialog's
Options pane. If you disable the Cut one
piece from each purchased length option,
you are allowing more than one piece to be
cut from each purchased length.

Group similar length items. Cuts items of
similar length from the same purchased
length whenever possible. This reflects the
way many contractors work on site.

Note that when purchased lengths of
members are cut, the quantity optimizer
evaluates the leftover piece a second time to
ensure optimal lumber usage.

6. To specify a tolerance for member lengths,
enter the desired value in the Tolerance edit
box. For example, if you have a member that
is 8'-1/32" and your tolerance is set to 0, the
member would be bumped up to the next
available purchased member length (e.g. 10').
If the tolerance is set to 1/32", however, it
would use the 8' purchased member length
because the extra 1/32" is less than or equal to
the allowable tolerance.

7. To account for the scrap resulting from the
gauge of the saw's cutting blade, enter the
saw blade width in the Saw Cut Allowance
edit box.

8. To specify the maximum length a piece can
be to be considered scrap, enter the desired
value in the Maximum Scrap Length edit
box. When members are cut, any leftover
pieces that exceed the Maximum Scrap
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Length are not considered scrap and will be
used for other usages if possible.

9. To group members by building location in
the cut list, enable the Group by Location
check box.

10. To group members by usage, enable the
Group by Usage check box.

11. To display items that do not fit within the
purchased member definitions and cutting
rules, enable the Show Skipped Items check
box. For example, if the Cut down long
members rule is disabled and there is a
member in the drawing that is longer than
the maximum purchased length defined in
the member's properties, the member will not
be displayed in the cut list unless you enable
the Show Skipped Items check box. Skipped
items are shown in red in the cut list.

12. To display all scrapped items in the cut list,
enable the Show Scrapped Items check box.
A scrapped item is the piece left over after a
member has been cut from a purchased
length. Scrapped items are highlighted in
alternating fields of green and white at the
end of the cut list.

13. Once you have defined your optimization set-
tings, click Save in the Report Template dia-
log. The cut list updates automatically.

Printing a Cut List
Building Essentials | Construction Suite

You can print a cut list directly from the Generate
Project Estimate dialog.

To print a cut list:
1. In the Generate Project Estimate dialog, select

the Cut List tab.

2. Select File > Print, or click to the left of
the report form drop box.

3. In the Print dialog, select the printer you
want to use, then click Print.

Specifying How Members and
Columns are Reported in the
Quantity Report
Building Essentials | Construction Suite

Members and columns can be reported in terms of
total linear length, or in purchased lengths in the
quantity report. Purchased lengths are the lengths of
lumber you would actually buy at the lumber yard.
This option is set in the report template that you
select for your estimate.
To specify how you want members and columns to
be reported:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to use for the
quantity report.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, select the
Cut List Optimization tab.

5. If you want to report the item in terms of
total linear length, enable the Calculate Total
Linear Length Only check box.

6. If you want to report the item in purchased
lengths, disable the Calculate Total Linear
Length Only check box. You will then need
to define purchased lengths for mem-
bers/columns in your project.

Tip: You can optimize the way members are cut to
reduce waste as much as possible. See Optimizing
a Cut List on page 354. If you want to include cut
lengths for a member/column type in your
Quantity Report, enable the Include Cut Lengths
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option in the item's properties. See Editing the
Quantitative Properties of Elements on page 347.

Specifying Purchased Lengths
for Members and Columns
Building Essentials | Construction Suite

Members and columns can be reported in terms of
total linear length, or in purchased lengths in the
quantity report. Purchased lengths are the lengths of
lumber you would actually buy at the lumber yard.

If you want to use purchased lengths in your quantity
report, you must specify that you want to use
purchased lengths in your report template (see
Specifying How Members and Columns are Reported
in the Quantity Report on page 356), and define
purchased lengths on a member or column’s
Purchased Items property page. Otherwise,
members and columns are reported in terms of total
linear length. For example, if you have 1000 feet
worth of 2” x 6” floor joists in your model, the cut list
will report 1000 feet of 2” x 6” floor joists if you don’t
have purchased lengths specified for 2” x 6” floor
joists in your model. If, however, you specify an 8’,
10’ and 12’ purchased length for the floor joist
members, the cut list will report a certain number of
8’ floor joists, a certain number of 10’ floor joists, etc. -
whatever is needed to account for that 1000 feet of
floor joist material.

The Purchased Items property page also has a direct
relationship with the Cut Down Long Members
option on a report template’s Cut List Optimization
page. If this option is enabled, members that exceed
the longest purchased length will be reported using a
combination of cut lengths specified on a member’s
Purchased Items property page.
For example, you might have 40’ of top plate on one
wall, but you likely wouldn’t buy a 40’ member. It
would be more realistic to buy several smaller lengths
to make up that 40’ of top plate.
To specify purchased lengths for a member or
column:
1. To specify purchased lengths for wall, floor,

ceiling or surface members in your drawing,
select the element in your drawing, then

right-click and select Properties. For walls,
click the Framing member button in the
properties dialog. For floors, ceilings, roofs
and surfaces, click the Specify Framing
button in the properties dialog. In the
framing dialog, select the member to edit,
then click Select. In the Catalog Access
dialog, right-click the member to edit and
select Edit Element.
To specify cut lengths for a member or
column in the catalog, double-click the
element in the catalog panel, or select it in the
catalog panel and then right-click and select
Edit Element. You can also open the Element
Manager, then select the member or column
that you want to edit.

To specify cut lengths for members in an
existing deck, click on the edge of the deck to
select it, then right-click and select
Properties. In the Decks dialog, select the
Frame tab. Then, click the Select button in
the Joists or Beams area. Note that it is not
currently possible to specify cut lengths for
deck boards (planking). In the Catalog
Access dialog, right-click the member to edit
and select Edit Element.

2. In the properties dialog, select the Purchased
Items tab. All cut lengths currently defined
for the item are displayed.

3. To delete a purchased length from the list,
select it and then click Delete. To delete all
purchased lengths from the list, click Clear
All.
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4. To add a purchased length to the list, click
Add. To edit an existing purchased length,
select it in the list, then click Edit.

5. Define the properties of the purchased length
in the Define Purchased Member dialog.

6. Specify a name for the purchased length as
you would like it to appear in your estimate.
If you want to name it automatically using a
pre-defined naming convention, click the
Autoname button. (See Using Automatic Name
Generation on page 441.)

7. Enter the desired length for the item in the
Length edit box.

8. In the Purchased Member Use area, specify
which usages the purchased length can be
used for. (Usages can be used as sort keys in
estimates and quotes.)

If the purchased length can be used for any
usage, enable the All usages radio button.
If you want the purchased length to be used
for certain usages only, enable the Only
these usages radio button, then Click

to select the desired usages
from the Usages library. When you select a
usage in the library, it is added to the usage
list in the Define Purchased Items dialog.
If the purchased length can be used for most
usages with some exceptions, enable the Any
usage except these radio button, then click

to select the usages that
you do not want the purchased length to be
used for. When you select a usage in the
Usages library it is added to the usage list.
To delete a usage from the usage list, select it

and then click .

9. In the Quantity area, specify the Price, Part
Number and Unit of Measure for the member.
This information may appear in estimates
and quotes, and can be used to sort
information in reports.

Tip: Appending -TALLY to a part number
marks it as a tally item in Quote Generator.

10. Once you have defined the purchased length,
click OK in the Define Purchased Items dia-
log.

11. Once you have defined all desired purchased
lengths for the member, click OK in the prop-
erties dialog.

Note: If you want to include cut lengths for a
member type in your Quantity Report, enable the
Include Cut Lengths option in the member's
properties. See Editing the Quantitative Properties of
Elements on page 347.

Disabling or Enabling Cut List
Generation
Building Essentials | Construction Suite

If you are not interested in viewing a cut list, you can
disable cut list generation if you want. If you do so,
the Cut List page of the Generate Project Estimate
dialog will be blank. This option is set in your report
template.
To disable or enable cut list generation:
1. Select Tools > Analyze > Generate Project

Estimate.
2. In the Generate Project Estimate dialog,

select the template you would like to use.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, on the Gen-
eral page, disable the Optimize Cut List
check box.

5. Click Save.

Creating a New Report Template
Building Essentials | Construction Suite
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The content and appearance of a project estimate are
determined by a report template. There are a variety
of report templates that you can edit to suit your
needs. You can also create new templates if you
prefer.
To create a new report template:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > New, or click on the
toolbar.

3. Define your template settings in the Report
Template dialog.

4. Click Save. The current estimate updates
automatically in the Generate Project Estim-
ate dialog.

Opening a Report Template
Building Essentials | Construction Suite

If you created a custom template in an older version
of the program, or would like to use a template that
you have copied to your system but don't see listed in
the Generate Project Estimate dialog, you can open it
using the Open Template tool.
To open a report template that is not in the list:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > Open, or click the Open

Template button .

3. In the Open dialog, locate the template that
you want to open. If the template was created
in the current version of the program, it will
have an *.RXML extension. If the template
was created in an older version of the pro-
gram, click the drop box next to the File
Name edit box and select Report Template
(pre-version 8.0), then locate the template. It
will have an *.RPT extension.

4. Click Open. The template's properties are dis-
played in the Report Template dialog box.

5. In the Report Template dialog, click Save.
The template is added to the list, and your
estimate is displayed using that template.

Note: When you save a template that was created
in an older version of the program, a copy of the
template is saved in the current *.RXML format.
The original file will remain on your system in its
original format.

Copying a Report Template
Building Essentials | Construction Suite

You can create a copy of an existing report template
by saving it under a different name. You can then edit
the copied template to suit your needs.
To create a copy of an existing report template:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template to copy from the report
form drop box, then click on the toolbar.

3. In the Report Template dialog, click
.

4. In the Save As dialog, type a name for the
new file in the File Name edit box. It will be
saved in RXML format.

5. Click . The template is added to
your list of report templates.

Editing a Report Template
Building Essentials | Construction Suite

The content and appearance of a project estimate are
determined by a report template. You can edit any of
the report templates to suit your needs.
To edit an existing report template:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template to edit from the report
template drop box.
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3. Select Templates > Edit, or click on the
toolbar.

4. Edit your template settings in the Report
Template dialog. See Report Template Prop-
erties on page 360.

5. Click Save. The current estimate updates
automatically in the Generate Project Estim-
ate dialog.

Deleting a Report Template
Building Essentials | Construction Suite

You can delete a report template from your list of
templates if you want.
To delete a report template:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template to delete from the report
template drop box.

3. Select Templates > Delete, or click on the
toolbar.

4. Click Yes to confirm the deletion. The tem-
plate is deleted. By default the report now
uses the previous template in the list.

Report Template Properties
Report templates have a detailed set of properties that
you can customize to suit your needs. When creating
or editing a template, you can specify the following:

General Settings
To access general report template properties, select
the General tab in the Report Template dialog.

General settings, such as the template name, report
file extension, sort order for information, and element
filter. You can also choose to generate a cut list if you
want.
Description: This is the description of the template as
it appears in the list of available templates in the
Generate Project Estimate dialog.
Report Extension. Determines the type of file the
estimate is written to when you save it. The file type
you choose in part determines what application

launches when you select the Open with Associated
Editor tool in the Generate Project Estimate dialog.
You can use Windows Explorer to associate a file
extension with a particular application.

Display Currency Symbol. Controls the display of
the currency symbol (e.g. dollar sign).

Optimize Cut List: Enable this check box if you want
to produce a cut list in addition to the quantity report.
You can specify cut list optimization settings on the
Cut List Optimization tab.

Use Cut List Results in Report. Applies the cutting
rules specified on the Cut List Optimization tab to the
members in the quantity report.
Sort Options
Quantity information can be sorted by Location,
Division, Category, Phase, Usage, Supplier, and Alternate
Code. All of these fields (except Location) are specified
on an element’s Quantity property page. You can
specify up to six levels of sorting in your report, and
choose either Ascending or Descending for each level.
The order in which sort keys appear in the Sort
Options pane determine the order in which
information is sorted. For example, if you choose to
sort by Location and then by Division, the program will
find the first location, list the first division of that
location, then list all of the elements in that division.
It will then list subsequent divisions and their
elements until all divisions have been listed for that
location.

Adds a sort level below the
currently selected sort level. Once the level has been
added, select the desired sort level from the drop box.

Removes the currently selected
sort level from the list.

Promote Sort Level. Moves the currently
selected sort level up in the list.

Demote Sort Level. Moves the currently
selected sort level down in the list.
Template Element Filter
The Template Element Filter determines which
elements are included in the project estimate, and
which are not.

Element will be included in the estimate.
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Element will be omitted from the estimate.

Note that there is also a location filter in the Generate
Project Estimate dialog that filters locations in your
report.

Optimization Settings
These settings apply to the cut list. For more
information, see Optimizing a Cut List on page 354.
Rules

Calculate Total Linear Length Only. Reports
members in terms of total linear length instead of
purchased member lengths in the quantity report.

Cut down long members. For members with specific
usages whose length exceeds the maximum
purchased length defined on the member's Purchased
Items property page, this lets you cut down the
member into shorter pieces. For example, if a member
is 20' long in the drawing but the longest purchased
length defined in that member's properties is 16', the
member may be broken down into a 12' piece and 8'
piece if Cut down long members is turned on.
Cut one piece from each purchased length. Cuts
only one piece from each purchased length provided
that the leftover piece is short enough to be scrapped.
You can define the Maximum Scrap Allowance in
the dialog's Options pane. If you disable the Cut one
piece from each purchased length option, you are
allowing more than one piece to be cut from each
purchased length.

Group similar length items. Cuts items of similar
length from the same purchased length whenever
possible. This reflects the way many contractors work
on site.

This rule applies to all items. Applies the currently
selected rule to all items, regardless of their usage.

This rule only applies to items with these usages.
Applies the currently selected rule to items with
specific usages only (those usages displayed in the
box below this setting). To add a usage to the usage
pane, click and then select a usage from
the Usage library. To remove a usage from the usage

pane, select the usage, then click .

Options

Tolerance. The allowable tolerance for member
lengths. For example, if you have a member that is 8'-
1/32" and your tolerance is set to 0, the member

would be bumped up to the next available purchased
member length (e.g. 10'). If the tolerance is set to
1/32", however, it would use the 8' purchased member
length because the extra 1/32" is less than or equal to
the allowable tolerance.

Saw cut allowance. The width of the saw's cutting
blade.

Maximum scrap length. The maximum length a
piece can be to be considered scrap. When members
are cut, any leftover pieces that exceed the Maximum
Scrap Length are not considered scrap and will be
used for other usages if possible.
Report Display

Group by Location. Groups items by building
location in the cut list. (e.g. Ground Floor, Second
Floor, etc.)

Group by Usage. Groups items by usage in the cut
list. (e.g. Stud, Plate, Floor Joist, etc.)

Show Skipped Items. Displays items that do not fit
within the purchased member definitions and cutting
rules. For example, if the Cut down long members
rule is disabled and there is a member in the drawing
that is longer than the maximum purchased length
defined in the member's properties, the member will
not be displayed in the cut list unless you enable the
Show Skipped Items check box. Skipped items are
shown in red in the cut list.

Show Scrapped Items. Displays all scrapped items in
the cut list. A scrapped item is the piece left over after
a member has been cut from a purchased length.

Record Settings
To access record properties, select the Records tab in
the Report Template dialog.

Record settings, which determine how report headers,
footers and element entries appear in the report. Each
element type has its own default format with an
appropriate listing of fields. You can add, edit and
delete fields if you want. If you do this, however,
make sure your headers correspond to the inform-
ation being reported.
Headers and Footers
Headers are words or strings of text (titles) that
appear at the beginning of a document, or that
introduce a block of information. For example, the
default report header includes the title Project Estimate
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and the name of the drawing file. In addition to the
main report header, you can specify up to three levels
of subsequent headers. For example, Level 1 headers
could include titles like Description, Quantity and
Price, which identify specific types of information that
follow them.

Footers are words or strings of text that appear at the
bottom of reports or blocks of information. You can
specify a main report footer as well as additional
levels of footers if you want. See Editing Headers and
Footers in a Report Template on page 365.
Elements
Each element type can be reported differently in your
quantity report using a format that you specify. For
example, walls are generally reported in terms of
length (linear feet), while elements like doors are
counted as individual items. Floors and ceilings are
reported in terms of area (square feet), in which case a
formula is used to determine the quantity value.

Each element type has its own default format with an
appropriate listing of fields. You can add, edit and
delete fields if you want. If you do this, however,
make sure your headers correspond to the
information being reported. See Editing Element
Entries in a Report Template on page 366.

Editing the Name of a Report
Template
Building Essentials | Construction Suite

You can edit the name of any report template on the
template’s General property page. This is the name
you see in the Generate Project Estimate dialog’s
report form drop box.
To edit the name of a report template:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template to edit from the report
template drop box.

3. Select Templates > Edit, or click on the
toolbar.

4. On the General page of the Report Template
dialog, edit the name in the Description edit

box.

5. Click Save.

Editing the File Extension of
Generated Quantity Reports
Building Essentials | Construction Suite

When you save a quantity report, it is written to a file
whose type is determined by the report template you
are using. For example, the file type created when
using the Standard Report Form template is a TXT
file. You can edit the file type generated by editing
the report template.
To edit the file extension of generated reports:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to edit from the
report template drop box.

3. Select Templates > Edit, or click on the
toolbar.

4. On the General page of the Report Template
dialog, edit the file extension in the Report
Extension edit box.

5. Click Save.
The file type you choose in part determines what
application launches when you select the Open with
Associated Editor tool in the Generate Project
Estimate dialog.

Controlling the Display of the
Currency Symbol in a Quantity
Report
Building Essentials | Construction Suite

Prices and costs in the quantity report usually include
a currency symbol, such as a dollar sign. You can
disable the display of the currency symbol by editing
the report template.
To control the display of the currency symbol:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.
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2. In the Generate Project Estimate dialog,
select the template you want to edit from the
report template drop box.

3. Select Templates > Edit, or click on the
toolbar.

4. On the General page of the Report Template
dialog, check or uncheck the Display Cur-
rency Symbol check box.

5. Click Save.

Using Optimized Results for
Members and Columns in the
Quantity Report
Building Essentials | Construction Suite

For those members and columns which are set to be
reported in purchased lengths instead of total linear
length, you can choose whether or not you want to
apply optimization settings to those purchased
lengths in your quantity report. Optimization settings
are defined in the report template that you apply to
your project estimate.
To use optimized results for members and
columns in your quantity report:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to use for the
quantity report.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, on the Gen-
eral page, make sure the Optimize Cut List
check box is enabled, and then enable the
Use Cut List Results in Report check box.

5. Click Save.

Specifying the Sort Order of
Materials in a Quantity Report
Building Essentials | Construction Suite

Sorting rules for materials are specified in the report
template that is applied to the project estimate.
Quantity information can be sorted by Location,
Division, Category, Phase, Usage, and Alternate Code in

the quantity report. All of these fields (except
Location) are specified on an element’s Quantity
property page. You can specify up to six levels of
sorting in your report, and choose either Ascending or
Descending for each level. The order in which sort
keys appear in the Sort Options pane determine the
order in which information is sorted. For example, if
you choose to sort by Location and then by Division,
the program will find the first location, list the first
division of that location, then list all of the elements in
that division. It will then list subsequent divisions and
their elements until all divisions have been listed for
that location.

To specify the sort order of materials in an
estimate:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to edit from the
report template drop box.

3. Select Templates > Edit, or click on the
toolbar.

4. On the General page of the Report Template
dialog, specify your sort options in the Sort
Options area.

The first entry in the list is the primary Sort
Level for the report. Once materials have
been sorted according to the first sort level,
they are then sorted according to the next sort
level in the list, and so on. You can specify up
to 6 sort levels for your report. The order in
which sort keys appear in the list is the order
in which materials will be sorted.
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To add a sort level to the report template,

click . The sort level is
added below the one that was selected prior
to adding a level. Once the sort level is added
to the list, click the drop box and select the
key that you want to sort by (Location,
Division, Phase, etc.).

To remove a sort level from the report
template, select the sort level in the list, and

then click .

To move a sort level up in the list, select the

sort level in the list and then click .

To move a sort level down in the list, select

the sort level in the list and then click .

5. Click Save to save your changes.

Filtering Elements from the
Quantity Report
Building Essentials | Construction Suite

You can omit specific types of elements from your
quantity report by editing the report template. For
example, if you wanted to create a window schedule,
you would enable the Windows element group and
disable all other element groups.
To filter elements from a project estimate:
1. In the Generate Project Estimate dialog, select

Templates > Edit, or click on the toolbar.

2. In the Report Template dialog, click the
filter icon of the element you want to filter.
When the filter icon is white, the element will
not appear in the estimate.

Element will be included in the estimate.

Element will be omitted from the
estimate.

3. Click Save. The quantity report updates auto-
matically in the Generate Project Estimate
dialog.

Note: You can also prevent an element from
appearing in the quantity report by editing the
element’s properties. See Excluding Elements from a
Quantity Report on page 353.

Specifying How Information is
Displayed in a Quantity Report
Building Essentials | Construction Suite

The settings on a template’s Records page determine
how report headers, footers and element entries
appear in a project estimate. Records are made up of
individual fields. You can edit, add, delete or copy
fields within a record, giving you complete control
over how information is reported.
To access the Records page:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to use for your
estimate.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, select the
Records tab.

To display a record:
1. In the Record Content window, expand the

item you want to view records for (Report
Header, Report Footer or Elements).

2. Select the record that you want to view. The
record is displayed in the adjacent Record
Field Definition window.
Below is a sample element record that
contains six fields:

08210 32” Hinged Door 3.00 Ea.
$40.00 $120.00

Generating_a_Project_Estimate.htm
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Here are the fields that make up the record:

08210: Division (variable)
32” Hinged Door: Description (variable)
3.00: Count (variable)
Ea.: Unit (constant)
$40.00: Price (variable)
$120.00: Cost (formula: Count*Price)

Editing Headers and Footers in
a Report Template
Building Essentials | Construction Suite

Headers are words or strings of text (titles) that
appear at the beginning of a document, or that
introduce a block of information. For example, the
default report header includes the title “Project
Estimate” and the project name. In addition to the
main report header, you can specify up to three levels
of subsequent headers. For example, Level 1 headers
could include titles like Description, Quantity and
Price, which identify specific types of information that
follow them.

Footers are words or strings of text that appear at the
bottom of reports or blocks of information. You can
specify a main report footer as well as additional
levels of footers if you want.
To edit a header or footer:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > Edit, or click on the
toolbar.

3. In the Report Template dialog, select the
Records tab.

4. In the Record Content window, expand the
Headers or Footers group.

5. Select the record you want to edit (e.g. Main
Header).

6. Click on the field you want to edit. Then,
depending on the type of field it is, either
type a value (in the case of the Description
field, for example), or make a selection from a
drop box.

Description. Identifies the field by name. 
Value. To specify a value for a header/footer
field, click in the Value field and then click
to access the Specify Value dialog. For
headers and footers, this will likely be either
a Constant or Variable. For example, if you
wanted to specify a title, you would select the
Constant option and then type the desired
title (e.g. 'Project Estimate' or 'Location') in
the edit box. If you wanted to specify a value
that changes depending on the project, such
as the project name, you would select the
Variable option and then select the desired
variable from the list (e.g. Project Name).
Most header/footer variables are directly
linked to fields in the Project Manager
dialog.
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Width. The maximum width of the field. If
the field entry exceeds the field width, the
entry will be shortened to fit.

Delimiter. An item that separates one field
from another. Choose from Comma, Tab, New
Line or None.

7. When you are finished editing fields, click
Save. The estimate updates automatically to
reflect your changes.

Editing Element Entries in a
Report Template
Building Essentials | Construction Suite

Each element type can be reported differently in your
project estimate using a format that you specify. For
example, walls are generally reported in terms of
length (linear feet), while elements like doors are
counted as individual items. Floors and ceilings are
reported in terms of area (square feet), in which case a
formula is used to determine the quantity value.

Each element type has its own default format with an
appropriate listing of fields. You can add and delete
fields if you want. If you do this, however, make sure
your headers correspond to the information being
reported.

1. Select Tools > Analyze > Generate Project
Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > Edit, or click on the
toolbar.

3. In the Report Template dialog, select the
Records tab.

4. In the Record Content window, expand the Ele-
ments group.

5. Select the element whose fields you want to
edit.

6. Click on the field that you want to edit. Then,
depending on the type of field it is, either
type a value (in the case of the Description
field, for example), or make a selection from a
drop box. Below is a list of field types.

Description. Identifies the field by name.
Value. Click in the Value field and then click
to display the Specify Value dialog.
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In this dialog you can specify whether the
value is a Constant, Variable or Formula. These
are described below.

Constant: A value that remains fixed, such as
the word EACH.

Variable: A value that changes, such as a
name or numerical value. If the source is a
variable, select the desired variant from the
drop box. In the case of elements, choose
from items such as Count, Length, Area,
Volume, Description, Type, Division,
Manufacturer, Supplier, Price, Part Number
and Alternate Code.

For certain variables, such as Length, Area and
Volume, you can specify the output units for
the item, such as Millimeters, Feet-Inches,
Square Meters or Cubic Yards. For some units
you can also select a level of precision for the
measurement.

* Note that the Quantity variable refers to the
calculated quantity of the material as
calculated according to the Unit of Measure
setting in the object's properties.

Formula: Lets you select or specify a formula
for calculating a value. For example, to
calculate the Cost of doors in your project,
you might specify a formula of Count * Price
in the Value field of the Cost entry (the
number of doors multiplied by the unit price
of the door). See Specifying Formulas on page
368.

Width. The maximum width of the field. If
the field entry exceeds the field width, the
entry will be shortened to fit.

Delimiter. An item that separates one field
from another. Choose from Comma, Tab,
New Line or None.

Cost. Click in the Cost field to include the
total cost calculated for the item. A check

mark indicates that the cost will be
reported.

7. To add a field to the element record, position
your cursor in the list of fields and then click

. A field will be added above the
one that was selected prior to adding a field.

8. To delete a field from the record, select the

field and then click .

9. When you are finished editing fields, click
Save. The estimate updates automatically to
reflect your changes.

Editing Fields in a Record
Building Essentials | Construction Suite

Each entry in your project estimate is based a record in
the report template. Each record is made up of several
fields. Fields that constitute a value can be defined as
either a constant, variable or formula.

As an example, the entry for a door may look
something like this:

08210 32” Hinged Door 3.00 Ea. $40.00
$120.00
This entry is made of up of the following six fields:

08210: Division (variable)
32” Hinged Door: Description (variable)
3.00: Count (variable)
Ea.: Unit (constant)
$40.00: Price (variable)
$120.00: Cost (formula: Count*Price)
You can edit the fields for any record in your report
template to suit your needs.

To edit a field in a record:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select the template you want to use for your
estimate.

3. Select Templates > Edit, or click on the
toolbar.

4. In the Report Template dialog, select the
Records tab.

5. In the left pane, select the element whose
record you want to edit.

6. Click on the field that you want to edit. Then,
depending on the type of field it is, either
type a value (in the case of the Description
field, for example), or make a selection from a
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drop box. Below is a list of field types.
Description. Identifies the field by name.
Value. Click in the Value field and then click
to display the Specify Value dialog.

In this dialog you can specify whether the
value is a Constant, Variable or Formula. These
are described below.

Constant: A value that remains fixed, such as
the word EACH.

Variable: A value that changes, such as a
name or numerical value. If the source is a
variable, select the desired variant from the
drop box. In the case of elements, choose
from items such as Count, Length, Area,
Volume, Description, Type, Division,
Manufacturer, Supplier, Price, Part Number
and Alternate Code.

For certain variables, such as Length, Area and
Volume, you can specify the output units for
the item, such as Millimeters, Feet-Inches,
Square Meters or Cubic Yards. For some units
you can also select a level of precision for the
measurement.

* Note that the Quantity variable refers to the
calculated quantity of the material as
calculated according to the Unit of Measure
setting in the object's properties.

Formula: Lets you select or specify a formula
for calculating a value. For example, to
calculate the Cost of doors in your project,
you might specify a formula of Count * Price
in the Value field of the Cost entry (the

number of doors multiplied by the unit price
of the door). See Specifying Formulas on page
368.

Width. The maximum width of the field. If
the field entry exceeds the field width, the
entry will be shortened to fit.

Delimiter. An item that separates one field
from another. Choose from Comma, Tab,
New Line or None.

Cost. Click in the Cost field to include the
total cost calculated for the item. A check

mark indicates that the cost will be
reported.

7. To add a field to the element record, position
your cursor in the list of fields and then click

. A field will be added above the
one that was selected prior to adding a field.

8. To delete a field from the record, select the

field and then click .

9. Click to save the changes to
your template.

Specifying Formulas
Building Essentials | Construction Suite
If you are defining an assembly, or adding or editing
a value field on the Records page of the Report
Template dialog, you can choose to specify a formula
for calculating the quantity of that item. Formulas are
mathematical equations (e.g. Count x Price) that are
used to calculate a value (e.g. Cost). You can create
and edit formulas to suit your needs. Once you have
created a formula you can test it with sample values
to make sure that it is working correctly.

You can save a formula for future use. You can then
load a saved formula into the Define Formula dialog
if you want to edit it or use it to create a new formula.

Below is an overview of the Define Formula dialog.
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To create a formula:
Build your formula by typing directly in the formula
window as well as clicking any of the available
variables, numbers, operators and functions displayed
in the dialog. The available variables vary according
to element type. For example, if you are defining
fields for a door, variables such as Count, Height and
Width will be included in the list. For a wall you are
likely to see variables such as Exterior Wall Area and
Interior Wall Area.

As an example, if you are creating a formula to count
door hinges, and there are two hinges per door, you
might specify a formula of Count * 2 (the number of
doors multiplied by 2), which would count two door
hinges for every instance of the door in your drawing.
To create this formula, you would do the following:

1. Click the Count variable in the list of vari-
ables.

2. Click .

3. Click or type 2 after the mul-
tiplication symbol.

Input Units

If you are using Length, Area or Volume variables in
your formula, you can specify the units in which you
want to measure those values by making the desired
selections from the Length, Area and Volume drop
boxes in the Input area. Initially, all quantities are
measured in millimeters regardless of the units of
measure used in your project. Making selections from
the Length, Area and Volume drop boxes converts
the millimeter values into the units you want. This
saves you a lot of time and effort because you do not
have to specify conversion factors in your formula —
the conversion is done for you.

For example, if your formula contains the Area
variable and you would like the area of the item to be
measured in square feet, you would select Square
Feet from the Area drop box.

Note: The Length option applies to all distance
measurements including Height and Width.

Output Units

If you are defining a record in a report template, the
Define Formula dialog will contain an Output area
containing unit choices for Length, Area and
Volume. These are the units of measure that will be
used to display the calculated quantity in the quantity
report.

Note: Output units are absent from the dialog if
you are specifying a formula for an assembly
because assemblies are simply calculated values.



- 370 -

Reports on the other hand involve both calculating
values and reporting calculated values.

To test a formula:

1. Click at the top of the dialog.
The formula appears in the Test Formula
dialog.

2. In the Variables window, click on one of the
variables that your formula contains, then
type a value for that variable and press Enter.
For example, our door hinge formula contains
a Count variable. If we type 4 for the Count
and press Enter, the formula will display an
answer of 8, which is correct (4 x 2=8).

3. When you are finished testing the formula,
click Close to return to the Define Formula
dialog.

To save a formula:

1. Click at the top of the dialog.

2. In the Save Formula dialog, type a name or
description of the formula for easy
identification.

3. Click OK.
To load a saved formula:

1. Click at the top of the dialog.

2. In the Load Formula dialog, select the
formula that you would like to load.

3. Click OK.

Adding Fields to a Record
Building Essentials | Construction Suite

When defining a report template, you can add
information to a record by adding fields to it.
To add a field to a record:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > Edit, or click on the
toolbar.
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3. In the Report Template dialog, select the
Records tab.

4. In the Record Content window, expand the Ele-
ments group.

5. Select the element whose fields you want to
edit. 

6. Position your cursor in the list of fields.

7. Click . A field will be added above
the one that was selected prior to adding a
field.

8. Define the field. See Editing Fields in a
Record on page 367.

Deleting Fields from a Record
Building Essentials | Construction Suite

When editing a report template, you can delete one or
all fields in a record.
To delete a field from a record:
1. Select Tools > Analyze > Generate Project

Estimate, or click on the Analyze tool-
bar.

2. In the Generate Project Estimate dialog,
select Templates > Edit, or click on the
toolbar.

3. In the Report Template dialog, select the
Records tab.

4. In the Record Content window, expand the Ele-
ments group.

5. Select the element whose fields you want to
edit. 

6. Select the field that you want to delete, then

click . If you want to delete all

fields in the record, click . You
are prompted to confirm the deletion. Click
Yes to delete all fields, or click No to leave
the fields intact.

Generating a Quote (QG)
Construction Suite only

A quote is a list of products with quantities, pricing
and other important information. Quotes are used by
building material supply retailers, wholesalers,

distributors and contractors to facilitate the design,
sale and installation of construction projects. You can
use the Generate Quote tool to instantly generate a
quote that opens in Quote Generator software
(included). You can then edit the quote to suit your
needs. For example, you can import SKU numbers,
edit pricing, and account for things like labor and
markup.
To generate a quote:
1. Select Tools > Analyze > Generate Quote, or

click on the Analyze toolbar. The quote is
opened in Quote Generator.

2. If there are any products with a $0.00 Cost
value, the following dialog will appear:

This is simply a warning that some Cost
values will need your attention. The cells are
highlighted in red in the quote.

Note: If you have already generated a quote in QG
and you are generating one again, a dialog will
appear that gives you the option of reloading the
previously saved quote, or loading a new quote
from Envisioneer. Click Yes to open a quote from
Envisioneer, or click No to reload the previously
saved quote.

Note: Quote Generator is a separate application. To
view its online help, select Help > View Help in
Quote Generator. Information is also included in
the main Envisioneer help file.

Uploading Data to an ERP Sys-
tem
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Upload to ERP  tool to upload a
drawing's quantitative data to a remote Enterprise
Resource Planning (ERP) system. Initially you will
need to define the URL of the ERP system, enter your
sign-in credentials, and specify upload options.
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To upload data to an ERP system:
1. Select Tools > Analyze > Upload to ERP, or

click on the Analyze toolbar.

2. To set up a link to an ERP system, click
next to the ERP System drop box. Or, to edit
the details of an existing link, select it from
the drop box, then click .

Specify the settings in the ERP Link
Details dialog box:

The following is a brief description of the
settings:

Description: The name to be displayed in the
ERP System drop box.

Template: The report template that will be
used to format the data.

Base URL: Example: http://www.your.com/
Validate Contract Number: Displays the
following panel in the Upload to ERP
System dialog box:

Request Drawing Uploads: Displays a
browse feature in the Upload to ERP System
dialog box, enabling you to upload drawings
from your local machine.

Validate Estimate Before Upload: Enables
the online system to confirm that all elements
in the estimate are valid. Elements may be
considered invalid if they are not recognized
by the system, if they are outside of the user's
price range, and so on.

User Name/Password: The credentials you
use to sign in to the ERP system.

3. Once you have specified a link to an ERP Sys-
tem, it will become an available option in the
ERP System drop box. Select it to continue.

4. If Request Drawing Uploads is enabled in
the link's details, you can click Select, then
use the file browser to select drawings for
upload.

A report is displayed in the dialog which
combines data from the report template with
data pulled from the online ERP system.

5. From the Please Choose Upload Type drop
box, select either Original Order, Changed
Order, or Final Order to identify the identify
the status of the order.

6. Click OK to begin the upload.

Generating a Door Schedule
Pro Architect | Building Essentials | Construction Suite

You can instantly view a door schedule for any
location in your project. The schedule displays a
detailed description of each door type on the selected
location, as well as the count for each door type. You
can insert the schedule in your project with a simple
mouse click. By default, the doors in your project are
tagged with schedule marks when you insert the
schedule.
To generate a door schedule:
1. Select Tools > Analyze > Schedules > Door

Schedule, or click on the Analyze tool-
bar.

2. To edit the title of the schedule, edit the head-
ing in the Schedule Title edit box.

3. To view a schedule for another building loc-
ation, select the desired location from the
Reference Building Location drop box.
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4. To prevent the doors in your project from
being tagged with schedule marks, disable
the Tag Elements with Schedule Mark check
box.

5. To edit the layout or appearance of the
schedule or schedule marks, click Setup.

6. To print the schedule, click , then make
the desired selections in the Print dialog.

7. To insert the schedule in your project, click
OK. (Otherwise, click Cancel to exit the dia-
log.) The schedule is attached to your cursor,
ready to be inserted.

8. Position the schedule where you want it, then
click to insert it.

NOTE: Doors that have the Include in Quantities
option disabled on the Door's Quantity properties
page will not be included in the schedule.

Generating a Window Schedule
Pro Architect | Building Essentials | Construction Suite

You can instantly view a window schedule for any
location in your project. The schedule displays a
detailed description of each window type on the
selected location, as well as the count for each
window type. You can insert the schedule in your
project with a simple mouse click. By default, the
windows in your project are tagged with schedule
marks when you insert the schedule.
To generate a window schedule:
1. Select Tools > Analyze > Schedules > Win-

dow Schedule, or click on the Analyze
toolbar.

2. To edit the title of the schedule, edit the head-
ing in the Schedule Title edit box.

3. To view a schedule for another building loc-
ation, select the desired location from the
Reference Building Location drop box.

4. To prevent the windows in your project from
being tagged with schedule marks, disable
the Tag Elements with Schedule Mark check
box.

5. To edit the layout or appearance of the
schedule or schedule marks, click Setup.

6. To print the schedule, click , then make
the desired selections in the Print dialog.

7. To insert the schedule in your project, click
OK. (Otherwise, click Cancel to exit the dia-
log.) The schedule is attached to your cursor,
ready to be inserted.

8. Position the schedule where you want it, then
click to insert it.

NOTE: Windows that have the Include in Quantities
option disabled in the Windows Quantity properties
will not appear in the Window schedule.

Generating a Member Schedule
Building Essentials | Construction Suite
You can instantly view a member schedule for any
location in your project. The schedule displays
members inserted with the Members tool. Roof, floor,
ceiling and surface framing is not included. However,
you can convert framing to members so that they
appear in the member schedule.

The schedule displays a detailed description of each
member type on the selected location, as well as the
size and length for each member type. You can insert
the schedule in your project with a simple mouse
click. By default, the members in your project are
tagged with schedule marks when you insert the
schedule.
To generate a member schedule:
1. Select Tools > Analyze > Schedules > Mem-

ber Schedule, or click on the Analyze
toolbar.

2. To edit the title of the schedule, edit the head-
ing in the Schedule Title edit box.

3. To view a schedule for another building loc-
ation, select the desired location from the
Reference Building Location drop box.

4. To prevent the members in your project from
being tagged with schedule marks, disable
the Tag Elements with Schedule Mark check
box.

5. To edit the layout or appearance of the
schedule or schedule marks, click Setup.

6. To print the schedule, click , then make
the desired selections in the Print dialog.
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7. To insert the schedule in your project, click
OK. (Otherwise, click Cancel to exit the dia-
log.) The schedule is attached to your cursor,
ready to be inserted.

8. Position the schedule where you want it, then
click to insert it.

Generating a Room Region
Schedule
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have calculated the space in rooms and areas
using a Room Region tool, you can generate a room
region schedule. The schedule lists any rooms for
which you have created a room region. It displays the
area, perimeter and volume of each room. You can
insert the schedule in your project with a simple
mouse click.
To generate a room schedule:
1. Select Tools > Analyze > Schedules > Room

Region Schedule, or click on the Ana-
lyze toolbar.

2. To edit the title of the schedule, edit the head-
ing in the Schedule Title edit box.

3. To view a schedule for another building loc-
ation, select the desired location from the
Reference Building Location drop box.

4. To edit the layout or appearance of the
schedule, click Setup.

5. To print the schedule, click , then make
the desired selections in the Print dialog.

6. To insert the schedule in your project, click
OK. (Otherwise, click Cancel to exit the dia-
log.) The schedule is attached to your cursor,
ready to be inserted.

7. Position the schedule where you want it, then
click to insert it.

Printing a Schedule
You can print a door, window or member schedule
directly from the Schedule dialog.
To print a schedule:
1. If you have already inserted the schedule in

your project, click on it to select it, then right-

click and select Properties. If you have not
inserted it yet, select Tools > Analyze >
Schedules, then select the type of schedule
you want to print.

2. In the Schedule dialog, click .

3. In the Print dialog, select the desired printer
to use, then click Print.

Defining the Field Layout of a
Schedule
Each type of schedule has a default layout of fields.
You can remove any of these fields, as well as add
new fields if you want. You can also control the
content and size of each field.
To define the layout of a schedule:
1. In the Schedule dialog, click Setup. Note

that if you have already inserted the
schedule, the inserted schedule will be
deleted, and a new one will be generated in
the dialog.

In the Schedule Setup dialog, the current
layout is displayed in the Layout area of the
dialog.

2. To delete a field, click on it to select it, then
click Remove.

3. To edit a field’s title, click on the field to
select it, then edit the title in the Heading edit
box.

4. To edit a field’s content, click on the field to
select it, then make a selection from the Con-
tent drop box.

5. To edit the width of a field, click on the field
to select it, then edit the value in the Width
edit box.

6. To insert a new field, click on the field that
you want to appear to the right of the new
field, then click Insert. A blank field is added
to the left of the currently selected field.
Define the Heading, Content and Width vari-
ables. Content options include Auto Mark,
Description, Type, Height, Width, Height x
Width, Width x Height, Thickness, Height
Rough Opening, Width Rough Opening, Grill
Style, Glass Area, Count, Location, Division,
Category, Manufacturer, Supplier, Price, Part
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Number, Alternate Code,Frame Type, Frame
Color, Glaze Type, U-Factor, SHGC and Cata-
log Mark.

7. Click OK. The schedule is updated with your
new settings.

Note: You cannot edit the layout of an inserted
schedule by selecting the Properties tool. A new
schedule will have to be generated.

Defining the Text Styles in a
Schedule
You can control the text styles used for a schedule’s
title, headings and content, as well as the justification
of text within each field.
To define the text styles in a schedule:
1. If you have already inserted the schedule in

your project, click on it to select it, then right-
click and select Properties. If you have not
inserted it yet, select Tools > Analyze >
Schedules, then select the type of schedule
you want to generate.

2. In the Schedule dialog, click Setup.
3. To edit the text style used for the schedule

title, field headings or content, click the Title,
Headings or Content button in the Schedule
Appearance area. In the Text Styles dialog,
select the text style you want to use for the
selected item, then click OK.

4. To edit the justification of text in each
column, click the desired justification button.
A left justification aligns all the text on the
left side of the column. A right justification
aligns the text on the right side of the
column. With a centered justification, each
line of text is centered in each column.

5. Click OK.

Note: Text style settings apply only to the inserted
schedule, not the schedule displayed in the dialog.

Defining the Line Styles in a
Schedule
You can change the line styles used for a schedule’s
border and division lines.
To define the line styles in a schedule:

1. If you have already inserted the schedule in
your project, click on it to select it, then right-
click and select Properties. If you have not
inserted it yet, select Tools > Analyze >
Schedules, then select the type of schedule
you want to generate.

2. In the Schedule dialog, click Setup.
3. To select a line style for the schedule’s bor-

der, click the Border button, then make a
selection from the Line Styles dialog.

4. To select a line style for the lines between
columns and rows, click the Division button,
then make a selection from the Line Styles
dialog.

5. Click OK.

Note: Line style settings apply only to the inserted
schedule, not the schedule displayed in the dialog.

Defining Schedule Marks
When defining schedule marks, you can choose either
a circle, square, hexagon or octagon shape. You can
also control the line style used for the mark, as well as
the text style of the mark content.
To define schedule marks:
1. If you have already inserted the schedule in

your project, click on it to select it, then right-
click and select Properties. If you have not
inserted it yet, select Tools > Analyze >
Schedules, then select the type of schedule
you want to generate.

2. In the Schedule dialog, click Setup.
3. To select a shape for the schedule marks, click

on the appropriate graphic in the Mark Style
area of the Schedule Setup dialog.

4. To select a text style for the schedule mark
text, click the Text Style button in the Mark
Style area, then select the desired style in the
Text Styles dialog.

5. To select a line style for the mark line, click
the Line Style button in the Mark Style area,
then select the desired line style in the Line
Styles dialog.

6. Click OK.



- 376 -

Removing Schedule Marks
If you do not want doors or windows to be tagged
with schedule marks, you can prevent them from
appearing by editing your schedule settings.
To remove schedule marks:
1. If you have already inserted the schedule in

your project, click on it to select it, then right-
click and select Properties. If you have not
inserted it yet, select Tools > Analyze >
Schedules, then select the desired type of
schedule.

2. In the Schedule dialog, disable the Tag Ele-
ments with Schedule Mark check box.

3. Click OK.

Note: You can also hide schedule marks from view
using the View Filter.

Green 3D Home.com
The Green 3D Home web site is dedicated to helping
you "go green". The site provides comprehensive
information on greening your home, energy use, and
energy resources. Some of the things you can find on
this site include:
l BIM catalogs of manufacturers' products for
download

l Tips on how you can green each room in your
home

l Detailed analysis of your home
l Information on how we use energy, and how
much

l Information on various energy sources
l Green products and services
l Sharing projects and ideas with others

To access the Green 3D Home web site:
1. Select Tools > Analyze > Green 3D Home.-

com or click on the Help toolbar.
Or, go to http://www.green3dhome.com in
your Internet browser.

Exporting Model Data to
REScheck
Building Essentials | Construction Suite

You can use the REScheck Export tool to export data
from your Envisioneer model to a REScheck XML
(*.rxl) file. You can then open this file in REScheck to
determine whether new homes, additions, and
alterations meet the requirements of the International
Energy Conservation Code (IECC), or a number of
state energy codes.
To export model data to REScheck:
1. Select Tools > Analyze > REScheck Export.
2. In the Save As dialog, select a save location

and file name, then click Save.

Displaying_Hiding_Schedule_Marks.htm
http://www.green3dhome.com/
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3D RealView™ Rendering adds light and shadow to a textured 3D view to achieve photo-realistic images of both the
interior and exterior of your home. You can save rendered images in BMP, JPG or TGA format, or open them
directly in image editing applications where you can further edit and enhance them. Once you’ve set up your scene,
creating a 3D RealView rendering involves only a mouse click or two. In a short time you’ll have a vivid, life-like
view to enjoy!

Use the Render Panoramic View tool to generate a realistic, wide-angle view that can be viewed using the VR app.

The powerful Animation tool lets you record an actual tour through your 3D model that you can play back at any
time. You can even add realistic sounds to your animation, such as a doorbell ringing. You can also choose to ray
trace the animation for a photorealistic display that includes light, shadows and reflection. To create an animation,
all you need to do is draw one or more paths for the camera to follow. Then, just sit back and watch your design
come to life!

Attaching sounds to elements is a great way to add realism and excitement to your design. For example, you can
attach the sound of a doorbell to a door, or even a voice-over. Once you’ve attached a sound to an element you can
play it any time using the Play Sound tool. The catalog includes a number of pre-defined sounds for your
convenience, including a creak, knock, doorbell, phone, clock chime, horn and ignition. You can attach sounds to
individual elements in your drawing, or to elements in the catalog.

3D RealViewTM Rendering
Rendering is a process of generating an image from a 3D model. The image is like a photograph, and contains
texture, lighting and shadows. In fact, it is sometimes difficult to distinguish a 3D RealView™ rendering from an
actual photograph. 3D RealView™ renderings are great to use when presenting designs to clients. Their
photorealistic nature captures attention and gives clients a true sense of the design.

Renderings are easy to create — just set up your 3D view, make sure you have lighting in place, and then use the
Render 3D RealView tool to create the rendering.
Before creating a rendering you can select a quality level for the rendered image, and define various settings that
affect the image output.

The progress of the rendering is displayed in real time, and you can adjust the brightness of the image and any
highlighted areas either during rendering or after rendering. Once the image has been rendered, you can save it as a
BMP, JPG or TGA file, or open it directly in an image editing program for further enhancement.

How Rendering Works
A rendered view is a photo realistic 3D view that includes light and shadows. To render a view, two algorithms are
used: global illumination and raytracing.

Global illumination is an algorithm that simulates the many reflections of light around a scene, generally resulting in
softer, more natural shadows and reflections.

The first part of the global illumination process involves finding those element surfaces that are visible to direct light
and calculating how much light is transferred to each element. Some elements will receive more light than others
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depending on their surface properties, and different
surfaces will reflect different amounts of light. Still,
each element will absorb some of the light, so the total
amount reflected back into the scene will be less than
that emitted by the light fixtures.

Raytracing is a direct illumination algorithm that
traces the path taken by a ray of light from the camera
through the scene, then calculates the reflection,
refraction, or absorption of the ray when it intersects
objects in the scene.

The process begins by finding the element that reflects
the most light. The element is considered a secondary
light source, so we need to calculate how much of its
light is transferred to other elements in the scene.
Multiple passes are performed until the amount of
light remaining in the scene is negligible in
comparison to the light originally emitted by the light
fixtures. When the passes have been completed, that’s
when raytracing can begin.

Material properties define how light reflects off a
surface. Direct light and ambient light levels define
the light that is reflected. Direct light is light that is
emitted from light fixtures. It has a specific color,
intensity and direction. Ambient light can be thought
of as a general level of light that is everywhere in the
scene. Every light in a scene contributes to the overall
ambient light in a scene.

All of this may seem complicated, but Envisioneer
takes care of it all in one mouse click.

Setting the Viewpoint for a Ren-
dering
When you create a 3D RealView™ rendering, your
model is captured at the angle currently shown on the
screen. Some topics you may want to look at:

Displaying 3D Camera Views on page 231

Changing Your Viewpoint on page 233

Changing the Viewing Field Angle on page 234

Setting the Lighting for a Ren-
dering
Even though creating a 3D RealView™ rendering
involves nothing more than a mouse click, there are a
few things you should consider beforehand.
Exterior Shots

If you want to do an exterior shot, the most important
factor to consider is sunlight. This is determined by
your global position and time of day. By adjusting
these settings, you control how much sunlight is in
the scene, and from what angle it shines.
Night Shots
To create a night shot, you need to first set your
background to a night scene. Once your background
is set, all you need to do is set the time to a time of
day when there is no sun. If you do want to create a
night shot, you will probably want to insert some
exterior lighting in your design.
Interior Shots
When creating interior shots, light comes from light
fixtures that you have inserted in the room, and can
also come through the windows if it is daytime. You
can turn lights on and off as well as change their
bulbs for different light intensity and effect.

Defining Your Location
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Setting your global position determines how much
daylight there will be in a scene relative to the time of
day in the scene's properties.
To define your location:
1. Select Settings > Document Settings, or

click on the Settings toolbar. You can also
click the Options button in the 3D RealView
dialog.

2. In the left pane, select Global.
3. Select a country and city from the appropriate

drop boxes. You can add or edit a city if
needed. Just click the Add or Edit button.
You will need to know the longitude, latitude
and time zone of the city.

4. To set the angle from true north, enter a
value in the Angle edit box, or simply click
and drag the arrow indicator to rotate it.

This is the “geographic” North, as opposed to
the “magnetic” North which you see on a
compass. The value you specify determines
where North is on your screen, and affects
the angle of the sun for daylight rendering.
The number in degrees that you enter is in

Defining_Time_Day.htm
Selecting_a_Background_for_3D_Views.htm
Selecting_a_Background_for_3D_Views.htm
Defining_Time_Day.htm
Defining_Time_Day.htm
Defining_Time_Day.htm
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relation to the 90° perpendicular orientation
of your drawing. A value of 1º makes the top
of the screen North. A value of 90º makes the
top of the screen East, and the left side of the
screen North.

It is assumed that information regarding
building orientation to True North can be
taken from, or calculated from, a surveyor's
certificate. However, True North can be
calculated from a Magnetic North reading
taken at your building site. See Calculating
True North from Magnetic North in the online
help.

5. Click OK.

Calculating True North from
Magnetic North
What is True North?

True North is the geographic North Pole. It is located
at 90° North latitude and all lines of longitude
converge at the pole. The Earth's axis connects the
north and south poles. The Earth's axis is the line
around which the Earth rotates. The North Pole is
approximately 450 miles (725 km) north of Greenland
in the middle of the Arctic Ocean.

What is Magnetic North?

Magnetic North is the magnetic north pole. It is the
focus of the planet's magnetic field and is the point
magnetic compasses point toward. Unlike the
geographic North Pole, the magnetic north pole
moves (even daily). It moves approximately 9 miles

(15 km) each year. It is presently located about 1000
miles (1600 km) south of the geographic North Pole at
78° 18' North and 104° West (southwest of Nunavut in
Northern Canada).

How do you calculate True North from Mag-
netic North?

The difference between Magnetic North and True
North is called the variation. To convert magnetic
readings to true, you need to find the variation for
your particular location. Maps such as U.S. Geological
Survey maps, aviation charts and marine charts all list
the variation. Because variation changes from location
to location, you need to get a map for your area.
Variation is listed in terms of degrees east or west. If
it is east variation, you subtract the number of
degrees from the magnetic direction to obtain the true
direction. If it is west variation, you add the number
of degrees to the magnetic direction to obtain the true
direction.

Note: If you use a compass to determine Magnetic
North in relation to the building line that you plan
to orient at 90° to the perpendicular in your
drawing, and factor in your local variation, you
should easily be able to calculate True North in
relation to your plan.

Setting the Season
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Setting the season can determine how plants will look in
a rendered scene, relative to your global location.
To set the season:
1. Select Settings > Document Settings, or

click on the Settings toolbar. You can also
click the Options button in the 3D RealView
dialog.

2. In the left pane, select Global.
3. Click the Plant Season drop box and select

either Summer, Winter, Fall, or Spring.
4. Click OK.

Creating a 3D RealViewTM Ren-
dering
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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You can render any 3D view in a matter of minutes,
with the click of a button. The result is an impressive,
photo-like image that incorporates light, shadows,
reflections, and other realistic attributes.

The 3D RealView tool uses both global illumination
and raytracing to produce an image of exceptional
quality. The 3D RealView feature begins by reading in
the model's geometry, and then proceeds with the
global illumination calculation, which occurs in
multiple passes. Global illumination is an algorithm
that simulates the many reflections of light around a
scene, resulting in soft, natural shadows and
reflections. Once global illumination is complete,
raytracing begins automatically. Raytracing is a direct
illumination algorithm that traces the path taken by a
ray of light from the camera through the scene, then
calculates the reflection, refraction, or absorption of
the ray when it intersects objects in the scene.

The 3D RealView dialog lets you see the progress of
the rendering in real time, and lets you know how
much time is remaining in each pass. You can adjust
the brightness of the image, as well as the intensity of
highlighted areas. Once the rendering is complete,
you can save the image, open it in an editing
application, or reset the view and render again.
To create a 3D RealView rendering:
1. Display the 3D view that you want to render.

2. Select View > Render 3D RealView.
3. In the 3D RealView dialog, make sure the

scene is how you want it to appear. You can
change the scene using tools below the
preview window, such as Zoom In, Zoom
Out and Walk Around.

4. To define the image output size, make a
selection from the Size drop box in the Image
area. You can select one of the common
output sizes or select Custom Size to define
a custom size. The dialog box will resize
accordingly.

Note: If you select a size that is larger than
your screen, the image will be rendered in
pieces or tiles off-screen. The rendered tiles
will be put together behind the scenes to

form a complete image that will be saved
at the specified size.

5. Click the Start render button to begin.

First, the model's geometry is analyzed. Once
that is done, the global illumination
calculation begins. Global illumination
determines how much light is given off by
the sun or by lighting fixtures, and how
much light is reflected off the surface of
elements. Global illumination occurs in two
or more passes. Once global illumination is
complete, raytracing begins automatically.
The view is updated in real time during these
calculations, and the Remaining Time and
Elapsed time of each pass is displayed in the
Progress area.

6. To adjust the overall brightness of the image,
adjust the value in the Brightness edit box.
Lower values darken the image, while higher
values make it brighter.

7. To adjust the intensity of highlighted areas,
adjust the value in the Burn edit box. This
can be a decimal value between 0 and 1.
Lower burn values will decrease the intensity
of the highlights to avoid “burned out” areas
in the image.

8. To control the overall brightness of an image,
adjust the Gamma value.
When the rendering is complete, the message
Render Complete! appears in the Progress
area. Now you can either save the image,
open it in an editing application, or reset the
view and render again.
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9. If you want to create a grayscale image,
enable the Convert to grayscale check box
before saving. This will produce a mono-
chromatic image containing varying shades of
gray.

10. To save the rendered image to a file, click
Save. In the Save As dialog, navigate to the
location where you want to save the image,
select a file type (BMP, JPG or TGA) from the
Save as type drop box, and then type a
name for the file in the File name edit box.
Click Save to save the image.

11. To open the image in an image editing applic-
ation, where you can edit or enhance it fur-
ther, click the down arrow next to the Save
button and select Launch Viewer. The applic-
ation that launches is the one that is asso-
ciated with image files in Windows Explorer.
For example, a BMP file may open in
Microsoft Paint, or whatever program that nor-
mally launches when you attempt to open a
BMP file from Windows Explorer.

12. If you do not want to keep the rendered
image, click Reset. This resets the view to its
original state, and you can render again if
you wish.

13. If you want to make changes to the actual
scene, like add a light fixture or apply a dif-
ferent material to an element, click Close,
and then make the desired changes. When
you are ready to render again, select View >
Render 3D RealView. If you want to return
to the camera position and zoom level that
you were at when you first rendered the
scene, select Last Camera Position from the
Camera drop box at the top of the dialog.

14. When you are finished viewing the 3D
RealView rendering, click Close.

Rendering a Panoramic View for
VR Viewing
Use the Render Panoramic View tool to generate a
rendered, wide-angle view that can be viewed using a
VR app. The resulting image incorporates light,
shadows, reflections, and other realistic attributes for
the ultimate virtual reality experience.

The Render Panoramic View tool uses some of the
same algorithms as the Render 3D RealView tool to
produce an image of exceptional quality. The
rendering process occurs in two distinct stages, and
each stage may include multiple passes.

Once the view has been generated, you will be
prompted to upload it for viewing with the VR app.

For more information visit
https://www.cadsoft.com/products/virtual-reality/.
To render a panoramic:
1. Display the 3D view that you want to render.

2. Select View > Render Panoramic, or click
on the View Control toolbar.

3. In the Generate Panoramic View dialog,
click the Step #1 Generate GI button to
begin. The Global Illumination calculation
begins. Global illumination determines how
much light is given off by the sun or by
lighting fixtures, and how much light is
reflected off the surface of elements. Global
illumination occurs in two or more passes.
Once global illumination is complete,
raytracing begins automatically. The view is
updated in real time during these
calculations, and the Remaining Time and
Elapsed time of each pass is displayed in the
Progress area.

4. When the first stage is complete, click the
Step #1 Generate Faces button.

5. To adjust the overall brightness of the image,
adjust the value in the Brightness edit box.
Lower values darken the image, while higher
values make it brighter.

https://www.cadsoft.com/products/virtual-reality/
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6. To adjust the intensity of highlighted areas,
adjust the value in the Burn edit box. This
can be a decimal value between 0 and 1.
Lower burn values will decrease the intensity
of the highlights to avoid “burned out” areas
in the image.

7. To control the overall brightness of an image,
adjust the Gamma value.
When the rendering is complete, the message
Render Complete! appears in the Progress
area. Now you can either save the image,
open it in an editing application, or reset the
view and render again.

8. If you do not want to keep the rendered
image, click Reset. This resets the view to its
original state, and you can render again if
you wish.

9. If you want to make changes to the actual
scene, like add a light fixture or apply a dif-
ferent material to an element, click Close,
and then make the desired changes. When
you are ready to render again, select View >
Render Panoramic View.

10. When the panoramic rendering is complete,
you will be prompted to upload it for
viewing with the VR app:

Setting the Rendering Quality
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the quality level chosen for the ray trace
quality is Level 2 - Low (fast). You can select a
different quality level before rendering if you want.
Note that the higher level of quality you choose, the
longer the rendering process takes. You can set the
default quality level for all renderings in your
Program Settings. If you want you can override the
default quality level directly within the 3D RealView
dialog when creating a rendering.
To set the default rendering quality for the project:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.
3. In the Ray Trace Quality area, select the qual-

ity level you want from the Level drop box.
4. Click OK.
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To adjust the rendering quality for a particular
rendering:
1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. In the Ray Trace Quality area, select the qual-
ity level you want from the Level drop box.

5. Click OK to return to the 3D RealView dia-
log.

Using Antialiasing in Rendering
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Antialiasing blends pixels in areas where two colors
or two materials meet to reduce artifacts (or “stair
steps”) and produce a more natural look to the scene.
By default, antialiasing is set to 1 to increase
rendering speed. You can select varying levels of
antialiasing. You can set the default antialiasing value
for all renderings in your Program Settings. You can
also override the default antialiasing value for a
particular rendering while the 3D RealView tool is
active.
To set the default antialiasing value:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.
3. Use the arrow keys next to the Antialiasing

edit box to increase or decrease the level of
antialiasing. The higher the level, the cleaner
the image, but the longer the rendering pro-
cess takes.

4. Click OK.
To adjust the antialiasing for a particular
rendering:
1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. Use the up arrows key next to the Antiali-
asing edit box to increase the level of anti-
aliasing. The higher the level, the cleaner the

image, but the longer the rendering process
takes.

5. Click OK to return to the 3D RealView dia-
log.

Adjusting the Noise Reduction
Level When Rendering
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Noise in a rendered image refers to areas of
graininess. This can happen in interior scenes that mix
sunlight and interior lighting, or when sunlight comes
through a skylight. If you see noise in a rendering,
you can increase the noise reduction level in your 3D
RealView settings, and then render the view again.
Note that increasing the noise reduction level may
increase the rendering time.
To set the default noise reduction level:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.

3. Adjust the Electrical lights noise reduction
and Skylight noise reduction values using
the scroll arrows.

4. Click OK.
To change the noise reduction level for a particular
rendering:
1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. Adjust the Electrical lights noise reduction
and Skylight noise reduction values using
the scroll arrows.

5. Click OK to return to the 3D RealView dia-
log.

Controlling the Intensity of
Trees and Billboards
Personal Architect | Pro Architect | Building Essentials |
Construction Suite



- 384 -

You can adjust the brightness and contrast of trees
and billboards in a rendered scene by editing your
rendering settings.
To set defaults for tree/billboard intensity:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.
3. Adjust the Tree and billboard intensity

value.

4. Click OK.
To specify the tree/billboard intensity for a
particular rendering:
1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. Adjust the Tree and billboard intensity
value.

5. Click OK to return to the 3D RealView dia-
log.

Allowing the Background Bright-
ness to Adjust when Rendering
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the brightness of the background adjusts
along with the rest of the scene when a rendering is
being generated. If you want the background
brightness to remain unchanged, you can disable
background brightness adjustment.

To allow or prevent background brightness
adjustment for all renderings:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.
3. In the Background area, enable or disable

the Allow brightness adjustment check box.
4. Click OK.

To allow or prevent background brightness
adjustment for a particular rendering:

1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. In the Background area, enable or disable
the Allow brightness adjustment check box.

5. Click OK to return to the 3D RealView dia-
log.

Using the Background Texture
as a Light Source when Ren-
dering
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When rendering, the Use texture as light source
option enables you to apply a tint to the scene which
is based on the color of the scene's background
texture.

To use the background texture as a light source
for all renderings:
1. Select Settings > Document Settings.
2. In the Document Settings dialog, select 3D

RealView in the left column.
3. In the Background area, enable the Use tex-

ture as light source check box. Edit the Tex-
ture intensity as desired.

4. Click OK.
To allow or prevent background brightness
adjustment for a particular rendering:
1. Select View > Render 3D RealView.
2. In the 3D RealView dialog, click the Options

button.

3. In the Document Settings dialog, select 3D
RealView in the left column.

4. In the Background area, enable the Use tex-
ture as light source check box. Edit the Tex-
ture intensity as desired.

5. Click OK to return to the 3D RealView dia-
log.
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Adjusting the Light Coming
from Light Fixtures
To adjust the color or intensity of light coming from a
light fixture, you can add light bulbs, change a light
bulb to a different type, adjust the intensity of the
light, select a different color for the light, or turn a
light off completely.

See the following topics:

Editing a Light Fixture's Light Source on page 141

Turning a Light On or Off on page 142

Editing the Surface Properties
of Materials
Different materials have different finishes. Surface
finishes include Dull, Low Gloss, Semi Gloss, High
Gloss, Liquid, Fully Reflective, Partially Reflective,
Shiny, Fully Transparent, and Partially Transparent.
The finish determines how much a material reflects,
emits and absorbs light. These factors can affect the
lighting in a rendered scene.
To edit the surface properties of an element’s
materials:
1. Select the element in your drawing.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the properties dialog, select the Appear-
ance tab.

4. On the Appearance page, click the Select but-
ton, or click the texture swatch to access the
Materials dialog.

5. In the Materials dialog, select the material to
edit, then select Edit > Edit Material, or right-
click and select Edit Material.

6. To change the surface finish of the material
(dull, shiny, etc.), make a selection from the
Preset Effects drop box. If you want to spe-
cify a custom surface finish, select Custom in
the list, then enable the Display settings
details check box.

7. Specify the properties of the finish. These are
described below.

Specular. Reflection that creates highlights
on materials, making them appear shiny.

Emissive. The amount of light given off by a
material. The more emissive a material is, the
more self-luminous it appears.

Color Bleed. The degree to which different
colors blend where they meet.

8. Click OK in the Material Properties dialog.
9. Click OK in the Materials dialog.
10. Click OK in the properties dialog.

Troubleshooting a 3D
RealViewTM Rendering
Problem: Rendering is too light or too dark

If you find that your rendering is too light or too
dark, or that you want to create different lighting
effects, consider the following concepts:

Time of Day. Your location and time of day
determine how much daylight is in a scene.

Light Fixtures. You may need to add interior light
fixtures or exterior light fixtures to increase the
amount of light in a scene. This is particularly
important for interior shots and night shots. Note that
rooms without light fixtures will be illuminated by
the camera's headlight when viewing and navigating
in 3D, but this light is not used in rendering.

Light Sources. You can change the bulbs in your
light fixtures to achieve different lighting effects. For
example, you can choose a bulb with a stronger or
weaker wattage, or one that is a different color.

Turning Lights Off. If you have light fixtures in your
scene and want to decrease the amount of light in the
scene, you can turn selected light fixtures off.

Gamma. Gamma correction controls the overall
brightness of an image. Lower values darken the
image, while higher values make it brighter. Images
that are not properly corrected can look either
bleached out, or too dark.

Scene Properties. You can adjust certain options in
your Scene Properties to control factors such as
daylight and brightness. For example, you can edit
the sun and sky conditions.
Problem: The quality of the rendering is poor

If your rendering looks blurry, has areas of graininess,
or has jagged edges, try the following:

Quality Level. There are five quality levels to choose
from. By default, the Low (fast) quality level is used.

Defining_Time_Day.htm
Changing_the_Sky_Conditions.htm
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Selecting a higher quality level may improve the
general appearance of your rendering.

Antialiasing. During the raytracing process,
antialiasing blends pixels in areas where two colors or
two materials meet to reduce artifacts (or “stair
steps”). By default, antialiasing is set to 1 to increase
rendering speed. To reduce jagged edges and create a
more natural-looking scene, try increasing the
antialiasing value.

Noise reduction level. Noise in a rendered image
refers to areas of graininess. This can happen in
interior scenes that mix sunlight and interior lighting,
or when sunlight comes through a skylight.
Increasing the noise reduction value will reduce noise
in your renderings.
Problem: A wall looks black instead of textured

Sometimes when a single wall is drawn (to fill in a
gable end, for example), it appears black when
rendered because it is seen as an interior wall instead
of an exterior wall. You can force either side of a wall
to be exterior by editing the wall's settings. The wall
will then be rendered with the proper materials.

To force wall sides to be exterior, go into the wall's
properties (select the wall and then right-click and
select Properties), then enable the Force Surface To
Be Exterior check box in either the Left Interior Surface
or Right Interior Surface area. For more information see
Forcing Wall Sides to be Exterior on page 63.

Animations
Animations are like movies — series of images that,
when viewed in rapid succession, create the illusion
of movement through a scene. Animations are the
perfect way to walk a client through their home and
give them a true feel for the design.

To create an animation, you need to draw a path
through your 2D plan for the camera to follow. You
can draw more than one path if you want, and specify
the order of paths for the camera to follow. You can
edit a path if necessary and even add sounds to it,
such as a voiceover or doorbell ringing. You can then
preview the animation and record it to a file.

When you record an animation, it is output to an AVI
file. You can control the animation’s speed, video
compression, resolution and frame rate. You can also
opt to ray trace the animation for optimal effect.

Drawing an Animation Path
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The first step in creating an animation is defining a
path for the camera to follow. You can specify where
you want the camera to look (along the path or at a
specific target), as well as the view angle.

You draw the path by selecting a camera start point
and subsequent control points. The path automatically
curves between points to create a smooth motion for
the camera. Once you have drawn the path, you can
add, remove and elevate control points if you want.

You can draw more than one path if you want. By
default, all paths will be included in the animation,
and will be followed in the order in which they were
drawn. You can, however, choose which paths you
want to include in the animation, as well as the order
of paths for the camera to follow.
To draw an animation path:
1. Make sure that the location on which you

want to capture the animation is the current
building location. Also, it is recommended
that you draw the path while in 2D plan
view.

2. Select Tools > Animation > Insert Path, or
click on the Animation toolbar.
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3. In the Path Properties dialog, specify a name
for the path for identification purposes.

4. In the Behavior area, specify what you want
the camera to focus on during the animation.
If you select Follow Path, the camera will
focus on a different target along the path in
each frame. If you select Specify Target, the
camera will always point towards a target
point that you specify.

5. In the View Angle area, specify how wide you
want the view angle to be by either sliding
the ruler or entering a value in the edit box.
Higher values produce a wide-angle view;
lower values produce a close-up view.

6. Click OK.
7. Select a start point for the camera. For

example, if you want to start your animation
by walking through the front door, select a
point outside the front door.

8. If you selected the Specify Target option,
select the point you want to the camera to
remain focused on during the animation.

9. Select the next point of the path. Each point
you select is called a control point. The cam-
era will move to each control point and cap-
ture an image of the view at that point.
Basically, control points are the key to draw-
ing and shaping your path.

10. Continue selecting control points until your
path is finished.

11. Right-click and select Finish. You can now
preview the animation.

Drawing Separate Camera and
Target Paths
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you want you can draw two paths for an animation:
one for the camera to move along (camera path), and
a separate one for the camera to focus on (target
path). This would be like watching an airplane from a
moving car.

If you want your camera to focus on a target path,
you need to draw the camera path using the Specify
Target option. Once you have drawn both paths, you
need to snap the camera path’s target point to the
target path.
Step One: Draw the Target Path
1. Select Tools > Animation > Insert Path, or

click on the Animation toolbar.

2. In the Path Properties dialog, give the target
path a name.

3. Click OK.
4. Pick points to define the target path, then

right-click and select Finish.
5. Select Tools > Animation > Animation Prop-

erties, or click on the Animation toolbar.

6. If you do not want to include the target path
in your animation, uncheck the Include check
box beside the target path’s name in the
Animation Properties dialog.

7. Click OK.
Step Two: Draw the Camera Path
1. Select Tools > Animation > Insert Path, or

click on the Animation toolbar.

2. In the Path Properties dialog, give the cam-
era path a name.

3. Enable the Specify Target option.
4. Click OK.
5. Select the start point of the camera path.

6. Select a random target point. You will snap
the target to the target path later.

7. Select the remaining points of the camera
path, then right-click and select Finish.
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Step Three: Connect the Paths
1. Click on the camera path to select it.

2. Click and drag the target point (the point at
the end of the arrow) to the target path, then
release your mouse button. The target point
automatically snaps to the camera of the tar-
get path. You are now ready to preview the
animation.

When you preview the animation, you’ll notice that
the camera moves along the camera path and focuses
on points along the target path as the animation
plays.

Previewing an Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Once you have drawn one or more paths for your
animation, you can preview the resulting animation.
You can play the animation automatically, or step
through it frame by frame.
To preview an animation:
1. Make sure you have drawn a suitable path

for your camera.

2. Select Tools > Animation > Create
Animation, or click on the Animation
toolbar.

3. In the Create Animation dialog, click to
automatically play the animation. To pause
the animation, click .

4. To play the animation manually by stepping
through each frame, click . To step back to
the previous frame, click . Alternatively
you can click and drag the slider to play it
manually or skip to specific frames of the
animation.

5. To return to the start of the animation so you
can play it again, click .

Note: By default, the animation plays once during
the preview. You can set it to repeat if you want.

Note: To be able to view the animation outside of
Envisioneer, you need to save the animation to a
file.

Note: If you enabled the Ray Trace Animation
option in your Animation Properties, the ray
tracing will not appear in the preview. It will only
appear when you save the animation to a file.

Repeating an Animation During
the Preview
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, an animation is played once when you
preview it. You can set the animation to repeat during
the preview, meaning it will play continuously until
you close the preview window.
To repeat an animation during the preview:
1. Select Tools > Animation > Animation Prop-

erties, or click on the Animation toolbar.
You can also access properties from the
Create Animation dialog.

2. In the Animation Properties dialog, enable
the Repeat Animation during preview check
box.

3. Click OK.
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Changing the Path Order in an
Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have drawn more than one path for your
animation, the paths will be followed in the order in
which they were drawn. You can change the path
order if you want.
To change the path order in an animation:
1. Select Tools > Animation > Animation Prop-

erties, or click on the Animation toolbar.
You can also access properties from the
Create Animation dialog.

2. In the Animation Properties dialog, use the
Move Up or Move Down buttons to move
selected paths up or down in the list.

3. Click OK.

Choosing the Paths to Include
in an Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, all animation paths that are present in
your drawing will be included in the resulting
animation. You can choose to prevent selected paths
from being included if you want.
To choose which paths you want to include in the
animation:
1. Select Tools > Animation > Animation Prop-

erties, or click on the Animation toolbar.
You can also access properties from the
Create Animation dialog.

2. In the Animation Properties dialog, uncheck
the boxes in the Include column for any
paths you do not want to include.

3. Click OK.

Moving an Animation Path's
Control Points
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can adjust an animation path by moving its
control points. When you move a control point, the

path automatically adjusts to maintain a smooth,
curved path. If the path was created using the 'Specify
Target' option, you can move the target point also.
To move control points on a path:
1. Click on the camera or any point on the path

to select the path. Blue grips appear at each
control point.

2. Hover your pointer over the control point
you want to move. This displays the Move
cursor.

3. Click and drag the point to the desired loc-
ation, then release your mouse button.

Adding Control Points to an
Animation Path
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Once you have drawn a path for your animation, you
can easily add control points to the path if you want.
Adding control points can help you expand your path
where needed, or provide a point to attach a sound
to.
To add a control point to your path:
1. Select Tools > Animation > Add Control

Point, or click on the Animation toolbar.

2. Click where you want to add the control
point. A control point is automatically added
to the path.

Removing a Control Point from
an Animation Path
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can easily remove a control point from an
animation path using the Remove Control Point tool.
To remove a control point from a path:
1. Select Tools > Animation > Remove Control

Point, or click on the Animation toolbar.

2. Click on the control point you want to
remove.

Note: Removing a control point can change the
shape of the path slightly depending on the
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location of adjacent control points to ensure a
smooth, curved path.

Editing the Elevation of a Con-
trol Point
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, control points are 5’-6” above the floor
level of the current building location. You can edit the
elevation of a control point on an animation path
using the Elevate Control Point tool. This adjusts the
path so it goes up or down depending on the
elevation you specify. For example, if your path is on
the ground floor and you have a control point at
either end of a staircase, elevating the top control
point will make it seem as if you’re walking up the
stairs.
To edit the elevation of a control point:
1. Select Tools > Animation > Elevate Control

Point, or click on the Animation toolbar.

2. Click on the control point you want to edit.

3. In the Elevate dialog, the value currently
shown is the current elevation of the control
point. Edit the elevation as desired.

4. Click OK.

Editing the Elevation of the Tar-
get in an Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you used the Specify Target option when defining an
animation path, you can raise or lower your target
point. This essentially changes the tilt of your camera
up or down. You can change the elevation of the
target point using the Commander.
To edit the elevation of the target in an animation:
1. Click on the animation path in 2D Plan view

to select it. Grips appear at the path's control
points and target point.

2. Hover your cursor over the target point, then
click and hold down your left mouse button.
The Commander becomes active.

3. While holding down your left mouse button,
press the TAB key twice to enter the third
edit box in the Commander. This is the Z
value (elevation).

4. Type the desired elevation for the target
point, then press ENTER.

Adding Sounds to an Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add a variety of sounds to your animation,
such as a doorbell ringing or the creak of a door
opening. Sound is added to an animation by inserting
a sound node at a selected path control point, and
choosing the sound file you want to play at that point.
The sound will be played when the camera reaches
that point during the playback of the animation.
To add a sound to an animation:
1. With your 2D plan displayed, select Tools >

Animation > Add Sound Node, or click
on the Animation toolbar.

2. Click on the control point on your animation
path where you want to insert the sound.

3. In the Open dialog, select the sound file you
want to insert. Sound files have a *.wav exten-
sion. A number of sounds can be found in the
program’s Sounds directory. To hear the selec-
ted sound, click the Play Sound button.

4. Click Open. A small node is inserted next to
the control point.

Note: Sound nodes can only be placed at control
points. You can add control points to your path if
necessary.

Removing Sounds from an Anim-
ation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can easily remove sounds that you have inserted
in your animation using the Remove Sound Node
tool.
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To remove a sound from an animation:
1. With your 2D plan displayed, select Tools >

Animation > Remove Sound Node, or click
on the Animation toolbar.

2. Click on the control point that the sound has
been added to. The sound node is removed.

Saving an Animation to a File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Once you have previewed your animation and are
satisfied with it, you can record it to an *.avi file
which can be played using any digital media
application that supports the *.avi file format, such as
Windows Media Player. When you save an
animation, the 3D view is rendered to achieve high
quality results. Rendering is a process that involves
the calculation of light in a scene, resulting in natural-
looking shadows and reflections. For even more
photorealism you can enable ray tracing in your
Program Settings.
To save an animation to a file:
1. Select Tools > Animation > Create Anim-

ation, or click on the Animation toolbar.

2. In the Create Animation dialog, click Save.
3. In the Save As dialog, specify a file name

and save location for the animation file, then
click Save. The animation begins recording.
The process begins by reading in the model's
geometry, and then proceeds with the global
illumination calculation. Global illumination is
an algorithm that simulates the many
reflections of light around a scene, resulting
in soft, natural shadows and reflections. If
you have specified that you want to ray trace
animations in your Program Settings, ray
tracing begins immediately after the global
illumination calculations have been made.
Raytracing is a direct illumination algorithm
that traces the path taken by a ray of light
from the camera through the scene, then
calculates the reflection, refraction, or
absorption of the ray when it intersects
objects in the scene.

The Create Animation dialog displays the
progress of the recording in real time, and
lets you know how much time is remaining
in each pass.

4. The process pauses after the first frame of the
animation has been rendered, enabling you to
adjust the Brightness and Burn values
(described below). When you are ready to
resume recording, click Continue.
Brightness refers to the overall brightness of
the scene. Lower values darken the scene,
while higher values make it brighter.

Burn is a parameter that controls the
intensity of highlighted areas. Lower burn
values will decrease the intensity of the
highlights to avoid “burned out” areas in the
animation. This can be a decimal value
between 0 and 1.

5. If you click Cancel while an animation is
being rendered, the rendering will stop, and
the view in the preview window will be reset.

6. When the recording is complete, click Close.
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Note: By default, the animation is saved at a size of
640 x 480 pixels. To save it at a different size, see
Specifying an Output Size for Animation Files on
page 393.

Note: You can choose to save the individual frames
of your animation as well. See Saving Individual
Animation Frames on page 392.

Editing the Default Name or
Save Location of Animation
Files
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can specify the default name and save location of
animation files by editing your Program Settings. The
name and path you choose will automatically appear
in the Save As dialog when you save animations.
Note that you can still override the default name and
location when saving an animation.
To edit the default name or save location of
animation output files:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, click the
browse button next to the Filename edit box.

3. In the Save As dialog, navigate to the loc-
ation where you want to save animations,
then enter a default name for *.avi files in the
File name edit box.

4. Click Save.

Saving Individual Animation
Frames
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can specify that you want to save the individual
frames of your animations to individual files by
editing your Program Settings. Frame images are
saved in JPG format in the same folder where your
AVI file is saved.
To save individual animation frames:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, enable the
Save individual frames to disc check box.

3. Click OK.

Changing the Speed of an Anim-
ation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the speed of an animation is 80 inches per
second if working in feet and inches, or 2.032 meters
per second if working in metric units. You can speed
up or slow down an animation by editing either the
duration or velocity setting in a path’s properties.
Note that a different speed can be set for each path in
your drawing.
To change the speed of an animation:
1. Click on the path whose speed setting you

want to change. The path is highlighted with
blue grips.

2. Right-click and select Properties.
3. In the Path Properties dialog, edit either the

Duration or Velocity value. The duration is
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based on the specified velocity and length of
the path. Increasing the duration value will
slow the animation down, and decreasing the
duration value will speed it up. The velocity
determines what distance in covered in one
second. Increasing the velocity value will
increase animation speed.

4. Click OK.

Note: The Speed setting affects only the output file.
It does not apply to the preview.

Compressing Animation Files
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, animations are uncompressed when you
save them. This can result in very large files.
Compressing an animation converts the data into a
format that requires fewer bits, usually so that it can
be stored or transmitted more efficiently. If you
would like your animation files to be compressed
when you save them, you can specify this in your
Program Settings. There is an extensive list of video
compression coders that you can choose from.
To compress animation output files:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, select the
desired coder from the Video Compression
drop box.

3. Click OK.

Specifying an Output Size for
Animation Files
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, animations are recorded at a size of 640 x
480 pixels. You can specify a different output size for
animations in your Program Settings.
To specify an output size for animation files:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, select the
desired size from the Size drop box. Pre-
defined sizes include 640 x 480, 800 x 600,
and 1024 x 768. Selecting the Custom option
lets you define a custom size by entering val-
ues in the Width and Height edit boxes.

3. Click OK.

Specifying a Frame Rate for
Animations
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The frame rate is the number of images displayed per
second. More simply, it is the video playback rate of
the AVI animation. The playback rate directly relates
to the perceived smoothness of its playback. The
higher the number of frames playing per second, the
smoother the video playback appears. Lower rates can
result in a choppier playback. You can specify the
desired frame rate for animations in your Program
Settings.
To specify a frame rate for animations:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
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can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, enter a
value between 1 and 32 in the Frame Rate
edit box. You can enter a value manually or
use the arrow buttons to scroll through a list
of values.

3. Click OK.

Ray Tracing an Animation
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Ray tracing involves the calculation and display of
light, shadows and reflection for a photorealistic
effect. Light comes from lighting fixtures as well as
through windows, and is bounced off of surfaces that
have reflective properties.

By default, animations are not ray traced. If you want
to create a ray traced animation, you need to enable
ray tracing in your Program Settings before saving the
animation. Note that ray tracing can increase the
recording time significantly.

Ray tracing begins automatically after the global
illumination calculations.
To create ray traced animations:
1. Select Settings > Document Settings, and

then select Animations in the left pane of the
Document Settings dialog. Alternatively you
can select Tools > Animation > Animation
Properties, or click on the Animation
toolbar, and then click the Animation Set-
tings button in the Animation Properties dia-
log. You can also access the Animation
Properties dialog directly from the Create
Animation dialog when previewing an anim-
ation.

2. In the Document Settings dialog, enable the
Ray Trace Animation check box.

3. Click OK.

Note: Ray tracing occurs only when you record the
animation. It is not applied when previewing the
animation. The recording pauses before ray tracing
is completed so that you can review the image and
make brightness adjustments if needed.

Turning Animation Paths On
and Off
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can instantly hide or show all animation paths
using the Animation Paths On/Off tool.
To turn animation paths on or off:
1. Select View > Viewing Aids > Animation

Paths On/Off, or click the down arrow next
to the Viewing Aids button on the View
Control toolbar and select Animation Paths
On/Off.

Deleting an Animation Path
You can remove an animation path from your
drawing in a couple of easy steps.
To delete an animation path:
1. Click on the path to select it.

2. Press the Delete key on your keyboard, right-
click and select Delete, or select Edit >
Modify Elements > Delete.

Sounds
Attaching sounds to your drawing is a fun way of
adding realism and excitement to your project. For
example, you can attach the sound of a doorbell
ringing to your front door.

You can use the Attach Sound File tool to attach
sounds to elements in your drawing, or elements in
your catalog. If you attach a sound to an element in
the catalog, the sound will automatically be attached
to the element when you insert it in your drawing.

Once you have attached a sound to an element, you
can play the sound with the Play Sound tool.

Note: The method of adding sounds to animations
is different than the method of adding sounds to
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elements. In animations you need to add a sound
node to your animation path.

Attaching Sounds to Elements
in Your Drawing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Attaching sounds to elements is a great way to add
realism and excitement to your design. You can use
the Attach Sound File tool to attach

sounds to selected elements in your drawing. For
example, you can add the sound of a doorbell or even
a voice-over to your front door.
To attach a sound to an element in your drawing:
1. Select Tools > Sounds > Attach Sound File.

The Sounds cursor is displayed .

2. Click on the element you want to add the
sound to. You can select multiple elements if
you want using Shift+click.

3. In the Open dialog, select the *.wav file you
want to attach, then click Open. Note that
there are a number of pre-defined sounds in
the program’s Sounds directory. You can also
use your own *.wav files if you want. A dia-
log appears telling you that the sound was
attached successfully.

4. Click OK.

Note: Only one sound can be attached to an
element. If you attempt to attach a sound to an
element that already has a sound attached to it, the
new sound will replace the old sound.

Attaching Sounds to Elements
in the Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Attach Sound File tool to attach
sounds to elements in your catalog. For example, you
can add the sound of a door creak to an interior door.
Each time you insert the element in your drawing, it
will have the sound attached to it.
To attach a sound to an element in the catalog:

1. Select File > Catalogs > Element Manager,
or right-click any element in the catalog panel
and Element Manager .

2. In the Element Manager, select the element
that you want to add a sound to.

3. Click below the properties pane, then
select Attach Sound File.

4. In the Open dialog, select the *.wav file you
want to attach, then click Open. Note that
there are a number of pre-defined sounds in
the program’s Sounds directory. You can also
use your own *.wav files if you want. A dia-
log appears telling you that the sound was
attached successfully.

5. Click OK. The name of the sound file is dis-
played next to the Sounds button.

6. To test the sound, click again and select
Play Sound.

7. Click OK.

Note: Attaching a sound to an element in the
catalog affects only future insertions of that
element. Elements that already exist in your
drawing are not affected.

Playing Sounds
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have attached a sound to an element, you can
play the sound by selecting the Play Sound tool, then
clicking on the element with the attached sound.
To play a sound:
1. Select Tools > Sounds > Play Sound. The

Sounds cursor is displayed.

2. Select the element with the sound attached to
it. The sound plays.

Note: A notification dialog appears if the element
does not have a sound attached to it.

Removing Sounds from Ele-
ments in Your Drawing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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If you have attached a sound to an element in your
drawing, you can remove it using the Remove Sound
tool.
To remove a sound from an element in your
drawing:
1. Select Tools > Sounds > Remove Sound.

The Sounds cursor is displayed.

2. Click on the element. A dialog tells you that
the sound has been successfully removed.

3. Click OK.

Removing Sounds from Ele-
ments in the Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have attached a sound to an element in the
catalog, you can remove it by editing the element’s
properties. Note that this does not remove the sound
from elements already inserted in your drawing.
To remove a sound from an element in the catalog:
1. Select File > Catalogs > Element Manager,

or right-click any element in the catalog panel
and select Element Manager.

2. In the Element Manager, select the element
you want to remove the sound from.

3. Click below the properties pane, then
select Remove Sound. A dialog tells you that
the sound has been successfully removed.

4. Click OK.

Selecting a Default Sounds Dir-
ectory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the program’s Sounds folder is displayed
in the Open dialog when attaching sounds to
elements or animations. You can select a different
default directory to display if you want.
To select a default Sounds directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, click on the Sounds Dir-
ectory in the File Paths area.

3. Click Modify.

4. In the Browse For Folder dialog, select the
directory you want to use as your default tem-
porary files directory, then click OK.

5. Click OK in the Program Settings dialog.
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While designing you have a variety of powerful drawing aids at your fingertips that can help you insert elements
easily and precisely where you want them in your drawing. The Drawing Aids are docked in the Status bar in the
lower right of your screen. Solid Fill, toggles the fill associated to objects on and off. If you want you can display a
drawing grid in your drawing area, as well as set up a snap grid so that your cursor snaps to the grid when you are
inserting elements. The Object Snap feature automatically snaps your pointer to existing objects, and the Angle Snap
snaps your pointer to specified angles. Snap tracking helps you draw objects at specific angles or positions relative
to other objects. The Collision Control feature prevents you from inserting elements where they do not fit. You can
set up drawing aids in your program settings, and toggle them on and off using the buttons on the Status bar.

For very precise control when inserting or editing elements, you can use a tool called the Commander, which lets
you view or enter exact values for distance, direction and angles. It is especially handy for users with some CAD
experience.

Setting Up a Drawing Grid
Personal Architect | Pro Architect | Building Essentials | Construction Suite

A drawing grid is simply a set of horizontal and vertical lines that can help you orient objects to one another. By
default, the spacing between grid lines is 4’, but you can change this if you want. You can also control the color and
style of the grid. Note that the drawing grid is a visual aid only, and will not be included in printouts. By default a
grid is displayed in the drawing area, but you can turn it off if you like.
To set up a drawing grid:
1. Select Settings > Document Settings or click on the Settings toolbar.

2. In the Document Settings dialog, select Drawing Aids in the left column.
3. In the Grid area, check the Enable (F7) check box.
4. Click the Color swatch, then select a color for the grid from the Color dialog.
5. From the Style drop box, select a style for the grid — Dots or Lines.
6. Specify the desired distance between vertical grid lines in the X Spacing edit box.
7. Specify the desired distance between horizontal grid lines in the Y Spacing edit box.
8. By default, the grid is 160’ x 160’, which is the default size of the terrain. To change the overall size of the

grid, enter the desired width in the X Limit edit box, and the desired height in the Y Limit edit box.
9. Click OK.

Turning the Drawing Grid On and Off
You can toggle the drawing grid on and off in one of two ways:
l Press F7 on your keyboard
l Click the GRID button on the Status bar
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Using the Grid Snap
The Grid Snap feature snaps your pointer to an
invisible grid when inserting elements. By default, the
spacing between the grid lines in the invisible grid is
4', but you can change this if you want. If you enable
the Match Grid option, the invisible snap grid
becomes the same size as the drawing grid. This will
make it seem like you are snapping to the drawing
grid while drawing.
To set up a snap grid:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, select
Drawing Aids in the left column.

3. To turn the grid snap on, enable the Grid
Snap (F4) check box.

4. If you want the snap grid to be the same size
as the drawing grid, check the Match Grid
check box in the Grid Snap area.

5. To specify a custom distance between vertical
grid lines, enter a value in the X Spacing edit
box.

6. To specify a custom distance between hori-
zontal grid lines, enter a value in the Y Spa-
cing edit box.

7. Click OK.

Tip: You can toggle the grid snap on and off by
clicking the GRIDSNAP button on the drawing aids
toolbar or pressing F4 on your keyboard.

Turning the Grid Snap On and
Off
You can toggle the grid snap on and off in one of two
ways:
l Press F4 on your keyboard
l Click the GRIDSNAP button on the Status bar

Using Ortho
The Ortho feature restricts your cursor movement to
90-degree angles when you are inserting elements.
This can be especially helpful when drawing elements
like walls.

By default, Ortho is enabled. You can toggle it on and
off using one of three methods.
To turn Ortho on or off:
l Press F8 on your keyboard, or
l Click the ORTHO button on the Status bar, or
l Select Settings > Document Settings, then on
the Drawing Aids pane, check or uncheck the
Ortho (F8) check box

To temporarily disable Ortho while drawing, press
and hold the Shift key. When you release the Shift
key, Ortho mode will resume.

Using Object Snaps in Model
View
When inserting an element, the Object Snap feature
makes your cursor automatically snap to common
points on existing elements in your drawing. This
allows you to select an insertion point or start point
more easily and precisely. When the Object Snap is
turned on, the Endpoint, Midpoint, Nearest and
Perpendicular snaps become active. Your cursor icon
changes when your cursor comes close to a snap
point, providing a visual indicator that snapping is
occurring.

Endpoint. Snaps to the endpoint of an object. 
Midpoint. Snaps to the midpoint of an object.
Nearest. Snaps to a point directly on an object.
Perpendicular. Snaps to a point on an object that
forms a perpendicular from the current point to the
selected object.

You can set the pixel search distance for the object
snap, which determines how close your pointer needs
to be to an element for it to snap to the element.
To turn the Object Snap on or off:
l Press F5 on your keyboard, or
l Click the OBJSNAP button on the Status bar,
or

l Select Settings > Document Settings, then on
the Drawing Aids pane, check or uncheck the
Object Snap (F5) check box in the Snap Beha-
vior area

To set the pixel search distance:
1. Select Settings > Document Settings or click

on the Settings toolbar.
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2. In the Document Settings dialog, select
Drawing Aids in the left column.

3. Below the Object Snap (F5) setting, type the
desired number of pixels in the Pixel Search
Distance edit box, or use the arrows to scroll
up or down through a list of values.

4. Click OK.

Using Angle Snap
When the Angle Snap feature is turned on, your
cursor snaps to specific angles when rotating an
element. If you set your snap angle to 10º, for
example, your cursor will snap at 10º intervals as you
rotate the element.

By default, the Angle Snap is on and is set to 15º.
To turn the Angle Snap on or off:
l Press F6 on your keyboard, or
l Click the ANGLESNAP button on the Status
bar, or

l Select Settings > Document Settings, then on
the Drawing Aids pane, check or uncheck the
Angle Snap (F6) check box

To change the snap angle:
1. Select Settings > Document Settings or click

on the Settings toolbar.

2. In the Document Settings dialog, select
Drawing Aids in the left column.

3. In the Snap Behavior area, type the desired
snap angle in the Snap Angle edit box, or use
the arrows to scroll up or down through a list
of values.

4. Click OK.

Object Snap Tracking
The Snap Tracking feature helps you draw objects at
specific angles or positions relative to other objects.
When snap tracking is turned on, temporary
alignment paths appear that are based on object snap
points, such as endpoints and midpoints. Such points
are marked with a small, solid square when you move
your cursor over their drawing paths. You can acquire
points on up to five elements at one time. Alignment
paths are horizontal and vertical, and can also be
angled if your Angle Snap is turned on. Snap tracking
can be turned on and off as needed. In order for snap

tracking to work, the Object Snap (OBJSNAP) must be
enabled. Snap tracking is available in both Model
View and Worksheet View.

Let's say in the following example that we want the
end of the wall being drawn to be in alignment with
point A. When you hover over point A and then
stretch your wall towards the drawing path of point
A, a horizontal dotted line appears indicating the path
of alignment with point A. This makes it easy to select
an end point for the wall that is aligned with point A.

To turn Snap Tracking on or off:
l Press F3 on your keyboard, or
l Click the SNAPTRACK button on the Status
bar, or

l Select Settings > Document Settings > Draw-
ing Aids, then check or uncheck the Snap
Tracking check box

Collision Control
The program’s intelligent Collision Control feature
prevents objects from being inserted where they do
not fit. By default, Collision Control is on, but you can
turn it off whenever you like using one of three
methods.
To turn Collision Control on or off:
l Press F9 on your keyboard, or
l Click on the Status bar, or
l Select Settings > Document Settings, then on
the Building Aids pane, check or uncheck the
Enable Collision Control (F9) check box

Note: Collision control affects building elements on
the current building location only. It does not affect
landscape elements.
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Using the Commander
The Commander can be a very useful tool when
inserting or editing elements. Using the Commander
you can:
l Specify the insertion height of an element
before it is inserted

l Select a precise insertion point for an element
l Specify a precise length and direction for ele-
ments like walls and railings

l Specify a precise distance and direction when
stretching or moving an element

l Specify a precise angle when rotating an ele-
ment

l Specify a precise radius/included angle when
curving a wall, ceiling, deck or opening

Even if you don’t want to enter precise values, you
can still use the Commander to view measurements
as you draw and edit elements. The values in the
Commander are linked to your cursor movement and
update as you proceed through a command.

The Commander becomes instantly active when
inserting elements. It is most useful for things like
walls and railings, because it lets you enter a precise
length for the element.

The Commander also becomes active when you are
moving, stretching or rotating elements. If you have
started moving, stretching or rotating an element
using your mouse, the Commander displays the move
distance or rotation angle as you move your mouse. If
you want to be able the enter values in the
Commander when moving, stretching or rotating an
element, you need to first select an appropriate
editing tool from the right-click menu or Edit >
Modify Elements menu such as Move, Stretch,
Lengthen, or Rotate.

Turning the Commander On or
Off
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Commander is a multi-functional tool that lets
you enter precise values when inserting or editing
elements. Even if you don’t need a high level of
precision, you may want the Commander displayed

so you can see lengths and angles as you draw or edit
elements.

The Commander is displayed in the lower part of the
screen, just above the Status Bar. Initially the
Commander will look grayed out because it is
inactive. It will become active when you insert or edit
elements.
To turn the Commander on or off:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. Check or uncheck the Commander check
box.

4. Click OK.

Displaying the Coordinate Icon
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Coordinate Icon marks the current point from
which an action will be performed. In other words, it
identifies the current reference point when using the
Commander. By default, this icon is turned off. If you
plan to use the Commander while working, you
should turn on the Coordinate Icon.

To display the Coordinate Icon:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Visual Aids area, check the Show
Coordinate Icon check box.

4. Click OK.

Specifying the Insertion Height
of an Element Before Inserting It
If you have the Commander turned on, it will display
a Base Height edit box as soon as an insertion tool
becomes active.

The value shown in the Base Height edit box is the
height at which the element will insert in your
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drawing. You can change the insertion height before
selecting an insertion point for the element by typing
a value in the Base Height edit box and pressing
TAB. If the element is a building element, the height
is measured from the floor level of the current
building location to the element’s insertion point. If
the element is a landscape element, the distance is
measured from the terrain to the element’s insertion
point. Most elements have their insertion point at the
bottom of the element. Exceptions are windows and
wall openings, in which the insertion point is located
at the top of the element. In the case of windows and
wall openings, the edit box reads “Head Height”.

Selecting a Reference Point
When Inserting and Editing Ele-
ments
To use the Commander, you must first specify a
reference point, or base point, from which values can
be measured. If you are drawing a wall, for example,
the first point you click on the screen is considered
the reference point. The Commander then becomes
active, and you can enter a Distance and Direction (or
X and Y values) for the wall.

If you want to use the Commander to edit an element
(e.g. move or rotate it), you must select a point from
which to measure the move distance/direction, or
rotation angle. Most often you would select one of the
element’s grab handles, which are the small blue
squares that appear on the major points of an element
when you select the element.

Entering Values in the Com-
mander
The Commander is intelligent and changes depending
on the tool you are using. For example, if you are
drawing walls, the Commander’s edit boxes become
Distance and Direction. If you are curving walls,
however, the edit boxes change to Radius and Included
Angle. You can move easily from one edit box to the
next using your Tab key. Pressing Enter after typing a
value completes the current action.

When entering values in the Commander, especially
when inserting or moving elements, it is important to
be aware of the current coordinate system in the
Commander.

The Commander offers two coordinate systems. In the
Polar system, you enter a distance and direction. In
the Cartesian system, you enter X, Y and Z
coordinates.

Note that you can switch between the Polar and
Cartesian coordinate system once you have selected a
reference point to draw from or move from. You do
this by making a selection from the coordinate system
drop box on the left side of the Commander.

Note: If moving, stretching or rotating elements,
and you want to enter values in the Commander,
you need to first select an appropriate editing tool
from the right-click menu or Edit > Modify
Elements menu such as Move, Stretch, Lengthen or
Rotate.

Specifying Distance and Dir-
ection in the Commander
The Polar coordinate system becomes active in the
Commander once you have selected a reference point
to draw from, or start a move from. In the Polar
coordinate system, you specify a distance and
direction (angle) when drawing or moving an
element.

Distance. Enter a positive value to specify the length
of the element, or the move distance.

Direction. Enter the direction you want the element
to run, or the direction in which you want to move an
element. For information about how direction is
specified, see Direction and Angle of Rotation.

Z. This value is only available when inserting
members. Enter the distance you want to move the
member vertically. You can enter a positive or
negative value to move it up or down. The Z value is
measured from the floor level of the current building
location.

Defining X, Y and Z Coordinates
While using the Commander to insert or edit
elements, you may choose to work in the Cartesian
coordinate system instead of the Polar coordinate
system. This lets you specify a precise reference point
to draw or move from by entering X and Y coordinate
values.
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To switch to the Cartesian coordinate system, select
Cartesian from the Commander's left drop box.

X. Enter an X coordinate to specify a horizontal
(left/right) distance in 2D plan view.

Y. Enter a Y coordinate to specify a vertical (up/down)
distance in 2D plan view.

Z. This coordinate is only available when inserting
members. Enter a Z coordinate to indicate elevation,
or height. The Z value is measured from the floor
level of the current building location.

Remember that the coordinates are measured from
the current reference point, which is marked by the
Coordinate Icon if it is enabled.

In the Cartesian system, you can enter both positive
and negative values for any of the coordinates.

Direction and Angle of Rotation
Direction in a drawing is specified in degrees of an
angle. The angle is calculated counterclockwise from
the positive X axis.
The Four Primary Drawing Directions

Although the four primary drawing directions are the
ones you will probably be working with the most, any
angle is possible. If you disable Ortho and Angle
Snap, and move an element randomly in your
drawing area, there is no restriction on angles at all.
Even if Ortho and Angle Snap are enabled, you can
enter any angle you want in the Commander.

Rotating Elements Using the
Commander
When you select the Rotate tool from the right-click
menu or Edit > Modify Elements menu, then select a
base point for the rotation, the Commander displays
an Enter Rotation Angle edit box.

To specify the desired angle of rotation for the
element, type the angle in the Enter Rotation Angle
edit box and press ENTER. For information on how

angles are measured, see Direction and Angle of
Rotation.

Curving Elements Using the
Commander
When curving an element such as a wall or floor
opening, you can use the Commander to specify a
precise curve angle.

Radius. The distance from the element (in its
uncurved state) to the center point of the curve.

Included Angle. The angle formed between two
radius lines extending from the center of the circle
implied by the curve out to the endpoints of the arc.
The larger the angle, the rounder and larger the
curve.

It is not necessary to enter both the Radius and
Included Angle values. If you enter one, the program
automatically supplies the other. Also, if you enter a
value and nothing happens after you press ENTER,
then the value is not valid in relation to the
dimensions of your element.

Measuring Distance in Model
View
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Use the Measure tool to measure the distance between
any two points in your 2D plan.
To use the Measure tool:

1. Select Tools > Measure, or click on the
Tools toolbar.

2. Click your first point on the screen.

3. Move your cursor in the direction you want
to measure. A ruler is displayed that stretches
as you move your cursor.
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4. Click your second point on the screen. The
distance is shown on the ruler as well as on
the Status bar at the bottom of the screen.

5. Once you have measured your first distance,
you can keep selecting points to measure
additional distances from the last point selec-
ted. A running total is displayed on the
Status bar.

6. When you have finished measuring, right-
click and select Finish.

Querying Elements
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Using the Query Element/Location tool you can select
any element in your drawing and instantly view its
name and building location.
To query an element/location:
1. Select Tools > Query Element/Location.
2. With the Query Element/Location cursor

active , click on the element you want to
inquire about. The Query Element/Location
dialog displays the element’s name and
building location.

3. When you are finished viewing the element
and location information, click OK.

Note: For landscaping and terrain elements, which
are associated with the terrain, the Location box
displays Terrain rather than a building location.

Note: The Query Element/Location tool can only be
used on elements that were inserted from the
catalog. You cannot use it on drafting objects.
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Envisioneer offers the standard Open tool for opening saved projects. Save features include Save, Save As, and Save
All.

Each view in your project has its own set of Print Properties. These include settings for the printer selection, paper
size, scaling, and print quality. These settings will automatically appear in the Print dialog when you print the view.
You can print across multiple sheets of paper if needed, and print to a file. The Batch Printing tool lets you process
the printing of multiple views at the same time.

There are a number of different items that you can import into your drawing. Use the Project Trace Image tool to
import a BMP, JPG or TGA file, such as a scanned floor plan, and then trace over it using real 3D elements. The
Photo Board Wizard lets you import digital photographs or scanned images that are then oriented vertically in 3D
view.

Perhaps one of the most versatile tools is the Object Import Wizard, which lets you quickly import custom 3D
objects in DWG, DXF, SKP or 3DS format.

You can export your drawing to different 2D and 3D file formats. To export to a BMP, JPG or TGA file, use the 2D
Image export tool. To export your 2D plan to a DWG or DXF file, use the 2D Drawing export tool. To export your
3D model to a DWG or DXF file, use the 3D Model export tool.

To specify general project information, such as the project name, type and number, fill out the fields in the Project
Manager. This dialog also has a Work History tab where you can keep track of who has done what, and when.

Opening a Saved Project
You can open any saved project using the Open tool.
To open a saved project:

1. Select File > Open, or click on the Standard toolbar.

2. In the Open dialog, navigate to the location where you saved the project.
3. Select the project to open, then click Open.

Tip: If the project you want to open is one that your recently worked on, it may be listed in the recently used file
list near the bottom of the File menu, or in the Projects section on the Startup screen. Just select it to open it. You
can also open a saved project from the Startup screen by selecting Open Existing.

Note: For information about opening projects from older versions of the program, see Opening a Project from an
Older Version on page xxxiii.

Changing the Number of Files on the Recently Used File List
Personal Architect | Pro Architect | Building Essentials | Construction Suite

By default, a maximum of four projects are listed in the recently used file list near the bottom of the File menu. You
can increase or decrease this number if you want.

- 405 -



- 406 -

To change the number of files in the recently used
file list:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, type the maximum num-
ber of files to display in the Recently used
file list edit box, or use the arrows to select a
number. You can list a maximum of 9 files.

Repairing Damaged Projects
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Occasionally a drawing may become damaged,
usually when drawing walls. The Repair Project tool
scans the project for elements that have caused
damage, and either fixes or removes them.
To repair a damaged project:
1. Select File > Repair Project.

If the recovery is successful, a dialog appears
with the message, "Recovery Successful".

If the recovery is not successful, a dialog
appears telling you why it was not successful.

Saving Projects
The program has three save functions: Save, Save As
and Save All. They are located on the File menu.
When saving a new project for the first time, or when
saving a project under a different name, you have the
option of saving it in a format that is compatible with
an older version of Envisioneer.

If you plan to share the project with others, you can
choose to pack any resources that it uses, and include
them in the saved project.

By default, projects are stored in the following
location:

C:\Users\*username*\Documents\Envisioneer\Projects
To save a project:
1. To save the current project for the first time,

or save changes to a project that you have

already saved, select File > Save, or click
on the Standard toolbar. To save the project
under a different name (and create a copy of
it), select File > Save As.

2. If you are saving for the first time, or saving
under a different name, the Save As dialog
appears. Type a name for the file in the File
name edit box.

3. If you want to save the file in a format that is
compatible with an older version of Envi-
sioneer, click the Save as Type drop box and
select the desired version.

4. If you want to pack resources with the saved
project, such as textures and linestyles, enable
the Pack Resources check box. This enables
you to share the project with others who may
not have those resources on their system.

5. Click Save.

To save all currently open projects:

Select File > Save All, or click on the Standard
toolbar.

Sharing Projects
If you would like to share a project with other
Envisioneer users, you can simply send them a copy
of the original .bld file. Note the following
considerations:
l If a user has an older version of Envisioneer,
you can use the Save As tool to save a copy of
the project in an older format. In the Save As
dialog box, the Save as type drop box con-
tains a list of previous version formats.

l If your project uses any custom resources that
may not be available on other users' systems,
such as custom textures or linestyles, use the
Save As tool to save a copy of the project. In
the Save As dialog box, make sure that you
enable the Pack Resources check box.
Although this will result in a larger file size,
you can be assured that others will be able to
properly visualize all aspects of your project.

Setting the Automatic Save
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Auto Save option saves your project for you at
regular intervals. This is a great way to make sure
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you save your changes regularly and avoid any loss
should a power failure or system error occur.
To set the Automatic Save:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, enable the Auto Save
check box.

3. From the Save time (min) drop box, select
the desired save interval in minutes, or use
the arrows to select a value.

4. Click OK.

Note: Disabling the Auto Save applies to the
current project only. It is turned on by default for
all new projects.

Note: If you have not saved your project yet, the
Auto Save will save the project to a temporary
autosave.bld file.

Setting the Number of Backups
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, one backup drawing is created when you
save your drawing. You can choose to save multiple
backups if you want.

Backup files are saved in the same folder as your
project files. The format of the first backup file is
ProjectName_1.bkp. If you choose to save additional
backups, the number increments by one for each
backup file (e.g. ProjectName_2.bkp).

The first backup file is always a copy of the drawing
as it is saved currently. If the number of backups is
set to 2, the second backup drawing is a copy of your
drawing as it was at the previous save. If the number
of backups is set to 3, the third backup drawing is a
copy of your drawing two saves back, and so on.
To set the number of backups:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Number of Backups edit box on the
General pane, type the number of backup files
you would like to save, or use the arrow keys
to increase or decrease the number.

3. Click OK.

Specifying a Default Save Loca-
tion for Projects
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, new (unsaved) projects are saved in the
following folder unless you specify otherwise:

C:\Users\*username*\Documents\Envisioneer\Projects

You can specify a different default save directory if
you want.
To specify the default save location:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, click on the Projects Dir-
ectory in the File Paths area.

3. Click Modify.
4. In the Browse For Folder dialog, select the

directory you want to use as your default
save directory, then click OK.

5. Click OK in the Program Settings dialog.

Saving a Project as a Template
By default you are prompted to select a template
when starting a new project. A template determines
what settings new projects will have. These include
the following:
l Building Location Settings
l Program Settings (unit of measure, drawing
aids, etc.)

l View Window Setup
l Wall Framing Configurations
l Dimension Settings
l Drafting Preferences

You can even include drafting objects and building
elements in a template if you want. For example, if
you use a standard set of drawing borders and title
blocks in all your projects, you can insert them on
your worksheets and save them in your template so
that they are already present when new projects are
started.

You can create a template out of any drawing by
simply saving it in your Templates directory. If you
want to use the same template for every new project,
you can specify this in your startup options.
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To create a template:
1. Unless you have already created the drawing

you want to use as a template, start a new
project (File > New).

2. Specify the settings you want to save with the
template, such as your building locations and
program settings. Note that any elements in
your drawing will be saved as well, so unless
you want these elements to appear in new
projects, you should delete the elements from
your drawing.

3. By default, the last open view is used as the
thumbnail for the template. Template thumb-
nails are displayed in the New dialog that
appears when you start new projects. If you
want to create a thumbnail image of one of
the project's views, make sure that view is
current before saving the project. (Note that
you can attach an image file such as a BMP or
JPG instead.)

4. Select File > Save As.
5. In the Save As dialog, navigate to the

program’s Templates folder. By default, this
is in the following location:

C:\ProgramData\
Cadsoft\Envisioneer\Templates

5. In the File name edit box, type a name for
the template.

6. To create a thumbnail and/or a description of
the template which will be displayed in the
New dialog box when you start new projects,

click .

To create a thumbnail based on the project's
last open view, enable the Use Last Open
View radio button in the Thumbnail Preview
area. To create a thumbnail based on an
image file, enable the Attach Image File
radio button, then click to browse for and
select the desired image. You can attach a
BMP, JPG, PNG or GIF image to the template.

To create a description of the template, type
the desired information in the Notes pane,
pressing CTRL + Enter for each new line of
text. Click OK.

7. When you are ready to save the project as a
template, click Save.

Note: If you do not save a template in the
Templates folder (or the folder that is selected as
the default templates folder in your program
settings), it will not be immediately available in the
New dialog when starting new projects. You will
have to browse for it every time.
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Setting the Path to the Tem-
plates Directory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have moved your Templates directory, or have
chosen to store your templates in a different directory,
you should reset the path to the template directory in
your Program Settings. The path you set determines
which templates are displayed in the New dialog
when you start new projects as well as the default
folder displayed when browsing for templates.

By default, your templates are stored in the following
directory:

C:\ProgramData\Cadsoft\Envisioneer\Templates
To set the path to your templates directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, click on the Templates
Directory in the File Paths area.

3. Click Modify.
4. In the Browse For Folder dialog, select the

directory containing your templates, then
click OK.

5. Click OK in the Program Settings dialog.

Selecting a Directory for Tem-
porary Files
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Certain functions of the program create temporary
files which are stored in a directory on your computer
system. By default, the path to the temporary
directory is as follows:

C:\Users\*username*\AppData\Local\Temp

You can specify a different directory to store your
temporary files in if you want.
To set a different temporary files directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, click on the Temporary
Directory in the File Paths area.

3. Click Modify.

4. In the Browse For Folder dialog, select the
directory you want to use as your default tem-
porary files directory, then click OK.

5. Click OK in the Program Settings dialog.

Closing Projects
Projects remain open until you close them or exit the
program. You can close the active project without
exiting the program. If you have more than one
drawing open, make sure the drawing you want to
close is the active one.
To close a drawing:

1. Select File > Close, or click on the Stand-
ard toolbar.

2. In the dialog, click Yes or No when you are
asked to save changes.

3. If you haven’t named the project yet and you
clicked Yes in the previous step, specify a
name for the project in the Save As dialog,
then click Save.

Defining a View's Print Prop-
erties
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Each view window in your project, whether it be a
Model View or Worksheet View window, has its own
set of print properties. These properties include the
printer/plotter selection, paper size, print area, page
setup, print scaling, print quality, and line weight
printing.
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Having view-specific print properties lets you define
and save unique print properties for each view, and
therefore eliminates the need to specify print settings
every time you want to print a view. It also makes it
possible to perform batch printing, where a number of
different views (with different print settings) can be
printed at once.

You can access a view's print properties using the
View Properties tool, or through the View Manager.
To define a view's print properties:
1. Right-click in the view window and select

View Properties, or select View > View Prop-
erties. Or, select View > View Manager and
select the view window whose properties you
want to define.

2. Select the Print Properties tab.
3. Define the view's print properties. The

properties are described below.
Printer/Plotter

Name. Click this drop box to select the
printer or plotter to use when printing this
view.

Click to define various
properties for the currently selected printer
such as paper and output settings, and print
quality.

Paper Size. Click this drop box to select the
size of paper you want to print on.

Orientation. Choose either Portrait or
Landscape. The Portrait option gives the
paper a vertical orientation, while the
Landscape option gives it a horizontal
orientation.

Print to file. If enabled, the view is printed to
a print file, such as a Postscript file, rather
than a printer.

Copies. The number of copies you want to
print.
Print Area

All (Extents). Prints the entire view, even if
part of it is currently not visible.

Window. Prints a selected area of your
drawing. To select the area, click the Window
button. Note that this option is not available
for 3D perspective views.

Display. Prints exactly what you see on the
screen in the current view. If only part of
your drawing is currently visible, only that
part will appear in the printout.

Click to temporarily access
your drawing area and draw a selection
window around the area you want to print.
This button is only available if the Window
print area option is selected.
Page Setup

Placement. The Lower Left option prints the
image in the lower left corner of the paper.
The Center on Paper option centers the
image on the paper.

Print all colors as black. (Worksheet View
only) If enabled, this will produce a black-
and-white printout.
Print Scaling
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Fit to Page. Scales the drawing to fit the
selected paper size. Note that this is the
default setting for 3D views, since 3D views
are not affected by changes in scale.

Print to Scale. Prints the current view
according to the Scale set below, regardless
of the paper size. This option does not work
with 3D views, since 3D views cannot be
scaled.

View Scale. The drawing scale of the current
view as set on the View Properties page in
the view's properties. This is the ratio of units
on paper to real-world units. For example, if
the view scale is 1/4" = 1'-0" (or 1:48), this
means that every 1'-0" of your actual model is
represented by 1/4" on paper. If you are using
the Print to Scale option, this gives you a
sense of how you are scaling the drawing.
For example, if your view scale is set to 1/4" =
1'-0" and you set the print scale to 1/2" = 1'-0",
you know that you are scaling the drawing
up in the printout. The drawing would be
larger when printed at the 1/2"= 1'-0" scale
than it would at the 1/4" = 1'-0" because every
1'-0" of the model is being represented by 1/2"
on paper instead of only 1/4" on paper.

Print Scale. Click the drop box to select a
print scale for the view (if using the Print to
Scale option). When you change the print
scale, things like text and dimensions will be
scaled in such a way that they are
proportional to the rest of the drawing.

Note that if you change the print scale, your
2D plan does not scale on the screen. It will
only be scaled on paper when you print the
drawing. Changing the print scale has no
effect in 3D views, neither on the screen nor
in printouts, unless it is an elevation view.
This is because a model being viewed in 3D
does not have concrete measurements like a
flat, 2D view has.
Line Work

Print Line Weights. Prints the lines in your
drawing using the weight (thickness)
assigned to them in element properties.

Otherwise, all lines print with the same
thickness.
Preview

Show View Contents. Disabling this check
box turns off the view inside the preview
window. You may want to take advantage of
this feature if you are having issues with your
graphics display (if graphics are slow to load
or refresh, for example). Your choice will also
be applied in the Print dialog and Batch
Printing dialog.

Printing Drawings
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The program uses the standard Windows Print routine
with a few added features, such as a print preview,
print area selection, scaling options, and paper
placement. When you open the Print dialog, the print
settings in the dialog reflect the print settings defined
for the current view window.
To print a drawing:

1. Select File > Print, or click on the Stand-
ard toolbar.

2. In the Print dialog, specify your print
settings.
Printer/Plotter

Name. Click this drop box to select a printer
or plotter to use when printing this view.

Click to define various
properties for the currently selected printer
such as paper and output settings, and print
quality.

Paper Size. Click this drop box to select the
size of paper you want to print on. Note that
if you are printing to scale, and the scale of
the drawing is too large for the selected paper
size, the drawing will be automatically tiled
across multiple sheets of paper. 

Orientation. Choose either Portrait or
Landscape. The Portrait option gives the
paper a vertical orientation, while the
Landscape option gives it a horizontal
orientation.
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Print to file. If enabled, the project is printed
to a print file rather than a printer.

Copies. Select the number of copies to print.
Print Area

Print Area -All (Extents). Prints the extents
of your drawing, which is the portion of your
drawing that currently contains elements. As
you add new elements, the extents update
automatically.

Print Area - Display. Prints exactly what you
see on the screen in the current view. If only
part of your drawing is currently visible, only
that part will appear in the printout.

Print Area - Window. Prints a specific area of
your drawing that you define by drawing a
bounding window around it. Click the
Window button, then click two points in your
drawing to define the selection window. You
can snap the window to elements in your
drawing if desired. The preview in the Print
dialog will update automatically. Note that
the Window option is not available for 3D
perspective views.
Page Setup

Placement. If you select Lower left, the
image is printed in the lower left corner of
the paper. If you select Center on paper, the
image is centered on the paper.

Print all colors as black. (Worksheet View
only) If enabled, this will produce a black-
and-white printout.
Print Scaling

Fit to Page. Scales the drawing to fit the
selected paper size. Note that this is the
default setting for 3D views, since 3D views
are not affected by changes in scale (unless
they are elevation views).

Print to Scale. Prints the current view
according to the Scale set below, regardless
of the paper size. This option does not work
with 3D views, since 3D views cannot be
scaled.

View Scale. The drawing scale of the current
view as set on the View Properties page in
the view's properties. This is the ratio of units

on paper to real-world units. For example, if
the view scale is 1/4" = 1'-0" (or 1:48), this
means that every 1'-0" of your actual model is
represented by 1/4" on paper. If you are using
the Print to Scale option, this gives you a
sense of how you are scaling the drawing.
For example, if your view scale is set to 1/4" =
1'-0" and you set the print scale to 1/2" = 1'-0",
you know that you are scaling the drawing
up in the printout. The drawing would be
larger when printed at the 1/2"= 1'-0" scale
than it would at the 1/4" = 1'-0" because every
1'-0" of the model is being represented by 1/2"
on paper instead of only 1/4" on paper.

Print Scale. Click the drop box to select a
print scale for the view (if using the Print to
Scale option). When you change the print
scale, things like text and dimensions will be
scaled in such a way that they are
proportional to the rest of the drawing.

Note that if you change the print scale, your
2D plan does not scale on the screen. It will
only be scaled on paper when you print the
drawing. Changing the print scale has no
effect in 3D views, neither on the screen nor
in printouts. This is because a model being
viewed in 3D does not have concrete
measurements like a flat, 2D view has.

When you change the print scale, things like
text and dimensions will be scaled in such a
way that they are proportional to the rest of
the drawing.
Line Work

Print Line Weights. Prints the lines in your
drawing using the weight (thickness)
assigned to them in element properties.
Otherwise, all lines print with the same
thickness.
Preview

The preview window on the right displays a
preview of how the drawing will fit on the
paper. If the drawing is too large for the
selected paper size, it will be automatically
tiled across multiple sheets of paper.
Separation marks will then appear in the
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preview indicating where the drawing will be
divided.

Show View Contents. Disabling this check
box turns off the view inside the preview
window. You may want to take advantage of
this feature if you are having issues with your
graphics display (if graphics are slow to load
or refresh, for example). Your choice will also
be applied in the Batch Printing dialog and
View Properties dialog.

3. Click OK.

Note: If you click Apply in the Print dialog, the
dialog's print settings will be applied to the view's
Print Properties.

Printing Across Multiple Sheets
of Paper
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You may want to print out your drawing at a large
scale, but do not have a piece of paper big enough to
fit it. In this case you can print the drawing in
sections onto smaller sheets of paper, then attach the
sheets together after printing. You can specify paper
and print scale settings in the Print dialog, or in a
view's print properties.
To set print settings in the Print dialog:

1. Select File > Print, or click on the Stand-
ard toolbar.

2. In the Print dialog, click Properties to select
the paper size to use.

3. From the Print Scaling drop box, select Print
to Scale.
The print preview displays separation marks
representing the individual sheets of paper. You
can adjust the print scale if you want.

4. Click OK. The drawing is printed onto mul-
tiple sheets of paper.

To set print settings for a specific view:
1. If the view is current, right-click in the draw-

ing area and select View Properties. Other-
wise, select View > View Manager, or click

on the View Control toolbar. In the left

pane of the View Manager dialog, select the
view whose print properties you would like
to define.

2. Select the Print Properties tab.
3. From the Paper Size drop box, select the

paper size that you want to use.

4. In the Print Scaling area, select Print to Scale
from the drop box. You can adjust the print
scale if you want.

5. Click OK. You can proceed with printing the
view.

Printing to a File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

When you print to a file, you need to first determine
which printer — for example, a PostScript printer —
will ultimately print the file. This way you can specify
an appropriate file type to print to (e.g. *.ps).

A print file allows others to print your Envisioneer
drawing, even if Envisioneer is not installed on their
computer. All they need is a printer that prints the
specified file type.
To print to a file:

1. Select File > Print, or click on the Stand-
ard toolbar.

2. In the Print dialog, enable the Print to file
check box.

3. Click Print.
4. In the Save As dialog, navigate to the folder

where you want to save the print file.

5. In the File name edit box, type a name and
extension for the print file (e.g. Project1.ps).

6. Click Save. The project is written to the print
file.

Creating a PDF File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

To create a PDF file of a view you need to have a PDF
writer installed on your computer. This is like a
special print driver or utility that has the capability of
producing PDF files. When a PDF writer is installed

Editing_the_Print_Scale_of_a_View.htm
Editing_the_Print_Scale_of_a_View.htm
Editing_the_Print_Scale_of_a_View.htm
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on your system it will appear in the list of printers in
the Print dialog, just like any other printer.

Some PDF writers are free and can be downloaded
from the Internet, and some can be purchased from
companies such as Adobe. Check out the following
web sites, or do a search on the Internet:
www.adobe.com, www.cutepdf.com, or
www.pdf995.com.
To create a PDF File:
1. Display the view that you would like to print.

2. Select File > Print, or click on the Stand-
ard toolbar.

3. In the Print dialog, select the PDF print
driver in the list of available printers.

4. Make sure the Print to File option is
disabled.

5. Once you have defined your print settings,
click Print.

6. In Save PDF File As dialog, select a save loc-
ation for the PDF file, then type a name for
the file in the File name edit box.

7. Click Save. The PDF file is created in the spe-
cified location.

Batch Printing
Pro Architect | Building Essentials | Construction Suite

Batch printing refers to the process of printing
multiple views or worksheets at the same time. When
using the Batch Printing tool, all you need to do is
select the views that you want to print, define the
print settings that you want to use for each view, then
click Print.
To batch print:
1. Select File > Batch Printing.

2. In the Batch Printing dialog, enable the
views that you want to print by clicking the
check boxes beside the view names. To make
all views printable, select Views > Make All
Printable, or right-click in the left pane and
select Make All Printable. To make all views
non-printable, select Views > Make All Non-
Printable, or right-click in the left pane and
select Make All Non-Printable.
Views in the Batch Printing dialog are
organized in the same way that they are
organized in the View Manager. You can
expand a group by clicking its plus sign (+),
or collapse a group by clicking its minus sign
(-). To expand or collapse all groups you can
use the Expand All or Collapse All options
on the Arrange menu (or right-click menu).

3. Views print in the order in which they appear
in the left pane. To change the print order of
views use the Move Up or Move Down tools
on the Arrange menu (or right-click menu).

4. To set a view as current in the drawing area,
select the view in the list, and then select
Views > Set Current.

5. To define a view's print properties, such as
the printer/plotter selection, paper size and
print scale, select the view in the list, and
then select the Print Properties tab in the
right pane. For more information about these
settings, see Defining a View's Print Properties
on page 409.

6. Click Print. Batch printing begins.

Vector Printing vs. Raster Print-
ing
Vector graphics use geometrical primitives such as
points, lines, curves and polygons to represent objects
on your screen. By default, the Print tool in
Envisioneer uses vector printing when printing from
Worksheet View. This means that only actual objects
will be included in the output. Non-objects, such as
the background color, will not be printed. Because
vector printing is vector-based and resolution-
independent, your output will be sharp and high-
quality regardless of any scaling you do.

http://www.adobe.com/
http://www.cutepdf.com/
http://www.pdf995.com/
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If you disable vector printing in your program
settings, raster printing will be used instead. Raster
images (also known as bitmap images) represent
objects as an array of pixels, as in a photograph.
Pixels are tiny dots of individual color that make up
what you see on your screen. The size and quality of
a raster image depend on the resolution selected.
Resolution refers to the number of pixels in an image,
and is measured in terms of DPI (Dots Per Inch).
Often, scaling a raster image to a larger size has a
negative impact on the image quality. The software
has to create pixels and estimate the color values of
these pixels. Also, the blending of pixels where one
object meets another can often result in blurriness.
This does not occur in vector printing since vector
images are not pixel-based.

When raster printing is used, everything you see in
the view window is included in the output, including
the background color. When printing a raster image,
the printer requires more image data than your
monitor. This is one of the reasons that raster printing
results in a larger file size than vector printing.

Disabling Vector Printing in
Worksheet View
Construction Suite only

By default, the Print tool uses the vector printing
method in Worksheet View. This is a superior form of
printing that results in sharp, high-quality images. If
for some reason vector printing is problematic for
you, you can disable vector printing and revert to
raster printing instead.
To disable vector printing:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Worksheet View Behavior area, disable
the Enable Vector Printing check box.

4. Click OK.

Importing an Image to Trace
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can import a BMP, JPG or TGA image, such as a
floor plan that you have scanned or sketched out in a
drawing program, and trace it using elements from
the catalog, creating a true Envisioneer model.
To import an image to trace:
1. In 2D plan view, select File > Import > Pro-

ject Trace Image.
2. In the Open dialog, select the file type you

are importing from the File type drop box.
You can import BMP, JPG or TGA files.

3. Locate the file to import, then click Open.
The image is displayed in the Import dialog.
You can zoom and pan in the preview pane
using the zoom/pan controls below the pane.
Note that changing the zoom level inside the
preview pane has no effect on the image
when it is imported.

4. Before importing the image you will need to
define the size or scale of the imported image.

If you are importing a floor plan and you
know the scale at which it was drawn
originally, you can enter that value in the
Scale edit boxes. For example, if the plan
was drawn at a 1/4" = 1'-0" (1:48) scale, you
would enter 48 in the Scale (X) or Scale (Y)
edit box. There are separate X and Y
(horizontal and vertical) scale settings. By
default, whatever you enter in one edit box
will automatically be displayed in the other
edit box, maintaining the same scale in both
directions. If you want the X scale to be
different than the Y scale, you need to click
the lock icon beside the Scale (X) and Scale
(Y) edit boxes. With the lock 'unlocked' you
can enter a different value in each edit box.
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Another way of specifying the scale is to
draw a reference line along an existing object
in the CAD image and specify the length of
that object in real-world units. To do this,
click the Pick Scale button next to the
Scale (X)or Scale (Y) edit box, then pick two
points along an object in the image to define
a reference line. (If the X scale and Y scale
will differ, you should pick points along a
horizontal object for the X scale, and pick
points along a vertical object for the Y scale.)
Then in the Scale by Reference dialog, enter
the length of the reference line and click OK.
For example, if you know that a particular
wall in your plan is 12' long, draw a line
along that wall and then enter 12' in the
Scale by Reference dialog.

The Scale values in the Import dialog will
then adjust to reflect the scale you defined.

5. To specify the angle of the imported image,
enter a value in the Angle edit box, or click

the Pick Angle button next to the Angle
edit box and pick two points along an object
in the image to define the angle. If you are
picking points to define the angle, the Angle
by Reference dialog appears and reports the
angle that you defined. You can edit the
angle here if you want.

6. If you want to import only a portion of the

image, click next to the Crop Box
item, then click two points diagonally in the
preview window to define a box around the
portion that you want to import. A blue box
is displayed around the selected portion. To

remove the crop box, click , then
click OK to confirm that you want to clear the
crop box.

7. To dim the imported image, slide the Dim-
ming slider to the desired dim level. The
higher the percentage, the more dim the
image will be.

8. If you want the Import dialog to appear again
after you insert the image so that you can
insert another image, enable the Multiple
Insert check box.

9. To import the image into the current view
window, click Insert. The image is attached
to your cursor.

10. Position the image where you want it, then
click to insert it. You can now trace the
image.

Note: Most floor plans are copyrighted, so make
sure you have permission to copy them.

Resizing a Project Trace Image
If you import a project trace image and it is not the
right size, you can scale it up or down to match the
plan’s drawing scale. Having a correct drawing scale
is important for tracing purposes so elements can be
created at the correct size.
To resize a project trace image:
1. Select the trace image.

2. Right-click and select Resize, or select Edit >
Modify Elements > Resize.

3. Find a wall with a known length, then select
a point at each end of the wall to create a
reference line. The length of the reference line
is displayed in real-world units in the Resize
Block dialog.

4. In the Resize Block dialog, enter the new
length that you want the reference line to rep-
resent. Entering a greater value will make the
image bigger, and entering a lesser value will
make the image smaller.

5. If you want the image to be scaled in both dir-
ections, enable the Maintain Aspect Ratio
radio button.
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6. If you want the image to be scaled in only
one direction, enable either the Horizontal
Only or Vertical Only radio button.

7. Click OK. The image is resized.

Tracing the Imported Floor Plan
Tracing an imported image is easy — just use the
tools on the Insert menu. Below are links to topics
that may help you:
l Drawing Walls on page 55
l Inserting Doors...page 83
l Inserting Windows...page 87
l Inserting Wall Openings...page 91
l Inserting Stairs and Ramps...page 109
l Inserting Cabinets...page 137
l Inserting Appliances...page 140

Displaying/Hiding Project Trace
Images
If you have used the Project Trace Image tool to
import a plan into your project, you can hide the
image if you want using the View Filter. This is an
alternative to deleting the image.
To filter project trace images from view:
1. Select View > View Filters > View Filter, or

click on the View Control toolbar.

2. In the View Filter dialog, select the Notation
tab.

3. In the Project Trace Images row, click the
eye icon in the Display column to turn project
trace images on or off.

Project trace image is turned on 

Project trace image is turned off

4. Click OK.

Deleting a Project Trace Image
Once you’re done tracing a floor plan, you can delete
the trace image from your drawing, leaving just your
Envisioneer model on the screen.
To delete a project trace image:
1. Select the trace image.

2. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.

Note: If you prefer you can just hide the project
trace image from view instead of deleting it.

Importing a Photo Board
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A photo board is simply a digital image that is
oriented vertically in your 3D workspace. You can
import any image you want — your family, pets,
neighbor’s house — the only limit is your
imagination. The handy Photo Board Wizard does it
all in a few quick steps.
To import a photo board:
1. Select File > Import > Photo Board Wizard.

2. Click Next.



- 418 -

3. Type a name for your photo board.

4. Click the Select button, then select the image
you want to import. You can import BMP,
JPG and TGA files. The image is displayed in
the preview window.

5. Define the size of the image by entering val-
ues in the Height and Width edit boxes.

6. Click Next.

7. Specify whether you want the photo board to
be stationary or active. If Stationary is selec-
ted, the board will always remain oriented
the same way, regardless of changes in your
camera angle. If Billboard is selected, the

photo board will rotate toward the camera so
it will always face you in 3D.

8. Click Next.

9. Click Finish. The photo board is attached to
your cursor, ready to be inserted.

10. Position the photo board where you want it,
then click to insert it.

11. Right-click and select Finish.

Saving Imported Photo Boards
to the Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can save a photo board that you have imported
using the Photo Board Wizard to your catalog so you
can insert it again in any project.
To save your photo board to the current catalog:
1. Select File > Catalogs > Save Element to

Catalog. Your pointer changes to a catalog
cursor.

2. Click on the photo board in your drawing.

3. Click Yes to save the photo board. The photo
board is added to the current catalog.

Inserting a Photo Board from
the Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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The catalog contains a collection of photo boards
containing pictures of people, animals, flags, and
other objects. If you have saved your imported photo
board to the catalog, it is also displayed with the
existing photo boards in the catalog.
To insert a photo board from the catalog:
1. Select Insert > Photo Board.
2. In the catalog panel, select the photo board

you want to insert.

3. Position the photo board where you want it,
then click to insert it.

4. Right-click and select Finish.

Moving a Photo Board
You can move a photo board easily by just clicking
and dragging it.
To move a photo board:
1. Select the photo board.

2. Hover your pointer over the board to display
the Move cursor.

3. Click and drag to move the board.

4. When the board is where you want it, release
your mouse button.

Rotating a Photo Board in 2D
You can use the Rotate tool to rotate a photo board
about a selected point in 2D plan view.
To rotate a photo board:
1. Select the photo board.

2. Right-click and select Rotate, or select Edit >
Modify Elements > Rotate.

3. Hover your pointer over the point you want
to rotate the photo board around.

4. Click and drag to rotate the photo board,
then release your mouse button.

Changing the Elevation of a
Photo Board
You can raise or lower a photo board using the
Elevate tool on the right-click menu.
To raise or lower a photo board:
1. Select the photo board.

2. Right-click and select Elevate, or select Edit >
Modify Elements > Elevate. The value in the

Elevate dialog is the current elevation of the
photo board.

3. In the Elevate dialog, specify the desired elev-
ation of the photo board above the terrain.

4. Click OK.

Tip: You can also change a photo board’s elevation
by changing the Distance above current location
or terrain variable on the photo board’s Behavior
property page.

Changing a Photo Board from
Stationary to Rotating and Vice
Versa
You can choose whether a photo board is stationary
or rotating after it has been inserted. A stationary
board keeps the same orientation regardless of
changes in the camera angle. A rotating board always
rotates towards the camera.
To change a photo board’s type:
1. Select the photo board.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Type area, click Stationary for a sta-
tionary photo board, or Billboard for a rotat-
ing photo board.

4. Click OK.

Editing the Size of a Photo
Board
You can edit the height and width of a photo board
after it has been inserted.
To edit the size of a photo board:
1. Select the photo board.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. Edit the Height or Width in the Properties
area. If Maintain Aspect Ratio is checked,
the height will automatically change if you
edit the width, and vice versa. This ensures
the image doesn’t get distorted.

4. Click OK.
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Deleting a Photo Board
You can delete a photo board in a couple of easy
steps.
To delete a photo board:
1. Select the photo board.

2. Press the Delete key on your keyboard, or
right-click and select Delete, or select Edit >
Modify Elements > Delete.

Creating Transparency in Photo
Board Images
You may find that you want to make portions of your
photo board image transparent for a more realistic
effect. If the image is of a person, for example, you
may want to make the background in the image
transparent so that when you insert the photo board
in your drawing, you see just the person in your 3D
view.

To create transparency in your photo board image,
you need to use a graphic editing program such as
Microsoft® Paint to apply a magenta color to those
portions you want to make transparent.

The RGB color settings for magenta are as follows:

Red: 255
Green: 0
Blue: 255
Once you have finished editing the image in the
graphic editing program, you can re-import the image
into Envisioneer using the Photo Board Wizard.

Importing Custom Objects into
Your Drawing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have any custom 3D objects in DWG, DXF, SKP
(Google™ SketchUp), 3DS. OBJ, or IFC format, you
can import them into your Envisioneer drawing.
Many sites on the Internet offer free downloading of
objects for your convenience. Typically, these are
objects such as furniture and appliances.

You can import a custom object directly into your
drawing using the Object Import Wizard. Once
inserted, you can edit its properties just as you would
edit any element in your drawing.

To import a custom object into your drawing:
1. Select File > Import > Object Wizard.
2. In the first edit box, type a name for the ele-

ment.

3. From the element drop box, select the type of
element you are importing.

4. If you selected Exterior Furniture, Exterior
Accessories or Exterior Lighting, you have
the option of inserting the element on the
floor of the current building location, or the
terrain. Select either the Insert on location or
Insert on terrain radio button. (All other ele-
ment types have one of the options pre-selec-
ted for you, with the other option disabled.)

5. Click the Select button.
6. In the Open dialog, locate and select the file

that you want to import, then click Open.
You can import DWG, DXF, SKP, OBJ, 3DS
and IFC files.

Note: If the imported file is larger than 4MB it is
considred a very large block (VLB) and a dialog box
will appear, noting that VLB files will be optimized
due to their potential size. The VLB import will have
additional steps regarding plan and elevation views.
Click OK to accept the message.
7. Specify how you want the components cre-

ated by making a selection from the next
drop box. For DWG and DXF files you can
choose from Colors or Layers. Since 3DS and
IFC objects are essentially an assembly of
materials, the only selection for 3DS and
IFC objects is Materials. (This step does not
apply to SketchUp files.)

8. Click Next.
9. On the Orient your element screen, use the

arrows to rotate the model so that it will be
oriented correctly when inserted in a draw-
ing.

10. Click Next.
11. If the object is a door or window, the Pos-

ition the insertion point of your element
screen will appear. Specify where along the
object's height (Z Axis) you would like to pos-
ition the object's insertion point. Use the
slider to move the insertion point up or
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down. To offset the door/window frame from
the wall surface, enter an offset value in the
Frame Offset edit box.

12. Click Next.
13. For some file types, the program needs to

know what units were used to create the
object originally so that it can be converted
into an appropriate size.

If you know what units were used to create
the object, select the units from the units drop
box. Otherwise, select the unit of measure
that will result in a logical Resultant Width,
Resultant Depth and Resultant Height.
Selecting Custom lets you specify a custom
scale in the Custom Scale edit box.
The scale is the multiplication factor of the
units used for objects in the block. For
example, if you're converting a file that you
assume was created in feet and inches, the
scale is 25.4.

14. Click Next.
NOTE: Block files that are over 4MB are considered
very large blocks (VLBs) and will be treated
differently in the following next steps. Just one dialog
box appears. That dialog allows you to accept the
plan view and elevation view that was generated
upon import or import a separate view by checking
"Replace with Custom" and then clicking Select to
find a plan view or an elevation view. Please note that
if "Replace with custom" is used the imported
elevation must have a closed polyline around the
elevation or an error message will appear "No valid
geometry". A valid outline is a polyline - the import
will disregard lines.

15. The next screen lists the object’s individual
components. Specify which components you
want to display or hide in 3D by clicking the
appropriate eye icons.

Component is displayed 

Component is not displayed

Enabling the Show only selected
component check box displays only the
currently selected component in the object
preview. This helps you distinguish between
the object's individual components.

To rename a component, double-click it, then
type the new name and press Enter.

13. Click Next.
14. The next screen lists the object's components

again, but this time you can specify which
components you want to display or hide in
2D plan view.

To create a custom plan view, select either
Outline or Slice below the preview window
to specify how the plan view is to be created.
To create a simple outline based on the
footprint of the object, select Outline. To
create a slice through the object, select Slice,
and then use the slider control next to the
preview window to specify the position of
the slice.

To control the visibility of components within
the custom plan view, click next to the
drop box, then specify which components
you want to hide or show in the Display
Components to Generate Plan View dialog.
Once the plan view has the desired
appearance in the preview window, click
to add the view to the list of components.
You can delete custom plan views from the
list if desired, but you cannot delete
components of the original object.

15. Click Next.
16. Click Finish.
17. Click to insert the new element in your draw-

ing.

18. Right-click and select Finish.

Tip: You can save the imported element in your
catalog using the Save Element to Catalog tool.

Importing Catalog Content from
a BIM File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Any catalog content that has been exported to a BIM
file can be imported into another catalog using the
Import BIM to Catalog tool.
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To import catalog content from a BIM file:
1. Make sure that the catalog into which you

want to import content is the current catalog.

2. Select File > Import > BIM to Catalog. You
can also launch this feature from the Element
Manager or Library Manager by selecting File
> BIM File > Import.

3. In the Open dialog, select the BIM file from
which you want to import items, then click
Open.

4. In the right pane of the Import Items from
BIM File dialog, select the group or item that
you want to transfer into the current catalog.

5. Click Transfer.
6. When you are finished transferring items into

your catalog, click OK.

Importing Project Content from
a BIM File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have exported project-specific content such as
layer definitions to a Building Information Modeling
(BIM) file, you can import the custom content
contained in that BIM file into another project.
To import project content from a BIM file:

1. Select File > Import > BIM to Project.
2. In the Open dialog, select the BIM file from

which you want to import items, then click
Open.

3. In the right pane of the Import Items from
BIM File dialog, select the folder or item that
you want to transfer into the current project.

4. Click Transfer.
5. When you are finished transferring items into

your project, click OK.

Importing an IFC File
Pro Architect | Building Essentials | Construction Suite

When you import an IFC file, Envisioneer intelligently
interprets the building and construction data and
transforms it into a true 3D model comprising actual
wall, door and window elements.

To import an IFC file:

1. Select File > Import > Import IFC File.
2. In the warning dialog, note that importing an

IFC will delete all existing building elements
in the current project. When you are ready to
proceed, click Yes.

3. In the Component Options dialog, specify
how you would like colors and linetypes to
be displayed. If By Layer is selected, the res-
ulting image will use the colors and linetypes
assigned to the layers of the CAD drawing. If
By Color is selected, it will use the colors and
linetypes of individual entities in the CAD
drawing.

4. Click OK.
5. In the Open dialog, select the desired IFC file,

then click Open. The model is imported.

Exporting the Current View to a
2D Image File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The 2D Image export tool lets you save the current
view to a BMP, JPG or TGA file, which can be opened
in most graphic editing applications.
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To export a view:
1. Select File > Export > 2D Image.
2. In the Save As dialog, click on the Save as

type drop box and select the file format you
want to export to.

3. Locate the directory where you want to save
the exported file.

4. In the File name edit box, type a file name.
5. Click Save. The Export View dialog appears.

6. From the Color drop box, select the desired
color setting. Choose from Grayscale, 256
Color, High Color (16-bit), High Color (24-bit) or
True Color (32-bit).

7. From the Size drop box, select the desired
output size. By default, Current View is selec-
ted, which saves the image at the size cur-
rently shown on the screen. You can choose
from a list of preset sizes, or select Custom
and enter the desired values in the Width and
Height edit boxes.

8. Click Save. The view is exported.

Note: This tool is only available in Model View
windows.

Exporting the 2D Drawing to a
2D AutoCAD File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The 2D Drawing export tool saves your 2D plan or 2D
worksheet in a 2D, vector drawing format that can be
opened in AutoCAD or any application that accepts
DWG and DXF files.
To export your 2D drawing:

1. Select File > Export > 2D Drawing.
2. Select the directory where you want to save

the exported file.

3. In the File name edit box, type a file name.
4. Click Save. A dialog appears confirming the

model has been exported successfully.

5. Click OK.

Note: If you are exporting to the DWG or DXF file
format, the layers assigned to elements in your
model will be replicated in AutoCAD, providing a
seamless transition between the two applications.

Exporting the 3D Model
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The 3D Model export tool lets you save your 3D
model to the following formats:
l AutoCAD Drawing (*.dwg)
l AutoCAD DXF (*.dxf)
l Autodesk 3D Studio (*.3ds)
l SketchUp (*.skp)
l VRML (*.wrl)
l Art*lantis (*.opt)
l Lightscape (*.lp)
l IFC File (*.ifc)
l FBX File (*.fbx)
l OBJ File (*.obj)

When you open the file in its associated application,
you will see an actual 3D model in that application.
To export your 3D model:
1. Select File > Export > 3D Model.
2. In the Save As dialog, click on the Save as

type drop box and select the file format you
want to export to.

3. Click Browse Folders and select the dir-
ectory where you want to save the exported
file.

4. In the File name edit box, type a file name.
5. Click Save. A dialog appears confirming the

model has been exported successfully.

6. Click OK.
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Note: If you are exporting to the DWG, DXF or
SKP file format, the layers assigned to elements in
your model will be replicated in AutoCAD or
Sketchup, providing a seamless transition between
the two applications.

Exporting to Weyerhaeuser
Javelin®
Construction Suite only

Javelin software allows Weyerhaeuser dealers to
specify optimized combinations of residential
engineered wood products and dimension lumber in
floor, wall and roof layouts. You can export your 3D
Envisioneer model to a Javelin XML file and then
open the file in Javelin.
To export to Javelin:
1. Select File > Export > Weyerhaeuser Javelin

.BIMXML.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.

Exporting to CSD iStruct™
Construction Suite only

You can export your 3D Envisioneer model to an
XML file and then open the file in CSD iStruct™.
To export to CSD iStruct:
1. Select File > Export > CSD iStruct .BIMXML.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.

Exporting to MiTek® SAPPHIRE
Structure™
Construction Suite only

Based on its legacy TrussFramer application, MiTek's
SAPPHIRE Structure™ application provides powerful
structural modeling, editing, and estimating
functionality. You can export your 3D Envisioneer
model to an MXF file that can be opened in
SAPPHIRE Structure™.
To export to MiTek SAPPHIRE Structure™:

1. Select File > Export > MiTek SAPPHIRE
Structure™ .MXF.

2. In the Save As dialog, specify a save location
and filename for the file.

3. Click Save.

Exporting to Boise BC Framer®
Construction Suite only

Boise BC Framer® is software that helps users create
floor and roof framing layouts. You can export your
3D Envisioneer model to an MXF file that can be
opened in BC Framer.
To export to Boise BC Framer:
1. Select File > Export > Boise BC Framer®

.MXF.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.

Exporting to Keymark® GS Soft-
ware Suite
Construction Suite only

Keymark® GS Software Suite is a suite of building
design and engineering software for light gauge steel.
You can export your 3D Envisioneer model to a LAY
file and then open the file in GS Software Suite.
To export to Keymark GS Software Suite:
1. Select File > Export > Keymark GS Software

Suite .LAY.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.
4. In the Floor Location Associations dialog,

match the building locations in your 3DEnvi-
sioneer model to floor names in GS Software
Suite, then click OK.

Exporting to Simpson Com-
ponent Solutions®
Construction Suite only

You can export your 3D Envisioneer model to a LAY
file and then open the file in Simpson Strong-Tie®
Component Solutions® software.
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To export to Simpson Component Solutions:
1. Select File > Export > Simpson Component

Solutions .LAY.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.
4. In the Floor Location Associations dialog,

match the building locations in your 3DEnvi-
sioneer model to floor names in Component
Solutions, then click OK.

Exporting to 20-20 Design
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

20-20 Design is 3D interior design software that allow
designers, remodelers, and builders to communicate
with the kitchen and bath design industry. You can
export your 3D Envisioneer model to a 2020XML file
and then open the file in 20-20 Design.
To export to 20-20 Design:
1. Select File > Export > 20-20 Design .XML.
2. In the Save As dialog, specify a save location

and filename for the file.

3. Click Save.

Exporting to Sketchfab
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Sketchfab is a website where you can publish and
share interactive 3D files. If you have an account on
Sketchfab, you can use the Sketchfab Export tool in
Envisioneer to upload your 3D Envisioneer model to
Sketchfab. To learn more about Sketchfab, visit
https://sketchfab.com/.
To export to Sketchfab:
1. Select File > Export > Sketchfab Export.
2. In the Upload to Sketchfab dialog box,

specify the settings described below. Settings
with an asterisk (*) are required settings.

Title *. The name of the model as you would
like it to appear in Sketchfab.

Description. A brief description of the
model.

Tags. Keywords or phrases that users can
use to search for your model.

Note that the tags 'Cadsoft' and 'Envisioneer'
will be automatically applied to the model.

Visibility. Select Public if you want the
model to be visible to everyone, or Private if
you want it to be visible only to users who
have the specified Password. Note that the
Private option is only available if you have a
premium Sketchfab account.

Email Address *. The email address
associated with your Sketchfab account.

Password *. The password for your
Sketchfab account.

Exporting Catalog Content to a
BIM File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you would like to transfer elements or libraries in
the current catalog to another catalog, you first need
to export the desired content to a BIM (Building
Information Management) file. You can then use the
Import BIM File tool to import the content into the
other catalog.

By exporting content to a BIM file you can also share
your catalog content with other Envisioneer users by
simply giving them the BIM file.
To export catalog content to a BIM File:
1. Make sure that the catalog from which you

want to export content is the current catalog.

2. Select File > Export > Catalog to BIM. You
can also launch this feature from the Element
Manager or Library Manager by selecting File
> BIM File > Export.

Adding_a_Description.htm
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3. By default, the content will be copied to a
new, blank BIM file. If you want to export the
content to an existing BIM file (i.e. add to a
BIM file), click above the right pane and
open the BIM file that you want to export to.

4. In the left pane of the Export Items to BIM
File dialog, select the content that you want
to export to a BIM file. To expand a group,
click its plus sign (+). You can select an entire
element group (e.g. Windows), individual
groups (e.g. Fixed Windows), or individual
elements within a group (e.g. 4' x 4' Fixed
Window). The same goes for libraries.

5. Click Transfer. The selected content is copied
to the BIM file in the right pane.

6. Continue transferring content if desired.

7. When you are finished transferring content,
click OK.

8. In the Save As dialog, type a name for the
BIM file in the File name edit box, then click
Save.

Note: When you transfer a group or item to a BIM
file, other content may be copied as well. This
additional content is associated with the items you
are transferring, and is necessary for the items to be
properly defined. For example, if you copy the
Doors group to the BIM file, the Parts group will
copy over as well, because doors have parts such as
hinges and doorknobs included as assemblies in
their properties. Similarly, if you copy the Materials
library to the BIM file, other libraries such as
Patterns, Line Styles and Manufacturers will copy
over as well because materials have patterns, line
styles and manufacturers defined in their
properties.

Note: When you copy individual groups or items
to a BIM file, the structure which the group or item
is part of is mimicked in the BIM file pane. For
example, if you copy the 4' x 4' Fixed Window to
the BIM file pane, it will appear in a folder named
"Fixed", and the Fixed folder will appear under a
"Windows" folder.

Exporting Project Content to a
BIM File
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have customized content in your project and
would like to use that content in another project, you
can export the custom content to a Building
Information Modeling (BIM) file for import into other
projects. For example, if you have edited layer
definitions, which are project-specific, you can export
those layer definitions to a BIM file and then import
the BIM file into other projects to make those layer
definitions available in those projects.
To export project content to a BIM file:
1. Open the project whose content you want to

export to a BIM file.

2. In Model View, select File > Export > Project
to BIM. The Export Items to a BIM File
dialog box appears.
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3. By default, the content will be copied to a
new, blank BIM file. If you want to export the
content to an existing BIM file (i.e. add to a
BIM file), click above the right pane and
open the BIM file that you want to export to.

4. In the left pane of the dialog, select a folder
or item that you want to export. Note that the
left pane will only contain elements that exist
in the current project.

5. Click Transfer to add the item to the BIM file
in the right pane.

6. Continue transferring content if desired.

7. When you are finished transferring items,
click OK.

8. In the Save As dialog, type a name for the
BIM file in the File name edit box, then click
Save.

Note: When you transfer a group or item to a BIM
file, other content may be copied as well. This
additional content is associated with the items you
are transferring, and is necessary for the items to be
properly defined. For example, if you copy a Layer
Table to the BIM file, the Line Types and Line
Weights used in the table's layer definitions will be
also be copied to the BIM file.

Accessing the Project Manager
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Project Manager to capture basic
project information, such as the project name,
company address and phone numbers. You can also
use it to keep track of who has worked on the project,
and when.
To access the Project Manager:
1. Select File > Project Manager.

Specifying Project Information
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Project Information page of the Project Manager
dialog lets you capture basic information about your
project, such as the project name, project number,
company name, company address, and important

phone numbers. You can also enter notes about the
project.
To enter project information:
1. Select File > Project Manager.

2. In the Project Manager dialog, select the Pro-
ject Information tab.

3. Enter the project information.

4. Click OK.

Keeping Track of Revisions
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Project Manager dialog’s Work History page lets
you keep track of who has worked on the project, and
when. You can make note of what was worked on, as
well as enter additional notes. This provides a
detailed system of revision control that can be
accessed by anyone working on the project.
To enter a revision:
1. Select File > Project Manager.
2. In the Project Manager dialog, select the

Work History tab.

3. Click Add.
4. In the Author edit box, enter your name or

the name of the person who completed the
work.

5. In the Date edit box, verify the date of the
revision. The current date is shown by
default.
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6. In the Subject edit box, enter the general sub-
ject of the revision.

7. In the Notes window, enter details about the
work that was completed.

8. Click OK.
9. Click Yes to add the revision to the work his-

tory list.

10. Click OK.
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When you start the program, a catalog of elements is displayed on the right side of the screen. This is where you
choose the elements that you want to insert. A catalog also contains various libraries, such as Materials, Text Styles
and Dimension Styles libraries.

The Element Manager lets you add, edit and delete elements in a catalog to suit your needs. You can also customize
the way a catalog is organized by adding, deleting or renaming groups.

The Library Manager lets you customize any library in the catalog by adding, editing and deleting library items.

You can create new, custom catalogs that contain a specific selection of elements.

You can export the content of a catalog to a TXT file, edit the items in the TXT file, and then import the edited
content back into the catalog in Envisioneer.

You can export selected libraries and elements to a BIM file for import into other catalogs. You can also import
content from any external BIM file.

You can view or edit catalog properties such as the catalog's name and author. You can lock a catalog to prevent
others from making unwanted edits to the catalog. While designing you can open any catalog you want to gain
access to the elements you want.

Adding a Group or Subgroup to a Catalog
Personal Architect | Pro Architect | Building Essentials | Construction Suite

Most elements and library items are organized by group. For example, walls are organized into groups such as Brick
Veneer, Interior Partition, and Poured Concrete. This helps you locate specific element types quickly. You can add
groups to any catalog or library using the Add Group tool. To create a deeper level of organization you can add a
subgroup to any existing group using the Add Subgroup tool.
To add a group or subgroup to the current catalog:
1. Open either the Element Manager or Library Manager depending on where you want to add the group.

To open the Element Manager select File > Catalogs > Element Manager, or click the down arrow next to
the Catalogs button on the Standard toolbar and select Element Manager. You can also right-click an
element in the catalog panel and select Element Manager.
To open the Library Manager select File > Catalogs > Library Manager.

2. Select the element catalog or library that you want to add a group to.

3. Select the category that you want to add a group to, then select Edit > Add Group, or right-click and select
Add Group. To add a subgroup to an existing group, select the group then select Edit > Add Group, or
right-click the group and select Add Group.

4. Type a name for the group, then press ENTER.

Moving a Subgroup to the Root
Personal Architect | Pro Architect | Building Essentials | Construction Suite
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In an element catalog or library, if you have a group
within a group, you can move that subgroup to the
root of the tree. In other words, you can promote the
subgroup to a group.
To move a subgroup to the root:
1. Open either the Element Manager or Library

Manager depending on where the group
resides.

To open the Element Manager select File >
Catalogs > Element Manager, or click the
down arrow next to the Catalogs button
on the Standard toolbar and Element
Manager. You can also right-click an element
in the catalog panel and select Element
Manager.
To open the Library Manager select File >
Catalogs > Library Manager.

2. Display the element catalog or library that
you want to edit.

3. Click and hold down your mouse button over
the subgroup that you would like to move,
then drag it to the root folder.

Renaming a Group in a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

In an element catalog or library, you can change the
name of any group using the Rename Group tool.
To rename a group:
1. Open either the Element Manager or Library

Manager depending on where the group
resides.

To open the Element Manager select File >
Catalogs > Element Manager, or click the
down arrow next to the Catalogs button
on the Standard toolbar and select Element
Manager. You can also right-click an element
in the catalog panel and select Element
Manager.
To open the Library Manager select File >
Catalogs > Library Manager.

2. Open the element catalog or library con-
taining the group that you want to rename.

3. Select the group that you want to rename,
then select Edit > Rename Group, or right-
click it and select Rename Group.

4. Type the new name and press ENTER.

Deleting a Group from a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can delete a group in an element catalog or
library provided it contains no elements or objects.
To delete a group in a catalog:
1. Open either the Element Manager or Library

Manager depending on where you want to
add the group. 

To open the Element Manager select File >
Catalogs > Element Manager, or click the
down arrow next to the Catalogs button
on the Standard toolbar and select Element
Manager. You can also right-click an element
in the catalog panel and select Element
Manager.
To open the Library Manager select File >
Catalogs > Library Manager.

2. Display the element catalog or library that
you want to edit.

3. Select the group that you want to delete. Note
that the group can only be deleted if it con-
tains no elements or objects.

4. Select Edit > Delete Group, or right-click and
select Delete Group.

Saving Edited Elements in Your
Drawing to a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have edited the properties of an inserted
element, you can save that element (and its custom
properties) to the current catalog.
To add an edited element from your drawing into
the current catalog:
1. Select File > Catalogs > Save Element to

Catalog, or click the down arrow next to the
Catalogs button on the Standard toolbar
and select Save Element to Catalog. Your
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pointer changes to a catalog cursor.

2. Select the element in your drawing.

3. Click Yes to save the element. You are asked
if you want to save another element to the
catalog.

4. Click Yes if you want to save another ele-
ment to the catalog, or No to finish.

Note: If the element that you select already exists
in the catalog, you will be asked if you want to
create a copy in the catalog to work with. If you
click Yes, a copy of the element is created in the
catalog, with a number appended to its name to
differentiate it from the original.

Importing Custom Objects into
Your Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have any custom 3D blocks in DWG, DXF, SKP
(Google™ SketchUp), OBJ, 3DS, or IFC format, you
can import them into your Envisioneer catalog so that
they are available to be inserted in your drawing.
Many sites on the Internet offer free downloading of
objects for your convenience. Typically, blocks are
objects such as furniture and appliances.
To import a custom object into your catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and Element
Manager.

2. Open the element folder that you want to add
the object to.

3. Select Edit > Add Element.
4. In the Define Element dialog, select the Cus-

tom Block option.
5. Click OK.
6. In the Open dialog, select the appropriate file

type from the Files of type drop box (DWG,
DXF, OBJ, , SKP, 3DS, IFC, IFCzip).

7. Locate and select the file to import, then click
Open.

Note: If the imported file is larger than 4MB it is
considred a very large block (VLB) and a dialog box
will appear, noting that VLB files will be optimized
due to their potential size. The VLB import will have
additional steps regarding plan and elevation views.
Click OK to accept the message.
8. In the Block Import Options dialog, specify

what you want the components created from
by making a selection in the Create Com-
ponents From drop box. For DWG and DXF
files you can choose from Colors or Layers.
Since 3DS and IFC objects are essentially an
assembly of materials, the only selection for
3DS objects is Materials. (This step does not
apply to SketchUp files.)

9. On the Orient your element screen, use the
arrows to rotate the model so that it will be
oriented correctly when inserted in a draw-
ing.

10. If the object is a door or window, the Pos-
ition the insertion point of your element
screen will appear. Specify where along the
object's height (Z Axis) you would like to pos-
ition the object's insertion point. Use the
slider to move the insertion point up or
down. To offset the door/window frame from
the wall surface, enter an offset value in the
Frame Offset edit box.

11. For some file types, the program needs to
know what units were used to create the
object originally so that it can be converted
into an appropriate size. If you know what
units were used to create the object, select the
units from the Convert File From drop box.
Otherwise, select the unit of measure in the
Convert File From drop box that will result
in a logical Resultant Width, Resultant
Depth and Resultant Height. Selecting Cus-
tom lets you specify a custom scale in the Cus-
tom Scale edit box. (This step does not apply
to SketchUp files.) Once logical dimensions
are displayed, click OK.

12. The next screen lists the object’s individual
components. Specify which components you
want to display or hide in 3D by clicking the
appropriate eye icons. Skip to NOTE below if
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the file is an OBJ file. The steps will be dif-
ferent.

Component is displayed 

Component is not displayed

Enabling the Show only selected
component check box displays only the
currently selected component in the object
preview. This helps you distinguish between
the object's individual components.

To rename a component, double-click it, then
type the new name and press Enter.

13. Click Next.
14. The next screen lists the object's components

again, but this time you can specify which
components you want to display or hide in
2D plan view.

To create a custom plan view, select either
Outline or Slice below the preview window
to specify how the plan view is to be created.
To create a simple outline based on the
footprint of the object, select Outline. To
create a slice through the object, select Slice,
and then use the slider control next to the
preview window to specify the position of
the slice.

To control the visibility of components within
the custom plan view, click next to the
drop box, then specify which components
you want to hide or show in the Display
Components to Generate Plan View dialog.
Once the plan view has the desired
appearance in the preview window, click
to add the view to the list of components.
You can delete custom plan views from the
list if desired, but you cannot delete
components of the original object.

NOTE: Block files that are over 4MB are considered
very large blocks (VLBs) and will be treated
differently. Just one dialog box appears. That dialog
allows you to accept the plan view and elevation view
that was generated upon import or import a separate
view by checking "Replace with Custom" and then
clicking Select to find a plan view or an elevation
view. Please note that if "Replace with custom" is
used the imported elevation must have a closed

polyline around the elevation or an error message will
appear "No valid geometry". A valid outline is a
polyline - the import will disregard lines.

15. Click Next.
16. Click Finish.
17. In the Element Manager, enter a name for

the element in the Name edit box.
18. Define the element’s properties. The element

will already have size properties assigned to
it that are taken from the original file, but you
can change these. You may need to edit the
orientation of the element so that it inserts
correctly in the drawing.

19. If you want to select a different file to apply
to your new element, click the Select button
in the Imported Element area of the Basic prop-
erty page.

20. Click OK. The new element is added to the
catalog.

Creating a New Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you plan to edit or add elements in the Master
Catalog, you may want to create a new catalog
instead of editing the existing one. That way, the
custom elements you create are distinguishable from
the defaults and are stored in one place. When you
create a new catalog, you specify a name and where
you want to store the catalog.

Once you have created a new catalog it becomes the
current catalog in the catalog panel. Initially the
catalog will be empty. You can import content into it
from another catalog using the BIM File Import tool.
You can also add elements to it using the Element
Manager, and library items using the Library
Manager.
To create a new catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select
Element Manager.
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The New Catalog tool is also available in the
Library Manager (File > Catalogs > Library
Manager).

2. Select File > New Catalog.
3. In the Create a new catalog dialog, type a

name (without extension) in the File Name
box.

4. Click next to the Location edit box and
select the directory where you want to store
the new catalog. The default is the program's
Catalogs directory, which is where you
should store all catalogs.

5. From the Type drop box, select the unit of
measure you would like to use for elements
in the catalog.

6. From the Precision drop box, select the level
of precision you would like to use for meas-
urements. For example, selecting #’-# #/16”
sets the level of precision to 1/16th of an inch
when working in feet and inches.

7. In the Name edit box, type your name.
8. In the Company edit box, type the name of

your company, if applicable.

9. If you want to prevent the catalog from being
edited by unauthorized persons, enable the
Lock Catalog to Editing check box. Then,
enter and re-enter a password in the Pass-
word dialog.

10. Click OK. A new, blank catalog is created.
You can now add groups and elements to the
catalog, or import elements from another
catalog. Remember to save the catalog after
you make changes to it.

Locking a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can prevent a catalog from being edited by
unauthorized persons by locking it. Once locked, a
password must be entered to unlock it.
To lock a catalog:
1. Select File > Catalogs > Catalog Properties,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select

Catalog Properties. You can also access cata-
log properties from the Element Manager
and Library Manager by selecting File >
Catalog Properties.

2. In the Catalog Properties dialog, enable the
Lock Catalog to Editing check box.

3. In the Password dialog, enter the password
that you want to use to unlock the catalog.
Then, enter the password again in the second
edit box to confirm it. For security reasons,
the actual characters of your password do not
appear as you type them.

4. Click OK.

Unlocking a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If a catalog has been locked to editing, you can unlock
it by entering the password that was created when the
catalog was locked.
To unlock a catalog:
1. Select File > Catalogs > Catalog Properties,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Catalog Properties. You can also access cata-
log properties from the Element Manager
and Library Manager by select File > Cata-
log Properties.

2. In the Catalog Properties dialog, disable the
Lock Catalog to Editing check box.

3. Enter the password needed to unlock it, then
click OK.

Downloading Manufacturer Con-
tent
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Green 3D Home web site contains various BIM
catalogs of manufacturer materials that you can
download and import into your Envisioneer catalog.
Some examples are Anderson windows, Kohler
faucets and Maytag appliances.
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To download manufacturer content:
1. Select File > Catalogs > Browse More Cata-

log Content or Help > Browse More Catalog
Content. You can also click on the Help
toolbar, or click the Download More link in
the catalog panel.

2. Locate the BIM catalog that you want to
download, then click Download Catalog.

3. Download the catalog to your computer.

4. Use the Import BIM to Catalog tool to import
the content of the manufacturer catalog into
your Envisioneer catalog.

Note: You must log in to be able to download
catalogs. Registration on the Green 3D Home web
site is quick and free.

Opening a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Open Catalog tool to open any
catalog and make it the current catalog in the catalog
panel. The Open Catalog tool is also available in the
Element Manager and Library Manager.
To open a catalog:
1. Select File > Catalogs > Open Catalog, or

click on the Standard toolbar and select
Open Catalog. You can also open a catalog
in the Element Manager or Library Manager
by selecting File > Open Catalog.

2. In the Open dialog, locate the catalog that
you want to open.

3. Click Open. The catalog you opened becomes
the active catalog.

Selecting a Default Catalog Dir-
ectory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, the program’s Catalogs directory is
displayed in the Open dialog when opening a catalog.
You can select a different default directory to display
if you want.
To select a default catalog directory:

1. Select Settings > Program Settings or click
on the Settings toolbar.

2. On the General pane, click on the Catalogs
Directory in the File Paths area.

3. Click Modify.
4. In the Browse For Folder dialog, select the

directory you want to use as your default
catalog directory, then click OK.

5. Click OK in the Program Settings dialog.

Viewing Catalog Properties
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can view the properties of the current catalog
(file name, location, etc.) using the Catalog Properties
tool.
To view the properties of the catalog currently
displayed in the catalog panel:
1. Select File > Catalogs > Catalog Properties,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Catalog Properties. You can also access the
Catalog Properties tool in the Element Man-
ager and Library Manager by selecting File >
Catalog Properties.

Saving a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Whether you have a created a new catalog or are
editing an existing one in the Element Manager or
Library Manager, you will want to save your changes.
Note that when you click OK in the Element Manager
or Library Manager, the current catalog saves
automatically.
To save the current catalog:
1. In the Element Manager or Library Manager

dialog, select File > Save Catalog.

Creating a Copy of a Catalog
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can create a copy of a catalog using the Save
Catalog As tool.
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To create a copy of a catalog under a different
name:
1. Make sure the catalog you want to save is the

current catalog.

2. Select File > Catalogs > Element Manager,
or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

3. In the Element Manager dialog, select File >
Save Catalog As.

4. In the File name edit box, type the name you
want to save under (without extension).

5. Click Save.

Note: The newly saved catalog becomes the current
catalog.
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The Master Catalog contains thousands of elements. You can add, edit and delete elements in the catalog using the
Element Manager.

When you want to add or edit an element in a catalog, you need to define the element's properties, such as its size
and appearance. Some elements will have more settings than others. When you edit an element in a catalog, your
changes will be applied to any future insertions of that element.

You can also edit elements that you have inserted in your drawing. When you edit an inserted element, the changes
you make are specific to that insertion of the element, and have no effect on the catalog or future insertions of the
element.

If you have edited the properties of an inserted element, you can save that element (and its custom properties) to the
current catalog using the Save Element to Catalog tool.

Using the Element Manager
The Element Manager contains a list of all the elements in the current catalog. Using the Element Manager you can
add and edit elements, import elements from another catalog, and create new catalogs.
To access the Element Manager:

1. Select File > Catalogs > Element Manager, or click the down arrow next to the Catalogs button on the
Standard toolbar and select Element Manager. You can also right-click an element in the catalog panel and
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select Element Manager.

All catalog elements are found in the left
navigation pane. The properties of the currently
selected element are displayed on the right side
of the dialog. Each set of properties has its own
tab (Basic, Appearance, Quantity, etc.). Simply
select a tab to view and/or edit those properties.

You can find an element by searching through
the tree in the navigation pane. Elements are
grouped by type (Walls, Doors, Windows, etc.),
and each element folder may have sub-folders for
additional organization. The Element Manager
includes a Search feature above the navigation
pane that you can use to quickly find a specific
element in the catalog.

Searching for Elements in the
Element Manager
The Element Manager includes a Search feature that
you can use to quickly find a specific element in the
catalog. You can search by keyword or by part
number. If you do a keyword search, the feature will
look at element names. If you do a part number

search, it will look at the Part No. values assigned to
elements on their Quantity property page. Search
terms are saved for your convenience so that you can
activate them again in the future.
To search the catalog:
1. Click the drop box in the Search area above

the navigation pane and select either
Description to search by keyword, or Part
No. to search by part number. An edit box
appears next to the drop box.

2. In the edit box, enter the keyword(s) or part
number to search for, then press Enter or

click . If you enter one or more
keywords, the search function will search all
element names throughout the catalog for the
specified text string. The search is not specific
to any one type of element, and will display
any match that contains the specified text
string, even if the string is part of a larger
word. For example, if you enter "wood" in the
search field, you may see results such as
Wood Siding, Wood Rail Edging, Solid Wood
Door, Hardwood Floor, and Japanese
Dogwood.

Note that if you enter two or more keywords,
the keywords must appear consecutively in
an element's name in order for the element to
appear in the search results. For example, if
you enter the keywords "wood edging", an
element named Wood Rail Edging would not
appear in the search results.

Once search results are obtained they are
displayed in the navigation pane.

3. To return the catalog to its default state,
where all elements are displayed, select
Show All from the Search drop box.

4. Search terms that you have used are saved in
the Search window. To activate a search that
you performed previously, select the desired
search term from the search drop box.
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Viewing Element Properties
Every element has a set of properties that defines the
element’s size, type and physical appearance. You can
customize an element’s properties to suit your needs.
Property pages vary depending on the element type,
as do the properties available on those pages.

You can access element properties through the
Element Manager or the catalog panel, or through an
inserted element. You can edit the properties of
inserted elements as well as elements in the Element
Manager.
To view element properties through the Element
Manager:
1. Select File > Catalogs > Element Manager,

or right-click an element in the catalog panel
and select Element Manager.

2. Select the element whose properties you want
to view. The element's properties appear on
the right side of the Element Manager.

To view element properties through the catalog
panel:
1. In the catalog panel, right-click the element

and select Edit Element.
To view the properties of an inserted element:
1. Select the element in your drawing.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

Adding Elements to a Catalog
You can create a new element in a catalog by defining
a number of different properties that determine its
size, geometry and appearance.
To add a new element to the current catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

2. In the Element Manager, expand the appro-
priate element type, then select the group that
you want to add the element to.

3. Select Edit > Add Element, or right-click and
select Add Element.

4. Elements like furniture, appliances and
accessories can be defined based on a set of
general parameters, or by importing a DWG,
DXF, 3DS or SKP file. If this is the case, you
will see the Define Element dialog.

5. To define the element by specifying size prop-
erties, select the specific element type you
want to create (chair, table, etc.), then click
OK.

6. To import a 3DS, DWG, DXF or SKP block,
select the Custom Block option, then click
OK. Some elements, like electronics, will
prompt you directly for a file because they do
not have a parametric template. For more
information, see Importing Custom Objects into
Your Catalog on page 431.

7. Define the element's properties on the right
side of the dialog. (See Working with Property
Pages on page 441.)

8. If you want to name the element auto-
matically using a pre-defined naming con-
vention, click the Autoname button. (See
Using Automatic Name Generation on page
441.)

9. Click OK. The element is added to the cata-
log.

Editing Elements in a Catalog
Every element has a number of different properties
that determine its size, geometry and appearance. You
can edit these properties to suit your needs. The
Element Manager contains a list of all elements in the
current catalog. You can edit a single element or
multiple elements simultaneously.
To edit an element in a catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

2. In the Element Manager, select the element
that you want to edit. You can select multiple
elements if you want by holding down the
Shift key and clicking on elements.
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3. If you want to name the element auto-
matically using a pre-defined naming con-
vention, click the Autoname button.

4. Edit the properties on the right side of the dia-
log. If multiple elements are selected, prop-
erty values that differ are shown in red.
Values shown in black are common to all the
elements selected. Values shown in red can
still be edited, but be aware that the value
will be applied to all elements in your selec-
tion set.

5. Click OK.

Note: Editing elements in a catalog has no effect on
elements already inserted in your drawing. It only
affects future insertions of the element.

Tracing and Replacing Elements
in a Catalog
Pro Architect | Building Essentials | Construction Suite

Items such as assemblies and infill configurations
reference one or more elements in the catalog. You
can use the Trace Element tool to see where a
particular element is referenced, and swap out the
element with a different one in that item's definition.
For example, let's say that all of the batt insulation
assemblies in the catalog reference Fiberglass
Insulation, but you want to use Mineral Wool
Insulation for all of your batt insulation applications.
You could use the Trace Element tool to quickly find
all items that reference Fiberglass Insulation, then
replace all or selected references with Mineral Wool
Insulation.

To trace an element:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

2. In the Element Manager, locate the element
that you want to trace, then right-click the ele-
ment and select Trace Element.

3. If the element is not referenced in any
definition (assembly, infill configuration, etc.),
a 'No references found' message is displayed.

If the element can be traced to one more item
definitions, the Trace Element dialog
appears, and displays a list of items that
reference the element:

4. To replace the element everywhere that is
referenced in the catalog, click the browse
button and select the desired replacement
element in the Replace dialog. Then, click
Replace All. When prompted, confirm your
choice to globally replace the element.

To replace the element in a specific item only,
double-click the item in the list to display an
edit dialog for that item. For example, if you
select an assembly, the Edit Assembly dialog
appears. In the edit dialog, click the browse
button next to the element's name and select
the desired replacement element in the
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Catalog Access dialog. Click OK to update
that item definition.

Note: When using the Trace Element tool to replace
element references, the replacement applies to the
catalog (and future element insertions) only. It does
not apply to elements that you have already
inserted in your drawing.

Deleting Elements from a Cata-
log
You can delete any element from a catalog.
To delete an element from a catalog:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

2. Select the element that you want to delete.

3. Select Edit > Delete Element, or right-click
and select Delete Element.

Working with Property Pages
When you access an element’s properties, the
properties are displayed on various tabbed pages. The
tabs and properties vary depending on the element.
The most common property pages are Basic,
Appearance, Line Work, Quantity and Behavior. The
notes and hyperlinks properties are common to all
property pages.

A preview of the element is shown in the preview
window. By default, the image is displayed in a 3D
rendered view. You can switch between 3D and 2D as
well as select different display modes by right-
clicking in the preview window and making a
selection from the menu.

When the image is in a 3D view, you can rotate it
around by clicking and dragging with your mouse.

Using Automatic Name Gen-
eration
Names of elements are based on pre-defined
formulas. The name 8" Concrete Wall is made up of
three variables:

Each variable is separated by a space. These variables
and spaces are defined in the name's formula.

If you add or change an element, and select Auto
Name, the element's name updates automatically in
the catalog. For example, if you create a concrete wall,
and define a width of 10", the name automatically
becomes 10" Concrete Wall.

Automatic name generation:
l Saves typing a name every time you add or
edit an element

l Ensures consistency in catalogs
l Prevents duplicate entries if you forget to
change a name

To use automatic name generation when adding or
editing an element, click the Autoname button next to
the Name edit box in the element’s properties dialog.

Note: Even if you have used the Autoname feature,
you can still add to or edit the name.

Modifying the Name Generation
Formula
You can modify the formula used to generate an
element's name when the Autoname feature is used
in the catalog or in an element's properties. Formulas
are made up of variables (like Element Class and
Element Type) and separators (spaces, symbols or
characters).

Editing an element’s name generation formula sets
the formula for any new elements you create of that
type. For example, if you edit the name generation
formula for an 8” Brick Wall, any new walls you add
to the catalog will use the new formula if you use
automatic name generation.
To modify the formula used for an element's
automatic name generation:
1. Select File > Catalogs > Element Manager,

or right-click an element in the catalog panel
and select Element Manager. In the catalog,
select the element to edit.

or

Select an element in your drawing, then
right-click and select Properties.
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2. On the Basic property page, click next to
the Autoname button. The Automatic Name
Generation dialog for that element type is
displayed. The right pane (titled Used Vari-
ables and Separators) displays the current for-
mula.

3. To remove a component from the formula,
select it and click Remove, or press the left
arrow key on your keyboard.

4. To add a component to the formula, select the
desired variable or separator in the Available
Variables or Available Separators window and
click Add, or press the right arrow key on
your keyboard.

5. To move a component in the formula, select
the component and click Move Up or Move
Down.

6. When you have finished modifying the for-
mula, click OK to close the Automatic Name
Generation dialog.

7. Click OK to close the Element Manager.

Editing the Size and Com-
position of an Element
You can edit the physical make-up of an element as
well as its dimensions by accessing the element’s
Basic property page. Some elements have additional
property pages that control its composition. For
example, cabinets have Leaf and Details property
pages.

When you edit the properties of elements that exist in
your drawing, only selected elements are changed.
Other occurrences of the element in your drawing
remain unchanged. You can, however, select and edit
multiple elements at the same time provided they
share the same properties.
To edit the properties of an inserted element:
1. Access the element's properties.

2. Adjust the properties as desired. Clicking a
dimension marked with an alphabetical char-
acter (a, b, c, etc.) highlights the cor-
responding dimension in the element graphic,
and vice versa, if one exists.

3. Click OK. The selected elements are updated
in the drawing.

Note: Editing the properties of an element in your
drawing has no effect on the element’s property
definition in the catalog it came from. Editing an
element in a catalog affects all future insertions of
that element in your drawing.

Changing an Element's Ori-
entation
Symbol elements, such as furniture and light fixtures,
are oriented in a logical fashion when you insert them
in your drawing. For example, tables are inserted in a
flat, upright position on the floor, and electrical
outlets are inserted in a vertical position on the face of
walls. You can edit the orientation of most symbol
elements. For example, you may want to flip an air
register so that you can insert it on the ceiling in your
basement.
To change an element’s orientation:
1. Access the element's properties.

2. On the Basic property page, click the
appropriate arrow keys in the Orientation area
to rotate the element.

X Axis: Rotates the element front to back, and
vice versa. 

Y Axis: Rotates the element towards its left or
right side in 3D.

Z Axis: Rotates the element left or right in 2D
plan view.

Note: Orientation control is only available
for simple block elements like furniture
and appliances. It does not apply to
elements with customizable components,
such as fireplaces or cabinets.

Controlling What Parts of an Ele-
ment are Displayed
You can hide certain parts of a block element from
view by changing its display properties.
To control what parts of an element are displayed:
1. Access the element's properties.

2. In the property dialog, click Display.
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3. To display or hide a component from view in
2D and/or 3D view, select it in the list, then
click the appropriate eye icon.

Component is displayed

Component is not displayed

4. Click OK to return to the properties dialog.
5. Click OK in the properties dialog.

Note: The Display control feature is only available
for simple block elements like furniture and
appliances. It does not apply to elements with
customizable components, such as fireplaces or
cabinets.

Simplifying an Element
If an element looks too complex in the preview
window, you can simplify it by reducing the number
of polygons used to display it.
To simplify an imported element:
1. Access the element's properties.

2. In the property dialog, click Simplify.
3. To simplify the element, slide the ruler to the

left. The Number of vertices in object and
Percentage of simplification values update
accordingly.

4. To put a limit on how much simplification
can take place, enter a value in the Min num-
ber of vertices per component edit box. The
larger the number, the less simplified the ele-
ment will become.

5. Click OK to return to the properties dialog.
6. Click OK in the properties dialog.

Note: The Simplify feature is only available for
simple block elements like furniture and
appliances. It does not apply to elements with
customizable components, such as fireplaces or
cabinets.

Editing an Element's Insertion
Point
Some elements have a defined Insertion Point, which
is the point on the element that is attached to the
cursor when you are inserting the element. For most
elements, the insertion point is at the bottom of the

element. For windows and wall openings, the
insertion point is at the top of the element. When
changing the elevation of an element, the distance is
measured from the floor or terrain to the element's
insertion point.
To edit an element’s insertion point:
1. Access the element's properties.

2. Select the Behavior tab.

3. Edit the values in the X Axis, Y Axis and Z
Axis edit boxes, or use the sliders beside
these edit boxes.

An X value moves the insertion point left or
right. A Y value moves the insertion point
forwards or backwards. A Z value moves the
insertion point up or down on the element.

4. Click OK.

Editing an Element's Snap Edge
Some elements have a defined Snap Edge, which
determines which edge of the element will snap to the
wall if you position it near a wall.
To edit an element’s snap edge:
1. Access the element's properties.

2. Select the Behavior tab.

3. Click on the desired snap edge graphic in the
Snap Edge area. Choose from None, Left, Right,
Front or Back.

4. Click OK.

Editing an Element's Insertion
Height
You can change the height at which single-click
elements are inserted by editing their behavior
properties. The Distance above current location or
terrain option lets you control the height at which the
element is inserted relative to the floor or terrain. The
value entered is the distance from the floor or terrain
to the insertion point of the element. (For most
elements except windows and wall openings, the
insertion point is at the bottom of the element.)
To edit an element’s insertion height:
1. Access the element's properties.

2. Select the Behavior tab.

3. Edit the value in the Distance above current
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location or terrain edit box.
4. Click OK.

Editing an Element's Layer
Assignments
Each of an element's components has a specific layer
assigned to it. Layer definitions determine the color,
line type and line weight used to display a
component's lines in 2D plan view. You can edit an
element's layer assignments on its Line Work
property page.
To edit an element's layer assignments:
1. Access the element's properties.

2. Select the Line Work tab.

3. In the Components pane, select the component
whose layer assignment you want to change.

4.

Select the desired layer from the Layer drop
box. The layer's color, line type and line
weight are displayed below the drop box.

To override the layer's Color, Line type or
Line weight setting, click on the property
that you want to override and then make a
selection from the drop box that appears.

5. When you are finished editing layer assign-
ments, click OK.

Editing an Element's Material
Settings
An element's material properties are displayed in
Rendered and Rendered Outline mode. If you choose
to edit an element’s material through its Appearance
property page, you can select different materials for
each of the element’s components.
To change an element’s material through the
Appearance property page:
1. Access the element's properties.

2. Select the Appearance tab.

3. In the Components pane, select the component
whose material you want to change.

4. To select a texture for the component, which
will be displayed in Rendered and Rendered
outline display mode, click the material
swatch or the browse button in the Material
area, then make a selection from the
Materials dialog.

5. To edit the way the material is applied to the
component in Rendered and Rendered
Outline mode, click the Mapping button in
the Material area, then define your mapping
settings. These are described below.

Auto Texture Mapping. Applies a UV map,
which is a flat, 2D representation of the
vertices of the 3D model. It defines where the
2D pixels in your texture will be placed on
the 3D surface. For imported elements,
selecting Auto uses the mapping already
applied to the element.

Face Texture Mapping. Applies the texture to
every single face of the element component.
This is the most common texture mapping
option used in the program.

Box Texture Mapping. Creates a rectangular
bounding box around the element, then
applies a texture to each of the box’s 6 sides.
This would be useful for an element such as a
sofa.

Predefined texture mapping. If using a texture
from an outside source, this uses the texture
mapping that was assigned to the texture
originally.

Override tile size. Allows you to specify a
custom tile size for the material. Tile height
refers to the height of one bitmap tile. The
program uses tiled rendering to display
images, meaning images are generated in
pieces (tiles) vertically and horizontally.
Changing the tile height of a brick material,
for example, would make the bricks look
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taller. Changing the tile width would make
the bricks look wider.

Note that the Override tile size option lets you
customize the tile size for this instance only
without creating a new material.

Position. Allows you to shift the material on
the element (left, right, up or down) by
clicking the appropriate arrows.

Rotation. Specifying an angle here rotates the
material on the element in a clockwise
direction.

6. When you are finished defining materials,
click OK.

Note: When you edit the material of an element in
your drawing, the element’s material definition in
the catalog does not change. The change only
applies to the selected element. Editing an element
in a catalog affects all future insertions of that
element in your drawing.

Editing an Element's Pattern Set-
tings
An element's pattern properties are displayed when
you view a model in Patterned mode. If you choose to
edit an element’s pattern settings through its Line
Work property page, you can select different patterns
for each of the element’s components.
To change an element’s pattern settings:
1. Access the element's properties.

2. Select the Line Work tab.

3. In the Components pane, select the component
whose pattern you want to change.

4. To select a pattern for the component, click
the pattern swatch or the browse button in
the Pattern area, then make a selection from
the Patterns dialog.

5. To edit the way the pattern is applied to the
element in Patterned display mode, click the
Mapping button in the Pattern area, then
define your mapping settings. These are
described below.

Rotation. Specifying an angle here rotates the
pattern on the element in a clockwise
direction.

Position. Allows you to shift the pattern on
the element (left, right, up or down) by
clicking the appropriate arrows.i

6. To specify a color and line weight for the pat-
tern's lines, select Layer below the pattern
swatch which has the desired color/line
weight properties. You can override the color
or line weight by clicking the Color swatch or
the Line Weight drop box.

7. When you are finished, click OK.

Adding Notes to an Element's
Properties
The Notes function in the properties dialog lets you
enter a note about the element. This additional
information can be anything you want.
To add a note to an element’s properties:
1. Access the element's properties.

2. Below the properties pane, click .

3. Enter your note in the Notes dialog.
4. Click OK.

Adding a Hyperlink to an Ele-
ment's Properties
When defining an element’s properties, you can create
a link to an external file (e.g. Word document) or Web
address. You can then open the hyperlink any time
you are viewing the element’s properties. You can
add multiple hyperlinks to an element's properties if
you want. When a hyperlink is added to an element,
the right click menu will be updated to include Open
Current Link that will go directly to the hyperlink
without having to open the object's properties dialog.
To add a hyperlink to an element’s properties:
1. Access the element's properties.

2. Below the properties pane, click , or click
the adjacent down arrow and select Manage
Hyperlinks.

3. In the Manage Hyperlinks dialog, click Add.
A new entry is added to the hyperlinks win-
dow. An icon appears to the left of the new
hyperlink indicating that it is the current
hyperlink.
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4. Type a name for the hyperlink in the Name
field (e.g. My Web Site).

5. Press the Tab key to move to the Links field,
then type the web address (e.g.
http://www.mywebsite.com) or path to the
file you are linking to. If you are linking to a
file, you can click Browse to search through
the directories on your computer. Once
you’ve located the file in the Open dialog,
click Open. The path to the file is auto-
matically displayed in the Links field.

6. To view the link, select it in the hyperlink
window, then click Open.

7. To delete a hyperlink, select it in the hyper-
link window, then click Delete.

8. Click OK.
Once the element is inserted into a model, if selected
the right click menu will display Open Current Link
to directly link to the first hyperlink listed for the
element.

Note: You can create a link to another Envisioneer
(*.bld) file. However, if that file uses the same
catalog as the current drawing, you cannot access
the catalog in the linked file.

Opening an Element's Hyperlink
If you have attached a hyperlink to an element, you
can open the hyperlink when viewing the element’s
properties.
To open an element’s hyperlink:
1. Access the element's properties.

2. Below the properties pane, click the arrow

next to the Hyperlinks button , then
select Open Current Link. The hyperlink is
opened.

Note: If you have attached multiple hyperlinks to
the element, the one marked current in the
Hyperlinks dialog will be opened.

Making a Hyperlink Current
When you attach more than one hyperlink to an
element’s properties, the current one is marked with
an icon in the Hyperlinks dialog.

When you use the tools in the Hyperlinks dialog
(Browse, Open, Delete), they apply to the currently
selected hyperlink. Also, when you select the Open
Current Link tool from the Hyperlinks flyout, it
opens the currently selected hyperlink.

To make a specific hyperlink current in the
Hyperlinks dialog, just click on any of its fields.

Grouping Elements in Your
Drawing to Create a Single Ele-
ment
You can select a group of elements in your drawing
and automatically create a new, single element in the
catalog which comprises all of the elements in the
group. For example, if you have added an extension
such as a sunroom to your model, you can select all of
the walls, doors, windows, roof and other elements
that make up that sunroom and create a new
'Sunroom' element in the catalog. You can then use
the Insert Group tool to insert the custom 'Sunroom'
element into any drawing.
To add a grouped element to the catalog:
1. Select the elements that you want to group,

preferably by windowing or crossing through
them.

2. Select Edit > Modify Elements > Add Group,
or right-click and select Add Group.

3. In the Add Group dialog box, give the new
element a name, and then confirm that the
elements listed are the ones that you would
like to include in the group.
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4. Click OK.

Inserting Grouped Elements
If you have used the Add Group tool to group
multiple elements into one, the grouped element is
added to the catalog for future reuse.
To insert a grouped element:

1. Select Insert > Insert Group, or click
on the Building toolbar.

2. In the catalog panel, select the grouped ele-
ment that you would like to insert.

3. Position the element in your drawing, then
click to insert it.

Editing Grouped Elements
When you use the Insert Group tool to insert a
grouped element into your drawing, the grouped
element remains selected upon insertion. At that point
you can right-click to access editing tools that will act

on the group as a whole. These include Delete,
Cut/Paste, Move, Rotate, Duplicate, Duplicate to
Locations, Mirror, and Generate Estimate.

Once you click away from the grouped element, it
becomes deselected, and is no longer considered a
group. You can now select and edit individual
elements within the group if desired.
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Items such as materials, patterns, text styles and dimension styles are stored in customizable libraries. The Library
Manager provides access to all the libraries of items and styles used in the display of elements, text and dimensions.
By accessing a library you can add content, or edit existing content. For example, if you access the Text Styles
library, you can add or edit a text style.

Library types include Materials, Material Usages, Material Filters, Patterns, Manufacturers, Text Styles, Dimension
Styles, Line Styles, Line Types, Line Weights, Light Sources, Framing, Assemblies, Phases, Categories, Usages and
Units of Measure, as well as configurations for the House Builder Wizard, Kitchen Builder Wizard, Bathroom
Builder Wizard, and Shed Builder Wizard.

Using the Library Manager
Personal Architect | Pro Architect | Building Essentials | Construction Suite

The Library Manager provides access to all the libraries of items and styles used in the display or creation of
elements, text and dimensions. By accessing a library you can add content, or edit existing content. For example, if
you access the Text Styles library, you can add or edit a text style.
To access the Library Manager:

1. Select File > Catalogs > Library Manager, or click the down arrow next to the Catalogs button on the
Standard toolbar and select Library Manager.

2. To display a library, select it from the Libraries menu.
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To add a group:
1. Select Edit > Add Group, or right-click in the

upper pane and select Add Group.
2. Type a name for the group, then press

ENTER.
To rename a group:
1. Select the group in the upper pane.

2. Select Edit > Rename Group, or right-click
and select Rename Group.

3. Type the new name, then press ENTER.
To delete a group:
1. Select the group in the upper pane.

2. Select Edit > Delete Group, or right-click and
select Delete Group.
Note: A group cannot be deleted if it contains
materials.

To add a new item to the library:
1. If the library contains a filter, select the appro-

priate filter from the Filter drop box (applies
to materials and assemblies).

2. In the upper pane, select the group you want
to add the item to (if applicable). Some lib-
raries do not contain groups.

3. Select Edit > Add [item], or right-click in the
upper pane and select Add [item].

4. Define the new item, then click OK.
To edit an item:
1. Select the item to edit.

2. Select Edit > Edit [item], or right-click and
select Edit [item].

3. Edit the item's properties.
To delete an item:
To delete an item:
1. Select the item to delete.

2. Select Edit > Delete [item], or right-click and
select Delete [item].
Note: If the item is being used by an element,
it cannot be deleted. In this case, a dialog
appears telling you this. If you want to see a
list of which elements are using the item,
click Yes.

Customizing the Materials
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The materials library contains a vast array of
materials that you can apply to elements. Even so,
you may find that you want to customize it at some
point in time.

In the materials library, materials are listed in groups
(Concrete, Brick, Wood, etc.) so you can organize and
find them easily. You can add, rename and delete
groups as needed.

You can add new materials to the library, as well as
edit and delete existing materials.
To access the materials library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Materials.

To access the materials library through the
Materials Paintbrush:
1. Go into a 3D view or 2D Designer's View.

2. Select Edit > Materials Paintbrush, or click
on any tabbed toolbar.

To access the materials library through an
element:
1. Select an element either in your drawing or in

the catalog panel.

2. Access the element's properties.

3. In the properties dialog, select the Appear-
ance tab.

4. Click the material swatch or the Select but-
ton in the Material pane.

To filter the material list:
1. Select a filter from the Filter drop box. This

displays a particular set of material groups
and types in the library. You can customize
the Material Filters library if you want.
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To add a group:
1. Select Edit > Add Group, or right-click in the

upper pane and select Add Group.
2. Type a name for the group, then press

ENTER.
To rename a group:
1. Select the group in the upper pane.

2. Select Edit > Rename Group, or right-click
and select Rename Group.

3. Type the new name, then press ENTER.
To delete a group:
1. Select the group in the upper pane.

2. Select Edit > Delete Group, or right-click and
select Delete Group.
Note: A group cannot be deleted if it contains
materials.

To add a new material:
1. In the upper pane, select the group you want

to add the material to.

2. Select Edit > Add Material, or right-click in
the material list and select Add Material.

3. In the Material Properties dialog, specify the
name and properties of the material, then
click OK.

To edit a material:
1. Select the material to edit.

2. Select Edit > Edit Material, or right-click and
select Edit Material.

3. Edit the material properties in the Material
Properties dialog.

To delete a material:
1. Select the material to delete.

2. Select Edit > Delete Material, or right-click
and select Delete Material.
Note: If the material is being used by an
element, it cannot be deleted. In this case, a
dialog appears telling you this. If you want to
see a list of which elements are using the
material, click Yes.

Editing Material Properties
When you are adding or editing a material in the
materials library, you need to specify the material’s
properties. These properties determine the texture or

color is used to display an element in the Rendered or
Rendered Outline display mode, and the texture
characteristics (for example, how it interacts with
light). Adjusting these properties can help you
achieve photorealistic results in 3D RealView
renderings.
To edit the properties of a material:
1. Select the material to edit in the materials lib-

rary.

2. Select Edit > Edit Material, or click the pre-
view swatch.

3. Edit the properties in the Material Properties
dialog. The properties are described below.
Properties Tab

Material Type. Determines the luminance or
reflectance of the surface. When you choose a
material type, only those settings that apply
to that type are available for editing.

Choose one of the following:
Generic. Material used to simulate most
surface types. Lets you define each of the
available factors (Opacity, Specular,
Reflection, etc.) without the restriction of any
particular lighting model.

Diffuse. Simulates a rough or matte material
that appears similarly bright from all viewing
directions. Suited for materials such as brick
or matte paint.

Lambert. Simulates a matte or non-shiny
surface with no specular highlights. Ideal for
materials such as chalk, pottery, matte paint,
or unpolished surfaces.

Phong. Simulates a shiny surface with
specular highlights. Commonly used for
materials such as polished wood floors, and
metals.

Energy Preservation. Refers to the notion
that the outgoing energy cannot be greater
than the incoming energy. Based on the
combination of diffuse, opacity, and
reflectivity components, this value will adjust
automatically as you edit these properties.
For more realistic materials, this value should
be equal to or less than 1.0.
Diffuse. The color or texture that you want to
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apply to the material, as seen in 3D rendered
or rendered outline display mode.

Enable the Color radio button to display the
material in a solid color. Click the color
swatch, then select the color you want to use
in the Color dialog. Use the slider to adjust
the luminance of the diffuse color.

Enable the Texture radio button to apply a
texture to the surface. To select a texture or
specify texture mapping properties, click the
texture swatch to display the Texture Map
dialog. See Editing Texture Mapping Properties
on page 453.

Bump. Simulates bumps and wrinkles
through small displacements on the surface.
The modified surface is then used for lighting
calculations (for example, when using the
Phong reflection model), giving the
appearance of detail instead of a smooth
surface.

To use the texture selected in the Diffuse
section as the Bump texture, ensure that the
lock icon next to the Bump texture swatch is
closed. To select a different texture to use for
the Bump texture, click the lock icon to
unlock it, and then make a selection the
Texture Map dialog, ensuring that you set
the Type to Normal Map. See Editing Texture
Mapping Properties on page 453.

To control the amount of bump mapping
applied, edit the Bump Scale value. A value
of 0 means no bump mapping will be
applied.

Emissive. The amount of light given off by a
material. Click the Color swatch to select the
color of light emitted. Use the slider to adjust
the level of emissivity. The more emissive a
material is, the more self-luminous it appears.

Opacity. Determines how transparent the
material is. Think of this as a mask being
applied over the surface. Click the Color
swatch to select a color for the opacity mask.
Use the Transparent/Opaque slider to adjust
the level of transparency. Use the

Dull/Glossy slider to specify the glossiness of
the opacity mask.

Specular. Reflection that creates highlights
on materials, making them appear shiny.
Click the Color swatch to select a color for
the specular highlights. Use the slider to
adjust the intensity of the highlight color. The
higher the value, the lighter (and therefore
shinier) the color. Use the Dull/Shiny slider to
adjust the size of the highlights.

Reflection. Refers to the throwing back of
light by a surface. Used to simulate used to
reflective objects like mirrors and shiny
surfaces. Click the Color swatch to select a
color for the reflected light. Use the slider to
adjust the amount of reflection. Use the
Sharp/Blurred slider to determine whether
the surface reflects the selected color, or its
surroundings. Note that the blurred effect
may increase rendering time.

IOR. The Index of Refraction. This describes
the way light bends when crossing the
material surface. A value of 1.0 means the
light will not change direction. Selecting a
material from the drop box (e.g. Air, Water,
Crystal, Glass, etc.) populates the IOR edit box
with the Index of Refraction for that material.
If you would prefer to specify a custom
value, select Custom from the drop box, then
specify a value in the IOR edit box.
Fresnel. When enabled, the reflection
strength becomes dependent on the viewing
angle of the surface. Some materials in nature
(glass, etc.) reflect light in this manner. Note
that the Fresnel effect depends on the Index
of Refraction as well.

Sphere/Box. Specifies the way the 2D texture
is applied to a 3D object. The basis of Sphere
mapping is to treat the object as if it were a
sphere. A single texture is applied to the
whole object, and the texture mapping
coordinates are generated based on the angle
of the surface at each point. Box mapping
creates a rectangular bounding box around
the element, then applies a texture to each of
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the box’s 6 sides. This would be useful for an
element such as a sofa.
Information Tab

From the Material Usage drop box, select a
usage for the material. You can access the
Material Usages library by clicking next
to this drop box. Usages can be applied to
material filters, which are used for filtering
the materials list.

To apply an assembly to the material, click
next to the Assembly drop box, then

select an assembly from the Assembly
library. Assemblies enable you to apply
pricing information to a material so that it is
accounted for in the project cost. You can
then see the material pricing in the project
estimate, or choose to ignore it if you wish.

From the Manufacturer drop box, select the
material’s manufacturer. You can access the
Manufacturers library by clicking next to
this drop box.

Editing Texture Mapping Prop-
erties
If you are using a texture to represent a material, you
can specify a number of settings that determine the
appearance of the texture.

You can access texture mapping properties in the
Material Properties dialog, by clicking a Texture
swatch. (See Editing Material Properties on page 451.)

This displays the Texture Map dialog:

Here you can click Select to choose a BMP, JPG, TGA
or PNG file from the Textures directory. If you want
to use textures from outside sources, see Using

Textures from Outside Sources on page 453 for
guidelines.

If you are selecting a Bump texture, you must set the
Type to Normal Map. Normal mapping is a technique
used for simulating the lighting of bumps and dents.
The Standard mapping type simply maps and wraps
the pixels to a 3D surface.

If you want to change the scale of the texture, enter
new values in the Tile Height and Tile Width edit
boxes. Tile height refers to the height of one bitmap
tile. The program uses tiled rendering to display
images, meaning images are generated in pieces (tiles)
vertically and horizontally. Changing the tile height of
a brick material, for example, would make the bricks
look taller. Changing the tile width would make the
bricks look wider.

By default, the Tile Height and Tile Width have the
Maintain Aspect Ratio lock closed. When the lock is
closed, the Tile Width changes to match the Tile
Height, and vice versa. This prevents distortion. If
you want to specify different values for each, you
need to open the Maintain Aspect Ratio lock by
clicking on it.

To repeat the bitmap tile horizontally, enable the Tile
Horizontally check box.
To repeat the bitmap tile vertically, enable the Tile
Vertically check box.
If you want to make portions of a texture transparent,
use a graphical editor to apply a magenta color to
those areas that you want to make transparent. Then,
in the Texture Map dialog, enable the Make magenta
color transparent check box.
The Texture Intensity setting lets you control the
brightness and contrast of the texture. Specify a value
from 0.00 to 2.00.

Using Textures from Outside
Sources
When changing a material’s texture assignment, you
can use textures (bitmaps) from outside sources
provided they are appropriately sized and not too
large. As a rule, the texture’s dimensions should be a
power of 2:

2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, etc.

Assemblies.htm
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If the dimensions are not powers of 2, the texture will
be cropped (from the top and right side) to the next
smallest size. For some textures, this will make it look
like the texture is cut off.

For example, if your texture is 500 x 500, it will be
cropped down to 256 x 256, since 500 is not a power
of 2. If the texture were 512 x 512, however, it would
not be cropped.

Cropping is not that important if the texture is a grid
pattern (such as brick), since such a texture is uniform
throughout. However, cropping can have an
undesirable result if the texture is something like a
tree.

Filtering or Sorting the Materials
Library
You can use a filter in the materials library to filter the
materials list according to specific usages. For
example, the Flooring filter will list material types
such as carpet, tile, concrete and wood. This can make
it easier to find the material you’re looking for when
editing materials or using the Materials Paintbrush.
To filter the materials library:
1. In the Materials library, make a selection

from the Filter drop box.

To Sort the Materials:

1. Select the Material Sort button.

2. Select from either of the selections listed to sort the
materials alphabetically, chronologically or by
popularity.

Specifying the Location of the
Textures Directory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, textures are located in the following
directory:

C:\ProgramData\Cadsoft\Envisioneer\Textures

If you move your Textures directory to another
location on your system, or would like to link to
another Textures directory (such as one from an older
version of the program), you will need to specify the
location of the Textures directory so that textures
appear properly in the program.
To specify the location of your Textures directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, select the
General tab.

3. In the File Paths area, click on the Textures
Directory to select it.

4. Click Modify.
5. In the Browse For Folder dialog, locate the

folder containing your textures, then click
OK.

6. Click OK in the Program Settings dialog.

Customizing the Material
Usages Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Material usages are a way of defining what a material
is used for. For example, Carpet is typically used for
floors and surfaces, but not for doors or walls. Most
materials in the materials library have a usage
assigned to them in their properties. Usages are used
to create material filters, which can be used in the
materials library to filter the display of materials.

You can add, edit and delete material usages to suit
your needs.
To access the Material Usages library through the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Material Usages.

To access the Material Usages library through a
material:
1. Select the material in the Materials library,

then right-click and select Edit Material.
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2. In the Material Properties dialog, click
next to the Material Usage drop box.

To add a new usage:
1. Select Edit > Add Material Usage, or right-

click in the Material Usages window and
select Add Material Usage.

To edit an existing usage:
1. Select it in the list, then select Edit > Edit

Material Usage, or right-click in the Material
Usages window and select Edit Material
Usage.

To define a usage:
1. In the Material Usage Properties dialog, spe-

cify or edit the usage name in the Name edit
box.

2. To select or de-select elements to include in
the usage, just click on them. Elements
marked with a red ‘X’ will not be included.

3. Click OK to return to the Material Usages lib-
rary.

To delete a usage from the library:
1. Select it, then select Edit > Delete Material

Usage, or right-click and select Delete Mater-
ial Usage.

To view the properties of an existing usage:
1. Select the usage, then select Edit > View

Material Usage, or right-click and select
View Material Usage.

2. Click OK.

Enforcing Material Usages
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, you can apply any material to an element.
However, if you enable the Enforce Material Usages
option in your program settings, you can prevent
materials from being applied to an element for which
the materials are not intended. For example, you
would be warned if you tried to apply a brick
material to a roof.
To enforce material usages:
1. Select Settings > Program Settings or click

the Program Settings button on the Settings
toolbar.

2. In the Program Settings dialog, select Build-
ing Aids in the left column.

3. Enable the Enforce Material Usages check
box.

4. Click OK.
If the Enforce Material Usages option is enabled and
you try to apply a material to an element for which it
is not intended, the Material Usage Conflict dialog
appears. At this point you can click Yes to apply the
material anyway, or click No to select another
material to apply.

Note: Materials are assigned usages in their
properties. Usages are defined in the Material
Usages Library.

Customizing the Material Filters
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Material filters are used in the materials library to
filter the materials list according to specific usages.
For example, the Flooring filter will list material types
such as carpet, tile, concrete and wood. This can make
it easier to find the material you’re looking for when
editing materials or using the Materials Paintbrush.

You can add and edit material filters in the Material
Filters library to suit your needs.
To customize the Material Filters library:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Material Filters.

3. To add a new filter, select Edit > Add Mater-
ial Filter, or right-click in the Material Filters
window and select Add Material Filter.

4. To edit an existing filter, select it in the list,
then select Edit > Edit Material Filter, or
right-click in the Material Filters window and
select Edit Material Filter.

5. In the Material Filter Properties dialog, you
can specify or edit the filter name in the
Name edit box.
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6. To select or de-select usages, just click on
them. Usages marked with a green check
mark will be included in the filter. For more
information about usages, see Customizing the
Material Usages Library on page 454.

7. Click OK to return to the Material Filters lib-
rary.

8. To delete a filter from the library, select it,
then select Edit > Delete Material Filter, or
right-click and select Delete Material Filter.

9. To view the properties of an existing filter,
select it, then select Edit > View Material Fil-
ter, or right-click and select View Material Fil-
ter.

10. Click OK.

Customizing the Patterns
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The patterns library contains an excellent selection of
pre-defined patterns that you can apply to materials.
You can create, edit and import patterns to suit your
needs.
To access the patterns library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Patterns.

To access the patterns library through an element:
1. Access the element's properties.

2. In the properties dialog, select the Appear-
ance tab.

3. In the Pattern pane, click the pattern swatch
or the Select button.

To add a pattern:
1. Select Edit > Add Pattern, or right-click in

the Patterns window and select Add Pattern.
2. Define the pattern properties, then click OK.

To edit a pattern:

1. Select the pattern in the list.

2. Select Edit > Edit Pattern, or right-click in the
Patterns window and select Edit Pattern.

3. Define the pattern properties, then click OK.
To delete a pattern from the patterns list:
1. Select the pattern in the list.

2. Select Edit > Delete Pattern, or right-click
and select Delete Pattern, or simply click the
Delete key on your keyboard.

Note: You cannot delete the pre-existing
patterns that come with the program — only
those that you have created or imported.

To import a pattern (PAT file):
1. Click Load.
2. In the Open dialog, locate the PAT file you

want to import, then click Open. The pattern
is added to the patterns library.

Note: Some pattern files, such as those from
applications like AutoCAD®, can be
compound pattern files. If importing a
compound pattern file, you may see a
number of patterns added to your patterns
list.

Editing a Pattern
You can edit a pattern’s scale and line definition.
To edit a pattern:
1. In the Patterns library, select the pattern you

want to edit.

2. To edit the scale of a pattern, enter a value in
the Scale edit box. A value of 2 doubles the
original scale, while a value of .5 halves the
original scale.

3. To edit the pattern’s line definition, fill out
the fields in the Pattern Definition pane.

No. of Lines. The number of lines that will
repeat in the pattern. Usually, this will be 1 or
2, but it could be more depending on the
complexity of the pattern. 

Edit Line. The line you are currently editing.
Definition. Generally, the segment lengths
and spaces in the line's pattern.

A single value (other than 0) creates a solid
line.
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For dashed patterns, segments and spaces can
be different lengths, but spaces must be
preceded by a negative sign to indicate they
are spaces.

For example, a definition of 20,-5,10,-5 (in
Metric) creates the following pattern: 20 mm
dash, 5 mm space, 10 mm dash, 5 mm space.

X Origin. The point on the X axis the line
passes through.

Y Origin. The point on the Y axis the line
passes through.

Angle. The angle of the line in degrees. 
Offset. The spacing between lines as the line
is repeated (offset) parallel to the original
throughout the pattern.

Shift. The distance each offset line is shifted
(left or right) from the origin of the previous
line. This creates a staggered effect.

Setting Up the Manufacturers
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The manufacturers library contains several
manufacturers of materials found in the materials
library. You can add manufacturers to the library, as
well as edit and delete existing manufacturers. Each
manufacturer has name, logo and contact information.
You can then attach manufacturer information to
elements and materials.

To access the manufacturers library directly:
1. Select File > Catalogs > Manufacturers. Or,

open the Library Manager and select Librar-
ies > Manufacturers.

To access the manufacturer's library through an
element:
1. Access the element's properties.

2. In the properties dialog, select the Quantity
tab.

3. Click next to the Manuf edit box.
To access the manufacturers library through a
material:
1. Select the material in the Materials library,

then right-click and select Edit Material.

2. In the Material Properties dialog, click
next to the Manufacturer drop box.

To add a new manufacturer to the list:
1. Select Edit > Add Manufacturer, or right-

click in the list window and select Add Man-
ufacturer.

To edit an existing manufacturer:
1. Select the manufacturer in the list, then select

Edit > Edit Manufacturer, or right-click and
select Edit Manufacturer.

2. In the Manufacturer Properties dialog, fill
out the name and contact information fields.
To select a logo if you have one, click inside
the Logo pane, then select the logo file in the
Open dialog. You can use JPG, BMP and
TGA files.

3. Click OK to return to the Manufacturers dia-
log.

To delete a manufacturer, select it in the list:
1. Select Edit > Delete Manufacturer, or right-

click and select Delete Manufacturer.

Attaching Manufacturer Inform-
ation to an Element
You can attach manufacturer information to an
element in the catalog, or in the drawing. You can
then view the manufacturer information any time you
are viewing the element’s properties.
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To attach manufacturer information to an element:
1. Access the element's properties.

2. In the properties dialog, select the Quantity
tab.

3. Click next the Manuf: edit box.

4. In the Manufacturers dialog, select the man-
ufacturer you want to attach to the element.
You can add or edit manufacturers if neces-
sary.

5. Click OK.

Note: Attaching a manufacturer to an element in
your drawing applies the information to that
particular instance of the element only. Other
instances or future insertions of the element are
unaffected.

Attaching Manufacturer Inform-
ation to a Material
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can attach manufacturer information to materials
in your materials library. You can then view the
manufacturer information any time you are viewing
the material’s properties.
To attach manufacturer information to a material:
1. Access the Materials library.

2. Select the material that you want to edit, then
select Edit > Edit Material, or right-click and
select Edit Material, or simply click on the
swatch.

3. In the Material Properties dialog, click the
manufacturer drop box and select the desired
manufacturer from the list.

4. Click OK.

Displaying Manufacturer Logos
in the Catalog and Property
Pages
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have attached manufacturer information to
elements or materials, and that information includes
logos, you can choose to display the logos in the

catalog, on the property pages of elements, and in the
Materials dialog. The logo appears above the preview
of the element or material.
To display manufacturer logos:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Tool Display area, enable the Man-
ufacturer Logos check box.

4. Click OK.

Customizing the Labels Library
You can add your own pre-defined text labels to the
labels library as well as edit and delete the existing
labels.
To customize the labels library:
1. Select a Text tool, then click the Library

button below the list of pre-defined labels in
the Text dialog.
You can also select File > Catalogs > Library
Manager. In the Library Manager dialog,
select Libraries > Labels.

2. To add a new label to the list, select Edit >
Add Label, or right-click in the label window
and select Add Label.

3. To edit an existing label, select it in the list,
then select Edit > Edit Label, or right-click
and select Edit Label. You can also click
inside the lower pane of the Labels dialog.

4. In the Label Properties dialog, type a name
for the label in the Name edit box. Then,
enter the label text in the Label Text window,
or click Import to load an existing text file.
The name is not necessarily the same as the
actual label text. It simply identifies the label
in the list of labels. For example, a label
named ‘Address’ can contain your company’s
full address.

5. Click OK to return to the Labels dialog.
6. To delete a label in the list, select the label,

then select Edit > Delete Label, or right-click
in the label window and select Delete Label.

7. When you are finished customizing the lib-
rary, click OK.
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Customizing the Text Styles
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add your own text styles to the text styles
library as well as edit and delete the existing text
styles.
To customize the text styles library:
1. If you are currently in the Text dialog, click

the Text Style button. If you are not currently
in the Text dialog you can launch it by
selecting a Text tool.

For direct access to text styles library, select
File > Catalogs > Library Manager. In the
Library Manager dialog, select Libraries >
Text Styles.

2. To add a new text style to the list, select Edit
> Add Text Style, or right-click in the text
style window and select Add Text Style.

3. To edit an existing text style, select it in the
list, then select Edit > Edit Text Style, or
right-click and select Edit Text Style. You can
also click inside the lower pane of the Text
Styles dialog.

4. In the Text Style Properties dialog, type a
name for the text style in the Name edit box.

5. From the Font drop box, select a font to use.
6. From the Font Style drop box, select a style

for the font. Choices can include Regular,
Italic, Bold, and Bold Italic.

7. In the Height edit box, specify the desired
text height.

8. Click the Color swatch to access the Color
dialog, where you can select a color for the
text.

9. Click OK to return to the Text Styles dialog.
10. To delete an existing text style, select it in the

list, then select Edit > Delete Text Style, or
right-click in the style window and select
Delete Text Style.

11. Click OK.

Customizing the Dimension
Styles Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add your own dimension styles to the
dimension styles library as well as edit and delete the
existing dimension styles.
To customize the dimension styles library:
1. If you have inserted dimensions in your

current project, you can access the dimension
styles library by selecting a dimension, then
right-clicking and selecting Change Style. If
you do not have dimensions inserted yet you
can select Settings > Current Dimension
Style and click Select in the Current
Dimension Style dialog.
For direct access to the dimension styles
library, select File > Catalogs > Library
Manager. In the Library Manager dialog,
select Libraries > Dimension Styles.

2. To add a new dimension style to the list,
select Edit > Add Dimension Style, or right-
click in the dimension style window and
select Add Dimension Style.

3. To edit an existing dimension style, select it
in the list, then select Edit > Edit Dimension
Style, or right-click and select Edit Dimen-
sion Style. You can also click inside the
lower pane of the Dimension Styles dialog.

4. In the Dimension Style Properties dialog,
type a name for the dimension style in the
Name edit box.

5. Define the dimension style.

6. To delete an existing dimension style, select it
in the list, then select Delete Dimension
Style, or right-click in the style window and
select Delete Dimension Style.

7. Click OK.



- 460 -

Dimension Style Properties
Anatomy of a Dimension

Dimension tab

Arrow Type. You can select the type of symbol you
want displayed at the ends of the dimension line.
Choose an arrow, dot or tick for your arrow type.

The properties below the Arrow Type selection
window (Extension Offset, Baseline Offset, etc.) vary
depending on the arrow type selected. As you make
different selections, the dimension updates in the
preview window.

Some of the common properties include:

Extension Offset. The distance between the end of
the extension line and the object being dimensioned.

Dimension Lap. The distance the dimension line
extends past the ends of the dimension. (The "ends" of
the dimension are where the dimension line and
extension lines intersect.)

Extension Lap. The distance the extension lines
extend past the dimension line.

Baseline Offset. The distance between dimensions
when the Baseline Dimension tool is used.
Leader tab

Arrow Type. You can specify the type of symbol you
want to display at the end of leaders. (Leaders are
used with the Text with Leader tool.) Choose an
arrow, dot or tick for your arrow type. 

The properties below the Arrow Type selection
window (Arrow Length, Landing Gap, Leader
Position, etc.) vary depending on the arrow type
selected. As you make different selections, the
dimension updates in the preview window.

Common properties include:

Landing Gap. The distance between the end of the
leader line and the object being annotated.

Leader Position. The justification of the leader in
relation to the text (choose Top, Middle or Bottom). For
example, a Top leader position aligns the leader with
the top of the text.
Text tab

Click to select a style for the dimension
text. A text style determines the font, font style, text
height and color of text.

Vertical Text Position
This is the vertical position of the dimension text
relative to the dimension line. 

Vertically Centered: Text is placed inside the
dimension line.

Horizontal Text: Forces the dimension text to always
be horizontal, regardless of the dimension line's angle.

Above Dimension Line: Text is placed above the
dimension line.

Distance: Distance between the text and the
dimension line when placing text above the
dimension line.

Horizontal Text Position
This is the position of the dimension text relative to
the ends of the dimension line. 

Centered: Centers the text inside the dimension line.
Distance from first end: Places the text a specific
distance from the first end of the dimension. Specify
the distance in the Distance edit box.

Distance from the second end: Places the text a
specific distance from the second end of the
dimension. Specify the distance in the Distance edit
box.
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Units
Override system units: Uses the unit of measure
specified in the Dimension Style Properties dialog
instead of the unit of measure specified in the
Program Settings.

Units\Distance: The units used for dimensions that
measure a distance.

Type: Choose from Feet-Inches, Millimeters,
Centimeters, Meters or Inches.

Precision: For Feet-Inches, the choices are whole
units (0, 1/2, 1/4 and so on). For metric units, the
choices are number of decimal places you can use.

Units\Angle: The units used for angular dimensions.
Type: Choose either Decimal Degrees or
Degrees/Minutes/Seconds.

Precision: Choose the number of decimal places you
would like angular dimensions to have (if using
Decimal Degrees).
Line Styles tab

Refers to the line styles of the dimension line,
extension lines and arrows. You can select a different
line style for the dimension line, extension lines and
arrows. A line style determines the pattern, color and
weight of a line.

To assign a different line style to a dimension
component, select the component in the left pane,
then click Select in the center pane to access the Line
Styles dialog.

Customizing the Line Styles
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

A line style defines the pattern, color and thickness of
a line. The line styles library contains a wide selection
of line styles that you can apply to elements, drafting
objects, electrical wiring and dimension styles. You
can access the line styles library by editing the
properties of an element, drafting object, wiring or
dimension style, or through the Libraries menu in the
Library Manager.

In the line styles library, line styles are listed in
groups so you can organize and find them easily. You
can add, rename and delete groups as needed. You

can add new line styles to the library, as well as edit
and delete existing line styles.
To access the line styles library through the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs

button on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Line Styles.

To access the line styles library through an
inserted element:
1. Select the element.

2. Right-click and select Properties.
3. In the properties dialog, select the Appear-

ance tab.

4. Click the Select button in the Linestyle area.
To access the line styles library through a drafting
object:
1. Select the drafting object (line, circle, etc.).

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

To access the line styles library through inserted
electrical wiring:
1. Select the wiring in your drawing.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

To access the line styles library by editing a
dimension style:
1. Select Settings > Dimension Styles. Or,

select a dimension in your drawing, then
right-click and select Change Style.

2. In the Dimension Styles dialog, Edit > Edit
Dimension Style.

3. In the Dimension Style Properties dialog,
select the Line Styles tab, then click Select.

To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.
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To rename a group:
1. Select the group in the upper pane.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
line styles.

To add or edit a line style:
1. In the upper pane, select the group that you

want to add the line style to, or that contains
the line style to edit.

2. To add a new line style, select Edit > Add
Line Style, or right-click and select Add Line
Style.

3. To edit an existing line style, select it in the
list, then select Edit > Edit Line Style, or
right-click and select Edit Line Style.

4. In the Line Style Properties dialog, define
the line style’s properties.

Name. Type a name for the line style as you
would like it to appear in the list of line
styles. 

Line Type. Click the browse button to select a
line type (continuous, dashed, etc.) from the
line type library. You can customize the line
types library if needed.

Line Weight. Click the browse button to
select a line weight (light, heavy, etc.) from
the line weight library. You can also
customize the line weights library.

Color. Click the color swatch to select a color
for the line from the Color dialog.

5. Click OK.
To delete a line style:
1. Select the line style to delete.

2. Select Edit > Delete Line Style, or right-click
and select Delete Line Style.
If the line style is being used by an element, a
dialog appears telling you this. You can click

Yes to view a list of elements using the line
style.

Customizing the Line Types
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Line type refers to the style of a line (dashed, dotted,
continuous, etc.). It is one of the properties of a line
style and a layer. The Line Types library contains a
list of pre-defined line types for your convenience.
You can add or edit line types to suit your needs.
To access the line types library:
1. Select File > Catalogs > Library Manager.

You can also access the line types library
while defining a line style or layer.

2. In the Library Manager dialog, select Librar-
ies > Linetypes.

To add a new line type:
1. Select Edit > Add Item, or right-click in the

Line Types window and select Add Item. A
new entry is added to the list.

To edit a line type:
1. Select the line type in the list.

2. In the Name edit box, type a name for the
line type as you would like it to appear in the
list of line types.

3. In the Definition edit box, edit the line type’s
definition. Lines are defined by a series of dis-
tances separated by commas. Each number
represents the length of either a line segment
or space. Positive numbers create a line seg-
ment of the specified length. Negative num-
bers create a space of the specified length. For
example, a dashed line may have a definition
like 1/4”, -1/4”.

4. Once you’ve edited the line type, click OK.
To delete a line type from the list:
1. Select the line type in the list.

2. Right-click and select Delete Item, or select
Edit > Delete Item.
Note: You cannot delete the existing, pre-
defined line types because they are being
used.
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Customizing the Line Weights
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Line weight refers to the thickness of a line, and is
one of the properties of a line style, as well as a layer.
You can add and edit line weights to suit your needs.
To access the line weights library:
1. Select File > Catalogs > Library Manager.

You can also access the line weights library
while defining a line style or layer.

2. In the Library Manager dialog, select Librar-
ies > Lineweights.

To add a new line weight:
1. Select Edit > Add Item, or right-click in the

Line Weight window and select Add Item. A
new entry is added to the list.

To edit a line weight:
1. Select the line weight in the list.

2. In the Name edit box, type a name for the
line weight as you would like it to appear in
the list of line weights.

3. In the Thickness edit box, type the desired
thickness for the line.

4. Once you’ve edited the line weight, click OK.
To delete a line weight from the list:
1. Select the line weight in the list.

2. Right-click and select Delete Item, or select
Edit > Delete Item.
Note: You cannot delete the existing, pre-
defined line weights because they are being
used.

Enabling/Disabling Line Weights
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, line weights are not displayed. All lines
are displayed using the same thickness. If you enable
the Show Line Weights option, line weights will
display in your drawing area as well as in printouts.
To enable or disable the display of line weights:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Linework area, check or uncheck the
Show Line Weights check box.

4. Click OK.

Customizing the Layers Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can add, edit, rename and delete layers in the
Layers Library. When you define a layer you can
specify its name, color, line type and line weight.
Layers defined in the Layers Library are saved to the
catalog and will be available in all projects. Layers can
be assigned to element components on the element's
Appearance property page. Layers are also used to
organize information in Worksheet View.
To access the layers library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs

button on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Layers.

To access the layers library through an element:
1. Double-click an element in your drawing or

in the catalog panel.

2. In the properties dialog, select the Appear-
ance tab.

3. Click the Layer drop box, and then select
Other in the layer list.

To access the layers library through the catalog
panel:
1. Right-click in the catalog panel and select

Library Manager.
2. In the Library Manager select Libraries >

Layers.
To add or edit a layer:
1. To create a new layer, click , or right-

click in the layer list and select Add. You can
also click and select Add. A
new layer called Layer 1 is added below the
currently selected layer.
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2. To edit an existing layer, select it in the list,
then click on the properties that you want to
change. These are described below.

Name. The name of the layer as you would
like it to appear in the list of layers. Double-
click to edit, or select it and click .

Color. The color of objects on the layer. Click
the box to display a list of colors. Select the
desired color, or select Other to access the
Color dialog.
Line Type. The style of line used to display
objects on the layer. Click the box to display a
list of line types. Select the desired line type,
or select Other to access the Line Types
dialog.

Line Weight. The weight of the line used to
display objects on the layer. Click the box to
display a list of line weights. Select the
desired line weight, or select Other to access
the Line Weights dialog.

To delete a layer:
1. Select the later to delete.

2. Click , or right-click and select
Delete.

Customizing the Light Source
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The light source library contains an assortment of
light sources, mainly fluorescent and incandescent
light bulbs, that can be applied to lighting fixtures.

You can customize the light source library by adding
and editing light sources. Most manufacturers of
lighting equipment provide downloadable .IES
photometric data files free of charge on their web sites
for use in lighting calculations. You can also define a
light as a Point or Spot light. Once you’ve added a
light source to your library, you can edit its intensity
and color if you want.

Light sources are listed in groups so you can organize
and find them easily. You can create, rename and
delete groups.
To access the light source library in the Library
Manager:

1. Select File > Catalogs > Library Manager, or
click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Light Sources.

To access the light source library through an
inserted light fixture:
1. Select the light fixture.

2. Right-click and select Properties, or select
Edit > Modify Elements > Properties.

3. In the Lights dialog, select the Lights tab.
4. Click Add or Edit to access the light source

library.
To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to rename.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
light sources.

To add or edit a light source:
1. Select the group you want to add the light

source to, or that contains the light source.

2. To add a new light source, select Edit > Add
Light, or right-click and select Add Light.

3. To edit an existing light source, select it in the
list, then select Edit > Edit Light, or right-
click and select Edit Light.

4. In the Light Source Properties dialog,
define the light source’s properties.

Name. Type a name for the light source as
you would like it to appear in the list of light
sources. 
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Type. Choose either IES, Point or Spot. IES
files are photometric data files provided by
lighting manufacturers for the purposes of
lighting calculations. A Point light spreads its
light out equally in all directions. A Spot
light spreads light in one direction from its
source to the target, and there is no light
behind the source. The spot light sheds its
light only within a limited cone that grows
wider as light moves further away from its
origin. A good example of a spot light is a
flashlight.

Load. If IES is selected as the type, click
Load to select an *.ies file to apply to the
light source. Many *.ies files can be found in
the program’s Lights folder.

Intensity (lumens). The level of brightness,
measured in lumens. Lumens measure how
much light you are getting from a bulb. More
lumens means a brighter light; fewer lumens
means a dimmer light. This value can be
edited for Point and Spot lights only.
Intensity scale. This is the intensity of the
light expressed as a percentage. For example,
if the light source is a 60 Watt bulb, a value of
50% would make the bulb function like a 30
Watt bulb.

Spot light cone angle. Available if the light
source type is set to Spot, this value
determines the width of the cone in which
light is spread. A wider angle means that the
light has a larger spread.

Color temperature. A measurement in
degrees kelvin that indicates the hue of a
light source. Color temperatures over 5,000K

are called cool colors (bluish white), while
lower color temperatures (2,700–3,000 K) are
called warm colors (yellowish white through
red).

Choose color. To change the color of the
light, click the color swatch and select a color
from the Color dialog.

5. Click OK.
To delete a light source:
1. Select the light source in the list.

2. Right-click and select Delete Light, or select
Edit > Delete Light, or just press the Delete
key on your keyboard.

Specifying the Location of the
Light Source Directory
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, light sources are located in the following
directory:

C:\ProgramData\Cadsoft\Envisioneer\Lights

If you move your Lights directory to another location
on your system, you will need to specify the location
of the Lights directory so that light sources can be
accessed by the program.
To specify the location of your light source
directory:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General pane, click on the Lights Dir-
ectory in the File Paths area.

3. Click Modify.
4. In the Browse For Folder dialog, locate the

folder containing your light sources, then
click OK.

5. Click OK in the Program Settings dialog.

Customizing the Door Leafs
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Door Leafs library contains door leafs that can be
applied to doors in the catalog or in your drawing.
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You can add, rename and delete door leaf groups,
and add new door leafs by importing a DWG, DXF,
SKP or 3DS drawing. You can also edit and delete
existing door leafs.

You can access the Door Leaf library by editing the
properties of a door, or through the Libraries menu in
the Library Manager.
To access the Door Leafs library through the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Door Leafs.

To access the Door Leafs library through an
inserted door:
1. Select the door in your drawing, then right-

click and select Properties.
2. Select the Properties tab, then in the Type

area, scroll over and select Custom.
To access the Door Leafs library through the
catalog:
1. Select a door in the catalog panel, then right-

click and select Edit Element.
2. Select the Properties tab, then in the Type

area, scroll over and select Custom.
To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
door leafs.

To add a new door leaf:

1. Select the group that you want to add the
door leaf to.

2. Select Edit > Add Door Leaf, or right-click
and select Add Door Leaf.

3. In the Door Leaf Properties dialog, click
Import New Leaf.

4. Use the Door Leaf Import Wizard to import
the door leaf. See Importing a Custom Door Leaf
on page 466.

To edit a door leaf:
1. Select the door leaf that you would like to

edit.

2. Select Edit > Edit Door Leaf, or right-click
and select Edit Door Leaf. See Editing Door
Leaf Properties on page 467.

To delete a door leaf:
1. Select the door leaf that you would like to

delete.

2. Select Edit > Delete Door Leaf, or right-click
and select Delete Door Leaf.

Importing a Custom Door Leaf
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can use the Door Leaf Import Wizard to import a
door leaf in DWG, DXF, SKP or 3DS format into the
Door Leafs library. Once imported, you can apply the
door leaf to any door in your drawing or catalog.
To import a custom door leaf:
1. Access the Door Leafs library.

2. Select the group that you want to add the
door leaf to, then select Edit > Add Door
Leaf, or right-click and select Add Door Leaf.

3. In the Door Leaf Properties dialog, click
Import New Leaf.
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4. In the Door Leaf Import Wizard, enter a
name for the new door leaf as you would like
it to appear in the library.

5. Specify whether the door leaf is to be a Door
Leaf or Cabinet Leaf. This ensures that the
leaf will be properly mapped to the object,
ensuring a realistic display in your drawing.

6. Click Select. In the Open dialog, select the
file type that you want to import (DWG,
DXF, SKP or 3DS), then locate and select the
desired file. When you click Open, a preview
of the door leaf appears in the preview pane.
You can click and drag in the preview pane
to rotate the door leaf, and right-click to
access various viewing options.

7. For DWG and DXF files, specify how you
want the components created by making a
selection from the drop box. You can choose
from Colors or Layers. For 3DS and SKP
files, the only selection available is Materials.

8. Click Next.
9. On the Orient your element screen, use the

arrows to rotate the door so that it will be ori-
ented correctly when inserted in a drawing.
In most cases you want to make sure that the
door is oriented vertically and sits flush with
the wall.

10. Click Next.

11. The next screen lists the object’s individual
components. Specify which components you
want to display or hide in 3D by clicking the
appropriate eye icons.

Component is displayed 

Component is not displayed

Enabling the Show only selected
component check box displays only the
currently selected component in the object
preview. This helps you distinguish between
the object's individual components.

To rename a component, double-click it, then
type the new name and press Enter.

12. Click Finish.

Editing Door Leaf Properties
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit the name, type and component
properties of a door leaf in the Door Leafs library.
To edit a door leaf:
1. Access the Door Leafs library.

2. In the Library Manager dialog, select the
door leaf that you would like to edit.

3. Right-click in the Door Leafs window and
select Edit Door Leaf. Or, select Edit > Edit
Door Leaf.

4. Make your changes in the Door Leaf
Properties dialog.
Name. The name of the door leaf as it
appears in the library.

Leaf Type. Select either Door Leaf or
Cabinet Leaf to specify how the leaf will be
used. This ensures that the leaf will be
properly mapped to the object to which it
will be applied.

Components. Specify which components you
want to display or hide in 3D by clicking the
appropriate eye icons.

Component is displayed 

Component is not displayed

To rename a component, double-click it, then
type the new name and press Enter.

5. Click OK.
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Customizing the Assemblies
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The assemblies library contains a variety of pre-
defined assemblies that you can customize.
Assemblies contain parts and other non-graphical
items that are associated with elements, but are not
physically present in the drawing. For example, a
door may have a Lock Set assembly attached to it
which includes a door lock and a set of hinges. A wall
may have a Drywall assembly that includes drywall
sheets, drywall screws, and paint. If an element has
an assembly attached to it in its properties, the parts
in that assembly will be reported in the project
estimate.

Assemblies are organized by element in the
assemblies library. You can add, rename and delete
groups as needed. You can add new assemblies to the
library, as well as edit and delete existing assemblies.

You can access the assemblies library through an
element's Quantity property page, or through the
Library Manager.
To access the assemblies library through the
Library Manager:
To access the assemblies library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Assembly.

To access the assemblies library through an
element's properties:
1. Select an element in your drawing, then

right-click and select Properties. Or, select
File > Catalogs > Element Manager, then
select an element.

2. In the properties dialog, select the Quantity
tab.

3. In the Assemblies area, click .
To add a group:

1. Right-click an existing group and select Add
Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
assemblies.

To add a new assembly:
1. Select the group that you want to add the

assembly to.

2. Select Edit > Add Assembly, or right-click
and select Add Assembly. See Defining an
Assembly on page 468.

To edit an assembly:
1. Select the assembly that you would like to

edit.

2. Select Edit > Edit Assembly, or right-click
and select Edit Assembly. See Defining an
Assembly on page 468.

To delete an assembly:
1. Select the assembly that you would like to

delete.

2. Select Edit > Delete Assembly, or right-click
and select Delete Assembly.

Defining an Assembly
Building Essentials | Construction Suite
Assemblies are parts or non-graphical items that are
linked to an element, but do not exist in the drawing.
For example, a door may have a Lock Set assembly
attached to it which includes a door lock and a set of
hinges. A wall may have a Drywall assembly that
includes drywall sheets, drywall screws, and paint. If
an element has assemblies attached to it in its
properties, those assemblies will be reported in the
project estimate.
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Assemblies are stored in a customizable assemblies
library. Defining an assembly involves selecting an
element from the catalog, then specifying a formula to
quantify it. For example, if you wanted to add a dead
bolt to a door assembly, you would choose the Dead
Bolt from the Parts category in the catalog, then
specify a simple Count formula to quantify it since it
is a single item of a preset size, and there is one per
door.
To define an assembly in the assemblies library: 
1. Access the assemblies library. You can do this

by selecting File > Catalogs > Library Man-
ager and then Libraries > Assembly. From
the Filter drop box, select the element type
for which you want to define assemblies. You
can also access the library from an element's
Quantity page. Right-click the element and
select Properties, then select the Quantity

tab. in the Assemblies area.

2. In the Groups pane of the assemblies library,
select the group that you want to add an
assembly to, or that contains the assembly
that you want to edit.

3. If you want to create a new assembly, select
Edit > Add Assembly, or right-click in the
Assembly pane and select Add Assembly. If
you want to edit an existing assembly, select
the assembly in the Assembly pane, then select
Edit > Edit Assembly or right-click and
select Edit Assembly.

4. Define the assembly in the Edit Assembly
dialog.

To edit the name of the assembly, type or edit
the name in the Name edit box.
To add an item to the assembly, click

, then make a selection from
the Catalog Access dialog. For example, if

you wanted to add a dead bolt to a door
assembly, you would select Parts from the
filter at the top of the Catalog Access dialog,
then select Dead Bolt in the Door Hardware
folder.

To remove an item from the assembly, select

the item in the list, then click .

To define a formula for calculating the
quantity of the item, click in the item's
Calculated Quantity field, then click . For
items with a single count, such as a dead bolt,
you can simply select the 'Count' variable in
the Define Formula dialog. For items which
are quantified differently, you will need to
select a different variable or build a formula
that quantifies the item correctly. For
example, for wall insulation you might select
the 'Exterior Wall Area' variable so that the
quantity of insulation is reported in terms of
square feet or square meters. See Specifying
Formulas on page 368.

The unit of measure in the Units field is the
unit of measure that will appear after the
calculated quantity in the project estimate.
This is taken from the Unit of Measure field
on the part's Quantity property page.

To assign a usage to the item, click in the
Usage field and make a selection from the
drop box. Choices are From Part, From
Parent, and Library. If From Part is selected,
the Usage assigned to part on its Quantity
property page is used. If From Parent is
selected, the Usage assigned to the element to
which the assembly is attached will be used.
If you select Library in the Usage field, the
Usages dialog appears and you can assign
any usage you want to the item.

To assign a phase to the item, click in the
Phase field and make a selection from the
drop box. The choices for Phase are the same
as the choices for Usage: From Part, From
Parent and Library.

5. When you have finished defining the
assembly, click OK to save your changes.
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Tracing and Replacing Elements
in a Catalog
Pro Architect | Building Essentials | Construction Suite

Items such as assemblies and infill configurations
reference one or more elements in the catalog. You
can use the Trace Element tool to see where a
particular element is referenced, and swap out the
element with a different one in that item's definition.
For example, let's say that all of the batt insulation
assemblies in the catalog reference Fiberglass
Insulation, but you want to use Mineral Wool
Insulation for all of your batt insulation applications.
You could use the Trace Element tool to quickly find
all items that reference Fiberglass Insulation, then
replace all or selected references with Mineral Wool
Insulation.

To trace an element:
1. Select File > Catalogs > Element Manager,

or click the down arrow next to the Catalogs

button on the Standard toolbar and select
Element Manager. You can also right-click
an element in the catalog panel and select Ele-
ment Manager.

2. In the Element Manager, locate the element
that you want to trace, then right-click the ele-
ment and select Trace Element.

3. If the element is not referenced in any
definition (assembly, infill configuration, etc.),
a 'No references found' message is displayed.

If the element can be traced to one more item
definitions, the Trace Element dialog
appears, and displays a list of items that
reference the element:

4. To replace the element everywhere that is
referenced in the catalog, click the browse
button and select the desired replacement
element in the Replace dialog. Then, click
Replace All. When prompted, confirm your
choice to globally replace the element.

To replace the element in a specific item only,
double-click the item in the list to display an
edit dialog for that item. For example, if you
select an assembly, the Edit Assembly dialog
appears. In the edit dialog, click the browse
button next to the element's name and select
the desired replacement element in the
Catalog Access dialog. Click OK to update
that item definition.

Note: When using the Trace Element tool to replace
element references, the replacement applies to the
catalog (and future element insertions) only. It does
not apply to elements that you have already
inserted in your drawing.
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Customizing the Usages Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

An element's usage can help make it more clear what
the element is to be used for. For example, one
particular member could be used for Basement
Beams, while another might be used for Studs. The
usages library contains various usages that you can
assign to elements on their Quantity property page.
Usages may appear in estimates and can be used as a
sort key in report templates. You can add, edit and
delete groups and usages in the usages library.

You can access the usages library through an
element's Quantity property page, or through the
Library Manager.
To access the usages library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Usages.

To access the usages library through an element's
properties:
1. Select an element in your drawing, then

right-click and select Properties. Or, select
File > Catalogs > Element Manager, then
select an element.You can also select an ele-
ment in the catalog panel and then right-click
and select Edit Element, or simply double-
click the element.

2. In the properties dialog, select the Quantity
tab.

3. Click next to the Usage edit box.
To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:

1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
usages.

To add a new usage:
1. Select the group that you want to add the

usage to.

2. Select Edit > Add Usage, or right-click and
select Add Usage.

3. In the Usage Properties dialog specify a
name and ID for the usage, then click OK.

To edit a usage:
1. Select the usage that you would like to edit.

2. Select Edit > Edit Usage, or right-click and
select Edit Usage.

3. Edit the properties of the usage in the Usage
Properties dialog, then click OK.

To delete a usage:
1. Select the usage that you would like to delete.

2. Select Edit > Delete Usage, or right-click and
select Delete Usage.

Customizing the Phases Library
Building Essentials | Construction Suite
The phases library contains various phases that you
can assign to elements on their Quantity property
page. A phase refers to a stage in the building
process. Examples are Foundation, Exterior
Construction, and Exterior Finish. Phases are often
reported in estimates, and can be used as sort keys in
report templates.

You can access the phases library through an
element's Quantity property page, or through the
Library Manager. You can customize the phases
library by adding, editing and deleting groups and
phases.
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To access the phases library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Phases.

To access the phases library through an element's
properties:
1. Select an element in your drawing, then

right-click and select Properties. Or, select
File > Catalogs > Element Manager, then
select an element. You can also select an ele-
ment in the catalog panel and then right-click
and select Edit Element, or simply double-
click the element.

2. In the properties dialog, select the Quantity
tab.

3. Click next to the Phase edit box.
To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
phases.

To add a new phase:
1. Select the group that you want to add the

phase to.

2. Select Edit > Add Phase, or right-click and
select Add Phase.

3. In the Phase Properties dialog specify a
name and ID for the phase, then click OK.

To edit a phase:

1. Select the phase that you would like to edit.

2. Select Edit > Edit Phase, or right-click and
select Edit Phase.

3. Edit the properties of the phase in the Phase
Properties dialog, then click OK.

To delete a phase:
1. Select the phase that you would like to delete.

2. Select Edit > Delete Phase, or right-click and
select Delete Phase.

Customizing the Categories
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The categories library contains a variety of categories
that you can assign to elements on their Quantity
property page. Categories are sometimes used in
estimates, and can also be used as a sort key in report
templates.

You can add, edit and delete groups and categories in
the categories library. You can access the categories
library through an element's Quantity property page,
or through the Library Manager.
To access the categories library through the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Categories.

To access the categories library through an
element's properties:
1. Select an element in your drawing, then

right-click and select Properties. Or, select
File > Catalogs > Element Manager, then
select an element.You can also select an ele-
ment in the catalog panel and then right-click
and select Edit Element, or simply double-
click the element.

2. In the properties dialog, select the Quantity
tab.

3. Click next to the Category edit box.
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To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
categories.

To add a new category:
1. Select the group that you want to add the cat-

egory to.

2. Select Edit > Add Category, or right-click
and select Add Category.

3. Specify a name for the category, then click
OK.

To edit a category:
1. Select the category that you would like to

edit.

2. Select Edit > Edit Category, or right-click
and select Edit Category.

3. Edit the name of the category, then click OK.
To delete a category:
1. Select the category that you would like to

delete.

2. Select Edit > Delete Category, or right-click
and select Delete Category.

Customizing the Units of Meas-
ure Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Units of Measure library contains a variety of
units that you can assign to elements on their
Quantity property page. There are units for
measuring single items, area, volume and length.

Units are reported for each element in estimates to
indicate how they are being quantified. For example,
doors are purchased as individual items and will have
the 'Each' unit, while something like insulation may
be measured in Square Feet.

Each unit of measure has a set of properties that
determine how it quantifies the material, including a
Conversion Factor for converting measurements from
millimeters to the unit you want, Unit Format
(Decimal, Feet & Inches, etc.) and a level of Precision.
The program will perform the necessary calculations
and conversions for you when you generate the
project estimate, resulting in an accurate material
take-off.

You can add, edit and delete groups and units of
measure in the Units of Measure library. You can
access the units of measure library through an
element's Quantity property page, or through the
Library Manager.
To access the Units of Measure library through the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Units of Measure.

To access the Units of Measure library through an
element's properties:
1. Select an element in your drawing, then

right-click and select Properties. Or, select
File > Catalogs > Element Manager, then
select an element. You can also select an ele-
ment in the catalog panel and then right-click
and select Edit Element, or simply double-
click the element.

2. In the properties dialog, select the Quantity
tab.

3. Click next to the Units edit box.
To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.
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To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
units of measure.

To add a new unit of measure:
1. Select the group that you want to add the

unit to.

2. Select Edit > Add Unit of Measure, or right-
click in the lower pane and select Add Unit of
Measure. The Unit of Measure dialog
appears:

3. In the Unit of Measure dialog, define the
unit's properties.

Name. The name of the unit of measure as it
will appear in the Unit of Measure library
and in the Units field in the project estimate.
This is the text that appears after the
numerical value (e.g. SQFT).

Quantify. Select either Count, Length, Area
or Volume to specify what you are
quantifying.

Unit Scale. Specify the factor that will
convert millimeters to the desired unit of
measurement. For example, if you wanted to
quantify a material in square inches, you
would enter a conversion factor of
0.0015500031, because 1 square millimeter =
0.0015500031 square inches.

Unit Format. Select the format in which you
want the quantity measurement to appear.

Select either Decimal, Inches, Feet-Inches,
or Feet-Inches-Sixteenths.

Note: Measurements are always calculated
in millimeters initially, regardless of what
is selected in the Unit Format field. If you
want to quantify a material using a
different unit, you must specify a
Conversion Factor in the unit's properties.

Precision. Select a level of precision for the
measurement. For example, selecting a
precision of #’-# #/16” sets the level of
precision to 1/16th of an inch when
measuring distances in feet and inches.

4. Click OK.
To edit a unit of measure:
1. Select the unit of measure that you would

like to edit.

2. Select Edit > Edit Unit of Measure, or right-
click and select Edit Unit of Measure.

3. Edit the properties in the Unit of Measure
dialog, then click OK. For more information
about the available properties, see the section
on adding a unit of measure to the library
(above).

To delete a unit of measure:
1. Select the unit of measure that you would

like to delete.

2. Select Edit > Delete Unit of Measure, or
right-click and select Delete Unit of Measure.

Customizing the Profiles Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The profiles library contains a variety of custom
profiles that can be applied to members and columns.

In the profiles library, profiles are listed in groups so
you can organize and find them easily. You can add,
rename and delete groups as needed. You can add
new profiles to the library, as well as edit and delete
existing profiles.

You can access the profiles library by editing the
properties of a member or column, or through the
Libraries menu in the Library Manager.
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To access the profiles library through the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Profiles.

To access the profiles library through an inserted
member or column:
1. Select the column or member in your draw-

ing, then right-click and select Properties.
2. In the Type area of the Basic property page,

scroll over and select Custom.
3. Click the Select Profile button at the bottom

of the dialog.
To access the profiles library through the catalog:
1. Select the column or member in the catalog

panel, then right-click and select Edit Ele-
ment.

2. In the Type area of the Basic property page,
scroll over and select Custom.

3. Click the Select Profile button at the bottom
of the dialog.

To add a group:
1. Right-click an existing group and select Add

Group, or select Edit > Add Group. An entry
is added to the list.

2. Type a name for the group, then press
ENTER.

To rename a group:
1. Select the group to edit.

2. Right-click and select Rename Group, or
select Edit > Rename Group.

3. Type the new name and press ENTER.
To delete a group:
1. Select the group to delete.

2. Right-click and select Delete Group, or select
Edit > Delete Group.
Note: A group cannot be deleted if it contains
profiles.

To add a new profile:
1. Select the group that you want to add the pro-

file to.

2. Select Edit > Add Profile, or right-click and
select Add Profile. See Creating Custom Pro-
files on page 475.

To edit a profile:
1. Select the profile that you would like to edit.

2. Select Edit > Edit Profile, or right-click and
select Edit Profile. See Editing a Custom Profile
on page 476.

To delete a profile:
1. Select the profile that you would like to

delete.

2. Select Edit > Delete Profile, or right-click and
select Delete Profile.

Creating Custom Profiles
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can create your own profiles for members,
columns and strip footings. To create a custom profile
you simply define the length and angle of each of the
profile’s segments. Segments can be straight or
curved.
To add a profile to the profiles library:
1. Access the profiles library.

2. In the Profiles dialog, right-click in the Pro-
files window and select Add Profile. Or,
select Edit > Add Profile.

3. In the Profile Properties dialog, enter a
name for the profile in the Name edit box.
You are now ready to start defining each of
the profile’s segments. Each segment is auto-
matically joined to the previous one to help
you form the shape.

4. To draw a line, click in the Properties
area, then enter a length in the Distance edit
box and a direction in the Angle edit box.
Click Insert to insert the line in the preview
window.

Note that the segment lengths you specify are
simply units (not inches or millimeters) and
have no relation to the actual member size —
they determine how long one segment is in
relation to another.
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5. To draw an arc, click . Enter a length for
the arc in the Distance edit box. This is the
distance between the start point and end
point. Enter a direction in the Angle edit box.
Enter the radius for the curve of the arc in the
Radius edit box, then select either Left or
Right from the Arc Direction drop box to spe-
cify the direction in which you want the arc
to curve from the start point. Click Insert to
insert the arc in the preview window.

6. To remove the last segment created, click
Remove. Clicking Remove again continues
to remove segments in reverse sequence.

7. To close the shape, click Close. A line is
drawn from the end point of the last segment
created to the start point of the first segment
created.

8. When the profile is complete, click OK.

Exporting a Polyline to the Pro-
file Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can export any polyline or polygon that you have
drawn or imported in Worksheet View to the profile
library. You can then apply that profile to any
member in your drawing or in the catalog. This tool is
ideal for creating custom baseboards, crown
moulding, chair rail and other types of trim, or any
custom member.

Many moulding and millwork companies offer
downloadable CAD drawings of their trim profiles on
the Internet. You can import these into Envisioneer
using the Import CAD File tool in Worksheet View
provided they are in DWG or DXF format.
To export a polyline to the profile library:
1. In Worksheet View, draw a polyline in the

desired profile shape, or import a profile
using the Import CAD File tool. Note that the
shape must be closed and cannot intersect
itself. If the profile will be used for trim,
make sure that the flat side is on the left and
the shaped side is on the right.

2. In Worksheet View, select File > Catalogs >
Export Polyline to Profile Library.

3. Click on the polyline that you want to export
to the profile library. Note that if the polyline
is one that you imported, you may need to
explode it first.

4. In the Profile Properties dialog, type a name
for the profile in the Name edit box.

5. Click OK. The profile is added to the Imported
Profiles group in the profile library.

6. In the Profile Library dialog, click OK.

Editing a Custom Profile
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can edit existing profiles by removing and
redrawing segments.
To edit an existing profile:
1. Access the profiles library.

2. In the Profiles dialog, select the profile that
you would like to edit.

3. Right-click in the Profiles window and select
Edit Profile. Or, select Edit > Edit Profile.

4. Make your changes in the Profile Properties
dialog. Note that you cannot select specific
segments to edit. You can remove segments
in reverse sequence (starting with the last one
drawn) and then insert new segments.

5. Click OK.

Note: Due to the nature in which profiles are
created, it may be easier to create a new profile
rather than edit an existing one.
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Customizing the Wall Span
Table Library
Building Essentials | Construction Suite
The Wall Span Table Library contains tables that
determine which head/sill/jamb configurations are to
be used to frame wall opening spans of varying sizes.
Each table contains a list of opening span sizes (2', 4',
6', etc.) with a specific head/sill/jamb configuration
assigned to each one.

You can add, edit and delete span tables in the Wall
Span Table Library.

To access the Wall Span Table Library from the
Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Framing Libraries > Wall Opening Span
Table.

To access the Wall Span Table Library from your
building location settings:
1. Select Settings > Building Locations, or

click on the View Control toolbar.

2. In the Building Locations dialog, click in the
Framing Options column.

3. In the Location Framing Options dialog,
double-click the span table listing.

To access the Wall Opening Span Table Library
from an inserted opening (in Framing Mode):
1. Go into Framing Mode (View > Framing

Mode On/Off).

2. Double-click an opening, or select the open-
ing and then right-click and select
Properties.

3. In the Edit Opening Configurations dialog,
enable the Use custom span table radio but-
ton, and then click the Select span table but-
ton.

To edit an existing span table:
1. Double-click the span table in the list, or

select the span table and select Edit > Edit
Wall Span Table Configuration, or right-
click and select Edit Wall Span Table Con-
figuration.

2. Edit the configuration in the Wall Framing
Span Table dialog. See Defining a Wall Open-
ing Span Table on page 477.

To add a new span table to the library:
1. Select Edit > Add Wall Span Table Con-

figuration, or right-click in the span table
pane and select Add Wall Span Table Con-
figuration.

2. Define the table in the Wall Framing Span
Table dialog. See Defining a Wall Opening
Span Table on page 477.

To delete a span table from the library:
1. Select the table to delete.

2. Select Edit > Delete Wall Span Table Con-
figuration, or right-click and select Delete
Wall Span Table Configuration.

To view a span table without editing it:
1. Select the table to view.

2. Select Edit > View Wall Span Table Con-
figuration, or right-click and select View Wall
Span Table Configuration.

Defining a Wall Opening Span
Table
Building Essentials | Construction Suite
Wall openings are framed according to wall opening
span tables that determine which head/sill/jamb
configurations are to be used for opening spans of
varying sizes. A span table contains a list of opening
sizes (2', 4', 6', etc.) and the head/sill/jamb
configuration that is to be used for each size.

Span tables are stored in the Wall Opening Span
Table Library. Every building location in your model
has a span table assigned to it. You can select a
custom span table to use for individual walls in your
model, or for individual openings.
To define a wall opening span table:
1. Open the Wall Opening Span Table Library,

and then select either the Add Wall Span



- 478 -

Table Configuration or Edit Wall Span
Table Configuration tool.

2. In the Wall Framing Span Table dialog, spe-
cify a name for the table in the Name edit box
as you would like it to appear in the Wall
Opening Span Table Library.

3. To add a span to the table, select the span in
the list that you want the new one to come

after, then click . A new span is
added below the currently selected one. By
default, its width will be an increment higher
than the previous one. For example, if you
select a 3' foot span in the list and then add a
new one, the newly added span will have a
width of 4'. You can edit this value if you
want. When you edit a span's width value,
the span automatically moves to the correct
position in the list to keep the list ordered.

To select a head/sill configuration for the
span, simply click the currently assigned
head/sill configuration and select the desired
one from the drop list. If you want to add,
edit or view a head/sill configuration, click
the browse button next to the current

head/sill selection to access the Head Sill
Jamb Library.

4. To edit an existing span you can adjust its
width value or assign a different head/sill con-
figuration to it by clicking on the currently
assigned configuration and selecting the
desired configuration from the drop list.

5. To remove a span from the table, select the

span, then click .

Customizing the Head/Sill/Jamb
Library
Building Essentials | Construction Suite
The Head/Sill/Jamb Library contains head/sill/jamb
configurations that can be used to frame openings in
walls. Head/sill/jamb configurations are used in wall
span tables which determine how openings of various
sizes should be framed.

A head/sill/jamb configuration determines what
members are used for the king studs, jack studs,
header, cripples and window sill, as well as each
member's position, alignment, etc.

You can add, edit and delete configurations in the
Head/Sill/Jamb Library.

To access the Head/Sill/Jamb Library in the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
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Library Manager.
2. In the Library Manager, select Libraries >

Framing Libraries > Head Sill Jamb Con-
figuration.

To access the Head/Sill/Jamb Library through an
inserted opening (in Framing Mode):
1. Go into Framing Mode (View > Framing

Mode On/Off).

2. Double-click an opening, or select the open-
ing and then right-click and select
Properties.

3. In the Edit Opening Configurations dialog,
select the Use custom head sill jamb con-
figuration radio button, then click the Select
configuration button.

To add a configuration to the Head/Sill/Jamb
Library:
1. Select Edit > Add Head Sill Jamb Con-

figuration, or right-click an existing con-
figuration and select Add Head Sill Jamb
Configuration.

2. Define the configuration in the Head Sill Con-
figuration dialog. See Defining a
Head/Sill/Jamb Configuration on page 479.

To edit a configuration in the Head/Sill/Jamb
Library:
1. Double-click the configuration in the list, or

select the configuration in the list and select
Edit > Edit Head Sill Jamb Configuration, or
right-click and select Edit Head Sill Jamb
Configuration.

2. Edit the configuration in the Head Sill Con-
figuration dialog. See Defining a
Head/Sill/Jamb Configuration on page 479.

To delete a configuration in the Head/Sill/Jamb
Library:
1. Select the configuration to delete.

2. Press the Delete key on your keyboard, or
select Edit > Delete Head Sill Jamb Con-
figuration, or right-click and select Delete
Head Sill Jamb Configuration.

To simply view a configuration without editing it:
1. Select the configuration to view.

2. Select Edit > View Head Sill Jamb Con-
figuration, or right-click and select View
Head Sill Jamb Configuration.

Defining a Head/Sill/Jamb Con-
figuration
Building Essentials | Construction Suite
Used in framing a wall opening, a head/sill/jamb
configuration determines what members are used for
the king studs, jack studs, headers and window sill, as
well as each member's position, alignment, etc. It also
defines the cripple regions above and below the
opening.

Head/sill/jamb configurations are stored in the
Head/Sill/Jamb Library, and are used to define wall
span tables.
To define a head/sill/jamb configuration:
1. Access the Head/Sill/Jamb Library, then

choose either the Add Head Sill Jamb
Configuration or Edit Head Sill
Configuration tool.

2. To edit a member in the configuration, select
it in the Members pane on the left side of the
Head Sill Configuration dialog (e.g. Left King
Stud or Header).

3. To add a new member to the configuration,
click . In the Add Member dialog,
type a name for the member in the top edit
box.

If the member is not part of the cripple
region, enable the Add member radio button,
and then select an orientation (Horizontal or
Vertical) from the lower edit box. This
determines whether the member is oriented
horizontally or vertically in the opening
frame.
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If you are adding a cripple region, enable the
Cripple region radio button. Note: Cripples
are defined as an area of members rather than
as individual members.

4. To add a new member by copying an existing
one, select the member to copy, then click

.

5. To remove a member from the configuration,
select the member to delete, then click

.

6. Define the member in the Parameters pane.
The settings vary depending on the type of
member. Settings are described below.
Opening Members (King studs, Jack studs,
Headers, Sill)

- General -

Name. The name of the member as it appears
in the configuration's list of members (e.g.
Left King Stud or Header 1).

Orientation. The direction of the member in
the frame (Horizontal or Vertical). A header
would have a horizontal orientation, while a
king stud would have a vertical orientation.

Use member from. To use the member type
assigned to the wall on the wall's Framing
property page, select Wall Properties. To use
a specific member from the member library,
select Member Library, then make a selection
from the Catalog Access dialog. The latter
option overrides the Framing Member
selection on the wall's Framing property
page.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected on the wall's Framing
property page. If Member Library is selected in

the 'Use member from' field, the Member
field displays the member type to be used (as
selected from the Member library). To select a
different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the member about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°).

- Quantity Info -

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

- Position Along Wall/Position Vertically-

Anchor to. The component to which the
member is anchored when looking at the
member's position along the length of the
wall (if it is vertical) or vertically in the wall
(if it is a horizontal). For example, a Left King
Stud is typically anchored to the Left Jack
Stud. The header, jack studs and window sill
are typically anchored to the opening since
they are the members that form the opening.

Alignment. The way in which the member is
aligned with the anchor member/component.
For example, if a Left King Stud is anchored
to the Left Jack Stud, and has a 'Rt. to Lt.'
alignment, this means that the right side of
the king stud is anchored to the left side of
the jack stud. If a Header is anchored the
opening and has a 'Bot. to Top' alignment,
this means that the bottom of the header is
anchored to the top of the opening. To
change the alignment, click in the Alignment
field, then click to display the Member
Alignment dialog.
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Use the sliders to adjust the position of the
member relative to the anchor component or
relative to the alignment line.

Shift. The distance the member is shifted
from its anchor position. A positive value
shifts the member to the right (for vertical
members) or up (for horizontal members),
while a negative value shifts the member to
the left or down depending on its orientation.

- Position Front to Back -

Anchor to. The component to which the
member is anchored when looking at the
member's position within the width of the
wall (from the front of the wall frame to the
back). In other words, the member's position
is relative to the anchor component's position.
Most members except for the window sill are
anchored to the Wall Core, which means their
position inside the frame is relative to the
wall core. You can anchor a member to a
specific component of the wall core, such as
the top plate or bottom plate, or to another
member in the opening frame.

Note that "wall core" refers to the
configuration of studs, top plate, bottom plate
and very top plate as a whole.

Alignment. The way in which the member is
aligned with the anchor component. For
example, if a king stud is anchored to the
core, and has a 'Mid. to Mid.' alignment, this
means that the middle of the king stud lines
up with the middle of the wall core. A 'Mid.
to Fnt.' alignment would mean that the

middle of the king stud lines up with the
front of the wall core when looking at the
wall frame face-on. If the window sill is
anchored to the header, and has a 'Fnt. to
Fnt.' alignment, this means that the front of
the window sill lines up with the front of the
header.

To change the alignment, click in the
Alignment field, then click to display the
Member Alignment dialog. Use the sliders to
adjust the position of the member and/or
anchor component to achieve the alignment
you want between the front and back of the
wall frame.

Shift. The distance the member is shifted
toward the front or back of the wall frame
from its anchor position. A positive value
shifts the member toward the back, while a
negative value shifts it toward the front.

- Top/Bottom End or Left/Right End -

The labels of the bottom two sections depend
on whether the member is oriented
horizontally or vertically. A vertical member
will display 'Top End' and 'Bottom End',
while a horizontal member will display 'Left
End' and 'Right End'.

Anchor to. The component to which the end
of the member is attached. For example, the
top of a king stud is typically anchored to the
top plate. The left end of a header is usually
anchored to the left king stud.

Align at anchors. The point on the anchor
component to which the member end
extends. For vertical members the selections
are Bottom, Center and Top. For horizontal
members the selections are Left, Center and
Right. For example, if the bottom of a king
stud is anchored to the bottom plate, and has
a 'Top' alignment, this means that the bottom
of the king stud sits on the top face of the
bottom plate. If it had a 'Bottom' alignment, it
would extend down to the bottom face of the
bottom plate.
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Extend. The distance the member end is
shifted from its anchor point. For example, if
your king stud were anchored to the bottom
of the bottom plate but you wanted to raise
the end of the stud up by 1/4", you would
enter 1/4 in the Extend field. A positive value
shifts the member end upward or to the right,
while a negative value shifts it downward or
to the left from its anchor point (depending
on its orientation).
Cripple Region

- General -

Name. The name of the member as it appears
in the configuration's list of members (e.g.
Upper Cripple).

Double cripple ends. Inserts double cripple
members at each end of the cripple region.

- Quantity Info -

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

- Top extent -

Anchor to. The component to which the top
of the cripple region is anchored. Typically
the top of an upper cripple region will be
anchored to the top plate. The top of a lower
cripple region is usually anchored to the sill.

Alignment. The part of the anchor member to
which the top of the cripple region extends. If
the top of an upper cripple region is
anchored to the top plate, and a Bottom
alignment is selected, the top of the cripple
region will be aligned with the bottom of the
top plate. Other choices are Center and Top.

Shift. The distance the top of the cripple
region is shifted from its anchor position. A
positive value shifts it up, and a negative
value shifts it down.

- Bottom extent -

Anchor to. The component to which the
bottom of the cripple region is anchored.
Typically the bottom of an upper cripple
region is anchored to the header. The bottom
of a lower cripple region is usually anchored
to the bottom plate.

Alignment. The part of the anchor member to
which the bottom of the cripple region
extends. If the bottom of an upper cripple
region is anchored to the header, and a Top
alignment is selected, the bottom of the
cripple region will be aligned with the top of
the header. Other choices are Center and
Bottom.

Shift. The distance the bottom of the cripple
region is shifted from its anchor position. A
positive value shifts it up, and a negative
value shifts it down.

- Left extent -

Anchor to. The component to which the left
end of the cripple region is anchored.
Typically the left end of an upper cripple
region is anchored to the Left King Stud, and
the left end of a lower cripple region is
anchored to the Left Jack Stud.

Align at anchors. The point on the anchor
component to which the left end of the
cripple region extends. Choices are Left, Right
and Center. For example, if the left end of an
upper cripple region is anchored to the Left
King Stud, and a Right alignment is selected,
the left end of the cripple region will extend
to the inside face of the King Stud. If a Left
alignment were selected, the cripple region
would extend to the outside of the King Stud.

Extend. The distance the cripple region end
is shifted from its anchor point. A positive
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value shifts it right, and a negative value
shifts it left.

- Right extent -

Anchor to. The component to which the right
end of the cripple region is anchored.
Typically the right end of an upper cripple
region is anchored to the Right King Stud,
and the right end of a lower cripple region is
anchored to the Right Jack Stud.

Align at anchors. The point on the anchor
component to which the right end of the
cripple region extends. Choices are Left, Right
and Center. For example, if the right end of an
upper cripple region is anchored to the Right
King Stud, and a Left alignment is selected,
the right end of the cripple region will extend
to the inside face of the King Stud.

Extend. The distance the cripple region end
is shifted from its anchor point. A positive
value shifts it right, and a negative value
shifts it left.

Customizing the Wall Infill
Library
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Wall Infill Library contains wall infill
configurations in both wood and steel that determine
how the infill of a wall should be framed. Infill refers
to the material that fills the volume of a framed wall
— studs, top plate, very top plate, bottom plate and
blocking. An infill configuration determines what
type of member is used for the infill, the spacing
between studs, and the position and alignment of
each component in the frame.

Each building location has an infill configuration
assigned to it that determines how walls on each
location are to be framed. You can override this
setting for individual walls in your model by
applying a custom infill configuration to a wall in
Framing Mode.

You can add, edit and delete infill configurations in
the Wall Infill Library.

To access the Wall Infill Library from the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Framing Libraries > Wall Framing Infill.

To access the Wall Infill Library from your building
location settings:
1. Select Settings > Building Locations, or

click on the View Control toolbar.

2. In the Building Locations dialog, click in the
Framing Options column.

3. In the Location Framing Options dialog,
double-click the Infill configuration item.

To access the Wall Infill Library from an individual
wall (in Framing Mode):
1. Go into Framing Mode (View > Framing

Mode On/Off).

2. Double-click a wall, or select the wall and
then right-click and select Properties.

3. In the Edit Infill Configuration dialog enable
the Use custom infill configuration radio
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button, then click the Select configuration
button.

To create a new infill configuration:
1. In the Infill Configuration dialog, select Edit

> Add Wall Infill Configuration, or right-click
in the infill pane and select Add Wall Infill
Configuration.

2. Define the configuration in the Infill Con-
figuration dialog. See Defining a Wall Infill
Configuration on page 484.

To edit an existing infill configuration:
1. Double-click the configuration to edit, or

select the configuration and select Edit > Edit
Wall Infill Configuration, or right-click and
select Edit Wall Infill Configuration.

2. Define the configuration in the Infill Con-
figuration dialog. See Defining a Wall Infill
Configuration on page 484.

To delete an infill configuration:
1. Select the configuration to delete.

2. Press the Delete key on your keyboard, or
select Edit > Delete Wall Infill Configuration,
or right-click and select Delete Wall Infill
Configuration.

To view an infill configuration without editing it:
1. Select the configuration to view.

2. Select Edit > View Wall Infill Configuration,
or right-click and select View Wall Infill Con-
figuration.

Defining a Wall Infill Con-
figuration
Building Essentials | Construction Suite
Infill refers to the material that fills the volume of a
framed wall — studs, top plate, very top plate,
bottom plate, and blocking. An infill configuration
determines what type of member is used for the infill,
the spacing between studs, and the position and
alignment of each component in the frame. An infill
configuration is assigned to each building location in
your project, and you can select a custom infill
configuration for individual walls in your model
using the Infill tool in Framing Mode.

Infill configurations are stored in the Wall Infill
Library where you can add and edit configurations to
suit your construction needs.
To define a wall infill configuration:
1. Open the Wall Infill Library, then choose

either the Add Wall Infill Configuration or
Edit Wall Infill Configuration tool.

Defining Infill Properties
To define stud behavior, select Infill Properties in the
left pane, then define the following settings in the
right pane:

Stud spacing. The distance between studs.
Interference. Refers to the presence of an object (such
as another member) where a stud would go. This may
occur, for example, where one wall intersects another,
or at the end of a wall. Selecting 'Nearest' shifts the
stud to one side of the interfering member. Selecting
'Remove' prevents a stud from being inserted where
there is interference.

Cut opening bottom plate. Cuts the bottom plate out
at the bottom of wall or door openings.
Projection into plates

Top extension. The distance the studs project into the
top plate. This is particularly useful for incorporating
framing channels in steel-framed walls.

Base extension. The distance the studs project into
the bottom plate.
Generate end studs
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Start end stud. If unchecked, the stud at the start of
the wall is removed.

End end stud. If unchecked, the stud at the end of
the wall is removed.

Defining the Bottom Plate
1. To edit the bottom plate, select a Bottom Plate

item in the Bottom Plate group in the left
pane, then define its parameters in the right
pane. You can add new members to this
group if needed.

2. To add a bottom plate member to the con-
figuration, select the Bottom Plate group or
an existing Bottom Plate item and click

. A new member is added to the list.

3. To add a bottom plate member to the con-
figuration by copying an existing member,
select the member to copy and then click

.

4. To delete a member from the configuration,
select the member to delete and then click

.

5. Define the parameters described below.

Use member from. To use the framing
member assigned to the wall in its properties,
select Wall Properties. To use a specific
member from the member library, select
Member Library, then make a selection from
the Catalog Access dialog. The latter option
overrides the Framing Member selection in
the wall's properties.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected in the wall's
properties. If Member Library is selected in the
'Use member from' field, the Member field
displays the member type to be used (as
selected from the Member library). To select a
different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the member about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°).

Double. If you want the bottom plate to be
doubled, click in the Double field and then
select Yes from the drop box. For a single
bottom plate, select No.
Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

6. To cut the bottom plate out at the bottom of
wall or door openings, select the Infill Prop-
erties folder in the left pane, then in the right
pane, enable the Cut opening bottom plate
check box.

Defining the Studs
1. To edit stud properties, select the Stud item in

the Studs group in the left pane. By default
there is one stud item listed. This will result
in a standard framed wall with a single stud
at every spacing interval. If you want mul-
tiple studs in the configuration (e.g. double
studs), you can add more stud items to the
Studs group.

2. To add a stud to the configuration, select the
Studs group or an existing Stud item and
click . A new member is added to
the list.

3. To add a stud to the configuration by copying
an existing stud, select the stud to copy and
then click .

4. To delete a stud from the configuration, select

the stud to delete and then click .

5. To define parameters for a stud component,
select the stud component in the left pane,
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then define the parameters in the right pane.
The parameters are described below.

General

Name. The name of the stud item as it
appears in the Studs group in the left pane.

Use member from. To use the framing
member assigned to the wall in its properties,
select Wall Properties. To use a specific
member from the member library, select
Member Library, then make a selection from
the Catalog Access dialog. The latter option
overrides the Framing Member selection in
the wall's properties.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected in the wall's
properties. If Member Library is selected in the
'Use member from' field, the Member field
displays the member type to be used (as
selected from the Member library). To select a
different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the member about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°).

Quantity Info

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

Position Along Wall

Anchor to. The item that the stud is relative
to in defining its position along the length of
the wall frame. If there is only one stud in the

configuration, the only available option is
Stud Reference Line, which is like an imaginary
chalk line that marks your stud spacing. If
there is more than one stud in the
configuration, you can anchor the stud to
another stud in the list, meaning its position
is relative to the stud to which it is anchored.

Alignment. The position of the stud relative
to the stud reference line or other stud. If the
stud is anchored to the Stud Reference Line,
you can align the stud on the left side, right
side, or center of this line. If the stud is
anchored to another stud, you can control
which side of the other stud you want to
anchor to. For example, a 'Lt. to Rt.'
alignment would mean that the left side of
the stud is anchored to the ride side of the
anchor stud. To change the alignment, click
in the Alignment field, then click to
display the Member Alignment dialog. Use
the slider controls to shift the anchor position.

Offset. The distance the stud is shifted from
its anchor position. A positive value shifts the
member to the right, while a negative value
shifts the stud to the left.

Position Front to Back

Anchor to. The item that the stud is relative
to in defining its position within the width of
the wall (from the front of the wall frame to
the back). If there is only one stud item in the
configuration, the studs will be anchored to
the Bottom Plate. If there is more than one
stud in the configuration, you can anchor the
stud to another stud in the configuration.

Alignment. The position of the stud relative
to the anchor item. A 'Mid. to Mid.' alignment
means that the middle of the stud lines up
with the middle of the anchor stud. A 'Mid.
to Fnt.' alignment would mean that the
middle of the stud lines up with the front of
the anchor stud when looking at the wall
frame face-on.

To change the alignment, click in the
Alignment field, then click to display the
Member Alignment dialog. Use the slider to
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adjust the position of the stud to achieve the
alignment you want between the front and
back of the wall frame.

Offset. The distance the stud is shifted
toward the front or back of the wall frame
from its anchor position. A positive value
shifts the stud toward the back, while a
negative value shifts it toward the front.

Defining Blocking
1. To edit blocking member properties, select

the Blocking item in the Blocking group in
the left pane. By default there is one blocking
member listed. If you want multiple blocking
members in your configuration, you can add
more blocking members to the Blocking
group.

2. To add a blocking member to the con-
figuration, select the Blocking group or an
existing Blocking item and click . A
new member is added to the list.

3. To add a blocking member to the con-
figuration by copying an existing blocking
member, select the blocking member to copy
and then click .

4. To delete a blocking member from the con-
figuration, select the blocking member to

delete and then click .

5. To define parameters for a blocking
component, select the blocking component in
the left pane, then define the parameters in
the right pane. You The parameters are
described below. 

General

Name. The name of the blocking item as it
appears in the Blocking group in the left
pane.

Use member from. To use the framing
member assigned to the wall in its properties,
select Wall Properties. To use a specific
member from the member library, select
Member Library, then make a selection from
the Catalog Access dialog. The latter option
overrides the Framing Member selection in
the wall's properties.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected in the wall's
properties. If Member Library is selected in the
'Use member from' field, the Member field
displays the member type to be used (as
selected from the Member library). To select a
different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the member about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°).

Quantity Info

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

Behavior Along Wall

Break at Stud. If you select Yes, the blocking
will be broken at each stud, resulting in
separate members between each set of studs.
If you select No, one solid member will run
across the wall.

Position Bottom to Top

Placement. Select the component from which
you want to offset the blocking a specific
distance - from bottom plate or from top
plate.
Initial Offset. The distance the blocking is
offset from the top or bottom plate
(whichever you selected in the Placement
drop box).

Spacing. Specifying a value here creates
copies of the blocking member vertically
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within the wall, from the initial offset point.
The Spacing value represents the spacing
between blocking members.

Stagger. If you have set your blocking
member to break at studs, selecting Yes here
will stagger the blocking members across the
wall. If you select No, the members will all be
even with each other. The stagger distance is
the thickness of the member.

Position Front to Back

Alignment. The front-to-back position of the
blocking member relative to the stud. A 'Mid.
to Mid.' alignment means that the middle of
the blocking member lines up with the
middle of the stud. A 'Back to Fnt.' alignment
would mean that the back of the blocking
member is attached to the front of the studs.

Offset. The distance the blocking member is
shifted toward the front or back of the wall
frame from its anchor position. A positive
value shifts the member toward the back,
while a negative value shifts it toward the
front.

Defining the Top Plate
1. To define the top plate, select Top Plate in the

left pane, then define the parameters in the
right pane. The parameters are described
below.

General

Use member from. To use the framing
member assigned to the wall in its properties,
select Wall Properties. To use a specific
member from the member library, select
Member Library, then make a selection from
the Catalog Access dialog. The latter option
overrides the Framing Member selection in
the wall's properties.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected in the wall's
properties. If Member Library is selected in the
'Use member from' field, the Member field
displays the member type to be used (as

selected from the Member library). To select a
different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the top plate about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°)

Quantity Info

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

Position Front to Back

Anchor to. (Bottom Plate) The top plate is
anchored to the bottom plate. This means that
the front-to-back position of the top plate
within the frame is relative to the position of
the bottom plate (see Alignment below).

Alignment. The position of the top plate
relative to the position of the bottom plate.
For example, a 'Mid. to Mid.' alignment
would mean that the middle of the top plate
lines up with the middle of the bottom plate.
A 'Mid. to Fnt.' alignment would mean that
the middle of the middle of the top plate lines
up with the front of the bottom plate, and so
on and so forth.

To change the alignment, click in the
Alignment field, then click to display the
Member Alignment dialog. Use the sliders to
adjust the position of the top plate relative to
the bottom plate.

Defining the Very Top Plate
1. To define the very top plate, select the Very

Top Plate item in the left pane.
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2. Define the parameters in the right pane. The
very top plate has the same parameters avail-
able as the top plate (see above).

Customizing the Intersection
Lookup Table Library
Building Essentials | Construction Suite
The Intersection Lookup Table Library contains a list
of intersection lookup table names. If you customize
framing configurations for intersections in Framing
Mode, you can save your custom configurations to an
intersection lookup table that can be used in future
projects.

Since intersection framing configurations can only be
defined in Framing Mode (with an actual model), the
Intersection Lookup Table Library contains only table
names. You can add, edit and delete table names in
the Intersection Lookup Table Library.

To access the Intersection Lookup Table Library
from the Library Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Framing Libraries > Intersection Lookup
Table.

To access the Intersection Lookup Table Library
from your building location settings:
1. Select Settings > Building Locations, or

click on the View Control toolbar.

2. In the Building Locations dialog, click in the
Framing Options column.

3. In the Location Framing Options dialog,
double-click the intersection lookup table list-
ing.

To add a lookup table to the list:
1. Select Edit > Add Intersection Lookup Con-

figuration, or right-click in the lookup table

pane and select Add Intersection Lookup
Configuration.

2. In the Lookup table dialog, type a name for
the table, then click OK.

Note: Adding a lookup table name to the library is
only useful if the lookup table library is empty and
you have been prompted for a lookup table. You
cannot save custom intersection framing
configurations (that you have defined in Framing
Mode) to an existing lookup table. You can only
create a new one. To create a new table that is
populated with intersection configurations, go to
Framing Mode and then click on a wall intersection.
Then, in the Edit Intersection dialog, click Export.
To edit the name of an existing lookup table:
1. Select the table in the list.

2. Select Edit > Edit Intersection Lookup Con-
figuration, or right-click in the lookup table
pane and select Edit Intersection Lookup
Configuration.

3. Edit the name in the Lookup table dialog,
then click OK.

To delete a lookup table from the list:
1. Select the table to delete.

2. Press the Delete key on your keyboard, or
select Edit > Delete Intersection Lookup
Table Configuration, or right-click in the
lookup table pane and select Delete Inter-
section Lookup Table Configuration.

Customizing the End Condition
Library
Building Essentials | Construction Suite
The End Condition Library contains a number of
different end condition configurations that you can
use when defining framing at wall intersections. End
conditions are selected in the Wall Intersection dialog
when defining framing options for intersections in
Framing Mode.

End condition configurations determine the number
of studs at the end of a wall, the rotation of each stud,
and the position of each stud relative to the wall core
or other studs.

You can add, edit and delete end condition
configurations in the End Condition Library.
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To access the End Condition Library in the Library
Manager:
1. Select File > Catalogs > Library Manager, or

click the down arrow next to the Catalogs but-

ton on the Standard toolbar and select
Library Manager.

2. In the Library Manager, select Libraries >
Framing Libraries > Wall End Conditions.

To access the End Condition Library from an
intersection in Framing Mode:
1. Go into Framing Mode (View > Framing

Mode On/Off).

2. Double-click an intersection, or select the
intersection and then right-click and select
Properties.

3. In the Edit Intersection dialog, click either
Add or Edit.

4. In the Wall Intersection dialog, click in the
End Condition field, then click in that
field.

To add a new end condition configuration to the
library:
1. Select Edit > Add End Condition Con-

figuration, or right-click in the end condition
pane and select Add End Condition Con-
figuration.

2. Define the configuration in the End Condi-
tion dialog. See Defining an End Condition Con-
figuration on page 490.

To edit an existing end condition configuration:
1. Double-click the end condition in the list, or

select the end condition to edit and select
Edit > Edit End Condition Configuration, or
right-click and select Edit End Condition
Configuration.

2. Define the configuration in the End Condi-
tion dialog. See Defining an End Condition Con-
figuration on page 490.

To delete an end condition configuration from the
library:
1. Select the configuration to delete.

2. Press the Delete key on your keyboard, or
select Edit > Delete End Condition Con-
figuration, or right-click and select Delete
End Condition Configuration.

To view an end condition configuration without
editing it:
1. Select the configuration to view.

2. Select Edit > View End Condition Con-
figuration, or right-click and select View End
Condition Configuration.

Defining an End Condition Con-
figuration
Building Essentials | Construction Suite
End condition configurations determine the number
of studs at the end of a wall, the rotation of each stud,
and the position of each stud relative to the wall core
or other studs. End conditions are selected in the Wall
Intersection dialog when defining framing options for
intersections in Framing Mode.

End condition configurations are stored in the End
Condition Library, where you can add, edit and
delete configurations.
To define an end condition configuration:
1. Open the End Condition Library, and then

choose either the Add End Condition
Configuration or Edit End Condition
Configuration tool.
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2. To add a stud to the configuration, click
. A new member is added to the list.

3. To add a new stud by copying an existing
stud in the configuration, select the stud to
copy and then click . A copy of the
stud is added to the list.

4. To remove a stud from the configuration,
select the stud to remove and then click

.

5. To define the parameters of a stud in the
configuration, select it in the left pane, and
then define its parameters in the right pane.
The parameters are described below.

General

Name. The name of the stud as it appears in
the list of studs in the end condition
configuration (e.g. End Stud).

Use member from. To use the framing
member assigned to the wall in its properties,
select Wall Properties. To use a specific
member from the member library, select
Member Library, then make a selection from
the Catalog Access dialog. The latter option
overrides the Framing Member selection in
the wall's properties.

Member. If Wall Properties is selected in the
'Use member from' field, the Member field
displays a generic description, 'Wall Frame
Member', indicating that the member to be
used is the one selected in the wall's
properties. If Member Library is selected in the
'Use member from' field, the Member field
displays the member type to be used (as
selected from the Member library). To select a

different member, click in this field and then
click to display the Catalog Access
dialog.

Rotation. The rotation of the member about
its center line (core). Click the down arrow in
this field to select the angle of rotation (0°,
90°, 180° or 270°).

- Quantity Info -

Usage. What the member will be used for.
Usages can be used as sort keys in estimates
and reports. To select a usage, click in this
field and then click to display the
Usages library.
Phase. The building stage or process in
which this member will be used. Phases can
be used as sort keys in estimates and quantity
reports. To select a phase, click in this field
and then click to display the Phases
library.

Position Along Wall

Anchor to. The item to which the stud is
anchored or lined up with when looking at
the stud's position along the length of the
wall. If there is only one stud in the list, the
only available option is 'Wall End'. If there is
more than one stud in the list, you can choose
to anchor the stud to the wall end or to
another stud in the configuration.

Alignment. The position of the stud relative
to the anchor object. If the stud is anchored to
the Wall End you can position the stud to the
left or right of the wall end, or center it on the
wall end. If the stud is anchored to another
stud in the configuration, you can specify
which side you want the stud to be
positioned on. For example, if the First Stud
is anchored to the End Stud and has a 'Lt. to
Rt.' alignment, the left edge of the First Stud
is anchored to the right edge of the End Stud.
In other words, the First Stud would appear
after the End Stud when looking along the
length of the wall.

To change the alignment, click in the
Alignment field, then click to display the
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Member Alignment dialog. Use the sliders to
adjust the anchor or alignment position.

Offset. The distance the stud is shifted from
its anchor position. A positive value shifts the
stud to the right, while a negative value shifts
the stud to the left.

Position Front to Back

Anchor to. The component to which the stud
is anchored when looking at the member's
position within the width of the wall (from
the front of the wall frame to the back). In
other words, the stud's position is relative to
the anchor component's position. If there is
only one stud in the configuration, the only
choice here is 'Wall Core'. If there is more
than one stud in the configuration, you can
anchor to the wall core or to another stud in
the configuration.

Note that "wall core" refers to the
configuration of studs, top plate, bottom plate
and very top plate as a whole.

Alignment. The position of the stud relative
to the anchor item. A 'Mid. to Mid.' alignment
means that the middle of the stud lines up
with the middle of the wall core or anchor
stud. A 'Mid. to Fnt.' alignment would mean
that the middle of the stud lines up with the
front of the wall core or anchor stud when
looking at the wall frame face-on.

To change the alignment, click in the
Alignment field, then click to display the
Member Alignment dialog. Use the sliders to
achieve the alignment you want between the
front and back of the wall frame.

Offset. The distance the stud is shifted
toward the front or back of the wall frame
from its anchor position. A positive value
shifts the stud toward the back, while a
negative value shifts it toward the front.
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You can customize many aspects of your work environment to maximize your design experience and create a space
that is tailored to the way you like to do things. For example, you can turn toolbars on and off, move toolbars, move
the information panel, and control the toolbar area color and drawing area color.

You can also control the way the program responds graphically, by enabling or disabling Hardware Acceleration, or
adjusting Interactive Lighting settings.

If you have problems with your graphics display, see Improving Graphics Display on page 498.

Displaying/Hiding Toolbars
Personal Architect | Pro Architect | Building Essentials | Construction Suite

There are several toolbars available for display in both Model View and Worksheet View. (By default, not all of
them are displayed.) You can hide or show individual toolbars by editing your program settings. When you display
a toolbar, it is displayed in one of the toolbar areas which are located directly above and below the drawing area.
Note that if you hide a toolbar that is displayed in a tab, the tab is hidden from view as well.
To hide or show toolbars:
1. Select Settings > Toolbars.
2. Click in the Tabbed column next to the toolbar’s name.

3. To display the toolbar in tabbed format, select Tabbed from the drop box.

4. To display the toolbar in non-tabbed (floatable) format, select Normal.
5. To hide the toolbar from view, select Off.
6. Click OK.

Tip: If a toolbar is currently floating freely on the screen, you can hide it by clicking the close button on its title
bar, or right-clicking its title bar and selecting Hide.

Displaying Toolbars in a Tabbed Format
Personal Architect | Pro Architect | Building Essentials | Construction Suite

You can display any toolbar in tabbed format, meaning a tab will be added to the row of toolbar tabs below the
menu bar.
To display a toolbar in a tab:
1. Select Settings > Toolbars.
2. Click in the Tabbed column next to the toolbar’s name, then select Tabbed from the drop box.

3. Click OK.

Displaying Toolbars in a Non-Tabbed Format
Personal Architect | Pro Architect | Building Essentials | Construction Suite
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You can change any tabbed toolbar to be displayed as
a non-tabbed, floatable toolbar.
To display toolbars in non-tabbed format:
1. Select Settings > Toolbars.
2. Click in the Tabbed column next to the tool-

bar’s name, then select Normal from the drop
box.

3. Click OK.

Changing the Color of Toolbar
Areas
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The program has two toolbar areas: one directly
above the drawing area, and one directly below the
drawing area. You can change this color in your
workspace Program Settings.
To change the color of toolbar areas:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. Click the color swatch next to the Toolbar
Areas option.

4. In the Color dialog, select or create the
desired color for your toolbar areas, then click
OK to return to the Program Settings dialog.

5. Click OK.

Customizing Toolbar Colors and
Effects
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Every toolbar has a set of advanced settings that
control its appearance. These settings include the
background color, text color, and whether the
background color is solid or has a gradient effect. You
can customize the colors and effects of each
individual toolbar.
To customize toolbar colors and effects:
1. Select Settings > Toolbars.
2. In the Program Settings dialog, click

.

3. In the Toolbar Colors dialog, select the tool-
bar that you want to customize in the left
pane.

4. To edit the color of text, click the color swatch
above the Text item, and then make a selec-
tion from the Color dialog.

5. To edit the toolbar's background color, click
the color swatch above the Background item,
and then make a selection from the Color dia-
log.

6. To display the background color as a solid,
enable the Solid radio button.

7. To create a gradient effect with the back-
ground color, enable the Gradient radio but-
ton. A gradient effect involves the gradual
transition from one shade to another.

8. Click OK.

Tip: You can save your toolbar color settings to a
*.theme file that can be loaded at any time. See
Saving a Toolbar Color Theme on page 494.

Saving a Toolbar Color Theme
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you have customized your toolbar color settings
you can save the color settings to a theme file. Once
you have saved your color settings to a theme file you
can then load the theme at any time without having
to set all your toolbars colors again.
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To save a toolbar color theme:
1. Select Settings > Toolbars.
2. Set up your toolbar colors as desired. In addi-

tion to the background color, you can define
advanced settings such as text color and
gradient color effects (see Customizing Toolbar
Colors and Effects on page 494).

3. In the Program Settings dialog, click the
Save Theme button.

4. In the Save As dialog, type a name for the
theme in the File name edit box. You can also
select an existing theme file to overwrite.

5. Click Save.

Loading a Toolbar Color Theme
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can instantly load any saved toolbar color theme
using the Load Theme tool in your toolbar settings.
To load a toolbar color theme:
1. Select Settings > Toolbars.
2. In the Program Settings dialog, click the

Load Theme button.
3. In the Open dialog, select the theme you

would like to load.

4. Click Open.

Moving Toolbars
You can drag any non-tabbed toolbar to any location
on the screen. At window edges, the toolbar will
automatically dock itself according to the location. For
example, if you drag it to the right edge of the screen,
it will assume a vertical orientation.

If you drag it into the drawing window, it will float
freely. You can then move it by dragging it by its title
bar.
To move a toolbar:
1. Click and hold your mouse button over the

left grip end of the toolbar (or its title bar if it
is currently in the drawing area).

2. Drag the toolbar to the desired location.

3. Release the mouse button.

Displaying/Hiding the Inform-
ation Panel
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, an information panel is displayed on the
right side of the screen. When you are in Insertion
mode, the panel displays the catalog of elements. In
Worksheet View, the panel displays object properties.
You can hide the information panel from view if you
want.
To display or hide the information panel:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Tool Display area, check or uncheck the
Info Panel check box.

4. Click OK.

Resizing the Information Panel
When the information panel is docked at one side of
your screen, you can make it narrower or wider by
simply clicking and dragging its edges. If you have
moved the panel away from the edge, so it is free-
floating, you can resize it by clicking and dragging its
corners.
To resize the information panel if it is docked:
1. Position your pointer over the panel's left out-

side edge. (If you have moved the panel to
the left side of the screen, position your
pointer over the right edge.) Watch for the
Resize cursor to appear.

2. Click and drag the edge of the panel to
stretch it in the desired direction.

3. Release your mouse button.
To resize the information panel if it is free-floating:
1. Position your pointer over one of the panel’s

corners.
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2. Click and drag to stretch the panel.

3. Release your mouse button.

Moving the Information Panel
If the information panel is docked on one side of the
screen, you can move it by clicking and dragging its
outside edge. If you move a panel to the side of the
screen, it will automatically dock itself to the edge of
the screen. Otherwise, the panel is displayed as a free-
floating window.

If the panel is free-floating, you can move it by
clicking and dragging its title bar.
To move the information panel when it is docked:
1. Position your pointer over the panel’s outside

edge. Watch for the Move cursor.

2. Click and drag the panel to move it.

3. Release your mouse button.
To move the information panel when it is free-
floating:
1. Position your pointer over the panel’s title

bar.

2. Click and drag the panel to move it.

3. Release your mouse button.

Displaying/Hiding the Status Bar
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

The Status bar is located at the bottom of the screen. It
displays helpful prompts while you are working on
your design project. For example, if you are inserting
a wall, it may display “Pick first insertion point”. The
Status bar also includes a selection of drawing aid
buttons such as ORTHO and OBJSNAP. The Status
bar can be toggled on and off as needed.
To display/hide the Status bar:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Tool Display area, select or clear the
Status Bar check box.

4. Click OK.

Changing the Color of the Draw-
ing Area
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

You can select a different color for your drawing area.
There are settings for both Model View and
Worksheet View.
To change the color of the drawing window:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. To change the color of the drawing area back-
ground in Model View, click the color swatch
next to the Model View option in the Work-
space Colors area. To change the color of the
workspace in Worksheet View, click the color
swatch next to the Worksheet View option.

4. In the Color dialog, select or create the
desired color, then click OK to return to the
Program Settings dialog.

5. Click OK.

Displaying/Hiding the Scroll
Bars
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

There are scroll bars on the bottom and right side of
the drawing area. You can toggle them on and off.
To display/hide the scroll bars:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Work-
space in the left column.

3. In the Tool Display area, select or clear the
Scroll Bars check box.

4. Click OK.
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Note: Disabling the scroll bars does not disable the
auto-scroll feature. The Auto Scroll control is
located on the Drawing Aids page of the Program
Settings dialog.

Controlling the Launch of the
Startup Screen
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a Startup screen appears every time you
start the program. The Startup screen lets you quickly
open new and saved projects, and provides instant
access to a variety of learning and support resources.
If you prefer you can disable the launch of the Startup
screen.
To control the launch of the Startup screen:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. On the General page of the Program Set-
tings dialog, check or uncheck the Launch
Startup Screen check box.

3. Click OK.

Tip: If the Startup screen is currently displayed,
you can disable its future launch by disabling the
Display on startup check box at the bottom of the
screen. To view the Startup screen any time, select
Help > Launch Startup Screen.

Viewing the Startup Screen
The Startup screen lets you quickly open new and
saved projects, and provides instant access to a
variety of learning and support resources. Any time
the Startup screen is not displayed you can launch it
instantly through the Help menu.
To view the Startup screen:
1. Select Help > Launch Startup Screen, or

click on the Help toolbar.

Note: To launch the Startup screen automatically
on program startup (or prevent it from launching)
you need to set the Launch Startup Screen option
in your program settings. Launching it from the

Help menu or toolbar will not cause it to launch
automatically at startup.

Customizing Keyboard Short-
cuts
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

Many commands have keyboard shortcuts assigned to
them in your Program Settings. You can create and
edit shortcuts for all commands in the program.
To customize a keyboard shortcut:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Key-
board in the left column.

3. From the Mode drop box, select either Model
View or Worksheet View depending on
where the command is located.

4. Locate the command whose shortcut you
would like to specify in the list of available
commands. If the command is not listed, it is
not eligible for a shortcut.

5. If a shortcut is currently assigned to the com-
mand, the shortcut is displayed in the Cur-
rent Quick Key for Command edit box. To
remove the current shortcut from the com-
mand, click Remove.

6. To assign a new shortcut to the command,
place your cursor in the Press Keys edit box,
then press the desired key sequence on your
keyboard, just as if you were using the short-
cut to execute the command. The keys you
press appear in the edit box as you type.

7. Once you’ve entered the key sequence, click
Assign. The new shortcut now appears in the
Current Quick Key for Command edit box.
Tip: You can use any character (letter or
number) on your keyboard, as well as the
SHIFT and CTRL keys when defining your
shortcut sequence.

Note: If the shortcut that you have entered is
already assigned to another command, the
command is displayed in the Currently Used

Default_Quick_Keys.htm


- 498 -

By drop box. You will need to specify a
different shortcut.

8. To save your keyboard shortcut settings to a
file, click Export. In the Save As dialog, type
a name for the file in the File name edit box,
then click Save. Shortcuts are saved to a spe-
cial *.qck file.

9. To import keyboard shortcuts that you have
saved, click Import. In the Open dialog, loc-
ate and select the *.qck file that you want to
import, then click Open.

Improving Graphics Display
The type of graphics card you have in your computer
can affect the way the program’s graphics are
displayed on your screen. If the display seems
unstable or contains some graphic artifacts Fuzz or
distortion in a graphic image or sequence of video
images. Large digital pixels (“blocks”) and jerkiness in
the video stream are examples of artifacts., here are
some tips on how you may be able to improve the
display:

1. Lower your screen resolution (to 1024 x 768,
for example) in the Windows Display Prop-
erties dialog. To access this dialog, right-click
your Windows desktop and select Properties.
In the Display Properties dialog, select the
Settings tab.

2. Lower the color setting in the Windows Dis-
play Properties dialog box. For example, if
your colors are set to True Color (32 bit),
change the setting to High Color (16 bit).

3. Disable interactive lighting, which is the real-
time lighting effect you see when you insert
light fixtures in Rendered or Rendered Out-
line display mode.

4. Disable tool tips. By default, tool tips are dis-
played as you hover over elements with your
cursor.

Performing a Graphics System
Check
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

If you are having issues with the graphics display, or
simply want to find out if you can improve graphics
display, you can use the system check utility to check
which graphics card is installed on your computer, as
well as the version of the driver. The utility may then
recommend a different driver to use. Installing the
recommended driver may improve your graphics
display.
To perform a graphics system check:
1. Select Settings > Program Settings and

select Graphics in the left pane of the Pro-
gram Settings dialog.

2. The Video Card pane displays information
about the currently installed graphics card
and driver.

It also recommends the best driver for
graphics performance.

Changing the Quality Level of
Interactive Lighting
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

As you insert light fixtures in your design you can see
real-time lighting effects if working in Rendered or
Rendered Outline display mode. By default, the
quality level of interactive lighting is set to Low,
which provides an adequate lighting display for the
average computer. If your computer has a powerful
video card, you can select a higher level of quality for
your interactive lighting.
To change the quality of interactive lighting:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Graph-
ics in the left column.

3. In the Lighting area, select either Low,
Medium or High.

4. Click OK.

Note: Selecting a higher quality level can slow
down your graphics display.

Disabling Interactive Lighting
Personal Architect | Pro Architect | Building Essentials |
Construction Suite
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By default, you can see real-time lighting effects as
you insert light fixtures in Rendered or Rendered
Outline display mode. If interactive lighting slows
down your graphics display, or you simply do not
want to use it, you can disable it.
To disable interactive lighting:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Graph-
ics in the left column.

3. Disable the Enable interactive lighting check
box.

4. Click OK.

Stereoscopic VR Viewing
Personal Architect | Pro Architect | Building Essentials |
Construction Suite

By default, a standard 360° view is produced during
virtual reality viewing in Presentation Mode. If you
switch to a stereoscopic view, depth data is added
between the foreground and background, creating a
more immersive experience.
To enable or disable stereoscopic VR viewing:
1. Select Settings > Program Settings or click

on the Settings toolbar.

2. In the Program Settings dialog, click Graph-
ics in the left column.

3. In the VR pane, check or uncheck the Ste-
reoscopic check box.

4. Click OK.
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Glossary

2

2D Designer's Plan
A flat, overhead view with colors and tex-
tures applied. A 2D plan view in rendered
display mode.

2D Plan
A flat, overhead view.

3

3D Overview
A predefined 3D Camera view where the
camera is elevated to provide an aerial view
of the model.

3D Perspective
A three-dimensional view in which the scale
of an element decreases according to its dis-
tance from the viewer. This produces the
same impression of distance and relative
size as that received by the human eye.

3D QuickView
A 3D view of your model from a pre-
defined angle.

3D RealView
A rendered image with photorealistic prop-
erties such as textures, lighting, and shad-
ows.

3DS File
3D Studio file. The program can convert
these files for use as Furnishings elements.

A

Aligned Dimension
A dimension that lies at the same angle as
the element it is dimensioning.

Alkaline
Having a PH of more than 7.

Alt Code
Alternate Code. An extra identification code
that is used to link an element in the pro-
gram's catalog to the databases of other
applications like Timberline.

Ambient Light
The available light in a scene. Ambient light
comes from all directions and has no visible
source.

Angle of True North
The location on the horizon directly below
the North Star. In other words, it is the geo-
graphic North, as opposed to magnetic
North, which is the direction indicated on a
compass.

Angle Snap
Makes elements move/rotate at specific incre-
ments (angles).

Animation
A movie. A series of images that, when
viewed in rapid succession, create the illu-
sion of movement through a scene.

Antialiasing
A method of improving image quality by
smoothing out jagged edges. This is
achieved by adjusting pixel positions or set-
ting pixel intensities so that there is a more
gradual transition between the color of a
line and the background color.

Array
A method of copying an element into a pat-
tern of rows and/or columns.

Artifacts
Fuzz or distortion in a graphic image or
sequence of video images. Large digital
pixels (blocks) and jerkiness in the video
stream are examples of artifacts.

Aspect Ratio
The ratio of width to height.
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Assembly
Items or parts that are linked to an element,
but do not exist in the drawing. For
example, walls have assemblies such as insu-
lation, vapor barrier, and drywall screws.

Auto Texture Mapping
Applies a UV map, which is a flat, 2D rep-
resentation of the vertices of the 3D model.
It defines where the 2D pixels in your tex-
ture will be placed on the 3D surface. For
imported elements, selecting Auto uses the
mapping already applied to the element.

Automatic Save
Saves your drawing for you at specified
intervals without prompting.

AVI
Audio Video Interleaved. A common video
file format by Microsoft that can be used to
record animations.

Awning Window
A window having a sash hinged on pins at
the two top or bottom corners of the frame.
It opens outward.

B

Back Bearing
The bearing of a back station as observed
from the station next in advance.

Backsplash
The rear portion of a countertop that sits
against the wall, or a splash guard that is
fastened to the wall and sits above the coun-
tertop.

Balustrade
A railing consisting of balusters (spindles)
attached to a top rail. Used along stairs,
landings, porches, decks, etc. Also called a
banister.

Baseboard
A board or moulding along the base of a
wall. Also called skirting.

Batch Printing
A process of printing a number of selected
views at once.

Batt Insulation
Pre-cut, flexible insulation that fits inside
wall cavities between the studs.

Bay Window
A window made up of three sash units that
project out from the wall. Usually includes a
roof structure.

Beam
In a deck frame, structural member sup-
ported by posts that acts to support the
decks floor joists.

Bearing
A surveying term used to designate dir-
ection. The bearing of a line is the acute hori-
zontal angle between the North meridian
and the line.

Berm
A mound or bank of soil without formal
sides. You often see large berms on the sides
of highways, which are used for noise con-
trol.

Bi-Fold Doors
Narrow doors that are hinged to fold
against each other and flat against the jamb.

BIM File
Building Information Modeling file. BIM is
the process of generating and managing
building data.

Bird's Mouth
The notch cut in the lower end of a rafter to
fit it to the top plate of a wall.
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BLD File
BUILD file. The drawing file produced by
the program. The extension given to the pro-
gram's drawing files.

Block
A single object that is composed of many
other objects.

Blocking
Members that run perpendicular to studs in
order to provide reinforcement, or attach-
ment sites for mounted hardware.

BMP
Bitmap. An image file whose bits are ref-
erenced to pixels.

Board-and-Batten
A type of exterior siding or interior paneling
that has alternating wide boards and narrow
wooden strips, called battens.

Bottom Plate
The bottom member of a framed wall. Also
called base plate or sole plate.

Boundary Hatch
A tool that lets you define an area with
hatching applied to it.

Bow Window
A type of bay window made up of several
window units set at slight angles to form a
curve.

Box Mapping
A texture mapping method that creates a
rectangular bounding box around the ele-
ment, then applies a texture to each of the
box's 6 sides. This would be useful for an
element such as a sofa.

Bullnose
A heavily rounded edge usually found on
stair treads.

C

CAD File
A file created in a Computer-Aided Design
program such as AutoCAD. The most com-
mon file types are DWG and DXF.

Casement Window
A window having a sash hinged on pins at
the top and bottom corners of one side. It
opens outward by means of a crank.

Catalog Directory
The directory containing the Master Catalog
and other catalogs that you have created.

Catalog Panel
The window on the right side of the screen
that displays the contents of the current cata-
log.

Category
A group, often named or numbered, to
which items are assigned based on sim-
ilarity or defined criteria.

Cathedral Ceiling
A high, open, usually slanting or pointed
ceiling.

Ceiling Height
The height of the underside of a ceiling sur-
face relative to the floor level.

Center Object Snap
Snaps to the center point of an arc or circle.

Chair Rail
A decorative molding applied horizontally
to a wall inside a room at a height of about
3 feet. Used to prevent chairs from marring
the wall.

Collision Control
An intelligent drawing aid that prevents ele-
ments from being inserted where they won't
fit.
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Color Bleed
The degree to which different colors blend
where they meet.

Commander
An editing window that appears when cer-
tain functions are chosen. It provides precise
control over such things as distance and dir-
ection.

Complexity
The level of detail shown when elements are
displayed.

Composite Wall
A wall comprising a structural wall and ven-
eer wall separated by an air space.

Compression
The conversion of data into a format that
requires fewer bits, usually so that it can be
stored or transmitted more efficiently.

Coordinate Icon
A small symbol displayed in the drawing
area that marks the current point from
which an action will be performed when
using the Commander.

Cove Molding
A molding with a concave face used as trim.

Crawlspace
The shallow area beneath a house enclosed
by the foundation walls.

Cripple
The short members used to frame under the
sill or above the header in a rough opening
for a window in a framed wall.

Crosshairs
Intersecting lines that represent the two
coordinate axes.

Crown Molding
A decorative molding along the top of a
wall.

Cut Line
A standard 2D drafting symbol used to rep-
resent a break in the drawing. It indicates
that the object continues in the same manner
after or between the break lines.

Cylinder Mapping
A texture mapping method that creates a cyl-
indrical bounding box around the element.
The texture is then mapped to the cylinder.
This might be an ideal option for elements
such as round columns.

D

Daylight Saving Time
Time usually one hour ahead of standard
time.

Delimeter
A character that marks the beginning or end
of a unit of data.

Diffuse
The amount of color that is reflected when
an element is illuminated by a light.

Display Filter
A dialog box used for displaying and hiding
elements and/or locations.

Division
A construction division identification. In
North America, CSI divisions are used.

Double Roof
A type of hip roof in which the slope to all
four sides is broken into two slopes. Both
slopes have a pitch.

DPI
Dots Per Inch. The measurement of res-
olution for printers.

Drag-and-Drop Mode
The default mode you are in when you
select an element for editing. You can move
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and rotate elements with your mouse when
you are in Drag and Drop mode.

Drawing Aids
Tools that control the way your cursor
works and the way elements are inserted.

Drywall
Gypsum, sometimes with additives, made
into paper-covered sheets for use an interior
wall or ceiling covering.

Duplicate
Copies a selected element on the same loc-
ation.

Dutch Gable
A combination of a hip and gable roof. On
either end, the lower segment is a hip roof
and the upper segment is a gable end. Also
known as a Dutch Hip Roof or a Full Return
Gable.

DWG
Standard file format for saving vector graph-
ics in applications like AutoCAD.

DXF
Drawing Exchange Format. An ASCII or bin-
ary file format of a CAD drawing.

Dynamic Cutaway
A 3D view of your model that you can strip
away by sliding a clipping plane back and
forth.

E

Editor
A software application capable of editing
text.

Element
A specific type of element, such as a door,
having its own distinct properties (size,
appearance, etc.).

Elevation
1. The front, back and side views of a build-
ing. 2. The height of an element above the
floor or terrain.

Emissive
The amount of light given off by a material.
The more emissive a material is, the more
self-luminous it appears.

Estimate
A report containing a listing of materials,
quantities, unit costs, and total cost.

F

Face Mapping
A texture mapping method that applies the
texture to every single face of the element
component. This is the most common tex-
ture mapping option used in the program

Face Slider
Two or more doors that open by sliding to
the side in front or behind each other. Also
called bypass doors.

Fascia
A flat wood or plywood strip nailed to the
overhanging ends of rafters.

Fillet
Connects two lines together at a point where
they would naturally meet if both were
extended.

Filter
To exclude an element or location from
being displayed, quantified or selected.

Fixed Window
A window whose sash is permanently fixed
in the frame.

Floor Level
The height of a floor (location) above the
ground (0).

- 505 -



Glossary

Fold-Back Stairs
Stairs that have two flights separated by a
landing and that make a complete 180-
degree turn. Sometimes called Scissor Stairs.

Fold-Up Door
A door made up of a number of narrow pan-
els that opens overhead by folding up like
an accordian.

Forward Bearing
The direction of a line segment from the cur-
rent station. Bearings are measured in
degrees (360 in a full circle), clockwise from
the North meridian.

Foundation
The supporting portion of a structure below
the ground floor construction, or below
grade, including the footings.

Frame Rate
The number of images displayed per
second. The video playback rate of an AVI
animation.

Framing Mode
A special display mode where individual
walls, openings and intersections are dis-
played as "glass boxes" for ease of iden-
tification and selection. In this mode you
can edit the framing configurations for indi-
vidual wall openings and intersections.

Framing Rule
The direction and order in which walls are
framed.

G

Gable Roof
A roof with two sloping sides (as opposed
to a Hip Roof, with four sloping sides).

Girt Wall
A wall built up of horizontal structural mem-
bers that are suspended between vertical

columns. Usually found in industrial build-
ings.

Glass Slider
A door having a wood or aluminum frame
fitted with one fixed glass panel and one
sliding glass panel. Often called a patio
door.

Global Illumination
An algorithm used in 3D computer graphics
rendering. Global illumination simulates the
many reflections of light around a scene,
generally resulting in softer, more natural
shadows and reflections.

Grayscale
An image in which colors are represented
by shades of gray.

Grid
A visual aid consisting of a pattern of hori-
zontal and vertical lines.

Grid Snap
An invisible grid whose lines you can snap
to with your cursor when inserting ele-
ments.

H

Hardware Acceleration
Takes advantage of any installed graphics
card that supports hardware acceleration,
increasing the speed of your graphics dis-
play.

Hatching
A pattern of lines used to represent a mater-
ial, such as wood or concrete. Hatching is
only visible in Patterned display mode.

Head
The top member of a window sash or door
frame.
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Head Height
The height at which the tops of openings,
doors, and windows are located relative to
the floor level.

Header
The structural members placed horizontally
over doors, windows and wall openings.

Hidden Line
A view mode where hidden lines are
removed from the view, leaving only sur-
faces displayed.

Highlite
A pane of glass located at the top of a win-
dow or door.

Hinged Door
Any type of door that swings open.

Hip Roof
A roof with four sloping sides (as opposed
to a Gable Roof, with two sloping sides).

Hopper Window
A window in which the sash is hinged on
pins at the two bottom corners, and which
opens inward.

Hung Window
A window having two sashes, and whose
lower sash slides up and over the fixed,
upper sash on the inside.

Hyperlinks
Jumps (links) to external document files or
web addresses.

I

IES File
Name derived from Illuminating Engin-
eering Society. A photometric data file
(Lights file) containing Luminaire definition
and information.

IFC
A file format deriving from the Industry
Foundation Classes (IFC) data model that
describes building and construction industry
data.

Index of Refraction
The amount that light bends as it passes
from one material to another.

Industry Foundation Classes
A data model commonly used for Building
Information Modeling (BIM) which
describes building and construction data.

Infill
The framing material that fills the volume of
a wall. Usually studs, top plate, bottom
plate and very top plate.

Info Panel
The pane on the right side of the screen that
displays the catalog in Model View, or
object properties in Worksheet View.

Insertion Object Snap
Snaps to the insertion point of text, blocks,
imported model views, and imported CAD
objects.

Interactive Lighting
Real-time lighting effects displayed while
you are inserting light fixtures in Rendered
or Rendered Outline mode.

Interface
Program components that you see on the
screen and use to perform tasks.

Intersection Lookup Table
An internal library of intersection framing
configurations.

Intersection Object Snap
Snaps to the point where objects cross each
other.
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J

Jack Stud
The trimmer that supports a header in a
framed wall opening.

Jamb
The wood or metal pieces that form the
sides and top of a door or window enclos-
ure.

Joist
One of a parallel set of structural members
used to support floor and ceiling loads.
They, in turn, are supported by beams,
girders, or bearing walls.

K

King Stud
The stud next to a door or window opening
to which the jack stud and header are
nailed.

L

L-Winder Stairs
Stairs that ascend in an L-shape and that use
wedge-shaped treads called winders to
change direction.

Landing
A platform between flights of stairs or at the
termination of a flight of stairs.

Layers
Like overlays used in paper-based drafting,
layers are used to organize the content of a
drawing and group information by function.

Line Style
Settings that determine the color, pattern
and thickness of a line.

Line Type
The pattern of a line, such as dashed or
solid.

Line Weight
The thickness (or heaviness) of a line.

Linear Dimension
A horiziontal or vertical dimension.

Lite
A pane of glass in a window or door.

Load-bearing
A structural member or combination of
members, such as a wall, that supports a
load in addition to its own weight.

Locations
Drawing layers containing definitions for
wall height, floor level, head height and ceil-
ing level.

Louvre Window
A small, slatted window placed high in a
gable end. Used mostly for ventilation.

Lumen
A Lumen is equal to one foot-candle (the
amount of light one candle generates one
foot away) falling on one SQUARE foot of
area.

Luminaire
The international term for a piece of lighting
equipment. The complete unit including
lamp, fixture, and other parts.

M

Magnetic North
Magnetic North is the magnetic north pole.
It is the focus of the planet's magnetic field
and is the point magnetic compasses point
toward.

Mansard Roof
A type of hip roof in which the slope to all
four sides is broken into two slopes. The
upper slope is nearly or completely flat,
while the lower slope has a sharp pitch.
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Margin
% of Retail Price that is Gross Profit.

Markup
The % difference between the Cost and
Retail price of an item.

Masonry
Brick, stone, concrete or concrete block.

Masonry Section
A 2D drafting symbol that indicates where
masonry is used.

Material Usages
Determine which materials are suitable to be
applied to specific elements.

Materials Paintbrush
A tool for instantly applying a selected
material to the surface of an element.

Member
Pieces of lumber or steel used in the con-
struction of a building, such as studs,
rafters, beams and piers, or as decorative
accents, such as baseboards and crown mold-
ing.

Midpoint Object Snap
Snaps to the midpoint of a line or arc.

Model View
A view window with a 3D environment
where you create and edit a 3D model.

Mono Footing
A pad of masonry, usually concrete, that is
wider than the column it supports. Used to
transfer the load of the column.

Mullion
A thin, non-structural bar between window
and door units.

Muntin Bars
The vertical and horizontal members that
divide the individual panes of glass in a win-
dow.

N

Nearest Object Snap
Snaps to a point on a line, circle, arc or other
object that is nearest to the center of the pick-
box (where the crosshairs intersect).

Newel
The main post to which the end of a railing
is attached.

Niche
A recess in a wall.

Non-load-bearing
A structural member or combination of
members, such as a wall, that supports no
load other than its own weight.

Nosing
The portion of a stair tread that projects
over the riser.

Nudge Distance
The distance an object moves when you
nudge it by pressing the arrow keys on your
keyboard.

O

Object Snaps
Drawing aids that snap your pickbox to com-
mon points on objects, such as endpoints
and midpoints.

Open GL
A 3D graphics Application Programming
Interface (API) that includes routines for
shading, texture mapping, texture filtering,
anti-aliasing, lighting, geometry trans-
formations, etc.

Opening
A cutout in a wall.

Ortho
A Drawing Aid that restricts drawing to
straight up, down, left, or right.
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Orthogonal View
An alternate name for Parallel View in
which all drawing lines are parallel and the
effect of distance is eliminated. Contrasts
with Perspective View.

Overhang
The part of the roof that extends over the
side wall. Also, the distance from the side
wall to the fascia.

P

Pan
A control that allows you to move the on-
screen view by dragging up, down, left, or
right.

Paper Margin Lines
Displays dashed lines near the edges of the
virtual paper, indicating the location of your
page margins. They denote the non-print-
able areas of the paper.

Paper Shadow
A virtual piece of paper in the drawing area
that represents the paper size selection in
the view's Print Properties.

Parallel View
A 3D view that eliminates the effect of dis-
tance from a view. In Parallel View, all
drawing lines are parallel. Contrasts with
Perspective View. Parallel View is some-
times called Orthogonal View.

Parametric
Having a set of physical properties that
determines the characteristics of an element.

PDF
Portable Document Format. A file format
created by Adobe Systems for the purpose
of sharing documents.

Perpendicular Object Snap
Snaps to a point on a line, arc or circle that
forms a perpendicular from the current

point to the selected object.

Perspective View
A 3D view in which the scale of an element
decreases according to its distance from the
viewer. Drawing lines converge to a van-
ishing point. Perspective View represents
the way an element would appear to the
human eye.

Phase
A stage in the construction process, such as
Foundation, Exterior Construction, or Exter-
ior Finish.

Photo Board
A digital image that is oriented vertically in
3D view, much like a billboard.

Photometric Data File
A file that allows you to define complex
light distributions based on physical lamp
properties. When loading a photometric file,
a photometric web is constructed that
defines the intensity of light for any dir-
ection from a light source.

Pickbox
A square located at the center of the
crosshairs, used for selecting objects.

Pixel
A word invented by combining the two
words picture and element. The smallest
unit of color on a computer display. The
number of pixels per inch depends on the
display device dimensions.

Pixel Search Distance
The Pixel Search Distance determines how
close your cursor (which is attached to an
element you are inserting) needs to be to an
existing element before Object Snap occurs.

Plan View
A flat, 2D view from above.
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Plate (top plate)
The top member of a framed wall upon
which the rafters and ceiling joists rest.

Plateau
A relatively large, flat area of land situated
above the adjacent land.

Pocket Door
A door that rolls on an overhead track into a
frame or pocket hidden in the wall.

Polygon
A closed shape with three or more line seg-
ments.

Polygon Hatch
A tool that lets you draw a polygon (closed
shape with 3 or more sides) with a hatch pat-
tern applied to it.

Polyline
A continuous, multi-segmented line.

Portal Frame
A simple support structure comprising
rafters atop a pair of columns.

Print Scale
The ratio of units on paper to units on the
screen. For example, a scale of 1/4" = 1'-0"
means that every foot of the model is rep-
resented by 1/4" on paper when the drawing
is printed. A wall that is 12' long would be
3" on paper.

Profile
An outline of an object seen from the side,
as in a section view.

Project Directory
The location of the default directory in
which projects are stored.

Project Estimate
A report containing a listing of materials,
quantities, unit costs, and total cost.

Project Trace Image
A BMP, JPG or TGA image that you can
import into your drawing area.

Q

Quadrant Object Snap
Snaps to the 0-, 90-, 180- and 270-degree pos-
itions on a circle or arc.

Quantity Report
A list of the type and quantity of materials
in your model. Also known as a Materials
List or Bill of Materials.

Quoins
Stones or blocks reinforcing or accenting the
corners of a building.

Quote
A list of products with quantities, pricing
and other important information. Used by
building material supply retailers, whole-
salers, distributors and contractors to facil-
itate the design, sale and installation of
construction projects.

R

Rafter
Structural members that make up the fram-
ing for a roof and roof overhang, and that
support the sheathing and roofing materials.

Raised Heel
The vertical distance from the support point
of a truss to the point where the roof slope
intersects.

Rake
To incline from the perpendicular.

Raster
A digital image, or bitmap. A data file rep-
resenting a rectangular grid of pixels, or
points of color, on a computer monitor,
paper, or other display device.
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Raytracing
A method for rendering 3D computer
graphic images. It traces the path taken by a
ray of light from the camera through the
scene, then calculates the reflection, refrac-
tion, or absorption of the ray when it inter-
sects objects in the scene.

Render
To generate a photorealistic image of a 3D
model using a raytracing and/or radiosity
algorithm to perform lighting calculations.

Rendered Mode
A display mode where solid textures and
colors are applied to surfaces, creating a real-
istic 3D effect.

Rendered Outline Mode
A display mode where solid colors and tex-
tures are applied to surfaces, and the sur-
faces are outlined with a dark line for high
definition.

Retaining Wall
A wall constructed to contain a lateral force,
such as a bank of dirt.

Revision Cloud
A cloud shape drawn around an area of
your drawing to bring attention to that area.

Rigid Insulation
Non-flexible panels often used on roofs and
walls to provide thermal insulation.

Riser
1. The vertical board placed between the
treads of a staircase. 2. A vertical run of
pipe.

Roller Door
A door made of hinged, horizontal steel or
wood panels that move on rollers in over-
head and side tracks.

Room Division
A tool used to split an automatic floor into
multiple floor surfaces, or define an opening

in the floor.

Rough Opening
The opening created in a wall to receive a
door or window frame.

S

Saddle
A small, double-sloping roof built behind
upper-story walls or the back side of a chim-
ney to divert water around the wall or chim-
ney.

Sash
A frame that holds one or more panes of
glass and that is set into the window frame.

Scale (print)
The ratio of units on paper to units on the
screen. For example, a scale of 1/4" = 1'-0"
means that every foot of the model is rep-
resented by 1/4" on paper when the drawing
is printed. A wall that is 12' long would be
3" on paper.

Schedule
An itemized report of doors or windows in
your project which includes a description
and count for each item.

Seat Cut
The horizontal cut that is made when cut-
ting a bird's mouth in a rafter.

Section
A cross-section view created by cutting
through the building. Useful for clarifying
construction details.

Separator
Any character used to separate words, such
as a blank space or punctuation mark.

Setback
The amount of space local zoning reg-
ulations require between a lot line and a
building line.
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Shininess
The ability of a texture to reflect light.

Sill
A member located at the lower side of a
rough or finished opening, as a window sill.

Site Boundary
A closed line that shows the legal property
boundary (lot lines), and is annotated with
bearing text, length text and peg numbers.
You can specify setbacks as well, which
define your building envelope.

Slab
Concrete pavement, i.e. driveways, garages,
and basement floors.

Slope
Ground that forms an incline. Also, the
incline angle of a roof surface.

SmartView
A view of your 3D model that you insert on
a worksheet. It can be a 2D plan, elevation,
section, 3D QuickView or 3D Camera view.
A SmartView can be instantly updated if
you make changes to your model.

Snap Angle
The increment angle your cursor will snap
at (if Angle Snap is enabled).

Snap Tracking
Helps you draw objects at specific angles or
positions relative to other objects. When
snap tracking is turned on, temporary align-
ment paths appear that are based on object
snap points, such as endpoints and mid-
points.

Soffit
The area below the eave and overhang. The
underside where the roof overhangs the
walls.

Solid Filling
Solid shading applied between wall lines in
2D plan view.

Span Table
A list of wall opening widths (spans) with
head/sill/jamb configurations for each.

Specular
Reflection that creates highlights on mater-
ials, making them appear shiny.

Split L-Shaped Stairs
Stairs that ascend in an L-shaped direction
and whose landing is split on a diagonal to
make the change in direction.

Spot Point
A point on a TIN terrain mesh that contains
X, Y and Z coordinate data. Determines the
elevation of the terrain at that point.

Spreadsheet
A table of values arranged in rows and
columns.

Status Bar
The bar below the drawing area that con-
tains the Help message for the current state
or action.

Stereo Vision
A 3D view with the added perception of
depth when 3D glasses are worn.

Stringer
The inclined side of a stair that supports the
treads and risers.

Strip Footing
A flat, masonry section, usually concrete,
that is wider than the wall it supports. Used
to transfer the vertical load of the wall.

Studs
Members inserted vertically in a wall frame.

Suspended Ceiling
A grid of T-shaped bars hung on wires from
overhead support framing, into which
removable panels are inserted to form a fin-
ished ceiling that allows easy access to the
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area above it. Typically found in office build-
ings and basements.

T

Tangent Object Snap
Snaps to a point on an object that forms a
tangent between the object and another
point.

Template
A set of pre-defined properties that determ-
ines the setup and outcome of something
(like a report).

Temporary Directory
The default directory in which temporary
files generated by the program are saved.

Terrain
A piece of land.

Texture Mapping
The way in which a texture (e.g. bitmap
image) is applied to the surfaces of an ele-
ment.

Tile Height
The height of one tile in a texture pattern.
The program generates large images by
tiling texture bitmaps horizontally and ver-
tically.

Tilt Door
A door consisting of a single leaf that opens
overhead by tilting up (e.g. Tilt Garage
Door).

TIN Mesh
Triangulated Irregular Network mesh. A rep-
resentation of the terrain's surface contours
based on a set of spot level points.

Title Block
A rectangular area in the lower right corner
of a construction document which reports
information about the drawing, such as the

drawing number, drawing title, and name of
the person who prepared the drawing.

Toe Space
A recessed area between the bottom of a cab-
inet and the floor that allows you to stand
close to the cabinet. Also called a toe kick.

Top Plate
The horizontal framing member nailed to
the top of the vertical studs.

Transom
A small window sash above a door that is
hinged at bottom so it can be opened
inward.

Transparency
The degree to which a texture can be pen-
etrated by light.

Tray Ceiling
A ceiling constructed with the sides angling
at approximately 45 degrees or curving to
another flat ceiling.

Tread
The horizontal part of a stair that is stepped
on.

True North
True North is the geographic North Pole. It
is located at 90 degrees North latitude and
all lines of longitude converge at the pole.
The Earth's axis connects the north and
south poles. The Earth's axis is the line
around which the Earth rotates.

Truss
A variety of members made up into a series
of triangles. Used for constructing roofs.

Twip
Abbreviation for 'twentieth of an inch point'.
A unit of measure that determines the width
of something in print or on the screen. It
equals 1/1440 inch or 1/567 of a centimeter.
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U

U-Winder Stairs
Stairs that ascend in a U-shaped direction.

Usage
What an element is used for. For example, a
piece of wood could be used as a stud or a
beam.

UV Mapping
A UV map is a flat, 2D representation of the
vertices of the 3D model. It defines where
the 2D pixels in your texture will be placed
on the 3D surface.

V

Vector Graphic
The representation of an image through the
use of geometric objects such as curves and
polygons.

Vector Printing
A vector-based, resolution-independent
method of printing that yields sharp, high-
quality output. In vector printing, non-
objects such as the background color are not
printed.

Velocity
Quickness of motion. The distance covered
per second.

Veneer
A layer of stone, brick, stucco or other dec-
orative material that is used to cover a
framed wall.

Vent Window
A window made up of two or more seg-
ments with one segment acting as a vent.

Very Top Plate
The top member of a framed wall upon
which the rafters and ceiling joists rest. Sits
above the top plate.

Video Compression
The conversion of data into a format that
requires fewer bits, usually so that it can be
stored or transmitted more efficiently.

View Filter
A feature that allows you to turn the display
of selected objects on or off as well as con-
trol their selectability.

View Tabs
Tabs below the drawing area that provide
access to open view windows.

VRML
Virtual Reality Modeling Language. The
open standard for virtual reality on the Inter-
net.

W

Winder
One of the wedge-shaped treads that make
up a winding or spiral staircase.

Windowing
A selection method where you click and
drag a rectangle, from left to right, around
elements you want to select.

Wireframe
The default 3D view where all lines making
up elements are displayed. It allows you to
see through elements.

Wood Section
A 2D drafting symbol used to indicate the
presence of wood elements such as blocking
or posts.

Worksheet View
A 2D drafting mode where you can prepare
working drawings for print.
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X

X Axis
One of the three drawing axes. An X
coordinate specifies a horizontal distance.

Y

Y Axis
One of the three drawing axes. A Y coordin-
ate specifies a vertical distance.

Z

Z Axis
One of the three drawing axes. The Z
coordinate indicates either elevation or
depth.

Z Buffer
A block of memory used to store the Z-axis
value of a pixel on the screen. Higher depth
values improve detail of 3D display but may
slow the system.

Zenith
Culminating point.

Zoom Realtime
Magnifies or shrinks the view as you click
and drag with your mouse.

Zoom to Fit
Zooms the drawing to the extents of the
drawing area, creating a maximized view of
your entire design.

Zoom Window
Magnifies an area of your drawing that you
select by windowing.
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#

# of Horizontal Panels 85, 88-89
# of Horizontal Panes 85, 88-89
# of Vertical Panels 85, 88-89
# of Vertical Panes 85, 88-89

2

20-20 Design
exporting to 425

2D Designer's Plan 231
2D Image export 422
2D Percent Open 209
2D Plan

inserting in Worksheet View 301
viewing 229-230

2D%Open (swing) 84

3

3D Camera Views
changing 232
changing target height 234
changing the camera height 233
changing viewing field angle 234
changing viewpoint 233
creating 232
displaying 231
flying around in 229, 237
inserting in Worksheet View 301
moving cameras 233
moving the target 233
spinning the view 229, 237
walking around 229, 236

3D Model export 423
3D Overview 231
3D Percent Open 209
3D Perspective 231
3D Quick View

viewing 231
3D QuickView

inserting in Worksheeet View 301
3D Real View

about 377
adjusting brightness 380-382
adjusting burn 380, 382
adjusting intensity of trees and billboards 384
adjusting lights 385

adjusting noise reduction level 383
allowing background brightness adjustment 384
checking system graphics 498
creating 379
creating grayscale output 381
forcing wall sides to be exterior 63
quality level 382
saving 381
setting global location 378
setting plant season 379
setting the lighting 378
setting the viewpoint 378
surface properties of materials 385
troubleshooting 385
using antialiasing 383
using background texture as light source 384

3D Stereo View 247
3D Studio export 423
3D Studio files, importing 431
3D%Open (swing) 84
3DS export 423
3DS import 420, 431, 466

A

Accessories
exterior 220
interior 140

Activate View 231, 233-234, 241
Activation, program xxxi
Active with CTRL key only (Auto Scroll) xxxviii
Add Assembly 468
Add Catalog 432
Add City 378
Add Control Point 389
Add Element 439, 446
Add field 370
Add Group 429, 446
Add layer 296
Add location data before prefix (wall panel tag) 162,

164, 170
Add location data before suffix (wall panel tag) 162,

164, 170
Add Member to Structural Floor 99
Add Node

ceiling 108
deck 214
floor 103

Add Opening Height after Width 269
Add Profile 475
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Add Sound Node 390
Add Subgroup 429
Add Surface Node 128
Add Template 358
Add Text Style 459
Adjust Height to Door 85
Adjust Height to Window 89
Adjust Support Height (Move Edge) 120
Adjust to Plane 81
Adjust Width 85, 89, 110, 113
Adopting default fields 371
Advanced Members 75-77
Advanced toolbar color settings 494
Age, plants 198
Air conditioners, central 144
Air returns 144
Align Dimension 275, 318
Aligned dimensions 271, 315
All (Extents), printing 410
All Locations On/Off 251
Allow brightness adjustment 384
Alternate Code sorting in estimate 363
Analyzing a model in REScheck 376
Angle bearing method 192, 195
Angle from Joists 215
Angle from True North 378
Angle measurement, site boundary 195
Angle of Rotation 402
Angle precision xxxv, 461
Angle Snap 399
Angle units 461
Angle, imported CAD file 288
Angle, imported image 310, 416
Angle, PDF 290, 309
Angle, slope 184
Angle, terrain mesh 187
Angled walls 64
Angles, measuring 340
Angular Dimensions 271, 315
Animation

adding control points 389
adding sounds 390
adjusting Burn value 391
changing path order 389
changing speed 392
choosing paths to include 389
compressing 393
creating 386
deleting path 394

drawing path 386
drawing target paths 387
editing elevation of target 390
editing frame rate 393
editing resolution size 393
elevating control points 390
moving control points 389
previewing 388
ray tracing 394
removing path control points 389
removing sounds 390
repeating during preview 388
saving individual frames 392
saving to file 391
specifying file name 392
specifying save location 392
tilting the camera 390
turning paths on/off 394

Animation Paths On/Off 394
Antialiasing

renderings 383
text in Worksheet View 313

Apexed doors 85
App, VR 381
Appearance matching 228
Appearance properties 444
Appliances

in KitchenWizard configuration 135
inserting 140
inserting with Kitchen Builder Wizard 133

Apply Name Changes to Selected Panel(s) 171
Apply to All Similar (paintbrush) 227
Approx. Edge Spacing 206
Arbors 219
Arc Direction 194
Arc Radius 194
Arc size, revision cloud 283, 340
Arc, elliptical 281, 323
Arched doors 85
Arcs

assigning a layer to 342
converting to 3D building elements 283
drawing in Model View 278
drawing in Worksheet View 321
editing curve in Model View 279
editing curve in Worksheet View 322
editing line style in Worksheet View 340
extending to other objects in Model View 279
trimming to other objects in Model View 279

Area unit of measure xxxiv
Area, room 344
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Area/Perimeter Calculator 343
Arraying

elements in Model View 225
members 81
objects in Worksheet View 336

Arrow keys, panning and navigating with 240
Arrow length 129
Arrow rotation 129
Arrow scaling 314
Arrow style, leader 266
Art*lantis export 423
Artifacts, eliminating 498
Ascending sort order in quantity reports 363
Assemblies

applying to materials 453
attaching to elements 350
customizing library 468
defining 468
deleting from library 468
ignoring for materials in estimate 352
removing from elements 350
replacing elements with in reports 351
tracing and replacing elements 440, 470

Attach footings to all similar columns 73
Attach Sound File 395
Attic Truss 78
Attributes

creating blocks with 333
defining 332
editing before capturing in a block 333
editing values 334
inserting blocks with 333

Authorization, program xxxi
Auto-cut terrain around building 180
Auto-rename Openings 93
Auto Break walls 66
Auto Extend wall tops 64
Auto Exterior Dimensions 268

creating 268
specifying settings for 268

Auto Interior Dimensions
creating 269
specifying settings 270

Auto Name 441
Auto Place Outlets 142
Auto Save

setting 406
Auto Scroll

controlling speed xxxviii
setting to be active with CTRL key only xxxviii

turning on/off xxxviii
Auto texture mapping 444
AutoCAD

exporting 2D plan to 423
exporting 3D model to 423

Automatic Name Generation
modifying formula for 441
using 441

Automatically Insert Floors 101
AVI export 391
Avoid Saddle Situations 118

B

Background
color 496
scene 235

Background brightness adjustment, allowing 384
Background texture, using as light source 384
Backsplash, properties 139
Backsplash, showing 138
Backup files 407
Baluster Depth 116
Baluster Spacing 116
Baluster Style 116
Baluster Width 116
Balustrades 113-114
Bark 204
Barn rafters 77
Base Height 400
Base Level, terrain 179
Base Offset 74, 223
Baseboards 67
Baseline dimensions 273, 316
Baseline Offset (for Baseline dimensions) 460
Baseline offset for walls 56
Basement, creating 57
Batch printing 414
Bathroom Builder Wizard

creating bathroom with 136
custom configuration 137

Bathroom Configuration 137
Bathrooms, designing 136
Bathtubs 144
Batt Insulation

assigning a layer to 342
drawing in Model View 283
drawing in Worksheet View 327
editing line style in Worksheet View 340

BC Framer export 424
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Beams 74
Bearing format 196
Bearing Line

inserting in structural floor 98
moving/stretching 98
removing 98

Bearing text style 195
Beds 140
Beds, garden 204
Behavior, light 141
Benches 220
Berms/Trenches

creating 182
editing height 182
editing shape 182
stretching 182

Bill of Materials 351
Billboard 418-419
BIM file

exporting catalog content to 425
exporting project content to 426
importing 421, 433
importing project content from 422

Bird baths 220
Bitmaps, custom 453
Black-and-white printing 410, 412
Black-and-white renderings, creating 381
Blanket insulation 283, 327
Blinds 140
Block Import Options 431
Block section 284, 328
Block simplification 443
Blocking 328, 487
Blocks

creating 330
creating with attributes 333
defining attributes 332
deleting unreferenced 332
editing 332
editing attribute values 334
inserting 331
inserting from other projects 331
inserting with attributes 333
scaling 331

BMP export 422
BMP import 310, 415, 453
Board-and-Batten shutters 94
Board Depth 208-209
Board Offset 208-209
Board Spacing 208-209

Board Width 208-209
Boards, corner 69
Boise BC Framer export 424
BOM from selected panel(s) 178
Bookshelves 140
Border lines 375
Borders, drawing

deleting default 306
inserting in Model View 287
inserting in Worksheet View 306

Borders, garden 220
Borders, wallpaper 67
Bottom Plate 148
Bottom Plate, cutting out in openings 485
Bottom Plate, defining 484
Bottom Rail Depth 116
Bottom Rail Height 115, 208-209
Bottom Rail Style 116
Bottom Rail Width 116
Boundary Hatch

editing hatch pattern 327
editing hatch pattern line properties 327
using 326

Boundary line, polygon 282
Boundary, terrain 181
Bowls 140
Box ceilings 106
Box mapping, material 451
Box texture mapping 444
Break at Columns 81
Break at Members 81
Break at Walls 81
Break line 285, 329
Breaking

edging 206
fences 207
lines in Model View 278
members 80
members at other elements 81
objects in Worksheet View 338
roofs 122
strip footings 72
walls 66-67

Brick section 284, 328
Bridging channel 487
Brightness

in renderings 380, 382
of animations 391
of rendered images 380-381
of trees and billboards in rendered images 384
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Brightness adjustment, background 384
Browse More Catalog Content 433
Building a house 51
Building Configuration 53
Building Locations

adding 48
checking which location is current 49
defining 47
defining wall framing options 147
dimming 49
displaying/hiding 251
filtering from project estimate 352
grouping by in cut list 356
making a location current 49
making selectable/non-selectable 253
querying an element's location 403

Building lot 191-192
Buildsoft template (Constellation) 351
Bulbs, light 141
Bump mapping 451
Burn

in animations 391
in renderings 380, 382

By Color component creation 287
By Layer component creation 287
BYLAYER 298

C

C-Shape member 81
Cabinets

editing 2D display 138
editing properties 138
editing solid fill colors 60
enabling/disabling solid fill 60
in BathroomWizard configuration 137
in KitchenWizard configuration 135
inserting 137
inserting countertop over 139
inserting with Kitchen Builder Wizard 133
medicine 140
solid filling 59
specifying mark method 276
specifying mark settings 277

Cable service boxes 141
CAD files

assigning a layer to inserted blocks 342
importing in Worksheet View 306
inserting in Model View 287

Calculate total linear length only 355-357, 361
Camera Properties 233-234

Camera views
changing 232
changing target height 234
changing the camera height 233
changing the viewing field angle 234
changing viewpoint 233
creating 232
displaying 231
moving cameras 233
moving the target 233

Cameras
changing height 233
moving 233
orbiting around model 229, 237
placing new 232
resetting 238
spinning 229, 237
turning on/off 232

Cameras On/Off 232
Cars 220
Cartesian Coordinate System 401
Cascade Open Views 262
Catalog Manager 437
Catalog panel

displaying/hiding 495
moving 496
resizing 495

Catalog Properties 434
Catalogs

accessing 437
accessing libraries 449
adding a group or subgroup 429
adding elements 439, 446
adding plants from Encyclopedia 204
copying 434
creating 432
deleting elements from 441
deleting groups 430
editing elements 439
exporting content to a BIM file 425
exporting quantitative properties to text file 349
importing content from other catalogs 421
importing manufacturer content 433
importing objects 431
locking 433
moving subgroups to the root 429
opening 434
renaming groups 430
saving 434
saving elements in drawing to 430
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searching 438
selecting default directory 434
simplifying an element 443
unlocking 433
viewing properties 434

Catalogs Directory 434
Categories

assigning to elements 347
assigning to purchased items 357
customizing categories library 472
exporting for all elements to text file 349

Categories library, customizing 472
Cathedral ceilings 107
Cathedral Truss 78
CD stands 140
Ceiling by Perimeter 105
Ceiling by Picking Points 106
Ceiling by Room 105
Ceiling fans 141
Ceiling Height 48
Ceiling Openings

creating 108
removing 108
reshaping 108
resizing 108

Ceilings
about 105
adding a node 108
by Perimeter 105
by Picking Points 106
by Room 105
cathedral 107
converting framing to members 159
creating manually 127
cutting openings 108
defining extents of ceilings inserted in

rooms 107
defining height 47
framing 155
removing openings from 108
reshaping 107
reshaping openings 108
resizing 107
resizing openings 108
stretching 108
tray 106

Center on wall
door 83
opening 91
window 87

Center snap 300-301

Center, inserting openings to 93
Central Air Units 144
Central Vac 141
Central Vac Outlets 142
Chair Rails 67
Chairs 140
Chamfer 339
Change Style 276
Check System (graphics) 498
Circles

assigning a layer to 342
converting to 3D building elements 283
drawing in Model View 280
drawing in Worksheet View 322
editing line style in Worksheet View 340

City 378
Cleaning equipment 141
Clear All fields 371
Clip Terrain 194
Clocks 140
Close 409
Close View 260
Closed Riser 219
Closing

project estimate dialog 353
projects 409
view windows 260

Clouds, revision 282, 325
Cold Angle member 81
Cold Rolled C member 81
Collapse All (groups) 258
Collapsing groups 258
Collision Control 399
Color

applying with paintbrush 226
background 496
editing for element patterns 445
editing for elements through layers 444
editing for layers in current project 297
editing for layers in layers library 463
editing solid fill for elements 60
grid 397
loading a toolbar color theme 495
material 451
overriding layer color 298
saving toolbar color settings to a theme 494
toolbar areas 494
toolbars 494

Color Bleed 385
Color Temperature (light) 465
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Columns
breaking members at 81
creating custom profiles 475
decorative 220
editing dimensions 74
editing elevation 74
editing shape 74
inserting 74
inserting mono footings under 73
reporting in purchased lengths 356
specifying purchased lengths 357
using optimized results in quantity report 363

Comfort Adjustment 247
Comma-delimited fields 367
Command shortcuts 497
Commander

defining X, Y, Z coordinates 401
displaying 400
entering values 401
selecting a reference point 401
specifying distance/direction 401-402
specifying insertion heights 400
turning off 400
using 400
using to curve 402
using to rotate 402

Common plant names 199
Company information 427
Component display 442
Component Solutions export 424
Composite walls 55, 61
Compost boxes 141
Compression, animation 393
Computers 140
Concrete section 284, 328
Connection, railing 115
Constellation report templates 351
Contact information xxxvii
Context-sensitive help xxxvii, xxxvii
Continuous dimensions 272, 316
Continuous Motion setting 241
Contours, terrain 180, 184, 187-189
Contractor quote 371
Control Points

adding to animation path 389
elevating 390
moving 389
removing 389

Controller, viewing/navigation 229

Convert a Copy xxxiii
Convert Framing to Members 159
Convert Roof to Surfaces 124
Convert the Original xxxiii
Convert to grayscale 381
Convert to Image, PDF 290
Convert to Structural Floor 103
Converting

drafting objects to 3D elements 283
floors to structural floors 103
hip to gable 118
older projects xxxiii
roofs to surfaces 124

Cooling units 144
Coordinate Icon 400
Coordinates 401
Copies, print 410-411
Copy Template 359
Copy View 259
Copying

by array in Model View 225
by array in Worksheet View 336
catalogs 434
elements 224
elements to other locations 225
members by offset 81
objects by offset 337
objects in Worksheet View 336
report templates 359
view windows 259
views 285
walls 57

Corner accents 220
Corner Boards 69
Corner Details

adding to walls 69
editing 69

Corner framing 151
Corrupted projects 406
Cost field 367
Cost, unit 349
Counter, showing 138
Countertops

editing 139
inserting 139

Country 378
Cove Molding 67
Create New Elevation 241
Create New from Template xxxii, xxxii, xxxiii
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Create New Project xxxii, xxxiii
Create New Section 244
Cripples, defining 479
Cropped textures 453
Cropping

CAD file during import 288
image during import 311, 416
PDF during import 290, 309
terrain mesh during import 187

Cross-sections 244, 246
Crosshairs 295
Crossing selection method 334
Crown Molding 67
CSD export 424
CSG TakeOff Plus template 351
CSV export, wall panels 178
CSV report template 351
Cups 140
Currency symbol, controlling display of 362
Current building location 49
Current view window 261
Cursor 295
Curtains 140
Curve removal (polyline) 321
Curving

elements 224
fills 205
polylines 321
site boundary edges 194
surfaces 131
using the Commander 402
walls 66

Custom Block import 431, 439
Custom door leaf import 466
Custom elements 439, 446
Custom object import 420, 431
Custom textures 453
Customer Care xxxvii
Customizing

assemblies library 468
dimension styles library 459
door leafs library 465
keyboard shortcuts 497
labels library 458
light source library 464
line styles library 461
line types library 462
line weights library 463
material filters library 455
material usages library 454

materials library 450
patterns library 456
profiles library 474
title block 306

Cut-off textures 453
Cut an Opening Around Next Story 118
Cut and Paste (Model View) 225
Cut Down Long Members 355, 361
Cut Lengths 356-357

including in quantity report 347
Cut Line

drawing in Model View 285
drawing in Worksheet View 329
editing line style in Worksheet View 340

Cut List
disabling generation 358
filtering locations 352
optimizing 354
preview 353
printing 356
specfiying settings for 354
specifying purchased lengths for members 356-

357
using results in quantity report 363
viewing 353

Cut one piece from each purchased length 355,
361

Cut Opening
ceilings 108
deck 216
floors 104
roofs 124
structural floor 99
surfaces 131

Cut opening bottom plate 485
Cutaway view 246
Cutting Allowance 355
Cutting terrain around building 180

D

D-Section member 81
Damaged projects 406
Date, setting for a scene 235
Datum Lines

defining appearance 303
including in elevations and sections 301

Deck Builder Wizard
using 212

Deck Openings
inserting 216
removing 217
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reshaping 217
resizing 217

Deck Stairs
adding 217
controlling railing display 218
editing risers 218
editing size 217
editing stringers 218
editing treads 218

Decks
adding a node 214
adding stairs 217
building with Deck Builder Wizard 212
building with Deck tool 213
changing decking direction 214
changing skirting material 216
controlling display of railings 216
controlling display of skirting 216
displaying footings 215
editing footings 215
editing frame 215
editing height 214
editing posts 215
inserting openings 216
railing style 216
reshaping 214
stretching 214

Decorative columns 220
Decurving polylines 321
Default Drafting Settings 144, 341-342
Default line style for wiring 144
Default Print Setup, wall panels 176
Default save directory 407

projects 407
Define Block 330, 333
Define Floors 104
Define SmartView 301
Define Surface 128
Definition, pattern 456
Degree precision xxxv
Delete Assembly 468
Delete Unreferenced Blocks 332
Delete Unreferenced SmartViews 306
Delete View 260
Deleting

animation paths 394
assemblies 468
assemblies from elements 350
bearing line 98
ceiling openings 108

deck openings 217
deck railings 216
default drawing border 306
default title block 306
elements 228
elements from catalog 441
elevations 243
fields from records 371
floor openings 104-105
groups from catalogs and libraries 430
groups from View Manager 258
layers 298
members from structural floor 99
objects in Worksheet View 340
photo board 420
project trace image 417
report templates 360
section views 246
surface openings 132
text styles 459
unreferenced blocks 332
unreferenced SmartViews 306
view windows 260
walls 67

Delimiter 366
Delimiter field 367
Depth below ground level 215
Descending sort order in quantity reports 363
Description field 365-366
Description, report template 362
Deselect All 43-44, 335
Deselecting elements 44
Designer's Plan, 2D 231
Desks 140
Detached garages 219
Details

assigning a layer to 342
assigning default line style 342
batt insulation 283, 327
corner 69
cut line 285, 329
deck stairs 218
doors 86
inserting pre-defined 287, 306
masonry section 284, 328
member spacing note 330
rigid insulation 284, 328
roof symbol 329
stairs 111
windows 90
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wood section 284, 328
Diagrams, wall panel 161, 166
Dialog help xxxvii
Diffuse material properties 451
Dimension Lap 460
Dimension Offset 460
Dimension Settings

Auto Exterior 268
Auto Interior 270

Dimension Styles
adding 459
current 268, 315
deleting 459
editing 459
editing dimensions in Model View 276
editing dimensions in Worksheet View 319
selecting for wall panel diagrams 165, 172-173
specifying for text with leader 267
updating globally 276

Dimension to Center 93
Dimension to Edge 94
Dimension to stud 269
Dimensions

adding opening height after width 269
aligned 271, 315
aligning 275, 318
angular 271, 315
assigning a layer to 342
Auto Exterior Dimensions 268
Auto Interior 269
auto interior settings 270
baseline 273, 316
changing style globally 276
changing style in Model View 276
changing style in Worksheet View 319
continuous 272, 316
customizing styles 459
dimensioning to stud 269
dynamic dimension settings 60
editing onscreen to move walls 65
editing the separator in opening

dimensions 269
element dimensions 442
Exterior Dimension Settings 268
joining 275, 318
linear 271, 315
moving dimension line 274, 318
moving text in Worksheet View 317
overall 273, 317
overriding text in Model View 275
overriding text in Worksheet View 319

properties 460
resetting text position 318
room 274
scaling 319
scaling values 320
setting current style in Model View 268
setting current style in Worksheet View 315
splitting 275, 318
stretching in Model View 274
stretching in Worksheet View 318
text style 460
units 460
using tape measure 340, 402
wall panel diagrams 165, 172-173

Dimming Percentage 49
Dimming, imported CAD file 288
Dimming, imported image 311, 416
Dimming, PDF 290, 309
Direction 401-402
Direction of deck boards 214
Direction, site boundary edges 193
Directories

drafting settings 289
light sources 465
project 407
save 407
temporary files 409
textures 454

Disabling Ortho temporarily 398
Diseases, plant 202
Dishwashers 140
Display (Print) 410-411
Display All 249-251
Display All But Framing 146
Display Currency Symbol 360, 362
Display Filter

filtering building elements from view 250
filtering building locations from view 251
filtering elements on terrain 251
filtering Framing Mode components 252
filtering notation objects 251
filtering project trace images from view 417
using 249

Display Framing 145
Display Gable 123
Display layer 299
Display Mode 247
Display None 249, 251
Display of element parts 442
Display on startup (Startup screen) 497
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Display order, layer 300
Display Properties (screen) xxxvi
Display Wall Tags, in wall panel diagrams 165, 172
Display, improving 498
Displaying

Framing Mode components 252
layers 299-300
terrain contour labels 189

Disposals, garbage 141
Distance

measuring in Model View 402
measuring in Worksheet View 340
specifying in Commander 401

Distance above current location or terrain 223, 443
Distance from line 195
Dividing rooms 103
Division 347, 357
Division line, moving 103
Division lines 375
Division sorting in estimate 363
Dollar signs, controlling display of 362
Door Bells 142
Door Heads 67
Door Leaf Import Wizard 466
Door leafs

customizing library 465
editing properties 467
importing custom 466

Door mats 220
Door Schedule

defining field layout 374
defining line styles 375
defining marks 375
defining text styles 375
generating 372
printing 374
removing schedule marks 376

Door Sills 67
Door Swing Direction 84
Door Trim 67
Doors

adding height after width in dimensions 269
adding trim 67
cutting out bottom plate 485
displaying sidelites/highlites 85
editing details 86
editing dynamic dimension settings 60
editing leaf 86
editing shape 85
editing size 85

editing swing properties 84
editing type 85
energy properties 86
flip entire 84
flipping swing 84
importing custom door leafs 466
inserting 83
inserting to center 93
inserting to edge 94
moving 83
removing trim from openings 87
sidelites/highlites 85
specifying definition of right-hand vs. left-

hand 84
specifying mark method 276
specifying mark settings 277
stretching 93
turning marks on/off 277
U-Factor 86

Dormer
inserting 124

Dormer Roof 124
Double Angle member 81
Down to current location 217
Down to deck location 218
Down to terrain 218
Drafting Settings

default line style for details 342
default line style for drafting objects 341
default line style for wiring 144
defaults for hatched polygons 342

Drafting Settings Directory 289
Drafting symbols 287, 306
Drafting worksheets

creating new 258
Drag and Drop mode 221
Drawing Aids

Angle Snap 399
Collision Control 399
Grid 397
Grid Snap 398
Object Snap 300, 398
Ortho 398
Snap Tracking 399

Drawing borders
deleting default 306
inserting in Model View 287
inserting in Worksheet View 306
wall panel diagrams 165, 175

Drawing Grid 397
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Drawing scale, project trace image 416
Drivers, checking 498
Driveways 189
Drop Exterior Face 61, 63
Dryers 140
Drywall 61
Dull finish 385
Duplicate 224, 336
Duplicate to Locations 57, 225
DVD players 140
DWG export 423
DWG import 287, 306, 420, 431, 466
DXF export 423
DXF import 287, 306, 420, 431, 466
Dynamic Cutaway 246
Dynamic Dimensions

editing settings 60
editing to move walls 65

E

Edge Height 206
EdgeWidth 206
Edge, inserting openings to 94
Edging

breaking 206
changing length 206
cleaning up corners 206
converting drafting objects to 283
editing size 206
inserting 205
repeating 43

Edit Assembly 468
Edit Block Attributes 334
Edit block definition 332
Edit City 378
Edit dimension to move wall 65
Edit Door Leaf 467
Edit Line 456
Edit mode 43
Edit prevention on layers 299
Edit Profile 476
Edit SmartView definition 304
Edit Template 359
Edit Text Style 459
Editing

attributes before capture 333
elements in catalog 439
elements in drawing 45
elements in Model View 45

fields in estimate records 367
objects in Worksheet View 334
Select/Edit mode 43

Editing restrictions 433
ELCmember 81
Electrical Elements

inserting 142
Electrical Junction Box 141
Electrical lights noise reduction 383
Electrical Wiring

assigning a layer to 342
inserting 143
selecting default line style 144

Electronics
inserting 140

Element fields, editing 366
Element Filter 250
Element Filter in Report Template 360
Element help xxxvii
Element import 420
Element Manager 437-438
Element Properties 347, 349, 437, 439, 441-443,

445-446
Elements

adding to catalog 439, 446
editing properties 437, 439
filtering from project estimate 364
modifying 45
querying 403
searching for in Element Manager 438
selecting 43

Elev from 0 401
Elev from Current 401
Elev from Location 401
Elevate

about 223
terrain 179
walls 63

Elevate Control Point 390
Elevation labels, contour 189
Elevation Marks

moving 242
turning on/off 242

Elevation Properties 243
Elevation, contours 180
Elevation, terrain 179
Elevation, walls 63
Elevations 303

creating custom 241
deleting 243
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detailing 243
editing properties 243
including in wall panel diagrams 165, 171
inserting in Worksheet View 301
missing or extra lines in inserted

SmartViews 303
moving target 243
turning marks on/off 242
viewing 241

Ellipse
drawing in Model View 280
drawing in Worksheet View 323

Elliptical Arc
drawing in Model View 281
drawing in Worksheet View 323

Emissive 385
Emissive property, material 451
Enable Sun Light 235
Enable Antialiased Text 313
Enable Screen Tips in Model Views 44
Encyclopedia

about 199
accessing 199
adding plants to catalog from 204
diseases page 202
inserting plants from 203
main page 199
notebook page 201
picture page 201
plant care calendar 201
plant filter 202
searching for a plant 199
selecting a plant to view 199
viewing plant information 200
world map page 201

End conditions
customizing library 489
defining a configuration 490
defining for members 82
selecting for intersection configurations 151
specifying for exterior dimensions 269

Endpoint snap 300-301
Energy calculations, door 86
Energy calculations, window 90
Enforce Material Usages 455
Enter via spacebar 43
Enter, in Worksheet View 334
Entering wall lengths 400-401
Equipment

inserting 141

ERP, uploading data to 371
Estimate

adding fields to 370
controlling inclusion of ceiling frame

members 155
controlling inclusion of floor frame

members 154
controlling inclusion of roof frame members 156
creating new report template 358
disabling cut list generation 358
editing element entries 366
editing headers/footers 365
editing pricing 349
editing quantitative properties of elements 347
editing report template 359
excluding elements from 353
filtering elements from 364
filtering locations from 352
generating a quote 371
ignoring assemblies attached to materials 352
opening quantity report in editor 353
printing cut list 356
printing quantity report 352
replacing elements with assemblies 351
report template properties 360
saving quantity report 352
selecting report template 351
sort order of materials 363
specifying how information is reported 364
uploading to ERP 371
using optimized results for members 363
viewing quantity report 351

Estimator template 351
Example projects xxxiv
Excavated areas 183
Excel template 351
Exercise equipment 141
Expand All (groups) 258
Expanding groups 258
Explicit Height 218
Exploding

objects in Worksheet View 340
roofs 124

Export Polyline to Profile Library 476
Export to BIM File 425
Export TXT File 349
Exporting

2D Drawing 423
3D Model 423
catalog content to a BIM file 425
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polylines to profile library 476
project content to BIM file 426
quantitative properties of catalog elements to

text file 349
to 20-20 Design 425
to 3D Studio (3DS) 423
to BMP 422
to Boise BC Framer 424
to CSD iStruct 424
to DWG 423
to DXF 423
to IFC file 423
to JPG 422
to Keymark GS Software Suite 424
to Lightscape (*.LP) 423
to MiTek SAPPHIRE Structure 424
to PDF file 413
to REScheck 376
to Simpson Component Solutions 424
to Sketchfab 425
to SKP 423
to TGA 422
to Weyerhaeuser Javelin 424
wall panels to CSV file 178

Exposure, scene 235
Extend to Plane (member) 81
Extend/Trim to Cutting Edge (members) 80
Extending

arcs in Model View 279
fences 207
lines 277
members to cutting edge 80
members to plane 81
objects in Worksheet View 338
railings 116
wall surface down 61
walls 62
walls to gable roof 64

Extension (cut line) 112
Extension Below Base 63
Extension for Generated Reports 362
Extension Lap 460
Extension Lines 269
Extension Offset 460
Extension, gable ladder 158
Extension, head/sill trim 67
Extents of ceiling in a room 107
Extents of floors in rooms 102
Extents of room regions in rooms 346
Extents, printing 410

Exterior Accessories
inserting 220

Exterior Dimension Settings 268
Exterior dimensions 268
Exterior Furniture

inserting 220
Exterior Side (wall) 68
Exterior Structures

inserting 219
inserting house templates 219

Exterior wall assembly option 350
Exterior wall surface 61
Exterior Wall Tops to Roof 64
Eyedropper 227

F

Face slider 85
Face texture mapping 444
Fascia board 156
Fascia Depth 123, 131
Fascia Distance 123
Fascia surface edge definition 130
FAST template (Constellation) 351
Faucets 144
Fax machines 140
Feet-Inches

in site boundary 195
working in xxxiv

Fence line, trimming members to 80
Fences

breaking 207
changing length 207
editing properties 207
inserting 206
parts 207
repeating 43
stretching 207

Field editing 364-366
Field width 366
Fields

adding to records 370
deleting from records 371
editing 367

File name, animation 392
File Paths

Catalogs Directory 434
Drafting Settings Directory 289
Lights Directory 465
Projects directory 407
Sounds Directory 396
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Temporary Files 409
Textures Directory 454

Files, recently used 405
Fill, solid 59-60
Filler cabinets 138
Fillet 339
Fillet - Join 339
Fillet - Radius 339
Filleted member 81
Fills

creating 204
curving 205
editing solid fill colors 60
enabling/disabling solid fill 60
reshaping 205
resizing 205
solid filling 59

Filter lock 250, 252
Filtering

building elements for selection 252
building locations for selection 253
building locations from view 251
display 249
element parts from display 442
elements from project estimate 364
elements in Project Estimate 360
elements on locations 250
Framing Mode components for selection 254
Framing Mode components from view 252
landscape elements for selection 253
landscape elements from view 251
locations from project estimate 352
materials library 454
notation objects for selection 254
notation objects from view 251
plants 202
project trace images from view 417
selectability 252

Find and Replace
text in Model View 265
text in Worksheet View 312

Finding text in Model View 265
Finding text in Worksheet View 312
Finishing commands 41
Fink Truss 78
Fireplaces 144
Fireplaces, outdoor 220
Fit to Page 411-412
Flat Truss 78
Flip End (intersection framing) 151

Flip Framing 149
Flip Opening

doors 84
gates 208
wall openings 92
windows 88

Flip Swing
door 84
gate 209

Flipping
door swings 84
doors 84
gate swing 209
gates 208
wall openings 92
windows 88

Floating cabinet 139
Floor and Foundation Builder Wizard 57
Floor by Perimeter 101
Floor by Picking Points 102
Floor by Room 101
Floor joist note 330
Floor Locations

defining 47
filtering from project estimate 352
filtering from view 251
making selectable/non-selectable 253
querying an element's location 403

Floor plan import 289, 308
Floor plan insertion 301
Floor registers 144
Floor Structure

adding members 99
cutting opening in 99
editing properties 99
inserting a bearing line 98
inserting by perimeter 97-98
inserting by room 97
moving framing base point 99
moving/stretching a bearing line 98
removing a bearing line 98
removing added members 99

Floor to Floor Distance 48
Floors

about 100
adding a location 48
adding a node 103
building locations 47
building new levels with Wizard 57
converting framing to members 159
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converting to structural floors 103
creating manually 127
defining extents of floors inserted in rooms 102
dimming 49
disabling/enabling automatic insertion 101
dividing 103
editing solid fill colors 60
editing thickness 103
enabling/disabling solid fill 60
framing 154
inserting by perimeter 101
inserting by picking points 102
inserting by room 101
inserting openings in 104
moving defined edges 101
removing openings 104-105
reshaping 102
reshaping openings 104
resizing 102
resizing openings 104
solid filling 59
stretching 103

Flowers 197, 203
Fly Around 229, 237, 239-240
Fold-up door 85
Follow Path 387
Font 264
Font Style 264
Font support in imported PDFs 308
Footers 365
Footings

converting drafting objects to 283
mono 73
strip 71
under deck posts 215

Forced gables 122
Forcing wall sides to be exterior 63
Formulas

defining 368
loading 370
saving 370
selecting for element records 366
testing 370

Foundation
stepped 64

Foundation Builder Wizard 57
Fountains 220
Frame as Load Bearing 147
Frame Rate, animation 393
Frame type, window 90
Frame, door 86

Frame, skylight 125
Frame, window 90
Frames, animation 392
Frames, portal 77-78
Frames, timber 77-78
Framing

ceilings 155
controlling selectability in Framing Mode 254
customizing for individual walls 148
displaying 145
displaying all but 146
filtering Framing Mode components from

view 252
flipping in wall 149
floors 154
locking visibility 249-250
roofs 123, 156
selecting wall framing member 146
walls 146
walls as load-bearing 147
walls as non-load-bearing 147

Framing Base Point, structural floor 99
Framing libraries

head/sill/jamb library 478
intersection lookup table 489
wall end condition 489
wall infill 483
wall opening span table 477

Framing Member (wall) 148
Framing Mode

controlling selectability of framing
components 254

creating custom intersection framing con-
figurations 151

editing framing rule for individual walls 149
editing head/sill/jamb configuration for individual

openings 150
editing infill for individual walls 148
editing intersection framing 151
editing span table selection for individual

walls 150
enabling/disabling 148
filtering framing components from view 252

Framing Options
defining in building locations 147
per building location 48

Framing panels, wall 161, 163, 166
Framing rule

selecting for building locations 147
selecting for individual walls or wall types 149

Freeze pick 254
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Freezers 140
Fresnel 451
Front Elevation 241
Fully Reflective finish 385
Fully Transparent finish 385
Furnaces 144
Furniture

exterior 220
interior 140

Furring channel 487

G

Gable board 156
Gable dormer 124
Gable end appearance 64, 119
Gable end display 122
Gable end walls 119
Gable Front 125
Gable ladder 156
Gable return type 123, 131
Gable roof 118
Gable surface edge definition 130
Gable type 131
Gables, mid-fascia 122
Gamma correction 380, 382
Gap 68
Garage door sill 87
Garages, detached 219
Garbage disposals 141
Garden Beds 204
Garden borders 220
Garden boxes 219
Gas Meters 141
Gate Height 209
Gate Width 209
Gates

editing properties 209
flipping 208
flipping swing 209
inserting 208

Gazebos 219
Generate Quote 371
Girders 74
Glaze type, window 90
Global illumination 379, 381
Global Position 378
Global update of SmartViews 305
Glossary xxxvii

Google SketchUp import 420, 431, 466
Grade Level (site data) 186
Gradient toolbars 494
Graininess, preventing in renderings 383
Graphics

improving display 498
problems with 498
specifying VR view type 235, 499

Graphics system check 498
Gravel 204
Grayscale renderings, creating 381
Green 3D Home.com 376
Greenhouses 219
Grid Color 397
Grid Snap 398
Grid Style 397
Grid, drawing 397
Group by Location, in cut list 356
Group by Usage, in cut list 356
Group similar length items 355, 361
Grouped Elements

creating 446
editing 447
inserting 447

Grouping elements 446
Groups

adding to catalogs and libraries 429
adding to View Manager 257

Growing plants 198
GS Software Suite export 424
Gutter member 81

H

Half Truss 78
Handicap access 109
Handle Style 139
Handles 139
Handrail Depth 115
Handrail Height 115
Handrail Style 115
Handrail Width 115
Handrails 113-114
Hatching

creating hatched polygons in Model View 282
creating hatched polygons in Worksheet

View 324
creating with Boundary Hatch 326
editing for elements 445
editing for polygons in Model View 282
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editing for polygons in Worksheet View 325
editing line properties for hatched polygons 325
editing line properties in Worksheet View 327
editing pattern in Worksheet View 327

Head Height 48, 400
Head, window/door 67
Head/Sill/Jamb configuration 147

assigning to a span table 477
customizing library 478
defining 479
selecting for individual openings 150
selecting in building locations 147
selecting span tables for individual walls 150

Head/Sill/Jamb Tool filter 252, 254
Header line style, openings 93
Headers

defining for ceiling openings 155
defining for floor openings 154
defining for roof openings 156
defining in report templates 365
defining in wall framing 479

Heaters 142
Heating elements 144
Height

berm 182
ceiling 48
deck 214
floor 47
hill 182
insertion height 443
plateau 183
roof 123
slope 184
specifying before insertion 400
Target 234
wall 47, 62

Height above current location 214
Height, opening 269
Height, terrain 179
Help

context-sensitive help xxxvii
online help xxxvi
technical support xxxvii
Tutor xxxvii

Hidden Line display mode 247
Hide All Items Except 254
Hiding

all except picked 254
animation paths 394
building elements 250
building locations 251

by picking 254
catalog panel 495
elements on terrain 251
Framing Mode components 252
information panel 495
layers 299
Navigator 230
notation objects 251
panel 495
parts of elements 442
project trace images 417
terrain contour labels 189
toolbars 493

Hiding elements from view 249
High Gloss finish 385
Highlites

doors 85
windows 89

Hills
editing height/shape 182
inserting 181

Hip board 156
Hip surface edge definition 130
Hip to Gable 118
History, material usage 227-228
History, work 427
HomeDev template (Constellation) 351
Horiz. Distance 123
Horizontal Separation 86, 90
Horizontal Text 460
Hot tubs 219
House Builder Wizard

custom configuration 53
launching automatically at startup 53
running 51

House Templates 219
Hug Terrain 191
HVAC Elements

inserting 144
Hyperlinks

adding 445
making current 446
opening 446

I

I-beams 74
Icon, coordinate 400
IFC export 423
IFC file

importing 422
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IFC import 422
Ignore assemblies attached to materials 352
Ignore Next Story 118
Ignore Wall Dimensions 270
Image import 310
Images

importing 415
inserting in Worksheet View 310
scaling 311

Imperial Units xxxiv, 195
Import BIM File 421, 433
Import CAD File

Model View 287
Worksheet View 306

Import geometry from file 431
Import Scale, wall panel 164, 175
Importing

3D Studio files 431
BMP files 310, 415
CAD files in Model View 287
CAD files in Worksheet View 306
catalog content from a BIM file 421, 433
custom objects 420
door leafs 466
DWG files 431
DXF files 431
IFC file 422
JPG files 310, 415
objects 431
patterns 456
PDF in Model View 289
PDF in Worksheet View 308
photo board 417
project content from BIM file 422
project trace image 415
site data 184
text files 263, 266
TGA files 310, 415
views in Model View 285

Inches
in site boundary 195
working in xxxiv

Inclines 183
Include cut lengths 347
Include element in quantities 353
Include Elevation View 165, 171
Include First Post 115
Include Footings 215
Include in Framing

ceiling members 155

floor members 154
roof members 156

Include in Quantities 347
Include Last Post 115
Include Opening Trim 87, 91, 93
Include Path 389
Include Posts 115, 215
Include Railings 218
Include Schedule (wall panel diagrams) 166, 174
Include Sill 87
Include Very Top Plates, wall panel diagrams 165,

172
Include Walls 125
Included Angle 402
Infill configuration

customizing wall infill library 483
defining 484
defining in building locations 147
selecting for individual walls or wall types 148
tracing and replacing elements 440, 470

Info Panel
hiding 495
moving 496
resizing 495

Inquiring about elements 403
Insert Attribute 332
Insert Block 331, 333
Insert Block from File 331
Insert CAD File

Model View 287
Worksheet View 306

Insert Image 310
Insert Model View 301
Insert Panels 176
Insert SmartView 303
Insert View 285
Inserting

accessories 140
appliances 140
berms/trenches 182
blocks 331, 333
cabinets 137
CAD files in Model View 287
CAD files in Worksheet View 306
ceilings 105-107
columns 74
countertops 139
decks 213
doors 83
dormer 124

- 535 -



Index

edging 205
electrical elements 142
electronics 140
elements 41-42
equipment 141
exterior accessories 220
exterior furniture 220
exterior structures 219
fences 206
fills 204
floors 101-103
furniture 140
gates 208
grouped elements 447
heating elements 144
hills/valleys 181
HVAC elements 144
irrigation 204
kitchen 133
lights 141, 220
members 74-77
members in structural floor 99
mono footings 73
openings in walls 91
outlets 142
pads 190
paths 189
patio 190
photo board 418
plants 197
plants from Encyclopedia 203
plateaus 183
plumbing 144
posts 74
railings 113-114
ramps 109
retaining walls 191
roofs 117
skylights 125
slopes 183
SmartViews 303
sprinklers 204
stairs 109
strip footings 71
structural floors 97-98, 103
switches 142
views in Model View 285
walls 55, 57
windows 87
wiring 143

Insertion behavior of members 81

Insertion by Room
ceilings 107
floors 102
room regions 346

Insertion height 443
Insertion method

line-drawn elements 42
single-click elements 43

Insertion offset
doors 83
openings 91
windows 87

Insertion Offset
single elements 42

Insertion point 443
Insertion Reference Point, member 79
Insertion settings, wall panel 164, 175
Insertion snap 300-301
Inside arc direction 194
Inside Line 195
Inside Niche Back 92
Installation xxxi
Insulation, batt 283, 327
Insulation, rigid 284, 328
Intensity, light 465
Intensity, tree and billboard 384
Interactive Lighting

changing quality 498
disabling 498

Interference, stud 484
Interior dimensions 269
Interior wall surface 61
Interior Wall Tops to Roof 64
Interior Walls

dimension setting 268
dimension string 268

Intersect Planes 129
Intersection lookup table

customizing library 489
selecting in building locations 147

Intersection snap 300-301
Intersection tool filter 252, 254
Intersections

creating custom framing configurations 151
customizing the end condition library 489
editing framing configuration 151
filtering display in Framing Mode 252

Interval, contour 180
Invert Selection (layers) 297, 463
Invisible in 2D, walls 63
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IOR 451
Irrigation

editing spray range 204
inserting 204

iStruct export 424

J

Jack studs, defining 479
Jacks 142
Jamb definition 479
Javelin export 424
Join Dimension 275, 318
Join Polyline 320
Joining objects to polyline 320
Joining surfaces 129
Joist Direction 154-155
Joist Member 154-155
Joist Spacing 154-155
Joist spacing note 330
JPG export 422
JPG import 310, 415
Justification of leader 460
Justification of text 263, 265, 375

K

Keyboard Shortcuts
customizing 497

Keymark GS Software Suite export 424
King studs, defining 479
Kitchen Builder Wizard

custom configuration 135
using 133

Kitchen Configuration 135

L

Label Display (contours) 189
Label Text Style (contours) 189
Label Text Style (wall panels) 165, 174
Labels

controlling for terrain contour lines 189
customizing library 458
inserting 263

Ladder framing, gable 156
Lambert model, material properties 451
Lamps 141
Landing Gap (leader) 460
Landing segments 110
Landing Thickness 112

Landscape Lighting 220
Landscape orientation 410-411
Landscaping

decks 213
displaying/hiding elements 251
edging 205
exterior accessories 220
exterior furniture 220
exterior structures 219
fences 206
fills 204
filtering elements for selection 253
gates 208
inserting a house template 219
lighting 220
paths 189
plants 197, 203
sprinklers 204

Latin plant names 199
Lattice, deck 216
Launch Startup Screen 497
Launch wizard when starting new project 53
Lawn edging 205
LAY export 424
Layers

about 296
assigning to objects 342
controlling ability to select objects 297, 299, 463
controlling display order priority 300
controlling visibility 297, 299, 463
controlling whether plotted 297, 299, 463
creating 296
deleting 298
deleting in current project 297
deleting in layers library 463
editing for elements 444
editing properties in current project 297
editing properties in layers library 463
editng priority 297
exporting from project to BIM file 426
importing project layers from BIM file 422
overriding settings 298
renaming in current project 297
renaming in layers library 463
selecting to draw on 296
setting current 296
transferring objects between 298

Layout
ramps 112
stairs 110
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Leader
changing style in Model View 266
changing style in Worksheet View 314
updating dimension style globally 267

Leader gap 460
Leader justification 460
Leader position 460
Leader text 267
Leader with text 266, 313
Leaf Depth 86
Leaf, cabinet 138
Leaf, door 86, 465-467
Learning the program xxxvi
Left Elevation 241
Left Interior Side 67
Left Interior Side (wall) 68
Length reporting, member 356-357, 361
Length text style 195
Length, measuring 340, 402
Length, site boundary edges 193
Lengthen Arrow 129
Lengthen to Fence (members) 80
Lengthening

fences 207
members 80
members to cutting edge 80
members to plane 81
railings 116
strip footings 72
walls 62

Lengths, wall 400-401
Leveling walls 65
Levels, adding 57
Libraries

adding a group or subgroup 429
assembly 468
categories 472
customizing 449
deleting groups 430
dimension styles 459
door leafs 465
exporting to a BIM file 425
head/sill/jamb 478
intersection lookup table 489
labels 458
light source 464
line styles 461
line weights 463
linetypes 462
material filters 455

material usages 454
materials 450
moving subgroups to the root 429
pattern 456
phases 471
profiles 474
renaming groups 430
text styles 459
units of measure 473
usages 471
wall end condition 489
wall infill 483
wall opening span table 477

Library Manager 449
Lifetime (plants) 200
Light posts 220
Light Sources

customizing library 464
editing in light fixtures 141
specifying path to directory 465
turning on/off 142

Light switches 142
Lighting conditions 378, 385
Lights

adjusting for 3D Real View 385
changing quality of interactive lighting 498
disabling interactive lighting 498
editing light source 141
inserting 141, 220
snap options 141
turning on/off 142

Lights directory 465
Lightscape export 423
Line Styles

2D headers 93
customizing library 461
default for details 342
default for drafting objects 341
default for electrical wiring 144
default for hatched polygons 342
default for revision clouds 341
defining for revision clouds 283, 340
defining in schedules 375
editing for drafting objects in Worksheet

View 340
editing for polygons in Model View 282
editing for polygons in Worksheet View 325
editing in site boundary 195
editing wiring 143
selecting for terrain 181
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Line types
customizing library 462
editing for elements 444
editing for hatching 327
editing for layers in current project 297
editing for layers in layers library 463
editing in line styles 461
overriding layer line types 298

Line weights
customizing 463
editing for elements 444
editing for hatching 327
editing for layers in current project 297
editing for layers in layers library 463
editing in line styles 461
enabling/disabling 463
overriding layer line weights 298
printing 411-412

Line Work properties 444-445
Linear dimensions 271, 315
Linear Length 355-357, 361
Lines

assigning a layer to 342
breaking in Model View 278
converting to 3D building elements 283
disabling page margin lines 295
drawing in Model View 277
drawing in Worksheet View 320
editing style in Worksheet View 340
extending to other objects 277
trimming 277

Links 446
Lip C member 81
Lip Z member 81
Liquid finish 385
Lites

doors 85
windows 89

Load-bearing span table 150
Load-bearing, framing wall as 147
Load pattern 456
Load Theme 495
Loading a formula 370
Location data, adding to wall panel tags 162, 164,

167, 170
Location sorting in estimate 363
Location, global 378
Locations

adding 48
allowing a different current location per view win-

dow 49
checking the current location 49
defining 47
defining wall framing options 147
dimming 49
filtering from project estimate 352
filtering from view 251
grouping by in cut list 356
making one current 49
making selectable/non-selectable 253
querying an element's location 403

Lock Catalog to Editing 432-433
Locking items from filtering 250, 252
Locking layers 299
Log member 81
Logo import 310
Logos, manufacturer 457-458
Look Around 229, 237, 239-240
Look Through 232
Lot, building 191-192, 194
Loungers 220
Loveseats 140
Low E window panes 90
Low Gloss finish 385
Lower Exterior Face Bottom 63
Lower Point location 129
Lower Width 113
Lowering elements 223
Lowering the terrain 179
Lowlites 89
LP export 423
Lumens (light intensity) 465
Luxwood Quote Generator 371

M

Magnetic North 379
Mailboxes 220
Main wall assembly option 350
Maintain Aspect Ratio 310, 415, 419
Maintain Current Location Per View 49
Maintain Support Height (Move Edge) 120
Make All Non-Selectable Except 255
Make Continuous 115
Make magenta color transparent 453
Manuals xxxvi
Manufacturer content, importing 433
Manufacturer Logos 458
Manufacturers

adding to library 457
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assigning to elements 347
assigning to materials 451
assigning to purchased items 357
attaching to elements 457
attaching to materials 458
deleting from library 457
displaying logos on property pages 458
editing in library 457

Mapping, pattern 445
Mapping, texture 444, 453
Margins, page 295
Mark Text

elevations 243
sections 246

Marks
defining for schedules 375
displaying/hiding in drawing 277
removing from schedules 376
specifying for elements 276, 347
specifying settings 277
turning on/off 276

Masonry Section
assigning a layer to 342
drawing in Model View 284
drawing in Worksheet View 328
editing line style in Worksheet View 340
editing properties in Model View 285
editing properties in Worksheet View 329

Match Appearance 228
Match case (Find and Replace) 265, 312
Match Grid 398
Match Planes, roof 121
Match whole word (Find and Replace) 265, 312
Matching a member to a plane 77, 81
Material Filters

customizing library 455
using in materials library 454

Material history list 227-228
Material Usages

assigning to materials 451
customizing library 454
enforcing during material application 455

Materials
applying assemblies to 453
applying with Materials Paintbrush 226
attaching manufacturers 458
changing an element's appearance 444
customizing filters 455
customizing library 450
editing pricing 349, 453
editing properties 451

editing quantitative properties 347
editing texture properties 453
filtering in library 454
ignoring assemblies in estimate 352
matching across multiple elements 228
selecting for terrain 181
setting maximum size for history list 228
sorting in project estimate 363
surface properties 385
uploading to ERP system 371
viewing quantity report 351
viewing recently used 227

Materials Library
customizing 450
filtering 454

Materials List 351
Materials Paintbrush

sampling materials with eyedropper 227
setting maximum size for material history

list 228
undoing an application 227
using 226
viewing recently used materials 227
walls 67

Materials quote 371
Max Stringer Spacing 111
Max Z (site data) 186
Max. Post Spacing 208
Max. Riser Height 218
Maximize view window 262
Maximized view 239
Maximum Scrap Length 355, 361
Measure, unit xxxiv
Measuring

angles in Worksheet View 340
distances in Model View 402
distances in Worksheet View 340

Medicine cabinets 140
Member Schedule

converting framing to members 159
defining field layout 374
defining line styles 375
defining schedule marks 375
defining text styles 375
editing in wall panel diagrams 166, 173
generating 373
printing 374
removing schedule marks 376

Member Spacing Note
inserting 330

Member tag style (wall panels) 173
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Members
adjusting to a plane 81
arraying 81
breaking 80
breaking at other members 81
converting drafting objects to 283
converting framing to 159
creating custom profiles 475
editing dimensions 82
editing insertion point 79
editing shape 81
editing solid fill colors 60
editing timber frames 78
end conditions 82
extending to cutting edge 80
extending to plane 81
horizontal 76
inserting 74-76
inserting by matching a plane 77
inserting by picking points 76
inserting multiple simultaneously 77
inserting trusses 77
mitering 82
offsetting 81
preventing breaking 81
quantifying by total linear length 361
removing from structural floor 99
repeating 43
reporting in purchased lengths 356
rotating profile 80
selecting for wall framing 146
sloping 76
solid filling 59
specifying mark method 276
specifying mark settings 277
specifying purchased lengths 357
stretching 80
trimming to cutting edge 80
using optimized results in quantity report 363

Merging catalogs 421, 425, 433
Mesh Spacing, terrain 180
Mesh, terrain 184, 187-189
Meters

in site boundary 195
utility 141
working in xxxiv

Metric unit suppression xxxv
Metric Units xxxiv, 195
Microwaves 140
Middle mouse button assignment 240

Middle Rail Height 208-209
Midpoint snap 300-301
Millimeters

in site boundary 195
working in xxxiv

Min number of vertices per component 443
Min Z (site data) 186
Mirroring

elements in Model View 226
elements in Worksheet View 338

Mirrors 140
MiTek SAPPHIRE Structure export 424
Miter if Possible 82
Mitering intersections 151
Mitering members 82
Model View

background color 496
creating new window 258

Model view tab 261
Model view window 257-258
Model Views

inserting in Model View 285
inserting in Worksheet View 301
resizing 287

Modify Elements 45
Modify toolbars 494
Moldings 68
Mono Footings

attaching to columns 73
attaching to multiple columns simultaneously 73
editing size 73
editing type 73
inserting 73
inserting by picking points 73

Monochromatic renderings, creating 381
Monolithic foundation 57
Motion response, zoom and navigation 240-241
Mouse Controls

assigning action to middle button 240
zooming and navigating 239

Mouse response when zooming and
navigating 240-241

Mouse scroll zooming 238
Move Camera 233
Move Dimension Line 274
Move Down (view) 261
Move Edge

ceiling 107
deck 214
deck opening 217
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fill 205
floor 102
pad 191
roof 120
room region 346
surface 128

Move Framing Base Point (floor) 99
Move Group to Root 429
Move Target 234, 243
Move Text

room region 346
text with leader 267

Move Up (view) 261
Movies 386
Moving

animation control points 389
bearing line 98
by nudging 222
cameras 233
catalog panel 496
dimension line 274, 318
dimension text in Worksheet View 317
doors 83
elements 221
elements to other locations 225
elevation marks 242
floor division line 103
floor edges 101
info panel 496
leader 266
leader text 267, 314
objects in Worksheet View 335
objects to other layers 298
photo board 419
section marks 245
strip footings 72
target of 3D view 233
toolbars 495
view windows in View Manager 261
wall openings 92
walls 65
windows 88

Mulch 204
Mullions

door 86
window 90

Multiple Insert 289, 291, 308-309, 311, 416
Multiple member insertion 77
Multiple text insert 263, 266, 311
MXF export 424

N

Name generation
about 441
modifying formula for 441
using 441

Name, report template 362
Naming convention, wall panel 167, 170
Navigating with the arrow keys 240
Navigating with the mouse 239
Navigation Speed, adjusting 240-241
Navigator

hiding 230
using 229

Nearest snap 300-301
New Catalog 432
New elements 439, 446
New Line delimiter 367
New Project xxxii, xxxiii
New Project from Template xxxii, xxxii, xxxiii
New View 258
Newel Depth 116
Newel Spacing 116
Newel Style 116
Newel Width 116
NEWSTAR template (Constellation) 351
Niche 91-92
Niche Back Side 92
Node

adding to ceiling 108
adding to deck 214
adding to floor 103
adding to surface 128

Noise reduction, adjusting for renderings 383
Non-load-bearing span table 150
Non-printable area 295
Normal mapping, texture 453
Normal toolbar setting 493
North (True) 379
Nosing Depth 111
Nosing, counter 138-139
Nosing, stairs 218
Notation

controlling selectability 254
filtering from view 251

Notebook page (plants) 201
Notes

adding to drawing 263
adding to element properties 445
in Project Manager 427
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member spacing 330
Nudge Distance 222
Nudging elements 222
Number field 367
Number of Backups 407
Number of Courses 69
Number of panels across in multi-insertion 165,

175
Number of vertices in object 443
Numbering wall panels 168-169

O

Object Import Wizard 420
Object Properties

about 294
hiding panel 495
moving 496
resizing panel 495

Object Snap Settings 301
Object Snap Tracking 399
Object Snaps

overriding 301
selecting 301
turning on/off 301
using 398-399
using in Worksheet View 300
using snap tracking 399
using specific 301

OBJSNAP 301
Offset 68
Offset below roof surface 64
Offset from wall 67
Offset Member 81
Offset tool 337
Offset, insertion 42
Offsetting

members 81
objects in Worksheet View 337
walls from baseline 56

Older projects, opening xxxiii
Omitting locations/regions from area/perimeter cal-

culations 343
Online Help xxxvi
Opacity, material 451
Open 405
Open a Saved Project 405
Open Catalog 434
Open Current Link 446
Open Samples xxxiv

Open Template 351, 359
Open View 260
Open with Associated Editor 353
Opening

Catalogs 434
drawings 405
older projects xxxiii
quantity report 353
report templates 351, 359
sample projects xxxiv
view windows 260

Opening dimension separator 269
Opening dimensions 269
Opening header, ceilings 155
Opening header, floors 154
Opening header, roofs 156
Opening height, adding to dimensions 269
Opening span table 477
Opening symbols, window 91
Openings

2D appearance 93
adding height after width in dimensions 269
adding trim 67
creating a niche 91
cutting out bottom plate 485
dimension string 268
editing dynamic dimension settings 60
editing head/sill/jamb configuration 150
editing in surfaces 132
editing shape 93
editing size 92
editing span table selection for individual

walls 150
filtering display in Framing Mode 252
flipping in walls 92
inserting 91
inserting in ceilings 108
inserting in decks 216
inserting in floors 104
inserting in roofs 124
inserting in structural floors 99
inserting in surfaces 131
inserting to center 93
inserting to edge 94
moving in walls 92
removing from ceilings 108
removing from decks 217
removing from floors 104-105
removing from roofs 124
removing from surfaces 132
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removing trim from doors 87
removing trim from wall openings 93
removing trim from windows 91
resizing/reshaping in ceilings 108
resizing/reshaping in floors 104
specifying mark method 276
specifying mark settings 277
stretching 93
turning marks on/off 277

OPT export 423
Optimize Cut List 358, 360
Optimized results, using in quantity report 363
Optimizing a cut list 354
Orbiting 229, 237
Order of wall panels, editing 168-169
Orders, uploading to ERP 371
Orientation 442
Orientation (paper) 410-411
Ortho 398
Outlets

inserting automatically 142
inserting manually 142

Outline, terrain 181
Outside arc direction 194
Outside Line 195
Ovens 140
Overall Dimension 273, 317
Overall dimension string 268
Overall Height 110
Overhang 122, 215, 219
Overhang Drop 122
Override dimension text (Model View) 275
Override dimension text (Worksheet View) 319
Override snap 301
Override tile size 444
Overriding layer settings 298
Overview, 3D 231

P

Pad footings 73
Pads

disabling Hug Terrain option 191
editing solid fill colors 60
editing thickness 191
enabling/disabling solid fill 60
inserting 190
reshaping 191
resizing 191
solid filling 59
stretching 191

Page Margin Line display 295
Page Orientation in printing 411
Page size 410-411
Paint 67
Paintbrush, materials 226-227
Pan tool 229, 239
Pane type, window 90
Panel

hiding 495
moving 496
resizing 495

Paneled shutters 94
Paneling, wood 67
Panels

about 161
applying name changes to panels 171
assigning a layer to 342
breaking walls into specific lengths 66
customizing 163
defining dimension settings 165, 172
defining schedule settings 166
displaying tags 163
displaying tags in diagrams 165, 172
editing inserted panel diagrams 177
editing insertion scale 164, 175
editing insertion settings 164, 175
editing names 167, 170
editing numbering order 168
editing panel length 67
editing schedule settings 173
editing sort order 168-169
editing spacing 165, 175
editing tags 163
editing worksheet scale 164, 175
exporting to CSV 178
flipping view side 168
including elevation view 165, 171
including plan view 165, 172
including very top plates 165, 172
inserting onto worksheets 176
moving breaks 67
number across in multi-insertion 165, 175
previewing 166-167
re-ordering manually 169
regenerating 166, 177
selecting dimension style 165, 172-173
selecting text styles 165, 174
setting default view side 162, 164
setting up tagging 162
specifying default print settings 176
viewing 166
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viewing properties of individual panels 167
Panning the view 229, 239-240
Panoramic View, rendering 381
Paper Shadow 295
Paper Size 410-411
Part Number 347, 357

exporting for all elements to text file 349
Partially Reflective 385
Parts

as assemblies 350, 468
tracing and replacing 440, 470

Paste (Model View) 225
Path lights 220
Path Order, animation 389
Paths

changing order in animation 389
choosing for animations 389
deleting for animations 394
drawing for animations 386
editing size 190
editing solid fill colors 60
enabling/disabling solid fill 60
inserting 189
solid filling 59
stretching 190

Patio chairs 220
Patio tables 220
Patio umbrellas 220
Patios 190
Patterned display mode 247, 445
Patterns

applying with Boundary Hatch 326
customizing library 456
defining for revision clouds in Model View 283,

340
editing 456
editing for polygons in Model View 282
editing for polygons in Worksheet View 325
importing 456
resetting 456
selecting for elements 445

PDF
converting to image for faster import 290
importing in Model View 289
importing in Worksheet View 308
printing to 413

Peg style 195
Peg text style 195
Percentage of simplification 443
Perimeter, building 343

Perimeter, room 344
Perpendicular snap 300-301
Perspective view 231
Phase Library, customizing 471
Phases

assigning to ceiling framing members 156
assigning to elements 347
assigning to floor framing members 100, 155
assigning to purchased items 357
assigning to roof framing members 157-158
customizing phases library 471
defining in end condition configurations 490
defining in head/sill/jamb tables 479
defining in wall infill configurations 484
exporting for all elements to text file 349

Phone Numbers 427
Phong model, material properties 451
Photo Board

changing to rotating 419
changing to stationary 419
deleting 420
editing size 419
importing 417
inserting from catalog 418
making portions transparent 420
moving 419
raising/lowering 419
rotating 419
saving to catalog 418

Photo copiers 140
Pick and drag 42
Pick Items to Hide 254
Pick Items to Make Non-Selectable 254
Pick Points 42
Pickbox 295
Picnic tables 220
Picture import 415, 417
Pictures 140
Pier footings 73
Piers 74
Pivot door 85
Pixel Search Distance 398
Place New Camera 232
Placement on Paper 410-411
Plan import 287, 289, 306, 308, 415
Plan insertion 301
Plan trace 417
Plan View

including in wall panel diagrams 165, 172
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viewing 2D Designer's View 231
viewing 2D Plan 229-230

Plant Care Calendar 201
Plant Encyclopedia

about 199
accessing 199
adding plants to catalog from 204
care calendar 201
diseases page 202
inserting plants from 203
main page 199
notebook page 201
picture page 201
plant filter 202
searching for a plant 199
selecting a plant to view 199
viewing plant information 200
world map page 201

Plant Filter (encyclopedia) 202
Plant Growth Over Time 198
Plant Season 379
Plant Seasonal Change 198
Planters 220
Planting Age 198
Plants

adding to catalog from Encyclopedia 204
care calendar 201
changing age 198
diseases 202
editing 2D appearance 197
Encyclopedia 199
forcing custom size 198
growth over time 198
height and spread 200
inserting 197
inserting from Encyclopedia 203
life expectancy 200
lighting preference 200
pictures 201
places of origin 201
season change 198
season color diagram 200
soil preference 200
temperature preference 200
type and needs 200
usages 200
viewing information about 200
views in Encyclopedia 200
water requirements 200
zone requirements 200

Plaster 61

Plateaus
editing the height 183
editing the peak shape 183
inserting 183
reshaping 183
stretching 183

Plates 140
Plates, top and bottom 484
Play gyms 219
Play Sound 395
Plot control, layer 299
Plotter selection 410-411
Plotting 411
Plumb fascia 123, 131
Plumb member ends 82
Plumb soffit 123, 131
Plumbing

in BathroomWizard configuration 137
inserting 144

Pocket door 85
Point light 465
Pointer Tool 43
Polar Array 336
Polar Coordinate System 401
Polygon Consolidation, enabling/disabling 303
Polygon Hatch

assigning a layer to 342
assigning default line style and pattern 342
drawing in Model View 282
drawing in Worksheet View 324
editing hatch pattern in Model View 282
editing hatch pattern in Worksheet View 325
editing hatch pattern line properties 325
editing line style in Worksheet View 340
specifying default settings 341

Polygons
assigning a layer to 342
assigning default line style and pattern 342
converting to 3D building elements 283
drawing equal-sided polygons in Worksheet

View 324
drawing hatched polygons in Worksheet

View 324
drawing in Model View 282
editing hatch pattern in Model View 282
editing hatch pattern in Worksheet View 325
editing hatch pattern line properties in Work-

sheet View 325
editing line style in Worksheet View 340
editing style of boundary line in Model View 282
specifying default settings 341
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Polylines
curving 321
decurving 321
drawing 320
exporting to profile library 476
joining objects to 320

Ponds 204
Pools, swimming 219
Portable catalog content 425
Portal Frames

editing properties 78
inserting 77
quantifying each member 347

Portrait orientation 410-411
POS integration 371
Position Offset 110, 112
Post Depth 115
Post edging 205
Post Extension 208
Post Height 115
Post Offset 116
Post Position 115
Post Rotation 115, 208
Post Spacing 115
Post Style 115
Post Width 115, 208
Posts 74, 215
Postscript file, printing to 410
Power mills 220
Power, sky settings 235
Pre-defined labels 263
Precision field 367
Precision in estimate 366
Precision of angles xxxv, 461
Precision of measure xxxiv
Predefined texture mapping 444
Prefix, wall panel tag 162, 164, 167, 170
Presentation Mode 235
Preventing editing on layers 299
Preview cut list 353
Preview, element 441
Preview, print 411
Preview, turning off in Print dialog 411, 413
Previewing

animations 388
Price quote 371
Prices

applying to finish materials 453
setting for elements 347, 349

setting for purchased items 357
Print All 411
Print all colors as black 410, 412
Print Area 411
Print Display 411
Print Line Weights 412
Print margins 295
Print Preview 411
Print Scale 411-412
Print Setup, wall panels 176
Print Tiling 413
Print to File 410, 413
Print to Scale 411-413
Print Window 411
Printer selection 410-411
Printing

across multiple sheets 413
batch printing 414
controlling plotting of layers 299
cut list 356
defining a view's print properties 409
drawings 411
line weights 411
quantity report 352
schedules 374
to a file 413
to a PDF file 413
vector printing 415
vector vs. raster 414

Priority, layer 297, 300
PrioSoft Template 351
Produce Cut List 358
Product quote 371
ProEst Quantity Template 351
Profile Rotation, member 80
Profiles

applying to trim 68
creating custom 475
creating from polylines 476
customizing library 474
deleting from library 474
editing 476
selecting for columns 74
selecting for members 81

Program activation xxxi
Project Estimate

closing 353
creating new report template 358
disabling cut list generation 358
editing element entries 366
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editing headers/footers 365
editing quantitative properties of elements 347
editing report template 359
excluding elements from 353
filtering elements from 364
filtering locations from 352
ignoring assemblies attached to materials 352
opening quantity report 353
pricing 349
printing 352
printing cut list 356
replacing elements with assemblies 351
report template properties 360
saving quantity report 352
selecting report templates 351
sort order of materials 363
specifying how information is reported 364
using optimized results for members 363
viewing quantity report 351

Project Information 427
Project Manager

accessing 427
keeping track of revisions 427
specifying project information 427

Project Trace Image
deleting 417
displaying/hiding 417
importing 415
resizing 416
tracing 417

Projecting studs into plates 484
Projection Plane Distance From Camera 247
Projections dimension string 268
Projects

closing 409
exporting content to BIM file 426
importing content from BIM file 422
opening 405
opening older xxxiii
repairing 406
saving 406
sharing 406
starting new xxxii
starting new from specific template xxxii
starting new from templates xxxiii
starting without using templates xxxiii
viewing samples xxxiv

Projects Directory 407
Prompt for Template xxxiii
Properties

adding notes 445

cabinets 138
catalogs 434
columns 74
corner details 69
countertops 139
deck stairs 217-218
decks 215-216
doors 85-86
edging 206
elements 437, 439, 442-443
elevation 243
fences 207
floors 103
gates 209
insertion point 443
irrigation 204
lights 141
line objects 340
members 81
mono footings 73
pads 191
paths 190
photo board 419
plants 197-198
railings 115
ramps 112
report templates 360
roofs 118-119, 122-123
section 246
shutters 94
site boundary 193
skylights 125
slabs 191
snap edge 443
stairs 110-112
strip footings 72
structural floor 99
text 264
text with leader 266
wall openings 92-93
wall panel 167
walls 62, 67
windows 88-90
working with Property pages 441

Property lines 191-192
Purchased member lengths 356-357

optimizing in quantity report 363
Purging

unreferenced blocks 332
unreferenced SmartViews 306

PVC lawn edging 205
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Q

Quadrant snap 300-301
Quality (print) 411
Quality Level, render 382
Quantify each Member (timber frame) 347
Quantitative data, for elements 347
Quantitative data, for purchased member

lengths 356-357
Quantity 349
Quantity report

editing element entries 366
editing headers/footers 365
editing pricing 349
editing the quantitative properties of

elements 347
excluding elements from 353
filtering elements 364
filtering locations 352
ignoring assemblies attached to materials 352
opening in associated editor 353
printing 352
replacing elements with assemblies 351
saving 352
selecting template 351
sort order of materials 363
specifying how information is reported 364
using optimized results for members 363
viewing 351

Query Element/Location 403
Quick Start Guide xxxvi
Quoins 69
Quote

generating 371
Quote Generator template (for estimates) 351

R

Radios 140
Radius 402
Radius, arc 279, 322
Rafters 123, 156
Rafters, portal frame 77
Rail Depth 208-209
Rail edging 205
Railing on both sides 218
Railing on left side 218
Railing on right side 218
Railing on Stair Center 114
Railing on Stair Left 113
Railing on Stair Right 114

Railings
controlling on deck stairs 218
deck 216
displaying on decks 216
editing properties 115
horizontal 114
lengthening 116
on both sides of stairs 113
on stair center 114
on stair left 113
on stair right 114
on stairs automatically 113
parts 115
removing from deck stairs 218
repeating 43
shortening 116
stretching 116

Railings by Picking Points 114
Railings on Stairs Automatically 113
Raise Exterior Face Top 63
Raising elements 223
Raising the terrain 179
Raked fascia 123, 131
Raked soffit 123, 131
Ramps

editing general properties 112
editing layout 112
inserting 109

Ranges 140
Raster printing 414-415
Raytracing

3D RealView 379
animation 394

Re-ordering views 261
Re-ordering wall panels manually 169
Realistic Representation mode 247
Realtime zoom 229, 238
Rear Elevation 241
Recently used file list 405
Recently used materials list 227
Recess, wall 91
Recessed lighting 141
Recording animation 391
Records

accessing 364
adding fields 370
defining formulas 368
deleting fields from 371
editing fields 367
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Rectangles
assigning a layer to 342
converting to 3D building elements 283
drawing in Model View 281
drawing in Worksheet View 325
editing line style in Worksheet View 340

Rectangular Array 225, 336
Recycling boxes 141
Redefine SmartView 305
Redo 221
Reference angle method 191, 195
Reference Point 401
Reference Point, member insertion 79
Reflection settings, material 451
Reflections, enabling 235
Refrigerators 140
Regenerating wall panels 166, 177
Regions, room 346
Registering the program xxxi
Remove Control Point 389
Remove Member from Structural Floor 99
Remove Opening

ceiling 108
deck 217
floor 105
roof 124
surface 132

Remove Sound 395-396
Remove Sound Node 390
Removing

assemblies from elements 350
bearing line 98
elements 228
members from structural floor 99

Rename layer 297, 463
Renaming

groups in catalogs and libraries 430
groups in View Manager 258
openings automatically after stretching 93
view windows 259

Render Panoramic View 381
Render Quality 382
Rendered display mode 247
Rendered Outline display mode 247
Rendering

3D RealView 379
about 377
adjusting brightness 380-382
adjusting burn 380, 382
adjusting intensity of trees and billboards 384

adjusting lighting 385
adjusting lights 385
adjusting noise reduction level 383
allowing background brightness adjustment 384
checking system graphics 498
creating grayscale output 381
editing surface properties of materials 385
forcing wall sides to be exterior 63
Panoramic View 381
saving 381
selecting quality level 382
setting global location 378
setting plant season 379
setting the lighting 378
setting viewpoint 378
troubleshooting 385
using antialiasing 383
using background texture as light source 384

Repair Project 406
Repeat 43
Repeat Animation During Preview 388
Repeat Insertion 43
Replace element with assemblies in quantities 351
Replace tool 226
Replace with Assemblies 347
Replacing

elements 226
elements in assemblies 440, 470
elements with assemblies 351
text in Model View 265
text in Worksheet View 312

Report only total linear length 355-356
Report Templates

controlling display of currency symbol 362
copying 359
creating 358
deleting 360
disabling cut list generation 358
editing 359
editing file extension 362
editing name 362
opening 351, 359
properties 360
selecting 351
sort order of materials 363
specifying how information is reported 364

Reports
cut list 353
filtering elements from 364
quantity report 351
quote 371
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uploading to ERP 371
REScheck Export 376
Reset Camera 238
Reset pattern 456
Reset Terrain 189
Reset text position 318
Reshaping

ceiling openings 108
ceilings 107-108
deck openings 217
decks 214
fills 205
floor openings 104
floors 102
Floors 103
plateaus 183
roofs 121
slabs 191
wiring 143

Resize Image 416
Resizing

catalog panel 495
ceiling openings 108
ceilings 107
deck openings 217
fills 205
floor openings 104
floors 102
information panel 495
model view images 287
project trace images 416
slabs 191
wall layout 60

Resolution, animation 393
Restarting line-drawn elements 43
Restore Down 262
Retail sales quote 371
Retaining Walls

applying materials 67
converting drafting objects to 283
drawing 191
editing width 62
extending below terrain 63
making invisible in 2D 63

Returns, air 144
Reverse Starter Course 69
Revision Clouds

assigning a layer to 342
defining settings 283, 340
drawing in Model View 282

drawing in Worksheet View 325
selecting default line style 341

Revision Control 427
Ridge board 156
Ridge surface edge definition 130
Right-click menus 45
Right-hand vs left-hand door definition 84
Right angles 398
Right Elevation 241
Right Interior Side 67
Right Interior Side (wall) 68
Rigid Insulation

assigning a layer to 342
drawing in Model View 284
drawing in Worksheet View 328
editing line style in Worksheet View 340

Rim Joist 154-155
Riser Angle 111
Riser Height 110, 217
Riser Maximum 110
Risers 218
Roller door 85
Roof Accessories

inserting 126
Roof by Perimeter 117
Roof by Picking Points 117
Roof Symbol

inserting 329
Roof vents 126
Roofs

breaking 122
changing way lower-story roof is created 118
converting framing to members 159
converting hip to gable 118
converting to surfaces 124
creating gables mid-fascia 122
creating manually 127
defining material at gable ends 119
displaying walls beneath gable ends 119
editing frame details 123
editing height 123
editing shape 122
editing size properties 122
extending walls beneath gable ends 64
framing 156
inserting accessories 126
inserting by picking points 117
inserting openings in 124
inserting over perimeter walls 117
inserting truss profiles 158
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matching planes 121
removing openings from 124
reshaping 121
selecting for editing 118
stretching 120-121
surface edge properties 130

Room area 344
Room dimensions 274
Room Division 103

assigning a layer to 342
Room perimeter 344
Room Region by Room 344
Room Region Schedule 374
Room Regions

assigning a layer to 342
defining by picking points 344
defining by room 344
defining extents of room regions to be inserted

in rooms 346
editing properties 346
generating schedule 374
moving text 346
reshaping 346
resizing 346

Room volume 344
Rotating

elements 223, 442
member profiles 80
objects in Worksheet View 335
photo board 419
surface arrow 129
using the Commander 402
walls 65

Rules for cut list 361

S

Saddle situations 118
Sales quote 371
Sample projects xxxiv
Sampling materials with eyedropper 227
Sandboxes 219
SAPPHIRE Structure export 424
Sash, door 86
Sash, skylight 125
Sash, window 90
Satellite dishes 141
Saturation, sky settings 235
Save as grayscale 381
Save Catalog 434
Save Catalog As 434

Save Element to Catalog 418, 430
Save indivdual frames to disc 392
Save location, projects 407
Save Theme 494
Save time (min) 406
Saving

3D RealView renderings 381
animation frames individually 392
animations 391-392
automatically 406
backups 407
catalog content to a BIM file 425
catalogs 434
default save location for projects 407
elements in drawing to catalog 430
formulas 370
photo board to catalog 418
project content to BIM file 426
project estimate 352
projects 406
projects as templates 407
quantity report 352
renderings 381
to 3DS (3D Studio) file 423
to BMP file 422
to DWG file 423
to DXF file 423
to JPG file 422
to LP (Lightscape) file 423
to OPT (Art*lantis) file 423
to TGA file 422
to WRL (VRML) file 423
toolbar color themes 494

Saw Cut Allowance 355, 361
Scale, CAD image 288, 307
Scale, imported image 310
Scale, pattern 456
Scale, PDF 290, 309
Scale, print 411-412
Scale, project trace image 415
Scale, view 258, 411
Scale, wall panel 164, 175
Scale, worksheets with wall panels 164, 175
Scaling

blocks 331
dimension geometry 319
dimension values 320
images 311
leader arrows 314
objects in Worksheet View 337
project trace image 416
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Scanned plan import 415
Scene Properties 235
Schedule Marks

defining 375
removing 376

Schedule Text Style (wall panels) 165, 174
Schedules

assigning a layer to 342
defining field layout 374
defining line styles 375
defining marks 375
defining text styles 375
door 372
editing settings in wall panel diagrams 173
in wall panel diagrams 165-166, 174
member 373
printing 374
removing schedule marks 376
room region 374
window 373

Scrap length, maximum 355, 361
Scrapped items, showing in cut list 356, 361
Screen tip display 44
Scroll bars 496
Scroll wheel mouse, zooming with 238
Scroll wheel, assigning action to 240
Scrolling in drawing area xxxviii
Search up (Find and Replace) 265, 312
Searching

in Replace dialog 226
in the Element Manager 438

Season Change 198
Season Color Diagram 200
Season, setting 379
Seasonal Change, plants 198
Seat (roof) 123
Section Marks

moving 245
turning on and off 244

Section Properties 246
Section View 303

changing depth 245
changing viewpoint 245
creating 244
deleting 246
detailing 246
displaying 244
editing properties 246
inserting in Worksheet View 301

missing or extra lines in inserted
SmartViews 303

Section, masonry 284, 328
Section, wood 284, 328
Select All 44, 252-253, 334
Select All Similar 44
Select elements on current location only while in

plan view 44
Select None 252-253
Select Previous 44, 334
Select Profile

column 74
member 81

Select/Edit 43
Selecting

deselecting elements 44
elements 43
elements on all locations in 2D 44
floors 43
Make All Non-Selectable Except 255
objects in Worksheet View 334
Pick Items to Make Non-Selectable 254
roofs 118

Selection control on layers 299
Selection Filter

about 252
building locations 253
elements on locations 252
elements on terrain 253
filtering Framing Mode components 254
Make All Non-Selectable Except 255
notation objects 254
Pick Items to Make Non-Selectable 254

Selection mode 43
Selection preview 44
Semi Gloss finish 385
Sensors 142
Separator, opening dimensions 269
Set All Active 260
Set All Inactive 260
Set Color 297, 463
Set Current (layer) 296
Set Current (view window) 261
Set Decking Direction 214
Set Line Type 297, 463
Set Line Weight 297, 463
Setbacks 194
Settings

polygon hatch 341
revision cloud 283, 340
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Shape, column 74
Shape, door 85
Shape, member 81
Shape, sidelite/highlite 86
Sharing

catalog content 425
project content 426
projects 406

Shed Builder Wizard
custom configuration 211
using 209

Shed Configuration 211
Shed dormer 124
Sheds

building 209
editing 211
inserting pre-made 219

Sheet size 410-411
Shelves, book 140
Shelves, in cabinets 138
SHGC, window 90
Shift key to disable Ortho 398
Shiny finish 385
Shortcut keys 497
Shortcut menus 45
Shortcuts for commands 497
Shortening

members 80
members to cutting edge 80
railings 116
strip footings 72
walls 62

Show Backsplash 138
Show Boundary (terrain) 181
Show Contours (terrain) 180
Show Coordinate Icon 400
Show Counter 138
Show Cut Lines 112
Show Handle 139
Show Labels (terrain contours) 189
Show Line Weights 463
Show Nosing 138
Show Riser 110
Show Scrapped Items, in cut list 356, 361
Show Shelves 139
Show Skipped Items, in cut list 356, 361
Show Trunk in Plan 197
Show View Contents 411, 413
Shower curtains 140
Showers 144

Shrubs 197, 203
Shutters

editing 94
inserting 94

Side Offset 116
Sidelites

doors 85
window 89
windows 89

Sidewalks 189
Sill definition 479
Sills 67

controlling display on garage doors 87
Simplify 443
Simpson Component Solutions export 424
Single Insertion Only 43
Sinks

inserting 144
Site Boundary

assigning a layer to 342
bearing method 195
clipping terrain to 194
creating with Angle Bearing Method 192
creating with Reference Angle Method 191
curving edges 194
defining setback distances 194
editing angles 193
editing edge lengths 193
editing line styles 195
editing peg style 195
editing text styles 195
stretching 193
units of measure 195

Site data, importing 184
Size from encyclopedia 198
Size of animation 393
Size of elements 442
Size of terrain 179
Size, door 85
Sketchfab Export 425
SketchUp export 423
SketchUp import 420, 431, 466
Skipped items, showing in cut list 356, 361
Skirting

changing material 216
controlling display 216

SKP export 423
SKP import 420, 431, 466
Sky settings 235
Skylight noise reduction 383
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Skylights
editing properties 125
inserting 125

Slab on Grade 57
Slabs

editing thickness 191
inserting 190
reshaping 191
resizing 191
stretching 191

Sliding door 85
Slope direction 129
Slope symbol 329
Slope Type 123
Slope Value 122
Slope, ramp 112
Slope, surface 128
Slopes

creating 183
editing angle 184
editing height 184
stretching 184

Sloping members 76, 81
Sloping walls 64
SmartViews 303

deleting unreferenced SmartViews 306
editing 304
enabling/disabling polygon consolidation when

inserting 303
handling missing or extra lines or faces 303
inserting 301
inserting saved 303
redefining settings 305
updating globally with changes to your

model 305
updating with changes to the model 305

Smoke detectors 142
Smoothing, TIN mesh 188
Snap Angle 399
Snap Edge 443
Snap grid 398
Snap light to 141
Snap Overrides 301
Snap tracking 399
Snapping to objects 300, 398-399
Snaps, object 300-301, 398-399
Sofas 140
Soffit 131
Software activation xxxi

Soil beds 204
Soil preference 200
Solar Heat Gain Coefficient 90
Solar panels 126
Solar tubes 126
Solid Fill

disabling for individual elements 60
editing colors 60
turning on 59

Solution Type 118
Sort order, in project estimate 360, 363
Sort order, wall panels 168-169
Sounds

adding to animation 390
attaching to catalog elements 395
attaching to elements in drawing 395
playing 395
removing from animation 390
removing from catalog elements 396
removing from elements 395
selecting default directory 396

Sounds Directory 396
Spacebar as Enter key 43
Spacer for filler cabinets 138
Spacing along Beam 215
Spacing note, member 330
Spacing, wall panel diagrams 165, 175
Span tables

customizing span table library 477
defining a table 477
defining in building locations 147
selecting for individual openings 150
selecting for individual walls 150

Specify Framing
ceilings 155
floors 154
roofs 123, 156

Specify Target 387
Specular 385
Specular settings, material 451
Speed improvement 44
Speed, animation 392
Speed, navigation 240-241
Speed, zoom 240-241
Sphere mapping, material 451
Spinning 229, 237, 240
Spline 321
Spline leader 313
Split Dimension 275, 318
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Splitting floors 103
Spot level points

adding to TIN mesh 187
editing elevation 188
importing 184

Spot light 465
Spot light cone angle 465
Spray, sprinkler 204
Sprinklers

editing spray range 204
inserting 204

Square Footage, building 343
Square Footage, room 344
Square member ends 82
Stairs

adding to deck 217
editing cut line 112
editing details 111
editing layout 110
editing size 110
inserting 109
landing segments 110
parts 109
segments 110

Standard mapping, texture 453
Standard Report Form 351
Start a New Project xxxii, xxxiii
Start Number, wall panels 162, 164, 168
Starting elevation, contours 180
Starting the program xxxi
Startup screen

disabling 497
enabling 497
viewing 497

Stationary photo board 417, 419
Status Bar 496
Step Back

Materials Paintbrush 227
roof by picking points 118
walls by baseline 57

Stepped footings 71
Stepping walls 64
Stereo Effect 247
Stereo Vision

about 247
adjusting settings 247
turning on/off 247

Stereos 140
Stereoscopic VR viewing 235, 499

Stories
adding 57
creating locations for 48

Stoves 140
Stretch Openings option 93
Stretching

bearing line 98
berms/trenches 182
ceiling openings 108
ceilings 107-108
decks 214
dimensions in Model View 274
dimensions in Worksheet View 318
doors 93
edging 206
fences 207
fills 205
floor edges 101
floor openings 104
floors 102
Floors 103
leader 266
members 80
model view images 287
objects in Worksheet View 337
openings 93
path elements 190
plateaus 183
railings 116
roofs 120-121
room regions 346
site boundary 193
slabs 191
slopes 184
strip footings 72
surfaces 128
walls 60, 62
windows 93
wiring 143

String 365
String field 367
Stringer Side Offset 111
Stringer Thickness 111
Stringer Width 111
Stringers 218
Strip Footings

breaking 72
converting drafting objects to 283
editing size 72
editing type 72
inserting 71
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lengthening/shortening 72
moving/stretching 72
repeating 43

Strip Footings Attached to Walls 71
Strip Footings by Picking Points 71
Structural Floor

adding members 99
converting finish floor to 103
cutting opening in 99
editing properties 99
inserting a bearing line 98
inserting by perimeter 97-98
inserting by room 97
moving framing base point 99
moving/stretching a bearing line 98
removing a bearing line 98
removing members 99

Structures, exterior 219
Stud interference 484
Stud spacing 148, 484
Studs

defining in end condition configuration 490
defining in infill configuration 484
defining in wall framing 148
dimensioning to 269
projecting into plates 484
selecting member type 146

Subgroups
adding to catalogs and libraries 429
moving to root 429

Subtracting locations/regions from area/perimeter
calculations 343

Suffix, wall panel tag 162, 164, 167, 170
Sun light, enabling/disabling 235
Sun Power 235
Sun Shadows, enabling 235
Supplier 347, 357
Support height above main roof 124
Support Height, roof surface 123
Support, technical xxxvii
Suppress display of metric units xxxv, xxxv
Suppress trailing zeros xxxv, xxxv
Surface Properties 385, 451
Surfaces

adding nodes to 128
converting framing to members 159
converting roofs to 124
creating 127
curving 131
cutting openings in 131

defining for walls 61
dropping a wall's exterior surface 63
editing arrow length 129
editing openings 132
editing roof edge details 131
editing slope 128
editing solid fill colors 60
editing thickness 131
editing up-slope direction 129
Intersect Planes 129
joining together 129
removing openings from 132
reshaping 128
resizing 128
roof surface edge properties 130
stretching 128

Survey 191-192
Survey data, importing 184
Swing

editing door swing properties 84
flipping door swing 84
flipping gate swing 209
window symbols 91

Swing Direction 84
Swing Type 84, 209
Swings 219
Switches 142
Symbols, window opening 91
System graphics, checking 498

T

T-Shape member 81
Tab-delimited fields 367
Tabbed toolbars 493
Tables 140
Tables, span 477
Tabs, view 261
Tag Elements with Schedule Mark 372-373, 376
Tag Text Style (wall panels) 165, 174
Tags

applying new settings to panels 171
displaying in wall panel diagrams 165, 172

Tags, schedule 375-376
Tags, wall panel 162-163, 167-170, 173
TakeOff Plus template 351
Tangent snap 300-301
Tape Measure 340, 402
Tapered member 81
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Target
changing height 234
moving 233
spinning around camera 229, 237

Target paths 387
Technical support xxxvii
Telephone service boxes 141
Telephones 140
Televisions 140
Temperature, color 465
Template element filter 360
Template houses 219
Templates

creating 407
creating thumbnails for 408
disabling use of on project startup xxxiii
prompting for at project startup xxxiii
setting directory 409
specifying descriptions for 408
starting new projects from a specific

template xxxii
starting new projects from templates xxxii, xxxiii

Templates (report)
controlling display of currency symbol 362
copying 359
creating 358
deleting 360
disabling cut list generation 358
editing 359
editing file extension 362
editing name 362
filtering elements from 364
opening 351, 359
properties 360
selecting for estimate 351
sort order of materials 363
specifying how information is reported 364

Templates (view filter)
applying 255
creating 255
editing 255

Temporary Files Directory 409
Tennis Courts 219
Terrain

adding spot points to TIN mesh 187
adjusting smoothness of TIN mesh

contours 188
assigning a layer to 342
clipping to site boundary 194
controlling display of contour labels 189
converting to TIN mesh 187

cutting around the building 180
defining base level 179
defining mesh spacing 180
defining size 179
displaying/hiding 251
displaying/hiding boundary 181
editing elevation of spot points 188
importing site data 184
resetting 189
selecting a line style 181
selecting a material 181
turning on/off 181

Terrain Base Level 186
Testing a formula 370
Text

adding in Model View 263
adding in Worksheet View 311
adding text with a leader in Model View 266
adding text with a leader in Worksheet View 313
assigning a layer to 342
changing the style in Model View 264
controlling display of contour labels 189
controlling quality through antialiasing 313
customizing labels library 458
customizing text style library 459
editing content 264
editing in default title block 306
editing in Worksheet View 312
editing justification 265
editing leader text 267
editing leader text in Worksheet View 314
finding and replacing in Model View 265
finding and replacing in Worksheet View 312
globally updating styles 265
moving dimension text 317
moving in room region 346
moving leader text in Model View 267
moving leader text in Worksheet View 314
resetting position in dimensions 318

Text Color 264, 494
Text file

exporting quantitative properties of
elements 349

Text Height 264
Text Position, resetting 318
Text Styles

adding 459
defining in schedules 375
deleting 459
editing 459
editing in drawing 264
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editing in site boundary 195
elevation marks 243
section marks 246
selecting for contour labels 189
selecting for wall panel diagrams 165, 174
specifying for text with leader 267
updating globally 265

Text with Leader 460
adding in Model View 266
adding in Worksheet View 313
editing leader style in Worksheet View 314
editing text in Model View 267
editing text in Worksheet View 314
editing text style in Model View 266
moving text in Model View 267
moving text in Worksheet View 314
scaling arrows 314
updating style globally 267

Texture intensity 453
Texture Mapping 444
Textures

applying to elements 226
applying to material 451
appropriate sizing for 453
cropped/cut-off 453
custom 453
editing mapping properties 453
from outside sources 453
selecting for terrain 181

Textures Directory 454
TGA export 422
TGA import 310, 415
Themes

loading toolbar color themes 495
saving toolbar color themes 494

Thermostats 142
Thickness

backsplash 138
counter 138
door leaf 86
floor 103
line 463
pads 191
paths 190
roof 122
surface 131

Three-dimensional viewing 229, 231
Thumbnail, creating for template 408
Tile Height 453
Tile Height/Width 444, 453

Tile Horizontally 453
Tile Open Views 261
Tile Vertically 453
Tile Width 453
Tiled printing 413
Tilt door 85
Tilt, light source 142
Tilting camera in animation 390
Timber Frames

editing properties 78
inserting 77
quantifying each member 347

Time of day, setting for a scene 235
TIN Mesh

adding spot level points to 187
adjusting smoothness of contours 188
controlling display of contour labels 189
converting terrain to 187
creating by importing spot level points 184
editing elevation of spot points 188
removing 189

TIN Smoothing 188
Title blocks

customizing default title block 306
deleting default title block 306
inserting in Model View 287
inserting in Worksheet View 306

Title blocks, wall panel diagrams 165, 175
Titles, project estimate 365
Toasters 140
Toe Depth 139
Toe Height 139
Toe Space 139
Toilets 144
Tolerance, in cut list 355, 361
Tool help xxxvii
Toolbar Areas 494
Toolbars

color of toolbar areas 494
customizing colors and effects 494
displaying 493
displaying in non-tabbed format 493
displaying in tabbed format 493
free-floating 493
hiding 493
loading a color theme 495
moving 495
saving color settings to a theme 494

Tooltip display 44
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Top Hat member 81
Top Plate 148, 484
Top Rail Height 208-209
Total linear length calculation 355-357, 361
Total Steps 110
Towel racks 140
Trace Element 440, 470
Trace image 415
Tracing a plan 417
Trailing zeros, suppressing xxxv
Trampolines 219
Transferring content between catalogs 421, 425,

433
Transferring objects to other layers 298
Transformer Box 141
Translate X 401
Translate Y 401
Transom

door 86
window 90

Transparency, in photo board 420
Transparency, in texures 453
Transparency, of material 385, 451
Trash cans 141
Trash Compactors 140
Tray ceilings 106
Tread Run 110, 218
Treads 218
Tree and billboard intensity 384
Trees 197, 203
Trellises 220
Trenches, creating 182
Triangulated Irregulated Network survey

mesh 184, 187-188
Trim

adding to walls 67
adding to windows and doors 67
applying profiles to 68
removing from doors 87
removing from wall openings 93
removing from window openings 91

Trim basepoint 68
Trimming

arcs 279
lines 277
members to cutting edge 80
objects to other objects 338

True North, calculating 379
Trunk Diameter 197

Truss Run
inserting 158

Trusses 123
editing properties 78
inserting members 77
inserting profiles under existing roof 158
quantifying each member separately 347

Tubs 144
Turbines 220
Turned studs 490
Tutor xxxvii
Tutorial xxxvi
Tutorials xxxvi
TXT export 349
TXT report template 351

U

U-Factor
adding to schedules 374
editing for a door 86
editing for a window 90

U-Section member 81
UDA Construction Office template 351
Undo 221
Undo material application 227
Uninstalling the program xxx
Unit field (report template) 366-367
Units of Measure

changing xxxiv
customizing library 473
exporting for all elements to text file 349
in dimensions 460-461
in report template 366-367
in site boundary 195
specifying for purchased items 357
specifying in element's Quantity properties 347
suppressing metric units xxxv
suppressing trailing zeros xxxv

Unlocking a catalog 433
Unreferenced blocks, deleting 332
Unreferenced SmartViews, deleting 306
Update SmartView 305
Update Smartviews (Global) 305
Update Style

dimension 276
text 265
text with leader 267

Updating wall panels 177
Upload to ERP 371
Upper Offset 113
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Upper Point location 129
Upper Width 113
Usage (plants) 200
Usages

assigning to ceiling framing members 156
assigning to elements 347
assigning to floor framing members 100, 155
assigning to purchased items 357
assigning to roof framing members 157
customizing material usages library 454
customizing usages library 471
defining in end condition configurations 490
defining in head/sill/jamb tables 479
defining in wall infill configurations 484
exporting for all elements to text file 349
grouping by in cut list 356

Usages library, customizing 471
Use Cut List Results in Report 363
Use encyclopedia object 204
Use No Template xxxiii
Use Optimized Results 360
Use physically accurate lighting 235
Use Space as Enter 43
Use Specific Template xxxii
Use texture as light source 384
Utility meters 141

V

Valley board 156
Valley surface edge definition 130
Value field (report template) 366
Value Scale 320
Value, field 365
Vanities

in Bathroom configuration 137
inserting 137

Varnished 385
Vaulted ceilings 107
VCRs 140
Vector Printing

about 414
disabling 415

Veneer Air Space 61
Veneer top/bottom extension 63
Veneer Width 61
Vents 144
Vents, roof 126
Vert. Distance 123
Vertical Separation 86, 90

Very Top Plate
defining in wall infill configuration 148, 484
including in wall panel diagrams 165, 172

Video Compression, animation 393
Videos xxxvi, 386
View Angle, 3D camera view 233-234
View Angle, animation 386
View Elevation 241-243
View Filter

controlling selectability of building locations 253
controlling selectability of notation objects 254
controlling selection of elements on

locations 252
controlling selection of landscape elements 253
creating a template 255
filtering building elements from view 250
filtering building locations from view 251
filtering Framing Mode components 252
filtering Framing Mode components for

selection 254
filtering landscape elements from view 251
filtering notation objects 251
filtering project trace images from view 417
filtering the display 249
filtering wall panel tags from view 163
selection filtering 252

View Filter Templates
applying 255
creating 255
editing 255

View import 285
View Manager

accessing 257
adding groups 257
collapsing groups 258
defining a view's print properties 409
deleting groups 258
expanding groups 258
re-ordering views 261
renaming groups 258
renaming views 259
setting current view window 261

View Project Estimate 353
View Properties 439
View Scale 258, 411
View Section 244
View side, wall panel 162, 164, 168
View Tabs 261
ViewWindows

allowing a different current location per
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window 49
cascading 262
closing 260
copying 259
creating 258
defining print properties 409
deleting 260
managing 257
opening 260
printing multiple 414
re-ordering in View Manager 261
renaming 259
restoring 262
returning to maximized view 262
setting current 261
switching between 261
switching to Worksheet View 293
tiling 261
turning tabs on 261

Viewing
2D Designer's Plan 231
2D Plan 229-230
3D Camera Views 229, 231
3D QuickView 231
changing the display mode 247
cut list 353
different locations per view window 49
dynamic cutaway views 246
in 3D 232
presentation mode 235
quantity report 353
startup screen 497
virtual reality 235
with the Navigator 229

Viewing field angle 234
Viewpoint 233
Views

inserting in Model View 285
resizing model view images 287
stretching model view images 287

Virtual Reality
specifying view type 235, 499
viewing in 235

Visibility, layer 299
Volleyball courts 219
Volume unit of measure xxxiv
Volume, room 344
VR app, generating panoramic views 381
VRML export 423

W

W-Shape member 81
Wainscoting 67
Walk Around 229, 236, 239-240
Walkthroughs 386
Walkways 189
Wall end conditions

customizing library 489
defining a configuration 490

Wall Framing
about 146
creating custom intersection configurations 151
editing framing rule for individual walls 149
editing head/sill/jamb configurations for indi-

vidual openings 150
editing infill for individual walls 148
editing intersection framing 151
editing span table selection for individual

walls 150
going into Framing Mode 148
making walls load-bearing or non-load-

bearing 147
selecting framing member 146

Wall Height 47, 62
Wall infill

customizing for individual walls 148
customizing infill library 483
defining 484
filtering display in Framing Mode 252
selecting in building locations 147

Wall Infill Tool filter 252, 254
Wall Opening Span Table 477
Wall Panels

about 161
applying name changes to panels 171
assigning a layer to 342
breaking walls into specific lengths 66
customizing 163
defining dimension settings 165, 172
defining schedule settings 166
displaying tags 163
displaying tags in diagrams 165, 172
editing content display 171
editing inserted panel diagrams 177
editing insertion scale 164, 175
editing insertion settings 164, 175
editing names 167, 170
editing numbering order 168
editing panel length 67
editing schedule settings 173
editing sort order 168-169
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editing spacing 165, 175
editing tags 163
editing worksheet scale 164, 175
exporting to CSV 178
flipping view side 168
including elevation view 165, 171
including plan view 165, 172
including very top plates 165, 172
inserting drawing borders 165, 175
inserting onto worksheets 176
moving breaks 67
number across in multi-insertion 165, 175
previewing 166-167
re-ordering manually 169
regenerating 166, 177
selecting dimension style 165, 172-173
selecting text styles 165, 174
setting default view side 162, 164
setting up tagging 162
specifying default print settings 176
viewing 166
viewing properties of individual panels 167

Wallpaper 67
Wallpaper borders 67
Walls

adding corner details 69
adding trim 67
applying materials to 67
applying paint 67
applying paneling 67
applying profiles to trim 68
applying wallpaper 67
attaching strip footings 71
breaking 66
breaking into specific lengths 66
breaking members at 81
composite 55, 61
converting drafting objects to 283
creating a niche 91
creating with Floor and Foundation Builder 57
creating with House Builder Wizard 51
curving 66
defining surfaces 61
deleting 67
disabling solid fill per wall 60
displaying at gable ends 119
dividing rooms without using walls 103
drawing 55
editing dynamic dimension settings 60
editing height 62
editing opening shape 93

editing opening size 92
editing solid fill colors 60
editing width 62
entering precise lengths 400-401
extending beneath gable ends 64
extending exterior face 63
flipping a niche 92
forcing sides to be exterior 63
inserting 57
inserting openings in 91
lengthening 62
lowering 63
making invisible in 2D 63
making level 65
making load-bearing or non-load-bearing 147
moving 65
moving breaks 67
moving openings 92
offsetting from baseline 56
raising 63
removing trim from door openings 87
removing trim from wall openings 93
removing trim from window openings 91
repeating 43
resizing wall layout 60
retaining 191
rotating 65
selecting framing member 146
shortening 62
sloping 64
solid filling 59
stepping 64
stretching 60, 62

Walls by Baseline 56
Washers 140
Washrooms, designing 136
Waste, stringer 111
Water 204
Water Heaters 144
Weather vanes 220
Weight, line 463
Weyerhaeuser Javelin export 424
Wheelchair access 109
Width field (report template) 366-367
Width, field 365
Width, wall 61-62
Wind chimes 220
Window (Print) 410
Window Heads 67
Window Height 88
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Window menu 261
Window Opening Symbols 91
Window Schedule

defining field layout 374
defining line styles 375
defining marks 375
defining text styles 375
generating 373
printing 374
removing schedule marks 376

Window Sill 479
Window Trim 67
WindowWidth 88
Windowing selection method 43, 334
Windows

adding height after width in dimensions 269
adding trim 67
attaching shutters 94
controlling opening symbols 91
displaying lites 89
editing details 90
editing dynamic dimension settings 60
editing lites 89
editing size properties 88
editing type 88
energy properties 90
flipping 88
inserting 87
inserting to center 93
inserting to edge 94
moving 88
removing trim from openings 91
specifying mark method 276
specifying mark settings 277
stretching 93
turning marks on/off 277
U-Factor 90

Wireframe display mode 247
Wiring

assigning a layer to 342
editing line style 143
inserting 143
reshaping 143
selecting default line style 144
stretching 143

Wizards
Bathroom Builder 136
Deck Builder 212
Door Leaf Import 466
Floor and Foundation Builder 57
House Builder 51

Kitchen Builder 133
Object Import 420
Photo Board 417
Shed Builder 209

Wood edging 205
Wood paneling 67
Wood Section

assigning a layer to 342
drawing in Model View 284
drawing in Worksheet View 328
editing line style in Worksheet View 340

Wood stoves 144
Work History 427
Worksheet Scale, wall panel 164, 175
Worksheet View

background color 496
controlling display of page margin lines 295
controlling display of paper shadow 295
creating new window 258
inserting CAD files 306
interface 294
switching to 293

Workspace colors 496
World Map page (plants) 201
WRL export 423

X

X Limit 397
X Origin 457
X Spacing 397-398
X, Y and Z coordinates 401
XLS template 351
XML export

to 20-20 Design 425
to CSD iStruct 424
to Weyerhaeuser Javelin 424

Y

Y Limit 397
Y Origin 457
Y Spacing 397-398

Z

Zenith 182
Zeros, suppressing in measurements xxxv
Zones of plants 200
Zoom In 238
Zoom Out 238
Zoom Previous 239
Zoom Realtime 229, 238-239
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Zoom Speed, adjusting 240-241
Zoom to Fit 239
ZoomWindow 238
Zooming with mouse buttons 239
Zooming with scroll wheel mouse 238
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